Visma Business Kunnskapsbase for Autoriserte forhandlere

Visma Business Kunnskapsbase

Visma Business Kunnskapsbase for Autoriserte forhandlere.

Dette er et verktøy for å søke i erfaring fra Visma Software Forhandlerservice og utvikling. Hjelpefilen er ment som et supplement til dokumentasjonen til Visma Business.

2007.04.20 (B43)


Hjelpevinduet

Introduksjon til hjelpen

Denne hjelpen er laget med Microsofts nyeste standard for hjelpefiler og andre elektroniske "bøker", HTML-hjelp. Hjelpen har kraftige søkefunksjoner og oppslagsmuligheter som raskt hjelper deg å finne det du søker etter.

Du kan åpne hjelpen inne i fra programmet på flere måter. Hvis du vil hente opp innholdsfortegnelsen, trykker du på menypunktet Hjelp/Innhold på nedtrekksmenyen i skjermbildet (den som starter med Fil Rediger, osv.).

Hvis du taster F1 eller Shift-F1 inne i programmet, vil du hente opp hjelpen på henholdsvis emnet man står på, eller feltet man står inne på. Se også nedtrekksmeny Hjelp/ for mer informasjon om hvordan hjelpen kan hentes

Hjelpevinduet

Når du åpner helpevinduet, er dette er delt inn i 3 deler, Innhold, Knapperad og side.

For å navigere og finne frem i hjelpen, kan du benytte Innholds-fortegnelsen, Stikkordregisteret og Søk.


Innholdsfortegnelse forklart

Innholdsfortegnelsen i hjelpen

Du kan bla deg gjennom innholdsfortegnelsen ved å:

  • klikke på fanen "Innhold"
  • klikke på boken du vil åpne
  • klikke på siden du vil lese

Dessuten fungerer navigasjonsknappene slik som beskrevet i Knapper.

Se også bruk av Stikkord og Søk


Stikkordregister i hjelpen

Stikkordregister

Stikkord er predefinerte ord som inneholder en kobling til en eller flere sider. Du kan bruke stikkordregistret på følgende måte:

  1. Klikk på fanen "Stikkord".
  2. Tast inn søkeord.
  3. Klikk på den siden du ønsker å se på.

Stikkordregisteret er mer nøyaktig enn Søk-funksjonen.

Se også bruk av Innhold og Søk


Søk i hjelpen

Søke i hjelpen

Søk i HTML-hjelp søker på alle forekomster av et eller flere begreper. Du kan søke på følgende måte:

  1. Klikk på fanen "Søk".
  2. Tast inn ett eller flere søke ord atskilt med mellomrom. Se søkemetoder nedenfor med mer informasjon.
  3. Klikk på den siden du ønsker å se på.

Søk-funksjonen søker på alle forekomster av ordet, det vil si den gir deg alle sider som inneholder søkeord(ene).

Se også bruk av stikkord.

Søkemetoder/avansert søk

Nederst i trefflisten for fritekstsøket finner du tre avkrysningsfelter som du kan bruke til avansert søk:

  • Kryss i feltet "Søk i tidligere resultater" hvis du vil foreta et nytt søk, med nye søkeord, bare på de sidene som finnes i trefflisten.
  • Kryss i feltet "Søk etter lignende ord" for å få treff også i ord som ligner søketeksten, for eksempel ulike bøyninger. Standardinnstillingen er at den er merket.
  • Kryss i "Søk bare i titler merker" hvis du vil søke bare i sidenes overskrifter, altså ikke i den løpende teksten.

Du kan dessuten søke etter uttrykk ved hjelp av anførselstegn, bruke jokertegn og bruke OR, NOT og NEAR, på samme måte som i en søkemotor på Internett.

Søke etter uttrykk

Hvis du skriver inn flere ord som søkeuttrykk, antar søket at du vil finne alle avsnitt som inneholder noen av ordene, men enkelte ganger vil du jo søke på nøyaktig det uttrykket du skriver inn. Da skal du begynne og avslutte med anførselstegn.

Eksempel: Hvis du skriver slett firma, finner søket alle avsnitt som inneholder enten slett, firma eller begge.

Hvis du i stedet skriver "slett firma", finner søket bare de avsnitt som inneholder hele uttrykket slett firma.

Søke med jokertegn

I søketeksten kan du bruke jokertegn på samme måte som i Windows-søk:
Stjerne (*) erstatter et valgfritt antall tegn på slutten av et ord.
Spørsmålstegn (?) erstatter ett tegn på angitt plass.

Eksempel: Regi* finner alle avsnitt som inneholder ord som begynner på Regi, uansett hvor mange tegn ordene inneholder, for eksempel Register, Registrere og Registrerte.

Åpne? finner alle avsnitt som inneholder ord som begynner på Åpne, og som inneholder ett tegn til, for eksempel Åpnes og Åpnet.

Søke med OR, NOT og NEAR

Du kan søke ved hjelp av OR, NOT og NEAR på samme måte som i en søkemotor på Internett.

Bruk OR mellom ord når du vil at noen av ordene skal være med.
Eksempel: "Slett OR bilag" finner alle avsnitt der enten slett, bilag eller begge to finnes.

Bruk NOT hvis det ene ordet skal være med, men ikke det andre.
Eksempel: "Slett NOT bilag" finner alle avsnitt der slett finnes og der bilag ikke finnes. Hvis begge ordene finnes i ett avsnitt, blir det ikke tatt med.

Bruk NEAR for to ord som skal finnes og som i tillegg skal finnes maksimalt ti ord fra hverandre.
Eksempel: "Slett NEAR bilag" finner alle avsnitt der både slett og bilag finnes, og der begge disse ordene finnes maksimalt ti ord fra hverandre. Avsnitt der begge disse ordene finnes, men står lengre fra hverandre, blir ikke tatt med.


Skrive ut hjelpen

Du kan skrive ut en eller flere sider fra hjelpen. Når du vil skrive ut, klikker du på "Skriv ut"-knappen. I dialogen som kommer fram, kan du velge å skrive ut valgt emne eller valgt emne og alle underliggende emner.


Knapper i hjelpen

Knappen skjuler vinduet som blant annet har innholdsfortegnelse.

Knappen viser hvor i innholdsfortegnelsen valgt side i hjelpen befinner seg. For eksempel hvis du slår opp i hjelpen via Shift-F1 og finner en side med informasjon på og du lurer på hvor denne siden befinner seg i innholdsfortegnelsen, trykker du på denne knappen og hjelpen vil vise deg hvor denne siden befinner seg. Eller hvis du har trykket på en link i et HTML-dokument, og vil vite hvor denne er lokalisert i innholdsfortegnelsen, trykker du på denne knappen.

Knappen henter forrige side du hadde oppe.

Knappen henter neste side i innholdsfortegnelsen.

Knappen går tilbake til siste brukte side.

Knappen går forover. Knappen er kun aktiv hvis bakover er benyttet.

Knappen går til første side i hjelpen.

Knappen skriver ut enten valgt emne eller valgt emne og alle underemner.


Visma Business Forhandlerservice

  • Det er 8 personer i Visma Business teamet
  • Vi håndterer alle henvendelser (support, feil, ønsker) fra autoriserte forhandlere. Ikke-autoriserte konsulenter, henvises til Visma Solutions AS
  • Henvendelsene skal registreres via Web i Visma Supportbase, dette gir deg blant annet:
  • Prioritert tilbakemelding til deg som er "ute hos kunde"
  • Full oversikt over egne saker med status til en hver tid
  • Logg av alle endringer på en sak
  • Full oversikt over feil og ønsker som er meldt
  • Automatisk oppdatering av erfaringsbasen
  • Vi er tilgjengelige hver ukedag fra kl. 08:00 - 16:00, henvendelser kan registreres hele døgnet

Registrer deg som bruker på www.vismasoftware.no under Forhandlerloungen/Supportbasen og du vil få tildelt ditt personlige brukernavn og passord.


Responstider

Visma Business Forhandlerservice - responstider

Prioritet | Respons-tid | Merknad
Ute hos kunde | ½ time | Benyttes KUN når du fysisk sitter ute hos kunde
Høy | 2 timer | Benyttes når du har en sak du MÅ ha svar på raskt fordi kunden ikke kommer videre
Normal | 2 dager | Benyttes på ordinære supporthenvendelser hvor du har konkrete spørsmål om en rutine du ikke får til å fungere som forventet

I løpet av denne tiden gir vi:

a) et løsningsforslag

eller

b) et estimatfor når du kan forvente tilbakemelding

Du må selv legge inn riktig prioritet på henvendelsen


Support på Visma Business

Alle saker som skal behandles av Visma Software ASA skal være registrert i SalesOffice Support system. De som kan eskalere saker til Visma Software ASA har tilgang til, enten via WEB klient eller direkte via Datakraftverket.

Til en sak skal det følge tilstrekkelig med dokumentasjon av problemet med tilhørende test data eller virkelige kundedata.

Når du registrerer saker i Supportbasen, er det viktig at du fyller ut følgende informasjon:

BIG

Hvis kunden benytter seg av BIG komponenter skal man starte Visma Business uten BIG og verifisere at feilen ikke kommer fra BIG applikasjonen.

Triggere og prosedyrer

Finnes det egen definerte triggere og prosedyrer i databasen skal disse "disables" og nye tester gjennomføres for a avdekke om disse er årsak til feilen. Er det ikke disse som skaper feilen skal de allikevel sendes med slik at de kan testes sammen med dataene.

-- Tar fram "Views" i valgt database. Skriptet kan kopieres rett inn i "Query Analyzer" eller "Visma Database Viewer".

select name as [View name] from sysobjects where OBJECTPROPERTY(id, N'IsView') = 1 order by name

-- Tar fram Lagrede prosedyrer i valgt database. Skriptet kan kopieres rett inn i "Query analyzer" eller "Visma Database Viewer".

select name as [Procedure name] from sysobjects where OBJECTPROPERTY(id, N'IsProcedure') = 1 order by name;

-- Tar fram Trigger i valgt database. Skriptet kan kopieres rett inn i "Query analyzer" eller "Visma Database Viewer".

select sysobjects.ID,sysobjects.parent_obj as TableID,sysobjects.name+' - '+b.name as [Trigger name - Table name] from sysobjects left join sysobjects b on b.Id=sysobjects.parent_obj where OBJECTPROPERTY(sysobjects.id, N'IsTrigger') = 1 order by sysobjects.parent_obj

Test data

Test data i små mengder hvor problemet er bekreftet kan leveres i Visma Business eksport format og da hele Firma databasen. Hvis ikke standard skjermbilder er benyttet skal også std.txt vedlegges.

NB! Testdata skal bare bestå av standard Demo data med tillegg av problemet.

Kunde database

Får vi tilsendt kundedata skal vi ha det i form av en database "zippet" backup for MS SQL Server eller Fysiske database "zippete" filer Fnnnn_Data.MDF og VBSYS_Data.MDF.
Disse filene må kopiers mens databasen er nede. Påse da at logg-filer ikke har vokst til GB størrelser i så fall må databasen "Shrinkes".
Har kunden Oracle eller DB2 skal Forhandler ta ut tekst filer og legge disse inn på MS SQL server for så å sende data, med mindre problemet er database relatert, da skal vi kun ha test data i form av tekstfil.

Kunde data som tekst fil

Unntaks vis kan vi motta tekstfil om disse ikke overskrider 20-30 MB
Et minimum når vi mottar kunde data for test er at firm.txt + Aktører er lagt ut sammen med nok tilleggsdata f. eks produkter mm. Dette bestemmes fra sak til sak.
NB! Vi skal ikke ha tekst fil hvis det er feil i lagerdata eller regnskapet da vi ikke kan sjekke endrings feltene som da blir satt til import dato/tid/bruker

Zip filens innehold

Data filer sammen med dokumentasjon på hva som skjer og pakkes ned i en fil med benevningen [Landkode]_Saksnr]_[Kundenavn].zip og legges på saken eller sendes i separat e-post hvis det ikke er mulig å legge den ved på "WEB access".

Hvordan legge ut data til tekstfil

Det er mange tabeller som benytters ved bruk av Visma Business og det er viktig at vi får en helhet, slik at vi kan finne alle parametere og grunndata som genererer feilen.
På snarveien skal du derfor sette in opsjonen "/xexp".

Dette vil gi en forenklet eksport av grunndata i fra Visma Business.i tillegg så vil det tilkomme et utvalg av andre tabeller avhengig av hva som er feil og her er det bare foreslått forskjellige tilleggsfiler.

Eksport av faste data

Opsjonen i snarveien fører til at du får en ekstra nedtrekks meny ”Type:”

  • Velg den riktige databasen for firmaet og så finner du "Firm" i nedtrekks menyen.
  • Det vil automatisk legge ut alle grunndata som vi trenger uten om transaksjoner.

  • Navngi filen med Firmanavn_Firm.txt

Eksport av skjermbilder

Velg "Std" i nedtrekks menyen i type og da vil automatisk "vbsys" bli valgt som database for alle tabeller som er nødvendig for å gjenskape feil i skjermbildene eller de skjermbilder som det henvises til i dokumentasjonen.

Tilleggsdata utlegg ved feil i Regnskaps modulen

Her kan man dele inn i forskjellige behov og feilsituasjoner for å redusere datamengden

Komplett regnskap

Tabellene nevnt under gir et komplett behov ved feil i regnskapet

Aktører
Åpne kunde poster
Kundetransaksjoner
Matchede kundetransaksjoner
Kundesaldoer
Åpne leverandør poster
Leverandørtranser
Matchede leverandørtransaksjoner
Leverandør saldoer
Automatposteringer
Hovedbokstransaksjoner
Hovedbokssaldoer
Hovedboksaldoer/R1-R12
Resultat og balanse definisjoner
Resultat og balanse definisjonslinjer
Saldogrupper
Driftsmiddelklasser
Driftsmidler
Driftsmiddeltransaksjoner
Driftsmiddelsaldoer
Ansvarsenheter R1-R12
Fordelingsnøkler
Fordelingslinjer
Budsjetter
Budsjettlinjer
Bunter
Bilag
Motreferanser
Oppdateringer
Oppdaterte bunter
Oppdaterte bilag
Oppdaterte motreferanser
Valutakurser
Periodiseringsnøkler
Periodiseringslinjer
Faktoringselskap
Kontonr. Serier
Heltalls bedrifts variabler
Desimal bedrifts variabler
Tekst bedrifts variabler
Valuta korreksjoner
Valuta korreksjons data
Bedriftsmaster

Navngi filen med FimraNavn_Regnskap.txt

Remitterings modulen

Tabellene nevnt under gir et minimums behov ved feil i remitteringsmodulen, her må vi også ha tilleggsdata fra Converter, de neste avsnitt.

Aktører
Åpne leverandør poster
Leverandørtransaksjoner
Matchede leverandørtransaksjoner
Leverandørsaldoer
Bankpartnere
Betalinger
Betalingslinjer
Kontonr-serier
Bedriftsmaster

Navngi filen med Firmanavn_Remit1.txt

Remittering med regnskap

Skal regnskaps data sjekkes i tillegg eller at kundetranser også legges ut for remittering må i tillegg for kunderemittering de 3 første og for regnskap alle

Åpne kundeposter
Kundetransaksjoner
Matchede kundetransaksjoner
Hovedbokstransaksjoner
Saldogrupper
Driftsmiddelklasser
Driftsmidler
Driftsmiddeltransaksjoner
Avdeling (R1)
Prosjekt (R2)
Kampanje (R6)
Evt. andre ansv.enheter .(R3-R5 og R7-R12)
Bunter
Bilagslinjer
Motreferanser
Oppdateringer
Oppdaterte bunter
Oppdaterte bilag
Oppdaterte motreferanser
Valutakurser
Bankforbindelser

Navngi filen med Firmanavn_Remit2.txt

Data til support i forbindelse med Remittering.

For at Forhandlersupport og utvikling skal kunne behandle feil i remitteringsmodulen så er vi avhengig av at datasettet er likt, fordi ved import av data fra banken så testes det mot eksisterende rader i Betalingslinjer. Samtidig så er det en rekke parametere som kan påvike resultatet både i Visma Business og Z Data Converter, derfor er det viktig at dere følger denne oppskriften ved innsending av data.

Z Data Converter

I Setup.exe for Z Data Converter så finnes et support verktøy som kopierer alle settinger og aktive filer som fines for Z Data.

Dette gjøres fra menyen Hjelp – Send post til Z Data.
Dette starter sending av e-post og lagrer samtidig en fil på Convert området som heter selfx.exe
Hvis lager denne filen umiddelbart etter en feil så vil du få lagret data slik de er i systemet etter feilen. Gir du filen et nytt navn f. eks selfx2003032.exe (dato) så kan du lagre flere.

Gå også inn i Hjelp – Om Converter og noter deg versjonsnummeret.

Noter ned versjons nr. og skriv det inn i e-posten.

Fjern supportconvert@zdata.no og erstatt med helpdesk@visma.no eller avtalt adresse.

Visma Business data

Remitteringsrutinen benytter en rekke tabeller og det er viktig at vi får en helhet, slik at vi kan finne alle parametere og grunndata som genererer feilen.
På snarveien skal du derfor sette in opsjonen "/xexp".

Dette vil gi en forenklet eksport av grunndata i fra Visma Business.

Merk: Vi skal ha tilsendte filer fordelt på 3 filer som definert under pga. lagvarige import tider før testing kan uføres.

Et alternativ hvis man har SQL server 2000 eller MSDE 2000 er å ta en sikkerhetskopi av databasen og pakke den med WinZip.

Eksport av faste data

Opsjonen i snarveien fører til at du får en ekstra nedtrekks meny ”Type:”

Velg den riktige databasen for firmaet og så finner du "Firm" i nedtrekks menyen. Det vil automatisk legge ut alle grunndata som vi trenger uten om transaksjoner.

Navngi filen med Firmanavn_Firm.txt

Eksport av minimum remitteringsdata

Velg eksporter data fra Opsjons menyen – Systemadministrasjon – Eksporter

Hold Ctrl tasten nede og merk følgende tabeller:

Aktører
Åpne leverandør poster
Leverandørtransaksjoner
Matchede leverandørtransaksjoner
Leverandørsaldoer
Bankpartnere
Betalinger
Betalingslinjer
Kontonr-serier
Bedriftsmaster

Navngi filen med Firmanavn_Remit1.txt

Remittering med regnskap

Skal regnskaps data sjekkes i tillegg eller at kundetranser også legges ut for remittering må i tillegg for kunderemittering de 3 første og for regnskap alle

Åpne kundeposter
Kundetransaksjoner
Matchede kundetransaksjoner
Hovedbokstransaksjoner
Saldogrupper
Driftsmiddelklasser
Driftsmidler
Driftsmiddeltransaksjoner
Avdeling (R1)
Prosjekt (R2)
Kampanje (R6)
Evt. andre ansvarsenheter .(R3-R5 og R7-R12)
Bunter
Bilagslinjer
Motreferanser
Oppdateringer
Oppdaterte bunter
Oppdaterte bilag
Oppdaterte motreferanser
Valutakurser
Bankforbindelser

Navngi filen med Firmanavn_Remit2.txt

Tilleggsfiler for ordre modulen

Ordre modulen kan også deles inn i flere nivåer avhengig av hvor feilen oppstår

Ordre registrering uten lager sjekk

Ved feil i ordreregistrering med henting av grunndata, pris og rabatt mm. Men uten lager sjekk og kostpris håndtering fra lagersaldo/vareparti.

Aktører
Ferier
Ansvarsenheter R1-12
Produkter
Strukturer
Leveringsalternativer
Strekkoder
Enheter
Pris og rabattmatrise
Prisrefusjoner
Prisfakturer
Produktkategorier
Produktbeskrivelse
Produktkunder
Plasseringer
Vareplasseringer
Valutakurser
Transportavtaler
Transportsoner
Bedriftsmaster

Navngi filen med Firmanavn_Ordre1.txt

Ordre med lager/kostpris

Skal også lager og full kostpris sjekkes må man i tillegg til Firmanavn_Ordre1.txt legge ut følgende tabeller:

Lagersaldoer
Beholdningsendringer
Varepartier
Lagerlogg
Ordrer
Ordrelinjer
Reservasjoner
Plukklister
Serienr.
Bestillingsforslag
Bestillingsforslagslinjer
Ordrejounal
Produkttransaksjoner

Navngi filen med Firmanavn_Ordre2.txt

Tilleggsfiler for CRM modulen

Ordre modulen kan også deles inn i flere nivåer avhengig av hovedfeilen oppstår

Komplett CRM

Ved feil i CRM modulen.

Aktører
Adresser
Info. typer
Info. behov
Kilder
Aktiviteter
Ferier
Ressurser
Ressursreservasjoner
Programmer
Maler
Stier
Mal referanser
Dokumenter
Dokumentkoblinger
Ansvarsenhetene 1-12
Deltakere
Produkter
Enheter
Pris og rabattmatrise
Prisfaktorer
Bedriftsmaster

Navngi filen med Firmanavn_CRM.txt


Tips & Råd

Dette kapitlet inneholder tips og råd, bruksmessig og tekniske for Visma Business.


Installasjon

Her finner du tips og gode råd om installasjon av Visma Business.


Flere Vbsys-ermot Visma Business på en PC

Flere Vbsys-er mot Visma Business på en PC

Årsak til at du skal bruke flere registry-nøkler mot Visma Business kan være at en registry-nøkkel viser Visma Advokat oppsettet, en annen viser Visma Byrå, den tredje Visma Professional etc. På terminalserver som drifter flere kunder vil det også være nødvendig med en slik løsning.

Du kan benytte følgende fremgangsmåte:

Registry settinger

Gå inn i Registry, Start – Kjør – "Regedit".

Velg HKEY_CURRENT_USER – Software – VISMA - VISMA BUSINESS.

Marker registry-nøkkelen "CurrentVersion" og velg Eksporter fra Fil-menyen.

Nå må du "Rename" "CurrentVersion" til det du ønsker (f.eks Ver450). Dette gjør du ved å høyreklikke på "CurrentVersion" og velge "Rename".

I den nye registry-nøkkelen må du endre en del parametere under "Database", "International" og "Miscellaneous". Sjekk at path`ene henvises til riktig sti, spesielt Memo_Path.

NB! Under registry-nøkkelen "Database" må du også huske på å endre parameteret "SYSDB". Her må du legge inn ønsket navn på ny Vbsys. F.eks.:

Visma Business database

For å generere ny Vbsys-database må du starte VismaBusiness med parameteret /i ("C:\Program Files\Visma\Business\VBus.exe" /i). Den vil da ta tak i navnet som ligger i "SYSDB" i registry og foreslå som navn på ny systemdatabase.

Husk å fjerne hake for "Opprett bedrift" og "Opprett demodata".

Visma Business Properties

Importer inn registry-nøkkelen du eksporterte i punkt 1. Det gjør du ved å velge Fil – Import inne i Registry. Denne blir nå hetende "CurrentVersion".

Nå har du en registry-nøkkel som heter "CurrentVersion" og en som heter "Ver450" (f.eks.).

For at Visma Business skal starte med riktig registry-nøkkel må du angi det på oppstartsparameteret. Enten på ikonet eller fra Start – Programmer – Visma – Visma Business. Høyreklikk på Visma Business og velg Egenskaper. I "Target" må du angi riktig registry-nøkkel med parameteret /n. (Husk ikke mellomrom) Se eksempel:

Dersom det ikke ligger /n på oppstartsparametert (Target), så bruker programmet CurrentVersion.


Forberedelser før installasjon/oppgradering

Basert på supporthenvendelser, beskriver vi her noen punkter som er aktuelle ved installasjon og oppgradering. Dette er kun ment som tips i tillegg til aktuell installasjonsveiledning som alltid må følges.

Integrasjoner

Avklar på forhånd hvilke integrasjoner mot andre systemer som benyttes. Er disse kompatible med versjonen du planlegger å installere?

- CRM integrasjon
- Visma Business dokumentsenter
- Visma Business rapportsenter
- Visma Business Outlook
- EDI integrasjoner

- Andre......

Backup

Sørg for å ha backup av alle databaser (eksport til tekstfil er ikke nok). Stol ikke på at kundens backup-rutiner fungerer, ta alltid en backup selv vha. Visma – SQL BackupRestore eller Enterprise Manager.

Filkopiering

Kopier hele programområdet til et annet område. Vær spesielt oppmerksom på at imp-filene overskrives ved oppgradering. Egne tilpassninger i imp-filer bør derfor alltid lagres med annet navn.

Innkopiering av filer

Under oppgradering kopieres filer av nyere versjon inn på programområdet. Hvis filene er i bruk, vil ikke korrekt innkopiering kunne skje. Sørg derfor for at alle brukere er logget ut, eller for å være på den sikre siden, bør serveren restartes før oppgradering.

Installasjon på nytt område

Hvis man velger å installere Visma Business på nytt område for å ha en backup av det gamle programområdet så vil det i enkelte tilfeller føre til at avinstallering av det gamle området skjer. Dette fordi det i VismaBusiness460.msi ligger informasjon om hvor filene er installert og de vil da bli fjernet.

Feilsituasjoner ved oppgradering til 4.70.x

Når filer fra gamle versjoner ligger igjen på programområdet

Hvis man har kopiert over filer og ikke benyttet installasjon så kan filer ligge igjen og skape problemer. Det gjelder blant annet filene:

Vbus.exe.manifest

Denne filen forårsaker følgende feilmeling og Visma Business starter ikke.

vbus.exe.config

Denne filen vil kunne skape feilsituasjoner når eventuelt Visma Business skal kalle på programfiler laget i .NET 2.0 og det gjelder blant annet sending og mottak av XML filer i det nye Visma EDI formatet 4.0 og de som har laget BIG programmer i .NET 2.0


Oversikt over dll-er

Oversikt over dll-er som blir installert ved Visma Business installasjon

Dersom du ønsker å vite hvilke dll-er som blir installert under en Visma Business installasjon (både Visma Business og felles systemfiler) kan du sjekke loggfilen. Loggfilen heter "VismaInstall.log" og ligger under Temp-katalogen til den som installerer, eksempel "C:\Documents and Settings\Administrator\Local Settings\Temp".

I denne filen kan du se hvilke dll-er som blir installert og hvor de blir lagt. Dette endrer seg fra versjon til versjon. Derfor er det vanskelig å lage en egen oversikt over dette da det må vedlikeholdes til hver versjon.

Merk: Det er egen loggfil for klientinstallasjonen.

Dette er et lite utdarag fra filen:

Eksempel påloggfilen "VismaInstall.log".


Terminalserver Installasjon

Installasjon på en terminalserver er i utgangspunktet ikke forskjellig fra en installasjon på en vanlig server. Det du må huske på er at du setter terminalserveren i ”install modus” for så sette den tilbake til ”execute modus” når du er ferdig med installasjonen.

Du setter altså serveren i ”install modus” ved hjelp av kommandoen ”change user /install” i ett dos-vindu. Gjennomfør så installasjonen på vanlig måte, og sett serveren tilbake i ”execute modus” ved hjelp av kommandoen ”change user /execute” i ett dos-vindu.

F. o. m. Windows 2003 fungerer Windows slik at den automatisk setter seg i ”install modus” hvis du kjører en fil som heter install.exe eller setup.exe, men det er greit å legge seg til denne vanen, da Windows erfaringsmessig ikke alltid automatisk setter seg i en slik modus.

Den mest vanlige måten å gjennomføre en installasjon når du tar i bruk terminalserver, er at klientinstallasjonen gjøres på selve terminalserveren.

Du har altså en server der Sql Server med databaser ligger, og du har en applikasjonsserver der serverinstallasjonen gjøres, og så har du en terminalserver der klientinstallasjonen gjøres.

Ressursmessig vil alltid presset ligge på selve terminalserveren. Det er her alle brukere vil logge seg på og forbruke de ressurser som er tilgjengelig. Det er derfor viktig og være romslig når det skal beregnes hvor mye fysisk minne (RAM) som skal være på terminalserveren.

Rettighetsmessig er ikke forskjellen stor. Alle brukere av terminalserver må ha rettigheter til

Programkatalog, dokumentkataloger etc. er avhengig av hvilke rutiner du skal bruke i Visma Business. Selve installasjonen bør selvfølgelig gjøres av en administrator bruker.

FaxMail-driver:

Kjører du terminalserver skal du ikke bruker den ”vanlige” driveren som kan velges under installasjonen av Visma Business. Du skal da bruke de driverne som ligger på cd under følgende path:

[CD Rom]:\Other\Terminal Printer Drivers\FaxMail printer driver

[CD Rom]:\Other\Terminal Printer Drivers\PDF printer driver

Konfigurasjon og oppsett med tanke på filepath og rettigheter er akkurat som på den vanlige FaxMail-driveren.


Generelt

Her finner du tips og gode råd av generell karakter i Visma Business.


Backup / restore SQL server

Ved nyinstallasjon av versjon 4.10 blir databasen MSDE 2000 installert sammen med Visma Business. Samtidig blir det installert ett verktøy for "Backup" og "Restore". Backup vil ikke bli tatt når du gjør dette etter en nyinstallasjon. Årsaken til dette er at det ved MSDE 2000 installasjon ikke blir opprettet en katalog som heter "backup". Dersom du lager denne manuelt vil programmet "Backup/restore SQL server" fungere som tenkt.

Katalogen lager du på området hvor MSDE er installert.


Bruk av .Net i Visma Business

Versjon 5.x og nyere er nok mer utsatt enn tidligere versjoner når vi kommer til .NET problematikk. Grunnen til det er at vi benytter flere .Net-funksjoner via NFL.dll enn det vi har gjort i tidligere versjoner. I dette skrivet har vi noen forklaringer på ulike begreper

Caspol

Caspol kommandoen setter Full trust på hele katalogen du angir.
Vi trenger Full trust på programkatalogen til Visma Business. For å få satt dette må vi nå kjøre følgende kommando under Start – Kjør: (Dette er Caspol kommandoen)

\Windows\Microsoft.Net\Framework\v2.0.50727\CasPol.exe -m -ag 1.2 -url "c:\Program Files\Visma\Business" FullTrust -n VismaBusinessTrust
(Det i blått endres avhengig av som er korrekt programområde for Visma Business)

Forklaring til Caspol kommandoen:
1.2 er id'en til kodegruppen som den skal legges under. 1.2 er Intranet Zone.
-url: Dette er mappen som VismaBusiness.exe/VBus.exe ligger i, sett i fra klienten
FullTrust: Gir alle rettigheter på systemet. Det trenger Visma Business.
-n Navnet på kode-gruppen. Kan godt hete VismaBusinessTrust, det har ingen betydning.

NB! For 64-bit OS finnes det også en katalog som heter Framework64, kjør derfor caspol.exe fra den katalogen.

MERK! Denne kommandoen må kjøres på alle klienter/terminalservere, evt. legges inn via Domain Policy. Det har ingen virkning å sette den på selve filserveren der Visma Business filene ligger eller på databaseserveren. Det har heller ingen virkning å sette det i .Net 1.1 konfigurasjonen, siden Business bruker .Net 3.5. (ikke noe delt oppsett mellom 1.1 og 2.0).

Caspol kommandoen har erstattet tidligere funksjoner som:

  • Net Security Configuration:
    Den Net Security Configuration som lå under Administrative Tools i Windows er nå erstattet med Caspol kommandoen som vist lenger nede i dokumentet.
    Security settinger under ”Local Intranet Sone”…, også erstattet med Caspol kommandoen.
  • NetSecurity.exe:
    Programmet som vi legger med under Other katalogen på cd`n er også erstattet av Caspol kommandoen. NetSecurity programmet satte kun rettigheter på VismaBusiness.exe, mens vi i 5.20 har langt flere .Net filer som også må ha Full trust.
    Dette programmet kan fortsatt benyttes til å lese rettigheter som er satt ved hjelp av knappen nederst til høyre ”List group”.

For å få utlisting av caspol på installajonen til fil slik at det er lettere å arbeide med teksten:

-stå i cmd, og kjør
caspol -l >[path]\[file]

f. eks. caspol -l > d:\sink\logs\cas.txt

Rettigheter

I MFC (Microsoft Foundation Classes) applikasjoner finnes det ikke noe code policy rammeverk, noe som innebærer at du enten må gi ”Full trust” eller ”No trust” (dvs. la være å installere applikasjonen). Siden Vbus.exe er en MFC-applikasjon, har alle ASP-leverandører som i dag tilbyr Visma Business implisitt ”Full trust” til Business.
Dette har ingenting med bruker-rettigheter eller filsystemets sikkerhet å gjøre. Det er kun nødvendig å gi ”Full-trust” rettigheter på mappen hvor Visma Business er installert. Det gjelder altså ikke alle mapper i Local Intranet Zone. Dersom det kun er administrator som har rettigheter til å skrive i denne mappen, er det fremdeles bare ham som kan endre innholdet i den.

VismaSoftware.Interop.Business.dll

VismaSoftware.Interop.Business.dll er et slags tilpasningsbibliotek mellom BIG (basert på COM-teknologi) og .Net
. Net kan ikke benytte COM+ direkte og trenger derfor slike interop-biblioteker for å gjøre det.

Installasjon av Visma Business kopierer denne filen (VismaSoftware.Interop.Business.dll) til Visma Business sitt programområde. For å kjøre våre BIG komponenter skal dette være nok (BIG komponenter som for eksempel Byrå benytter).

BIG applikasjoner som ligger i andre kataloger enn Visma Business sitt programområde (for eksempel applikasjoner som forhandlerne lager, andre integrasjonsverktøy etc.), krever at Interop.dll ligger i GAC (Global Assembly Cache) Dvs. at Install.bat må kjøres.

Install.bat:
På cd`n til Visma Business finner du Install.bat. Den ligger under D:\GlobalAssemblyCache.
Install.bat legger VismaSoftware.Interop.Business.dll inn i GAC via gacutil-kommandoen.

Dersom du MÅ ha ting i GAC, må du sørge for at kun EN versjon er installert (av Visma Business) og at registreringen skjer fra den katalogen hvor den gjeldende versjonen av Visma Business ligger.

Dersom du trenger å fjerne VismaSoftware.Interop.Business fra c:\\windows\assembly kan du slette filen direkte eller du kan avinstallere ved hjelp av kommandoen gacutl /u VismaSoftware.Interop.Business.
Deretter kjøres Install.bat på nytt fra katalogen der gjeldende versjon av Visma Business ligger.

Ingenting skal ligge lokalt. Dersom VismaSoftware.Interop.Business.dll er i GAC, ligger den på en måte lokalt, men i et skjult område. Install.bat må kjøres fra hver arbeidsstasjon, men du browser deg frem mot serveren.

Diverse feilsituasjoner knyttet til .Net

MERK! Generelt sett skal alle .Net problemer relatert til rettigheter automatisk logges i application eventloggen.

Feilsituasjon:

Når det gjelder bruk av BIG fra .Net-applikasjoner, så skal caspol-kommandoen løse dette, siden VismaSoftware.Interop.Business.dll ligger i program-katalogen som får Full Trust.

  • VismaSoftware.Interop.Business ligger i global assembly cache (GAC). Det skal den helst ikke gjøre. Den skal kun ligge i program-katalogen.
  • BIG er feilregistrert på systemet fordi pga oppgradering, eller at det kjøres flere versjoner av Business på samme maskin. Normalt løses dette ved å ikke kjøre flere versjoner samtidig og i tillegg starte riktig versjon av VBus.exe på maskinen med problemer.

Vi benytter .NET for eksempel når vi skal generere TIFF eller PDF filer. Ved generering kan derfor denne meldingen oppstå:

Løsningsforslag:

Løsningen vil her være å kjøre filen “NFL_RegAsm.cmd” (finnes før versjon 5.20) fra Visma Business sitt programområde, f.eks. C:\Program Files\Visma\Business\ (filen kjøres fra arbeidsstasjonen som har problemet, men du søker deg frem til filen som ligger på serveren).
Dersom det er versjon 5.20 à må følgende kommando benyttes:

c:\windows\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe NFL.dll /unregister
c:\windows\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe /codebase /tlb:nfl.tlb NFL.dll

Grunnen til at meldingen kommer er at filen ”NFL.dll” ikke ble korrekt registrert ved installasjon/oppgradering.
Etter registrering av denne filen, vil meldingen nå bli borte, men det kan være at du fortsatt har problemer med å generere TIFF filer. Kontroller at brukeren har tilstrekkelig rettigheter på filserveren (altså at de kan opprette filer på ønsket område). Dersom de har det, så er årsaken mest sannsynlig at .Net security ikke er satt korrekt.


Dos-kommandoer

Dos-kommandoer for MSDE

Lage nytt sa-passord:

Først må du gå inn i Dos-kommandolinje.

osql –E (tast Enter)

sp_password NULL, ’nytt passord’, ’sa’ (tast Enter)

go (tast Enter)

Attach/Detach av databaser:

Først må du gå inn i Dos-kommandolinje.

Så skriver du inn kommandoen:

Osql -U sa (tast Enter)

Password: (tast Enter)

Ved attach skriver du:

EXEC sp_attach_db ‘DATABASE’ , ‘C:\Program Files\Microsoft Sql Server\MsSql\DATABASE_Data.MDF’ ,

‘C:\Program Files\Microsoft Sql Server\MsSql\DATABASE_log.LDF’

Ved detach skriver du:

EXEC sp_detach_db 'databasenavn',

Sjekke hvilket tegnsett...etc. databasen er satt til å bruke:

Først må du gå inn i Dos-kommandolinje.

Så skriver du inn kommandoen:

Osql -U sa (tast Enter)

Password: (tast Enter)

Sp_helpsort

go

Justere minnebehandlingen til SQL:

Først må du gå inn i Dos-kommandolinje.

Så skriver du inn kommandoen:

Osql -U sa (tast Enter)

Password: (tast Enter)

sp_configure 'max server memory/min server memory', <minnestørrelse>

go

reconfigure

go


Indeksering av Microsoft SQL 7.0 database

I Microsoft SQL server 7.0 finnes det en rekke verktøy for å bedre hastigheten på de ulike operasjoner som gjøres i databasen. I programmet SQL Server Profiler finnes det en veiviser som kan hjelpe deg dersom enkelte operasjoner ta lengre tid en forventet. Under valget ”tools” kan det ved hjelp av en veiviser startes en jobb som holder styr på alle operasjoner som skjer i databasen.

Denne veiviseren skal hjelpe meg med å finne de spørringer som tar lengst tid og som krever mest av SQL Serveren.

Vi kan så velge hvilken database som skal undersøkes eller eller vi kan velge å teste på hele SQL Serveren, og hvor lang tid den enkelte spøring eller søk kan ta før det skal logges.

Når vi nå sier OK og godkjenner at vi skal starte denne jobben kan vi se at den har blitt startet i SQL Server Profiler. Jeg velger så å stoppe denne jobben. Dette gjør jeg fordi jeg skal fortelle at det skal dannes en fil (trc) som inneholder resultatet av den jobben jeg har satt i gang. Det gjør jeg ved å høyre-klikke på jobben og deretter velge egenskaper (properties).

Neste trinn er å utføre de krevende operasjonene. Dette bør gjøres over tid og ikke bare den ene operasjonen da det å sette opp en indeks kan få den konsekvensen at andre operasjoner går tregere. Derfor kan denne jobbe gjerne stå på noen timer mens det er full og normal aktivitet blandt de som jobber mot datbasen. Slik at den fanger opp de mest krevende jobbene. I dette eksemplet er det blitt registrert noen ordrelinjer i en database som har en ganske krevende og komplisert pris og rabattmatrise. Vi kan se at den har funnet 9 hendelser som har tatt lenger enn 1000 millisekunder å gjennomføre. Disse 9 hendelsene ønsker jeg å analysere nærmere og finne ut om det er mulig å redusere tiden SQL Serveren bruker på å utføre disse handlingene. Til å hjelpe meg med det bruker jeg nok en veiviser "Index Tuning Wizard". Før vi starter denne veiviseren må vi først stoppe den jobben vi har startet i SQL Server Profiler.

Vi må først fortelle at vi har allerede har laget en fil og deretter hvor denne filen ligger på harddisken.

Neste trinn er å plukke ut de tabeller i databasen som skal analyseres. Vi kan som her velge å analysere alle tabellene eller kun enkelt tabeller. I dette eksemplet er det valgt å sjekke alle tabellene. Denne joben kan ta tid dersom det er mange hendelser som skal analyseres.

Resulatet blir rapportert i neste dialog. Her blir det anbefalt hvilke kolonner og tabeller analysen anbefaler at det indekseres på. De som allerede eksisterer vil det ikke bli gjort noe med, men de som ikke eksisterer vil bli dannet dersom dere velger "next" eller dere kan velge å sette opp disse manuelt i Visma Business. Analysen konkulderer med at vi vil oppleve en forbedring med 91 % dersom vi velger å indeksere databasen som anbefalt.

NB!! Dersom vi ønsker å beholde disse indeksene for fremtiden må vi lage disse manuelt i Visma Business. Vi kan også velge å la veiviseren fullføre, da vil indeksene som blir opprettet bli slettet dersom vi oppgraderer eller regenerer indekser. Det å slette indeksene kan være aktuellt i de tilfeller der hvor vi skal gjøre operasjoner som er tidkrevende, men vi skal kun gjøre dem en gang, da kan det være lurt å slette indeksene i ettertid slik at de ikke påvirker hastigheten i andre deler av systemet.

Et annet tips dersom kunden benytter MSDE (hvor denne veiviseren ikke er tilgjengelig) kan være å laste ned kunden data på kontoret hvor Mssql 7 er installert og så gå gjennom veiviseren på denne basen og få en anbefaling på hva som skal indekseres for så å dra ut til kunden å indeksere basen ved hjelp av Visma Business.


Ntdll.dll

Tips omkring NTDLL.DLL

Et raskt søk på nettet avdekker fort at det er mange applikasjoner som sliter med feil knyttet til ntdll.dll. Nedenfor finner du en del generelle tips om mulige årsaker til feilmeldingene, og hva som kan gjøres i forbindelse med feilsøk og feilretting.

Ntdll-meldinger finnes i mange varianter:

  • "STOP: 0xC0000221 unknown hard error C:\Windows\System32\Ntdll.dll"
  • "STOP: C0000221 unknown hard error \SystemRoot\System32\ntdll.dll"
  • "AppName: [PROGRAM NAVN] ModName: ntdll.dll"
  • "[PROGRAM NAME] caused a fault in module NTDLL.DLL at [EN ADRESSE]"
  • "Crash caused in ntdll.dll!"
  • "NTDLL.DLL Error!"
  • "Unhandled exception at [EN ADRESSE] (NTDLL.DLL)"

Meldingen kan komme før et program starter, mens et program kjører og i avslutning av et program.

Mulige årsaker

Her er det mye å velge mellom. Det kan være at selve ntdll.dll er i feil versjon eller er blitt korrupt, det kan være maskinvare problemer som gir meldingen, eller det kan være noe i samspillet mellom operativsystemet og enkelte programmer som ikke fungerer slik det skal.

Feilsøk og retting

1. Kjør omstart på maskinen. En gang i mellom forsvinner feilen av seg selv bare med det

2. Oppstår feilen hver gang du bruker et bestemt program, kan det lønne seg å avinstallere, restarte maskinen og installere programmet på nytt. Husk å sjekke at du har siste versjon.

Kontroller alltid om det er kommet hotfix eller patch til programmet. Skyldes feilen en svakhet i programkoden, vil den ofte være funnet og rettet.

3. Også operativsystemet inneholder mulige svakheter. Vær sikker på at du har fått med alle windows-oppdateringer

4. Tilleggsfunksjoner til internet explorer er ofte skyld i denne typen problemer. Test ved å koble fra google toolbars etc. Koble på en og en funksjon til feilen kommer tilbake forå finne synderen.

Tips: Dersom det viser seg at feilen faktisk kan henføres til internet explorer, kan du teste med et alternativ, Firefox, Opera eller tilsvarende.

5. Finnes en NLSPATH som systemparameter på operativsystemet, kan dette med fordel slettes. - Husk å notere stien, slik at verdien kan settes tilbake dersom endringen ikke løser problemet.

6. Sjekk at DEP (Data Execution Prevention) står til laveste trinn – bare operativsystem kjerne. Dersom den står til noe annet, mådu sjekke ut egen artikkel om dette på forhandlelounge under CRM.

7. Sjekk at du har siste versjon av drivere til maskinen. Eldre drivere til grafikkort er f.eks. kjente problem-makere i forhold til ntdll.

8. Diffuse ntdll-meldinger kan oppstå dersom det er minnefeil på en av ram-brikkene i maskinen. Ofte er det nok å kjøre den mest omfattende minnetesten som følger med maskinen for å avdekke problemet, selv om PC-doctor el.lignende utfører bedre og grundigere tester.

9. Feilen kan melde seg desom du har interne og eksterne IDE disker på samme kontroller.

10. Slitt kabel eller kabel med dårlig kontakt mellom kontroller og interndisk er også kjent årsak.

11. Dersom det ikke er nok å reinstallere programmet som skaper problemer,kan det være en løsning å kjøre repair på operativsystemet. Repair frisker nemlig opp de fleste dll'ene – iklusiv ntdll.dll. Husk at du må legge inn alle SP og patcher igjen.

12. Når alt ovenfor er testet og du fortsatt ikke er i mål, har du bare to muligheter igjen. Den første er "format c:" og komplett nyinstallasjon av operativsystemet.

13. Som nr 2: Det finnes noen få saker hvor det var fysisk feil på harddisken som var årsaken til problemet. I disse tilfellene ble det byttet disk før operativsystemet ble lagt inn på nytt.

En metode som har reddet mange er følgende:

  • Avinstallerer alle .Net versjoner
  • Avinstallerer alle unødige programmer, er man i tvil avinstaller og heller reinstaller etterpå.
  • Avinstallerer Visma Business
  • Avinstallerer SP3
  • Kjører CClean eller tilsvarende og rydder i temporere filer, unødige programmer, og ikke minst registry.
  • Restarte maskinen.
  • Hente siste versjon av .net 3.5 SP1 på http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7 og installere denne.
  • Installere SP3
  • Installere Visma Business.


Ny orm (virus)

som legger inn passord på SQL sa bruker hvis sa bruker ikke har passord.

Les mer om dette på følgende:

  • eksterne link.

Rydd opp ved hjelp av antivirusprogram.

For å sette passord på sa bruker uten å kjenne nåværende passord kan du gjøre følgende:

  • Logg på server som Administrator.
  • Start cmd prompt og bruk følgende kommando:
  • osql –E <enter>
  • sp_password NULL, ’nytt passord’, ’sa’ <enter>
  • go <enter>
  • exit <enter>

    • Start Visma Business / Visma Lønn og legg inn ’nytt passord’ (samme som over)
    på sa bruker i tabellen Brukere.


Registrering av filer

Eksempel på kommando for registrering av filer:

Hvis du skal avregistrere filer, legger du inn –U etter *.exe.


Restore Microsoft SQL database

Start opp SQL Server Enterprise Manager og gå inn på Databases. Marker den databasen som det skal legges tilbake backup på og høyreklikk. Databasen kan godt ha et annet nummer/navn enn det som du har fått på backupen. (F.eks. backupen du har fått er på F0001, den kan legges inn på F0003)

Velg ”Alle oppgaver” og ”Restore Database...”

I bildet du får opp blir det automatisk satt opp riktig firmadatabase i feltet ”Restore database”. Utfor Restore, setter du ? From device. Bildet du da får opp, ser slik ut:

Klikk på Select Devices og i neste dialogboks, velger du Add.

La det stå ? File name og browse deg frem til område/katalogen hvor du har lagt backupfilen fra forhandler/kunde. F.eks.:

Klikk Ok.

Klikk Ok her også.

På bildet du nå for opp (under) velger du fanen for Options.

Sett hake i ”Force restore over existing database”, og under ”Move to physical file name” angir du stien hvor basen du skal restore skal legge seg. NB! Husk at dette må være et gyldig område. Du får endret område ved å klikke i feltet.

Klikk Ok, og du er igang med å restore backupen.


Växlar att använda i VISMA Business

/I Installation

Med denna växel startas VISMA Business så att installationsdialogen öppnas direkt. Växeln fylls i sist på den befintliga kommandoraden.

/N Nyckel

Står för den nyckel, vilken finns i registereditorn, som VISMA Business ska starta upp med. Namnet på nyckel anges direkt efter växeln på kommandoraden och bör skrivas på samma sätt på kommandoraden som i registereditorn med avseende på gemener och versaler. Om ingen nyckel anges på kommandoraden kommer VISMA att använda Current Version (HKEY_CURRENT_USER\Software\VISMA\VISMA BUSINESS\CurrentVersion).

/U User

Genom att definiera användarnamnet på kommandoraden direkt efter denna växel, behöver användaren inte skriva in sitt användarnamn i inloggningsdialogen. Användarnamnet är då redan registrerat i dialogen där den visas.

/P Password.

Genom att ange både user och password behöver användaren inte ange något, utan kommer in i programmet direkt. Om flera växlar används definieras exempelvis user och password med mellanslag mellan växlarna. (/Usystem /Pkalle)

/R Import.

Denna växel används för att importera en textfil utan att ”strata” programmet. Filens namn och eventuell sökväg skrivs direkt efter växeln. Vilken importmetod som ska nyttjas definieras i filen. Denna växel måste kombineras med /U och eventuellt /P för att erhålla önskad funktionalitet.

J Innerjoin

När programmet startas med denna växel ges du möjlighet att koppla relaterade tabeller innanför (innerjoin). Denna växel bör endast nyttjas av den som har god sql kännedom.

/D Demoinstallation.

Om programmet startas med denna växel kommer VISMA Business starta en demoinstallation, likt den som görs i setup programmet men med skillnaden att du inte får några frågor innan installationen sätter igång.

/B Back over complaint

Tar bort den 6e toolbaren i registereditorn och återställer toolbar summery så att äldre versioner utan egendefinierade knappar kan startas utan att programfel uppträder. Detta är enbart intressant att nyttja då flera VISMA Business installationer av olika version ska köras på samma arbetsstation.


Engelske ledetekster på formularet

Engelske ledetekster på formularet.

Ønsker du å få automatikk i at ledetekstene på formularet skal styres av hvilke språk som er definert på kunden, kan du benytte følgende fremgangsmåte:

På formularet må du sette antall overskriftslinjer lik null. Det gjør du ved å gå inn på bildet som er definert for dette formularet, f.eks Faktura 1. Marker ordrelinjene, gå i design, høyreklikk og velg Andre preferanser. Her setter du "Antall overskriftslinjer" til 0.

Deretter må du redigere ut de feltene du skal benytte til overskrift inn på formularet. Benytt makroen for Fritekst. I eksempelet har vi brukt Fritekst (1), Fritekst (2), osv til Fritekst (5) benyttet.

Opprett så ”ledetekstene” i teksttabellen. Du må registrere Språknr, Teksttype, Tekstnr og Tekst. Bruk teksttype 1 for Fritekst. Tekstnr er det som legges inn i parantesen på formularet og henviser til hilken tekst som skal benyttes. Hvis du på formularet legger Fritekst(5) blir teksten på formularet det du har definert på Fritekst med tekstnr 5 i Teksttabellen. I eksempelet her er det ”Pris” eller ”Price” som blir skrivet på formularet. Det er språknummer på ordren som avgjør hvilken av tekstene som velges.

Registrerer du en ordre med språknr 44 vil du få engelske ledetekster på faktura som er vist under.

Registrerer du en ordre med språknr 47 vil du få norske ledetekster på faktura som er vist under.


Enkel forklaring på utskriftsoppsett

Enkel forklaring på utskriftsoppsett i 4.xx.x

Når en skriver ut i Visma Business, har man en del valg om hvordan man vil gjøre dette.

Man kan enten definere hvilke skrivere som skal brukes i de enkelte vinduer ved hjelp av tabeller inne på ”skrivere/adgang”, man kan også lagre ett vindusoppsett med ønsket skriver definert, eller så kan man bruke standard skriver som er definert i Windows.

Det sistnevnte brukes hvis ikke noe annet er definert.

Definere skrivere og Vindusskrivere inne i ”skrivere/adgang”:

  • Man starter med å opprette en skrivergruppe, som blir gitt ett nummer og ett navn.

  • Man tildeler så de brukerne man ønsker i denne skrivergruppen.

  • Det neste man gjør er å definere ett skriveroppsett, som også får tildelt ett skriveroppsettsnummer og beskrivesle. Her legger man til den skriveren man ønsker å benytte.

    Når den ønskede skriver er lagt til, er det på tide å sette opp vindusskrivere.

    Her bestemmer man seg først for hvilke vindusnavn og vindusnummer man ønsker som skal skrives ut på den aktuelle skriveren. NB: Her må man passe på å stå i det skriveroppsettet man ønsker skal brukes, når man definerer vindusskrivere!

    Feltene ”sideelementnr.” og ”skriveroppsettsnr.” er skjult i Visma Business som default, så man bør hente frem disse feltene for å få større oversikt.

    Skriveroppsettsnr. forteller hvilket skriveroppsett vinduet skal bruke.

    Sideelementnr. forteller hvilke sideelementer som skal brukes i utskiften av vinduet. Sideelementer er elementer som er med i vinduet.

    Når man setter hvilket sideelementnr. man skal bruke, er det viktig og bruke det sideelementnr. som bruker riktig sideelemttype, som er hva du egentlig vil ha skrevet ut.(som regel er dette type 0, som er innholdet av en tabell).

    Etter dette setter du hvilke skrivergruppe vinduet skal bruke.

  • Avslutt med å lagre oppsettet.

Lagre vindusoppsett:

Den kanskje enkleste måten å sette opp en annen skriver i ett vindu på, er å lagre vindusoppsettet etter at du har forandret skriveren.

Dette gjøres ganske enkelt ved å stå i det vinduet du vil forandre skriver, gå så til utskriftsformat og endre skriver til den skriveren du ønsker å bruke for dette vinduet.

Når du har gjort dette lagrer du hele vindusoppsettet med samme navn. Nå vil den nye skriveren bli tatt i bruk neste gang du ønsker å skrive ut fra dette vinduet.

Pass bare på at etter at du har trykket ”lagre vindusoppsett” forteller hva som skal lagres og for hvilke brukere og bedrifter endringene skal gjøres.

Standard Windows skriver:

Standard Windows skriver går bare ut på at hvis ingen av de overnevnte oppsett tatt i bruk, vil Visma Business bruke den skriveren som er satt opp som default i Windows i alle utskrifter.


Lagring av skriverinformasjon

I de skjermbildene vi leverer ved installasjon av Visma Business er det ikke lagret noen skriver. Det betyr at det ligger blank (ingen verdi) i feltet ”$Skrivernavn” i tabellen ”Vinduer” knyttet til dette skjermbilde eller tilhørende bilder (eksempel: 200 Salgsordre):

Det samme gjelder informasjon om ”Sideskiftnivå”, ”Kopier pr. side” og liknenede. Det betyr at det er standard skriver som benyttes for utskrift i skjermbilde ”200 Salgsordre”.

Skrive ut til annen skriver enn standard skriver: (utskrift via formular)

Dersom jeg ønsker å benytte en annen skriver i et skjermbilde som har et formular knyttet til seg, må jeg gjøre følgende:

Gå inn i Formularredigering (Administrasjon – Formularredigering) og hent frem ønsket formular under fanen ”Ordredokumenter”. F.eks. Formularnr. 13 ”Faktura”)

Ut fra skjermbildet over ser vi at formularet ”Faktura” benytter ”Utskriftsoppsett 3756 som er oppsett ”9320. Faktura1*”. Vi må da inn på ”Faktura1” skjermbilde for å gjøre endringer som har med skriveren å gjøre. For å gå inn i dette skjermbilde, velg knappen ”Ordrelinje”

Velg deretter ”Faktura1”

Dette skjermbildet ser slik ut:

Her velger du Fil – Utskriftsformat og knappen ”Skriver” og lagrer en annen skriver enn standardskriveren:

Lagre vindusoppsettet...

Slik blir det seende ut i tabellen Vinduer:

Vinduet ”200 Salgsordre” er uendret, mens vinduet ”Faktura 1” har fått lagret en skriver på seg.

MERK: Dersom jeg velger Fil – Utskriftsformat (i skjermbildet ”200 Salgsordre”) og velger ”Skriver”= \\GORGON\XeroxDC , klikker Ok og lagerer vindusoppsettet i Visma Business...

...da vil følgende skje:

Vindustabellen legger inn navnet på STANDARDSKRIVEREN min i feltet ”$Skrivernavn”:

Dette blir derfor feil. Skal du lagre en skriver til et skjermbilde, må du gjøre det via ”Utskriftsoppsettsvinduet” (F.eks. Faktura1).

Utskrift til annen skriver enn standard skriver: (uten formular knyttet til seg)

Har laget meg et skjermbilde som jeg har kalt Kunder. Her er det foreløpig ikke lagret noen skriver. Tabellen Vinduer ser derfor slik ut:

Dersom jeg nå ønsker å lagre en skriver til dette vinduet, velger jeg Fil – Utskriftsformat og knappen ”Skriver”. Velger ønsket skriver og klikker Ok. Lagrer Vindusoppsettet.

Vindustabellen blir da seende slik ut:

Og hvis jeg gjør en utskrift fra skjermbildet Kunder kommer det til denne skriveren.

MERK: Dersom du har lagret en skriver til et skjermbilde, men ønsker å overstyre dette ved en utskrift... da må du inn på Fil – Utskriftsformat og endre til ønsket skriver. Dersom det er utskrift av et formular som skal gjøres, må endringen foretas på Utskriftsoppsettsvinduet.


Problemer med utskrifter via Terminalserver

Problemer med utskrift via terminalserver

Gjelder Windows 2000, SP3

Se artikkel Q328020 på Technet:

  • http://support.microsoft.com/default.aspx?scid=KB;EN-US;q328020&

    • Dette er et problem som oppstår når du kjører fra en mappet drive mot terminalserver og benytter SP3 for Windows 2000.


Rapport håndtering

4 Rapport-håndtering

4.1 Navneendringer

Tabellene ”Rapportdefinisjoner” og ”Rapportdefinisjonslinjer” i bedriftsdatabasene (som har vært med siden versjon 1.0), endrer navn (på skjermen) til ”Resultat/balansedefinisjoner” og ”Resultat/balansedefinisjonslinjer”. Kolonnene ”Rapportdef.nr” og ”Rapportdef. ID” endrer navn (på skjermen) til hhv. ”Res./bal.def.nr” og “Res./bal.def. ID”.

Memory-tabellen ”Rapportkolonner” endrer navn til ”Resultat/balansekolonner”.

h2>4.2 Rapportdefinisjoner

Systemdatabasen utvides med en tabell ”Rapportdefinisjoner”, hvor man kan legge inn en rad for hver rapport som er definertFootnotes]

  • Primærnøkkelen er et 32-bits heltallsfelt ”Rapportdefinisjonsnr”, som man f.eks. kan tildele neste ledige nr ved å taste ”+” i feltet.
  • I feltet ”Beskrivelse” kan man legge inn en beskrivelse av rapportdefinisjonen, på inntil 80 tegn.
  • Feltet ”Rapportgruppenr” er et 32-bits heltallsfelt som refererer til tabellen ”Rapportgrupper”, med nr og navn på rapportgrupper, som kan benyttes til å gruppere rapportdefinisjonene. Oppslag i dette feltet leder til denne tabellen.
  • Feltet ”Rapportsystem” angir hvilket rapportsystem rapportdefinisjonen er laget med. Oppslag i feltet leder til en liste med verdiene:

Visma Business

Crystal Reports

2. Visma Business Report Center

Feltet ”Rapportnr” angir rapportnummeret til rapporten, hvis det er en Visma Business rapport (Rapportsystem = 0). Oppslag i feltet leder til en liste med for tiden følgende valg:

0. Standard utskrift av sideelementene
177. Fakturaer/kreditnotaer
178. Fraktbrev
241. Etiketter
179. Pakksedler
180. Plukklister
181. Ordrebekreftelser
182. Tilbud
183. Bestillinger
184. Forespørsler
291. Produksjonsbestillinger
223. Bestillingsforslag
239. Prisliste
251. Leveransebeskjeder
162. Åpen postliste for kunder
301. Generalnotaer
163. Purre/renteforslag
164. Purrebrev
165. Rentenotaer
166. Kontoutskrift for kunder
167. Saldoliste for kunder
261. Refusjonsanmodning
168. Åpen postliste for leverandører
169. Remitteringsforslag
170. Remitteringsgiroer
171. Kontoutskrift for leverandører
172. Saldoliste for leverandører
173. Kontoutskrift for hovedbok
174. Saldoliste for hovedbok
175. Resultatregnskap og balanse
176. Avgiftsoppgave
226. Kontoutskrift for driftsmidler
235. Saldoliste for driftsmidler

Feltet ”Vindusnr” refererer da til vindustabellen, og i kombinasjon med ”Sideelementnr” til raden i tabellen med vinduselementer for hovedtabell-sideelementet, eksempelvis ordre-sideelementet hvis det er et ordredokument. Oppslag i vindusnr-kolonnen leder til vindustabellen, og oppslag i sideelementnr-kolonnen til vinduselement-tabellen.

  • Feltet ”Definisjonsfilnavn” angir filnavnet, inkludert stien, til filen som definerer rapporten (.rpt-filen) hvis det er Crystal Reports rapport (Rapportsystem = 1). Oppslag i feltet leder til dialogen for valg av filnavn.
  • Feltet ”GUID” angir rapportens GUID (Globally Unique IDentifier) hvis det er en Visma Business Report Center rapport (Rapportsystem = 2).
  • I tillegg kommer feltene ”Datasamling” og ”Rapportdef. ID”, som er til internt bruk for Visma, i forbindelse med oppgradering av Professional-oppsett og andre standardiserte datasamlinger.

4.3 Rapportdefinisjonsparametre

Til tabellen ”Rapportdefinisjoner” kan man koble en tabell ”Rapportdefinisjonsparametre”, hvor man legger inn en rad for hver parameter til en rapport.

  • Primærnøkkelen utgjøres av feltene ”Rapportdefinisjonsnr” og ”Parameternr”.

”Rapportdefinisjonsnr” refererer til en rad i tabellen ”Rapportdefinisjoner”, og elimineres ved kobling mot den (kolonnen skjules, og fylles ut automatisk på nye rader som legges til).

”Parameternr” er et linjenr som tildeles verdier automatisk av programmet.

Redigeringer i tabellen låser vedkommende rad i rapportdefinisjonstabellen. Ved sletting av en rapportdefinisjon, slettes også rader for den i tabellen med rapportdefinisjonsparametre.

  • Feltet ”Sorteringssekvensnr” tildeles verdier automatisk av programmet, og gjør det mulig å benytte menyvalget ”Rediger\Innsett” for å innsette rader mellom eksisterende.
  • ”Parameternavn” er et 40-tegns tekstfelt som inneholder navnet på parameteren.
  • I feltet ”Ledetekst” legger man inn en tekst på inntil 40 tegn, som er egnet som ledetekst når brukeren skal oppgi parameteren.
  • I feltet ”Datatype” angir man hvilken datatype verdiene til parameteren har. Oppslag i feltet leder til en liste med valgene:

Heltall

1.Desimaltall

2.Tekst

3.Dato

4.Avkrysning

Datoer (Datatype = 3) lagres datoen på formatet YYYYMMDD. Avkrysninger (Datatype = 4) lagres som 0 (False) eller 1 (True).

  • Hvis parameteren skal ha oppslagsmulighet i en tabell, angir man tabellnummeret i feltet ”Tabellnr”. Oppslag i feltet leder til en liste med nr og navn på tabeller. Tabellen med hovedbokskontoer har f.eks. tabellnr 65.
Tomt felt (verdien 0 i databasen) betyr ingen oppslag.

  • Feltet ”Kolonnenr” fylles ut hvis oppslag skal gjøres på en annen kolonne enn primærnøkkelkolonnen. Oppslag i feltet leder (for tiden) til en liste med følgende verdier, med relevans for oppslag i aktørtabellen (tabellnr 152):

4045. Kundenr

4046. Leverandørnr

4047. Ansattnr

Tomt felt (verdien 0 i databasen) betyr oppslag på primærnøkkelen i tabellen angitt i feltet ”Tabellnr”.

  • Feltet ”Standardverdi” er et 260-tegns tekstfelt, hvor man kan definere en standardverdi for parameteren. Feltet er initielt tomt. Alle typer verdier blir representert som tekst i dette feltet.

4.4 Bedriftsrapporter

Tabellen ”Bedriftsrapporter” kan kobles til bedrifter eller rapportdefinisjoner, og angir rapportdefinisjoner som er relevante for ulike bedrifter.

  • Primærnøkkelen utgjøres av feltene ”Bedriftsnr” og ”Bedriftsrapportnr”.

”Bedriftsnr” refererer til bedriftstabellen, og elimineres ved kobling mot den (kolonnen skjules, og fylles ut automatisk på nye rader som legges til).

”Bedriftsrapportnr” er et linjenr som tildeles verdier automatisk av programmet.

Redigeringer i tabellen låser vedkommende rad i bedriftstabellen. Ved sletting av en bedrift, slettes også rader for den i tabellen med bedriftsrapporter.

  • Feltet ”Sorteringssekvensnr” tildeles verdier automatisk av programmet, og gjør det mulig å benytte menyvalget ”Rediger\Innsett” for å innsette rader mellom eksisterende.
  • Feltet ”Rapportdefinisjonsnr” refererer til en rad i tabellen ”Rapportdefinisjoner”. Oppslag i feltet leder til denne tabellen. Merk at samme rapportdefinisjon kan anvendes flere ganger for samme bedrift.
  • Feltet ”Rapportparametre” kan benyttes til å overstyre parametre som er lagret med i oppsettet, hvis det er en Visma Business-rapport (Rapportsystem = 0). Parametrene er de samme som til kommandoen @REPORT_PARAMETERS i kommando/import-filer, og (med unntak av /R og /P) som benyttes i kolonnen ”Rapportparametre” i oppsett-tabellene. Mulige parametre er omtalt i tilknytning til de aktuelle rapportene i systemspesifikasjonene for ordre/logistikk og regnskap.
  • Memorykolonnen ”Verifiser parametre” visualiserer flagget med bitverdien 8 i feltet ”Bedriftsrapportbehandling”, for om jobbene som produseres med behandlingsmenyvalget ”Bestill rapport” skal gis jobbstatusen 0 (Registert) i stedet for 1 (Klar for utførelse).
  • Feltet ”Prioritet” forteller hvilken prioritet jobber som utfører rapporten skal ha.

-2 = Lavest

-1 = Under normal

0 = Normal

1 = Over normal

2 = Høyest

Visma Business rapporter defineres ut fra oppsettet som er referert til i feltene ”Vindusnr” og ”Sideelementnr”, og de følgende kolonnene gjelder ikke Visma Business-rapporter – med unntak av ”Filnavn”, som kan overstyres når ”Send til” settes lik 1.

  • Feltet ”Send til” angir hvor rapporten skal sendes til. Oppslag i feltet leder til en liste med valgene:

0.Skriver

1.Fil

2.E-postadresse

  • Feltet ”Skriveroppsettnr” kan fylles ut hvis rapporten skal skrives ut på skriver (når ”Send til” = 0). Oppslag i feltet leder til tabellen med skriveroppsett.
  • Feltet ”Filtype” angir hvilken type fil som skal lages (når ”Send til” = 1 eller 2). Oppslag i feltet leder i første omgang til en liste med valgene:

0.PDF

1.Excel

2.RTF

3.Tekst

  • Feltet ”Filnavn” angir navnet (inkludert stien) på filen som skal produseres når ”Send til” = 1 eller 2. Oppslag i feltet leder til dialogen for valg av filnavn.
  • Feltet ”Sti” kan i stedet fylles ut med en sti (inkludert f.eks. et underområde for bedriften) til området som rapporten skal legges på, hvis det er en Visma Business Report Center-rapport (Rapportsystem = 2). Oppslag i feltet leder til dialogen for valg av sti.
  • Feltet ”E-postadresse” fylles ut med en e-postadresse dersom rapporten skal sendes som e-post (når ”Send til” = 2).

4.5 Bedriftsrapportparametre

Til tabellen ”Bedriftsrapporter” kan det kobles en tabell ”Bedriftsrapportparametre”, som oppbevarer parametre til rapporten for den aktuelle bedriften.

  • Primærnøkkelen utgjøres av feltene ”Bedriftsnr”, ”Bedriftsrapportnr” og ”Parameternr”.

”Bedriftsnr” refererer til bedriftstabellen, og sammen med ”Bedriftsrapportnr” til tabellen ”Bedriftsrapporter”. Kolonnen elimineres ved kobling mot tabellene (kolonnene skjules, og fylles ut automatisk på nye rader som legges til).

”Parameternr” er et linjenr som tildeles verdier automatisk av programmet.

Redigeringer i tabellen låser vedkommende rad i bedriftstabellen. Ved sletting av en bedrift eller bedriftsrapport, slettes også rader for den i tabellen med bedriftsrapportparametre.

  • Feltet ”Sorteringssekvensnr” tildeles verdier automatisk av programmet, og gjør det mulig å benytte menyvalget ”Rediger\Innsett” for å innsette rader mellom eksisterende.
  • ”Parameternavn” er et 40-tegns tekstfelt som inneholder navnet på parameteren.
  • Verdien til parameteren oppbevares i feltet ”Verdi”, som er et 260-tegns tekstfelt. Alle typer verdier blir representert som tekst i dette feltet.

4.6 Bestille rapporter

I tabellen ”Bedriftsrapporter” er det et behandlingsmenyvalg ”Bestill rapport”, for å bestille markerte rapporter eller rapporten på den aktive raden (hvis ingen er markert). Merk at det kan bestilles rapporter for flere forskjellige bedrifter samtidig.

Menyvalget legger inn en rad i jobb-tabellen for hver bedriftsrapport, og tilhørende rader i tabellen med jobbparametre.

  1. Raden i jobb-tabellen fylles ut med informasjon fra

a)raden i bedriftsrapport-tabellen og

b)raden til bedriftsrapporten i rapportdefinisjonstabellen.

  2. Jobbparameter-tabellen fylles ut med 1 rad for hver rad til

a)bedriftsrapporten i bedriftsrapportparameter-tabellen, og

b)rapportdefinisjonen til bedriftsrapporten i rapportdefinisjonsparameter-tabellen, med parameternavn som ikke er tildelt en overstyrt verdi i bedriftsrapportparameter-tabellen, dvs. under a).

Parametrene kommer i den rekkefølgen de er lagt inn i rapportdefinisjonsparameter-tabellen. Deretter kommer eventuelle parametre i bedriftsrapportparameter-tabellen som ikke er med i den førstnevnte tabellen.

5 Jobb-håndtering

5.1 Jobber

I systemdatabasen er det en tabell ”Jobber”, som programmet fyller med 1 rad for hver jobb som skal utføres. Tabellen og de tilhørende tabellene omtalt nedenfor, kan også redigeres av brukeren (hvis han ikke er fratatt adgangen til det via adgangsgruppen angitt på raden hans i brukertabellen).

I tillegg til å oppbevare jobber som skal utføres, vil tabellen også inneholde informasjon om utførte jobber, inntil man velger å slette dem.

  • Jobbene identifiseres med hvert sitt ”Jobbnr”, som er et 32-bits heltall. Neste ledige nr kan tildeles ved å trykke ”+” i feltet.

Hva som skal gjøres og hvor

  • Feltet ”Jobbtype” angir hvilken type jobb som skal utføres. Oppslag i feltet leder til en liste med verdiene:

1.Behandling

2.Rapport

  • Feltet ”Bedriftsnr” refererer til bedriftstabellen, og angir hvilken bedrift jobben skal utføres i. Oppslag i feltet leder til bedriftstabellen. Feltet fylles ikke ut (dvs. har verdien 0 i databasen) hvis jobben er bedriftsuavhengig.
  • Hvis det er en behandling, eller en Visma Business rapport (Rapportsystem = 0), refererer feltet ”Vindusnr” til vindustabellen, og i kombinasjon med ”Sideelementnr” til raden i tabellen med vinduselementer for hovedtabell-sideelementet, eksempelvis et ordre-sideelement hvis det skal gjøres en behandling i ordretabellen eller en utskrift av ordredokumenter. Oppslag i vindusnr-kolonnen leder til vindustabellen, og oppslag i sideelementnr-kolonnen til vinduselement-tabellen.
  • Feltet ”Tabellnr” forteller hvilken tabell sideelementet representerer, og blir automatisk fylt ut når sideelementnr oppgis. Feltet er sperret mot redigering. Oppslag i feltet leder til en liste med nr og navn på tabeller. Ordretabellen har f.eks. tabellnr 127.

Behandling (Jobbtype = 1)

  • Feltet ”Behandlingsnr” angir hvilken behandling som skal utføres. Oppslag i feltet leder til en liste med nr og navn på behandlinger – i tabellen som er angitt i feltet ”Tabellnr”. Ferdigmelding av ordrer har f.eks. behandlingsnr 187.
  • Hvis det i stedet skal utføres en behandling skrevet via BIG, oppgis GUID’en til behandlingen i feltet ”GUID”. Se også avsnittet ”Starte behandlinger skrevet via BIG”.

Rapport (Jobbtype = 2)

Hvis det er en rapport (Jobbtype = 2), angir feltet ”Rapportsystem” hvilket rapportsystem som skal benyttes. Oppslag i feltet leder til en liste med verdiene:

Visma Business

1. Crystal Reports

2. Visma Business Report Center

  • Feltet ”Rapportnr” angir rapportnummeret til rapporten, hvis det er en Visma Business rapport (Rapportsystem = 0). Oppslag i feltet leder til en liste med samme valg som i tabellen med rapportdefinisjoner.
  • Feltet ”Rapportparametre” kan benyttes til å overstyre parametre som er lagret med i oppsettet, hvis det er en Visma Business-rapport (Rapportsystem = 0). Parametrene er de samme som til kommandoen @REPORT_PARAMETERS i kommando/import-filer, og (med unntak av /R og /P) som benyttes i kolonnen ”Rapportparametre” i oppsett-tabellene. Mulige parametre er omtalt i tilknytning til de aktuelle rapportene i systemspesifikasjonene for ordre/logistikk og regnskap.

Visma Business rapporter defineres ut fra oppsettet som er referert til i feltene ”Vindusnr” og ”Sideelementnr”, og de følgende kolonnene gjelder ikke Visma Business-rapporter – med unntak av ”Filnavn”, som kan overstyres når ”Send til” settes lik 1.

  • Feltet ”Definisjonsfilnavn” angir filnavnet, inkludert stien, til filen som definerer rapporten (.rpt-filen) hvis det er Crystal Reports rapport (Rapportsystem = 1). Oppslag i feltet leder til dialogen for valg av filnavn.
  • Feltet ”GUID” angir rapportens GUID (Globally Unique IDentifier) hvis det er en Visma Business Report Center rapport (Rapportsystem = 2).
  • Feltet ”Send til” angir hvor rapporten skal sendes til. Oppslag i feltet leder til en liste med valgene:

Skriver

Fil

E-postadresse

  • Feltet ”Skriveroppsettnr” kan fylles ut hvis rapporten skal skrives ut på skriver (når ”Send til” = 0). Oppslag i feltet leder til tabellen med skriveroppsett.
  • Feltet ”Filtype” angir hvilken type fil som skal lages (når ”Send til” = 1 eller 2). Oppslag i feltet leder i første omgang til en liste med verdiene:
    • PDF
    • Excel
    • RTF

3. Tekst

  • Feltet ”Filnavn” angir navnet (inkludert stien) på filen som skal produseres når ”Send til” = 1 eller 2. Oppslag i feltet leder til dialogen for valg av filnavn.
  • Feltet ”Sti” kan i stedet fylles ut med en sti (inkludert f.eks. et underområde for bedriften) til området som rapporten skal legges på, hvis det er en Visma Business Report Center-rapport (Rapportsystem = 2). Oppslag i feltet leder til dialogen for valg av sti.
  • Feltet ”E-postadresse” fylles ut med en e-postadresse dersom rapporten skal sendes som e-post når ”Send til” = 2).

Når og hvem

  • Jobbene tildeles prioriteter i feltet ”Prioritet”, som det kan sorteres på ved behandling av jobbkøen. Feltet er et 32-bits heltallsfelt, men prioritetene angis normalt bare i intervallet ‑2 til 2:

-2 = Lavest

-1 = Under normal

0 = Normal

1 = Over normal

2 = Høyest

  • Feltene ”Tidligste startdato” og ”Tidligste startkl.” kan fylles ut med tidligste dato og/eller klokkeslett jobben skal utføres på.
  • Feltet ”Opprettet av bruker” refererer til brukertabellen, og forteller hvem som la inn jobben. Feltene ”Opprettet av dato” og ”Opprettet av kl.” angir når jobben ble lagt inn. (Tilsvarende felter finnes i bl.a. ordretabellen.)

(Dette kommer i tillegg til feltene ”Endret av bruker”, ”Endret dato” og ”Endret kl.”, som er med i alle redigerbare tabeller, og som forteller hvem som har redigert jobben sist eller utført den, og når.)

  • Feltet ”Jobbgruppenr” er et 32-bits heltallsfelt som kan benyttes til å gruppere jobbene, f.eks. for å finne lettere tilbake til jobber som man ønsker å gjøre om igjen.

Tilbakemeldinger

  • Feltet ”Jobbstatus” forteller hvor langt behandlingen av jobben har kommet. Oppslag i feltet leder til en liste med verdiene:

Registrert

1. Klar for utførelse

2. Utført

En jobb som registreres av brukeren, får i utgangspunktet jobbstatus 0 (Registert). Jobber som produseres av behandlingsmenyvalget ”Bestill rapport” i tabellen med bedriftsrapporer, får verdien 0 i stedet for 1 (Klar for utførelse) hvis det er krysset av for ”Verifiser parametre” i den tabellen. Når brukeren har fått verifisert verdiene på jobb-raden og i jobbparameter-tabellen, kan han velge å endre jobbstatusen fra 0 til 1. Dette kan også gjøres på markerte rader med behandlingsmenyvalget ”Klar for utførelse”. (Dette menyvalget hopper over rader med andre statuser enn 0.)

Når behandlingsmenyvalget ”Utfør” har utført en jobb, endres jobbstatusen til 2 (Utført). Jobben er logist låst (via ”Prosessnr”-feltet) mens redigering eller utføring av jobben pågår.

En jobb kan gjøres om igjen ved å endre jobbstatusen tilbake fra 2 til 1, enten manuelt eller på markerte rader (eller den aktive raden) med behandlingsmenyvalget ”Gjør om igjen”. (Dette menyvalget hopper over rader med andre statuser enn 2.)

  • Feltet ”Utføringsstatus” er et 32-bits heltallsfelt, som forteller hvordan utførelsen av jobben gikk. Hver mulig utgang på en behandling kan være gitt et unikt nr. Feltet beholder verdien 0 hvis jobben ble utført som normalt.
  • Feltet ”Melding” kan inneholde en melding etter at jobben er utført, på inntil 260 tegn.

5.2 Jobbparametere

Til tabellen ”Jobber” kan det kobles en tabell ”Jobbparametre”, som oppbevarer parametre til jobbene.

  • Primærnøkkelen utgjøres av feltene ”Jobbnr” og ”Parameternr”.

”Jobbnr” refererer til jobb-tabellen, og elimineres ved kobling mot den (kolonnen skjules, og fylles ut automatisk på nye rader som legges til).

”Parameternr” er et linjenr som tildeles verdier automatisk av programmet.

Redigeringer i tabellen låser vedkommende rad i jobb-tabellen. Ved sletting av en jobb, slettes også rader for den i tabellen med jobbparametre.

  • Feltet ”Sorteringssekvensnr” tildeles verdier automatisk av programmet, og gjør det mulig å benytte menyvalget ”Rediger\Innsett” for å innsette rader mellom eksisterende.
  • ”Parameternavn” er et 40-tegns tekstfelt som inneholder navnet på parameteren.
  • Verdien til parameteren oppbevares i feltet ”Verdi”, som er et 260-tegns tekstfelt. Alle typer verdier blir representert som tekst i dette feltet.

For Visma Business-rapporter, angis parametre i kolonnen ”Rapportparametre” i jobb-tabellen.

5.3 Jobbrader

Til tabellen ”Jobber” kan det også kobles en tabell ”Jobbrader”, som oppbevarer primærnøklene til radene som skal behandles.

  • Primærnøkkelen utgjøres av feltene ”Jobbnr” og ”Radnr”.

”Jobbnr” refererer til jobb-tabellen, og elimineres ved kobling mot den (kolonnen skjules, og fylles ut automatisk på nye rader som legges til).

”Radnr” er et linjenr som tildeles verdier automatisk av programmet.

Redigeringer i tabellen låser vedkommende rad i jobb-tabellen. Ved sletting av en jobb, slettes også rader for den i tabellen med jobbrader.

  • Feltet ”Sorteringssekvensnr” tildeles verdier automatisk av programmet, og gjør det mulig å benytte menyvalget ”Rediger\Innsett” for å innsette rader mellom eksisterende.

Radene for en jobb blir behandlet i den rekkefølgen som denne kolonnen angir.

  • Feltet ”Primærnøkkel” inneholder verdien fra hver av primærnøkkelkolonne i den aktuelle tabellen (angitt i feltet ”Tabellnr” i jobb-tabellen), omgjort til tekst, og adskilt med tegnet ”|”. Feltet er 260 tegn langt.

Jobbrad-tabellen benyttes i første omgang bare i forbindelse med starting av behandlinger skrevet via BIG.

5.4 Utføre jobber

I jobb-tabellen er det et behandlingsmenyvalget ”Utfør”, for å utføre markerte jobber, eller jobben på den aktive raden.

Som alltid kan man på forhånd definere utvalgsvilkår, sortere radene (f.eks. på kolonnen ”Prioritet”), fylle ut verdier på søkeraden, og gjerne markere hele tabellen.

Bare jobber med jobbstatus 1 (Klar for utføring) vil bli startet, forutsatt at de ikke er under redigering eller utførelse (logisk låst via ”Prosessnr”-feltet). En jobb blir ikke utført hvis en eventuell dato og/eller et eventuelt klokkslett som er angitt på raden ikke er kommet.

Dialoger undertrykkes for rapporter. Etter hvert er det meningen at dette også skal kunne gjøres for behandlinger.

[1] Tabellen ”Rapporter” (som har vært med siden versjon 3.11), har noe av samme funksjonaliteten som tabellene ”Rapportdefinisjoner” og ”Bedriftsrapporter”, men gjelder bare Crystal Reports rapporter, mangler håndtering av flere bedrifter, definering av parametre og oppbevaring av verdier for dem, og er dessuten låst opp mot Visma Lønn. Visma Business-brukere som har anvendt denne tabellen, bør vurdere å ta i bruk de nye tabellene i stedet.


Rapportparametre i kommandofiler

Ved utskrift av resultat- og balanserapporter med @PRINT-kommandoen (eller forhåndsvisning med @PREVIEW-kommandoen) fra kommandofiler, kan man benytte parametrene nedenfor i @REPORT_PARAMETERS (”Rapportparametre”)-kommandoen, jf. systemspesifikasjonen ”Felles for delsystemene”.

Parametrene svarer til valg i resultat- og balanse-dialogen omtalt foran.

Oppsett

Parametrene /B, /D, /F, /E og /C (men ikke /PR, /PC1, /PC2, /PA, /PB1, /PB2, /OU, /XPL og /XB) lagres også med i oppsettene, når man velger å lagre et oppsett etter en utskrift eller forhåndsvisning, jf. kolonnen ”Rapportparametre” i tabellene med vinduer og arbeidsområdevinduer.

I oppsettene lagres også parameteren /R9, som erstattes av rapportvariantnr-parameteren til @PRINT (175)- eller @PREVIEW (175)-kommandoen.

Periode-intervall

Følgende parametre etterfølges av fra år, fra periode, til år og til periode, adskilt med komma:

  • Realisert: /PR
  • Sammenligning 1: /PC1
  • Sammenligning 2: /PC2
  • Tillegg til realisert: /PA
  • Budsjett 1: /PB1
  • Budsjett 2: /PB2

Budsjettnr

/B etterfulgt av inntil 3 budsjettnr (tillegg til realisert, budsjett 1 og budsjett 2), adskilt med komma.

Rapportdefinisjonsnr

/D etterfulgt av et rapportdefinisjonsnr definert i rapportdefinisjonstabellen.

Resultat- og balanserapportflagg

/F etterfulgt av summen av ønskede bit-verdier blant følgende resultat- og balanserapportflagg:

64 (0x00000040): Spesifiser kontoer.
128 (0x00000080): Les saldoer samlet.

Ansvarsenhetsklasser

/OU etterfulgt av numrene på eventuelle ansvarsenhetsklasser (1 - 6) som det skal rapporteres på (jf. ansvarsenhetsdelvinduer i oppsettet), og i ønsket rekkefølge, adskilt med komma. F.eks. ”/OU1,2”.

Rapportvalutatype

/E etterfulgt av en av følgende rapportvalutatyper:

  1. Standard valuta
  2. EURO
  3. Konsernvaluta
  4. Annen valuta

Valutanr

/C etterfulgt av valutanr. Denne parameteren benyttes i kombinasjon med /E3.

Resultat- og balanse-valutakurser

/XPL og /XB etterfulgt av hhv. en resultat- og balanse-valutakurs. Eventuelle desimaler angis med punktum som desimalseparator.


Oppgradering av skjermbilder

Bakgrunn

Til versjon 5.0 ble det implementert et nytt sett med standard skjermbilder for nyinstallasjon av Visma Business. Det er naturlig at forhandlere/eksisterende kunder tar utgangspunkt i disse dersom de skal designe/bygge opp nye skjermbilder etter oppgradering til 5.0.

I versjon 5.0 finnes det i tillegg mange nye og spennende designmuligheter som gjør at kundene kan få bedre/enklere skjermbilder. Vi anbefaler derfor at eksisterende kunder sammen med forhandler vurderer om dagens skjermbilder fungerer hensiktsmessig..

Hvilke muligheter kunden har til å ta i bruk dette nye skjermbildeoppsettet og til å tilpasse sitt eksisterende oppsett avhenger av kundens lisens. Vi har per i dag 4 forskjellige lisenstyper + Visma Regnskapsbyrå. Regnskapsbyråløsningen vil ikke bli beskrevet her.

Visma Business Design

Ved oppgradering beholdes eksisterende oppsett. Kunden kan tilpasse og endre skjermbildene som ønsket. På forhandlerlounge finnes det et dokument med en beskrivelse av fremgangsmåten for å legge nytt skjermbildeoppsett i tillegg til eksisterende. Dette er hensiktsmessig der hvor kunden har gjort endel tilpassninger selv, men gradvis ønsker å ta i bruk vårt nye skjermbildeoppsett med sine spesialtilpasninger.

Visma Business Professional

Kunde vil ved oppgradering beholde det oppsettet som ble implementert i versjon 4.60. Dette betyr at kunden IKKE automatisk får oppgradert skjermbildene sine til nytt oppsett. Det som skiller en Visma Professional lisens fra en Lisens på Visma Business Design er:

  • I Professional lisensen så er det en begrensning som gjør at kunden kun kan endre og tilpasse i skjermbilder beregnet for utskrift. Dette er skjermbilder som har blitt kjent som
    "* skjermbildene". Disse skjermbildene er merket med en * i navnet.
  • Ved oppgradering kjøres det et ekstra importsteg for oppgradering av skjermbilder. Dette importsteget forutsetter at det følger med skjermbildeoppsett som er tilpasset en slik oppgradering. Nytt skjermbildeoppsett til versjon 5.0 er ikke tilpasset dette.

Dette fører til at kunder med Professional lisens ikke skal importere skjermbildeoppsett for versjon 5.0. Konsekvensene av å gjøre det er:

  • Ingen skjermbilder kan tilpasses da det ikke er noen "* skjermbilder" i versjon 5.0 skjermbildene.
  • Ved oppgradering til neste hovedversjon så vil ekstra importsteg for oppgradering av skjermbilder bli kjørt med bakgrunn i 4.60 skjermbilder og alt nytt vil være tapt.

Visma Business 3.x

Som Visma Business Design.

Visma Micro80

Samme lisens som Visma Business Professional, men er ikke begrenset av andre tilpassningsmuligheter annet enn at det ikke er anledning til å koble eller inkludere. Det kjøres heller ikke et ekstra importsteg ved oppgradering.


Oppgradering av spesial / bransje

Spesialversjoner
Visma Micro80 og Visma Byrå/Advokat som er nyinstallert på versjon 3.x. (Ikke de som har nyinstallert Visma Byrå/Advokat versjon 4.x).
Disse har en annen verdi i mastertabellen.
Disse spesialversjonene har gamle oppsett og har derfor startvindu som åpningsvindu. De har også tilgang til "litt design", men ikke koble og inkludere.

Når disse skal oppgraderes, kan de benytte både Visma Business Design, Visma Business Professional og Visma Business Byrå/Advokat cd. Det vil ikke automatisk bli lagt inn nye skjermbilder da de har annen verdi i mastertabellen (som indikerer at det er en spesialversjon). Da beholder de sine gamle bilder og får kun oppgradert programmet. De beholder sin gamle funksjonalitet selv om de oppgraderer til nyere programversjon.

Visma Business Regnskapsbyrå / Advokat som er nyinstallert på versjon 4.x er ingen spesialversjon (kan ikke gjøre noen i design (lagre skjermbilder/utvalg/+ + +)) og skal derfor benytte Visma Business Regnskapsbyrå / Advokat cd for oppgradering. Automatisk oppgradering av Byrå/Advokat skjermbilder.

Visma Business Professional skal benytte Visma Business Professional cd til oppgradering. Automatisk oppgradering av skjermbilder.

Visma Business Design skal selvfølgelig benytte Visma Business Design cd til oppgradering. Ingen oppgradering av skjermbilder.

NB! Dersom du har installert Visma Business (med Visma Business lisens) før versjon 4.x og har importert f.eks. Professional skjermbildene, så vil det ikke foretas noen oppgradering av disse ved oppgradering til ny versjon. Det testes nemmelig på lisensen.


Visma Business Design og bruk av oppsett for Visma Business Regnskapsbyrå eller Visma Business Advokat

Til 4.30 er det lagt inn strengere tester vedrørende lisensiering. Det innebærer at kunder som kjører Visma Business Design ikke har tilgang til oppsettet for Visma Business Regnskapsbyrå og Visma Business Advokat.

Årsaken er at Visma Business Regnskapsbyrå er lagt i vindusnummerserie innenfor 400 000 og Visma Business Advokat i vindusnummerserien 500 000. Kunder med Visma Business Design har ikke tilgang til å åpne oppsett med vindusnummer innenfor disse seriene.

Dette vil også ramme de som har laget egendefinerte vinduer i disse seriene. Disse vinduene kan flyttes på fler måter. Ett alternativ er å eksportere vinduene og så importere dem i korrekt serie. Dersom du skal gjøre dette bør du følge denne framgangsmåten.

Ønsker kunden fortsatt å benytte disse bildene må de/dere selv endre nummerserien på disse. Det kan f.eks gjøres via et script (eksempel på script) som flytter alle i 400 000-serien til et lavere vindusnummer (f.eks 200 000 nummer lavere). Selvfølgelig må ikke disse krasje med eksisterende vinduer hos kunden. NB! De kan ikke flyttes til 100 000-serien for de benyttes av Visma Lønn.


oppsett

EDI og XML

Her finner du tips og gode råd for EDI og XML i Visma Business.


Edi i Visma Business

Formål: Hva skal man ta hensyn til når man skal sette igang med standard EDI i Visma Business

Eksport/Importformat
Betegnelsen importformat er noe missvisende, da det blir brukt samme format både for eksport av data (for eksempel utlegging av betalingsanmodning til bank) og import av data (for eksempel innlesing av returdata). Vi vil likevel benytte denne betegnelsen i denne beskrivelsen.

Hva er en importdefinisjon?
En importdefinisjon er en tekstfil som inneholder en spesifikasjon av de feltene som blir lagt ut fra/lest inn til Visma Business.

Formatet spesifiserer koblingen mellom de reelle dataene i Visma Business og dataene slik de er plassert i tekstfilen. Definisjonen inneholder også beskrivelse av feltenes formater, innbyrdes plassering og liknende.

Når bør du definere egne formater?
Visma har tilpasset en del formater. Dette gjelder blant annet formater for de vanligste banker, formater tilpasset EDI import/eksport på Visma Business interne formater samt ulike factoringformater. Dersom du har behov for å benytte et utvekslingsformat som Visma Business ikke er tilrettelagt for, bør du gjøre følgende:

  1. Finne ut hva slags formater og rutiner banken/partneren benytter i dag. Det kan være at du kan benytte et av de eksisterende formatene direkte.
  2. Vurdere om du skal tilpasse formatet selv, eller be forhandler om bistand.

NB! Se i dokumentasjonen for å lære mer om hvordan tilpasse imp-filer.

EDI - Meldinger
Tabellen EDI meldinger:

Meldingstype:
Her definerer du meldingstypen. Det vil si hva slags import eller eksport det er snakk om.

  • Er det en endring på en eksisterende ordre?
  • Er det en ny ordre som du skal sende til en leverandør?
  • ...

Retning:
Her kan du velge hvilken retning denne meldingen skal ha. Du kan velge mellom inngående melding (1. Inn) eller utgående melding (2. Ut).

EDI-Mal:
Her kan du velge hvilken mal-fil som Visma Business skal benytte ved behandling av denne meldingen. Mal-filene har etternavn imp. En imp-fil beskriver formatet på, og innholdet i, filen som blir lest inn/lagt ut.

Import
Automatisk import av EDI-meldinger:
Du kan sette opp Visma Business til å lese inn EDI-meldinger automatisk. Du kan velge å lese inn meldinger på ett gitt tidspunkt, eller med et gitt tidsintervall. Du forteller Visma Business hvordan du vil styre importen ved å fylle ut feltene i dialogboksen EDI-Kloke. Dialogboksen får du fram ved å velge Opsjoner/EDI-Klokke på menylinjen (i alle vinduer).

Ved hjelp av dette menyvalget kan du starte og stoppe automatisk innlesing av EDI-meldinger. Hvis EDI-klokken allerede er startet fra din sesjon, vil Visma Business sette en hake ved siden av menyvalget. Feltet EDI-sesjon i tabellen Aktive sesjoner viser fra hvilken sejsjon EDI-Klokken er startet.

Eksport
Valg av sendemåte for dokumenter (Aktører og Ordre):
Du må fortelle Visma Business hvordan du ønsker å behandle de ulike dokumenttypene (EDI-meldinger). Dette gjelder både kunder, leverandører og ordredokumenter. Du spesifiserer dette ved å krysse av i de rette kolonnene i dialogboksen "Sendemåte for dokumenter", som er koblet til fletet "Sendemåte for dokumenter" i tabellen Aktører. Tilsvarende dialog er koblet til samme felt i ordrehodet, hvor du kan overstyre parameterene fra tabellen Aktører for hver enkelt ordre.

Du kan velge sendemåte for følgende dokumenter:

  • Fakturaer
  • Pakksedler
  • Leveransebeskjeder
  • Ordrebekreftelser
  • Bestillinger

For hver dokumenttype kan du krysse av for:

  • Post (vanlig utskrift på skriver). Du må krysse av her dersom du også vil ha en vanlig utskrift av dokumentet.
  • E-post (dokumentet blir sendt via E-post til mottakeren). Dette valget krever at du har installert et E-post system, og at du har registrert en
    E-postadresse for denne aktøren.
  • Faks (dokumentet blir sendt via faks til mottakeren). Dette valget krever at du har installert en faks-gateway, og at du har registrert et faktsnummer for denne aktøren.
  • EDI (dokumentet blir sendt via EDI til mottakeren. Du kan ikke bruke dette valget for Pakksedler og Leveransebeskjeder.

Du kan velge flere forsendelsesmåter for hvert dokument. Du kan godt velge å ha både Post og EDI som forsendelsesmåte for fakturaer.

Hvor lagres filene/leses EDI-filene fra

EDI-filene blir plassert i mapper hvis du har krysset av i feltet EDI-Mapper i tabellen Systemopplysninger.

Ellers får filene unike navn av Visma Business. Mappene blir opprettet under F0001, F0002 etc. på Visma Business sitt programområde, hvis ikke annet er registrert i EDI_PATH i registry.

NB! Det er viktig at den EDI-brukeren som skal lese inn/eksportere ut filer har les og skrive adgang til dette område på serveren.


Hvordan importere order og kunder/leverandører samtidi

Hvordan importere order og kunder/leverandører samtidig

Du kan importere en kunde eller leverandør samtidig som du importerer en ordre. Ved å bruke "Actor" definisjonen og angi linjene med "A" istedet for "H" for Head (ordrehode) eller "L" for linje, kan du kjøre denne definisjonen samtidig som en ordre blir importert.

Når du angir en linje med "A", vil endrede felter som for eksempel nytt telefonnummer bli oppdatert hvis du har tastet inn et eksisterende kundenummer. Hvis alle feltene er nye, vil ny kunde bli lagret.

Feltene blir definert på samme måte som ordrefeltene "Actor.ActNo", "Actor.Nm" og så videre.

Det blir opprettet et "Aktørnr" hvis en kunde eller leverandør ikke finnes i tabellen fra før.

MERK! Oppdatering av eksisterende kundedata skjer ikke ved import.

Eksempel:

Ordersr.imp

a,1,;,1,,,,,,,,,,,,,,,,,,,,,,,,,,

b,Actor,1,,1,

c,RecType,1,1,0,,,,,,,,,S,

c,Actor.CustNo,2,10,0,,,,,,,,,I,

c,Actor.Nm,3,40,0,,,,,,,,,S,

b,OrderHead,1,,1,

c,RecType,1,1,0,,,,,,,,,S,

c,Ord.OrdDt,2,10,0,YYYYMMDD,,,,,,,,D,

c,Ord.CustNo,3,10,0,,,,,,,,,I,

c,Ord.Nm,4,40,0,,,,,,,,,S,

c,Ord.Ad1,5,40,0,,,,,,,,,S,

c,Ord.Ad2,6,40,0,,,,,,,,,S,

c,Ord.Ad3,7,40,0,,,,,,,,,S,

c,Ord.Ad4,8,40,0,,,,,,,,,S,

c,Ord.PNo,9,10,0,,,,,,,,,S,

c,Ord.PArea,10,40,0,,,,,,,,,S,

b,OrderLine,1,,1,

c,RecType,1,1,0,,,,,,,,,S,

c,OrdLn.LnNo,2,10,0,,,,,,,,,I,

c,OrdLn.ProdNo,3,40,0,,,,,,,,,S,

c,OrdLn.Descr,4,60,0,,,,,,,,,S,

c,OrdLn.Un,5,10,0,,,,,,,,,I,

c,OrdLn.NoInvoAb,6,16,0,,,,,,,,,S,

c,OrdLn.Price,7,16,0,,,,,,,,,S,

c,OrdLn.Dc1P,8,16,0,,,,,,,,,S,

b,DummyLayout,1,,1,

c,RecType,1,1,0,,,,,,,,,S,

Ordersr.edi

A;10600;Olsen AS

H;;;1;;;10600;Olsen AS;Strandgt 4;Pb 24;;;1602;FREDRIKSTAD;;;;;;;;;;;;15;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;30

L;;1000;;1;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;1

L;;1001;;3;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;1

L;;1002;;5;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;1

L;;1003;;7;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;1

L;;1004;;9;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;1

L;;1005;;11;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;1

(edi-filen skal ikke ha linjeskift i H-recorden)


Overføre ordre fra EDI

Overfør ordre via EDI (til annen klient i Visma Business)

Dette eksemplet beskriver en framgangsmåte for å overføre ordre til en annen intern klient. Et eksempel kan være å lage en intern bestilling som legges over til en annen klient som salgsordre.

Lag to imp-filer med nødvendige felter. I dette eksempelet er det lagt inn en fastverdi i kundenummer (10012), dette er vårt kundenummer i ”inn-klienten”.

Tabellen viser begge imp-filene i samme tabell. I bruk skal ordut.imp ligge i ”fra-klient” og ordinn.imp i ”til-klient".

I ”Sendemåte for dok” må du krysse av for å sende bestilling pr EDI:

Edi filen (ordersw.edi) som lages ved godkjenning av bestilling må flyttes fra katalogen

\Visma\Business\Fxxxx\ORDERSW
til
\Visma\Business\Fxxxx\ORDERSR

Dette kan utføres av en ekstern applikasjon, bat-fil eller lignende. Eksempel på innhold i bat-fil: move ordersw.edi "C:\Program Files\Visma\Business\F0107\ORDERSR". EDI-klokken må være startet. Ved import opprettes følgende salgsordre:

Ordinn.imp kan du hente her

Ordut.imp kan du hente her


Visma XML

Foreløpig har vi kun støtte for Faktura, Bestilling og Ordrebekreftelse
Dette må settes opp for å få Visma XML til å fungere:

Leverandør:

Må fylle ut feltet ”GLN/GS1 nr.” – dette for å ha et unikt nr. for evt. innlesing. Dette nr. får leverandøren oppgitt. Det kan være et EAN nr. eller et ORG.nr.

E-dokumentinformasjon: (Ordre/Logistikk – Faste opplysninger)

Her må du fylle ut:
”Melding” – Visma XML Ordrebekreftelse/Faktura/Bestilling
”Skriv til fil” – Hvor XML filene skal mellomlagre seg
”Kjøring status” – Om det er test-kjøring eller i produksjon
”Brukernavn” – Brukernavnet du trenger for å koble deg opp mot den eksterne mottaker
”Formularnr.” – Disse formularene må ligge i tabellen Formularer (111, 112, 113)
”Nedlastingssti” – Adressen til serveren du skal hente XML-filene fra. For FTP bruk
”Opplastingssti” – Adressen til serveren du skal legge XML-filene ut på. For FTP bruk
”Format ID” – Hvilket format du vil eksportere fakturaer, bestillinger og ordrebekr.

  • Faktura = 104
  • Ordre = 204
  • Ordrebekreftelse = 304

E-dokument: (Ordre/Logistikk – Faste opplysninger)

Her må du fylle ut:
”Format ID” – Faktura, Bestilling og Ordrebekreftelse
”XLS filnavn” – Her skal ikke stien ligge, men kun filnavn. Denne filen finnes på IMP katalogen til Visma Business. Dette er programmert

Bedriftsopplysninger:

Feltet ”Ordrebehandling” og parameteret ”Bruk Visma XML format” må være haket av.

Formularer:

Formularer for Faktura, Bestilling og Ordrebekreftelse må opprettes i denne tabellen.

  • 111 = Faktura
  • 112 = Bestilling
  • 113 = Ordrebekreftelse

Disse må stemme overens med det du har angitt i tabellen E-dokumentinformasjon

EDI transaksjonslogg: (Ordre/Logistikk – Ordrer)

Her sender du og henter og evt. ser på XML filene

Diverse feilsituasjoner:

Feilsituasjon:
Får følgende feilmelding ved utskrift til Edi fil: "Unknown error 0x80131600"

Løsningsforslag:
E-dokument informasjon pekte på et formular som ikke fantes.


Design i Visma Business

Hvordan benytte opptaksfunksjonene i Designverktøylinjen til å ta med verdier fra et skjermbilde til et annet?

Hvordan benytte virtuelle bøker til å bygge bilder med ”drilldown”?

For forklaring på fargelegging, bildefiler og annen generell Design, se Designguide.

Eksempel 1

Opptak: Ta med verdi fra en celle i en tabell og gjøre søk på denne verdien i en annen tabell.

Til tabellen Åpne kundeposter skal vi lage en knapp som skal ha følgende funksjon:

  • Kopierer bilagsnummeret fra den raden markøren står i
  • Åpner tabellen Oppdaterte bilag
    • Arial'>
  • Tar frem søkelinjen i denne tabellen og limer inn bilagsnummeret

Vi starter med å splitte tabellen Åpne kundeposter ved å høyreklikke i tabellen i Designmodus.

I den splittede tabellen fjerner vi alle felter, bortsett fra feltet Bilagsnummer. Via Design fjerner vi også marg, tittellinje, setter antall overskriftslinjer til 0 og gjør tabellen så liten som mulig:

Grunnen til at tabellen splittes er at vi ønsker å sikre at det kopieres fra riktig kolonne i tabellen. Kopieringen av bilagsnummeret vi senere skal gjøre i opptaket på knappen, gjøres derfor i den splittede tabellen. Dermed ”tvinges” opptaket til å kopiere fra riktig kolonne, nemlig Bilagsnummer. Den splittede tabellen settes også med disse parameterne fra Designverktøylinjen:

Hopp over

Ikke flytt i forgrunnen

Dette settes for at tabellen ikke skal flytte seg foran knappen som vi senere skal plassere over den splittede tabellen.

Videre inkluderer vi en knapp i bildet, legger på ønsket bildefil og tekst.

Før vi starter opptaket er det også greit å åpne det bildet opptaket skal ta deg til, i vårt tilfelle Oppdaterte Bilag. Dette har ingen funksjonell verdi, men det gjør det litt enklere når opptaket skal spilles inn. En annen forberedelse som bør gjøres er å sørge for at man slår av ”Flytt sideelementer”. Dette gjøres når man er i Designmodus ved hjelp av dette ikonet på Designverktøylinjen [image] eller hurtigtast Ctrl+M.

Da er vi klare til å starte opptaket.
I Designmodus markerer vi først knappen, og slår så av ”Flytt sideelementer”.
Deretter starter vi opptaket med dette ikonet på Designverktøylinjen

Marker så i denne rekkefølge:

  • Den splittede tabellen - og trykk Ctrl+C (kopier)
  • Gå til vinduet Oppdaterte bilag via menyvalget Vindu
  • Plasser markøren i kolonnen Bilagsnummer, som må være den første kolonnen i denne tabellen
  • Gå via menyvalget Vis - Gå til - Første felt
  • Hent frem søkelinjen (Ctrl+F) eller ved hjelp av dette ikonet
  • Trykk så Ctrl+V (lim inn)
  • Fjern så søkeraden (Ctrl+F) eller ved hjelp av samme ikon som for hent søkelinje
  • Stopp opptaket ved hjelp av det samme ikonet som vi klikket for å starte

Så plasseres knappen over den splittede tabellen for kosmetikkens skyld.

Til sist kan vi inkludere en knapp i vinduet Oppdaterte bilag, og spille inn et opptak på denne som tar oss tilbake til vinduet Åpne kundeposter.

Marker da i denne rekkefølge:

  • Plasser markøren på den inkluderte knappen
  • Klikk på ikonet for opptak
  • Gå til vinduet Åpne kundeposter via menyvalget Vindu
  • Plasser markøren i tabellen
  • Klikk opptaksikonet igjen for å stoppe opptaket

Eksempel 2

”Drilldown” ved hjelp av Virtuelle bøker

Vi skal nå se på hvordan vi kan benytte Virtuelle bøker for å lage en slags Drilldown, dvs. se underliggende transer. Denne metoden er benyttet bl. a. i vårt standard skjermbilde 503. Panorama søk (versjon 4.50).

I dette eksempelet tar vi utgangspunkt i aktørtabellen og ordretabellen. Vi skal lage et bilde hvor vi kan hente ordreinformasjon på de ulike kundene. Dette blir dermed en ”kortversjon” av hvordan Panoramabildet er bygget opp.

Vi starter med å inkludere aktørtabellen, og gjøre utvalg slik at dette blir en ”kundetabell”. Tabellen lagres med søkelinjen fremme og via ”Andre preferanser” settes tabellen til ”Tom inntil søk/utvalg”, slik at dette blir et søkevindu. Dette er en fordel også ved åpning av bildet mht. hastighet.

Deretter kobles ordretabellen til aktørtabellen via nøkkelen Kundenr>Kundenr. Vi skal kun ha feltet Fakt. beløp i fremt. fremme. Etter at alle andre felter er fjernet, setter vi tabellen i skjemaformat ved hjelp av dette ikonet [image] eller hurtigtast Ctrl+T. Vi ønsker at dette feltet skal vise tilbud eks. mva. Vi gjør derfor følgende utvalg i tabellen:

Deretter døper vi feltet Tilbud eks. mva, og setter på ”Ta med totallinje” og ”Vis bare bruddlinjer” i sorteringsdialogen. Bildet vårt ser da foreløpig slik ut:

Det neste vi gjør er å inkludere en Virtuell bok. Dette gjøres ved å holde SHIFT nede samtidig som man trykker på dette ikonet [image] på Designverktøylinjen. I Designmodus høyreklikker vi så på boken og velger Uavhengig plasserte sidemerker.

Dette gjør at vi fritt kan plassere sidemerkene i skjermbildet. Vi gir boken ønsket design med bildefiler beregnet til knapper (i dette eksempelet har vi brukt Small.gif og Small_1.gif. Disse ligger under Layout, Regular) og passende tekst, og plasserer ett av sidemerkene til høyre for ordretabellen (Tilbud eks. mva).

Videre kobles ordretabellen på nytt til aktørtabellen, og ordrelinjer kobles til ordretabellen. I ordretabellen gjøres de samme utvalg som vi gjorde i Tilbud eks. mva, og så setter vi på ”Ta med totallinje” i sorteringsdialogen. Disse to tabellene knyttes til den siden som vi plasserte til høyre for Tilbud eks. mva, slik at når vi klikker på denne siden får frem de ordre og ordrelinjer som ligger til grunn for beløpet i Tilbud eks. mva. De to øvrige sidene har foreløpig ingen funksjon.

På neste side skal vi lage et detaljbilde for å se hvor stor ordrereserve vi har. Igjen så kobles ordretabellen til aktørtabellen. Vi fjerner felter og sitter igjen med Fakt. beløp i fremt. nok en gang. Vi døper feltet Ordreres. eks. mva og plasserer tabellen til høyre for den første detaljsiden vi lagde. Ordretabellen kobles igjen til aktørtabellen og ordrelinjer kobles til ordre.

Disse 2 ”nye” ordretabellene settes opp med følgende utvalg slik at riktige verdier presenteres:

Tabellene gis ønsket farge, og neste side plasseres til høyre for Ordreres. eks. mva. Ordre og ordrelinjer knyttes til denne siden.

Den siste siden skal gi oss en oversikt over hva vi totalt har omsatt for til de ulike kundene. Vi kobler derfor produkttransaksjoner til aktørtabellen og fjerner alle felter bortsett fra beløp. Kolonnen døpes om til Totalt kunde. Vi tar frem sorteringsdialogen til denne tabellen og setter på ”Ta med totallinje” og ”Vis bare bruddlinjer”.

Deretter gjør vi samme kobling en gang til. Produkttransaksjonstabellen som skal gi oss detaljer sorteres med brudd på produktnummer, og vi setter på ”Ta med totallinje”.

Til slutt ønsker vi at bildet skal lagres slik at ingen av detaljsidene er aktive når bildet åpnes. For å få til dette trenger vi en side til i den virtuelle boken. Denne siden plasseres helt oppe i hjørnet og gjøres ”usynlig”. Vi legger først på en side til i boken:

I Designmodus høyreklikker vi på den ny siden og slår av ”Like sidemerker”

Deretter henter vi en bildefil som hjelper oss å gjemme denne siden (I Layoutmappen, under Buttons og Regular ligger White.bmp. Denne er brukt i dette eksempelet). Denne benyttes både på aktiv- og inaktiv side. Teksten setter vi f. eks til ”1”, eller noe annet som tar liten plass. Denne teksten har ingen annen funksjon enn at den hjelper oss å finne denne siden igjen ved behov.

Det er denne siden vi ønsker å ha aktiv ved åpning av bildet, slik at alle de andre sidene er inaktive. Når bildet åpnes vil det se slik ut:

Nå kan vi gjøre søk på kundenummer og hente de detaljene vi er på jakt etter. Ønskes det flere nivåer eller annen type informasjon så utøkes antall sider i boken. Logikken vil være den samme, med kobling av tabeller, utvalg etc. Teknikken fra det første eksempelet i dette dokumentet, med kopiering av verdi til annet skjermbilde, kan vi også legge inn i ett og samme skjermbilde.


Drill-trugh

Til versjon 5.0 av Visma Business så ble introdusert en funksjon for å ta med seg informasjon/nøkkelverdier fra en tabell og over til en annen. Dette kalles Drill-trugh. Denne funksjonen kan gjøres fra alle tabeller inne i Visma Business.

Fremgangsmåten er:

Design et skjermbilde hvor du har noen nøkkeltall/informasjon du ønsker å se detaljene/opphavet til.

Her er det Ordrereserve eks. MVA vi ønsker å se detaljene på.

Detaljene designes i et eget skjermbilde:

Her er kundeinformasjon (aktørtabellen) hentet frem og så er kundens ordrer koblet til under. I ordretabellen så er det gjort et utvalg som viser kun de ordrer som ikke er levert

På Ribbonen ”design” så aktiveres et menyvalg som heter parametere når skjermbildet settes i designmodus.

Når dette velges så kommer det opp en dialog hvor det kan defineres parametere.

Vi velger å kalle det kundenr med formatet tekst.

I utvalget på aktørtabellen så lager vi et utvalg som sier:

Kundenr skal være lik parameteret kundenr.

Lagre dette vinduet.

Det kan defineres et fritt antall parametere. Formatet må vær = kolonnens format.

NB! På felter lik f. eks kundenr så benyttes tekst som format fordi du ikke skal ha med tall etter desimaler.

Inkluder en knapp i det skjermbildet hvor du har noen nøkkeltall/informasjon du ønsker å se detaljene/opphavet til.

Start opptak på knappen:

Klikk markøren innom den tabellen hvor parameteren skal hentes fra. I skjermbildet så stiller vi markøren i aktørtabellen for å ta med kundenr.

Åpne deretter skjermbildet med detaljinformasjonen.

Dialog for å ”angi formel for parametere” kommer opp.

Her legges koblingen mellom parameteren kundenr og kundenr i aktørtabellen opp.

Stopp opptaket.

Lagre begge skjermbildene.


Adgangsregulering i Visma Business

Adgangsregulering i Visma Business!

Visma Business er et økonomisystem med mange muligheter. For en del bedrifter er det viktig å kunne sette ulik adgang på ulike brukere. Noen skal f.eks. kun registrere ordre og ikke ha tilgang til regnskapstabellene, mens andre kanskje kun skal ha tilgang til regnskapstabellene. I Visma Business Design finnes muligheten for å designe egne skjermbilder. Dette skal ofte begrenses til noen få brukere, det er derfor veldig viktig å sette opp en adgangsregulering som tar hånd om dette.

Brukerdokumentasjonen beskriver de ulike adgangsreguleringene du kan sette. Her skal vi ta for oss en liten del, under Tabeller – Felles – Brukere – Adgangsgrupper.

Den gruppen du her gjør endringer på, må angis i Brukertabellen utfor den aktuelle brukeren i feltet Adgangsgruppenr. Ved å markere en adgangsgruppe og velge Behandling, har du 3 muligheter:

Tabelladgang
Kolonneadgang
Funksjonsadgang

Det vi skal vise her er en av adgangsreguleringsmulighetene som ligger under Funksjonsadgang. Velg Type = Diverse, se under:

Redigere mapper/oppsett

Her har du mulighet til å gi kun få brukere tilgang til å slette, endre navn o.l på mapper og skjermbilder. Brukeren som ikke har tilgang til dette, vil få nesten alle valgene nedtonet dersom det høyreklikkes på et skjermbildet:

Dette ikonet (åpne) vil også bli nedtonet, og brukeren har heller ikke mulighet til å åpne med Ctrl + O. Denne er spesielt viktig å sette dersom du har Visma Business Design og kun har en bruker som skal ta hånd om å designe.

Tabellmapper

Settes det adgangsregulering på dette valget, hindrer du brukeren i å få tilgang til Tabellmappene. Tabellmappene er de nederste mappene i Visma Utforsker, Tabeller:

Felles
CRM
Ordre/logistikk
Lønn
Regnskap

Dette ikonet (åpne) vil bli nedtonet og brukeren har heller ikke mulighet til å klikke Ctrl+O for å åpne.

Slette/endre utvalgsvilkår

Du kan forhindre brukere i å slette og endre utvalgsvilkår, med valget "Slette/endre utvalgsvilkår". Trykknappene for "Slett" og "Endre" vil da være nedtonet i utvalgsvilkår-dialogen og radiobutton-en "Eller" i dialogen for å legge til nye utvalgsvilkår. Brukerne vil da ikke kunne se flere rader enn de som omfattes av utvalgsvilkårene som er lagret med i oppsettene.

Slette plukkede/ferdigmeldte ordrelinjer

Du kan forhindre brukere fra å redusere antallet, slette eller annullere ordrelinjer hvor noe er plukket via dette valget. Reduksjon av antallet på en ordrelinje vil da bli avvist dersom det nye antallet pluss ferdigmeldt antall er mindre enn plukket antall. Sletting og annullering gjelder både ordrelinjer og ordrer. Ordrer vil ikke bli slettet dersom noe er plukket på noen av ordrelinjene. Ved annullering av ordrer, blir ikke ordrelinjer hvor noe er plukket annullert

Avskrive store betalingsavvik

Dette valget er ikke implementert i denne versjonen.

Oppheve matchinger med differanse


Beregnede kolonner og spørringer i formularer

Beregnede kolonner

I Visma Business har du mulighet til å lage egne kolonner som er en funksjon av eksisterende kolonneverdier. Eksempel på dette kan være at du ønsker en sum som viser summen av 2 kolonner, f.eks. gitte linjerabatter.

Denne kunne vært laget ved å summere alle rabatt %-kolonnene, men dette vil gi feil resultat hvis det benyttes kjederabatter i Bedriftsopplysninger. Den vil også bli feil hvis det samtidig benyttes rabattbeløp.

En måte å gjøre det på er å benytte kolonnen ”Pris etter rabatt” og ”Pris”. Forholdet mellom disse vil gi uttrykke gitte rabatter.

Figur 1 Vindu hvor "Total rabatt" er beregnet

I tabellen ”Beregnede kolonner” er dette satt opp på følgende måte:

Figur 2 Eksempel på beregnet kolonne for å vise total rabatt %

I kolonnen ”Beregn.kol.nr” tastes +. I kolonnen ”Tabellnr” gjør du oppslag og finner den tabellen du ønsker å lage en beregnet kolonne i.
I kolonnen ”Formel” uttrykkes beregningen du ønsker. Oppslag i denne kolonnen gir følgende dialog.

Figur 3 Oppslag i "Formel"-kolonnen

- og videre oppslag i @Kolonne (Feltnavn) gir alle kolonnene i tabellen du har valgt

Figur 4 Tilgjengelige kolonner det kan beregnes i fra

Formelen i vårt eksempel er som følger:

(((@Kolonne (Pris etter rabatt)/@Kolonne (Pris))-1)*-100)

Som vi ser dividerer vi ”Pris etter rabatt” med kolonnen ”Pris”. Deretter trekker vi ifra 1 for å finne rest. Deretter multipliseres resultatet med (-100) for å uttrykke tallet i % og rett fortegn. Det er også lagt inn parenteser slik at uttrykk som skal beregnes for seg isoleres.

IF/ELSE

Det er også flere muligheter ved beregnede kolonner. Du kan også benytte spørringer i uttrykket ditt. Hvis du ønsker at noe skal fremkomme bare hvis det ligger en bestemt verdi på ordrelinjen. Et eksempel kan være at du vil vise MVA-satsene til varene dine på ordrelinjen.

Figur 5 Ordrelinjer med MVA-satsene

Figur 6 Fakturalayout med MVA-satser

Figur 7 Beregning for å vise MVA-sats

Formelen som er benyttet denne gangen er:

@Kolonne (Avg. og bokf.gr.)=4?12:((@Kolonne (Avg. og bokf.gr.)=1?24):(@Kolonne (Avg. og bokf.gr.)=2?0))

Her er i tillegg til eksempelet over [?] og [:] benyttet.

[?] = IF

[:] = ELSE

Her spør vi om kolonnen ”Avg. Og bokf.gr” er lik 4. Hvis den er det skal verdien 12 returneres. Hvis ikke ”Avg. Og bokf.gr” er lik 4 spør vi videre om ”Avg. Og bokf.gr” er lik 1. Hvis den er det returneres verdien 24. Til slutt spør vi om ”Avg. Og bokf.gr” er lik 2 og da skal vi returnere 0. 0 vil forsåvidt ikke synes siden det ikke er en verdi, men utdyper eksempelet.

Slik kunne vi fortsatt med alle avgift og bokføringsgruppene.

Spørringer i formularer

I enkelte situasjoner er det ønskelig at formularer skal vise forskjellig informasjon ut i fra hva som ligger på ordren. Det ligger en del logikk på dette allerede, f.eks. at den skriver ”Kreditnota” i stedet for ”Faktura” der det er riktig. Videre skrives bare de sumlinjene ordren benytter. F.eks. 12 % mva-grunnlag hvis det er det på ordren.

Ved hjelp av spørringer i formularene kan brukeren selv bestemme hva som skal komme ut i forutbestemte situasjoner.

Et eksempel er beskrevet under. Her ønsker vi å skrive ut landnavnet sammen med adressen hvis kunden ikke er norsk.

Figur 8 Tabellen Formularelementer. Eksempel 1 på spørringer i formularer.

Elementtype 7 = IF
Elementtype 8 = ELSEIF
Elementtype 9 = ELSE
Elementtype 10 = ENDIF

Det som er lagt inni firkanten beskriver formelen. Du må legge inn 3 rader. Den første har Elementtype 7 og er selve spørringen, i dette eksempel Landnr. <> 47. Neste rad beskriver hva den skal gjøre hvis spørringen slår til. Denne linjen er da en vanlig linje med Elementnummer 1. Avslutningsvis legger du inn en rad med elementtype 10 som avslutter spørringen din. Legg merke til at det er Sort.sekv.nr. som bestemmer rekkefølgen på spørringen.

Figur 9 Faktura 1 som har landnummer 47 på ordren

Figur 10 Faktura 2 som har landnummer 44 på ordren

Et annet eksempel er vist i standardoppsettet på avgiftsoppgaven

Figur 11 Eksempel 2 på spørringer i formular

Her ser vi at formularet spør om:

@SumUtgMva ()+(@SumInvAvg ())-(@SumInngMva ())+(@InngMva (3))

Hvis formelen er mindre enn 0 skal den sette verdien [X] i x-posisjon 4550. Hvis ikke summen er mindre enn 0, men derimot større enn null skal den returnere [X] i x-posisjon 7600. Til slutt spør den om verdien er lik 0. Da skal den legge [X] i x-posisjonen 9100.

Beregnede kolonner med bruddsum

Beregnede kolonner finner du i dialogen for Hent frem kolonne. Her er det navnet du har angitt i tabellen beregnede kolonner som blir presentert. I dette eksempelet er det Beløp inkl. mva. Den beregnede kolonnen er opprettet med følgende formel.

Når du bruker beregnede kolonner i tabeller hvor du skal vise bruddsummer, må du angi at den beregnede kolonnen skal ha bruddverdi. Dette gjør du ved å høyreklikke når du har fokus i kolonnen, velg Kolonne i menyen og Bruddverdi. Du må være i Design modus for å få tilgang til dette. Det er også en forutsetning at kolonnene som ligger til grunn for den beregnede kolonnen er satt opp med bruddverdi.

I eksempelet under er kolonnen ”Beløp inkl. mva” en beregnet kolonne. Den er satt opp med Bruddveri og formatering slik at den blir presentert med 2 desimaler. Formatering av kolonne finner du ved å høyreklikke i kolonne, velg Kolonne og Format.

Eksempel på tabell med beregnet kolonne, beløp inkl. Mva:


Hvordan bruke data fra Visma Business i en Pivot-tabell i Microsoft Excel

Det er mange ganger du ønsker en bedre oversikt over dataene som ligger i Visma Business. For eksempel kan budsjettet fort bli uoversiktelig med mange linjer og feilsøk kan være vanskelig. Ved å bruke Microsoft Excel kan du enkelt få en bedre oversikt.

I Microsoft Excel kan du godt hente data fra en direkte oppdatert spørring i databasen. Dette krever litt arbeid og innsikt i databasen og det kan derfor være vel så enkelt å bare klippe og lime dataene inn i Microsoft Excel. Prinsippet for eksempelet under er det samme uansett hvordan du henter inn dataene.

Eksempel: Budsjett

Vi har budsjettert i Visma Business og vi har fått mange budsjettlinjer. Vi ønsker å få en bedre oversikt en det Visma kan gi oss. Det vi ønsker oss er :

Konto/mnd | jan | febr | mars | april | etc.
3000 |  |  |  |  |
3100 |  |  |  |  |
6100 |  |  |  |  |
6200 |  |  |  |  |
etc. |  |  |  |  |

Framgangsmåte:

Kopier budsjettlinjer fra Visma Business inn til Microsoft Excel.

Slett evt. kolonner eller linjer som du ikke har bruk for. (Merk kolonnen, høyreklikk og velg ”Slett”). Husk på at siste linje hele tiden vil bli full av 0. Disse kan du også slette. Sett på kolonneoverskrifter.

Sett på en ny kolonne som du kaller beløp. Legg inn formel som tar debet og trekker fra kredit. I vårt eksempel blir formelen i linje 3 lik =D3-E3

Kopier så denne formelen nedover regnearket ved hjelp av å stå på formelen og dobbeltklikke på den vesle firkanten i ramma rundt beløpet

Tabellen din skal nå se slik ut :

Marker hele dataområdet, inkludert kolonneoverskrifter og velg Data – Pivottabell

Du får opp denne dialogboksen:

Trykk Neste/Next

Trykk Neste/Next

I neste dialog må du gjøre noen valg:

Velg ”Existing worksheet”, trykk i det hvite feltet, trykk på ”sheet2” nederst til venstre. Velg ”Layout” i dialogboksen.

I layout-boksen kan du dra boksen ”Periode” til feltet ”Column”, ”Kontonr” til kolonnen ”Row” og ”Beløp” til feltet ”Data”. Slik:

Velg Ok og ”Finish” i neste dialogboks og vips :

Om du vil kan du nå dra f. eks avdelingsfeltet inn i kontonumrene. Da får du dette bildet:

Vil du fjerne denne underdelingen kan du dra ”Avd” tilbake i lista.


IF-tester i formularer - eksempel

Eksempel på IF-tester i formularer

Dette eksempelet beskriver hvordan det er mulig å erstatte Adresselinje 1 med Adresselinje 2 fra ordren, dersom Adresselinje 1 er blank. Formularelementene er satt opp slik. NB! tabellen må sorteres etter linjenummer når disse linjene legges inn:

Når Adresselinje 1 finnes....

...blir Adresselinje 1 skrevet ut:

Når Adresselinje 1 er blank....

...blir Adresselinje 2 skrevet ut:


Eksterne nummer på behandlingsmenyvalg

Eksterne nummer på behandlingsmenyvalg

Tabell/Funksjon | Eksern ID | Default parameters
Adgangsgrupper
Tabelladgang | 70 |
Kolonneadgang | 71 |
Funksjonsadgang | 72 |
470***Write access regulations information to file | 753 |
Kopier adgang | 73 |
Adresser
Send e-post | 429 |
Overfør til aktør | 82 |
Aktive bedriftsprosesser
Opphev låsing | 160 |
Aktive sesjoner
Stopp sesjon | 75 |
Aktive systemprosesser
Opphev låsing | 76 |
Aktiviteter
Opprett dokument | 139 |
Velg brukere | 197 |
Endre tidspunkt | 198 |
Kopier aktivitet | 142 |
Flytt aktivitet | 141 |
Hent memo | 310 |
Sjekk ut memo | 311 |
Sjekk inn memo | 312 |
Opprett ordre | 218 |
Behandlingsmåte | 718 |
Aktører
Opprett dokument | 79 |
Flett brev | 80 |
Send e-post | 468 |
Opprett aktivitet | 193 |
Gå til eksternt CRM-system | 370 |
Endre netthandelspassord | 696 |
Beregn klientrenter | 636 |
Slett renteforslag | 741 |
Bokfør renteforslag | 742 |
Direkte debitering | 230 |
Direkte remittering | 81 |
Kontroller inkassostatus | 752 |
Overfør til inkasso | 702 |
Legg ut endringsliste til inkasso | 703 |
Retur fra inkasso | 711 |
Bytt kunde-/leverandørnummer | 634 |
Generer timesaldo | 722 |
Altinn
Endre passord | 727 |
Testforbindelse | 728 |
Altinnlogg
Testforbindelse | 729 |
Send | 730 |
Status | 731 |
Ansvarsenhet 1
Opprett dokument | 109 |
Ansvarsenhet 2
Opprett dokument | 114 |
Ansvarsenhet 3
Opprett dokument | 119 |
Ansvarsenhet 4
Opprett dokument | 124 |
Ansvarsenhet 5
Opprett dokument | 129 |
Ansvarsenhet 6
Opprett dokument | 134 |
Generer kampanjeliste | 135 |
Flett brev | 136 |
Opprett aktivitet | 137 |
Ansvarsenhet 7
Opprett dokument | 601 |
Ansvarsenhet 8
Opprett dokument | 602 |
Ansvarsenhet 9
Opprett dokument | 603 |
Ansvarsenhet 10
Opprett dokument | 604 |
Ansvarsenhet 11
Opprett dokument | 605 |
Ansvarsenhet 12
Opprett dokument | 606 |
Avgiftskoder
Beregn MVA-sats | 750 |
Bankpartnere
Legg ut data | 738 |
Hent returdata | 739 |
Oppsett av Converter | 740 |
Bedriftsdatafeil
Vis SQL kommando | 191 |
Bedriftsopplysninger
Endre tellere | 203 |
Obligatoriske teksttyper | 208 |
Endre standard valuta | 293 |
Pris/rabatt-kriterier | 207 |
Kredittkontroll | 280 |
Slett ordrer | 328 |
Lag bunt med differanser | 298 |
Regenerer regnskapssaldoer | 196 |
Flytt sperredatoen | 202 |
Bedriftsrapporter
Bestill rapport | 624 |
Bestillingsforslag
Generer ordrer | 224 |
Bestillingsforslagslinjer
Generer ordrer | 225 |
Betalinger
Legg ut data | 295 |
Hent returdata | 305 |
Oppsett av Converter | 325 |
Betalingslinjer
Lag regnskapsbunt | 302 |
Bilag
Periodisering | 236 |
Fordel mva-beløp | 519 |
Ekspander automatposter | 158 |
Hent åpne poster | 720 |
Scan | 650 |
Dokument flyt | 665 |
Dokument viser | 679 |
Dokument informasjon | 693 |
Brukere
Endre passord | 69 |
Lag passord for SQL | 638 |
Budsjettlinjer
Fordeling | 209 |
Bunter
Les OCR data | 155 |
Oppdater bunt | 156 |
Deltakere
Send e-post | 541 |
Dokumenter
Rediger dokument | 144 |
Kopier dokument | 211 |
Flytt dokument | 212 |
Scan | 645 |
Dokument flyt | 659 |
Dokument viser | 673 |
Dokument informasjon | 687 |
Dokumentkoblinger
Versjoner | 190 |
Rediger dokument | 146 |
Send e-post | 389 |
Scan | 652 |
Dokument flyt | 660 |
Dokument viser | 674 |
Dokument informasjon | 688 |
Driftsmiddeltransaksjoner
Sanering | 276 |
Scan | 644 |
Dokument flyt | 658 |
Dokument viser | 672 |
Dokument informasjon | 686 |
Driftsmidler
Opprett dokument | 228 |
Avskrivning | 229 |
E-Dokument informasjon
Endre passord | 744 |
EBF kjøringer
Overfør data | 96 |
Hent dir. deb.data | 232 |
Hent dir. rem.data | 97 |
Behandle returdata | 98 |
Slett fil | 99 |
Opphev kjøring | 100 |
EBF systemer
Endre passord | 95 |
EDI Transaksjonslogg |  |
Send XML | 745 |
Motta XML | 746 |
Formularer
Grafisk redigering | 74 |
Hovedbokskontoer |  |
Automatposteringer | 237 |
Bytt kontonummer | 630 |
Hovedbokstransaksjoner
Sanering | 278 |
Scan | 643 |
Dokument flyt | 657 |
Dokument viser | 671 |
Dokument informasjon | 685 |
Valutakorreksjon | 707 |
Jobber
Klar for utførelse | 625 |
Gjør om igjen | 626 |
Utfør | 584 |
Kontogrupper
Kontogruppe-hierarki | 195 |
Kundetransaksjoner
Opphev matchinger | 88 |
Sanering | 274 |
Scan | 640 |
Dokument flyt | 654 |
Dokument viser | 668 |
Dokument informasjon | 682 |
Vis fakturakopi | 698 |
Valutakorreksjon | 705 |
Lagersaldoer
Overfør til lagertelling | 284 |
Trekk tilbake reservasjoner | 285 |
Korriger beholdninger | 201 |
Regenerer lagersaldoer | 244 | YES
Innenfor lev.tiden | 250 |
Leverandørtransaksjoner
Opphev matchinger | 94 |
Sanering | 275 |
Scan | 642 |
Dokument flyt | 656 |
Dokument viser | 670 |
Dokument informasjon | 684 |
Valutakorreksjon | 706 |
Oppdaterte bilag
Opprett ny bunt | 590 |
Scan | 651 |
Dokument flyt | 666 |
Dokument viser | 680 |
Dokument informasjon | 694 |
Oppdaterte bunter
Opprett ny bunt | 271 |
Eksporter bunt til fil | 332 |
Ordrelinjer
Ekspander struktur | 151 |
Generer ordrer | 300 |
Annuller | 243 |
Bekreftet | 152 |
Sendt | 247 |
Oppdater ordrer | 249 |
Trekk tilbake plukking u/res | 749 |
Ferdigmeld | 153 |
Tilbakelevert | 154 |
Mottatt faktura | 200 |
Behandlingsmåte | 265 |
Scan | 648 |
Dokument flyt | 663 |
Dokument viser | 677 |
Dokument informasjon | 691 |
Ordrer
Opprett dokument | 150 |
Del opp | 233 |
Overfør | 314 |
Nullstill | 234 |
Legg til | 245 |
Rekalkuler priser | 299 |
Lagre om | 252 |
Generer ordrer | 240 |
Generer kopi av ordre | 712 |
Kalkuler produksjonsstart | 710 |
Annuller | 242 |
Bekreftet | 186 |
Sendt | 246 |
Ferdigmeld | 187 |
Tilbakelevert | 188 |
Mottatt faktura | 199 |
Ordrestatus | 219 |
Plukklister
Ferdigmeld | 214 |
Trekk tilbake | 215 |
Pris- og rabattmatrise
Prisjustering | 210 |
Prisrefusjoner
Prisrefusjon avslått | 259 |
Prisrefusjon bekreftet | 260 |
Kredit mottatt | 289 |
Produkter
Opprett dokument | 148 |
Scan | 646 |
Dokument flyt | 661 |
Dokument viser | 675 |
Dokument informasjon | 689 |
Opprett lagersaldo | 221 |
Behandlingsmåte | 266 |
Bytt produktnummer | 635 |
Produkttransaksjoner
Behandlingsmåte | 268 |
Bokfør kostnader | 290 |
Bokfør midlertidig lagerverdi | 735 |
Internfakturering | 307 |
Sanering | 277 |
Scan | 649 |
Dokument flyt | 664 |
Dokument viser | 678 |
Dokument informasjon | 692 |
Aktiver driftsmiddel | 629 |
Vis fakturakopi | 699 |
Programmer |  |
Start program | 143 |
Rapporter
Kjør rapport | 269 |
Installere rapport | 737 |
Redigere rapport | 331 |
Rentebeløpslinjer
Overfør renter til ordrer | 709 |
Reservasjoner
Ferdigmeld | 216 |
Tilbakelevert | 220 |
Mottatt faktura | 217 |
Ressurser
Generer timesaldo | 723 |
Godkjenn timeliste | 724 |
Godkjenn egen tid | 748 |
Ressursreservasjoner
Opprett dokument | 106 |
Resultat/balansedefinisjonslinjer
Enkel understrekning | 102 |
Dobbel understrekning | 103 |
Sideskift | 104 |
Skriveroppsett
Skrivervalg | 304 |
Strukturer
Behandlingsmåte | 267 |
Systemdatafeil
Vis SQL kommando | 192 |
Systemopplysnonger
Endre tellere | 754 |
Timegruppe
Generer timekalender | 719 |
Valuta
Bytt enhet | 292 |
Valuta korreksjons data
Oppdaterer valutakorreksjon | 708 |
Varepartier
Overfør | 205 |
Skill ut | 206 |
Overfør til lagertelling | 715 |
Trekk tilbake reservasjoner | 716 |
Korriger beholdninger | 717 |
Scan | 647 |
Dokument flyt | 662 |
Dokument viser | 676 |
Dokument informasjon | 690 |
Åpne kundeposter
Match post-mot-post | 84 |
Match like beløp | 85 |
Match referanser | 86 |
Factoring | 308 |
Lag betalingsforslag | 701 |
Avskriv betalinger | 507 |
Avslutt post | 194 |
Splitt åpne poster | 700 |
Scan | 639 |
Dokument flyt | 653 |
Dokument viser | 667 |
Dokument informasjon | 681 |
Vis fakturakopi | 697 |
Åpne leverandørposter
Match post-mot-post | 90 |
Match like beløp | 91 |
Match referanser | 92 |
Lag betalingsforslag | 294 |
Avslutt post | 751 |
Scan | 641 |
Dokument flyt | 655 |
Dokument viser | 669 |
Dokument informasjon | 683 |
Rapporter | Eksern ID | Default parameters
Fakturaer/kreditnotaer |  | YES
Fraktbrev |  | YES
Etiketter |  | YES
Pakksedler |  | YES
Plukklister |  | YES
Ordrebekreftelser |  | YES
Tilbud |  | YES
Bestillinger |  | YES
Forespørsler |  | YES
Produksjonsbestillinger |  | YES
Ordreutskrift |  | YES
Ordredokumentkopi |  |
Bestillingsforslag |  | YES
Prisliste |  |
Leveransebeskjeder |  |
Åpen postliste for kunder |  |
Generalnotaer |  |
Purre/renteforslag |  |
Purrebrev |  |
Rentenotaer |  |
Kontoutskrift for kunder |  |
Saldoliste for kunder |  |
Refusjonsanmodning |  |
Åpen postliste for leverandører |  |
Remitteringsforslag |  |
Remitteringsgiroer |  |
Kontoutskrift for leverandører |  |
Saldoliste for leverandører |  |
Kontoutskrift for hovedbok |  |
Saldoliste for hovedbok |  |
Resultatregnskap og balanse |  |
Avgiftsoppgave |  |
Kontoutskrift for driftsmidler |  |
Saldoliste for driftsmidler |  |


Felles registre

Bakgrunn

Ønske om et felles kunde/leverandørregister.

Begrensninger

Alle bedriftsdatabasene som skal ha felles Kunde/leverandørregister må vaskes. Det vil si at før felles registre tas i bruk så kan det ikke ligge overlappende kundenr/leverandør i de ulike databasene. Fremgangsmåte for å rydde opp i dette er beskrevet under.

Alle transaksjoner, dokumenter etc. vil kun være tilgjengelig i de ulike bedriftsdatabasene.

Alle felt i aktørtabellen blir felles, dette fører til at feltene knyttet til purrestatus vil gjelde i alle bedriftsdatabasene

”Purret pr dato" ·Feltet ”Purret pr. dato” viser når du sist sendte purrebrev til kunden, og har betydning for når du eventuelt skal sende neste purrebrev.

”Purre-utskriftsdato”
Feltet ”Purre-utskriftsdato” tar vare på datoen for siste purreutskrift på kunden.

”Antall purringer”
Feltet for ”Antall purringer” viser hvor mange ganger du har purret posten som er purret flest ganger (som godt kan være høyere enn brevnummeret). Feltet blir nullstilt når posten er oppgjort.

”Kundepref”

”Til Inkasso” – ”Overført til inkasso” Vil være felles og gjelde på tvers av klientmassen.

Fremgangsmåte

”Vaske aktørtabellen”

Alle kundedatabasene må gås igjennom for å sikre at kundene ikke får overlappende kundenr.serier. Kunder som i dag er felles (dvs. samme kunde eksisterer i flere databaser må tildeles samme kunde/levnr). Fremgangsmåten for å tildele kunde/levnr er å benytte funksjonen ”Nytt kunde/levnr”.

Gå igjennom aktørtabellen i alle bedriftsdatabasene, flytt kunde/leverandørene til nye kundenr dersom dette er overlappende. Anbefaler å opprette disse i egne serier pr database så vi er sikre på at dette ikke blir noe overlapping.

Fyll ut nytt kundenr i feltet ”Nytt kundenr”. Når behandlingsmenyvalget "Bytt kunde-/leverandørnummer” kjøres så byttes kundenr og alle transaksjoner på kundeflyttes til nytt kundenr.

Samme fremgangsmåte gjelder leverandører.

NB!! Alle kunder/leverandører må være opprettet i Masterdatabasen

Når aktørtabellen er vasket så kan aktørtabellen settes til felles.

NB! Når dette gjøres så vil aktørtabellen i alle databasene, med unntak av i masterdatabasen slettes og erstattes med ett view! Dette medfører at all informasjon som er lagret der vil forsvinne! Derfor er vaskejobben meget viktig.

I tabellen ”Felles tabeller” settes Tabellen ”(152) Aktører ” til felles for de ulike bedriftsdatabasene.

I det aktuelle eksempelet så er bedriftsbasenr 8999 satt som ”master database”. Når dette er gjort så har vi kun en aktørtabell som skal vedlikeholdes.


Tabellen Fri informasjon

Tabellene ”Fri Informasjon 1-3”

Ved oppgradering til nye versjoner så er det viktig at view som er benyttet i tidligere versjoner gås igjennom slik at datamodellen i oppgradert versjon og viewet er like. Til versjon 4.60 er det gjort en endring i tabellene Fri informasjon 1-3. det vil si at det lagt til nye felt:

Txt3, Txt4, FreeInf2, FreeInf3, MainFrI1, PictFNm, WebPg, NoteNm, InfCatNo, PrCatNo, Dt5, Dt6, Dt7, Dt8, Dt9, Dt10, Dt11, Dt12, Dt13, Dt14, PropNo, PriceLn, ShpNo

Her kan du laste ned oppdatert mal for view i 4.60.


Hente data fra Visma Business til Microsoft Excel

Dataene i Visma Business er lagret i en åpen database. Dette gir oss muligheten til å lage en link til denne databasen og få disse presentert i Microsoft Excel eller Access. Det vil si at når denne jobben er gjort må den ikke gjøres flere ganger. Vi kan benytte oss av de funksjonalitetene og finesser som finnes slik at vi kan lage rapporter som blir visuelle og enkle å lese. Vi skal vise i et eksempel hvordan dette enkelt kan gjøres i Excel.

Vi må først lage en kobling slik at dataene blir hentet inn i Excel. Til dette benytter vi oss av ODBC. Alle som benytter Visma Buiness har dette installert da dette er det samme verktøyet som blir benyttet av Visma Business. Eksemplet er laget i Office 2000 og det kreves det at programmet Microsoft Query er installert.

Vi skal lage oss en ny spørring mot vår database. Her må vi gi et nytt navn til datakilden. Dette må vi huske til senere. Hva slags driver vi skal benytte avhenger av hva slags database dataene er lagret i. I dette eksemplet er det SQL server som er benyttet. Når vi skal knytte oss opp må vi gjøre dette mot en bestemt database.

Tabellen vi skal ta utgangspunkt er produkttransaksjonstabellen. Denne tabellen heter på SQL språk ProdTr. Dersom man er usikker på hva tabellen og de enkelte kolonnene heter så kan vi i Visma Business endre på tekstene slik at kolonnene blir presentert med SQL navn. Menyvalget Opsjoner og Tekster gir deg denne funksjonen i Visma Business.

Nå har vi laget linken som gjør det mulig å lese data fra Visma Business Databasen. Neste trinn blir å hente inn dataene i Excel og benytte oss av funksjoner som man finner i Excel. Pivot er et eksempel på dette. Eksemplet som vi skal vise tar hensyn til alt salg av ulike produkttyper innenfor ulike perioder.

For å hente inn data benytter vi oss av en veiviser i Excel. Denne veiviseren starter vi ved hjelp av menyvalget ”Data” og ”Pivot tabell og Pivot skjema rapport”. Vi velger å hente data fra en ekstern datakilde. Her velger vi datakilden ”VismaExcel” som vi allerede har laget.

Vi får nå opp en meny hvor vi skal velge hvilke kolonner vi vil ha med i rapporten vår. Vi har i dette eksemplet valgt Transaksjonstype (TrTp), Påløpte kostnader (CIncCst), Beløp (Am) Produkttype (ProdTp) og År/periode (YrPr). Husk å legge på et utvalg på transaksjonstype slik at rapporten kun tar hensyn til salg. Etter at dataene er hentet går vi videre med steg 2 av 3.

Steg 3 er å fortelle hvordan rapporten skal se ut. Vi velger å se på layouten til rapporten. Her bestemmer vi hvilke kolonner som skal presenteres og hvilke som skal summeres. I eksemplet skal vi finne ut hvor mye kostnader og inntekter av det enkelte produkt innenfor ulike perioder. Summene blir derfor ”Beløp” og ”Påløpte kostnader”.

Dersom vi nå sier OK og at vi er ferdig med rapporten vil den bli seende slik ut:

Hvordan den ferdig rapporten ser ut kan redigeres på mange måter. I dette eksemplet ønsker vi å benytte en av Excel standard formater på rapporter:

Etter å ha lagt på farge på enkelte felt og laget et kalkulert felt som viser dekningsbidraget blir den ferdige rapporten seende slik ut:

Dette er bare et eksempel på en rapport som du kan lage. Her er muligheten mange og det er bare fantasien som setter en stopper. Det som er det fine ved å gjøre det på denne måten er at dataene er korrekte og oppdaterte så snart rapporten er ”oppfrisket” etter endringer i Visma Business sin database.


Import fra regneark til Visma Business

I noen tilfeller kan det være hensiktsmessig å hente data inn i Visma Business fra et regneark. Ofte kan dette gjøres ved klipp/lim, men spesielt ved store datamengder (innlegging av aktører, budsjetter osv.) kan dette være en tung løsning. Alternativet da er å hente dataene rett inn i databasen via "Importer" - menyen.

Ettersom mange kan ha bruk for denne metoden ved import av kunder/leverandører, bruker vi dette som eksempel. Det første vi gjør er å gå inn i tabellen "Aktører" (tast Ctrl+O). Den ligger plassert under Felles - Aktører:

Bildet viser noen av kolonnene i denne tabellen. Hent frem de som er brukt i regnearket og sett disse kolonnene i samme rekkefølge. Gå så til "Tekster" under Hjem-menyen (i 4.60.x ligger dette under Opsjoner/Systemadministrasjon)_

I dialogen velger du hvilken type tekst som skal vises i kolonne-overskriftene. Endre denne fra Brukerdefinerte til SQL. Bildet vil da se slik ut:

Disse tekstene skal stå i den øverste raden i regnearket i stedet for tilsvarende norske tekster. Dette for at datasystemet skal gjenkjenne hvor dataene skal legges i tabellen ved import.

Når disse tekstene er lagt inn, lagres denne filen i csv-format, dvs. semikolon-separasjon mellom kolonnene. Når dette er gjort, gå ut i et tekstredigeringsprogram, for eksempel Wordpad. Her vil filen åpnes med semikolon som skille mellom kolonnene. Gå til Rediger, velg Erstatt, og legg inn ";" på "Søk etter" og "," i "Erstatt med". Trykk "Erstatt alle". Lagre filen.

Deretter går vi inn i Visma Business, "Importer" under Hjem-menyen (Opsjoner/Systemadministrasjon/Importer i tidligere versjoner). Dialogen du da kommer inn i skal ha disse valgene:

Når du nå trykker Importer vil du få velge hvilken fil du vil importere. Deretter vil du få opp en dialog der dataene i filen er presentert i kolonner, slik:

Ser dette riktig ut, kan du trykke på Neste, og gå til neste bilde der du velger hvilken tabell du skal importere til. Har du ikke endret tekstene tilbake fra SQL, vil valgene i denne menyen presenteres som dette i stedet for norsk.


Standard språk i Visma Business

Siden Visma Business nå er definert som en av våre internasjonale applikasjoner, har vi vært nødt til å endre hovedspråket i applikasjonen fra norsk til engelsk. Bl.a. på grunn av ulike ordlengder i de enkelte språk er det enklere å bygge ulike språkversjoner med utgangspunkt i engelsk enn det er dersom en bruker norsk som grunnspråk.

Dette betyr at den som fra tidligere versjoner ikke er vant til å gjøre noe med pråk i forbindelse med installasjon og oppgradering nå kan oppleve enkelte uregelmessigheter. Derfor denne artikkelen.

Når du installerer eller oppgraderer programmet fastslår du standardspråket for denne installasjonen. Velges engelsk her, blir standardspråk engelsk, velges norsk blir det norsk. Språkvalget du gjør, lagres i nøkkelen INTL_DEFAULT i registry hva som dukker opp som forslag til standard vil kunne bli påvirket av språkoppsett på maskinen du installerer på. – Vel verdt å kontrollere om de som har installert serveren har brydd seg om å sette den opp som norsk, eller om den fortsatt er plassert i USA....

Når brukerne senere logger seg på, hentes INTL_DEFAULT fra registry, og verdien her bestemmer hvilket språk brukeren skal få – eller rettere hvilken xxxprog.txt som skal leses inn, og hvilken kolonne i oversettelsestabellen som skal være aktiv

Vi har pr i dag ingen funksjon for å sette ulike språk pr firma (klient)

Hvordan settes så språk for hver enkelt bruker?
Dersom standardspråket skal brukes, behøver en ikke gjøre noe. Det er bare avvikene fra standard som må behandles, og det gjør en via Systemparametre – Brukere, i kolonnen Programspråknr.
Merk: For ”standardbrukerne” (-altså de som følger hovedspråket på installasjonen) vil denne kolonnen vanligvis være blank

Xxxprog.txt filen styrer alle programtekster. På ribbonen så betyr dette f.eks ”hjem” tabben

Alle oppslags dialoger som ikke kan defineres i teksttabellen henter også sine tekster fra denne xxxprog.txt filen.
Oversettelsestabellen oversetter i prinsippet alt som du finner inne i selve skjermbildet i tillegg til navnene på skjembilder og mapper.
Det du finner på ribbonen som er ”skjermbilder” vil derfor oversettes via oversettelsestabellen, ikke i xxxprog.txt

Hva så med feltoppslag? Her vil det være teksttabellen som kommer inn med oppslag basert på brukerens språknummer.
Forutsetningen her er da selvsalgt at samme koder finnes i de forskjellige språk det er henvisninger til på brukerne.

Hvilke tekster som skrives ut på formularer styres ikke av brukeren og/eller /INTL_DEFAULT, men av hvilket språk kunden eller leverandøren er satt opp med.
Formularene må selvsagt være tilpasset det språk som kunden/leverandør ligger inne med.


Variabler

Variabler i Visma Business

I dette dokumentet vil vi gi en innføring i bruk av variabler vist med eksempler.

Navnerom (Tabeller - Felles – Variabler)

Navnerom er en overordnet variabel som ligger i en ”system” tabell som heter Navnerom. I tabeller for variabler ligger alltid Navnerom som en kolonne og er en del av primærnøkkel. Opprett Navnerom som vist under:

Tekst bedriftsvariabler (Tabeller - Felles – Variabler

I denne tabellen kan du legge opp variabler for logoer som du kan vise i vinduer og formularer eller tekster som for eksempel skal ut på formularer. Denne tabellen er knyttet til bedriftsbasen og variablene vil bli vist i vinduer eller formularer der dette er lagt inn. Dette fordrer at variablene har samme navn i de forskjellige bedriftsbasene.

Logo i oppsett

Under ser du tabellen for Tekst-bedriftsvariabler med eksempler på variabler. I dette eksempelet skal vi legge inn logo i vindu for bilagsregistreringen og velger å bruke variabelen Logo.

Merk! Formatet på bildet må være *.bmp.

Opprett Tekst-bedriftsvariabler som vist under:

Gå til vinduet hvor du ønsker å vise logo. I design velger du Inkluder via Fil, Inkluder, Bedriftsavhengig bilde. Du får da opp dialogen vist under og velger Navnerom og variabel samt Elementnr. Elementnummer styrer hvilken verdi på variabelen du vil bruke. Her har vi brukt elementnummer 1 som tilsvarer kolonnen Verdi 1 i Tekst-bedriftsvariabler.

Under ser du eksempel på bruk av logo i vindu for bilagsregistreringen hvor logoen er lagt nederst i vinduet.

Logo på formular

Under ser du tabellen for Tekst-bedriftsvariabler med eksempler på variabler. I dette eksempelet skal vi legge inn logo i formular og velger å bruke variabelen Logo_formular.

Merk! Formatet på bildet må være *.bmp.

I formularredigeringen må du hente frem kolonnen Navnerom. Du må bruke Elementtype 11 Bedriftsavhengig bilde 1 (Verdi 1 i Tekst-bedriftsvariabler) eller 12 Bedriftsavhengig bilde 2 (Verdi 2). Legg inn ”Logo” i kolonnen Navnerom og ”Formular_logo” i kolonnen Tekst/parametere. Når du skal bruke logo fra fil skal du ikke bruke makro i Tekst/parametere.

Logoen vil da bli presentert på angitt plass på formularet ved utskrift eller forhåndsvisning.

Tekst på formular

Under ser du tabellen for Tekst-bedriftsvariabler med eksempler på variabler. I dette eksempelet skal vi legge inn Tekst i formular og velger å bruke variabelen Formulartekst..

I formularredigeringen må du hente frem kolonnen Navnerom. Du må bruke Elementtype 11 Bedriftsavhengig bilde 1 (Verdi 1 i Tekst-bedriftsvariabler) eller 12 Bedriftsavhengig bilde 2 (Verdi 2). Legg inn ”Tekst” i kolonnen Navnerom og makroen @BedriftsTekst(Variabelnavn, Elementnr) i kolonnen Tekst/parametre. I makroen må du i dette eksempelet erstatte Variabelnavn med Formulartekst (hentet fra Tekst-bedriftsvariabler) og angi elementnummer 1 (@BedriftsTekst(Formulartekst, 1).

Formulartekst vil da bli presentert på angitt plass på formularet ved utskrift eller forhåndsvisning.

Heltalls bedriftsvariabler (Tabeller - Felles – Variabler)

Her skal vi se på hvordan du kan bruke Heltalls-bedriftsvariabler som forenklet utvalgsdialog.

Du må først opprette et navnerom i tabellen navnerom som du deretter kan bruke i tabellen Heltalls-bedriftsvariabler.

I tabellen Heltalls-bedriftsvariabler oppretter du en variabel som du kan bruke til utvalg i vinduer. I dette eksempelet kan du bruke variabelnavn ”Utvalgsdialog”. Det er ikke nødvendig å legge inn verdier i kolonnene Verdi 1, Verdi 2 osv.

Opprett Heltalls-bedriftsvariabler som vist under:

Vindu med utvalg via Heltalls-bedriftsvariabler

Nå skal du opprette et nytt vindu hvor du skal inkludere Heltalls-bedriftsvariabler og Kundetransaksjoner. I Heltalls-bedriftsvariabler legger du inn et utvalg hvor du kun skal ha med variabelnavn ”Utvalgsdialog”. Tabellen Kundetransaksjoner kan du sette opp med sortering på kundenr og bruddlinjer og hake i ”Vis bare bruddlinjer” og ”Ta med totallinje”. Under følger eksempel på et ferdig oppsett.

Utvalg med test mot Heltalls-bedriftsvariabler

Nå skal du legge inn utvalg i Kundetransaksjoner slik at det som blir vist i tabellen er i henhold til verdier i Heltalls-bedriftsvariabler. Sett opp utvalg på kolonnen Periode >= Variabel.

Under ser du et ferdig utfylt utvalg.

For å gjøre inntastingen litt enklere i Heltalls-bedriftsvariabler kan du nå endre ledetekstene på Verdi kolonnen til Fra periode, Til periode og år.

Du kan nå teste løsningen ved å endre verdier i Heltalls-bedriftsvariabler, lagre og gå til kundetransaksjoner og oppfriske.

For å gjøre løsningen mere elegant kan du lage en knapp hvor du spiller inn lagring av Heltalls-bedriftsvariabler og flytter markør til Kundetransaksjoner og oppfrisker.

Tips: Gjør en endring i Heltalls-bedriftsvariabler uten å lagre før du spiller inn makro. Start opptak, sett fokus i År og tast Enter, Lagre, flytt fokus til Kundetransaksjoner og oppfrisk (F5)

Eksempel på ferdig vindu.

Utvalg på dato med Tekst-bedriftsvariabler

Her skal vi vise hvordan du kan bruke Tekst-bedriftsvariabler som forenklet utvalgsdialog.

Du må først opprette et navnerom i tabellen navnerom som du deretter kan bruke i tabellen Tekst-bedriftsvariabler.

I tabellen Tekst-bedriftsvariabler oppretter du en variabel som du kan bruke for utvalg i vinduer. I dette eksempelet kan du bruke variabelnavn ”Utvalgtekst”. Det er ikke nødvendig å legge inn verdier i kolonnene Verdi 1, Verdi.

Opprett Tekst-bedriftsvariabel som vist under:

>Vindu med utvalg via Tekst-bedriftsvariabler

Nå skal du opprette et nytt vindu hvor du skal inkludere Tekst-bedriftsvariabler og Produkttransaksjoner. I Tekst-bedriftsvariabler legger du inn et utvalg hvor du kun skal ha med variabelnavn ”Utvalgtekst”.

Tabellen Produkttransaksjoner kan du sette opp med sortering på produktnr. og bruddlinjer og hake i ”Ta med totallinje”. Under følger eksempel på et ferdig oppsett.

Utvalg med test mot Tekst-bedriftsvariabler

Nå skal du legge inn utvalg i Produkttransaksjoner slik at det som blir vist i tabellen er i henhold til verdier i Tekst-bedriftsvariabler. Sett opp utvalg på kolonnen Trans.type = Salg (1) og på Trans.dato som vist under.

For å gjøre inntastingen litt enklere i Tekst-bedriftsvariabler kan du nå endre ledetekstene på Verdi kolonnene til Fra dato og Til dato.

Du kan nå teste løsningen ved å endre verdier i Tekst-bedriftsvariabler, lagre og gå til produkttransaksjoner og oppfriske.

For å gjøre løsningen mere elegant kan du lage en knapp hvor du spiller inn lagring av Tekst-bedriftsvariabler og flytter markør til Produkttransaksjoner og oppfrisker.

Gjør en endring i Heltalls-bedriftsvariabler uten å lagre før du spiller inn makro. Start opptak, sett fokus i Til dato og tast Enter, Lagre, flytt fokus til Kundetransaksjoner og oppfrisk (F5).

I det ferdige vinduet som er vist over er det også lagt inn ett html dokument med beskrivelse av hvordan vinduet skal brukes.


Variabler

Views ved bruk av FreeInfo-tabellene

FreeInfo-tabellene er frie tabeller som inneholder en rekke felt fra hele databasen. Disse feltene kan du fritt ta i bruk for å presentere de data som du ønsker.

Det er ikke implementert behandlingsregler utover å kunne registrere data i tabellene. Du kan bruke tabellene til å lagre tilleggsinformasjon som du ikke har noen annen funksjon for i Visma Business.

Du kan også lage views med FreeInfo-tabellene som utgangspunkt. Ved å fjerne (drop) tabellen og lage et "view", kan du presentere de data du ønsker fra forskjellig steder i systemet. Viewet kan hente informasjon fra en eller flere tabeller og beregne nye verdier etter egne formler. Et View MÅ bli laget med samme antall felt og type som FreeInfo-tabellene.

Nedenfor ser du et eksempel på hvordan et view kan gi deg de data du ønsker. I eksempelet er det laget et view som bruker FreeInfo1 som utgangspunkt. Viewet inneholder en formel som beregner hvor mange ferdigvarer det er mulig å produsere med de råvarene som ligger på lager(Strukturer).

I bildet over ser du hvor mange Salongbord du kan produsere ut fra de råvarer du har tilgjengelig på lager. Produserbart antall er innringet i rødt.

Trykk her for å åpne viewet som er laget for dette eksemplet. Dette viewet kan du bruke som utgangspunkt når du skal lage ditt eget view. På linjenr. 70 og 71 i viewet ser du formelen som beregner produserbart antall.

Hvis viewet ikke lenger skal brukes og du ønsker å ta i bruk tabellen igjen er framgangsmåten følgende:

Slett viewet (drop view) bruk Query Analyzer og generer et script av tabellen fra en annen database, for eksempel demoklienten.

Kjør scriptet mot klienten for å opprette tabellen.


Fax/Mail drivere

Visma Business Fax/Mail driver blir automatisk installert på alle Win NT, XP og Win2000 maskiner.

Terminalserver

Visma Fax/Mail driver må installeres direkte på terminalserveren. Egne drivere for terminalserver finnes på Visma Business CD (4.50.x) under Other, Terminal Printer Drivers.

”Lag fakturakopi”

Har du satt kryss i feltet ”Lag fakturakopi” i Ordrebehandling i tabellen Bedriftsopplysninger, blir det genererert en tiff-fil ved utskrift av fakturaer. I tillegg til kopi av Faktura, kan det også produseres tiff-fil av Tilbud, Pakkseddel, Bestilling og Ordrebekreftelse.

Merk: Det er kun kopier av faktura som kan vises i Visma Business via Behandlingsmenyen.

Fax/Mail driver, versjon 4.60.1

Installeres fra C:\Program Files\Visma\Business\TIFF. I denne katalogen finner du følgende filer. (Start setup.exe)

Registry

I registry til Visma Business under Hkey_Current_User – Software – Visma – Business – CurrentVersion – Database har vi en nøkkel som heter FAX_MAIL_PATH. Denne stien blir satt til programområde under installasjon / klientinstallasjon av Visma Business.

Merk: Det er denne stien som styrer hvor du ønsker at TIFF filene skal ligge. Husk å starte Visma Business på nytt etter endringer i Registry.

Dersom stien er C:\Program Files\Visma\Business, vil den i tillegg legge til mappene \FXXXX\FaxMail.

Dersom du har satt hake i parameteret ”Lag kopier i separate mapper” i feltet ”Faks og e-post behandling” i tabellen Bedriftsopplysninger, vil den også legge på mappene Invoice, Orderconf, Purchase, Quotes etc. avhengig av hva du har satt at det skal lages kopi av. Dette angis også i feltet ”Faks og e-postbehandling” i tabellen Bedriftsopplysninger:

SetPrinterDirectory.dll

Denne filen blir registrert under installasjon / klientinstallasjon. Det er på grunn av at denne registreres at det er Registry som styrer hvor filene skal ligge. Dersom den av en eller annen grunn ikke ble registrert under installasjo, kan følgende feilmelding komme ved utskrift av ordredokumenter:

Du må da manuelt registrere filen. Det gjør du på følgende måte:

Hvis du høyreklikker på Visma Business Fax/Mail driveren og velger Properties – Printing Preferences – fanen Filename Generation så ser du at det finnes et sti under ”Output Directory”. Denne benyttese ikke.

Printere

Ved bruk av ”Lag fakturakopi” vil utskriften alltid komme på den printeren som er definert i utskriftsoppsettet. Hvis det ikke er definert noe på utskriftsoppsettet, velger Visma Business standardprinter. Dette kan m.a.o. ikke overstyres i det vinduet du registrerer ordre/skriver ut faktura fra.

"Create Multipage Image"

Dersom det kun blir produsert en faktura med siste side så er årsaken at det mangler et parameter på printeren. Dette parameteret heter ”Create Multipage Image” og du finner det under ”Printing Preferenses” og ”File Formats”.

Formularet blir forminsket

Visma Fax/Mail foretar en skalering av utskriften. Løsningen blir å fortelle Visma Fax/Mail at papiret er mindre enn det virkelig er.

Eksempel på skalering = 5,5 %.

Et A4-ark har målene 210.0x297.0 mm. Legg derfor inn ”Variable Paper Size” med width (2100x0,945=) 1985 og height (2970x0,945=) 2806.


CRM

Her finner du tips og gode råd i CRM modulen som er et salg- og kundestøttesystem i Visma Business.


Tagger


Standard

MACRO_ACTOR_COLUMN_INFO
ActorNo | §ActorNo | DocFileName | §DocFileName
ActorName | §ActorName | DocPathFileName | §DocPathFileName
ActorAddress1 | §ActorAddress1 | DocTheme | §DocTheme
ActorAddress2 | §ActorAddress2 | DocDesc | §DocDesc
ActorAddress3 | §ActorAddress3 | DocDate | §DocDate
ActorAddress4 | §ActorAddress4 | DocYear | §DocYear
ActorPostNo | §ActorPostNo | DocMonth | §DocMonth
ActorPostPlace | §ActorPostPlace | DocDay | §DocDay
ActorPhone | §ActorPhone |  |
ActorPrivatePhone | §ActorPrivatePhone | FirmName | §FirmName
ActorMobilePhone | §ActorMobilePhone | FirmAddress1 | §FirmAddress1
ActorPersonalSearcher | §ActorPersonalSearcher | FirmAddress2 | §FirmAddress2
ActorFax | §ActorFax | FirmAddress3 | §FirmAddress3
ActorCustomerNo | §ActorCustomerNo | FirmAddress4 | §FirmAddress4
ActorSupplierNo | §ActorSupplierNo | FirmPostNumber | §FirmPostNumber
ActorEmployeeNo | §ActorEmployeeNo | FirmPostPlace | §FirmPostPlace
ActorSeller | §ActorSeller | FirmPhone | §FirmPhone
ActorBuyer | §ActorBuyer | FirmFax | §FirmFax
ActorResponsible | §ActorResponsible | FirmBankGiro | §FirmBankGiro
ActorBusinessNo | §ActorBusinessNo | FirmPostGiro | §FirmPostGiro
ActorEuTaxNo | §ActorEuTaxNo |  |
ActorFreeInfo1 | §ActorFreeInfo1 | UserName | §UserName
ActorFreeInfo2 | §ActorFreeInfo2 | UserTitle | §UserTitle
ActorFreeInfo3 | §ActorFreeInfo3 | UserInitial | §UserInitial
ActorFreeInfo4 | §ActorFreeInfo4 |  |
ActorFreeInfo5 | §ActorFreeInfo5 |  |
ActorFreeInfo6 | §ActorFreeInfo6 |  |
ActorFreeInfo7 | §ActorFreeInfo7 |  |
ActorFreeInfo8 | §ActorFreeInfo8 |  |
ActorEMail | §ActorEMail |  |
ActorYourRef | §ActorYourRef |  |
ActorCountry | §ActorCountry |  |
ActorISOCountry | §ActorISOCountry |  |
YourRef | §YourRef |  |
ActorLiaison1 | §ActorLiaison1 |  |
MACRO_CONTACT_ACTOR_COLUMN_INFO
ContactActorNo | §ContactActorNo | DocFileName | §DocFileName
ContactActorName | §ContactActorName | DocPathFileName | §DocPathFileName
ContactActorAddress1 | §ContactActorAddress1 | DocTheme | §DocTheme
ContactActorAddress2 | §ContactActorAddress2 | DocDesc | §DocDesc
ContactActorAddress3 | §ContactActorAddress3 | DocDate | §DocDate
ContactActorAddress4 | §ContactActorAddress4 | DocYear | §DocYear
ContactActorPostNo | §ContactActorPostNo | DocMonth | §DocMonth
ContactActorPostPlace | §ContactActorPostPlace | DocDay | §DocDay
ContactActorPhone | §ContactActorPhone |  |
ContactActorFax | §ContactActorFax | FirmName | §FirmName
ContactActorCustomerNo | §ContactActorCustomerNo | FirmAddress1 | §FirmAddress1
ContactActorSupplierNo | §ContactActorSupplierNo | FirmAddress2 | §FirmAddress2
ContactActorFreeInfo1 | §ContactActorFreeInfo1 | FirmAddress3 | §FirmAddress3
ContactActorFreeInfo2 | §ContactActorFreeInfo2 | FirmAddress4 | §FirmAddress4
ContactActorFreeInfo3 | §ContactActorFreeInfo3 | FirmPostNumber | §FirmPostNumber
ContactActorFreeInfo4 | §ContactActorFreeInfo4 | FirmPostPlace | §FirmPostPlace
ContactActorFreeInfo5 | §ContactActorFreeInfo5 | FirmPhone | §FirmPhone
ContactActorFreeInfo6 | §ContactActorFreeInfo6 | FirmFax | §FirmFax
ContactActorFreeInfo7 | §ContactActorFreeInfo7 | FirmBankGiro | §FirmBankGiro
ContactActorFreeInfo8 | §ContactActorFreeInfo8 | FirmPostGiro | §FirmPostGiro
ContactActorEMail | §ContactActorEMail |  |
ContactActorYourRef | §ContactActorYourRef | UserName | §UserName
ContactActorCountry | §ContactActorCountry | UserTitle | §UserTitle
ContactActorISOCountry | §ContactActorISOCountry | UserInitial | §UserInitial
MACRO_ORDER_COLUMN_INFO
OrderNo | §OrderNo | DocFileName | §DocFileName
OrderName | §OrderName | DocPathFileName | §DocPathFileName
OrderAddress1 | §OrderAddress1 | DocTheme | §DocTheme
OrderAddress2 | §OrderAddress2 | DocDesc | §DocDesc
OrderAddress3 | §OrderAddress3 | DocDate | §DocDate
OrderAddress4 | §OrderAddress4 | DocYear | §DocYear
OrderPostNo | §OrderPostNo | DocMonth | §DocMonth
OrderPostPlace | §OrderPostPlace | DocDay | §DocDay
OrderCustomerNo | §OrderCustomerNo |  |
OrderSupplierNo | §OrderSupplierNo | FirmName | §FirmName
OrderFreeInfo1 | §OrderFreeInfo1 | FirmAddress1 | §FirmAddress1
OrderFreeInfo2 | §OrderFreeInfo2 | FirmAddress2 | §FirmAddress2
OrderFreeInfo3 | §OrderFreeInfo3 | FirmAddress3 | §FirmAddress3
OrderFreeInfo4 | §OrderFreeInfo4 | FirmAddress4 | §FirmAddress4
OrderFreeInfo5 | §OrderFreeInfo5 | FirmPostNumber | §FirmPostNumber
OrderFreeInfo6 | §OrderFreeInfo6 | FirmPostPlace | §FirmPostPlace
OrderYourRef | §OrderYourRef | FirmPhone | §FirmPhone
OrderOurRef | §OrderOurRef | FirmFax | §FirmFax
OrderCountry | §OrderCountry | FirmBankGiro | §FirmBankGiro
OrderMainNo | §OrderMainNo | FirmPostGiro | §FirmPostGiro
OrderBaseNo | §OrderBaseNo |  |
OrderOfferNo | §OrderOfferNo | UserName | §UserName
OrderDate | §OrderDate | UserTitle | §UserTitle
OrderRequestedDate | §OrderRequestedDate | UserInitial | §UserInitial
OrderConfirmedDate | §OrderConfirmedDate |  |
OrderInvoiceNo | §OrderInvoiceNo |  |
OrderInvoiceDate | §OrderInvoiceDate |  |
OrderDeliveryName | §OrderDeliveryName |  |
OrderDeliveryAddress1 | §OrderDeliveryAddress1 |  |
OrderDeliveryAddress2 | §OrderDeliveryAddress2 |  |
OrderDeliveryAddress3 | §OrderDeliveryAddress3 |  |
OrderDeliveryAddress4 | §OrderDeliveryAddress4 |  |
OrderDeliveryPostNo | §OrderDeliveryPostNo |  |
OrderDeliveryPostPlace | §OrderDeliveryPostPlace |  |
MACRO_R2_COLUMN_INFO
RespUnitNo | §RespUnitNo | DocFileName | §DocFileName
RespUnitName | §RespUnitName | DocPathFileName | §DocPathFileName
RespUnitAddress1 | §RespUnitAddress1 | DocTheme | §DocTheme
RespUnitAddress2 | §RespUnitAddress2 | DocDesc | §DocDesc
RespUnitAddress3 | §RespUnitAddress3 | DocDate | §DocDate
RespUnitAddress4 | §RespUnitAddress4 | DocYear | §DocYear
RespUnitPostNo | §RespUnitPostNo | DocMonth | §DocMonth
RespUnitPostPlace | §RespUnitPostPlace | DocDay | §DocDay
RespUnitCustomerNo | §RespUnitCustomerNo |  |
RespUnitSupplierNo | §RespUnitSupplierNo | FirmName | §FirmName
RespUnitResponsible | §RespUnitResponsible | FirmAddress1 | §FirmAddress1
RespUnitFreeInfo1 | §RespUnitFreeInfo1 | FirmAddress2 | §FirmAddress2
RespUnitFreeInfo2 | §RespUnitFreeInfo2 | FirmAddress3 | §FirmAddress3
RespUnitFreeInfo3 | §RespUnitFreeInfo3 | FirmAddress4 | §FirmAddress4
RespUnitFreeInfo4 | §RespUnitFreeInfo4 | FirmPostNumber | §FirmPostNumber
RespUnitFreeInfo5 | §RespUnitFreeInfo5 | FirmPostPlace | §FirmPostPlace
RespUnitFreeInfo6 | §RespUnitFreeInfo6 | FirmPhone | §FirmPhone
RespUnitFreeInfo7 | §RespUnitFreeInfo7 | FirmFax | §FirmFax
RespUnitFreeInfo8 | §RespUnitFreeInfo8 | FirmBankGiro | §FirmBankGiro
RespUnitEMail | §RespUnitEMail | FirmPostGiro | §FirmPostGiro
RespUnitCountry | §RespUnitCountry |  |
 |  | UserName | §UserName
 |  | UserTitle | §UserTitle
 |  | UserInitial | §UserInitial
MACRO_PRODUCT_COLUMN_INFO
ProductNumber | §ProductNumber | DocFileName | §DocFileName
ProductDescription | §ProductDescription | DocPathFileName | §DocPathFileName
ProductType1 | §ProductType1 | DocTheme | §DocTheme
ProductPriceGroup1 | §ProductPriceGroup1 | DocDesc | §DocDesc
ProductStandardSalesUnit | §ProductStandardSalesUnit | DocDate | §DocDate
ProductDesiredMargin | §ProductDesiredMargin | DocYear | §DocYear
ProductNormalStock | §ProductNormalStock | DocMonth | §DocMonth
ProductVolumePerUnit | §ProductVolumePerUnit | DocDay | §DocDay
ProductReplacementProduct | §ProductReplacementProduct |  |
ProductFreeInfo1 | §ProductFreeInfo1 | FirmName | §FirmName
ProductFreeInfo2 | §ProductFreeInfo2 | FirmAddress1 | §FirmAddress1
ProductFreeInfo3 | §ProductFreeInfo3 | FirmAddress2 | §FirmAddress2
ProductFreeInfo4 | §ProductFreeInfo4 | FirmAddress3 | §FirmAddress3
ProductFreeInfo5 | §ProductFreeInfo5 | FirmAddress4 | §FirmAddress4
ProductFreeInfo6 | §ProductFreeInfo6 | FirmPostNumber | §FirmPostNumber
ProductType2 | §ProductType2 | FirmPostPlace | §FirmPostPlace
ProductResponsible | §ProductResponsible | FirmPhone | §FirmPhone
ProductBuyer | §ProductBuyer | FirmFax | §FirmFax
ProductPriceGroup2 | §ProductPriceGroup2 | FirmBankGiro | §FirmBankGiro
ProductPriceGroup3 | §ProductPriceGroup3 | FirmPostGiro | §FirmPostGiro
ProductUnitMeasure | §ProductUnitMeasure |  |
ProductUnitsPerUnit | §ProductUnitsPerUnit | UserName | §UserName
ProductFreeInfo7 | §ProductFreeInfo7 | UserTitle | §UserTitle
ProductFreeInfo8 | §ProductFreeInfo8 | UserInitial | §UserInitial
ProductType3 | §ProductType3 |  |
ProductType4 | §ProductType4 |  |
ProductPriceUnit | §ProductPriceUnit |  |
ProductPriceNumber | §ProductPriceNumber |  |
ProductOldNumber | §ProductOldNumber |  |
ProductEanItemNumber | §ProductEanItemNumber |  |
ProductNewNumber | §ProductNewNumber |  |
ProductScanFolderNumber | §ProductScanFolderNumber |  |
ProductScanDocumentNumber | §ProductScanDocumentNumber |  |


Tags from table Products

From products to Word og Excel

From version 3. | Tag name | From version 4.40 | Tag name
FirmName | §FirmName | DocYear | §DocYear
DocDesc | §DocDesc | DocMonth | §DocMonth
DocDate | §DocDate | DocDay | §DocDay
 |  | DocFileName | §DocFileName
 |  | DocPathFileName | §DocPathFileName
From version 4.50 |  |  |
ProductNumber | §ProductNumber | ProductUnitMeasure | §ProductUnitMeasure
ProductDescription | §ProductDescription | ProductUnitsPerUnit | §ProductUnitsPerUnit
ProductType1 | §ProductType1 | ProductPriceUnit | §ProductPriceUnit
ProductType2 | §ProductType2 | ProductPriceNumber | §ProductPriceNumber
ProductType3 | §ProductType3 | ProductOldNumber | §ProductOldNumber
ProductType4 | §ProductType4 | ProductEanItemNumber | §ProductEanItemNumber
ProductPriceGroup1 | §ProductPriceGroup1 | ProductNewNumber | §ProductNewNumber
ProductPriceGroup2 | §ProductPriceGroup2 | ProductScanFolderNumber | §ProductScanFolderNumber
ProductPriceGroup3 | §ProductPriceGroup3 | ProductScanDocumentNumber | §ProductScanDocumentNumber
ProductStandardSalesUnit | §ProductStandardSalesUnit |  |
ProductDesiredMargin | §ProductDesiredMargin | FirmAddress1 | §FirmAddress1
ProductNormalStock | §ProductNormalStock | FirmAddress2 | §FirmAddress2
ProductVolumePerUnit | §ProductVolumePerUnit | FirmAddress3 | §FirmAddress3
ProductReplacementProduct | §ProductReplacementProduct | FirmAddress4 | §FirmAddress4
ProductFreeInfo1 | §ProductFreeInfo1 | FirmPostNumber | §FirmPostNumber
ProductFreeInfo2 | §ProductFreeInfo2 | FirmPostPlace | §FirmPostPlace
ProductFreeInfo3 | §ProductFreeInfo3 | FirmPhone | §FirmPhone
ProductFreeInfo4 | §ProductFreeInfo4 | FirmFax | §FirmFax
ProductFreeInfo5 | §ProductFreeInfo5 | FirmBankGiro | §FirmBankGiro
ProductFreeInfo6 | §ProductFreeInfo6 | FirmPostGiro | §FirmPostGiro
ProductFreeInfo7 | §ProductFreeInfo7 |  |
ProductFreeInfo8 | §ProductFreeInfo8 |  |
ProductResponsible | §ProductResponsible |  |
ProductBuyer | §ProductBuyer |  |


From Associate table to Word og Excel

From Associate table to Word og Excel

From version 3.x | Tag name | From version 4.01 | Tag name
ActorNo | §ActorNo | ActorEMail | §ActorEMail
ActorName | §ActorName |  |
ActorAddress1 | §ActorAddress1 | From version 4.20: |
ActorAddress2 | §ActorAddress2 |  |
ActorAddress3 | §ActorAddress3 | ContactActorNo | §ContactActorNo
ActorAddress4 | §ActorAddress4 | ContactActorName | §ContactActorName
ActorPostNo | §ActorPostNo | ContactActorAddress1 | §ContactActorAddress1
ActorPostPlace | §ActorPostPlace | ContactActorAddress2 | §ContactActorAddress2
ActorCountry | §ActorCountry | ContactActorAddress3 | §ContactActorAddress3
ActorPhone | §ActorPhone | ContactActorAddress4 | §ContactActorAddress4
ActorFax | §ActorFax | ContactActorPostNo | §ContactActorPostNo
ActorCustomerNo | §ActorCustomerNo | ContactActorPostPlace | §ContactActorPostPlace
ActorSupplierNo | §ActorSupplierNo | ContactActorPhone | §ContactActorPhone
ActorFreeInfo1 | §ActorFreeInfo1 | ContactActorFax | §ContactActorFax
ActorFreeInfo2 | §ActorFreeInfo2 | ContactActorCustomerNo | §ContactActorCustomerNo
ActorFreeInfo3 | §ActorFreeInfo3 | ContactActorSupplierNo | §ContactActorSupplierNo
ActorFreeInfo4 | §ActorFreeInfo4 | ContactActorFreeInfo1 | §ContactActorFreeInfo1
ActorFreeInfo5 | §ActorFreeInfo5 | ContactActorFreeInfo2 | §ContactActorFreeInfo2
ActorFreeInfo6 | §ActorFreeInfo6 | ContactActorFreeInfo3 | §ContactActorFreeInfo3
ActorLiaison1 | §ActorLiaison1 | ContactActorFreeInfo4 | §ContactActorFreeInfo4
FirmName | §FirmName | ContactActorFreeInfo5 | §ContactActorFreeInfo5
UserName | §UserName | ContactActorFreeInfo6 | §ContactActorFreeInfo6
UserTitle | §UserTitle | ContactActorFreeInfo7 | §ContactActorFreeInfo7
UserInitial | §UserInitial | ContactActorFreeInfo8 | §ContactActorFreeInfo8
YourRef | §YourRef | ContactActorEMail | §ContactActorEMail
ActorYourRef | §ActorYourRef | ContactActorYourRef | §ContactActorYourRef
FirmAddress1 | §FirmAddress1 | ContactActorCountry | §ContactActorCountry
FirmAddress2 | §FirmAddress2 | ActorFreeInfo7 | §ActorFreeInfo7
FirmAddress3 | §FirmAddress3 | ActorFreeInfo8 | §ActorFreeInfo8
FirmAddress4 | §FirmAddress4 |  |
FirmPostNumber | §FirmPostNumber | From version 4.40 |
FirmPostPlace | §FirmPostPlace | DocYear | §DocYear
FirmPhone | §FirmPhone | DocMonth | §DocMonth
FirmFax | §FirmFax | DocDay | §DocDay
FirmBankGiro | §FirmBankGiro | ActorISOCountry | §ActorISOCountry
FirmPostGiro | §FirmPostGiro | ContactActorISOCountry | §ContactActorISOCountry
DocTheme | §DocTheme | DocFileName | §DocFileName
DocDesc | §DocDesc | DocPathFileName | §DocPathFileName
DocDate | §DocDate |  |
 |  | From version 4.50 |
 |  | ActorISOCountry | §ActorISOCountry
 |  | ContactActorISOCountry | §ContactActorISOCountry


Tags in table Appointments

This are the Visma tags that can be used from Appointments

From version 3. | Tag name | From version 4.50 | Tag name
FirmName | §FirmName | ActorNo | §ActorNo
UserName | §UserName | FirmAddress1 | §FirmAddress1
UserTitle | §UserTitle | FirmAddress2 | §FirmAddress2
UserInitial | §UserInitial | FirmAddress3 | §FirmAddress3
DocTheme | §DocTheme | FirmAddress4 | §FirmAddress4
DocDesc | §DocDesc | FirmPostNumber | §FirmPostNumber
DocDate | §DocDate | FirmPostPlace | §FirmPostPlace
 |  | FirmPhone | §FirmPhone
From version 4.40 |  | FirmFax | §FirmFax
DocYear | §DocYear | FirmBankGiro | §FirmBankGiro
DocMonth | §DocMonth | FirmPostGiro | §FirmPostGiro
DocDay | §DocDay |  |
DocFileName | §DocFileName |  |
DocPathFileName | §DocPathFileName |  |


Tags in table Order

This is the Visma taggs that can be used from Orders

From version 3.x |  | From version 4.40 |
ActorNo | §ActorNo | DocYear | §DocYear
FirmName | §FirmName | DocMonth | §DocMonth
DocDesc | §DocDesc | DocDay | §DocDay
DocDate | §DocDate | DocFileName | §DocFileName
 |  | DocPathFileName | §DocPathFileName
From version 4.50 |  |  |
OrderNo | §OrderNo | OrderDeliveryName | §OrderDeliveryName
OrderName | §OrderName | OrderDeliveryAddress1 | §OrderDeliveryAddress1
OrderAddress1 | §OrderAddress1 | OrderDeliveryAddress2 | §OrderDeliveryAddress2
OrderAddress2 | §OrderAddress2 | OrderDeliveryAddress3 | §OrderDeliveryAddress3
OrderAddress3 | §OrderAddress3 | OrderDeliveryAddress4 | §OrderDeliveryAddress4
OrderAddress4 | §OrderAddress4 | OrderDeliveryPostNo | §OrderDeliveryPostNo
OrderPostNo | §OrderPostNo | OrderDeliveryPostPlace | §OrderDeliveryPostPlace
OrderPostPlace | §OrderPostPlace |  |
OrderCustomerNo | §OrderCustomerNo | FirmAddress1 | §FirmAddress1
OrderSupplierNo | §OrderSupplierNo | FirmAddress2 | §FirmAddress2
OrderFreeInfo1 | §OrderFreeInfo1 | FirmAddress3 | §FirmAddress3
OrderFreeInfo2 | §OrderFreeInfo2 | FirmAddress4 | §FirmAddress4
OrderFreeInfo3 | §OrderFreeInfo3 | FirmPostNumber | §FirmPostNumber
OrderFreeInfo4 | §OrderFreeInfo4 | FirmPostPlace | §FirmPostPlace
OrderFreeInfo5 | §OrderFreeInfo5 | FirmPhone | §FirmPhone
OrderFreeInfo6 | §OrderFreeInfo6 | FirmFax | §FirmFax
OrderYourRef | §OrderYourRef | FirmBankGiro | §FirmBankGiro
OrderOurRef | §OrderOurRef | FirmPostGiro | §FirmPostGiro
OrderCountry | §OrderCountry |  |
OrderMainNo | §OrderMainNo |  |
OrderOfferNo | §OrderOfferNo |  |
OrderDate | §OrderDate |  |
OrderRequestedDate | §OrderRequestedDate |  |
OrderConfirmedDate | §OrderConfirmedDate |  |
OrderInvoiceNo | §OrderInvoiceNo |  |
OrderInvoiceDate | §OrderInvoiceDate |  |


Tags in table Organisational units

This is the Visma tags that can be used from other Organisational units

(excepts R2)

From version 3.x | Tag name | From version 4.50 | Tag name
ActorLiaison1 | §ActorLiaison1 | ActorNo | §ActorNo
FirmName | §FirmName | FirmAddress1 | §FirmAddress1
UserName | §UserName | FirmAddress2 | §FirmAddress2
UserTitle | §UserTitle | FirmAddress3 | §FirmAddress3
UserInitial | §UserInitial | FirmAddress4 | §FirmAddress4
Yourref | §Yourref | FirmPostNumber | §FirmPostNumber
DocTheme | §DocTheme | FirmPostPlace | §FirmPostPlace
DocDesc | §DocDesc | FirmPhone | §FirmPhone
DocDate | §DocDate | FirmFax | §FirmFax
 |  | FirmBankGiro | §FirmBankGiro
From version 4.40 |  | FirmPostGiro | §FirmPostGiro
DocYear | §DocYear |  |
DocMonth | §DocMonth |  |
DocDay | §DocDay |  |
DocFileName | §DocFileName |  |
DocPathFileName | §DocPathFileName |  |


This is the Visma tags that can be used from Organisational units 2

(Projects)

Fra ver.3.x: | Tag name | Fra ver.4.40: | Tag name
ActorLiaison1 | §ActorLiaison1 | DocYear | §DocYear
FirmName | §FirmName | DocMonth | §DocMonth
UserName | §UserName | DocDay | §DocDay
UserTitle | §UserTitle | DocFileName | §DocFileName
UserInitial | §UserInitial | DocPathFileName | §DocPathFileName
Yourref | §Yourref |  |
DocTheme | §DocTheme |  |
DocDesc | §DocDesc |  |
DocDate | §DocDate |  |
From version 4.50 |  |  |
RespUnitNo | §RespUnitNo | FirmAddress1 | §FirmAddress1
RespUnitName | §RespUnitName | FirmAddress2 | §FirmAddress2
RespUnitAddress1 | §RespUnitAddress1 | FirmAddress3 | §FirmAddress3
RespUnitAddress2 | §RespUnitAddress2 | FirmAddress4 | §FirmAddress4
RespUnitAddress3 | §RespUnitAddress3 | FirmPostNumber | §FirmPostNumber
RespUnitAddress4 | §RespUnitAddress4 | FirmPostPlace | §FirmPostPlace
RespUnitPostNo | §RespUnitPostNo | FirmPhone | §FirmPhone
RespUnitPostPlace | §RespUnitPostPlace | FirmFax | §FirmFax
RespUnitCustomerNo | §RespUnitCustomerNo | FirmBankGiro | §FirmBankGiro
RespUnitSupplierNo | §RespUnitSupplierNo | FirmPostGiro | §FirmPostGiro
RespUnitResponsible | §RespUnitResponsible |  |
RespUnitFreeInfo1 | §RespUnitFreeInfo1 |  |
RespUnitFreeInfo2 | §RespUnitFreeInfo2 |  |
RespUnitFreeInfo3 | §RespUnitFreeInfo3 |  |
RespUnitFreeInfo4 | §RespUnitFreeInfo4 |  |
RespUnitFreeInfo5 | §RespUnitFreeInfo5 |  |
RespUnitFreeInfo6 | §RespUnitFreeInfo6 |  |
RespUnitFreeInfo7 | §RespUnitFreeInfo7 |  |
RespUnitFreeInfo8 | §RespUnitFreeInfo8 |  |
RespUnitEMail | §RespUnitEMail |  |
RespUnitCountry | §RespUnitCountry |  |


Tags in table Recourses

This is Visma tags that can be used from Recourses

Fra ver.3.x: |  | From version 4.50 | Tag name
FirmName | §FirmName | ActorNo | §ActorNo
UserName | §UserName | FirmAddress1 | §FirmAddress1
UserTitle | §UserTitle | FirmAddress2 | §FirmAddress2
UserInitial | §UserInitial | FirmAddress3 | §FirmAddress3
DocTheme | §DocTheme | FirmAddress4 | §FirmAddress4
DocDesc | §DocDesc | FirmPostNumber | §FirmPostNumber
DocDate | §DocDate | FirmPostPlace | §FirmPostPlace
 |  | FirmPhone | §FirmPhone
Fra ver.4.01: |  | FirmFax | §FirmFax
DocYear | §DocYear | FirmBankGiro | §FirmBankGiro
DocMonth | §DocMonth | FirmPostGiro | §FirmPostGiro
DocDay | §DocDay |  |
DocFileName | §DocFileName |  |
DocPathFileName | §DocPathFileName |  |


Fletting av etiketter fra Visma Business

Fletting av adresse-etiketter fra Visma Business

For å få til fletting av adresseetiketter fra Visma Business databasen til Word, så må det gjøres en del settinger i Word:

Velg Mail Merge fra menyen Tools.

Start med knappen Create og velg Mailing Labels.

Klikk på Active Window i denne dialogen.

Knappen Get Data blir aktiv. Her velger du Create Data Source, og du får opp denne dialogen. Klikk på knappen MS Query.

MS Query starter. Marker <New Data Source> og klikk OK.

Gi datakilden et navn og velg riktig driver. Klikk på Connect.

Angi riktig server og login ID, og klikk på Options>>

Velg Database, og klikk OK.

Hent frem tabellen Actor i felt 4, og klikk OK

Marker datakilden og klikk OK.

Flytt over de kolonnene du ønsker å ha med i din query, og klikk Next>

I denne dialogen kan du gjøre de utvalgene du ønsker. F.eks. fra/til kundenummer.

I denne dialogen kan du evt. sortere dataene

Velg Return Data to Microsoft Word og klikk på Finish.

Bekreft denne dialogen

Dialogboksen Label Opitions gir deg mulighet til å tilpasse etikettene. Klikk Ok.

Her setter du inn de feltene du ønsker skal synes på etikettene.

Klikk på Merge i denne dialogen

Her klikker du også på Merge og etikettene er laget


Fletting av etiketter Microsoft Office 2007

Dette dokumentet beskriver en metode for å lage adresse-etiketter til aktørene i Visma Business. Funksjonaliteten rundt fletting er i Word2007 samlet under fliken "Mailings". Du starter med å velge "Labels" under knappen "Start Mail Merge":

Dette valget leder til dialogen nedenfor. Her må du ta stilling til bl. a hvilken skuff i printeren det skal trekkes papir fra, hvor store etikettene skal være etc. Når disse parameterne er satt, klikker du OK.

Neste punkt under fliken "Mailings" er "Select Recipients". Her velger du "Use Existing List":

Dette valget fører til dialogen nedenfor. Her skal du velge å lage en " New SQL Server Connection.odc". Velg dette og klikk "Open":

Følgende Wizard starter. Her begynner du med å legge inn navnet på SQL Serveren, og evt. passord:

I neste steg velger du hvilken Firmabase du skal lage etiketter til, og deretter må du angi hvilken tabell du skal hente dataene i, nemlig tabellen Actor:

Wizarden avsluttes med at du lagrer koblingen med et navn og evt. en beskrivelse:

Neste menypunkt under "Mailings" er "Edit Recipients List".

Dette menypunktet åpner dialogen hvor du får mulighet til å selektere og sortere dataene. I dette eksempelet ønsker vi å lage etiketter på alle kundene i databasen. Vi må derfor gjøre en selektering. Ikonet for "Filter" åpner dialogen hvor dette skal gjøres:

Følgende selektering sørger for at vi kun får treff på aktører som har et kundenummer i aktørtabellen i Visma Business (Kundenummer forskjellig fra 0):

Klikk OK her, og klikk OK i dialogen "Mail Merge Recipients".

Da er du klar for å velge de feltene fra Visma Business du ønsker skal være med på etikettene. Dette gjøres fra menypunktet "Insert Merge Field":

I vårt eksempel skal etikettene bestå av kundens navn, adresselinje1, postnummer og poststed. Velg først navn (Nm). Tast en "Enter" slik at du kommer på ny linje. Hent så neste felt; Ad1. Gjenta dette til du har med de feltene du ønsker. Øverste del av arket ser nå slik ut:

Det neste du nå skal gjøre er å klikke på "Update Labels":

Dette fører til at alle etikettene oppdateres likt med den "malen" du definerte:

Til slutt kan du klikke på "Preview results" for å se resultatet, og "Finish & Merge"-nedtrekksmenyen for å ferdigbehandle:


Flette brev via kampanje

Skjermbildet Aktivitetsprosessen som kan importeres til Visma Business.

Hvordan ta i bruk og nyttiggjøre denne funksjonaliteten?

I skillearket Planlegging gjøres planleggingen for kampanjen:

Her har du også oversikt over Dokumenter, Memoer etc. som knytter seg til kampanjen.

I skillearket Deltagere gjøres de utvalg og selekteringer som skal danne grunnlaget for hvilke kunder som skal motta informasjon om kampanjen. Det finnes en rekke muligheter for selektering/utvalg i de ulike skillearkene i de tilkoblede sideelementene:

Etter at du har definert ønsket utvalg, trykker du på knappen "Generer kampanjeliste" fra Behandlingsmenyen.

Følgende dialog fremkommer:

Inf. typene hentes fra tabellen Inf. typer. I denne tabellen kan du definerer ønskede "kategorier". Ved å koble tabellen Inf. behov til Aktørtabellen kan du angi den enkelte aktørs "Informasjonsbehov".

I overstående dialog kan du ytterligere avgrense hvilke aktører som skal motta informasjon ved hjelp av Inf. typen. Velger du f. eks Innkjøpere vil alle aktører med denne inf. typen og som er med i "hovedutvalget" motta informasjon.

Krysser du videre av for Kontaktperson, så avgrenses utvalget til kontaktpersonene hos de kundene som er med i "hovedutvalget".

Kryss i Unik gir deg èn forekomst av hver kunde/kontaktperson i utvalget.

I feltet "Tittel" kan du legge inn f. eks Innkjøper. Dette, kombinert med avkrysning i Unik, vil gi en deltagerliste som inneholder èn forekomst av hver kunde med "attention" Innkjøper (istedenfor navn på innkjøper).

Klikk OK og systemet genererer en deltagerliste på bakgrunn av de utvalg/selekteringer som er gjort:

Da er du klar til å flette brev mot dette utvalget.

Via Behandlingsmenyen velger du "Flett brev", og får opp denne dialogen:

Forklaring til feltene i dialogen:

Program: Her velger du den tekstbehandleren du skal bruke til brevfletting. Informasjonen hentes fra tabellen Programmer (Tabeller – Felles – CRM – Dokumenter).

Flette dokument: Her velger du malen for flettebrevet. Informasjon hentes fra tabellen Maler (Tabeller – Felles – Dokumenter).

Data kilde: Her oppgir du stien og filnavnet for kildedataene, det vil si opplysningene som skal bli flettet inn i brevet. Visma Business foreslår automatisk en fil. Bruk den eller oppgi eventuelt en annen fil.

Ny fil: Kryss av i denne sjekkboksen hvis du vil at innholdet i filen med kildedataene skal bli laget på nytt, basert på utvalget av mottakere du nå har gjort.
Hvis du ikke krysser av her, blir det eksisterende innholdet i filen brukt. Det vil si at det ikke blir tatt hensyn til det eventuelle utvalget du nå har gjort.
Standard er feltet krysset.

Slett kilde: Kryss av i denne sjekkboksen hvis du vil at filen med kildedataene skal bli slettet etter at flettingen er gjort.
Ønsker du å ta vare på denne filen, krysser du ikke av her.
Standard er feltet krysset.

Flette type: Her velger du hvilken form du ønsker å distribuere flettebrevet på.

o     Bare fil: Velg denne radioknappen hvis du bare vil opprette filen med kildedataene, basert på utvalget av mottakere du nå har gjort. Det blir da ikke utført noen fletting.

o     Skriver: Velg denne radioknappen hvis du vil at alle flettebrevene skal bli skrevet ut på skriver.
Standard er denne radioknappen på.

o     Telefax: Velg denne radioknappen hvis du vil at mottakere som er registrert med telefaksnummer i tabellen "Aktører" skal motta brevet som telefaks.
MERK! Feltet "Skriv hvis ikke telefaks", må være krysset av i tabellen "Bedriftsopplysninger". I tillegg må du ha installert et telefaksprogram som kan lese faksnummeret som Visma Business legger ut på dokumentet.

o     E-post: Velg denne radioknappen hvis du vil at mottakere som er registrert med E-postadresse i tabellen "Aktører" skal motta brevet som elektronisk post. Fyll inn et emne for E-posten i feltet til høyre.
Mottakere som ikke har E-postadresse, vil motta brevet som telefaks hvis de har et telefaksnummer, hvis ikke blir brevet skrevet ut på skriver.
MERK! Det må være installert et program for elektronisk post som er integrert med et telefakssystem.
Feltet "Telefaks hvis ikke E-post", må være krysset av i tabellen "Bedriftsopplysninger".
Feltet "Skriv hvis ikke telefaks", må være krysset av i tabellen "Bedriftsopplysninger".

o     Fil: Velg denne radioknappen hvis du vil lagre flettebrevene i en fil i stedet for å skrive dem ut eller sende dem. I feltet til høyre oppgir du stien og filnavnet til filen.

Dokumentbeskrivelse: Her taster du inn en beskrivelse for flettebrevet. Den blir senere vist i feltet "Beskrivelse" i dokumentoversikten (tabellen "Dokumentkoblinger) i Visma Business.

Vår ref.: Her står initialene dine med små bokstaver. De blir satt inn automatisk i brevet under flettingen hvis malen er laget slik.

Bruker: Her står navnet ditt. Det blir automatisk satt inn i brevet under flettingen hvis malen er laget slik.

Tittel: Her står tittelen din. Det forutsetter at tittelen er registrert i tabellen "Aktører".

Att.: Her skriver du hvem som skal ha brevet hos mottakeren, for eksempel salgsansvarlig eller daglig leder. Teksten blir automatisk satt inn i brevet under flettingen hvis malen er laget slik.

Passord: Hvis du ønsker å passordbeskytte flettebrevet, legger du inn passordet i dette feltet. Da kan brevet bare bli åpnet hvis du kjenner passordet.

Privat: Sjekkboksen "Privat", må bli avkrysset når du legger inn passord.

Dato: Her står dagens dato. Den blir automatisk satt inn i brevet under flettingen hvis malen er laget slik. Du kan endre dato hvis du ønsker det.

Gruppe: I denne nedtrekkslisten velger du hvilken gruppe du ønsker at flettedokumentet skal tilhøre. Visma Business lagrer valgt dokumentgruppe i tabellen "Dokument".
MERK! Dokumentgruppene oppretter du i tabellen "Tekster". Denne finner du under mappen "Faste opplysninger".

Hjelp: Denne knappen leder til CRM hjelpen under Visma Business.

Etter at kampanjen er gjennomført gjøres oppfølging og analyse. I skillearket Deltagere kan du angi hva slags respons du har fått fra de forskjellige deltagerne. Hvis vedkommende ga respons på kampanjen, kan du angi antall produkter (for eksempel antall minutter, antall brosjyrer) som vedkommende ønsket. Du vil få med antallet når du senere skal opprette en aktivitet utfra kampanjen. Hvis antallet ikke er utfylt, blir i stedet verdien i feltet "Antall" på aktivitet fra tabellen "Responstype foreslått. Du bør fylle ut feltet "Antall" hvis du senere skal generere ordre utfra aktiviteten.

Når responstypen er satt for de enkelte deltagerne, kan du fra tabellen Kampanje velge Opprett aktivitet fra Behandlingsmenyen.
I dialogen som fremkommer velger du hvilken responstype som skal overføres til aktiviteter og du angir også hvem som er ansvarlig for oppfølging.

Ut i fra denne dialogen vil du nå få overført de deltagerne som har responstype 32 "Ønsker møte" over til Aktiviteter. Feltet Overført blir nå avkrysset.

I skillearket Aktiviteter vil du nå ha følgende:

Disse aktivitetene finner du også i skjermbildet My Business på den brukeren som ble satt som ansvarlig. Herfra kan du videre generere ordre ut fra aktiviteten.

I skillearket Analyse har du oversikt over hva kampanjen evt. har generert av produkt- og hovedbokstransaksjoner.


CRM integrasjon

Når det gjelder selve installasjonen av integrasjonen, vil den ikke bli beskrevet i dette dokumentet. I hjelpefilen for integrasjonen (SetupVsoLnk.chm), er det en detaljert beskrivelse av installasjonen, steg for steg.

Det som vil bli beskrevet i dette dokumentet er sentrale deler av installasjonen og kjente feilsituasjoner.

Integrasjonen virker bare en vei

Det mest vanlige problemet som kan oppstå etter installasjon er at integrasjonen ikke fungerer begge veier. Det fungerer å endre data i Visma CRM og det kommer over i Visma Business, men når du endrer data i Visma Business kommer ikke disse over i Visma CRM.

Dette skyldes som oftest at VSOIWMod-komponenten ikke er riktig registrert.

Når endringer gjøres i Visma CRM fyres triggere og prosedyrer på sql-server, slik at data skrives direkte til Visma Business. Men fra Visma Business til Visma CRM går data via en dcom-komponent som heter VSOIWMod.

Det du da bør undersøke er om filene VSOIWMod.exe og VSOISLib.dll ligger i katalogen c:\program files\windows\system32\ på Sql-Server og om de er registrert.

Hvis de ikke ligger i system32-katalogen, må du kopiere disse filene dit fra katalogen der installasjonsfilene til integrasjonen ligger.

VSOIWMod.exe registeres ved å gå i en dos kommandoboks og skrive:

c:\program files\windows\system32\VSOIWMod.exe /regserver.

VSOISLib.dll registreres ved å trykke ”start” -> ”run” og så skrive inn:

Regsvr32 ‘c:\program files\windows\system32\VSOISLib.dll’.

Som default blir komponenten satt til å kjøre på interaktiv bruker, men det som da kan skje er at brukeren ikke har rettigheter nok, slik at data ikke overføres til Visma CRM.

Det du da bør gjøre er å sette den til å kjøre på en egen bruker, som har tilstrekkelige rettigheter på Sql Server

For å komme til denne dialogboksen trykker du ”start” -> ”run”, skriver ”dcomcnfg” og trykker ”ok”.

Du blar deg så fram til komponenten VSOIWMod som ligger under ”komponenttjenester” -> ”datamaskiner” -> ”min datamaskin” -> ”dcom-konfigurasjon”

Høyreklikk på VSOIWMod og velg egenskaper.

Hvis du velger å benytte en egen bruker til VSOIWMod komponenten bør du også sette verdien 1 i registrynøklene:

HKEY_CURRENT_USER\Software\Rubicon\SalesOfficeProfiles\DisableAutoDCOMUpdate

og

HKEY_LOCAL_MACHINE\Software\Rubicon\SalesOffice-Profiles\DisableAutoDCOMUpdate

Dette for å forhindre at komponenten settes tilbake til å kjøre på ”interaktiv bruker”.

Tabellen ”visrso_config”

Visrso_config er en av de mest sentrale tabellene i integrasjonen og ligger plassert i bedriftsdatabasen for Visma Business.

Her finner du informasjon om triggere som er installert, hvilke brukere og passord som er satt til å benyttes, hvilke grupperingsfelter som er integrert mellom systemene…etc.

I denne tabellen kan du gjøre endringer i konfigurasjonen uten å kjøre installasjonsrutinen på nytt.

Her er en oversikt over hva noen av feltene betyr:

rso_dbserv = Servernavn der database hvor Visma CRM ligger.
rso_cliusr = Bruker som blir benyttet til pålogging i Visma CRM.
rso_clipwd = Passord til pålogging i Visma CRM(kryptert).
rso_cliname = Klientnavn på database i Visma CRM.
vb_dbserv = Servernavn der database hvor Visma Business ligger.
vb_dbusr = Bruker som blir brukt til pålogging i Visma Business.
vb_dbpwd = Passord til pålogging i Visma Business (kryptert).
vb_dbbase = Databasenavn til Visma Business.
rso_bapikey = Bapikey i Visma CRM (kryptert).
vb_firmnum = Bedriftsnummer i Visma Business.
vb_firmname = Bedriftsnavn i Visma Business.
vb_debugmode = Setter mer detaljert logging av eller på. Loggen finns i
system32-katalogen og heter VSOISLib.log.

Tabellen ”companyinformation”

Denne tabellen ligger i databasen til Visma CRM og inneholder informasjon når data skal overføres til Visma Business. Her finner du blant annet informasjon om klientnummer i Visma Business, Servernavn der Visma Business ligger, informasjon om grupperingsfelter og infomasjon om databasebruker og passord til Visma Business.

Feillogging:

Når noe går galt under installasjon eller drift av systemet, er ofte en god logg det beste verktøyet for å finne ut hvor problemet ligger. Integrasjonen generer to slike logger som kan være nyttig. Integrasjonen loggfører i hovedsak info på to plasser:

VSOISLib.log

Ligger i system32-katalogen og gir informasjon om hva som skjer under overføring av data mellom systemene. For å få en detaljert loggføring setter du verdien 1 i feltet ”value” under ”vb_debugmode” i ”visrso_config”.

SetupVsoLnk.log:

Ligger i katalog der installasjonsfilene for integrasjonen ligger og gir informasjon om hva som gjøres under installasjonen og hva som eventuelt gikk galt.


Generelt

Ordre

Her finner du tips og gode råd i ordremodulen i Visma Business.


Standard Visma XML utskrift i Visma Business

Standard Visma XML utskrift i Visma Business 4.40.4.

Oppgradering fra tidligere versjoner

For å skrive ut e-Faktura til Posten med Visma Business standard XML må du gjøre 4 ting.

  1. Importer et formular og oppsett – e-Faktura.txt
  2. Oppdater tabellen E-dokument informasjon

Last ned skjermbilde for e-Faktura her

Last ned formular for e-Faktura her

1. Importer et formular og oppsett – e-Faktura.tx

Start Visma Business og gå inn under Opsjoner\Systemadministrasjon\Importer.

Velg Systemdatabase og ”Legg bare til nye rader” –

Klikk på ”Importer” og søk fram till filen e-Faktura.txt og velg den.

Klikk Åpne.

1.1 Formularer

Nå har du fått inn to nye formularer i formulartabellen med formular nr.

998 -”Dummy XML” og 999 - ”XML e-Faktura”, forutsatt at du ikke hadde formular nr. 998 eller 999 fra før. Formular 998 kan slettes etter import.

Merk: Hvis du hadde formular 998 eller 999 fra før har du kun fått et nytt som er tildelt neste ledige nr. - ”XML e-Faktura”. Hvis det nye formularet ikke har formular nr. 999 må du enten endre slik at formularet for ”XML e-Faktura” får 999 eller du må endre i Utskrifts oppsettet slik at det benytter det nye formular nr. og ikke 999.

1.2 Oppsett

  1. Gå på nytt inn under Opsjoner\Systemadministrasjon\Importer.
  2. Velg Systemdatabase og ”Legg bare til nye rader” (se over) –
  3. Klikk på ”Importer” og søk fram til filen e-Faktura.txt og velg den.
  4. Klikk Åpne.

Nå har du fått inn et nytt oppsett som heter ”XML med ordrelinjer” direkte under mappen Oppsett. Dette er et oppsett med Ordre og Ordrelinjer. For at XML utskriften skal fungere må alle felt som skrives ut på ordrelinjen finnes i oppsettet du skriver ut fra.

I dette oppsettet er formular 999 angitt. I Ordredokument dialogen så er det avkrysset att E-dokument ska brukes.

Merk: Hvis import av formularer har tildelt et annet nr. pga. at du allerede hadde benyttet formular nr. 999 må du kopiere det nye formularet til 999 eller endre i Formular nr. i Oppsettet.

2. Oppdatere tabellen E-dokument informasjon.

Under Tabeller\Ordre\logistikk\Faste opplysninger finnes tabellen E-dokument informasjon. Åpne den.

I denne tabellen skal følgende felt fylles ut :

  • Melding – det finnes bare en verdi i dag => 1. Faktura
  • Skriv til fil – her angis området samt ”begynnelsen” på filnavnet. I eksemplet over står det invovice. Det innebærer at filene kommer til å hete invoice3000001.xml, invoice3000002.xml, osv.
  • Les fra fil – har angis område till xml.imp.

3. Import av kun e-Faktura Formulartet uten oppsett

For de som ikke har det nye formularet etter oppgradering eller import så ligger det som egen fil e-Forumlar.txt ved utpakking av e-Faktura.zip

Se punkt 1.1 for mer informasjon.

4. Begrensninger

4.1 Fakturering av normal og direkte ordre samtidig

Det er ikke mulig å fakturere normal ordre og direkte ordre med samme imp fil i denne versjonen. Dette ligger i logikken til feltet Rest som er et felt som oppdateres ved ferdigmelding. En direkte ordre kan ikke ferdigmeldes og det gjøres ikke kontroller mot lager, slik at alt faktureres og under prosessen så er rest antall = antall

Dette kan rettes opp ved å erstatte feltet Gjenstår å plukke for direkte ordre i imp fil.

4.2 Kanselering av enkelt fakturaer

Det er ikke mulig å benytte funksjonen i dialogen for å kanslere enkelte fakturaer, det er ikke lagt noen begrensning på det i denne versjonen, men det vil i neste versjon av Visma Business ikke være mulig å kanslere enkelte fakturaer når E-dokument er valgt.

4.3 Desimal felter (0,00)

Enkelte felter gir ,00 i utlegget fra ordrehodet (formularet) dette er midlertidig løst ved å multiplisere med 1 som da gir 0,00.

4.4 Akonto-, og Fastpris fakturering

Sumlinje logikken i Akonto-/Fastpris kan ikke benyttes da sumlinjene ikke er normale ordrelinjer og blir dermed ikke med ut..

4.5 Samlefaktura

Er ikke implementert


Innføring i Visma Business Time

Fra versjon 4.50.0 ble det gjort forbedringer i forbindelse med timeregistrering knyttet mot prosjekt i Visma Business. Det er opprettet tre nye tabeller; Timegruppe, Timekalender og Timesaldoer. Kort sagt kan dusi at disse tabellene benyttes til å administrere timeregistreringen. Timene føres i aktivitetstabellen, og godkjennes med behandlingsmenyvalget ”Godkjenn Timeliste”. Alle timer føres på en ”Ressurs”. Det vil si at også de ansatte (i tillegg til maskiner, møterom o.l.) må opprettes i ressurstabellen. Dette gjør Visma Business automatisk for Timegrupper som gjelder for ansatte.

Administrasjon

Før du setter i gang må du altså ”administrere” oppsettet for timeregistreringen. Dette gjøres i standard skjermbildene ved å klikke på knappen ”Administrasjon”, og ”Timegrupper”. Her skal duopprette Timegruppe, Timekalender og Timesaldoer for ressursen som skal føre timer.

Timegruppe

Timegrupper opprettes for å skape en kalender over normal arbeidstid. Timegrupper kan opprettes for ansatte eller ressurser. Det kan opprettes et ubegrenset antall timegrupper. En typisk timegruppe kan se slik ut:

Denne timegruppen gjelder for året 2005, og vil gi 52 perioder dukan føre timer på. Den gjelder for de ansatte i Visma Business, og ikke andre ressurser (rom, maskiner etc). Den tar også hensyn til de verdier som er lagt inn i tabellen ”Ferier”. Den gir også en normaltid som tilsvarer 8 timer pr dag. Merk at dersom duskal kunne føre timer på flexitid må feltet ”Maks. Flexitid ha en verdi.

Timekalender

Neste steg er altså å opprette en timekalender ut fra timegruppen vi nettopp har laget. Dette gjøres ved å sette markørein i feltet ”Timegruppenr” og i Behandling velge ”Generer Timekalender”. Kalenderen holder oversikt over timer som normalt er tilgjengelig i angitt periode. Vi får da en timekalender som vist nedenfor:

Timesaldoer

Neste trinn er å generere en timesaldo for den ansatte.Legg inn ønsket timegruppe på den ansatte og velg generer timesaldo fra behandlingsmenyen.

Timesaldo benytter kalender fra angitt timegruppe og lager en saldo pr periode. Saldo vil holde oversikt over den tid som er fakturerbar/påløpt på ressursen/ansatt. Timesaldo blir opprettet pr ansatt/ressurs. Den ansatte opprettes nå også automatisk i ressurstabellen slik at han kan føre timer.

Som duser i bildet over er de ansatte opprettet i ressurstabellen, og det er generert en timesaldo pr ressurs, pr periode vi oppga i timegruppen.

Timeregistrering

Nå etter at timegruppe, timekalender og timesaldoer er opprettet kan vi begynne å føre timer. Dersom duskal he noen ”rene” timeførere kan dulegge opp dette i brukere/brukergrupper. I dette vinduet knyttes brukerene opp mot oppsettsgrupper. Legg inn disse brukerne i timegruppe 1. Systemansvarlig/timelistegodkjenner må være i gruppe 3 i tillegg til oppsettsgruppe 1.

Brukere som kun skal registere timer skal ha satt kryss i ”Timebruker”.

Disse brukerne vil nå komme rett inn i skjermbildet for timeregistrering. Hvis ikke ligger dette bak knappen Time/Prosjekt og Timeregistrering:

Her kommer brukeren som er innlogget automatisk opp. Du starter registreringen ved å opprette en linje:

Tast + i feltet

Søk deretter etter prosjekter ved å tatse * i feltet prosjekt.
Velg produkt. Produkter med hake i feltet ”Aktivitet” vil dukke opp som ”Timeprodukter”.
Register deretter forbrukt tid på den aktuelle dag.
Gjenta til alle timer er registrert.
Sett deretter X i feltet ”Utført”.
Timene er registrert.

Godkjenning av timeliste

Etter at timefører har ført sine timer for perioden skal de godkjennes. Dette gjøres ved å ha markøren i feltet for ressursen, og velge behandling og ”Godkjenn timeliste”.

Timelisten er nå godkjent, og ”forsvinner” fra timeregistreringsbildet.

Overfør til ordre

Det er laget et skjermbilde for overføring av godkjente timer til ordre. Disse ligger bak knappen ”Godkjenn for fakturering”. Marker de timene som skal overføres til ordre, velg behandling og ”Opprett ordre”. Timene blir overført til respektive ordre og er klar til fakturering.


Utfylt avtaleskjema

Tidredovisning

Registrering av tider i Visma Business Tidredovisning är beroende av att Tabellerna Tidgrupper, Tidkalendrar och Tidsaldon innehåller värden. Det är Aktiviteter som används för att registrera tiden samt andra inblandade tabeller som Företagsuppgifter, Aktörer, Resurser, Produkter, Pris och rabattmatrisen och Responstyp.

Tankegången bakom hela Tidredovisningsmodulen är att all tidregistrering sker utifrån Resurser. Anställda som registrerar tid finns som resurser, men resurser kan även vara materiella ting och lokaler som tidigare. Anställda finns oftast och skall finnas som aktörer med anställningsnummer. Utifrån dessa anställningsnummer kan man via ett behandlingsmenyval med automatik skapa motsvarande resurs. Vi beskriver detta närmare längre ner. Först krävs att vissa andra grundregister är ifyllda.

Tidgrupper

”Tidgrupper” är en grundtabell som används när man skapar ”Tidkalenderrader” och ”Tidsaldon” som i sin tur skapar resurser. I tabellen finns uppgifter om vilken periodindelning man vill arbeta med, om utgångspunkten skall vara anställda eller resurser, m.m. Här är en beskrivning av fälten i tabellen ”Tidgrupper”:

Beskrivning av fälten i tabellen Tidgrupper

Tidgruppnr.

Detta fält är primärnyckel i tabellen.

I detta fält tilldelas tidgruppen löpande nummer. Om du ska lägga till en tidgrupp själv kan du skriva "+" i fältet för att nästa lediga nummer ska tilldelas, eller skriva in ett nytt nummer.

Benämning

I det här fältet ger du tidgruppen ett namn som sen visas i olika dialogrutor där du kan välja tidgrupp.

Innevarande år

I detta fält anger du innevarande år. Värdet i det här fältet används senare när tidkalender skapas, och du kan även använda värdet när du gör urval i tabeller där tidgruppnummer förekommer. Fältet visar årtalet med 4 siffror (ÅÅÅÅ), men du behöver bara skriva in sista siffran i ett årtal. Värdet 4 tolkas t.ex. som 2004.

Innevarande år/period

I detta fält anger du innevarande år och period. Värdet i det här fältet används senare när tidkalender skapas, och du kan även använda värdet när du gör urval i tabeller där tidgruppnummer förekommer. Fältet visar årtal med 4 siffror och period med en siffra mellan 1 och 366 (ÅÅÅÅ/PPP). När du skriver in värdet uppfattar Visma Business de tre första siffrorna som perioden. Om du skriver in "/" uppfattas de första siffrorna som år och efterföljande siffror som period.

Exempel: Om du skriver in 4/1 blir det 2004/1.

Spärrad år/period

I detta fält anger du spärrat år och period. Värdet i det här fältet används senare när tidkalender skapas, och kontrolleras även när saldoaktiviteter läggs in. Du kan även använda värdet när du gör urval i tabeller där tidgruppnummer förekommer. Fältet visar årtal med 4 siffror och period med en siffra mellan 1 och 366 (ÅÅÅÅ/PPP). När du skriver in värdet uppfattar Visma Business de tre första siffrorna som perioden. Om du skriver in "/" uppfattas de första siffrorna som år och efterföljande siffror som period.
OBS! För årets första period ska du bara ange årtalet och period 0, och fältet visar då (ÅÅÅÅ/).

Max flextid

I det här fältet kan du ange en eventuell maximal flextid som kan överföras till nästa period.

En anställd kan till exempel ha 167 timmar som normal tid, och ha en IB på 70 timmar från förra månaden och jobba 40 timmar den här månaden. Med en normal tid visar då UB 110 och fältet "Flextidsavkortning" visar 10. IB för nästa period kommer då vara 100. De timmarna som avkortats justeras i flextidssammanhang och skulle eventuellt ges som övertid.

Tidbehandling

I det här fältet anger du behandlingsreglerna för tidgruppen. Om du gör uppslag i fältet visas följande dialogruta:

Gäller för:

Här väljer du om tidgruppen ska vara en anställningsgrupp eller en resursgrupp.
Detta bestämmer varifrån du kan skapa tidsaldo. För anställda skapas det från tabellen "Aktörer" och för resurser från tabellen "Resurser".

Perioder
  • Här anger du hur många perioder som ska användas och Visma Business räknar ut det automatiskt utifrån kalendern, och tar hänsyn till skottår.
  • Dagar skapar en kalenderrad per dag.
  • Vecka skapar en kalenderrad per vecka. Här kan vecka ett börja i föregående år och vecka 52/53 kan gå in i nästa år.
  • Månad skapar en kalenderrad per kalendermånad.
  • 4 veckor skapar en fyraveckorsperiod. Detta används i Storbritannien.
Veckodagar

Här kryssar du för vilka veckodagar du ska kunna registrera på.
Om du väljer söndag som första veckodag beräknas veckobyte på söndagar. Detta används i USA.

Reservationsregler
  • ”Reservera hela dagar” används vid de tillfällen då reservationen alltid ska gälla för hela dagen. Tiden kan gott variera i antal timmar.
  • Om du använder ”Kontrollera fridagar” kontrolleras datum i tabellen "Fridagar" när tidkalender och tidsaldo skapas.
  • ”Ej orderkontroll” ger varning om att resursen redan är bokad.
  • ”Ej aktivitetskontroll” ger varning om att aktiviteten redan är bokad

Perioder per år

Det här fältet beräknas automatiskt utifrån vilket periodmått du valt i fältet "Tidbehandling".

Från kl

Det här fältet används när tidkalender skapas. Som standard används det som starttid för varje giltig veckodag.

Till kl

Det här fältet används när tidkalender skapas. Som standard används det som sluttid för varje giltig veckodag.

Avvikelsetid

När tidkalender skapas används det här fältet som standardavdrag av "Totaltid per dag", till exempel 00:30 för lunchrast.

Normaltid

Det här fältet visar antal timmar och värdet utgörs av differensen mellan fälten "Från kl." och Till kl."

Skapa Tidkalender

Behandlingsmenyvalet "Skapa tidkalender" i tabellen "Tidgrupper" leder till en dialog med alternativrutor.

Generering av Tidkalender skapar en kalenderrad för varje period för vald grupp och använder värden från denna dialog på alla rader. Tidkalendern kommer sedan i sin tur att vara underlaget för att skapa Tidsaldon till varje enskild anställd eller resurs.

Om det finns en rad för vald period sedan tidigare eller en senare period inom periodvalet så kommer det inte att skapas några rader.

Förklaring till fälten i dialogen “Skapa Tidkalender”

Fält | Förklaring
Generellt |
Tidgrupper | Gruppen hämtas från den aktiva Tidgruppen du stod på när menyvalet gjordes. Det visas också om gruppen gäller för anställda eller resurser och för vilket periodval som gäller. Det är inte möjligt att ändra detta val så om det är fel grupp måste du avbryta.
Från datum Till datum | Från och Till datum föreslås utifrån Spärrad period i från datum och kalenderåret ut i till datum. I vissa tillfällen när vecka är periodbegreppet så kan förslaget ligga både i föregående år i från datum och nästa år i till datum då vecka 1 kan starta föregående år och vecka 52/53 kan sluta i nästa år.
Reservera hela dagen | Denna parameter överför till Tidkalender och sedan vidare till Tidsaldo för varje resurs och används för att reservera resursen hela dagen även om den inte används hela tiden. Speciellt användbart vid utlåning/bokning av hotellrum, bilar och liknande.
Kontrollera fridagar | Detta kryss medför att generering av Tidkalender kontrollerar tabellen fridagar och tar hänsyn till denna. Det förutsätter att resursnr. och omfattning för Tidkalender är satt på fridagen.
Nollsaldo för fridagar | Krysset i detta fält skapar en Kalenderrad utan tid, d.v.s. från och till kl. 00:00 – 00:00, och kan inte reserveras. Detta sker så att externa program skall kunna producera rapporter och liknande, och det ger också användare av Visma Business en bättre översikt.
Tider Måndag - Söndag | Måndag – Söndag föreslås utifrån fältet Tidbehandling i tabellen Tidgrupper, och du kan bara ändra tidpunkterna, inte dagarna. Är dessa fel måste du avbryta och korrigera i fältet för respektive tidgrupp och därefter generera på nytt. Det är möjligt att ha olika tidpunkter för var dag.
Avvikelsetid | Avvikelsetiden från Tidgruppen hämtas men det är möjligt att överstyra i dialogen

Efter att ha valt OK visas en dialog där du kan bekräfta och skapa Tidkalender eller du kan avbryta och kommer då tillbaka till dialogen där du kan göra ändringar.

Tabellen Tidkalendrar

Denna tabell innehåller nu en rad per period som är skapad utifrån Tidgruppens inställningar – En veckas normala arbetstid, start och sluttid per dag m.m.
Tidkalendern utgör underlag för vidare generering av tidsaldon för anställda och resurser. Du kan ändra enskilda värden innan tidsaldon skapas. Utöver detta har tidkalendern ingen funktion under tidregistreringen.
Värden till tabellen skapas när du använder behandlingsmenyvalet "Skapa tidkalender" i tabellen "Tidgrupp".

Beskrivning av fälten i tabellen Tidkalendrar

Arbetsdagar

Det här fältet beräknas när du kör behandlingsmenyvalet "Skapa tidkalender". Om du har kryssat för att tabellen för fridagar ska tas med i beräkningen, tas det även hänsyn till de veckodagar som har aktiverats för tidgruppen.

Avvikelsetid

När tidkalender skapas används det här fältet som standardavdrag av "Totaltid per dag", till exempel 00:30 för lunchrast.

Från datum

I det här fältet genereras från datum när du kör behandlingsmenyvalet "Skapa tidkalender". Datumet kan även registreras manuellt. Fältet används för att definiera startdatumet för perioden.

Från kl. Mandag - Söndag

Det här fältet uppdateras när tidkalender skapas. Som standard används det som starttid för varje giltig veckodag.

Från vecka

Det här fältet visar veckonummer för från datum och du kan inte redigera fältet.

Normaltid

Det här fältet visar totalt antal timmar för perioden, och beräknas utifrån fälten "Timmar måndag-söndag" plus "Avvikelsetid".

Till datum

I det här fältet genereras till datum när du kör funktionen "Skapa tidkalender". Datumet kan även registreras manuellt. Fältet används för att definiera slutdatumet för perioden. Det här fältet har samma värde som Från datum för dagperioder.

Till kl Måndag - söndag

Det här fältet används när tidkalender skapas. Som standard används det som sluttid för varje giltig veckodag.

Till vecka

Det här fältet visas veckonummer för till datum och du kan inte redigera fältet.

Tidbehandling

I det här fältet kopieras behandlingsreglerna från tidgruppen. Om du gör uppslag i fältet visas en dialogruta. Här kan du ändra enskilda val som gjorts när tidkalendern skapades.

Gäller för

Här väljer du om tidgruppen ska vara en anställningsgrupp eller en resursgrupp.
Detta bestämmer varifrån du kan skapa tidsaldo. För anställda skapas det från tabellen "Aktörer" och för resurser från tabellen "Resurser".

Perioder
  • Här anger du hur många perioder som ska användas och Visma Business räknar ut det automatiskt utifrån kalendern, och tar hänsyn till skottår.
  • Dagar skapar en kalenderrad per dag.
  • Vecka skapar en kalenderrad per vecka. Här kan vecka ett börja i föregående år och vecka 52/53 kan gå in i nästa år.
  • Månad skapar en kalenderrad per kalendermånad.
  • 4. veckor skapar en fyraveckorsperiod. Detta används i Storbritannien.
Veckodagar

Här kryssar du för vilka veckodagar du ska kunna registrera på.

Om du väljer söndag som första veckodag beräknas veckobyte på söndagar. Detta används i USA.

Reservationsregler
  • ”Reservera hela dagar” används vid de tillfällen då reservationen alltid ska gälla för hela dagen. Tiden kan gott variera i antal timmar.
  • Om du använder ”Kontrollera fridagar” kontrolleras datum i tabellen "Fridagar" när tidkalender och tidsaldo skapas.
  • ”Ej orderkontroll” ger varning om att resursen redan är bokad.
  • ”Ej aktivitetskontroll” ger varning om att aktiviteten redan är bokad

Tidgruppnr.

Detta fält är primärnyckel i tabellen.

I det här fältet genereras tidgrupp när du använder behandlingsmenyvalet "Skapa tidkalender" i tabellen "Tidgrupp". Du kan också registrera tidgrupper manuellt. Du kan göra uppslag i tabellen "Tidgrupp".

Tidkalenderperiod

Detta fält är primärnyckel i tabellen.

I det här fältet genereras perioden när du använder behandlingsmenyvalet "Skapa tidkalender" i tabellen "Tidgrupp". Du kan också registrera tidsperioder manuellt.

Timmar måndag - söndag

Det här fältet uppdateras när tidkalender skapas, och visar antalet arbetstimmar inklusive avvikelsetid.

Skapa tidsaldo

Så har vi då kommit till funktionen att skapa tidsaldo. Tidsaldo skapas med behandlingsmenyvalet "Skapa tidsaldo" i tabellen "Resurser" eller tabellen "Aktörer".

Du kan ändra enskilda värden för enskilda resurser. Tidsaldo utgör underlaget för beräkning av tillgänglig tid och saldon för tidrapporter.

Skapa tidsaldo från aktörer

Först måste du ha skapat Tidgrupper i tabellen Tidgrupper och därefter skapa en Tidkalender för den gruppen (beskrivning tidigare i dokumentet). En förutsättning är att aktören har anställningsnr. Behandlingsmenyvalet ”Skapa tidsaldo” i tabellen ”Aktörer” leder till följande dialog.

Förklaring till fälten i dialogen "Skapa tidsaldon"

Fält

Förklaring

Tidgrupp

Rullistan visar alla tillgängliga tidgrupper för anställda och du måste välja en grupp för att rutinen ska skapa något.

Om inga grupper visas i den här dialogrutan, även om det finns tidgrupper registrerade, beror det på att det inte finns tidgrupper registrerade för anställda (Tidbehandling).

Använd tidgrupp från anställd

Om du kryssar för det här fältet används tidgruppen från den anställda istället för den tidgrupp som valts i dialogrutan. Anställda som inte har en grupp tilldelas den valda gruppen.

Behandla bara anställda med vald tidgrupp

Om du kryssar för det här fältet behandlas bara anställda med vald grupp.

Från datum Till datum

Från datum föreslås utifrån spärrad period, och till datum utifrån kalenderåret.

I enskilda fall, när "vecka" är periodbegreppet, ligger förslaget både i föregående år i från datum och i nästa år i till datum, eftersom vecka 1 kan börja i föregående år och vecka 52/53 kan gå in i nästa år.

Du måste välja en Tidgrupp från listan. Bara Tidgrupper som är reserverade för anställda visas. Du kan kryssa för standardfälten ”Använd tidgrupp från anställd” och ”Behandla bara anställda med vald tidgrupp” för att se till att det bara är anställda med denna valda grupp som behandlas.

Tar du bort kryssen för ”Behandla bara anställda med vald tidgrupp” och behåller valet för ”Använd tidgrupp från anställd” så kommer alla anställda som det är registrerat en grupp på att använda denna och för anställda utan grupp skapas tidsaldo med gruppen som valts i dialogen. De anställda utan grupp uppdateras med vald grupp.

Raderar du även valet för ”Använd tidgrupp från anställd” så kommer alla anställda som behandlas att skapas med vald grupp och uppdateras med detta värde.

En resurs med samma nummer som anställningsnummer skapas automatiskt i tabellen "Resurser". Om numret redan finns som resurs sedan tidigare tilldelas nästa lediga resursnummer. Om det finns en resurs med samma nummer och med samma anställningsnummer används den, och uppdateras eventuellt med uppgifter från tidgruppen om ändring har gjorts.

Om det inte skapas något så kan orsaken vara att det inte finns kalenderrader för valt datumintervall eller att aktören inte har något anställningsnr.

Skapa tidsaldo från resurser

Du måste först lägga in tidgrupper i tabellen "Tidgrupp", och därefter skapa en tidkalender för den gruppen (se beskrivning tidigare i dokumentet). Behandlingsmenyvalet ”Skapa tidsaldo” i tabellen Resurser leder till följande dialogruta:

Förklaring till fälten i dialogen “Skapa Tidsaldo”

Fält

Förklaring

Tidgrupp

Rullistan visar alla tillgängliga tidgrupper för resursen och du måste välja en grupp för att rutinen ska skapa något.

Om inga grupper visas i den här dialogrutan, även om det finns tidgrupper registrerade, beror det på att det inte finns tidgrupper registrerade för resurser (Tidbehandling).

Använd tidgrupp från resursen

OBS! Om du kryssar för det här fältet används tidgruppen från resursen istället för den tidgrupp som valts i dialogrutan. Resurser som inte har en grupp tilldelas den valda gruppen.

Behandla bara resurser med vald tidgrupp

Om du kryssar för det här fältet behandlas bara resurser med vald grupp.

Från datum Till datum

Från datum föreslås utifrån spärrad period, och till datum utifrån kalenderåret.

I enskilda fall, när "vecka" är periodbegreppet, ligger förslaget både i föregående år i från datum och i nästa år i till datum, eftersom vecka 1 kan börja i föregående år och vecka 52/53 kan gå in i nästa år.

Du måste välja en tidgrupp från rullistan. Bara tidgrupper som är reserverade för resurserna visas. Du kan kryssa för standardfälten "Använd tidgrupp från resursen" och "Behandla bara resurser med vald tidgrupp", för att se till att det bara är resurser med vald tidgrupp som behandlas.

Om du tar bort markeringen för "Behandla bara resurser med vald tidgrupp" och behåller markeringen för "Använd tidgrupp från resursen" kommer den att användas av alla resurser som har en grupp registrerad. Resurser utan grupp genereras med den grupp du väljer i dialogrutan. Resurser utan grupp uppdateras med vald grupp.

Om du inte kryssar för fältet "Använd tidgrupp från resursen" kommer alla resurser som behandlas att skapas med vald grupp och uppdateras med de värdena.

Om tidsaldo inte skapas kan det bero på att programmet inte hittar kalenderrader för det datumintervall du har valt.

Förklaring till fälten i tabellen "Tidsaldon"

Anst.nr

Om resursen är en anställd, genereras anställningsnummer i det här fältet med hjälp av menyalternativet "Skapa tidsaldo". Du kan göra uppslag i fältet till tabellen "Aktörer".

Arbetsdagar

Det här fältet kopieras från tabellen "Tidkalender" med menyalternativet "Skapa tidsaldo". Tabellen "Fridagar" för den enskilda anställda eller resursen tas hänsyn till.

Avvikelsetid

Det här fältet kopieras från tabellen "Tidkalender" när tidsaldo skapas, och används som standardavdrag av "Totaltid per dag", till exempel 00:30 för lunchrast.

Fakturerbart antal

Det här fältet visar ackumulerat antal timmar från tabellen "Aktiviteter" som ska ingå i tidsaldon för respektive period och resurs.

Flextid IB

Det här fältet beräknas vid godkänning av tidrapporter, och uppdaterar de kommande perioder där en tid registrerats.

Flextidsavkortning

Det här fältet visar en eventuell flextidsavkortning när ett värde har registrerats i "Max flextid". Om "Max flextid" till exempel är 100 och "Flextid UB" visar 110, så kommer det här fältet visa 10. Flextidsavkortning på 10 kommer då inte överföras som "Flextid IB" till nästa period.

Flextid UB

I fältet visas summan av fälten "Flextid IB" och "Upplupet under perioden".

Från kl

Det här fältet beräknar ett genomsnitt från tabellen "Tidkalender" när tidsaldo skapas. Som standard används det som starttid för varje giltig veckodag.

Max flextid

I det här fältet kan du ange en maximal flextid som kan överföras till nästa period.

En anställd kan till exempel ha 167 timmar som normal tid, och ha en IB på 70 timmar från förra månaden och jobba 40 timmar den här månaden. Med en normal tid visar då UB 110 och fältet "Flextidsavkortning" visar 10. IB för nästa period kommer då vara 100. De timmarna som avkortats justeras i flextidssammanhang och skulle eventuellt ges som övertid.

Normal och övertidsdiff.

Det här fältet visar differensen mellan "Normaltid" och "Upplupen tid" efter att du lagt in eventuell övertid.

Normaltid

I det här fältet visas totalt antal timmar för perioden. Det beräknas med "Timmar per dag" multiplicerat med "Arbetsdagar" plus "Avvikelsetid" ((Timmar per dag" * "Arbetsdagar") + "Avvikelsetid) som underlag.

Normal tidsdiff.

I det här fältet visas differensen mellan "Normaltid" och "Upplupen tid".

Överfört till lön

I det här fältet ackumuleras antalet som överförs till lönefilen från tabellen "Aktiviteter".

Överförd till order

I det här fältet ackumuleras antalet som överförs till order från tabellen "Aktiviteter".

Övertid

I detta fält registrerar du antal övertidstimmar i perioden. Antalet påverkar beräkningen av flextid.

Upplupet antal

Det här fältet visar ackumulerat antal upplupna timmar från tabellen "Aktiviteter" som ska ingå i tidsaldon för respektive period och resurs.

Upplupet antal godkänt

I det här fältet visas ackumulerat antal upplupna timmar från tabellen "Aktiviteter" som är godkända på tidrapport eller överförda till lönefil.

Upplupet ej godkänt

I det här fältet visas differensen mellan "Upplupet antal" och "Upplupet antal godkänt".

Resursnr

I det här fältet skapas resursnummer med funktionen "Skapa tidsaldo". Du kan också registrera reservationsnummer manuellt. Du kan göra uppslag i fältet till tabellen "Resurser". Detta fält är primärnyckel i tabellen.

Resursstatus

Bitvärden i det här fältet visar om den är:

Ledig (1 - Grön)
Delvis reserverad (2 - Gul)
Helt reserverad (4 - Röd)

Det är värdena i fälten "Normaltid" och "Upplupet antal" som påverkar fältet "Resursstatus". Fältet presenteras med en färgad cirkel.

Reserverad tid

Det här fältet visar ackumulerade tidsanslag från tabellen "Aktiviteter" som ska ingå i tidsaldon för respektive period och resurs.

Tidstatus

Det här fältet visar status för vad som har gjorts med den här saldoraden. Fältet presenteras i färgkoder i fyra rutor vilka kan anta färgen röd eller grön.

Grön = Ej utförd
Röd = Utförd

De olika rutorna har följande innebörd:

Ruta 1= registrerat tid
Ruta 2= godkänd tidrapport
Ruta 3= överförd till lön
Ruta 4= överförd till order.

Tidgruppnr.

I det här fältet skapas tidgrupper med funktionen "Skapa tidsaldo". Du kan också registrera tidgruppsnummer manuellt. Du kan göra uppslag i fältet till tabellen Tidgrupp. Beroende på vilka val som gjorts i dialogrutan för att skapa tidsaldo kommer det här fältet från anställd, resurs, eller vald grupp. Detta fält är primärnyckel i tabellen.

Tidkalenderperiod

I det här fältet skapas perioden med hjälp av funktionen "Skapa tidsaldo". Tidperioden kan även registreras manuellt. Detta fält är primärnyckel i tabellen.

Tidbehandling

I det här fältet kopieras behandlingsreglerna från tabellen "Tidkalender". Du kan slå upp i fältet. I dialogrutan kan du nu ändra enskilda val som gjordes under generering av tidsaldon.

Gäller för

Här väljer du om tidgruppen ska vara en anställningsgrupp eller en resursgrupp.

Detta bestämmer varifrån du kan skapa tidsaldo. För anställda skapas det från tabellen "Aktörer" och för resurser från tabellen "Resurser".

Perioder:

Här anger du hur många perioder som ska användas och Visma Business räknar ut det automatiskt utifrån kalendern. Skottår tas med i beräkningen.

  • Dagar skapar en kalenderrad för varje dag.
  • Vecka skapar en kalenderrad för varje vecka. Här kan vecka ett börja i föregående år och vecka 52/53 kan gå in i nästa år.
  • Månad skapar en kalenderrad för varje kalendermånad.
  • 4 veckor skapar fyraveckorsperioder. Det används i Storbritannien.
Veckodagar

Här kryssar du för vilka veckodagar du ska kunna registrera på. Om du väljer söndag som första veckodag beräknas veckobyte på söndagar. Det används i USA.

Reservationsregler:

  • ”Reservera hela dagar” används vid de tillfällen då reservationen ska göras för hela dagen. Tiden kan gott variera i antal timmar.
  • Om du använder ”Kontrollera fridagar” kontrolleras datum i tabellen "Fridagar" när tidkalender och tidsaldo skapas.
  • ”Ej orderkontroll” ger varning om att resursen redan är bokad.
  • ”Ej aktivitetskontroll” ger varning om att aktiviteten redan är bokad

Timmar per dag

Det här fältet beräknar ett genomsnitt från tabellen "Tidkalender" när tidsaldo skapas. Det visar antal arbetstimmar inklusive avvikelsetid.

Till kl

Det beräknas med "Från kl." och "Timmar per dag" som underlag.

Fönster för registeradministration

I Sivracs tidredovisning finns ett standardfönster man kan använda för att administrera ovan nämnda register.

Fönster 907 – Tidgrupper

Flik 1 – Tidgrupper

Under den första fliken kan man registrera och underhålla Tidgrupper samt utifrån dessa skapa Tidkalenderrader. De olika fälten i respektive tabell finns beskrivna ovan. Man registrerar en ny tidgrupp genom att trycka + i första fältet och därefter fylla i önskade fält. Du kan också söka fram en befintlig tidgrupp genom att söka på valfritt fält. Du skapar Tidkalenderrader genom att stå i något fält i tabellen Tidgrupper och välja behandlingsmenyvalet ”Skapa Tidkalender”.

Beskrivning av dialogruta och tillvägagångssätt finns ovan.

Flik 2 – Helgdagar

Under denna flik finns tabellen för helgdagar. Du kan hindra registrering av aktiviteter på vissa datum (lediga dagar, helgdagar och semester). Det förutsätter att dagarna är registrerade i denna tabell för den aktör det gäller. Du kan lägga in flera semesterintervall per användare. Om du försöker lägga in en aktivitet på en tidpunkt som är registrerad som semester får du en varning och du kan inte lägga in aktiviteten.

OBS! Du kan välja om det ska vara möjligt att lägga in aktiviteter även om den anställde har semester. Detta gör du i tabellen "Fridagar". Då får du en varning men du kan fortfarande lägga in aktiviteten.

Flik 3 – Anställda

Under denna flik finns tabellen ”Aktörer” med urval på att det skall finnas Anställningsnr på aktören. Här finns diverse anställningsuppgifter samt fält för Tidgruppstillhörighet. Här kan man även se vilka fridagar som finns för resp. anställd.

Flik 4 – Resurser

Här finns tabellen Resurser med följande fält:

Resursnr:

Detta fält är primärnyckel i tabellen

Namn:

I detta fält skriver du namnet på resursen

Produktnr:

Om resursen är knuten till en produkt eller en tjänst, anges/visas detta produktnumret här.

Tidgruppnr:

Om resursen är knuten till en viss tidgrupp, anges / visas detta här

Anställningsnr:

Om resursen tillhör en anställd kan anges/visas anställningsnummer i det här fältet.

Ansvarig:

Detta fält refererar till fältet "Anställningsnummer" i tabellen "Aktörer". Du kan sortera och göra urval i fältet när du arbetar med resurserna. Du kan också slå upp anställda och överföra information från tabellen "Aktörer" till tabellen "Resurser".

Tillkopplat Resurserna finns även tabellen Tidsaldon. Här kan du se vilka tidsaldouppgifter som finns för respektive Resurs och du kan även göra vissa förändringar vid behov. Beskrivning av fälten i tabellen finner du tidigare i detta dokument.

Registrera tider

Nu skall alla förutsättningar vara klara för att börja arbeta med tidregistrering. Bland standardvyerna finns exempelfönster för detta ändamål.

Tidregistrering 230

I detta fönster arbetar man med att registrera tider veckovis och utgångspunkten är som tidigare nämnts resurser.

Flik 1 – Reg. denna vecka

Resursen som visas är den person som är inloggad i Visma Business. Flik 1 ”Reg. denna vecka” används för att registrera innevarande veckas tider. Tiderna registreras i Aktivitetstabellen och till denna har kopplats en kalender. Den föreslår alltid dagens datum i ett dolt fält i aktivitetstabellen som heter ”Från datum”. Registrerar man t.ex. hela veckans tider på fredagen får man meddelande om att Från datum har ändrats då man registrerar i övriga veckodagar.

Första fältet trycker man + (plus) i för att få fram aktivitetsaktörnumret för raden, d.v.s. den inloggades aktivitetsaktörnummer. Därefter registreras uppgifter om projekt, kund, ev. ordernr, produktnr. Därefter registreras nedlagda timmar för de olika veckodagarna.

Projekt (R2)

Här anges eventuellt projektnummer som tiden avser. Uppslag kan göras i fältet till Projekttabellen.

Namn:

Projektnamn hämtas automatiskt.

Ordernr:

Här kan anges ett ordernummer som skall användas vid fakturering av tiden. När du väljer "Behandling/Upprätta order" från menyraden upprättas en ny order för aktiviteten som du står på. Fältet fylls i med ordernumret från tabellen "Order".
Vill du följa upp en bestämd order kan du registrera ett ordernummer från en existerande order.

Kundnr:

Här anges vilken kund tiden avser. Uppslag kan göras i underliggande kundregister.

Namn:

Kundnamnet hämtas upp med automatik.

Produktnr:

Här kan anges vilken typ av tidprodukt som avses. Uppslag leder till en dialog med en dropplist där man kan välja mellan olika produkter. I dropplisten visas de produkter som flaggats som aktivitetsprodukter.

Måndag-Söndag:

De här fälten kan du registrera timmar för varje dag. Timmarna ackumuleras i fälten "Antal" och ”Upplupet antal". Fältet visas i timmar och minuter (HH:MM). Tillhörande "Dag i antal" visar 01:30 som 1,5 och beräknas till 90 minuter i fältet "Antal".

Utfört:

Detta fält kryssas i när veckans/radens aktiveter är utförda och klara. Aktivitetsstatusen ändras då och tiderna kan godkännas för fakturering.

Nederst till vänster i Memorutan kan man göra noteringar för varje vecko/aktivitetsrad.

Nederst till höger visas aktivtetsradens olika statusvärden

Tidsstatus:

Det här fältet visar status för vad som har gjorts med den här saldoraden. Fältet presenteras i färgkoder i fyra rutor vilka kan anta färgen röd eller grön.

  • Grön = Ej utförd
  • Röd = Utförd

De olika rutorna har följande innebörd:

  • Ruta 1= registrerat tid
  • Ruta 2= godkänd tidrapport
  • Ruta 3= överförd till lön
  • Ruta 4= överförd till order.

Resursstatus:

Bitvärden i det här fältet visar om den är:

  • Ledig (1 - Grön)
  • Delvis reserverad (2 - Gul)
  • Helt reserverad (4 - Röd)

Det är värdena i fälten "Normaltid" och "Upplupet antal" som påverkar fältet "Reservationsstatus". Fältet presenteras med en färgad cirkel.

Upplupet antal:

Det här fältet visar ackumulerat antal upplupna timmar från tabellen "Aktiviteter" som ska ingå i tidsaldon för respektive period och resurs.

Normaltidsdiff:

I det här fältet visas differensen mellan "Normaltid", som angivits för aktuell tidgrupp, och "Upplupen tid".

Flik 2 – Reg. annan vecka

Under flik 2 ”Reg. annan vecka” är det tänkt att man skall registrera tider för annan vecka än innevarande. Registreringen är i stort sett lika som under flik 1, men här finns även ett fält som heter ”Första datum i veckan”. Här anger man datumet för måndagen den vecka man avser att registrera tider för. Systemet vet då vilka datum som de olika veckodagarna har och kan då sätta rätt ”Till datum”. Övriga fält registreras på samma sätt som under flik 1.

Flik 3 – ”Reg. löpande”.

Under denna flik ser registreringsbilden något annorlunda ut. Här är det tänkt att man skall kunna registrera tider för enskilda dagar eller delar av dagar. Vissa dagar eller veckor jobbar man kanske med flera olika projekt eller kunder och då är det enklare att registrera i detta fönster.

Följande fält finns i detta delfönster:

Aktivitetsaktörnr:

Här trycker du + för att registrera dina egna tider. Skall du registrera tider för någon annan får du hämta/registrera denna persons aktörnr. Du kan göra uppslag i fältet för att söka bland aktörer.

Från datum

Här anger du vilket datum aktiviteten gäller.

Från kl

Ange vilken tid aktiviteten startade.

Till kl

Ange vilken tid aktiviteten avslutades.

Produkt nr

Här anges den produkt aktiviteten avser.

Överstyrd benämning

Här föreslås produktbenämningen, men du kan ändra denna text till en mer specifik beskrivning.

Upplupna timmar:

Systemet räknar fram den upplupna tiden utifrån fälten ”Från kl” och ”Till kl”. Denna tid är den fakturerbara tiden och kan ev. skilja sig från den verkligt nedlagda tiden som visas i fältet ”Antal timmar” nedan.

Antal timmar

Systemet räknar fram detta fält på samma sätt som fältet ovan. Detta fält används även för att uppdatera ”tidsaldon” i de fall detta skall ske (se vidare beskrivning nedan).

Flik 4 – ”Icke godkända”

Under denna flik visas samtliga aktiviteter för den aktuella resursen som ännu inte godkänts. Uppgifter som visas för aktiviteterna är motsvarande de som finns under flik 1 och 2.

Godkännande av tidrapporter

I en projektorganisation där man löpande arbetar med tidrapportering är det vanligt att någon ansvarig skall godkänna tidrapporterna innan de kan vara underlag för lön och/eller för fakturering.

Vem får godkänna tidrapporter

Den som har Systemansvarigrättigheter har alltid rätt att godkänna allas tidrapporter. Egna tidrapporter har man alltid rättighet att godkänna, vilket man givetvis kan spärra användare från via den vanliga accesshanteringen. Man kan även ge tillåtelse att godkänna andras tidrapporter.

Ej rätt att godkänna egna rapporter

Spärra möjlighet till godkännande av egna rapporter sker för accessgruppen via ”Funktionsaccess” och ”Behandlingsmenyval” för tabellen ”Resurser” och valet ”Godkänn tidrapport”.

Rätt att godkänna andras tidrapporter

För att ge annan än systemansvarig rättighet att godkänna andras tidrapporter gör man följande: Under accessgruppens ”Funktionsaccess” väljer man ”Diverse” och valet ”Godkänning av andras tidrapporter”.

Fönster 131 Godkännande tidrapporter

I Visma Business finns ett standardfönster för att arbeta med Godkännande av tidrapporter.

Här visas alla resurser som dessutom har ett anställningsnummer och dennes icke godkända aktiviteter. Beroende på rättigheter kan jag nu godkänna mina eller ev. andras aktiviteter/tidrapporter som visas i fönstret och som är utfört. Detta sker genom att man står på aktuell ”Resurs” och går via ”Behandling” och ”Godkänn tidrapport”

Utgångspunkten i systemet är alltså att allt som är ”Utfört” godkänns via behandlingen. Det finns dock möjlighet att via fältet ”Aktivitetsbehandling” markera vissa rader som undantagna för godkännande. För att få tillgång till detta fält måste man ha viss rättighet. Denna rättighet kan man styra via den enskilde användaren. I användartabellen finns ett fält som heter ”Anv.pref” som leder till en dialog:

För att kunna undanta godkännande av enskilda tidrapporter måste man ha den nedersta flaggan ibockad.

Detta öppnar möjligheten att i fältet ”Aktivitetsbehandling” på den aktuella tidrapporten/aktivitetsraden bocka i fältet ”Godkänn Ej tidrapport”.

Den aktuella raden undantas då vid godkännandebehandlingen.

I sidelementet med tid/aktivitetsraderna några kolumnrubriker rödmarkerade. Dessa fält skall vara ifyllda innan godkännande, så att det snabbt och enkelt går att fakturera.

Det finns ytterligare ett fält som kan vara intressant att nämna och det är ”Aktivitetsstatus”. Här visas tillsammans med ett Bitvärde en färgad prick. Fältet antar olika värden och färger utifrån markeringar i följande dialog:

De olika färgerna som kan visas och dess innebörd är följande:

  • Grön = Inga flaggor
  • Gul = Utförd
  • Blå = Tidrapport godkänd
  • Röd = Överförd till lön

Det nedersta sidelementet visar tidsaldon för den period och den resurs markerad aktivitet ingår i. Här visas uppgifter om:

Tidsperiod:

Vilken period uppgifterna avser

Upplupet antal godkänt:

I det här fältet visas ackumulerat antal upplupna timmar från tabellen "Aktiviteter" som är godkända på tidrapport eller överförda till lönefil.

Upplupet antal ej godkänt:

I det här fältet visas differensen mellan "Upplupet antal" och "Upplupet antal godkänt".

Fakturerbart antal:

Det här fältet visar ackumulerat antal timmar från tabellen "Aktiviteter" som ska ingå i tidsaldon för respektive period och resurs.

Flextid IB:

Det här fältet beräknas vid godkännande av tidrapporter, och uppdaterar kommande perioder där en tid registrerats.

Flextid UB:

I fältet visas summan av fälten "Flextid IB" och "Upplupet under perioden.

Flextidsavkortning:

Det här fältet visar en eventuell flextidsavkortning när ett värde har registrerats i "Max flextid". Om "Max flextid" till exempel är 100 och "Flextid UB" visar 110, så kommer det här fältet visa 10. Flextidsavkortning på 10 kommer då inte överföras som "Flextid IB" till nästa period.

Avvikelsetid:

Det här fältet kopieras från tabellen "Tidkalender" när tidsaldo skapas, och används som standardavdrag av "Totaltid per dag", till exempel 00:30 för lunchrast.

Normaltidsdiff:

I det här fältet visas differensen mellan "Normaltid" och "Upplupen tid".

Arbetsdag:

Det här fältet kopieras från tabellen "Tidkalender" med menyalternativet "Skapa tidsaldo". Tabellen "Fridagar" för den enskilda anställda eller resursen tas hänsyn till.

Tidstatus:

Det här fältet visar status för vad som har gjorts med den här saldoraden. Fältet presenteras i färgkoder.

  • Grön = Ej utförd
  • Röd = Utförd

De olika rutorna har följande innebörd:

  • Ruta 1= registrerat tid
  • Ruta 2= godkänd tidrapport
  • Ruta 3= överförd till lön
  • Ruta 4= överförd till order.

Resursstatus:

Bitvärden i det här fältet visar om den är:

Ledig (1 - Grön)

Delvis reserverad (2 - Gul)

Helt reserverad (4 - Röd)

Det är värdena i fälten "Normaltid" och "Upplupet antal" som påverkar fältet "Reservationsstatus". Fältet presenteras med en färgad cirkel.

Överför till order

Godkända tider/aktivitetsrader är nu klara för att föras över till order för fakturering. Det finns olika sätt att arbeta med detta. Vissa arbetar med att föra över samtliga tider vid ett tillfälle inför en fakturering. Andra jobbar så att man löpande för över tider till order för att antingen samlingsfakturera vid ett senare tillfälle alternativt fyller på samma order löpande för att fakturera vid ett senare tillfälle. I vårt standarduppsätt finns ett speciellt fönster som man kan arbeta med att föra över tider till order.

Fönster 132 – Överför till order

Här kan man välja att arbeta med de godkända tiderna veckovis eller löpande.

Flik 1 – Vecka

För att ordern som skapas skall ha fullständiga uppgifter inför fakturering så har vi markerat fälten för Kundnr resp. Produktnummer med rött, så att man är uppmärksam på att fylla i dessa innan aktivitetsraden förs över. Som nämnts ovan kan man arbeta på olika sätt med överföringen. Vill man fakturera löpande eller använda samlingsfaktura är det bara att gå till Behandlingsmenyvalet ”Upprätta order” efter att alla obligatoriska värden är ifyllda. Man behöver således inte fylla i fältet ordernr.

Vill man däremot löpande ”fylla på” en befintlig order, anger man detta ordernummer i motsvarande fält. Man kan även göra uppslag i fältet för att söka upp önskat ordernummer. De markerade aktivitetsraderna hamnar nu, vid ”upprätta order”, på denna sedan tidigare befintliga ordern.

Nederst i fönstret finns uppgifter från Tidsaldotabellen, vilka beskrivits tidigare i beskrivningen av fönstret ”Godkännande tidrapporter”.

Flik 2 - Löpande

Fliken för ”Löpande” ser något annorlunda ut och saknar fälten för respektive veckodags tider. Istället finns fälten ”Upplupna timmar” och ” Antal timmar”. Skillnaden dessa emellan är att ”Antal timmar” är det antal timmar man faktiskt lagt ned – d.v.s. det som systemet räknat fram utifrån tidsangivelserna. Fältet ”Upplupna timmar visar det antal timmar som kommer att föras över till ordern för vidare fakturering.

Projektuppföljning

När man arbetar med tidrapportering sker detta ofta på projektnivå. I Sivracs Tidredovisning finns ett fönster för att underhålla och följa upp projekten.

Fönster 133 - Projektadministration

Flik 1 - Översikt

Här finns först, på fliken ”Översikt”, uppgifter om tider. Ej godkända, Godkända ej överförda etc. Här visas uppgifterna totalsummerade, men genom att klicka på pilen med ”Detaljer” visas vad summan består av. Här exempel på ”Godkända, ej överförda” timmar:

Övriga flikar

Utöver denna översikt finns i fönstret även uppgifter om ev. fakturaplan om sådan används, Budget för projektet, Priser (pris och rabattmatrisen) samt Dokumentkopplingar gjorda till projektet.


Time

01 Administrasjon

Timegrupper

Timegrupper opprettes for å skape en kalender over normal arbeidstid. Timegrupper kan opprettes for ansatte eller ressurser. Det kan opprettes et ubegrenset antall timegrupper.

Når timegruppen er opprettet så genereres det en timekalender. Kalenderen holder oversikt over timer som normalt er tilgjengelig i angitt periode. Merk avkryssningen i ”sjekk ferie tabellen”. Her tas det hensyn til innlagte helligdager

Timesaldo

Legg inn ønsket timegruppe på den ansatte og generer timesaldo. På de ansatte som skal registrere timer.

Timesaldo benytter kalender fra angitt timegruppe og lager en saldo pr periode. Saldo vil holde oversikt over den tid dom er fakturerbar/påløpt på ressursen/ansatt. Timesaldo blior opprettet pr ansatt/ressurs.

02. Bruker/Brukergrupper

I dette vinduet knyttes brukerene opp mot oppsettsgrupper for at for de brukerne som kun skal registrere timer får opp dette etter pålogging. Legg inn disse brukerne i timegruppe 1. Systemansvarlig/timelistegodkjenner må være i gruppe 3 i tillegg til oppsettsgruppe 1.

Brukere som kun skal registere timer skal ha satt kryss i ”Timebruker”

03. Prosjektadministrasjon

Øverst i skjermbildet ser vi informasjon som er regsitrert direkte på prosjektet. Husk alltid å kontrollere at kundenr og ordrenr er utfyllt. Disse er derfor markert i rødt. Ansvarsenhet nr 7 er benyttet for prosjekt.

Skillearket Oversikt gir informasjon om hvor mye som totalt er registret på prosjektet og hvor langt det er kommet. Dersom dere klikker på pilen detaljer så får dere se den underliggende transakasjonen.

Skillearkene Betalingsplan/Ordre. Her bestemmer dere om prosjektet skal faktureres som en plan eller fortløpende. Når dere har bestemmt dette klikker dere på :

Alternativt

Når dette gjøres vil det bli opprettet en prosjekt ordre og feltet ordrenr på prosjektet blir utfyllt. Ved registrering av timer så vil dette feltet bli ”kopiert” til feltet ordrenr på den rad som timer registreres på. Dette skjer ved hjelp av en trigger som ligger i database og er ikke standard funksjonalitet.

Skillearket Budsjetter her registreres budjsetter pr prosjekt på påløpte timer.

Skillearket Aktivitet her registreres aktiviteter som er knyttet til de ulike prosjektene. Disse vil komme opp ved regsitrering på de ulike prosjektene.

Aktivitetstype benyttes for å fortelle hva slags aktivitet dette er. Ved registrering av timer så vil dette feltet bli ”kopiert” til feltet produktnummer på den rad som timer registreres på. Dette sørger en ”trigger” for og er ikke standard funksjonalitet. I tilleg sørges det for at korrekt aktivitets behandling blir satt. Dette hentes fra produktet. Forutsetningen er at produkt med tilsvarende nummer som angis her er opprettet i produkttabellen. Behandlingsmåten på produktet blir satt ved hjelp av utfyllingsregeler. Dette skal ikke bruker forholde seg til.

Skillearket Priser viser oversikt på priser som gjeler dette prosjektet og her registreres disse prisene. Prisene vil kun gjelde for gjeldene prosjekt.

Skillearket Dokumenter holder oversikt over dokumenter som er opprettet på prosjektene.

Skillearket Deltaker her settes det opp hvilke prosjekter timeregistrerene ikke skal ha adgng til . Dette for å lette registreringen av timer. Det må settes opp hvilke prosjekt bruker IKKE skal ha adgang til. Dette gjøres på følgende måte:

Gå inn på prosjekt bruker ikke skal ha adgang til. Finn frem bruker. Og klikk på knappen

Nå blir avgrensningen på prosjektet satt og denne bruker får ikke opp dette prosjektet ved oppslag ved timeregistrering.

Det er definert en adgangsgruppe pr bruker. Merk at brukernavn må være angitt i i tabellen bruker-avgrensningsgrupper.

04. Timeregistrering

Timer registreres på denne måten :

Timeregistrering

  1. Tast + i feltet
  2. Søk deretter etter prosjekter ved å tatse * i feltet
  3. Aktiviteter blir så aktive i høyre del av skjermbildet

  4. Marker så den aktivitet du skal registrere timer på
  5. Klikk deretter
  6. Aktiviteten blir deretter kopiert inn på registrerings linjen

  7. Register deretter forbrukt tid på den aktuelle dag
  8. Gjenta til alle timer er registrert
  9. Sett deretter X i feltet
  10. Timene er registrert.

Reise/utlegg registreres på denne måten:

Registrering av reise/utlegg

  1. Register dato for reise/utlegg
  2. Søk deretter etter prosjekter ved å tatse * i feltet
  3. Søk deretter etter produkter ved å tatse * i feltet
  4. Marker så det produkt du skal registrere reisen/utlegget på

  5. Angi så antall forbrukt i feltet

  6. Gjenta til alle reiser/utlegg er registrert
  7. Sett deretter 2 (Til attestasjon) i feltet
  8. Reiser/utlegg er sendt til attestasjon.

05. Timelistegodkjenning

Godkjenning av timeliste

Her godkjennes timer. Det er viktig at bruker som skal godkjenne timer her har rettigheter til å godkjenne andres timer. Dette settes i adgangsregulering/funksjonadgang/diverse.

Her får bruker som har adgang til skjembildet opp alle ansatte (Adgangsgruppe 3).

Timelister godkjennes ved å benytte behandlinsmenyvalget: ”Godkjenn timeliste”

Attestering av Reise/utlegg

Reise/utlegg attesteres ved å sette attestasjon = 3 (Attestert). Ved lagring vil raden forsvinne fra skjembildet.

06. Overfør til ordre

Timer

Timer godkjennes ved hjelp av behandlingsmenyvalget Opprett ordre:

Marker de timene som skal overføres til ordre og disse blir overført til respektive ordre og er klar til fakturering.

Reise/utlegg

Reise/utelgg godkjennes ved hjelp av behandlingsmenyvalget Overfør:

Marker de timene som skal overføres til ordre og disse blir overført til respektive ordre og er klar til fakturering

Her kan du laste ned skjermbilder, demodatasett og triggere.


Timer til Lønn

Overføring av timer til Visma Lønn

Oppsett i Visma Business

Produktene som skal overføres til Visma Lønn må ha riktig lønnsart og aktivitetsbehandling

Ved overføring til Lønn benyttes standard imp fil i Visma Business sin imp katalog. Sti for hvilken imp fil som skal benyttes, hvor lønnsfilen skal legges og med hvilket navn, settes opp i tabellen E-dokumenter.

Overføring:

For å kunne kjøre overføring til lønn, må du benytte seg av "Godkjenning av timelister".
Kun timer med lønnsartnummer vil bli overført.
Lønnskjøringen må være opprettet i Visma Lønn før import. Lønnskjørenr i Visma Business og i Visma Lønn må være identiske. Lønnskjørenr settes og justeres i valget "Endre Tellere" under Behandling i tabellen Bedriftsopplysninger.

MERK!!! Det må kjøres et utlegg per timegruppe. Mellom hvert utlegg til lønn, må foregående fil importeres i lønn, for den vil bli overskrevet. Lønnskjørenummer må tilbakestilles før kjøring for neste timegruppe.

Fra Visma Business Time:

En timeaktivitetslinje blir ikke klar for overføring til lønn før timelisten er godkjent og kun linjer med lønnsartnr vil få status "Klar for overføring til lønnsfil".
Timelistene godkjennes på normal måte – uke for uke – eller iht. egne interne rutiner. Avkrysning for "Utlegg til lønnsfil" skal IKKE krysses av.
Opprett et eget skjermbilde for overføring av overtidstimer (evt. timer for ans. på timelønn) til lønn.

Skjermbildet inneholder alle timeaktivitetslinjer med status "Klar for utlegg til lønnsfil".
Når lønnskjøringen er opprettet i Lønn, kjøres det ut liste fra Visma Business Time.
Lønnfilutlegget genereres på samme måte som "Godkjenne timer" og i samme dialogboks

I Godkjenningsdialogen skal følgende være krysset av:

Ta bort avkrysning for "Godkjenning av Timeliste".
Kryss av for "Overfør til Lønn".
Legg inn datoer eller ukenummer for ønsket overføringsperiode. Sjekk datoene i skjermbildet for å være sikker på å få med alle. Ikke overførte linjer fra tidligere lønnsperioder (f.eks. ved for sen innlevering / godkjenning av timelister) vil legge seg klare til overføring på neste lønning. Det er derfor viktig å få med laveste og høyeste ukenr.
Sjekk at lønnskjørenummer i det nedtonede feltet er i overensstemmelse med lønnskjørenr i Visma Lønn som skal ta i mot timene. Dersom lønnskjørenr ikke stemmer, må utlegget avbrytes og telleren endres før utlegget kjøres på nytt (se over). Lønnsfilnavnet er det samme som ble satt i
E-dokumentinformasjonstabellen.

Import i Visma Lønn

Når lønnskjøringen er opprettet og filen er generert fra Visma Business skal den importeres i Visma Lønn.

Benytt knappen "Finn" for å browse deg fram til ønsket fil (Visma Lønn husker dette til neste gang om det ikke er importert andre filer i mellomtiden)

Kontroller at riktig lønnsår og riktig kjørenr er valgt før du trykker på START

MERK!!! En csv fil kan åpnes i Excel, dersom du åpner den i Excel før import, må du IKKE lagre filen i Excel, den får da feil antall kolonner og importen vil feile. Må du endre på innholdet i filen, åpne filen i Notepad.


Bokføring av kostnader ved produksjon

Dette beskriver hvordan strukturvarer kan settes opp for å kunne gi en regnskapsmessig oversikt over kostnader og beholdning underveis i produksjonen.

Avgifts- og bokføringsgrupper

Hovedvaren og råvarene må ha forskjellige Avg. og bokf. grupper slik at de blir bokført på separate kontoer for varekostnad. Råmaterialene skal ha produksjonsvarens konto som debet. Hvis det også skjer direktesalg av råvarene må man ta i bruk Kontosett, bruk kontosett 2 for produksjon og kontosett 1 salg.

Behandlingsmåte (hovedprodukt):

Behandlingsmåte for produksjonsvare. Må akkumulere kostnader opp i strukturhodet. Kostnader må unntas totaler for å unngå doble beløp.

Innkjøp av material:

Innkjøp av material vil blir bokført slik:

Produksjonsordre:

Kostnader bokføres ved å markere produksjonsordrens produkttransaksjoner med transtype 5, velg behandlingsmenyvalget ”Bokfør kostnader”.

Dette leder til følgende dialog, velg ”Fullstendige bilag”:

Bokføring av kostnader ved produksjon:

Konto for råvarer er kreditert og konto for ferdigvarer er debitert.

Salg av ferdigvarer:

Bokføring av salg:

Varebeholdningskontoen for ferdigvarer blir kreditert.


Beställningsförslag

Inledning

Beställningsförslaget är ett utmärkt hjälpmedel att skaffa information om när, var och hur för ett inköp. Inköpet syftar till att tillfredsställa kundernas behov av varor i korrekt tid och till korrekt utförande. Du kan sitta på en avdelning i ett hörn av företaget och registrera order, och i ett annat hörn på en annan avdelning och beställa varor. Men det är naturligtvis inte alls nödvändigt att vara flera avdelningar för att ha nytta av beställningsförslagsmodulen i Visma Business.

Direktleveranser till slutkund finns det ett visst stöd för. Det finns möjlighet att göra Visma Business ännu smartare än det är idag och genom att lägga till funktionalitet direkt i databasen kan vi lägga in leveransadressen – vår kunds adress - på beställningen till leverantör, och detta skall vi titta mer på senare.

Begreppen som jag konsekvent kommer att använda mig av är: Order = order från kund, Beställning = Order till leverantör. Att Visma Business använder order i bägge fallen skapar ju annars lite osäkerhet.

Visma Business har en ”formaliserad” syn på verkligheten när det gäller hantering av beställningsförslag. Det är ett måste om man skall kunna formalisera verkligheten så att det går att automatisera något så komplext som ett beställningsförslag. Det innebär att ledtider, leveranstider etc som det oerhört svårt att bestämma ett korrekt värde för (eftersom de kan skilja sig från en leverans till en annan) måste få fasta värden som vi måste leva med. Vi har inte möjlighet att säga ”det kommer om 7 dagar +/- 2 dagar”. Detta är en formaliserad syn på verkligheten.

Ni kanske inte tycker att det är så komplext, men jag måste erkänna att jag tycker detta är svårt.

För att göra det mer lättfattligt kommer jag först att gå igenom den nödvändiga information som krävs i tabellerna för att Visma Business skall uppföra sig som vi vill att det skall göra. Därefter kommer en redogörelse för teorin bakom de olika metoderna och hur Visma Business ser på dessa metoder. Till sist kommer det praktiska exempel som kommer att ge lite ”hands-on”.

Teori

Beställningsmetoder i teorin

Visma Business har stöd för tre olika beställningsmetoder. Var och en olika, men med flera gemensamma fält. Dessa fält måste vara ifyllda på ett korrekt sätt för att beställningsförslagsrutinen skall fungera. Nedan skall jag beskriva lite om de olika metodernas teori och därefter hur de praktiskt skall sättas upp för att fungera på ett korrekt sätt. Vilka fält som måste var ifyllda mm.

Saldoförändringar

Saldoförändringsmetoden lämpar sig utmärkt för produkter av sällanköpstyp, men också för produkter med korta eller säkra leveranstider. Detta kommer sig av att med korta eller säkra leveranstider så finns det ingen anledning att lägga upp säkerhetslager eller motsvarande. Det är ofta fråga om direktleverans till slutkund, efter en kortare ompackningsrunda på eget lager.

Saldoförändringar sker över tiden och det finns ett par parametrar som bara är användbara vid beställningsförslagsgenereringen med denna typ av beställningsmetod. Du kan använda dig av en tidshorisont framåt, och ta hänsyn till Min lager, Max lager och ekonomisk inköpskvantitet.

Beställningspunkt

Beställningspunkt är utmärkt för de flesta produkter. Den håller reda på Min lager, och Max lager. Den har ytterligare ett begrepp och det är Beställningspunkt (som namnet kanske antyder). Denna beställningspunkt med avdrag för säkerhetslager är erfarenhetsmässigt den mängd som kommer att säljas inom ”ledtid” dagar.

Nedan är ett idealexempel på beställningspunktssystemet, alternativ 1. Vid tidpunkt T0 så fylls lagret upp till Bp (=beställningspunkt). Under den tid som det tar att skaffa nya produkter så säljs lagret och när ”Ledtid i dagar” T1 nås finns fortfarande produkter kvar i lager över Min lagernivån.

Den absoluta fördelen med beställningspunktssystemet är att beställningsförslaget kan köras när som helst, och hur ofta som helst. Det finns inga begränsningar vad gäller uttag med mera, som det gör med till exempel periodiska beställningar.

Beställning görs vid T0 och då kontrolleras lagersaldot vid exakt denna tidpunkt. Behovet att beställa fås när ”Disponibelt saldo” < ”Beställningspunkt”. Behovet att beställa blir n (heltal) * ”Ekonomisk inköpsmängd” när detta blir >= Beställningspunkten. Om Disponibelt lagersaldo befinner sig ovanför Bp så görs ingenting.

Nedan är en bild på Beställningspunkt alternativ 2

Som syns ovan så har vi två stycken brister att hantera. Den ena är bristen som finns idag (T0), som är skillnaden mellan disponibelt lagersaldo och beställningspunkten Bp. Den andra är den som inträffar vid T1 som är skillnaden mellan Min lager och disponibelt lagersaldo vid T1 som är ”Ledtid” dagar bort, med hänsyn taget till under perioden uppkomna in- och utleveranser.

Alternativ två kontrollerar även framåt, och det skiljer alternativ 1 och alternativ 2 från varandra eftersom alternativ 1 endast tittar på T0. I Visma Business utvärderas båda samtidigt. Det sker naturligtvis inte samtidigt, men utvärdering sker alltid efter BÅDA principerna.

Periodisk beställning

Periodisk beställning fungerar som så att beställning sker till exempel var femte dag och det är typiskt produkter som fluktuerar mycket i efterfrågan och som har en begränsad livscykel. Ett typiskt exempel skulle vara en skrivare eller vissa typ av datorer.

Fördelen med periodisk beställning är att den kan ta hand om ”underefterfrågan”. Genom att tillåta negativa beställningsförslag får Du en varning om när produkten tappar efterfrågan. Du väljer om Du vill se negativt beställningsförslag.

Nackdelen med metoden är att förslaget Du får, automatiskt godkänns. Det finns ingen möjlighet att ”backa” förslaget så till vida att de räknare som nollställs och de datum som sätts görs vid generering av beställningsförslag. Dessa kan som sagt inte backas, och så som det är uppbyggt kan Du inte – med mindre än att Du manuellt raderar datumen i lagersaldotabellen på relevanta tabeller – ta ut ett nytt beställningsförslag innan ytterligare ”period” dagar.

Nödvändig information i tabellerna

De tabeller som ligger till grund för att ett korrekt beställningsförslag skall komma till stånd är:

Aktörstabellen

I aktörstabellen ligger parametrar som fylls i med automatik i de produkt- och lagerrelaterade tabellerna om de fylls i på leverantören. Dessa fält är: Adm.tid, Lev.tid och Transp.tid som är förkortningar för:

Administrationstid

Tid som det internt inom Ditt företag tar för att få utfört beställningen. Denna tid beror på rutiner som i sin tur påverkar beställningsfrekvensen av produkten.

Leveranstid

Tid som det att producera/plocka ihop din beställning. Denna tid är den tid som det tar INTERNT hos din leverantör att effektuera din beställning.

Transporttid

Tid det tar från det att din leverantör skickar iväg din beställning till det att Du får hem till ditt lager. Om detta skall fungera fullt ut bör leverantörens produkter ha samma tider – vilket de ofta inte har. Du kan alltid se de överförda tiderna som ett förslag i de produktrelaterade tabellerna.

Produkttabellen

Standard försäljningsenhet talar om vad som är standard vid orderregistrering.

Lagersaldotabellen

I lagersaldotabellen ligger de viktigaste värdena för att få ett korrekt beställningsförslag (vad gäller produktinformation).

Produkt-/Lagernr

Det finns en rad per produkt-/lagernummerkombination. De val som görs per rad gäller ENDAST denna rad, och inte per leverantör eller produkt. Om det aktuellt med samma behandling per leverantör föreslår jag att urval sker på leverantör och värdena i dialogen anges och på det sättet överstyr de värden som är angivna i Lagersaldotabellen.

Fysiskt saldo

Fysiskt saldo är summan av orealiserad lagerökning och realiserat saldo. Detta fält finns inte i databasen, utan är uträknat.

Tidsaspekten

När produkterna är sända från leverantör ingår de inte längre ”Bekräftat av Leverantör”, och när produkterna är inlevererade är de inte längre med i ”Sänt från Lev.”, utan de ingår då i ”Orealiserad lagerökning” intill dess att de är fakturamottagna. Då blir det realiserade.

Det som säljs från ett lager där produkterna endast är inlevererade mot lager (men inte fakturamottagna) kommer att visas som ett negativt realiserat saldo. Att ha ett negativt realiserat saldo är helt OK om man har en positiv orealiserad lagerökning som väger upp.

Reserverad och reserverbart

Dessa två fält talar om vilket som är, respektive inte är tillgängligt för att reservera på en reservationsrad (som kan skapas på flera olika sätt).

Ökning/minskning innanför ledtid

Ökning, och minskning är samlingsbegrepp för allt som kommer in och allt som går ut.

Transaktionstyp | Ökning | Minskning | Netto
1. Försäljning | Kredit i order | I order | Netto i order
2. Uthyrning | Kredit i uthyrningsorder | I uthyrningsorder | Netto i uthyrningsorder
3. Utlåning | Kredit i utlåningsorder | I utlåningsorder | Netto i utlåningsorder
4. Justering | Kredit orealiserad förlust | Orealiserad förlust | Netto orealiserad förlust
5. Varuförbrukning | Kredit i beord. till prod. | I beord. till prod. | Netto i beord. Till prod.
6. Inköp | I beställning | Kredit i beställning | Netto i beställning
7. Produktion | I produktion | Kredit i produktion | Netto i produktion
8. Lageröverföring | I lageröverföring till | I lageröverföring från | Netto i lageröverföring
 | Summa ökning | Summa minskning | Netto saldoförändring

En kredit till kund är alltså en ökning. Innanför ledtid är alltså det som händer innanför den tid som vi angivit som ledtid (som är den uträknade summan av Adm.tid, Lev.tid och Transp.tid). Detta är särskilt viktigt att veta vid generering av beställningsförslag.

Hur beräknas fälten?

Ökning/minskning innanför ledtiden uppdateras med utgångspunkt i:

a. bekräftat leveransdatum (ankomstdatum vid inköp/produktion) <= dagens datum+total leveranstid (flyttat till närmaste arbetsdag).

OCH I KOMBINATION MED

b. Om det är en försäljningsorder och den redan har blivit löst allokerad (dvs att den en gång har varit innanför ledtiden – men nu kan befinna sig utanför)

Löpande uppdatering av fälten är nödvändigt eftersom det ändrar sig från dag till dag vad som är innanför respektive utanför ledtid. Det finns ett menyval i ordertabellen/lagersaldotabellen som är avsett att lagra om dessa tabeller för att uppdatera informationen.

Saldo innanför ledtiden finns inte i databasen med räknas ut som:

Fysiskt saldo +Ökning innanför ledtiden – Minskning innanför ledtiden.

Saldo inklusive ändringar

Saldo inklusive ändringar är uträknat genom:

Fysiskt saldo + Netto saldoförändringar. Detta är helt oberoende av ledtiden.

Beställningsmetod

Beställningsmetoden kan vara olika på olika produkter och ändå skapas under ett och samma beställningsförslag. Standard metod för beställning är Saldoförändringsmetoden. Den väljs om inget annat är valt. Det går också utmärkt att överstyra beställnings-metoden i Beställningsförslagsdialogen.

Min lager och Max lager

Dessa har betydelse, i kombination med lagersaldot, för att styra inköpsmängden). Mängden kan anges i dagar eller i enheter och oavsett vilket som anges räknas det andra värdet ut och anges i blå skrift. För att kunna räkna ut detta krävs att Du har angivit uttagstakten. Uttagstakten är det samma som en prognos.

Ekonomisk inköpsmängd

Det vill säga den mängd som det är ekonomiskt fördelaktigt att köpa in. Den kan beräknas till exempel med Wilson-formeln och kompletteras med praktiska överslag (Det är inte ett praktiskt överslag, utan ett överslag som praktik har funnit bra). Denna kan också anges i dagar eller i enheter och med funktionalitet som ovan.

Normal leverantör

Den leverantör som Du normalt köper in från till detta lager. Det finns möjlighet att avgränsa sig till att alltid använda normal leverantör vid beställningsförslaget.

Beställningsintervall

Vid periodisk beställning anges i fältet det minsta antal dagar som skall löpa mellan varje periodisk beställning. Detta gäller för denna Produkt/lager-kombinationen.

Beställningsförslagsdatum, och uttag sedan beställningsförslag

Visma Business håller reda på när det senaste beställningsförslaget skrevs ut och antal av denna produkt som har ”förbrukats” sedan detta datum. Förbrukat är egentligen fel beteckning eftersom Uttag sedan beställningsförslag ökar med reserverat antal sedan senaste beställningsförslag. Vid utskrift av beställningsförslag nollställs räknaren i detta fält, samt beställningsförslagsdatum sätts till dagens datum – även om inget förslag att beställas kommer fram. Detta fält används endast vid periodisk beställning. Dock är informationen i fältet intressant att använda som jämförelse, även vid andra typer av beställningstyper.

Beställningspunkt i lagerenhet eller dagar

Vid beställningspunktsmetoden används detta värde som det värde som beställning skall ske om Disponibelt lagersaldo (Disponibelt lagersaldo = Fysiskt saldo – Summa(i Order) + Summa (i Best inom Ledtid)) faller under denna punkt. Det andra användningsområdet för detta fält är för att ange en normalnivå på lagret som Visma Business kommer att ta hänsyn till vid periodisk beställning. Lagerenheter och dagar fylls ut på samma sätt som i ovanstående fall.

Beställningsbehandling

Uppslag i detta fält visar en dialog med avkryssningsfält som är till hjälp för att skapa beställningsförslag. Dialogen ser ut som nedan och detaljerna kommer vi att penetrera i avsnittet om beställningsförslag.

Aggregeringsnivå

Vid metoden för saldoförändringar kan aggregeringsnivå anges för att inte få för finfördelat beställningsförslag. Om till exempel beställning sker en gång per vecka och leverans sker på motsvarande sätt kan det vara idé att summera ihop beställningsförslagsraderna per vecka för att inte få för mycket detaljer att oroa sig för.

Avrundningsmetod

Avrundningsmetoden kan överstyras vid utskrift av beställningsförslag, och om inget anges görs heller ingen avrundning.

Lagersaldotabellen är den tabell som Du aktivt arbetar mot. Tabellen är central eftersom det är ”huvudtabellen” i kopplingen mot beställningsförslagsrader.

Avrundning

Avrundning anges i en multipel som det närmast skall avrundas till. Till exempel 1 anger att antalet skall avrundas till helt antal av multipeln 1.

Leveransalternativtabellen

I leveransalternativtabellen ligger fält som är unika för var leverantör av en speciell produkt. Det kan vara leverantörsspecifik information om leverantörens produktnummer mm. Det finns sedan Visma Business 3.30 åtta stycken fält för att kunna skapa en egen REPA-rapport.

Fält som berör och påverkar beställningsförslag är:

Inköpsenhet

Om denna skiljer sig från försäljningsenhet. Denna kommer att föreslås (om den är ifylld) på beställningsförslagsraden och vid generering av order, även på beställningsraden. Vid uppslag refererar fältet till Enhets-tabellen som ligger i Produkter-mappen.

Ekonomisk inköpsmängd

Ekonomisk inköpsmängd är viktig vid användning av beställningspunktsmetoden eftersom Visma Business multiplicerar med en faktor n gånger ”Ekonomisk inköpsmängd” för att komma över antalet som är lika med beställningspunkten. Om denna då är 0 (noll) kan det skapa lite problem så till vida att Visma Business försöker multiplicera med 0 för att komma över beställnings-punkten.

Produktion

Detta är ett avkryssningsfält som anger om det skall skapas en produktionsorder, eller en inköpsorder. Om det är avkryssat i detta fält skapas en produktionsorder till leverantören. Produktionsorder direkt till leverantör får nog ses som en utopi. Vi bryr oss ju inte om, om det skall produceras hos leverantören. Det enda vi bryr oss om är om vi får produkterna. Produktionsorder är för ”internt bruk”.

Adm.tid, Lev.tid och Transp.tid

Samt Total Lev.tid som är en beräknad summa av de tre. Fälten som också finns i aktörstabellen blir föreslagna från denna tabell. Om det är aktuellt att endast använda ETT fält (för att förenkla hanteringen) är det enklast att endast använda Lev.tid.

När fälten från leveransalternativ-tabellen blir uppdaterade eller tillagda så uppdateras denna information automatiskt i lagersaldotabellen på den rad där Normal leverantör i lagersaldotabellen stämmer överens med leverantörs-numret i leveransalternativtabellen.

Fälten från lagersaldotabellen föreslås på orderraden.

Fälten från leveransalternativtabellen föreslås på beställningsförslag samt beställningsrader.

Vid beställning sätts önskat och bekräftat leveransdatum till Beställnings-/transaktionsdatum+leveranstid, och ankomstdatum sätts till bekräftat leveransdatum+transporttid.

Sammanfattning

Det är många variabler som ska/kan sättas. Det är bara erfarenheten samt möjligheten att, efter hand, uppdatera värdena i dina tabeller till att vara mer och mer korrekta som skapar en bra slutprodukt. Detta är inte helt enkelt, eftersom det krävs att Du inte bara kan Visma Business, utan även kräver att Du förstår dig på inköp. Det tidigare är betydligt enklare än det senare.

Grunder i Visma Business

Beställningsförslag enligt Visma Business

Beställningsförslag skapas från ett fönster med Lagersaldotabellen med tillkopplade beställningsförslagsrader.är Du använder Dig av utskrift, vare sig det är förhandsgranskning eller till skrivare, kommer en dialog upp som frågar efter parametrar till ditt beställningsförslag.

Du gör urval på önskade kriterier i lagersaldotabellen som till exempel lager, inköpsansvarig, eller leverantörsnummer. De olika produkterna kan i sin tur ta sina parametrar antingen från lagersaldotabellen, eller så kan dialogens värden överstyra valen som är gjorda på de enskilda produkterna.

Du kan ta fram vilka som helst underliggande kolumner/fält, och dessa kommer att tas med vid utskriften. Sidbytesnivå kan sättas till 0 för att slippa sidbrytningar per produkt.

Parametrar i dialogen lagras med uppsättet, (dock inte datumet).

Val i lagersaldotabellen

I dialogen finns det tre stycken Combo-boxar. Det första valet är (Från lagersaldotabellen) och innebär att värdena kommer att hämtas från Lagersaldotabellen där värdet kan anges per Produkt/lagerkombination.

Avkryssningsfälten kan ha ett av tre statusar (undantaget ”Utskrift” och ”Skriv till tabeller”) som innebär att Visma Business antingen använder parametern (Ifylld med vit bakgrund), att parametern är avslagen (helt vit ruta) och till sist att parametern skall hämtas från Lagersaldotabellen där motsvarigheten finns i fältet ”Best. beh.” (grått fält med kryss).

Lagersaldotabellen använder fler fält som har med beställningsförslag att göra, dessa är genomgångna ovan.

Upplysningar som saknas i leveransalternativtabellen hämtas från lagersaldotabellen. Detta gäller Ekonomisk inköpskvantitet och Leveranstid. Oavsett om det är så att det saknas data i leveransalternativtabellen eller om det helt saknas rader.

Generella parametrar

Beställningsmetod

Du kan välja mellan tre olika metoder:

Beställ utifrån saldoförändringar

Med denna metod räknar Visma Business beställningsdatum bakåt så många dagar som är angivet som leverans- plus transporttid för det aktuella leveransalternativet (eller lagersaldoraden), från den tidpunkt då det fysiska saldot understiger Min lager.

Beställ när beställningspunkt nås

Vid användning av beställningspunktsmetoden kommer Visma Business att beställa enligt alternativ 1 eller 2. Det vill säga det högsta av:

1. Minsta antal * Ekonomisk inköpskv. >= Beställningspunkt – Saldo inkl. ändringar till dagens datum (=Disponibelt saldo), om Saldo inkl. ändringar fram till dagens datum < Beställningspunkten.

2. Minsta antal * Ekonomisk inköpskv. >= Min lager – Saldo innanför ledtid – Reserverat utanför ledtid, om Saldot innanför ledtid + reserverat utanför ledtiden < Min lager.

Saldo inklusive ändringar fram till och med dagens datum = Fysiskt saldo + Summa ökning innanför ledtiden (båda dessa värden finns i lagersaldotabellen) – Summa minskning på rader i saldoförändringstabellen med datum <= aktuellt datum.

Periodisk beställning

Vid periodisk beställning kommer Visma Business att föreslå att fylla upp lagret enligt; uttaget sedan föregående beställningsförslag + önskad lagernivå (som är detsamma som fältet för Beställningspunkt) – Saldo innanför ledtiden – reserverat utanför ledtiden, med dagens datum som beställningsdatum.

Som tidigare nämnts kommer lagersaldoraden endast med om det har minst så många dagar som är angivet i fältet ”Best.intervall”, eller att fältet som innehåller senaste beställningsdatum inte är ifyllt.

Avrundning

Antalet på beställningsförslag kan uppdateras genom att välja en avrundningsmetod.

1. Uppåt

2. Nedåt

3. Närmast

Avrundning sker i relation till värdet i fältet ”Avrundning”. Antalet före avrundning tas vara på, på beställningsförslagsraden.

Använd normal leverantör

Om det är kryssat av för att använda normal leverantör, kommer Visma Business att avgränsa sig till att använda leveransalternativ för den leverantör som är angiven som normal leverantör i lagersaldotabellen. Annars används den leverantör som kan tillfredsställa behovet av produkter snabbast.

Utskrift, och Skriv till tabeller

Du kan välja om beställningsförslaget skall skrivas ut och/eller (om inte förhandsgranskning) även skriva till tabeller . Om utskrift sker till tabeller skapas det en rad i beställningsförslagstabellen med därtill hörande en eller flera rader i beställningsförslagsrader.

Du kan naturligtvis även göra utskrift av innehållet i dessa tabeller.

Parametrar som endast gäller alternativet Beställ utifrån saldoförändringar

Ta hänsyn till framtida förväntade saldoförändringar

Om det är kryssat av för att ta hänsyn till förväntade framtida saldoförändringar, kommer Visma Business att ta hänsyn till planerade in- och utleveranser utifrån saldoförändringstabellen, som uppdateras vid order-/beställningsregistrering.

Senaste beställningsdatum

Om Du anger ett beställningsdatum i denna dialog, kommer Visma Business att begränsa sig till beställningar som skall vara gjorda före detta datum. Visma Business kommer alltså att bortse från beställningar som skall göras senare.

Om Du inte använder rutinen dagligen bör datumet sättas till det datum som är dagen före nästa gång Du skall köra ett beställningsförslag.

Aggregeringsnivå

Saldoförändringarna kan slås samman genom att välja en av aggregeringsnivåerna:

1. Per vecka

2. Per månad

3. Totalt

Visma Business kommer annars att behandla saldoförändringarna per dag. Detta kan bli lite plottrigt eftersom leverantören förmodligen inte vill skicka små sändningar kan det vara en idé att försöka få leveransen per vecka och aggregera per vecka i stället för per dag.

Fyll upp minimilagersgräns, Köp in ekonomisk mängd och överskrid ej maximumlagersgräns.

Om det är kryssat av för ” Fyll upp minimilagersgräns”, kommer Visma Business att beställa så mycket att detta täcks, och annars endast tillse att saldot inte blir negativt. Om det är kryssat av för ” Köp in ekonomisk mängd” så kommer Visma Business att beställa minst så mycket. Har Du kryssat av för ”Överskrid ej maximum-lagergräns” kommer Visma Business att beställa så mycket att detta inte överskrids.

Prioritera leveranstid

Om detta valet är förkryssat kommer Visma Business att välja bland de alternativ som kan levereras så snart som möjligt innan aktuellt datum. Om leverans inte kan ske för det önskade datumet (på grund av att Du är sen med beställningsförslagsuttaget), väljs det alternativ som kommer närmast.

Parametrar som endast gäller periodisk beställning

Ta med negativt beställningsbehov

En fördel med metoden för periodisk beställning är att den ger en varning för ”underefterfrågan”. Detta kommer fram i formen av negativa beställningsförslagsrader när saldot överstiger periodens uttag och den önskade lagernivån, det vill säga att när försäljningen visar sig vara mindre än väntat, och det är kryssat av för att ta med negativt beställningsbehov.

Vid generering av Inköps- och produktionsorder kommer Visma Business att ignorera rader med negativt antal.

Redigering av beställningsförslag

Du kan gå in i tabellen som heter beställningsförslag med tillhörande rader och redigera detta direkt. Du kan också lägga till egna rader eller ta bort föreslagna rader.

Generell information

Beställningsförslagsnummer

Beställningsförslaget får ett unikt nummer genom att trycka ’+’ i fältet för beställningsnummer. Detta beställningsnummer kommer vid upprättande av beställning att kopieras till den upprättade beställningens Internnummer.

Beskrivning

Upplysningsfält för valfri information. 40 tecken långt.

Parametrar för generering av order

Ordertyp

Anges om beställningen skall upprättas med ANNAN ordertyp än 1 (Normalorder).

Samlad leverans

Anges som beställningen som skapas skall samlevereras. Datum för samleverans sätts till leveransdatum i orderhuvudet till det leveransdatum som är längst BORT i tiden (det ”sämsta”), räknat från dagens datum.

Sparas

Om detta val är ifyllt kommer inte beställningsförslaget att raderas efter överföring till beställning.

Generella val på beställningsförslagsrader

Beställningsförslagsnummer

Beställningsförslagsnummer kommer löpande att räknas upp vid produktion av nytt förslag. Detta beställningsförslagsnummer kommer att kopieras till Beställningen/Produktionsorderns fält Internnummer där numret är fullt sökbart. Observera att flera beställningar/produktionsorder kan ha samma Internnummer.

Upplysning 1 och 2

Fria upplysningsfält som inte kopieras någonstans.

Föreslagna värden

Produktnummer, lagernummer, leveransalternativ och leverantörsnummer

Produktnr och lagernr kommer från Produkt respektive Lagertabell. Tillsammans utgör de primär nyckel i Lagersaldotabellen. Produktnr + Leveransalternativ tillsammans är primär nyckel i Leveransalternativtabellen. Leverantörsnummer kommer från Lev.nr –kolumnen i Aktörstabellen.

Förslag från produkt och eventuellt leverantör

Vid inmatning av produktnummer – eller leverantörsnummer då produktnummer är ifyllt – föreslås det leveransalternativ som har högst prioritet för produkten alternativt leverantören. Visma Business kommer att varna om det inte finns ett leveransalternativ.

När leveransalternativ blir föreslaget eller inmatat (till exempel via uppslag) föreslås:

  • Leverantörsnummer
  • Produktion
  • Transporttid
  • Senaste leveransdatum = senaste ankomstdatum -Transporttid
  • Leveranstid
  • Senaste beställningsdatum = Senaste leveransdatum – Leveranstid
  • Enhet
  • Antal = Ekonomisk inköpskvantitet

Produktion

Detta avkryssningsfält föreslås från leveransalternativtabellen och avgör om det skall skapas ett inköps- eller en produktionsorder till leverantören.

Transporttid, leveranstid, senaste ankomst-, leverans- och beställningsdag/vecka

Transporttid och leveranstid kommer som förslag från leveransalternativtabellen. Senaste ankomstdatum är bestämt utifrån tidpunkt för behovet. På de beställningsförslag som Visma Business producerar är ankomstdatum det datum lagersaldot måste fyllas på för att täcka behovet av produkten.

Vid inmatning av senaste ankomstdatum eller transporttid, beräknas senaste leveransdatum och vid inmatning av senaste leveransdag eller leveranstid beräknas senaste beställningsdatum. Ordningsföljden är omvänd på orderraden, då beställningsdatum anses vara givet (order/transaktionsdatum). Förutsätts vara given och leveransdatum (önskat och bekräftat) och ankomstdatum beräknas utifrån detta. Datumen kan också visas och matas in som år/vecka/dag i egna kolumner(fält).

Överstyrt leveransdatum

Vid inmatning i detta fält sätts:

  1. Senaste ankomstdatum = överstyrt leveransdatum + transporttid
  2. Senaste leveransdatum = överstyrt leveransdatum
  3. Senaste beställningsdatum = överstyrt leveransdatum – leveranstid

Enhet

Enhetsfältet refererar till enhetstabellen och föreslås utifrån standard inköpsenhet från leveransalternativtabellen, och om den inte är ifylld, från standard försäljningsenhet i Produkttabellen.

Antal

Detta fält anger antalet som skall köpas in, räknat i inköpsenheten enheten (sorten) på raden. Vid egen inmatning av produktnummer kommer antalet som föreslås att vara lika med Ekonomisk inköpskvantitet. På de rader som Visma Business skapar kommer antalet att sättas till det behov Visma Business räknat ut att Du har.

Antal före avrundning

Fältet innehåller antalet före avrundning, och blir oförändrat, även vid redigering av antalsfältet.

Kända begränsningar

Det är INTE möjligt att – i version 3.30 – få det att fungera på ett korrekt sätt med enhetsomvandlingar från beställningsförslag till beställning. Detta beror på att omräkningen från Antal * antal per Enhet (som ger Antal i inventeringsenhet) inte sker på ett korrekt sätt. För att få detta att fungera krävs lite handpåläggning som Du kommer att beskriva senare.

Generering av inköps- och produktionsorder

Visma Business skapar beställningar direkt utifrån beställningsförslag (-en). Beställningar och produktionsorder kan också skapas direkt från en kundorder.

Behandlingsmenyvalet Generera order

Beställningar skapas genom att använda behandlingsmenyvalet Generera order. Detta behandlingsmenyval kan användas både från Beställningsförslag och Beställningsförslagsrader. Det går utmärkt att antingen markera endast rader, alternativt skapa beställningar till flera leverantörer samtidigt.

Visma Business hindrar flera att skapa beställningar från samma förslag samtidigt.

Samma produkt kan dock förekomma i flera förslag och generera multipla beställningar. Det är därför viktigt att om flera inköpare arbetar samtidigt, att dessa inte har produkter som är gemensamma, utan att de fördelas på ett korrekt sätt dem emellan. Detta kan göras genom att det är möjligt att koppla till tabeller till Lagersaldotabellen och göra urval på dessa, även de kolumner som kommer från främmande tabeller.

Beställningshuvudet

Vid användning av behandlingsmenyvalet skapas en beställning per leverantör och eventuellt en produktionsorder. Vid användning av behandlingsmenyvalet från beställningsförslaget (huvudet) så blir det skilda beställningar per beställningsförslag.

  • Beställningen får nästa lediga ordernummer.
  • Transaktionstypen blir satt till 6 eller 7 beroende på om det är en inköps- eller produktionsorder som skapas.
  • Ordertypen blir satt till normalorder om inte ordertypen är överstyrd i beställningsförslagshuvudet.
  • Orderdatum blir satt till det tidigaste av beställningsdatumen(transaktionsdatumen).
  • Om det är kryssat av för samleverans på beställningsförslaget, kommer ordern att få ett samlat leveransdatum som är baserat på den beställningsrad som har det ”högsta” leveransdatumet.
  • I beställningshuvudet tar Visma Business också med information om leverantören och eventuell leveransadress samt fakturamottagare angiven på leverantören. Om de två saknas används adressen från eget företag samt från leverantören.
  • Beställningsförslagsnumret kommer med på beställningen som Internnummer.
  • Om behandlingsmenyvalet utförs från rad, används parametrarna från beställningsförslagshuvudet till den första raden per leverantör, eller det som gäller produktion. Raderna MÅSTE vara sorterade på leverantörsnummer. Annars kommer Du att få felmeddelande därom.

Beställningsrader

På beställningsraden fyller Visma Business i värden från beställningsförslagsraderna och hämtar information från produkttabellen. Duplicerar värden från beställningshuvudet, gör uppslag i Pris- och Rabattmatrisen, beräknar kostpris inklusive tull och frakt. Därefter lagras beställningen och med detta räknas belopp ut i orderhuvud och på rader samt uppdaterar lagersaldotabell (beroende på ordertyp) och orderstatus sätts.

Datumfälten på beställningsraden blir ifyllt utifrån beställningsförslagsraderna:

  • Transaktionsdatum = Senaste beställningsdatum
  • Önskat leveransdatum = Överstyrt leveransdatum, om detta är ifyllt, annars Senaste leveransdatum
  • Bekräftat leveransdatum = Senaste leveransdatum
  • Ankomstdatum = Senaste ankomstdatum

När behandlingen utförs från beställningsförslagshuvudet läser Visma Business beställningsförslagsraderna sorterat på beställningsförslagsnummer, leverantörsnummer och sorteringssekvensnummer, som det är definierat ett index på.

Meddelanden före, under och efter behandlingen

Om redigeringar gjorts och lagring inte skett kommer Du att få fråga om att lagra före behandlingen utförs. Om behandlingen utförs från beställningsförslagsraderna kommer Visma Business att meddela om raderna inte är sorterade på leverantörsnummer. Om raderna inte är kopplade till huvudet är det nödvändigt att definiera ett index på leverantörsnummer på beställningsförslagsraderna. Detta behövs inte om beställningar skapas utifrån beställningsförslagshuvudet, eftersom sortering då inte behöver ske.

Praktik

Beställningsförslaget i praktiken

Låt oss skapa en produkt som vi kan testa med. Det är viktigt att Du inte har använt produkten tidigare eftersom du bara kommer att bli förvirrad om Du inte kan följa exemplet steg för steg och då kommer Du att avbryta med irrelevanta frågor som bara visar att Du inte varit uppmärksam. Har Du läst så här långt och är med så börjar vi.

Grunddata

Uppläggning av leverantörsdata

Vi tar den godtyckliga leverantören Wheel in Sweden och kompletterar med en leveranstid på 7 dagar:

Så här skall det se ut när vi är klara…

Uppläggning av produktdata

För att visa hur data kommer från tabellerna är det viktigt att registrera produktdata i rätt ordning. Skapa en produkt som heter 070 Testprodukt. 070 står för noll dagar Adm.tid, 7 dagar leveranstid och noll dagar transporttid.

Som Du upptäcker så föreslås 7 som Lev.tid automatiskt när vi anger leverantörsnummer 97012797 i leveransalternativ.

Uppläggning av produkter på en order (för att skapa underlag för beställningsförslaget)

Skapa en order till en godtycklig kund för att skapa en illusion av många olika order från många olika kunder med olika tidsaspekter. Att det bara finns på en order har ingen betydelse.

Som Du ser har jag friserat den orderbild som normalt finns. Detta är för att jag vet att vi inte kommer få plats med allt på 800x600 så det kommer till slut bli två fönster i alla fall.
Välj datum enligt följande: Ett för länge sedan, ett idag, ett inom 7 dagar (som är den totala ledtiden) och till sist ett som ligger c:a 20 dagar framåt i tiden.

Skapa sedan nedanstående fönster:

Du skall kunna se exakt det som syns på bilden. Efter kompletteringen har Du tagit fram en massa roliga fält i lagersaldotabellen och dessa vet Du ju redan vad de betyder…

Generera beställningsförslag

Efter det att ordern är skapad skall vi nu skapa ett beställningsförslag på denna (enda) order. Vi skall gå igenom alla tre metoderna och för att vi inte skall få med skräp så skall Du innan denna första körning radera alla tidigare gjorda beställningsförslag.

Gå in i fönstret med lagersaldotabellen och koppla till beställningsförslagsrader. Det skall då se ut så här:

Detta är Visma Business sätt att sätta upp systemet för beställnings-förslagsgenerering. Detta sker genom utskriftsdialogen. Skulle Du dock vilja använda skrivare rekommenderas sidbytesnivå att sättas till 0. Annars kommer Du att få en ny sida per produkt-/lager-kombination och det kan bli många sidor. Det går utmärkt att skriva ett beställningsförslag till tabeller, utan att för den skull använda skrivare. Det skall vi nu göra.

Beställ utifrån saldoförändringar

Tryck på skrivarknappen och Du får då fram beställnings-förslagsdialogen. Ändra värdena så att din dialog ser ut som denna:

Vi använder oss av förväntade framtida lagerförändringar (fram till den 1/5) för att se hur detta hanteras. Kom ihåg att det datum som skall användas är det datum som infaller dagen före nästa körning.

Efter körning skall det se ut så här:

Varför har antalet blivit 65 och 40? 40 kan vi kanske mer intuitivt förstå, men 65? Jo, det finns ett Saldo innanför ledtid som är –60 och till detta kommer vårt val att fylla upp till minimilagergränsen. Detta ger 65. Att det sedan blir 40 beror på att minimilagret redan är uppfyllt, och därför inte behöver fyllas på.

Den uppmärksamme ser då att det finns två rader och att beställningsdatum samt leveransdatum infaller på en söndag. Detta beror på att parametern i företagsuppgifterna inte är satta att ta hänsyn till leveransfria dagar. När beställningsförslaget är skapat går Du in i en annan bild för att behandla det.

Behandla beställningsförslag

Beställningsförslagsbilden - som skräddarsys per kund - kan innehålla information som det här fönstret.

Detta är endast ett förslag på hur fönstret kan se ut.

Överstyr datum

Beställningsförslaget kan behandlas precis som vilken beställning som helst. Det som kan skapa lite frågor är de två faktum (som vi oftast får frågor om) är att ”Önskat leveransdatum” skapar förvirring genom att vissa leverantörer inte skickar sin leverans förrän datumet är uppnått, det vill säga att leverantören kommer inte ens att behandla ordern före ”Önskat leveransdatum”. Detta är vårt främsta motiv till att ”mörka” de datum vi fått genom beställningsförslaget och komma med ett alternativt datum.

Vi skall i förslaget ovan överstyra datumet till att ankomstdatumet infaller på en måndag.

Nu kommer senaste leveransdatum och ankomstdatum att ändra sig i motsvarande grad.

Summa per beställningsförslag

Det andra är att vi inte kan få en sammanräknad summa på hur mycket vi beställt för. Eftersom det finns en utmärkt kopplingsmöjlighet och beräkningsmöjlighet i Excel har jag skapat en liten ”Beställningssummerare” . Den fungerar som så att den tar fram relevant information till ett Excelblad, där den också räknar fram summan av beställningsförslaget. Detta kräver då en förenkling av verkligheten i form av endast svenska kronor (Standardvaluta) och endast inköp i styck. Denna ”summerare” ligger som separat fil under Beställningsförslagsmappen på CDn.

Utfallet i Excelbladet blir i alla fall så här:

Vi anger beställningsförslagsnumret och trycker därefter på tryckknappen. I just denna modell så finns ett maximum på 22 rader, och dessa rader räknas samman. Det finns säkert möjlighet att gör delsummor per leverantör, men det kan inte jag. Det ger dock extrapoäng till inlämningsuppgiften att fixa till detta.

Skapa beställning

Som sista steg skapas beställningen. Denna skapar vi genom att markera beställningsförslagshuvudet och välja behandlings-menyvalet ”Generera order”. Detta behandlingsmenyval skapar antingen en inköps- eller en produktionsorder beroende på typ av produkt.

Markera raden och tryck på behandlingsmenyvalet!

Åtgärder efter generering av inköpsordern

Efter det att beställningen är gjord kommer den att se ut så här:

Det enda som återstår är att skriva ut beställningen och skicka den till leverantören.

Vi skall nu gå vidare med att skapa ett beställningsförslag utifrån var och en av de övriga metoderna. Men för att kunna göra det krävs att beställningen raderas, annars har vi redan fyllt upp vårt behov och kommer inte få något förslag (om vi har otur).

Beställningspunkt

När beställningsförslag skapas med utgångspunkt i Beställnings-punktsvarianten så används ALLTID beställningsförslag av alternativ 1 OCH alternativ 2. Det innebär att vi inte har mycket variabler att bolla med utan vi kör direkt med följande parametrar:

Vi får då följande förslag:

Varför får vi 65? Vilken av de två alternativen är det som får tillslag? Jo det är alternativ 2 som får tillslag eftersom det inom ledtiden kommer att få lagersaldot att gå ner under minlager-gränsen.

Varför kommer inte de extra 40 med? Det beror på att alla order utanför ledtiden ignoreras med beställningspunktssystemet, som de också skulle göra inom saldoförändringsmetoden om Du inte explicit talar om att vi skall titta framåt i tiden.

Periodisk beställning

Använd följande parametrar:

En periodisk beställning kommer att ge följande svar:

Antalet är nu 81 som förslag. Vad beror detta på? Jo att uttaget sedan tidigare förslag är 0 och saldo innanför ledtiden är (-60) och formeln blir sålunda: 0 + 21 (Beställningspunkt tillika önskad lagernivå) – -60 (Saldo innanför ledtiden) – 0 (reserverat utanför ledtiden). 0+21-(-60)-0=81 QED.

Övningsexempel

Syfte

För att göra lite fler exempel och för att få Dig att öva lite vill jag att Du lägger upp produkter med det grunddata som jag beskriver nedan och kör exemplet och är beredd att tala om vad Du får för resultat. Varje uppgift utförs på egen hand och sedan går vi igenom den gemensamt efteråt.

Exempel 1

En produkt med flera möjliga leverantörer. När får vi tillslag på vilken?
Lägg upp en produkt med två olika leveransalternativ. Sätt den ”normala” leverantörens Lev.tid till 10 dagar och den andras till 12 dagar. Minska sedan priset för den med 12 dagar.
Skapa en order med behov vid olika tider. Gör ett beställnings-förslag enligt beställningspunkt och kontrollera vilken leverantör som välj om vi tar bort krysset för att välja normal leverantör.

Exempel 2

Produkten skall köpas in i dussin och säljas i styck.
Lägg upp en produkt med 2+7+5 dagars leveranstid (Adm, Lev, Transp.tid).
Låt den kosta 200 kronor och med leveransalternativ från leverantören 60606060.
Skapa order som underlag och gör ett beställningsförslag.

Uppgift 1

Inlämningsuppgift

Syftet med uppgiften är tvådelad. Å den ena sidan vill vi kontrollera hur Du angriper ett logiskt problem. Å den andra sidan vill vi kontrollera vad Du gör med uppgifter som är oklara och kräver egen tanke. Steg 3 kursen är den sista chansen för oss på Visma att forma det vi vill att Du skall vara; en utomordentlig partner som har svar på det mesta och som finner en utmaning i obesvarade frågor. När nästa stycke börjar skall Du läsa noggrant och analysera det som står. Uppgiften tar förmodligen inte mer än en kvart att göra, en timme att dokumentera och resten av tiden får Du rast.

Sivrac har fått in en ny produkt som Du skall hjälpa till att lägga upp i Produktregister mm. Det är cykelhjälmen ”Betongkeps”. Denna cykelhjälm är förpackad i en pappkartong och kostar 75 kronor. Den kostar 250:- i butik. Den köps av Back-pack AB. I butiken finns det en avsevärd skyltning som kräver ett 15-tal hjälmar för att det inte skall se tomt ut. Ytterligare 5 hjälmar har man som ”Prov-hjälmar”. Om det kniper så säljer man proverna också. Varje hjälm är förpackad i en låda som är 35*29*23 cm. En lastpall är c:a 1,2x0,8 meter. Det ryms 6 på höjden på varje pall. I Sivracs lager finns det ett rum där hjälmarna förvaras. Utrymmet som är tilldelat hjälmen är c:a 3*4 meter. Det säljs 40 hjälmar på tre dagar under sommaren och under en vecka alldeles innan tjejtrampet sålde man 225 hjälmar. Det var hektiskt. Leverantören, som levererar även annat, har en genomsnittstid för leveranser på 3 veckor. Hjälmar tar Back-pack AB från ett lager i närheten och det tar c:a 1 vecka från det att vi beställer till det att får hem dem. Leverantören har en egenhet och det är att han alltid vill ha alla beställningar på jämna dussin. Det är en gammal vana säger han, eftersom han är Gross-handlare. Eftersom Back-pack säljer en massa olika saker med olika leveranstider vill vi att när vi tar ut ett beställningsförslag till Back-pack att vi bara skall behöva köra igenom produktlistan en gång. Vi kan kompletteringsköpa från Wheel in Sweden AB, men han har en leveranstid på 10 dagar.

Uppgifter att redovisa:

  • Rekommendera en beställningsmetod
  • Priser, leveransalternativ och produktupplägg.
  • Parametrar som stödjer din rekommenderade beställningsmetod. Ex.vis Bp, max- och minlager. (och andra typer av parametrar)
  • Gör ett exempel på beställningsförslag med en enkel instruktion om hur det skall hanteras i Visma Business.
  • För att bli godkänd på det här delmomentet krävs en korrekt motiverad och med i övrigt korrekta parametrar satta produkt. Det skall hänga ihop från början till slut och alla antaganden som Du har gjort skall Du motivera. Kom ihåg att detta är en rak enkel uppgift som inte kräver mer än att Du följt med under veckan.


Feil eller manglende informasjon på kopi fra Ordredokumenter

For å hindre at formularer knyttet til Dokumentarkiv blir endret, må det i Systemopplysninger, Systemoppl.behandl. settes hake i ”Hindre redigering av formular på ordredokumentkopi”.

For å se hvilke formularlinjer som er knyttet til ordredokumentet kan du koble tabellen Ordredokumentformler til tabellen Ordredokumenter.

I Ordredokumentformler ligger det henvisning til linjenummer i tabellen Formularelementer. Dersom formularelementer for formularet er endret etter at ordredokumentet er opprettet, kan det være informasjon som blir utelatt ved utskrift av kopi. Dette på grunn av at henvisning fra Ordredokumentformler ikke stemmer med Formularelementer for Formularet på Ordredokumentlinjen.

Hvordan rette formularet

Dersom det er gjort endringer på formularer som det er henvist til fra tabellen Ordredokumenter så må det lages nytt formular likt det opprinnelige (se tabellen Ordredokumentformler). Deretter må du legge inn riktig formularnummer i tabellen Ordredokumenter (kolonnen er ikke redigerbar i Visma Business slik at du må gjøre dette via Query Analyzer eller Visma Databaseviewer).


Dokumentkopier i Visma Business

Fra versjon 4.60 er det mulig å ta vare på kopier av ordredokumenter i egne tabeller, Ordredokumenter og Ordredokumentlinjer (Unntak: Etiketter og Ordreutskrift). I Bedriftsopplysninger, i feltet Dokumentkopier, velger du hvilke typer ordredokumenter det skal lages kopi av:

Det er laget et standard skjermbilde, Dokumentarkiv, som gir oversikt over alle typer dokumenter:

Denne rutinen for ordredokumentkopier benytter ikke Visma Business Fax/Mail, og det dannes derfor heller ingen tif-filer. Du har derfor i realiteten ingen muligheter for å sende en kopi på mail.

Det er heller ikke mulig å skrive ut en kopi til en annen printer enn den originalen gikk til, hvis utskriftsoppsettet er lagret med en spesiell printer.

Ordredokumentkopi med gruppering av ordrer på samlefaktura

  • Hvis det er krysset av for ”Gruppering pr. ordre” i ordredokumentdialogen ved utskrift av samlefakturaer, og du tar vare på ordredokumentkopier legger programmet inn første rad i tabellen Ordredokumenter for hver ordre, med referanse i kolonnen ”Hovedordredok.nr” til linjen for selve ordredokumentet, og refererer ordredokumentlinjene til ordredokumentlinjen for ordren som de er gruppert under.
  • Feltene for dokumenttype, dokumentdato, formularnummer, oppsettnummer og sideelementnummer vil bare være utfylt på raden til dokumentet.
  • I dialogen til feltet ”Ordredokumentbehandl.”, i ordrehodet, på raden til dokumentet vil det være krysset av for ”Gruppering pr. ordre”.
  • Ved utskrift av ordredokumentkopier, hopper programmet over linjer hvor hovedordredokumentnummer er utfylt.
  • Det er tilstrekkelig å markere raden med avkrysningen for ”Gruppering pr. ordre”, for å få ut kopier av samlefakturaer med linjer gruppert pr. ordre.
  • Når programmet legger til rader i tabellen Ordredokumenter, i bedriftsdatabasene, blir det samtidig satt et flagg på formularet og oppsettet, i systemdatabasen, for at de er med på ordredokumenter.
  • I tabellen Formularer er dette flagget med bitverdien 16 i kolonnen ”Grafisk red. flagg”, og i oppsett-tabellen flagget med bitverdien 16 i kolonnen ”Vindusflagg”.
  • Ved lagring av et vindusoppsett, undersøker programmet om flagget er på oppsett-raden. I så fall får du spørsmål om du likevel ønsker å endre oppsettet.
  • Når du starter redigering av et ordredokumentformular (formulartype 6) i tabellene med formularer eller formularelementer, eller grafisk med behandlingsmenyvalget ”Grafisk redigering” i formulartabellen, blir det gitt en feilmelding på statuslinjen dersom flagget er på formularraden og det er krysset av for ”Hindre redigering av formular på ordredokumentkopi” i dialogen til feltet ”Systemoppl.behandl.” i tabellen Systemopplysninger.

Det er allikevel åpnet for å redigere utskriftsoppsettet for ordredokumentet. Dette fordi du skal ha mulighet til å f. eks. endre printer. Vær derfor oppmerksom på at hvis du gjør endringer ifht hvilke kolonner som skal vises på fakturaen fra ordrelinjene, så vil også kopiene du skriver fra Dokumentarkivet få ”nytt oppsett”, og er dermed ikke lenger en kopi av orginalen som kunden har mottatt.


Eksport av fakturajournal pr. dag/uke/mnd

Mange eksporterer fakturagrunnlaget fra Visma Business. Dette gjør du med utgangspunkt i tabellen ”Oppdaterte bunter”.

Alle som har lisens kun med Faktura, vil automatisk få oppdatert fakturaene slik at de havner i ”Oppdaterte bunter”.

Du kan markere ønskede linjer i tabellen og velge menyvalget ”Eksportere bunt til fil...”, i dialogen som fremkommer legger du inn ønsket filnavn og stien der den skal legge seg:

Dersom du ønsker å lage en fil pr. dag/uke/mnd, kan du ta i bruk Kalenderfunksjonen.

Gå i Design og velg Fil – Inkluder, og velg Kalender. Kalenderen vil da legge seg i skjermbildet. Dersom du høyreklikker på tabellen ”Oppdaterte bunter” og velger ”Knytt til kalender”, så får du opp denne dialogen:

Velg ønsket dato (Endret dato, Reverseringsdato eller Valuteringsdato). I eksempelet har vi valgt ”Valuteringsdato”.

Marker nå ønsket dag, uke eller måned i Kalenderen og du vil se ”Oppdaterte bunter” endre seg. Velg Behandling – Eksporter bunt til fil...

Eksempel på ukejournal:

Her er det uke 36 som er markert...


Factoring

For å kunne fakturere via factoring må du i tabellen "Bedriftsopplysninger" registere hvilket kundenummer (”Factoring kunde”) factoringselskapet er opprettet på i tabellen "Aktører", og hvilken ID (”Factoring ID”) bedriften har fått tildelt fra factoringselskapet.

I tillegg ønsker factoringselskapene ofte særegne KID-nummer. Da kan du fylle ut feltet "KID factoring-sifre" i tabellen "Bedriftsopplysninger". Feltet definerer hvordan KID-kodene skal bli bygget opp ved factoring. Når det er krysset av for ”Factoring” i dialogboksen til "Ordredokumenter", vil KID-makroen benytte den definisjonen som er satt opp.

Ved oppslag i feltet "KID factoring-sifre" viser dialogboksen de makrofunksjonene som er tilgjengelige.

I tabellen "Aktører" må du registrere factoringselskapet som en kunde. Du må fylle ut disse feltene:

  • Kundenummer
  • Navn
  • Bankgiro, postgiro

Merk: Hvis du skal fakturere en kunde via factoring, må du registrere kundens factoringnummer hos factoringselskapet i feltet "Factoringnummer" i tabellen "Aktører".

Hvis factoringnummeret er utfylt på en kunde, vil Visma Business anta at ordrene skal gå via factoring.

Merk: For kunder som vanligvis blir fakturert via factoring, må du passe på å fjerne factoringnummeret hvis en ordre ikke skal gå via factoringselskapet.

Når du registrerer en ordre, blir feltet "Factoringnummer" fylt ut automatisk i tabellen "Ordre", hvis ordren skal gå via factoring. Feltet blir fylt ut når du fyller ut feltet "Faktureres kundenummer". Om du ønsker det, kan du overstyre denne verdien.

Ved utskrift av faktura / kreditnota, må du krysse av for factoring i dialogboksen "Utskrift" for å skrive ut factoringordrene. Det er bare ordre med utfylt factoringnummer, og som er klare for fakturering, som vil bli skrevet ut.

Hvis du ikke krysser av for factoring, vil kun de ordrene der "Factoringnummer-feltet" er tomt, bli skrevet ut.

Det blir som regel brukt et annet fakturaformular for fakturaer som blir betalt via factoring. Det vil vanligvis stå på fakturaen at den er overdratt til factoringselskapet, og at betalinger skal skje til dette firmaet.

Factoringtransaksjoner til ASCII fil

Merk: Du må ha tilgang til tabellen "Åpen postliste kunder" for å kunne kjøre denne rutinen. Du må også oppprette Factoringselskapet i tabellen

Factoringselskap: (Felles – Regnskap – Kundereskontro)

Ved fakturering på factoringkunder kan du legge opplysningene ut til ASCII fil. Dette gjør du under "Åpen postliste kunder". Der velger du "Behandling / factoring" som leder til en dialogboks som inneholder:

· Importfil

· Factoringfil

· Avkrysningsfelt - "Genererer ny factoringfil på kjørenummer:"

Feltene "Importfil" og "Factoringfil" inneholder de filnavnene som du har satt opp i tabellen "Factoringselskap". Marker sjekkboksen "Generer ny factoringfil på kjørenummer" hvis du ønsker ny factoringfil generert på et gammelt kjørenummer. Kjørenummeret henter du fram i nedtrekkslisten under sjekkboksen.

I importfilen, som blir produsert ved generering av factoringfil, kan du legge ut felter fra tabellene kundetransaksjoner, ordrehode, produkttransaksjoner, aktører, valuta, betalingsbetingelser og bedriftsopplysninger.

Postene som du sender til factoringselskapet velger du via utvalg / søk / markering av rader. For at Visma Business skal godta valget må:

  • kundenummer på den åpne posten være det samme som i feltet "Factoringkunde" i bedriftsopplysninger
  • sjekkboksen "factoring utført" i dialogen til feltet "Transaksjonsstatus" være blankt

Sistnevnte vil Visma Business automatisk krysse av etter at rutinen er utført.

I reskontroen blir kundetransaksjonene ført på factoringselskapet i stedet for på den enkelte kundereskontro. Statistikkdata blir spesifisert for den enkelte fakturamottaker.

Nyttige felt for factoring i tabellene "Åpen postliste kunder" og "Kontoutskrift kunder / kundetransaksjoner"

  • Transaksjonsstatus – i dialogboksen til dette feltet setter Visma Business automatisk kryss i feltet "factoring utført" etter at du har kjørt rutinen. Sjekkboksen blir visualisert i feltet med status 8. Med dette kan du på en enkel måte holde oversikt over hvilke fakturaer som har gått gjennom factoringrutinen.
  • Factoringkjørenummer – dette feltet viser tildelt kjørenummer etter factoringrutinen.

Merk: Det er vanlig å sende kunder som er opprettet/endret siden forrige gang med som egen fil til factoringselskapet. (Er det nye kunder i de fakturatransene vi sender over i factoringfilen, må factoringselskapet opprette disse i sitt system før de leser inn factoringfilen fra oss). Vi har ikke rutine for å skrive ut endrede/nye kunder siden forrige remitering.


Factoring i Visma Business

Factoring i Visma Business fra versjon 4.60.3 eller nyere

Aktører

(Tabeller – Felles – Aktører)

I tabellen Aktører må du opprette factoringselskapet som en kunde:

I vårt eksempel så er dette kundenr. 10014.

Alle kunder som skal faktureres via Factoringselskapet AS, må ha en verdi i feltet ”Factoringnr.”. Verdien i dette feltet anbefaler vi at er kunden sitt kundenummer hos factoringselskapet.

Merk: I feltet ”Fact.selsk.nr/KID-def.” MÅ du knytte en kunde opp mot et valgt Factoringselskap/KID-def..

Factoringselskap og KID def

(Tabeller – Regnskap – Faste opplysninger)

I denne tabellen legger du inn opplysninger om factoringselskapet. Her kan du legge inn flere factoringselskap.

Feltet ”Fact.behandling” à Siden denne tabellen kan benyttes til flere forskjellige formål (OCR, Inkasso…) kan du dette feltet angi at dette gjelder ”Factoringselskap”.

Bedriftsopplysninger

Det eneste du skal behøve å legge inn i denne tabellen som omhandler Factoring, er

”Std. Factoringselskap/KID-kode def.”. Her gjør du oppslag og velger ønsket factoringselskap.

Merk: Dersom det skal kjøres ut ”vanlig” fakturering, må verdien i feltet ”Std.factoringselskap/KID.kode def.” fjernes.

På grunn av en feil vi har i versjon 4.60.3, så må også feltet ”FactoringID” angis i denne tabellen, dersom den skal være med i KID koden. Dette vil bli rettet, slik at også dette feltet skal registreres i tabellen ”Factoringselskap og KID def.”.

Flere factoringselskap

Dersom du har flere factoringselskap liggende i tabellen ”Factoringselskap og KID def”, henter den ”Std.factoringselskap/KID-kode def.” i fra tabellen ”Bedriftsopplysninger”.

Selv om du har ulike oppsett liggende på Aktøren, så er det verdien i Bedriftsopplysninger som blir hentet.

Husk å angi riktig ”Factoring/KID def.” under fanen Varianter i utskriftsdialogen.

Fakturering

Ved fakturering må du under fanen ”Varianter” i utskriftsdialogen, under fanen Varianter angi at denne faktureringen skal til factoring.

Den vil automatisk foreslå ”1. DnB Factoring AS” siden det er dette som er angitt i Bedriftsopplysninger i feltet ”Std. Faktoringselskap/KID-kode def.”, men du må sette hake i ”Factoring/KID-kode def.”


Avvikende faktureringsadresse

Definisjon

Hvordan legge opp rutine for de som har behov for annen faktureringsadresse enn det som er kundens adresse. Normalt legges dette opp ved at bruker legger inn faktureres adressen i stedet for kundens egentlige adresse på kunden og for eksempel adresse 4 til c/o adresse. Dette er uheldig hvis vi ønsker å ta vare på kundens egentlige adresse for all annen korrespondanse enn faktura.

Eksempel på behov

Kunde 10001 ”Alt i gaver og utstyr AS” skal faktureres kunde 10002 ” Fjell & Sønn ANS” men fakturaen skal ikke sendes kunde 10002, men til regnskapskontoret til 10002 som heter ”Totaløkonomi for alle”. Reskontroføringen skal skje mot 10002.

Kunde 10003 ”Snekkerbua ANS” sine fakturaer skal sendes til regnskapskontoret ”Totaløkonomi for alle” men reskontroføres kunde 10003.

Utfordring

Visma mangler en kolonne for ”Faktureres aktørnummer” som skal være fakturaadressen til en kunde på samme måte som ”Utleveres aktørnummer”.

Generelt kan benyttes ”Utleveres aktørnr.” og angitt aktørnummeret til faktureringsadressen på de kundene som har annen fakturaadresse siden denne verdien blir arvet til ordren samtidig som dette må bli presentert på fakturaen i stedet for ”Faktureres kundenr” sitt navn, adresse1, adresse2 og postnr/sted.

Utfordringen skjer hvis kunden har ”Faktureres kundenr.” fra før, dvs. at den skal reskontroføres en annen enn den selv. Da vil kundens ”Utleveres til aktørnr” bli presentert på ordren og ikke ”Faktureres kundenr.” sin ”Utleveres til aktørnr.”.

”Faktureres kundenr.” må ikke ha noen verdi i feltet ”Utleveres til aktørnr”.

Forutsetninger

Kolonnen ”Utleveres til aktørnr.” i aktørtabellen må ikke benyttes til det den er tenkt til, dvs. leveringsadresse, men til fakturaadresse.

Kolonnen ”Leveres aktørnummer” i ordretabellen må ikke benyttes til det den er tenkt til, dvs. leveringsadresse, men til fakturaadresse.

(Leveres aktørnummer på ordren må ikke overstyres på ordren hvis ”Kundenummer” avviker fra ”Faktureres kundenr.”.)

Forslag til løsning 1

I aktørtabellen

Figur 1 Eksempel på hvordan det settes opp i aktørtabellen

  • Kunde 10000 reskontroføres mot seg selv og sin egen adresse.
  • Kunde 10001 reskontroføres mot kunde 10002 som igjen har en egen fakturaadresse mot aktørnummer. 75
  • Kunde 10003 reskontroføres mot seg selv, men har egen fakturaadresse mot aktørnummer. 75.
  • Kunde 10004 reskontroføres mot kunde 10005 som igjen benytter sin egen adresse.

På formularet

Sette opp et formular hvor leveres aktørnummer kommer ut som fakturaadresse.

For å fange opp de tilfellene hvor faktureres kundenummer har egen avvikende fakturaadresse må det legges inn en ”IF”-setning.

Figur 2 Eksempel på IF-setning til fakturaadresse.

Elementtype 7 = IF
Elementtype 8 = ELSEIF
Elementtype 9 = ELSE
Elementtype 10 = ENDIF

Spørringen er:

IF

faktureres kundenummer er ulik kundenummer og har en annen fakturaadresse, dvs. at ”utleveres til aktørnr” er større enn 0 skal denne presenteres.

ELSEIF

bare faktureres kundenummer er ulik kundenummer men faktureres kundenummer IKKE har annen fakturaadresse, skal faktureres kundenummer sin adresse presenteres

ELSE

presenter leveres adressen til ordren. Dvs. hvis kundenummer og faktureres kundenummer er likt. Denne vil alltid bli foreslått fra kunden ved opprettelse.

ENDIF

Hvis denne metoden benyttes bør det for ordens skyld fremkomme hvilken kunde fakturaen egentlig går mot etc. Denne ”gjelder kunde….” teksten bør bare presenteres hvis en av IF-setningene kommer til anvendelse og kan legges inn i den samme spørringen med tilhørende x og y verdier for hvor makroverdien skal presenteres.

Resultatet av formularet over gir oss følgende fakturaprinter:

Figur 3 Faktura for en som faktureres egen adresse

Figur 4 Faktura hvor kunde 10001 reskontroføres mot kunde 10002 som igjen har en egen fakturaadresse

Figur 5 Faktura hvor kunde 10003 reskontroføres mot seg selv, men har egen fakturaadresse mot aktørnummer.

Figur 6 Kunde 10004 reskontroføres mot kunde 10005 som igjen benytter sin egen fakturaadresse.

Forslag til løsning 2

Leveringsadresse

Alternativt kan Leveringsadressetabellen komme til anvendelse. Dette i de tilfeller hvor fakturaadressen ikke er permanent på kunden, men varierer innenfor gitte (faktureres)aktørnummer pr. kunde. Dette løses ved at du kobler til leveringsadressetabellen fra ”Ordre”-tabellen” med ”Faktureres kundenr.” som fremmed nøkkel.

Hvis faktureringsadressen varierer hver gang kan dette legges inn på ordren som leveringsadresse ved oppslag i kolonnen ”Leveres aktørnummer” under registrering. Det er da ikke behov for IF-setninger i formularet, men bare skrive ut leveringsadresse-makroen fra ordren.


Fakturamottak

Formål: Fakturamottak med attestasjon og mulighet for kontroll av det som er bestilt mot det mottatte på faktura.

Forutsetninger

Bokføringstilfeller

Krysset for bokføring av fakturamottak tas vekk. Grunnen til dette er fordi bilagsbunten blir registrert manuelt eller ved hjelp av dokumentsenter.

Trigger

Følgende trigger må legges inn i ordretabellen for å oppdatere hovedordrenummer på innkjøpsordren.

CREATE TRIGGER main_order_no ON [dbo].[Ord]
FOR INSERT
AS update ord
set mainord = ord.ordno from inserted where ord.ordno = inserted.ordno

Årsaken til at du må benytte en trigger er at det ikke finnes en kobling mellom ordrenummer på bilagslinjen og ordrehodet. For å skape koblingen kopieres ordrenummer til hovedordrenummer. Denne koblingen er ønskelig for å muliggjøre kontroll mellom det bestilte og det mottatte.

Eksempel 1 med Dokumentsenter

Registrering av innkjøpsordre

Hovedordrenummer blir satt = ordrenummer. Varene ankommer lager og varemottak foretas.

Alle varene ankommer i sin helhet.

Lagersaldoen viser at disse varene er ankommet.

Fakturaen mottas og skannes inn i dokumentsenter. Denne påføres regnskapsdata og sendes på flyt til respektive ansatte:

Merk: Vi har bedt vår leverandør påføre vårt ordrenummer slik at dette kan tastes ved registrering av fakturaen ved ankomst.

Legger inn ordrenummer = 424 siden dette er påført som rekvisisjonsnummer.

Når fakturaen er ferdig behandlet i dokumentsenter, skal vi bokføre den endelige fakturaen.

Vi ser her at prisen er endret fra vi registrerte vår bestilling.

Oppdaterer pris på ordren slik at korrekte verdier blir oppdatert til lagersaldo og produkttransaksjoner.

Registrerer samtidig det antallet som er fakturamottatt i feltet ”Fakt NÅ”. Som vi nå kan se er Beløp eks mva = Fakt. Beløp eks mva. (Beløp eks mva er en beregnet kolonne i tabellen bilag (@Kolonne (Beløp)-@Kolonne (Mva-beløp)). Når vi nå lagrer så er lagersaldo og produkttransaksjoner oppdatert og vi kan oppdatere den bilagsbunten som er behandlet i Dokumentsenter.

Vi ser at lagersaldoen er oppdatert korrekt.

Eksempel 2 med Forhåndsregistrering/attestasjon
Registrering av innkjøpsordre

Hovedordrenummer blir satt = ordrenummer. Varene ankommer lager og varemottak foretas.

Som vi ser så er det kun ankommet 25 av produktet ”33 Hammer” og 15 av produktet ”34 Sag”

Lagersaldoen viser at disse varene er ankommet.

Fakturaen mottas og den er på 4991,- inklusiv MVA

Fakturaen kommer tilbake ferdig attestert uten kommentarer.

Registrerer ordrenr 426 i kolonnen ordrenr. Da hentes denne ordren frem i skillearket ordre.

Prisen er endret i forhold til vår opprinnelige bestilling fakturaen er på:

33 | hammer | 25 stk | 80,-
34 | Sag | 15 stk | 135,-

Oppdaterer pris på ordren slik at korrekte verdier blir oppdatert til lagersaldo og produkttransaksjoner.

Registrerer samtidig det antall som er fakturamottatt i feltet ”Fakt NÅ”. Som vi kan se så er Beløp eks mva = Fakt. Beløp eks mva. (Beløp eks mva er en beregnet kolonne i tabellen bilag (@Kolonne (Beløp)-@Kolonne (Mva-beløp)). Når vi nå lagrer så er lagersaldo og produkttransaksjoner oppdatert og vi kan oppdatere den bilagsbunten som er behandlet i Dokumentsenter.

Lagersaldoen er oppdatert korrekt.

Bunten kan oppdateres.

Når de resterende varene/faktura ankommer så følger vi samme rutine.

Last ned skjermbilde for Bilagsregistrering

Last ned skjermbilde for Forhåndsreg./Attestasjonr

Importer til Vbsys med ”Legg bare til nye rader”.


Fakturering av avgiftsfritt salg fra ordre

Fakturering av avgiftsfritt salg fra ordre.

Ut fra spørsmålene vi får er det mange som tror det holder å legge inn område 1,2 eller 3 for å få avgiftsfritt på ordren. Det er ikke tilstrekklig.

Hvis du kun legger område lik avgiftsfritt i ordrehode, blir fakturaen avgiftsfri, men på bunten som blir dannet blir det lagt på mva både på reskontro og salgskonto (fri). For å få riktig behandling kan følgende alternativ benyttes.

Alternativ 1:

I feltet ”Avg.kode kunde” må du legge inn avgiftskode” 4. Avgiftsfritt salg”.

Alternativ 2:

Opprett en avgifts-og bokføringsgruppe for fritt salg med avgiftskode salg lik 4 som i skjermbildet under. Legg denne avg.bokf gruppen på de produktene det er aktuelt å selge til ”avgiftsfrie” kunder. (evt opprett en avg.bokf.gr. som er lik den du i dag har standard med avg.k.salg lik 4, men endr kontosett. Da slipper du å endre på alle produkter)

Slik det står nå, får i utgangspunktet alle kunder denne avgiftskoden. For å avgrense det til å gjelde kunder som er avgiftsfrie må du opprette et kontosett slik at alle kunder som skal ha avgiftsfri faktura legges i dette kontosettet.


Fakturering av forsikringsoppgjør

Når forsikringstaker er MVA pliktig skal netto verdien av forsikringssaken faktureres forsikringsselskap og MVA faktureres forsikringstaker. Dette pga at forsikringsselskap ikke er MVA pliktige.

Under følger forslag til hvordan dette kan løses i Visma Business. Dette forutsetter Visma Business versjon 4.60.

Opprett to nye avgiftskoder

Opprett avgifts- og bokføringsopplysninger som vist under

Eksempel på Avgifts- og bokføringsopplysninger for produkter for forsikringsoppgjør.

Eksempel på Avgifts- og bokføringsopplysninger for produkt for MVA.

Produkter

På produkter som benyttes i forbindelse med forsikringsoppgjør må du overstyre Avgifts- og bokføringsopplysninger til koden som er opprettet for dette. Du må opprette eget produkt for MVA forikringsoppgjør. Dette er produktet du skal bruke ved fakturering av MVA i forbindelse med forsikringssaken.

Formular for Omsetningsoppgave (MVA oppgave)

I formularet for Omsetningsoppgave må du gjøre en endring i post 4. Legg til AvgPliktigSalg(5) i grunnlag. Se redigeringslinjen i eksemplet under:


Faktureringsplan med avregning

I tillegg til løpende ordreregistrering og fakturering, har du i Visma Business mulighet for à konto-fakturering med etterfølgende avregning. Et eksempel på bruk av faktureringsplan med avregning kan være forskuddsbetaling av håndverksarbeid.

Faktureringsplanen legger du inn som en vanlig ordre, der verdien i feltet "Faktureres i henhold til plan" settes til ”1. A konto/avregning”.

Figur 1 Ajourhold av faktureringsplan

Produktene som benyttes må være unntatt lagerhåndtering. Faktureringsplan – linjer blir ikke behandlet lagermessig, og kvalifiserer for fakturering uten ferdigmelding.

Ved utskrift av fastpris eller à kontofakturaer kan du krysse av i dialogboksen "Ordredokumenter" for at fakturadatoen skal hentes fra plandatoen (transaksjonsdatoen) på faktureringsplan-linjene. Da vil det bli produsert en faktura pr. plandato på faktureringsplan-linjene, slik at en ordre kan bli splittet i flere fakturaer.

Det antall faktureringsplanlinjer som kommer ut styres av transaksjonsdatoen. De datoene som faller tidligere eller lik datoen i ”Ordredokumenter” vil bli behandlet.

I vårt tilfelle skrives det ut to fakturaer med fakturadato lik transdato fra linjene. Etter fakturering endres plantype fra 1(A konto) til 5(Faktuert à konto).

Ved avregning pr 15.07.2004 legger man inn en avregningslinje (plantype 4) slik at fakturaen blir fratrukket det som tidligere er fakturert. På avregningslinjen registrerer man bare avregningsdatoen i feltet ”Transdato” og plantype 4 (Avregning). De tidligere à konto-føringene finner Visma Business på faktureringsplanlinjer med plantype 5(Faktuert à konto), og disse må ikke slettes eller modifiseres før de er avregnet. I tillegg legger man inn en ny ordrelinje med de virkelige kostnadene (husk at denne linjen må ferdigmeldes).

Figur 2 Oppsett for avregning før ferdigmelding av avregningslinje

Dette gir følgende avregningsfaktura:

Figur 3 Avregningsfaktura

I dette tilfellet ble det en Kreditnota siden avregnet beløp var mindre enn à kontobeløp.


Forslag til nytt utvalg på Salgsordrevindu

Forslag til nytt utvalg på salgsordrevinduet:

Det utvalget som finnes i dag tar ikke hensyn til restordre. Altså, hvis man har en restordre liggende og ønsker å se på den eller gjøre endringer, får man ikke den fram med dette utvalget. Dette vil også ta med restordre:

Forklaring til de tre ordrestatusene:

1. Bits AV 1024 = Utvalget skal vise ordre som IKKE er fakturert.

2. Eller bits PÅ 1025 = Utvalget skal vise ordre som er klar for fakturering

3. Eller bits PÅ 256 = Uvalget skal vise ordre som er klar for ferdigmelding


Fraktfordeling

Frakt/kostnadsfordeling på ordrelinjer ved innkjøp

Fra versjon 5.20 er det mulig å få frakt eller andre kostnader fordelt automatisk på ordrelinjene i en innkjøpsordre. Dette kan fordeles ut fra enten beløp, volum, vekt eller antall. Slik kan dette legges til på ordren:

I ordrehodet henter du frem feltene ”Fraktbeh.” og ”Kostprispåslag (kr)”:

Ved oppslag i ”Fraktbeh.” vil du se en dialog der du kan velge hvilken metode du ønsker å benytte for å fordele kostnaden:

Ved ”Beløp” vil kostnaden fordele seg i forhold til hver enkelt ordrelinjes verdi, ”Nettovekt”, ”Bruttovekt” og ”Volum” fordeler kostnaden utifra vekt og volum registrert på produktet, i kombinasjon med antallet på ordrelinjen, mens ”Antall” vil fordele kostnaden utifra antallet på ordrelinjen, i forhold til det totale antallet på ordren.

Når du har valgt fordelingsmetode, fordeler du kostnaden ved å legge inn denne i feltet ”Kostprispåslag (kr)”. Legg merke til at denne vil fordele seg i feltet ”Kostpris” på ordrelinjene, men først etter at varemottak er foretatt.

I bildet under er ordren ferdigmeldt, men kostnaden er ikke fordelt:

Så fordeler vi en kostnad på 300 i forhold til antall:

En mer sannsynlig fordeling i dette tilfellet er i forhold til beløp. Dersom ”Fraktbeh.” endres til å ta hensyn til beløp i stedet for antall, blir resultatet slik:

En fordeling av fraktkostnad på denne måten vil påvirke kostprisen på varepartiene først etter at fakturamottak er gjennomført.
Denne rutinen påvirker ikke det totale beløpet som betales leverandøren, dette må beregnes på innkjøpet på samme måte som tidligere.


Generere kopi av ordre

Generer kopi av ordre

Med menyvalget Behandling/Generer kopi av ordre kan du på en enkel måte kopiere en ordre med Transaksjonstype 1-6, og Ordretypene 1, 2 og 5-8.

Dersom du ikke overstyrer noen felter i dialogen, vil en kopi av ordren opprettes med dato fra dialogen, og ellers ta med verdier fra opprinnelig ordre. NB! Felter som ikke tas med ved kopiering:

  • Kontaktperson

  • Deres ref (hentes fra aktør)

  • Merket

  • Ordrepref (hentes alltid fra aktør)

  • Lagernr (hentes fra aktør)

  • Avg.kode

  • Selger/innkjøper

  • Valutanr (hentes fra aktør/bedriftsopplysninger)

  • Valutakurs (hentes fra valuta/valutakurs)

Kundenummer: Dersom dette feltet står tomt, vil kundenummeret fra opprinnelig ordre kopieres til den nye. Dette gjelder transaksjonstyper der kundenummer er i bruk.

Lag kreditnota: Dette valget er tilgjengelig ved kopiering av fakturerte ordre. Det er ikke tilgjengelig for innkjøpsordre.

Priser fra pris og rabattmatrise: Kryss av her for å hente priser på nytt fra pris og rabattmatrisen. Dersom produktet ikke finnes her, beholdes verdien fra opprinnelig ordre.

Kopier ansv. enh. fra kunder: For å hente ansvarsenheter på nytt fra valgt kunde.


Generere kreditnota

Generering av kreditnota fra faktura

1. Generere kreditnota fra en faktura

I bedriftsopplysninger finnes det et felt som heter "Fakt. ref. behandl.".

Ved å dobbeltklikke her får du opp 2 alternativer:

  1. Presentere orginallinjer

  2. Presentere orginallinjer 2 ganger (-/+)

Ved å legge inn valg nr. 1 ”Presentere orginallinjer” skjer følgende:

- La oss si du har fakturert og har fakturanr. 1000226

Denne fakturaen skal krediteres og du registrerer en kreditnota.

I feltet "Fakturareferranse" i ordrehodet legger du inn fakturanr. 1000226. Når du nå trykker Enter, så ser du at kreditnotaen blir laget med utgangspunkt i fakturanr. 1000226.

Alt som legger seg i Ordrelinjer blir fylt ut automatisk med utgangspunkt i fakturaen.

Ved å legge inn valg nr. 2 ”Presentere orginallinjer 2 ganger (-/+)skjer dette:

Du registrerer en ordre, ikke legg inn kreditnota som ordrepref., men legg inn fakturanummer i fakturareferranse i ordrehodet. Ved å taste enter nå, så får du først opp en linje som er krediteringen og deretter en linje som presenterer slik det skulle ha vært.....!

Det betyr at den først krediterer den fakturaen som i utgangspunktet er feil og i tillegg så foreslås en ny ordrelinje med mulighet for endring J


Historisk lagerverdi

Dette dokumentet beskriver hvordan Visma Business kan settes opp for å kunne produsere en rapport som viser den historiske lagerverdien.

Forutsetninger

For å løse dette så er det tatt i bruk et ”view” på tabellen Produkttransaksjoner. Dette ”viewet” gjøres synlig i Visma Business i tabellen Fri informasjon 1. Dette viewet legges inn i de aktuelle databasene ved hjelp av et skript som kjøres i Microsoft Query Analyzer eller Visma sin egen ”Database viewer”. Dette skriptet kan tilpasses til den enkelte installasjon. Vedlagte skript er tilpasset versjon 4.60.x

Start f. eks Microsoft Query Analyzer, velg aktuell database, hent opp skriptet og kjør skriptet

Last ned viewet her

Dette viewet henter data fra Produkttransaksjoner. Alle transaksjoner som ikke er unntatt fra lagerhåndtering hentes inn.

Det er en forutsening at feltet ”Realisert År/periode” er utfylt på transaksjonen. Dersom feltet ikke er oppdatert så kan du kjøre vedlagte SQL skript, på samme måte som skriptet ovenfor.

Last ned SQL skript her

Det er tilpasset et skjermbilde for dette. Dokumentasjon følger nedenfor. Dette skjermbilde importeres til systemdatabasen med legg bare til nye rader

Last ned Vindu her

For at dette skjermbild skal fungere så må det i tillegg legges opp en variabel i tabellen ”Heltalls-systemvariabler”.

Last ned variabler her

Skjermbilde ”Historisk lagerverdi”

Selekter Til og med År/periode i dialogen øverst til høyre i skjermbildet. Syntaksen er: YYYYPP

Lagerliste

Utvalg på at ”Realisert år/periode <= Heltall-bedriftsvariabel (regnskap) [1]

Sortering på produktnr:

Det kan være ønskelig å sortere på avgifts og bokføringsgruppen i tillegg eller isteden for. Dette kan være enklere for sammenligning med regnskap.

Hensikten med dette skillearket er å kunne skrive ut en lagerverdi pr den perioden som er angitt i feltet ”Til og med år/periode” øverst til venstre i skjermbildet. Rapporten tar med seg alle transaksjoner som er ferdigmeldt. Det betyr at det er viktig at ”ikke bokførte transaksjoner”, ”korrigerte transaksjoner” og ”Avventer realisering” blir oppdatert slik at Hovedboken er mest mulig avstemmt med statistikken.

Derfor er det viktig at disse behandles under skillearkene for ”ikke bokførte transaksjoner”, ”korrigerte transaksjoner” og ”Avventer realisering”

Under skillearket ”regnskap” så gjøres det utvalg på de kontoer som de skal avstemmes mot. Ved import av skjermbildet så er resultatkonto for ”innkjøp av varer” og ”varekost ved salg” satt opp. Normalt så vil det ligge et utvalg på aktuelle balanse kontoer her.


Import av lagertelling

Dersom man teller lager med et eksternt system og deretter ønsker å importere resultatet til Visma Business, kan man få til dette ved at importen inkluderer følgende felter:

Dersom en lagertelling skal importeres til Visma Business, bør den dermed inkludere følgende:

@Begin_firm () Definerer klienten resultatet skal leses inn til
@Import_method (1) Importmetode: ”Overskriv oppgitte felter”
@StcBal (=prodno, =stcno, cntdf, cntby) Tabell og kolonner som importeres: StcBal=Lagersaldo, ProdNo=produktnr, StcNo=Lagernr, CntDf=Telt antall, CntBy=Telt av
"1001" "1" "13" "system" Verdier som importeres, i samme rekkefølge kolonnene er definert på forrige
"1002" "1" "20" "system" rad
@firm_end () Stopper jobben ved å vise til klienten

@Begin_firm og @Firm_end benyttes der importen er satt som en automatisk jobb. Dersom importen gjøres manuelt mot en spesifikk klient, er ikke disse linjene nødvendig.

Når dette er importert, vil det ligge verdier i ”Telt antall” på produktets lagersaldo. Dersom produktet allerede er overført til telling, kan fysisk beholdning korrigeres ved å velge ”Korrigér beholdninger” i behandlingsmenyen. Dersom det ikke er overført til telling, gjør dette via behandlingsmenyen, og kjør deretter ”Korrigér beholdninger”.

NB! Visma Business krever at alle de beskrevne feltene er tilstede for å kunne oppdatere fysisk beholdning. Har en rad for eksempel ”Telt antall” men mangler ”Telt av”, blir ikke de importerte verdiene tatt hensyn til ved ”Korrigér beholdninger”, selv om de ser ut til å være korrekt importert.


Innkjøpsordre

Hva skjer i hvilken tabell ved innkjøpsordre?

Hvilke felter oppdateres underveis i behandlingen av en standard innkjøpsordre, fra registrering til fakturamottak

Scenario 1:

Ordretype 1, transtype 6, ordrepref=0, behandlingsmåter=0, antall=1, pris (100) hentet fra pris og rabattmatrise, lager hentet fra produkt. Ordrehode og linje registrert før lagring.

Ved lagring:

Beløpsfelt satt til 100 og antallsfelt satt til 1 dersom annet ikke er nevnt.

Ordrehode: Fakt.beløp i fremtiden, Fakt.beløp totalt
Ordrelinje: Fakt.beløp i fremtiden, Fakt.beløp totalt, Opprinnelig antall, Bekreftet lev.dato (=ordredato)
Reservasjoner: Lagernr, Partinr, Antall, Kostpris (fra ordrelinje), Totalt antall, Transtype
Varepartier: Produktnr, Lagernr, Partinr, I tilgang, Reserverbart, Reserverbart mot tilgang, Kostpris (fra ordrelinje), Kostvalutanr, Kostvalutakurs, Ordrenr
Lagersaldoer: Produktnr, Reserverbart, Best.dato, Forv.ank.dato, Tilgang, Beh.inkl.endring, FIFO-pris, I bestilling, Lagernr, Netto beh.endring, Netto i bestilling, Siste FIFO pris, Reserverbart mot tilgang
Produkttransaksjoner: Transdato, Transtype, Produktnr, Ferdigmeldingsdato, I tilgang, Kostpris, Lagernr, Lev.nr, Opprinnelig antall, Ordrenr, Partinr, Pris, Standardpris, Valutanr, Valutakurs

Ved behandlingsmenyvalg ”Bekreftet”:

Ordrehode: Bekreftet lev.dato
Varepartier: Varepartistatus (bekreftet av leverandør)
Lagersaldoer: Bekreftet av lev.

Ved behandlingsmenyvalg ”Ferdigmeld”:

Ordrehode: Ferdigm.dato
Ordrelinje: Antall (0), Beløp (0), Ferdigmeldt, Ferdigm.dato, Pål. kostn. (0), Påløpt (0)
Reservasjoner: Antall (0), Ferdigmeldt
Varepartier: Fysisk beholdning, I tilgang (0), Urealisert lagerøkning, Fysisk lagerverdi, Reserverbart mot lager, Reserverbart mot tilgang (0), Opprettet dato
Lagersaldoer: Fysisk beholdning, Urealisert lagerøkning, Fysisk lagerverdi, I bestilling (0), Lagerverdi etter siste FIFO, Netto beh.endring, Netto i bestilling (0), Positiv fysisk beholdning, Positiv fysisk lagerverdi, Reserverbart mot lager, Reserverbart mot tilgang (0)
Produkttransaksjoner: Ferdigm.dato, I tilgang (0), Påløpt, Trans.status, Antall, Beløp

Lagret endring av pris på ordrelinje:
Ordrehode: Fakt.beløp i fremt., Fakt.beløp totalt
Ordrelinje: Kostpris, Fakt.beløp i fremtiden, Fakt.beløp totalt, Ordrelinjestatus (overstyrt pris)

Ved behandlingsmenyvalg ”Mottatt faktura”:

Beløpsfelt satt til 120 og antallsfelt satt til 1 dersom annet ikke er nevnt.

Ordrehode: Fakt.beløp i fremt.(0), Fakt.beløp totalt (0), Fakturanr
Ordrelinje: Fakt.beløp i fremt.(0), Fakt.beløp totalt (0), Fakturanr, Fakt/real.
Reservasjoner: Fakt/real, Kostpris, Fakturanr
Varepartier: Realisert beholdning, Kostpris, Mottatt, Mottatt beløp, Realisert lagerverdi
Lagersaldoer: Realisert beholdning, FIFO-pris, Fysisk lagerverdi, Lagerverdi etter siste FIFO, Siste FIFO-pris, Realisert lagerverdi
Produkttransaksjoner: Fakturadato, Fakturanr, Kostpris, Pris, Beløp, Trans.status

Scenario 2:

Som over, men antall = 2 med delvis ferdigmelding med pris = 100 (dvs beløpsfeltene ved lagring = 200), etterfulgt av ferdigmelding av rest og fakturamottak med pris = 120.

Ferdigmelding av 1 stk ved Ferdig NÅ:

Beløpsfelt satt til 100 og antallsfelt satt til 1 dersom annet ikke er nevnt.

Ordrehode: Ferdigmeldingsdato
Ordrelinje: Beløp, Ferdigmeldt, Pål.kostn., Påløpt
Reservasjoner: Splittet i to reservasjoner. RSV1: Antall , Totalt Antall. RSV2: Parti nr (2), Ferdigmeldt, Ferdigm.dato, Kostpris, Totalt antall
Varepartier: Splittet i to partier. Vareparti 1: I tilgang, Reserverbart, Reserverbart mot tilgang. Vareparti 2: Fysisk beholdning, Reserverbart, Urealisert lagerøkning, Fysisk lagerverdi, Kostpris
Lagersaldoer: Fysisk beholdning, Tilgang, Bekreftet av lev., Urealisert lagerøkn., Fysisk lagerverdi, I bestilling, Lagerverdi etter siste FIFO, Netto beh.endring, Netto i bestilling, Positiv fysisk beholdning, Positiv fysisk lagerverdi, Reserverbart mot lager, Reserverbart mot tilgang, Opprettet dato
Produkttransaksjoner: Splittet i to rader, begge med trans.nr 1. Opprinnelig rad: Ferdigm.dato, I tilgang. Ny rad: Kostpris, Opprinnelig antall (2), Partinr (2), Påløpt, Trans.status, Antall, Beløp

Ved behandlingsmenyvalg ”Mottatt faktura”:

Beløpsfelt satt til 100 og antallsfelt satt til 1 dersom annet ikke er nevnt.

Ordrehode: Fakt.beløp i fremt., Fakt.beløp totalt, Fakturadato, Fakturanr
Ordrelinje: Fakt.beløp i fremt. Fakt.beløp totalt, Fakt/real, Fakturanr, Urealisert antall
Reservasjoner: RSV 2: Fakt/real
Varepartier: Parti 2: Realisert beholdning, Mottatt, Realisert lagerverdi
Lagersaldoer: Realisert lagerverdi, Realisert beholdning
Produkttransaksjoner: Ny rad: Fakturanr, Fakturadato, Trans.status

Ferdigmelding, del 2:

Beløpsfelt satt til 100 og antallsfelt satt til 1 dersom annet ikke er nevnt.

Ordrelinje: Antall (0), Beløp (0), Ferdigmeldt (2)
Reservasjoner: RSV 1: Ferdigmeldt
Varepartier: Parti 1: Fysisk beholdning, Urealisert lagerøkning, Fysisk lagerverdi, Reserverbart mot lager, Reserverbart mot tilgang (0)
Lagersaldoer: Fysisk beholdning (2), Tilgang (0), Urealisert lagerøkning, Beh.inkl.endring (2), Fysisk lagerverdi (200)
Produkttransaksjoner: Opprinnelig rad: Ferdigm.dato, Påløpt, Trans.status, Antall

Lagret endring av pris på ordrelinje:

Beløpsfelt satt til 120 dersom annet ikke er nevnt.

Ordrehode: Faktbeløp i fremt., Fakt.beløp totalt
Ordrelinje: Kostpris, Pris, Fakt.beløp i fremt., Fakt.beløp totalt, Ordrelinjestatus

Ved behandlingsmenyvalg ”Mottatt faktura”:

Beløpsfelt satt til 120 og antallsfelt satt til 1 dersom annet ikke er nevnt.

Ordrehode: Fakt.beløp i fremt.(0), Fakt.beløp totalt(0), Fakturadato, Fakturanr
Ordrelinje: Fakt.beløp i fremt. (0), Fakt.beløp totalt (0), Fakt/real (2), Fakturanr, Urealisert antall (0)
Reservasjoner: RSV1: Fakt/real, Kostpris, Fakturanr
Varepartier: Realisert beholdning, Urealisert lagerøkning (0), Kostpris, Fysisk lagerverdi, Mottatt, Mottatt beløp, Realisert lagerverdi
Lagersaldo: Realisert beholdning (2), Urealisert lagerøkning (0), FIFO-pris (110), Fysisk lagerverdi (220), Realisert lagerverdi (220), Lagerverdi etter siste FIFO (240), Positiv fysisk lagerverdi (220), Siste FIFO-pris, Realisert lagerverdi (220)
Produkttransaksjoner: Fakturanr, Fakturadato, Kostpris, Pris, Beløp, Trans.status


Knapper i hjelpen

Internfakturering av timer for andre ansvarsenheter.

I tabellen Produkttransaksjoner finner du menyvalget ”Behandling / Internfakturering”. Når du velger dette, produserer Visma Business en bunt med mellomregningsbilag for de radene du har markert.

Forutsetninger for å få dette til...

Tabellen Bedriftsopplysninger:

Feltene ”Inng.fakt.serie”, ”Internfakt.kontonr” og ” Internfakt.serie” må fylles ut.

* Og feltene for Ansvarsenhet(er) som skal benyttes må fylles ut.

Tabellen Aktører:

Aktøren må ha fått tildelt et ”Ansattnr.” og den må være registrert med ansvarsenhet.

Tabellen Aktøropplysninger:

Gjør oppslag i feltet ”Aktørnr.” og hent frem riktig ansattnummer. Beløp 1 må fylles ut. Dette beløpet vil bli foreslått som pris ved internfakturering av dette ”oppdraget”.

Eksempel på fremgangsmåte:

Registrer en ordre til kunde 10000 med Avdeling 100 og Prosjekt 1000

Ferdigmelder ordren og fakturerer.

Slik ser det da ut i Produkttransaksjoner:

Før du velger Internfakturering, må feltene ”Ansattnr.”, og ønsket ansvarsenhet(er) sorteres med brudd. Du får feilmelding hvis du ikke har sortert med brudd på minimum ansattnummer og ønsket ansvarsenhet.

Vi har gjort følgende sortering:

For å starte internfaktureringen, velger du Internfakturering fra Behandlingsmenyen. Menyvalget leder til en dialogboks hvor du velger blant de navngitte ansvarsenhetsklassene som du har satt opp i tabellen "Bedriftsopplysninger".

Visma Business foreslår den første av ansvarsenhetsklassene som du har sortert med brudd på og det er kun denne som vil være med over til Bunter og Bilag. (Selv om det ligger f.eks. Prosjekt på ordren, vil den ikke bli med over til Bunter og Bilag… Dette ligger imidlertid inne som ønske til senere versjoner av Visma Business.)

Dialogboksen har også et felt hvor du registrerer valuteringsdato, og en avkrysning for å oppdatere bunten direkte. Visma Business foreslår dagens dato som valuteringsdato.

Visma Business produserer bilag for de bruddnivåene du definerer i delvinduet. Det blir produsert to bilagslinjer for hver bruddlinje hvor ansvarsenheten er forskjellig fra det som er registrert på de ansatte i tabellen "Aktører".

En bilagslinje hvor ansvarsenheten på produktansaksjonen blir debitert.

En bilagslinje hvor ansvarsenheten i tabellen "Aktører" blir kreditert.

Det blir fylt ut "Ansattnummer" på bilagslinjene. I tillegg kommer eventuelle andre bruddkolonner i delvinduet som også forekommer på bilagslinjene, for eksempel ordrenummer, fakturanummer, kundenummer, leverandørnummer og produktnummer.

Bilagslinjene blir påført neste ledige bilagsartnummer og bilagsart etter hva som er lagt inn i sistnevnte felt.

Du får lagt til en ordrelinje ved oppdatering av bilaget hvis du krysser av for "Oppdater ordre" på bilagsarten. Ordrenummer og produktnummer må da være utfylt på bilagslinjen.

Feltet Transaksjonsstatus
I tabellen "Produkttransaksjoner" setter Visma Business kryss i sjekkboksen "Internfakturert" i dialogen til feltet "Transaksjonsstatus" hver gang du internfakturerer.

Dette forhindrer internfakturering flere ganger selv om du skulle komme til å markere radene. Visma Business visualiserer avkrysningen som er satt i sjekkboksen ved å sette status 8 i feltet "Transaksjonsstatus". Visma Business vil da automatisk hoppe over slike transaksjoner. Du kan også gjøre utvalg på at feltet "Internfakturert" ikke skal sette kryss i sjekkboksen for internfakturert. Da går behandlingen raskere.


Kontantfaktura i Visma Business

Du kan bruke Visma Business til kontantfakturering. Du bruker da Ordretype "3 –Kontantordre", og registrerer Kundenummer for ”diverse-kunde” i tabellen Aktører. Du kan opprette flere ”diverse-kunder” med ulike betingelser. Du kan også benytte en vanlig kunde hvis du ønsker statistikkføring mot disse kundene, selv om de betaler kontant.

Tips: Når du oppretter kontantkunde/diverse-kunde i tabellen Aktører anbefaler vi at du velger ”Ikke oppbevar åpne poster” i feltet Matchingsmetode kunde. Da unngår du ekstra reskontroarbeid.

Nummerserie

Du kan ha en egen nummerserie for kontantfakturaer. Du angir nummerserien i tabellen Bedriftsopplysninger ved hjelp av feltet Kontantfakturaserie. Du kan for eksempel angi bilagsserie 111 som kontantfakturaserie, deretter velge en ledig nummerserie og gjøre den lik den vanlige fakturanummerserien.

Betalingsmåte

I tabellen Betalingsmåter kan du registrere de ulike betalingsmåtene. De blir styrt direkte til en balansekonto (kassakonto) og behøver ikke gå via reskontro. Det er da mulig å selge kontant til en kunde, som vanligvis blir fakturert, uten at det blir opprettet transaksjoner i reskontroen.

Lagring/Godkjenning

Når ordren blir lagret, blir fakturaen skrevet ut automatisk. Du får opp en dialogboks som hjelper deg når du mottar betaling. Du registrerer hvor mye du har fått av kunden, og med utgangspunkt i fakturabeløpet, blir beløpet som kunden skal ha tilbake presentert på skjermen. Du vil i utgangspunktet ikke få opp standard godkjenningsdialog ved kontantfakturering. For å få opp godkjenningsdialogen må du sette dette parameteret i feltet Ordrebehandling i tabellen Bedriftsopplysninger.

Dersom du velger å godkjenne, vil regnskapet (og statistikken) bli oppdatert. Regnskapet vil bli oppdatert med en bunt pr. kontantfaktura. Du kan også undertrykke dialogen for betalingsmåte og beløp i samme felt som godkjenning.

Hvis du ønsker å bruke kontantfaktura, kan du lage et eget oppsett for dette. Bruk transaksjonstype 1: Salg, og ordretype 3: Kontant, som standardverdier.


Korrigering av negative varepartier

Negative varepartier kan bli dannet av flere årsaker, f.eks. dersom du registrere ordre med ordretype 2.

Vi har laget et eksempel på hvordan du enklest kan korrigere dette. I skjermbildet under har vi tatt utgangspunkt i Ordre og Ordrelinjer, med utvalg på Transtype = 4 og Ordretype = 4. Videre så har vi koblet tabellene Varepartier og Lagersaldoer til Ordrelinjer.

I vårt eksempel har vi –12 på lager av vare 4003 på Vareparti nr.2. Dette ønsker vi å ”nulle” ut. På ordrelinjene angir vi riktig partinummer (det vi vil ”nulle” ut), vi legger inn –12 i antallsfeltet og ved lagring så ser vi at partinr. 2 blir borte.


Kvantumsrabatt

Kvantumsrabatt (Rabatt på produktprisgruppe)

Dette er et forslag til hvordan du kan benytte kvantumsrabatt på Produktprisgruppe, når denne skal gjelde samlet antall over flere ordrelinjer.

Produktene kan settes opp med følgende priser og rabatter:

Følgende parameter må settes i Bedriftsopplysninger:

  • Pris/rab. sumfelt = 1 betyr at rabatten beregnes utifra det samlede Antall
  • Pris/rab. krit 1 = 4 betyr at Produktprisgruppe 1 skal være gjeldende kriterie på rader uten produktnummer i pris- og rabattmatrisen.

Registrer følgende ordre, merk at antall er tilsammen 25 og kvalifiserer for 5% rabatt:

NB! Etter registrering må vi kjøre Behandlingsmenyvalget "Rekalkulering av priser", da beregnes ny rabatt basert på det samlede antallet i produktprisgruppen:


Lagermål

Når lagersaldo-, vareparti- eller beholdningsendringstabellene kobles indirekte til ordrelinjene, kan du få programmet til å regne om beholdningsfeltene, kostprisene og forsendelsesomkostningene i dem ved å fylle ut feltet “Lagermål” med en av følgende verdier, som kan foreslås fra strekkoden, enheten eller produktet:

Velger du

1, Antall i grunnenhet,
dividerer Visma Business beholdningene med "Antall pr. enhet".
2 – Lengde
3 – Areal
4 – Volum
5 – Nettovekt
2 – 5 dividerer Visma Business beholdningene pr. enhet og multipliserer med vedkommende "pr. enhet"-faktor fra ordrelinjen.

Hvis "pr. enhet"-faktoren ikke er oppgitt, skjer det ingen omregning. Dette innebærer at pr. enhet-faktorene må være uttrykt for den aktuelle enheten, og ikke i lagerets grunnenhet. Hvis du for eksempel selger parkett i bord og pakker, angir du dimensjonene pr. bord i tabellen "Produkter" og pr. pakke i tabellen "Enheter".

Samme omregning blir også gjort av antallet på ordrelinjene når Visma Business oppdaterer lagertabellene ved blant annet lagring av ordrene. Hvis feltet "Lagermål" ikke er utfylt, blir ikke tilkoblede lagerbeholdninger omregnet på skjermen, men ved lagring av ordrene dividerer Visma Business antallet med "Antall pr. enhet".

Endrer du "Lagermål" eller "pr. enhet"-faktor på ordrelinjen, blir lagerbeholdningene i tilkoblede vinduer omregnet med det samme.

Eksempel

Produktet ”Pærebrus” er satt opp på følgende måte:

Ved ordreregistrering på dette produktet kan du via feltet Lagermål på ordrelinjen, se lagerbeholdning og kostpriser avhengig av hva som registreres i Lagermål.

I dette eksempelet er Lagermål = 1:

Hvis Lagermål på ordrelinjen endres til 4, skjer det en omregning i de koblede tabellene:


Regenerering av Lagersaldoer

Regenereringen gjøres fra Behandlingsmenyvalget ”Regenerere lagersaldoer” i tabellen Lagersaldoer. Dersom du har feil i Lagersaldoene, kan det være hensiktsmessig å foreta en regenerering av lagersaldoene. En regenerering summerer det som ligger i tabellene:

  • Varepartier - Alle feltene som er felles for Varepartier og Lagersaldoer
  • Produkttransaksjoner - Transaksjonsstatus for inn/ut av lager
  • Ordrelinjer - Hva som ligger i innkjøp og hva som ligger i reservert.

Regenerering gjenoppbygger tabellen Lagersaldoer på grunnlag av disse tabellene.

Merk: Ved regenerering blir alltid varepartiene overskrevet. FIFO: Dette feltet viser et veid gjennomsnitt av kostprisene på de varene du har på lageret, og blir beregnet ut fra varepartier med positiv fysisk beholdning. Det kan derfor være lurt å foreta en slik regenerering før Lagertelling.

Lagertelling

Du foretar lagertelling for å avstemme lageret mot materiellregnskapet i Visma Business. Standard skjermbilde for Lagertelling ser slik ut:

Lager | Viser alle produkter pr. lager, sortert i stigende produktnummerrekkefølge.
Produkt | Viser pr. produkt på lagersteder
Tellegruppe | Viser alle produkter sortert i stigende lagernummer, så i stigende tellegruppe, i stigende produktnummer og så i normal plassering
Total | Sortert i stigende lagernummer, usortert.
Produkter til telling | Viser en totalliste over alle produkter som er overført til telling – Lagersaldostatus = 1. Sortert på lagenummer og tellegruppe

Merk: Du kan ikke registrere ordrer eller behandle produkter som er under opptelling, altså de som har "Lagersaldosstatus" = "1". "Korriger beholdninger" låser opp.

Lagertellingsrutine

Når du skal foreta en lagertelling kan du følge denne rutinen:

  1. Marker eller gjør utvalg på de produktene du ønsker å overføre til lagertelling og velg deretter ”Overfør til lagertelling” fra Behandlingsmenyvalget.
  2. Gå til fanen ”Produkter til telling”. Her ser du at det automatisk blir fylt ut verdien 1 i feltet ”Lagerstatus” (Lagerstatus 1 = Under telling). Feltet ”Tellbart antall” blir fylt ut med verdier fra Lagersaldotabellen (”Fysisk beholdning” – (minus) ”Ferdigmeldt”).
    Dersom du ønsker å fjerne produkter fra fanen ”Produkter til telling”, må du manuelt fjerne verdien 1 i feltet ”Lagerstatus”.
  3. Legg inn det riktige antallet i feltet ”Telt antall”. Dersom du henter frem feltet ”Telledifferanse”, så viser dette differansen mellom "Opptalt antall" (som du har tastet inn) og "Tellbart antall" (som Visma Business har beregnet).
  4. Velg ”Korriger beholdninger” fra Behandlingsmenyvalget.
  5. ”Fysisk beholdning” (i Lagersaldotabellen og på Varepartiene) vil endres til det ”nye” antallet (som ble lagt i ”Telt antall”).

Hvis det er en negativ telledifferanse, vil Visma Business bare redusere beholdningen i FIFO-rekkefølge på varepartier som er under lagertelling.

Merk: Dersom du får melding om at lagersaldoen ikke kan bli redusert på grunn av reservasjoner, må du markere de produktene (radene) som meldingen viser. Velg deretter menyvalget "Behandling/Trekk tilbake reservasjoner". Lagersaldo-radene er nå markert som om de er under lagertelling inntil Visma Business kan korrigere lagersaldoen til "Telt antall".

Etter at behandlingsmenyvalget ”Korriger beholdninger” er utført på markerte produkter, vil disse legge seg i tabellen ”Produkttransaksjoner” med Transtype = 4 (Tap).

Ved reduksjon av beholdningen tar Visma Business telledifferansen fra varepartiene i standard FIFO-rekkefølge, og ved økning legger Visma Business til nye varepartier med kostpris lik gjennomsnittlig kostpris for produktet på lageret. Transaksjonene får transaksjonstype 4 (tap) med negative antallsfelt hvis lagerbeholdningen øker og varepartiene får normal leverandør og normal plassering fra tabellen "Lagersaldoer".

All historikk som forteller hvem som har foretatt telling og når ligger i tabellen ”Lagersaldoer”.

Bedriftsopplysninger

I tabellen Bedriftsopplysninger dialogen Ordrebehandling, finner du følgende felt som berører Lagertelling:

”Sjekk lagersaldotabellen for produkter under lagertelling”
- Ved lagertelling og hvor du har satt "behandlingsmåte" på ordrelinjen til "legg til varepartier med negativ disponibilitet", skal du også sette parameteren "sjekk lagersaldotabellen for produkter under lagertelling". Hvis ikke dette valget er krysset av vil Visma Business legge til et negativt vareparti selv om produktet er under lagertelling

Denne parameteren er implementert for å minimalisere beholdningsfeil ved ferdigmelding av en salgsordre.

“Ikke beregn “Produkter til utlån” i tellbart antall -
Her krysser du av for at produkter som du har til utlån ikke skal bli telt opp når tellbart antall blir beregnet. Produkter til utlån er en del av den fysiske beholdningen og vil normalt bli regnet med.

“Ta ikke med utleid i tellbart antall – Som standard tar den med seg “Utleide” produkter med til lagertelling.

Tabellen Varepartier

Oppslag i feltet “Varepartistatus” leder til en dialog med følgende sjekkbokser:

Visma Business avmerker sjekkboksen "Under lagertelling" når du benytter behandlingsmenyvalget "Overført til lagertelling" Avmerkingen blir slått av når du benytter behandlingsmenyvalget "Korriger beholdninger". Du kan også avmerke eller fjerne dette manuelt, hvis du ønsker å omgå den videre behandlingen.

Når du benytter behandlingsmenyvalget "Korriger beholdninger", blir bare beholdninger på varepartier som er under lagertelling redusert. Hvis du fjerner avmerkingen "Under lagertelling" blir ikke disse varepartiene tatt med. Ved behandling av ordrer blir det ikke foretatt reservasjon fra varepartier som er under lagertelling.

Hva skjer med varer under lagertelling

  • Du kan registrere ordre på varer som er under lagertelling
  • Du vil ikke få ferdigmeldt eller fakturert ordrelinjer som inneholder varer under lagertelling. Du får meldingen ”Antall rader behandlet...”, men den foretar ingen ferdigmelding.
  • Ved behandling av ordrer, vil Visma Business ikke foreta reservasjon fra varepartier som er under lagertelling (enten reservasjonen skjer ved lagring, plukking eller ferdigmelding).


Ordredokumenter på fax

Ordredokumenter på telefaks

  1. MAPI kompatiblet FAX/mail system må være installert på server.
  2. På klienten må følgende være installert
    • Fax mail printer
    • Visma Business
    • MAPI Kompatibelt mail system
    • Klient av fax program
  3. Sett opp følgende i Bedriftsopplysninger

    Prefix og suffix

    Hvordan dette settes opp får du beskjed om fra Mail/fax system leverandøre

  4. Sendemåte for dokumenter

    Sett opp på ordredokumentet ønsket sendemåte:

    Dette setter du opp på aktøren
  5. Start opp mail-klient (Litt usikker på om du må dette)
  6. Start Utskrift av ordrebekreftelse.
  7. Tif – filer blir laget i den katalog som er angitt i FAX/MAIL_PATH i registry


Ordregenerering ved hjelp av "Del opp"

Ordregenerering ved hjelp av ”Del opp”

Hvis du overstyrer kunde- eller leverandørnummer på én eller flere ordrelinjer må du dele opp ordren pr. kunde/leverandør før du kan fakturere eller kjøre utskrift av innkjøpsordre. Du deler opp ordren ved hjelp av menyvalget Behandling/Del opp i tabellen Ordrer. Menyvalget behandler den aktive ordren eller de ordrene du på forhånd har markert.

Hver ordre vil uansett bli behandlet for seg, ved at den blir splittet opp i én ordre pr. kunde (ved salg, utleie eller utlån) eller pr. leverandør (ved innkjøp). Hvert ordrehode blir påført informasjon om aktuell kunde eller leverandør fra tabellen Aktører. Den kunden/leverandøren som har lavest kunde-/leverandørnummer blir liggende igjen i den opprinnelige ordren, mens de øvrige blir tildelt nye ordrenummer. Ordrene kan du vedlikeholde både før og etter oppdeling. Ordrene kan eventuelt inngå i samlefakturaer.

Merk: For at du skal kunne overstyre kunde-/leverandørnummer på ordrelinjene må du ikke registrere kunde-/leverandørnummer i ordrehodet. I stedet kan du registrere ansattnummer, selger/innkjøper eller ansvarlig som fellesnevner på ordren. Ordrer uten kunde-/ leverandørnummer blir ikke fakturert eller skrevet ut på innkjøpsordre eller andre ordredokumenter. Dette hindrer at ordrene blir behandlet ved en feiltagelse.

For kunder som har behov for denne funksjonaliteten vil det lønne seg å tilrettelegge et skjermbilde for denne typen fakturering. I skjermbildet nedenfor er ordrelinjene koblet til ordrehodet, og aktørtabellen med utvalg på kunder er inkludert. På denne måten kan du enkelt kopiere aktuelle kundenummer fra aktørtabellen og lime disse inn i ordrelinjene. Det er i tillegg satt to utfyllingsregler; en på feltet produktnummer og en på feltet antall. Dermed fylles disse feltene automatisk med ønsket produktnummer og antall når du limer inn kundenummer.

Etter du har limt inn kundenumrene må du kjøre behandlingsmenyvalget ”Rekalkuler priser” slik at pris og beløp oppdateres. Til slutt kjører du behandlingsmenyvalget ”Del opp”, og ordren splittes slik at hver kunde får sin ordre.


Rapportering av valutatransaksjoner

Produksjonsordre

Generelt
Ordretypen produksjonsordre benyttes til å sette råvarer sammen til et nytt produkt. Ved ferdigmelding av produksjonsordre overføres varer fra råvarelager til ferdigvare lager. Ferdigvaren har transstatus 7[Produksjon] som gir lagerøkning. Råvarer har transstatus 5[Vareforbruk] som gir reduksjon på lager.

Ved hjelp av avgifts- og bokføringsgruppene er det også mulig å overføre saldoen fra råvarekontoen til ferdigvarekontoen i regnskapet.

Dersom det benyttes strukturvarer i produksjonsordre bør det samtidig krysses av for råvare i strukturtabellen. Avmerker du dette feltet blir ordrelinjen påført transaksjonstype 5, "Vareforbruk", når strukturen blir ekspandert på en produksjonsordre. Du kan kjøre plukklister for vareforbruk på produksjonsordrer.

Produkter

Produksjonsordre

Parameter som påvirker produksjonsordre

Behandlingsmåte på produkt

Kostnader ved produksjon:

Avmerker du dette feltet blir kostnader og beløp på produksjonsbestillinger akkumulert opp i strukturhodet. Akkumuleringen skjer når du lagrer og på ordredokumenter. For å unngå dobbel bokføring må du avmerke tilsvarende felt for bokfør kostnader ved produksjon på siden "Etterbehandling".

Unnta fra totaler:

Kostnader ved produksjon kan unntas fra total, bokføring og statistikkføring. Detaljert forklaring på disse parametrene ligger i hjelpefilen.

Hvordan opprettes en produksjonsordre
I tillegg til manuell registrering av produksjonsordre kan den automatisk bli generert via behandlingsmenyvalget ”Generer ordre” og via ”Bestillingsforslag”. I tabellen leveringsalternativer må det krysses av for ”Produksjon”. Denne avkrysningen bestemmer om produktet kommer med på en produksjonsordre eller en innkjøpsordre

Dialog ved generering av ordre
I tabellen "Bedriftsopplysninger" finner du feltet "Bestillings gen. behandling" hvor du har mulighet til å styre hva som skal bli kopiert fra en salgsordre til innkjøps-/produksjonsordre. Feltet leder til følgende dialog:

Bruk av views i Fri informasjon
Tabellene ”Fri informasjon 1-3” kan benyttes til å lagre tilleggsinformasjon som ikke ligger som standard i tabellene. I tillegg kan disse tabellene erstattes av et view som henter opplysninger fra andre tabeller i databasen. View’et kan hente informasjon fra en eller flere tabeller og beregne nye verdier etter egne formler.

Et eksempel på dette er å lage en beregning av hvor mange ferdigvarer det er mulig å produsere med de råvarene som ligger på lager:

Lagersaldotabellen
Lagersaldotabellen inneholder egne kolonner for produksjon. Dette gir en god oversikt over hva som til enhver tid ligger i produksjonsordre.


Tabellen Reservarsjoner

Tabellen Reservasjoner

Dokumentet inneholder en beskrivelse av tabellen Reservasjoner med tilhørende behandlingsmenyvalg/trykknapper.

Datamodell for ordre/logistikk

De dynamiske tabellene i ordre/logistikk-systemet er illustrert i figuren nedenfor, sammen med de viktigste relasjonene mellom dem.

Du ser at det går ut piler i alle retninger fra boksen som representerer tabellen ”Reservasjoner”. Denne tabellen spiller en sentral rolle som bindeledd mellom ordrelinjer, plukklister, varepartier og transaksjoner. Programmet gjør automatisk mesteparten av arbeidet med å oppdatere den, men du som bruker kan også redigere i tabellen.

Reservasjoner

Du kan velge å koble den til ordrelinjene under ordreregistreringen (f.eks. med Ctrl+K) dersom du ikke skal behandle hele antallet på ordrelinjen. Det kan for eksempel være hvis du skal reservere fra forskjellige varepartier ved lagerreduksjon, eller splitte i flere varepartier ved lagerøkning. Ved lagerøkning blir opplysninger overført fra tabellene ”Reservasjoner”/ ”Ordrelinjer” til ”Varepartier”. Ved lagerreduksjon blir det overført den andre veien.

Tabellen ”Reservasjoner” kan du også koble til tabellen ”Plukklister” for å se hvilke reservasjoner de ulike plukklistene omfatter.

Sletting av rader

Programmet sletter automatisk reservasjonsrader hvis antall, reservert, plukket, ferdigmeldt og fakturert/realisert alle er 0.

Grunnparametere

Ordrenummer og linjenummer

Ordre- og linjenummer refererer til en ordrelinje, og blir eliminert ved kobling mot ordrelinjene.

Partinummer og overført partinummer

Disse feltene angir i kombinasjon med produktnummer og lagernummer/overført til lagernummer hvilke varepartier reservasjonslinjen omfatter. Se nærmere beskrivelse av dem i omtalen av de tilsvarende feltene på ordrelinjene.

Restriksjoner ved redigering

Programmet hindrer endring av partinummer i reservasjonstabellen for avgangsordrelinjer hvor noe er reservert eller fakturert/realisert, og for tilgangsordrelinjer etter varemottak.

Reservasjonsnummer og sorteringssekvensnummer

Disse kolonnene behandles tilsvarende som på linjenummer og sorteringssekvensnummer ordrelinjene, se kapitlet om ordreregistrering, og medfører at menyvalget ”Innsett” kan benyttes til å innsette rader mellom eksisterende. Primærnøkkelen i reservasjonstabellen utgjøres av ordrenummer, linjenummer og reservasjonsnummer. Reservasjonsønskene blir prioritert i den rekkefølgen som sorteringssekvensnummeret angir.

Generelle opplysninger

Serienummer, plassering og holdbarhetsdato/uke

Disse feltene inneholder opplysninger om varepartiene, og overføres til og fra varepartitabellen, og til produkttransaksjonene. Se nærmere omtale feltene med samme navn på ordrelinjene.

Antallsparametere

Antall

I kolonnen “Antall” taster du inn de antallene som du ønsker å reservere (ved lagerreduksjon), eller størrelsen på de varepartiene som ordrelinjen ønskes splittet opp i ved lagerøkning, målt i ordrelinjens enhet. Hvis hele antallet på ordrelinjen skal reserveres fra samme parti, kan det gjøres direkte på ordrelinjen. “Reservert” blir økt med det antallet som programmet klarer å reservere. Det antallet som programmet ikke klarer å reservere, fratrekkes antallsfeltet, slik at antall = reservert + fakturert/realisert – ferdigmeldt.

Antallsfeltet blir redusert ved ferdigmelding, slik at det viser restantallet på reservasjonslinjen. Feltet viser 0 i stedet for blankt hvis noe er ferdigmeldt. Programmet hindrer skifting av fortegn i antallsfeltet på en reservasjonslinje (eller ordrelinje) hvor reservert eller ferdigmeldt antall har et annet fortegn. Hvis brukeren reduserer antallsfeltet, vil det medføre tilbaketrekning av reservasjoner. Programmet fyller også ut dette feltet på rader som det legger til. Antallsfeltet summerer seg opp til antallsfeltet på ordrelinjen, dersom hele ordrelinjen er behandlet.

Plukk NÅ, ferdig NÅ og fakturer NÅ

Disse feltene kan benyttes på tilsvarende måte som på ordrelinjen, dersom deler av reservasjonslinjene skal behandles, se omtale foran.

Tilbake NÅ, kasser NÅ og erstatt NÅ

Disse feltene benyttes ved utleie/utlån på tilsvarende måte som på ordrelinjen, når det blir levert tilbake til bestemte partier, eller varer på dem må kasseres eller erstattes, se omtale foran.

Betalingsparametere

Kostvalutanummer, kostvalutakurs, frakt 1 – 4, toll, og kostpris i kostvalutaen og standard valuta

Disse feltene inneholder opplysninger om varepartiene, og overføres til og fra tabellen ”Varepartier” og til produkttransaksjonene.

Status-felter

Reservert

“Reservert” viser hvor mye som for tiden er reservert av det totale antallet på reservasjonslinjen. Verdiene i denne kolonnen summerer seg opp til “Reservert” på ordrelinjene (pr. ordrenummer), på varepartiene (pr. produktnummer, lagernummer og partinummer-kombinasjon) og i tabellen ”Lagersaldoer” (pr. produktnummer og lagernummer-kombinasjon).

Det som ennå ikke er reservert vises i feltet “Ikke reservert” på ordrelinjen.

Plukket og gjenstår å plukke

“Plukket” viser hvor mye av det totale antallet på reservasjonslinjen som har blitt plukket. Verdiene i denne kolonnen summerer seg opp til “Plukket” på ordrelinjene.

“Gjenstår å plukke” viser differansen mellom det totale antallet på reservasjonslinjen og det som tidligere måtte være plukket på den, og ligger ikke i databasen.

Plukklistenummer

Ved utskrift av plukklister blir reservasjonsradene påført et plukklistenummer, til bruk for programmet ved en eventuell senere ferdigmelding i henhold til plukklisten eller tilbaketrekning av plukklisten. Dette gjør også at reservasjonsradene kan kobles til plukklistetabellen.

Ferdigmeldt av, ferdigmeldt dato/uke og klokkeslett

I disse feltene tar programmet vare på navnet til brukeren som sist har ferdigmeldt noe på reservasjonslinjen, og datoen og klokkeslettet ferdigmeldingen. Datoen kan også vises som dagnummer, ukenummer og år i en egen kolonne.

Ferdigmeldt

“Ferdigmeldt” viser hvor mye av det totale antallet på reservasjonslinjen som har blitt ferdigmeldt. Verdiene i denne kolonnen summerer seg opp til “Ferdigmeldt” på ordrelinjene.

Totalt antall

“Totalt antall” viser det totale fakturerbare/realiserbare antallet, dvs. summen av restantallet og ferdigmeldt antall, og ligger ikke i databasen. Kolonnen får i utgangspunktet den verdien som tastes inn i kolonnen “Antall”, og forblir uendret når du ferdigmelder, men økes eller reduseres igjen hvis antallsfeltet endres av brukeren.

Verdiene i denne kolonnen summerer seg opp til feltet med samme navn på ordrelinjen, dersom hele ordrelinjen er behandlet.

Fakturert/realisert

“Fakturert/realisert” viser hvor mye av det ferdigmeldte antallet som har blitt fakturert/realisert på reservasjonslinjen. Verdiene i denne kolonnen summerer seg opp til “Fakturert/realisert” på ordrelinjene.

Tilbakelevert, kassert og erstatningspliktig antall

Disse feltene viser ved utleie/utlån hvor mye som har blitt tilbakelevert, kassert eller som skal erstattes, og summerer seg opp til tilsvarende felter på ordrelinjene.

Virkelig returdato/uke

“Virkelig returdato” tar vare på datoen for når tilbakelevering fant sted. I ordrehodet og på ordrelinjene er det en kolonne “Forventet returdato” for når du forventet at tilbakelevering skulle finne sted. Virkelig returdato kan også vises og tastes inn som dagnummer, ukenummer og år i en egen kolonne.

Ordrejournalnummer og transaksjonsnummer, overført ordrejournalnummer og overført transaksjonsnummer

Ved realisering legger programmet igjen referanser til produkttransaksjonstabellen i disse feltene, og gjør det mulig for programmet å korrigere eller slette produkttransaksjonene i ettertid.

Ved lageroverførsler og eventuelt utleie/utlån benyttes feltene for overført ordrejournalnummer og overført transaksjonsnummer til å referere til transaksjonen for det lageret/partiet det overføres til.

Behandlingsmenyvalg

Ferdigmeld, tilbakelevert, og mottatt faktura

Disse behandlingsmenyvalgene fungerer på tilsvarende måte som i ordrelinje-delvinduet, bare avgrenset til reservasjonslinjer i stedet for ordrelinjer.

Ordrelinje

Reserver NÅ

Dette feltet kan fylles ut dersom du ønsker å reservere deler av ordrelinjen. Ønsket vareparti kan være angitt i partinummer-feltet. Alternativt kan du fylle ut ”Antall” og ”Partinummer” i reservasjonstabellen. Reservasjonen skjer ved lagring.

Verdien i feltet “Ikke reservert” er grenseverdi for inntasting i feltet “Reserver NÅ”. Et negativt antall vil trekke tilbake reservasjoner. Feltet ligger ikke i databasen, og blir nullstilt etter lagring.

Behandlingsrekkefølgen ved reservasjoner er:

  1. Reservasjonsønsker (partinummer og antall) angitt i reservasjonstabellen.
  2. Reservasjonsønsker på ordrelinjen.
  3. Varepartier i FIFO-rekkefølge (sorteringssekvensnummer).
  4. Legge til varepartier med negativ disponibilitet.

Hvis det krysses av for å ”Ikke behandle varepartier i FIFO-rekkefølge”, vil programmet unnlate å undersøke varepartier i FIFO-rekkefølge (steg 3), om ikke reservasjonsønsker kan innfris eller det ikke er noen reservasjonsønsker. Se også omtale av ”Reservasjonsmåte” nedenfor.

Steg 4 vil bli utført hvis det fremdeles gjenstår en rest å reservere etter at programmet eventuelt har undersøkt alle varepartiene for produktet på lageret, og

  • du har krysset av for ”Legg til varepartier med negativ disponibilitet”, eller
  • det er en direkteordre, kontantordre eller realisert-ordre (ordretype 2 – 4). Se omtale av feltet ”Ordretype” i ordretabellen i kapitlet om ordreregistrering.

Opplysninger fra avgangsordrelinjer til negative varepartier

Ved oppretting av et negativt vareparti, tar programmet med seg serienummer, plassering, holdbarhetsdato, ordrenummer og kostprisfelter fra avgangsordrelinjen til varepartiet. Dermed blir de også med i reservasjonstabellen, på produkttransaksjonene og ved bokføring.

Lagersaldo

Reservert

“Reservert” viser hvor mye som er reservert. Reservasjoner oppheves ved tilbakelevering, kassering eller erstatning ved utleie/utlån, og ellers ved fakturering/realisering.

Reserverbart

“Reserverbart” viser hvor mye som er tilgjengelig for reservasjon på lageret i øyeblikket. Feltet ligger ikke i databasen, men blir beregnet ut fra følgende formel:

Reserverbart = Fysisk beholdning – Reservert

Endringer

Reserverbart antall økes ved varemottak og reduseres ved reservasjon, og påvirkes ikke av fakturering/realisering.

Illustrasjon

Figuren nedenfor illustrerer sammenhengen mellom beholdningsbegrepene.


Sanering av Produkttransaksjoner

Bakgrunn

Visma Business tar vare på alle produkttransaksjoner som er skapt siden kunden tok i bruk Visma Business. Dette gjør at det kan ligge transaksjoner som er flere å gamle. Konsekvensen er at tabellen med produkttransaksjoner vokser, blir tyngre å håndtere og Visma Business blir oppfattet som tregt. Derfor kan det være ønskelig å slette/sanere disse transaksjonene. Fremgangsmåten som er beskrevet forutsetter versjon 5.0 av Visma Business.

Fremgangsmåte

Åpne opp tabellen "Produkttransaksjoner" og gjør et utvalg slik at kun de transer som skal saneres kommer frem. "Trans.dato" settes til < eller <= ønsket dato. I dette eksemplet så er dato satt til "Trans.dato" < 31.12.2006.

NB!! Andre utvalg enn "Trans.dato" vil ikke bli hensyntatt.

Utfør saneringen med menyvalget

Konsekvenser

Alle transaksjoner med transaksjonsdato eldre enn dato angitt i utvalgsdialogen er nå slettet med mindre transaksjonen har en påvirkning på dagens lagerbeholdning.

Eksempel: Produkt kjøp inn 01.12.2006 med transaksjonstype 6 (innkjøp). Dersom ikke hele denne inngående beholdningen ikke har en avgang så vil ikke produktransaksjonsraden fra 2006 bli slettet/sanert. Dette for å ikke ødelegge for en senere regnenerering av lagersaldo.

Alle transer som er sanert/slettet er blitt overført til tabellen "Produkttransaksjoner 2". Denne tabellen er en eksakt kopi av orginal tabellen "Produkttransaksjoner". Her har du da muligheten til å finne igjen transaksjoner på perioder som er sanert/slettet. Dette medfører at databasen ikke blir mindre, men det vil være betraktelig færre transkasjoner å prosessere i de normale statistikk rapportene/skjermbildene.


Serienummer

Det finnes to måter å håndtere Serienummer på i Visma business, ved bruk av serienr. Tabellen som ikke har full lager kontroll og ved bruk av reservasjonstabellen som gir full lager kontroll og sporbarhet.

Ved lagerøkning vil serienr oppdateres fra ordrelinje til reservasjonene og igjen til varepartiene og produkttransaksjonene.

Ved lagerreduksjon vil systemet søke i vareparti tabellen om serienummeret finnes og hvis du har satt på avvis ikke eksisterende serienr. vil det ikke være mulig å registrere noe som ikke finnes. Systemet vil oppdatere feltet partinr. og evt. Ferdig NÅ med 1 avhengig om behandlingsmåte for ”Tell opp Ferdig NÅ ved inntasting av serienr” er satt på Reservasjonslinjene vil alltid hente serienr. fra Varepartiet ved lagerreduksjon om det er angitt. Ønsker du ikke det så kan ikke krysset for avvis ikke eksisterende serienr. setes på og du må registrere Serienr. på ordrelinje, reservasjoner eller serienr. tabellen

Det er viktig å sette opp produktene riktig i forhold til hvilket nivå du ønsker sporbarhet av seriner.

  • Tildeling av serienr. ved lagerøkning (Varemottak, Produksjon, Kreditnotaer. Da vil det genereres varepartier pr. enhet ved mottak og det skulle ikke være nødvendig å sette kryss for lagerreduksjon avhengig av om krysset for om ”avvis ikke eksisterende serienr.” og ”Avvis dupliserte serienr.” er satt på.
  • Tildeling av serienr. ved lagerreduksjon (Salgsordre, Utleie og Produksjon) Dette må settes hvis du ønsker å ha full sporbarhet uten å registrere serienr. ved varemottak.
  • Tildeling av serienr. ved bruk av serienr. tabellen som ikke gir noen kontroll mot varepartier og lager.

Et vareparti pr. serienr.

Det finnes to behandlingsmåter på produktet for å generere et vareparti/reservasjon pr. serienr. ”Ved lagerøkning” og Ved lagerreduksjon” som ved ferdigmelding av ordrelinjen vil generere et vareparti pr. enhet

Ved lagerøkning

Når dette krysset er på så vil det ved varemottak, ferdigmelding av produksjon og kreditering av salgsordre samt andre lagerøkninger genereres et vareparti pr. enhet

Ved lagerreduksjon

Når dette krysset er på så vil det ved reservasjon/ferdigmelding av salgsordre, ferdigmelding av vareforbruk produksjon samt andre lagerreduksjoner genereres et vareparti pr. enhet

Avvisning

Ved inntasting av serienr. finnes det flere kontroller som kan gi melding om at serienummeret enten er benyttet tidligere, eller at det ikke finnes.

Ikke eksisterende serienr.

Det finnes et behandlingsmåte på produktet ”Ikke eksisterende serienr.” for å sjekke om serienr. som legges inn på en salgsordre eller annen lagerreduksjon om serienr. finnes i tabellen ”Varepartier”. Hvis det ikke finnes vil du ikke komme videre i registreringen. Meldingen gis på statuslinjen for reservasjoner og ordrelinjer men som dialog i serienr. tabellen

Dupliserte serienr.

Det finnes et behandlingsmåte på produktet ”Dupliserte serienr.” for å sjekke om serienr. er benyttet fra før. Dette valget sjekker om du har tastet inn samme serienr. flere ganger for samme ordrelinje og i reservasjonstabellen sjekker den også om serienr. er benyttet tidligere for ordrelinjens produktnr. i tabellen Produkttransaksjoner.

Plukkliste

Normalt så gjøres det reservasjoner når plukkliste kjøres men for serienr. produkter så ønsker du ikke en slik tildeling. Det er først ved ferdigmelding at du ønsker å registrere serienr.

Merk: Lagersaldoen vil bli oppdatert med reserver antall for serienr. produkter selv om reservasjonen ikke genereres og Ordrelinjestatus oppdateres for at plukking uten reservasjon er utført. Ved ferdigmelding av disse radene vil ikke reservert oppdateres da det ble gjort ved plukking.

Reserver serienr. ved plukking

Som standard så er ikke dette krysset satt på fordi du i de fleste tilfellene ikke ønsker å tildele serienr. fra varepartier på et så tidlig tidspunkt. Hvis du ønsker den samme funksjonen som i tidligere versjoner eller vil ha så streng tildeling av serienr. må du krysse av her og reservasjonslinjer vil bli generert ved plukking på vanlig måte.

Serier. på ordrelinjer

Serienr. kan oppgis på ordrelinje hvis det bare skal registreres et serienr. eller ferdigmeldes et og et serienr med lagring mellom hver gang som forutsetter at Tell opp Ferdig NÅ ved inntasting av serienr. er på.

Ferdigmelding

Ved utlevering og innlevering kan du angi serienummer på ordrelinjer og hvis behandlingsmåte ”Tell opp ferdig nå ved inntasting av serienummer” er krysset for på produktet vil "Ferdig NÅ" oppdateres med 1 i antall. Ved lagring vil randen behandles på vanlig måte som om du hadde lagt inn 1 Ferdig NÅ manuelt. Hvis det ikke finnes mer å ferdigmelde så nullstilles Ferdig NÅ og ingen reservasjon blir gjort.

Merk! Har du lagt inn en annen verdi i ”Ferdig NÅ” vil denne bli overskrevet med 1

Hvis du for eksempel ved en lagerøkning skal registrere flere serienr. som er nesten like kan du på ordrelinjen legge in deler av serienr. og ferdigmelde. Så kan du rette opp serienummerere i reservasjonstabellen som så vil oppdatere varepartiet og produkttranslasjoner.

Serier. i reservasjoner

Serienr. bør oppgis i reservasjonstabellen fordi dette fil føre til at det skapes en produkttransaksjon pr. reservasjonslinjer. Og du vil få full kontroll over uttaket samtidig som sporbarheten ivaretas i produkttransaksjoner.

Ferdigmelding

Ved utlevering og innlevering kan du angi serienummer på tomme reservasjonslinjer og hvis behandlingsmåte ”Tell opp ferdig nå ved inntasting av serienummer” er krysset for på produktet vil "Ferdig NÅ" oppdateres med 1 i antall. Om ikke raden er realisert fra før.

Serienr. tabellen

Du benytter denne tabellen når du har behov for å registrere flere serienummer til en salgs- eller innkjøpsordrelinje og ikke ønsker en streng individ kontroll. For eksempel på elektriske artikler som TV/Radio, krever serienummer på grunn av garantier, derfor er det av og til behov for flere serienummer til en salgs- eller innkjøpsordrelinje.

Du kan benytte oss av serienummer både ved innlevering og utlevering av varer. Hvis vi vil ha serienummer oppbevart i et vareparti, må du ha en innlevering pr. individ pr. vare, og da vil vi anbefale at du benytter Reservasjoner isteden.

Ferdigmelding

Ved utlevering kan du angi serienummer itabellen "Serienummer" som kan bli koblet til tabellen "Ordrelinjer". Det finnes en behandlingsmåte ”Tell opp ferdig nå ved inntasting av serienummer” som kan bli brukt ved utlevering som teller opp "Ferdig NÅ" feltet på ordrelinjen ved inntasting av serienummer i den tilkoblede serienummertabellen hvis samme mengder gods skal bli utlevert med angivelse av serienummer.

Merk! I fra serienr. tabellen har du ikke noen kontroll på hvilket vareparti som blir benyttet da reservasjonen vil bli utført i FIFO rekkefølge. Ønsker du kontroll på dette må du benytte reservasjoner til å taste serienr.

Denne tabellen kan kobles til

  • Ordrer
  • Ordrelinjer
  • Lagersaldoer
  • Varepartier
  • Produkttraunasjoner
  • Produkter

Utskrifter

Ved utskrift av ordredokumenter finnes det flere parameter å tenke på når serienr. skal hånteres.

Plukklister

I utskriftsdialogen finnes det en avkryssing i varianter under gruppen Plukking

Du må ikke sette kryss for ”Slå sammen reservasjonslinjer pr. ordrelinje” hvis du samtidig har satt kryss for ”Reserver serienr. ved plukking” fordi du da ikke vil kunne skrive ut de reserverte radene sitt serienr. avkrysningen for Bruk serienr. fra reservasjoner gjelder ikke for Plukkliste som genererer reservasjonslinjene.

Faktura med serienr. fra reservasjoner

I utskriftsdialogen finnes det en avkryssing i tillegg ”Serienr. fra reservasjonslinjer”.

Ved å krysse av her, vil Visma Business skyte inn linjer under ordrelinjene, med serienummer fra tabellen Resvasjoner. Serienumrene blir skrevet ut fortløpende i beskrivelseskolonnen, med mellomrom mellom.

Faktura med serienr. fra serienr. tabellen

I utskriftsdialogen finnes det en avkryssing i tillegg ”Serienr. fra serienr. tabellen”.
Ved å krysse av her, vil Visma Business skyte inn linjer under ordrelinjene, med serienummer fra tabellen Serienr. Serienumrene blir skrevet ut fortløpende i beskrivelseskolonnen, med mellomrom mellom.


Adgangsregulering i Visma Business

Spesialavgift

Dette dokumentet tar for seg hvordan du kan sette opp og få med spesialavgift på fakturaformularet. I følgende eksempel skal det beregnes en miljøavgift på elektroniske produkter, men samme funksjonalitet kan f.eks. benyttes til beregning av frakt etc.

Start med å opprette en tekstkode for "Sumlinje" (Teksttype = 57) og en Tekstkode for "Avgifts- og bokføringsgruppe (Teksttype = 17) som vist under:

(Administrasjon - Bedriftsparametere)

Deretter må du opprette en Avgifts- og bokføringsgruppe for Miljøavgift:

(Administrasjon - Bedriftsparametere)

Feltet "Sp. avg. mva pl." styrer om Miljøavgiften skal være med i mva-grunlaget eller ikke. I dette eksempelet er Miljøavgiften ikke med i grunnlaget.
Feltet "Sp. avg. kode" leder til denne dialogen:

I dette eksempelet velger vi at Miljøavgiften skal beregnes i % av linjebeløp (2). I feltet "Sp. avg. sats/bel." registreres %-satsen eller beløpet for Miljøavgift. Produkter som det skal beregnes Miljøavgift av knyttes så til denne Avgifts- og bokføringsgruppen:

(Administrasjon - Logistikk - Produktopplysninger)

Teksten til sumlinjen "Spesialavgift"hentes fra Teksttabellen. Vi ønsker at fakturaen skal komme med teksten "Miljøavgift". Dette settes opp i Teksttabellen, som vist over (Bilde 1, bytt ut Spesialavgift med Miljøavgift på Teksttype = 57).

Når det nå registreres ordre og faktureres på dette produktet, kommer Miljøavgiften spesifisert på fakturaen:

(Logistikk - Salgsordre - Direkteordre)


Transportavtaler

Beskrivelse

Det som blir beregnet er fraktpris i forhold til vekt på varene. Dette vil også komme frem på formularet.

Når du registrerer en ordre og angir riktig vekt i feltet "Ferdigmeldt vekt", vil frakt 1, 2, 3 eller 4 (avhengig av hva som ligger i Bedriftsopplysninger) automatisk fylles ut. Dette forutsetter at vekten du har lagt inn er innenfor intervallet som er angitt i tabellen Transportsoner. Beløpet i fraktfeltet beregnes ut fra Tonnraten på aktøren og kostnaden på transportsonen.

Se eksempel litt senere i dokumentet…

Tabeller / felter som må fylles ut

2 nye tabeller kreves for å håndtere fraktavtale. Det er tabellene Transportsoner og Transportavtaler.

Transportsoner

Tabeller – Ordre/logistikk – Faste opplysninger

I denne tabellen legger du inn utkjøringskostanden pr. kg. Legg inn fraktsonenummeret i feltet “Sone” og angi “Fom. Vekt” og “Tom.vekt” i kg, samt kostnaden. Denne kosten vil senere bli med på å beregne fraktkostnaden i ordrehode (sammen med angitt tonnrate).

Transportavtaletabellen

Tabeller – Ordre/logistikk – Faste opplysninger

Denne tabellen inneholder transportørens navn, samt kostander for respektive tonnrater 1-4.

I feltet “Transp.avtalenr.” kan du taste + for neste ledige nummer. Legg inn “Lev.nr.” (kan gjøre oppslag mot Aktørtabellen), “Tonnrate 1-4 (i disse feltene legger du inn fastsatte takster for transportavtalen). Du må også angi riktig ”Sone” (her gjør du oppslag mot Transportsonetabellen)

Bedriftsopplysninger

I feltet "Transportavtalebehandling" i tabellen "Bedriftsopplysninger" bestemmer du hva slags fraktbehandling transportavtalen skal ha. Du kan velge mellom Tonnrate og Kostnad.

I tillegg må du fylle ut Frakt 1, 2, 3 eller 4 og riktig Fraktbrevserie.

Aktører/Ordrehode

Feltene “Transportavtalenr.” og “Tonnrate 1-4” kan legges inn på aktøren, eller du kan overstyre det i ordrehode.

Forutsetninger

Hele rutinen forutsetter at det Bedriftsopplysninger er satt opp riktig med hensyn til hvilket fraktfelt som skal oppdateres med fraktbeløpet.

Når det fylles ut en verdi i feltet “Ferdigmeldt vekt”, så beregnes automatisk fraktkostnaden utifra fraktavtalen og verdien fylles ut i feltet “Frakt 1-4”, avhengig av hva som er satt i Bedriftsopplysninger. Feltet oppdateres ved lagring av ordren.

Eksempel
Har lagt inn data i tabellene Transportavtaler og Transportsoner som vist over.
På aktøren har jeg lagt inn verdien 1 i ”Transportavtaler og verdien 2 i feltet ”Tonnrate” (begge feltene er oppslagsfelt).
I ordreregistreringen henter den Transportavtalenr. og Tonnrate fra aktøren. Registrerer videre ordrelinjene jeg ønsker og til slutt legger jeg inn ”Ferdigmeldt vekt” i ordrehode. Idet jeg nå lagrer, beregner den riktig frakt (tonnrate på aktør + kostand på angitt transportsone) i feltet Frakt 1 (2, 3 eller 4).


Generelt

Regnskap

Her finner du tips og gode råd for modulen Regnskap i Visma Business.


Visma Business - Betalingsformidling via ConvertX

Betalingsidentifikasjon/melding til mottaker

Registrering uten KID

  • Feltet ”Ekstratekst” kommer ikke med som melding til mottaker
  • Feltet ”Referanse” kommer ikke med som melding til mottaker
  • Feltet ”Fakturanr” kommer med over som melding til mottaker

Registrering med KID

  • Kun KID blir sendt som betalingsidentifikasjon.
  • Feltet ”Fakturanr.” kommer ikke med over som melding til mottaker.

Tabellen Bankpartner (Tabeller – Regnskap – Betalingsformidling)

Opprett en bankpartner per belastningskonto/valutakonto. For å slippe å lage et betalingsforslag pr. valuta kan du angi Bankpartnernr. på leverandøren. Når du da lager betalingsforslag setter du hake i parameteret ”Benytt bankpartner fra leverandør (kunde)”. Husk å sette opp ”Bruk database forbindelse for ZData” i feltet ”EBF behandling” for at ConvertX skal benyttes.

Tabellen Bedriftsopplysninger (Tabeller – Felles – Fasteopplysninger)

Feltet ”Regnskapsbehandling”

Forklaring på disse parameterene i feltet ”Regnskapsbehandling” i tabellen Bedriftsopplysninger:

  • ”Tillat negative betalinger” = Medfører at det kan remitteres poster som totalt gir negativ betaling. Eksempel: Kreditnota som overstiger faktura. Dette er aktuelt i de tilfeller hvor banken overvåker og motregner kreditnota.
  • ”Ingen debetsaldo ved remittering” = Hvis du krysser av i dette feltet sjekker Visma Business at utbetaling ikke gir debetsaldo på en leverandør. Programmet godtar ikke overføring av transaksjoner til betalingsforslag som medfører at saldoen på leverandøren gir debetsaldo. Det blir gjort kontroll mot betalingslinjer med status 1, 2, 3, 5 og utgående balanse på leverandøren. Betalingstransaksjoner som enda ikke er bokført blir også behandlet. Dette blir kontrollert mot saldo på leverandøren i tabellen Leverandørsaldoer.
  • ”Anvend betalingsbetingelser på kreditnotaer” = Forfallsdato og planlagt betalingsdato blir satt på kreditnota.
  • ”Ikke planlagt betalingsdato på kreditnotaer” = Planlagt betalingsdato blir ikke satt på kreditnota. Ved remittering vil da bilagsdato bli brukt.

Merk: Parametrene ”Anvend betalingsbetingelser på kreditnotaer” og ”Ikke planlagt betalingsdato på kreditnotaer” er gjensidig utelukkende slik at du bare kan velge en av disse.

Bet. frie dager

Her kan du sette hake ved de dagene som er betalingsfrie. Nederst i dialogen kan du bestemme om planlagt betalingsdato skal flyttes til en tidligere dato.

Valg i denne dialogen vil kun bli tatt hensyn til når du bruker en bilagsart hvor det i Bilagsartbehandling er satt hake i Flytt planlagt betalingsdato til arb.dag ved registrering av faktura.

Konto for provisjon / bankgebyr

Hovedbokskonto for provisjon/bankgebyr må du registrere i tabellen Bankpartner (Hovedb. k. gebyr) eller Valuta (Remit. geb. konto). Dersom konto ikke er angitt, som beskrevet, ved generering av bilag for betaling med provisjon / gebyr vil dette havne på feilkonto (9999).

Kreditnota og remittering

  • Kreditnotaen kan aldri være større enn betalingen ved remittering.
  • Kreditnotaen og betalingen kan aldri være lik ved remittering.
  • Begge disse forekomstene vil bli avvist av Z-Data.

Dersom du skal remittere en kreditnota, må kreditnotaen være mindre enn betalingen og feltet ”Planlagt bet. Dato” må være likt på betalingen og kreditotaen.

Du trenger ikke sette opp noe i hverken Bankpartnertabellen eller Bedriftsopplysninger for å få til dette.

DK Melding til Mottaker (kort og lang Advi)

I Bankpartnertabellen og feltet ”EBF behandling” har vi parameteret ”Kort melding til mottaker”. Oppdater til siste versjon av ConvertX (1.4.0.9) fra vår ZData sin hjemmeside.

Det er her gjort noen små endringer i formatene Unitel og DanskeBank.

Generelt gjelder følgende:

Meddelelsestype skal være Langadvis (dette er også default på formatet - kort advis brukes til blant annet lønn og pensjoner).

Dersom du oppretter samletranser skal du benytte tekstkode 100 i felt 51 og i felt 53 legges avsenders navn. De enkelte fakturanr. vil da komme i felt 23-26 og eventuelt felt 54-90. Dette har vi fått oppgitt av banken.

Felt 51 = Tekstkode (3 langt) settes slik:

1) Meddelelsestype = Straks advis medfører at felt 51 = tomt

2) Meddelelse = Lang advis medfører:

a) Dersom samletx og feltet Varslingskode (NtfCd) er ulik tomt eller 0 medfører at felt 51 = Varslingskode

b)Dersom samletx og feltet Varslingskode (NtfCd) er tomt eller 0 medfører at felt 51 = 100 = Fritekst (settes altså av ConvertX som default)

c)Dersom ikke samletx og feltet Varslingskode (NtfCd) er ulik tomt eller 0 medfører at felt 51 = Varslingskode

d)Dersom ikke samletx og feltet Varslingskode (NtfCd) er tomt eller 0 medfører at felt 51 = 160 = Faktura (settes altså av ConvertX som default)

Felt 53 = Kort fri advis (20 langt) settes slik:

1) Meddelelsestype = Starks advis eller Kort meddelelse medfører at felt 53 = tomt

2) Meddelelsestype = Lang advis medfører:

a) Dersom feltet Varslingskode = 100 eller ConvertX har satt felt 51 til 100 (alternativ b for felt 51) og feltet Varslingstekst (NtfTxt) ikke er tom, medfører at felt 53 = Varslingstekst

b) Dersom feltet Varslingskode = 100 eller ConvertX har satt felt 51 til 100 (alternativ b for felt 51) og feltet Varslingstekst (NtfTxt) er tom, medfører at felt 53 = Bedriftsnavn

c) Dersom feltet Varslingskode = 160 eller ConvertX har satt felt 51 til 160 (alternativ d for felt 51) og feltet Varslingstekst (NtfTxt) ikke er tom, medfører at felt 53 = Varslingstekst

d) Dersom feltet Varslingskode = 160 eller ConvertX har satt felt 51 til 160 (alternativ d for felt 51) og feltet Varslingstekst (NtfTxt) er tom, medfører at felt 53 = Fakturanr (InvoNo)

Ellers settes felt 53 = tomt.

Felt 23-26 = Meddelelse line 1 til 4 (4 x 35 langt) settes slik:

Dersom meddelelsestype = lang advis eller straks advis, fylles feltene med innholdet fra feltet Tekstlinje (TxtLn) og dersom dette feltet ikke allerede inneholder fakturanr (InvoNo) legges også dette til.

Ellers settes feltene tomme.

Felt 54-90 = Lang advis tekst, meddelelseslinje 5 til 41 (37 x 35 langt) settes slik:

Dersom meddelelsestype = lang advis eller straks advis og feltet Tekstlinje (TxtLn) +/- et eventuelt fakturanr (InvoNo) er lengre enn felt 23-26, legges resten av meldingen her

Ellers settes feltene tomme.

Alt her i henhold til tilbakemeldinger fra Nordea.

DK Samletranser for danske formater

Dersom parameteren ”Samletranser” skal benyttes på danske formater...

... forutsetter det at krysset for ”Samletransaksjoner” i feltet ”EBF behandling” i Bankpartnertabellen er utfylt:

DK Egenreference

Innstilling for danske formater for hva som skal være tekst på avsenders kontoutdrag. Denne innstilling finner du under parametre for formatet som er valgt på ”Fil til bank”.

Samling av betalingstransaksjoner (ved kreditnota)

Telepay 2.0 tillater remittering av kreditnotaer etter spesielle vilkår. Felles er at telepay ikke tillater kreditnotaer i bunter der summen er 0 eller negativ. Telepay bunter sammen såkalte strukturerte og ustrukturerte transaksjoner på betalingsdato;

  • ustrukturerte transaksjoner er transaksjoner som ikke har KID eller fakturanummer. Dvs. transaksjoner som skrives med melding. (NB! enkelte funksjoner i Visma Business har den effekten at transaksjoner behandles som med melding, selv om den har oppgitt KID og/eller fakturanummer).
  • strukturerte transaksjoner er transaksjoner som har enten KID eller fakturanummer oppgitt.

Ustrukturerte transaksjoner på samme dato til samme mottaker vil havne i en felles bunt, og alle strukturerte transaksjoner på samme dato og til samme mottaker vil havne i en felles bunt. Det vil si at det buntes strukturerte og ustrukturerte transaksjoner hver for seg. Husk at buntene MÅ ha positiv sum, derfor må en kreditnota alltid kunne buntes sammen med en eller flere betalinger som gjør at totalsummen blir positiv (det holder ikke at den blir 0).

ConvertX vil prøve å flytte betalinger på dato for å, om mulig, lage bunter som er positive (dersom ConvertX flytter en transaksjon på dato vil du man få melding om dette). Om ConvertX ikke klarer å lage en positiv bunt vil alle transaksjoner til mottakeren avvises.

Husk altså at ustrukturerte transaksjoner buntes for seg og strukturerte transaksjoner buntes for seg. For å gjøre en transaksjon/kreditnota strukturert, kan du sette på KID eller fakturanummer, den vil så kunne buntes sammen med betalinger med KID (anbefalt). Alternativt kan man sende alt ustrukturert ved å slette KID på betalinger og kreditnota.

Merk: I ZData er fortegnsstillingen snudd, slik at når det er snakk om positiv bunt vil det si at leverandøren har penger tilgode.

Betalingsmottaker avvises dersom:

  1. Det er feil på en kreditnota til mottakeren.
  2. Det er negativ sum til mottakeren. Du vil få følgende feilmelding:
    "Sum oppdrag er negativ (Ustrukturert)", eller "Sum oppdrag er negativ (Strukturert)" i feltet betalingsreturkode.

Denne informasjonen finner du her: http://www.zdata.no/ConvertXVB_Help/Norwegian/Visma_ConvertX_brukerveiledning/TelePay_2_0.htm

Avtalegiro

Ved bruk av avtalegiro og remittering samtidig via ConvertX må det opprettes egen bankprofil (bank) for avtalegiro i ”Oppsett av Converter”. Årsaken til at det må være en egen bankprofil for avtalegiro er at avtalegiro transer blir tatt med i fil for remittering også hvis samme bankprofil blir brukt. Ved eksport av avtalegiro er det viktig at konto blir koblet til rett bankprofil.

Import av avtaler kan fortsatt ligge på samme bankprofil som remittering.

Eksempel

Telepay 2.01

Bankene har innført en ny versjon av sitt betalingsformat (Telepay 2) og dette har følgende praktiske konsekvenser for deg som bruker:

Innlandsremittering

Nå kan du sende både betalinger med KID og kreditnotaer til samme leverandør uten først å slette KID på fakturaen for å få trukket fra kreditnotaen. Informasjon som blir registrert på betalingslinjene i feltet KID-kode (SQL navn CID) og Fakturanummer (SQL navn InvoiceNo) blir nå sendt i samme overføring til leverandøren. Se Telepay 2.0 informasjonen for ytterligere informasjon.

Utlandsremittering

Bruk av ny EBF krever vedlikehold grunndata leverandører.

Tidligere har SwiftAdresse1 vært brukt til å legge inn bankens SortingCode/FW-code. Denne verdien skal nå legges i et eget felt som heter Bankfilial (SQL feltnavn Branch). (Hvis ikke dette feltet finnes hentes det frem). SwiftAdresse1 skal inneholde Bankens navn.

Viktige felter å fylle ut på leverandøren:

  • Felt i Visma
  • Felt i Banken
  • Bankfilial
  • SortingCode/Fedwire
  • SwiftCode
  • SwiftCode
  • SwiftAdresse1
  • Bankens navn
  • SwiftAdresse2, 3, 4
  • Bankens adresse(r)

Kontroll av betalingsdata utland

Banken har også endret kravet til hvordan utlandsbetalinger må utfylles. Betalinger som ikke oppfyller kravet vil enten bli avvist eller bli behandlet manuelt av banken, noe som de fleste banker tar seg godt betalt for. Ny versjon av EBF utfører test mot de fleste krav banker har før betalingene blir sendt til banken. Test som gjennomføres på utlandsbetalinger er følgende:

Betalinger som blir markert som Feil, og må rettes før de kan sendes.

Feilmelding

Felter i Visma (SQL navn i parantes)
  • Ikke utfylt valutakode
  • Fakturavalutakode = ISO kode (ISO) fra Betalingslinjer eller Belastes valutanr (PmtCur) fra Betalingslinjer
  • Leverandørens Navn, adresse eller landkode er ikke utfylt.
  • Navn (Nm) på leverandør fra Aktører, Adresselinje1 (Ad1) på leverandør fra Aktører, Landnr (Ctry) på leverandør fra Aktører.
  • Feil utfylt IBAN nummer (leverandørens bankkonto).
  • Bankkontor (BGiro) på leverandør fra Aktør.
  • SwiftCode og SwiftAdresser er blank
  • Swiftkode (SwftCd) på leverandør fra Aktør, Swiftadresse1 (SwftAd1) på leverandør fra Aktør, Swiftadresse2 (SwftAd2) på leverandør fra Aktør, Swiftadresse3 (SwftAd3) på leverandør fra Aktør og Swiftadresse4 (SwftAd4) på leverandør fra Aktør.

Betalinger blir markert som Advarsel, og bør rettes før de kan sendes.

Advarsel

  • Felter i Visma (SQL navn i parantes)
  • Feil eller ikke oppgitt SwiftCode.
  • Swiftkode (SwftCd) på leverandør fra Aktør.
  • Ikke utfylt bankartkode.
  • Dekl.kode fra Betalingslinjer (DeclCD)
  • Ikke utfylt meldingsfelt til Norges Bank. InfoBank
  • Deklarasjonstekst fra Betalingslinjer (DeclTxt).

Denne informasjonen finner du her: http://www.zdata.no/ConvertXVB_Help/Norwegian/Visma_ConvertX_brukerveiledning/Changes_from_Convert_5_5.htm

Remittering til Plusgiro (Postgiro)

Dersom du ønsker å remittere til Plusgiro (ofte svenske kunder), må du huske på å sette hake i parameteret ”Bruk postgirokonto ved remittering – sv” i feltet ”Lev.pref.”:

Feltet blir brukt i svensk remittering av ZData ConvertX. Plusgiro (Postgiro) blir også brukt på andre formater, derfor må du ikke krysse av i dette feltet hvis du remitterer til andre bankformater enn de svenske.

Dersom du har både Bankgironr. og Plusgironr. (postgironr.) liggende på aktøren, benyttes Bankkontonr. dersom det ikke er hake i dette parameteret.

Merk: Ved betalingsformat Bankgiro der leverandøren har samme Bankgironr. som Plusgironr., tolker ConvertX det som et Plusgironr. selv om det er valgt betalingsformat Bankgiro. Du får da ikke sendt filen som bankgirobetaling.

Dette er løst i ConvertX versjon 1.4.0.8:

For Plusgirot gjelder nå følgende:

Ved remittering til leverandør som ikke har Plusgirotkonto, men en 10-siffret personkonto i Nordea skal dette kontonummer plasseres i feltet Postgiro på leverandøren i Visma Business.

Dette fordi girering til plusgirotkonto og kontoinnsetting til 10-siffret personkonto i Nordea behandles likt.

Utbetalingsanvisning

Dersom leverandøren hverken har Plusgironr. eller Bankgironr. liggende på seg i Aktørtabellen, så vil den få tilsendt en utbetalingsanvisning fra banken dersom du har tatt vekk krysset for ”Remit.hvis gironr.” i tabellen Bedriftsopplysninger:

Betalingen kommer med i Betalingsforslag på vanlig måte, og filen til banken ser ca. slik ut:

Remittering i Valuta

Bilag for betaling i valuta

Ved remittering av faktura i valuta, vil alltid bilag for betalingen bli ført med samme valutakurs som på fakturaen. Dette for at reskontropostene (faktura og betaling) skal gå i null både for beløp i valuta og i egen valuta. Verdien på fakturaen blir målt mot belastet beløp på betalingslinjen og differransen vil utgjøre kursdifferransen (agio/disagio). Provisjon blir ført på konto for bankgebyr, angitt på bankpartner eller valuta, og lagt til belastet beløp slik at dette samlet blir ført ut av konto for bank.

Dekl.kode og Dekl. Tekst

  • ConvertX, versjon 1.4.0.5 eller nyere
  • Versjon 4.60.2 av Visma Business

I Teksttabellen må du legge inn de ulike Deklareringskodene (Dekl.kode). Disse skal registreres på Teksttype lik 131.

Standard Dekl.koder er:

Disse kan du laste ned her

Deretter legger du inn ønsket ”Dekl.kode” på Leverandøren:

Dekl. koden som du legger på Leverandøren vil da bli hentet i Bilagsregistreringen og til Bilagslinjene ved registrering.

Bunten oppdateres.

Åpne poster vil nå se slik ut:

Du lager betalingsforslag på samme måte som tidligere...

Dersom det er Deklarasjonskode på betalingslinjen blir det sjekket om det er registrert Deklarasjonstekst på betalingslinjen. Dersom det er registrert Deklarasjonstekst på betalingslinjen blir denne brukt. Ellers blir Deklarasjonsteksten hentet fra Teksttabellen i henhold til Deklarasjonskode ved eksport av betalinger.

Når du deretter legger ut data, kan du åpne filen som skal sendes til banken å se at "Dekl.kode" ligger der med korrekt Deklarasjonstekst, hentet fra betalingslinjen eller teksttabellen.

Eksempel på fil til banken:

SE Remittering i valuta

Formatet BankGirot (SE) kan ikke brukes til utenlandsk remittering, kun innland.

For remittering til utlandet brukes SISU_BGC (SE) dersom avsender remitterer fra et bankgirotnummer og sender filer via BGC eller SISU_SEB (SE) dersom avsender remitterer fra et 11-siffret kontonummer og sender filer direkte til SEB.

OCR retur

Det er nå mulig å importere både OCR retur og avregning av betalinger i samme fil via ConvertX, siden begge blir lest via formatet ”AutoDetect”.

Dialog for betalingsforslag

Dersom det kun er registrert en bankpartner i tabellen bankpartnere vil denne bli foreslått i feltet Bankpartner.

Er det registrert flere bankpartnere vil det ikke bli foreslått bankpartner i dialogen. Du må velge hvilken bankpartner som skal bli brukt.

Alternativt kan du registrere bankpartner på leverandør (aktør) og i dialogen sette hake på ”Benytt bankpartner fra leverandør (kunde)”. Det vil da bli generert betalinger i henhold til bankpartnere registrert på leverandører som er utvalgt ved generering av betalingsforslag.

Hvis du samtidig velger bankpartner i dialogen kan du også sette hake i ”Produser betalinger kun for valgt bankpartner”.

Overvåking av kreditnotaer

For å stille inn hvor mange dager banken skal overvåke en kreditnota før de sender den tilbake settes opp i Visma Business. ( I tidligere versjoner satt man dette i Converteren).

Dette hentes ikke lenger fra ConvertX, men i fra Visma Business:

Det kan settes på 2 måter:

  1. Fra feltet Kreditnota forfallsdager (CNtDy) på Betalingslinjene
  2. Fra feltet Std. kreditnota forfallsdager (CNtDy) på Bankpartner

Trusted Connection

ConvertX kan kjøre med Trusted Connection og SQL Autentisering.

Dersom Trusted Connection skal benyttes, fjerner du ”Login” og ”Passord” i oppsettet i ConvertX, men har hake i ”Overstyr innstillinger fra Visma Business” og angir riktig ”Server”.

(Oppsett – Oppsett og fane Database)

Dersom SQL Autentisering skal benyttes, setter du også hake i ”Overstyr innstillinger fra Visma Business” og angir riktig ”Server”. I tillegg må du legge inn ”Login” = sa og ”Passord” = passordet på sa brukeren

Dersom du ønsker å benytte en annen bruker enn sa, angir du denne brukeren under ”Login” og tilhørende Passord.

Gjenoppbygg KID (KID konvertering)

  1. For å få KID behandlet settes felt Gjenoppbygg KID = Ja
  2. Filter benyttes hvis ikke alle KID felt skal gjenoppbygges. Eksempelvis et bestemt kontonummer eller KID felt av en bestemt type.
  3. I felt orginal KID deles KID feltet opp i de deler en trenger i ny KID definisjon. Hver del oppgis i lengde (antall karakterer) på feltet, og hver del skilles med parantes [] og semikolon som skille.
  4. I ny Kid feltet må en angi både deler og lengde på hver del som skal skrives. Del 1 fra orginal KID blir definert som 0 i ny KID osv. Lengden på delen oppgies etter kolon. Hver del i ny kid skilles med semikolon og omgies med parantes [].

Eksempel:

KID 003014650106600 (tre første sifre betyr intet, 6 neste er fakturanr, 5 neste er kundenr og siste siffer er modulus 10.
Original definisjon: [3];[6];[5];[1]
Ny definisjon: : [1:6];[2:5]

Innbetaling+ (Cremul)

Problemstilling:
Forskjellig lengde på fakturanr. i KID og meldingsfelt på Innbetaling+ poster. Dette skyldes foranstilt 0 i fakturanr.

Det er lagt ut ny versjon av 1.7.0.5 (10.10.2006) for nedlasting på Zdata.no, Last ned, Visma, Visma Business.

For å få testet på fakturanr. med forskjellig antall siffer i forhold til lengde i KID kan du i Oppsett av Converter, Oppsett, Oppsett, Innbetaling+ og "Se etter ekstra fakturanr. i tekst med lengde" sette antall tegn som fakturanr. vanligvis inneholder i meldingsfelt.


Fakturamottak

Elektronisk betalingsformidling

For å ta i bruk elektronisk betalingsformidlinger er det en del innstillinger du må gjøre både i Visma Business og i oppsettet av Z Data Converter.

Teknisk

Installasjon og innstilling av Z Data Converter er beskrevet i hjelpefilen til Z Data og blir ikke omtalt her. I dette dokumentet finner du noen punkter som kan være greit å vite.

Registry

Kommunikasjonen mellom Visma Business og Z Data foregår via Registry. Suksessfaktoren for kommunikasjonen er at "Prog_Path" til de to programmene finnes.

Visma Business sin "Prog_Path" finner du normalt under HKEY_CURRENT_USER – Software – Visma - Visma Business – CurrentVersion - Miscellaneous.

Z Data Converter sin "Prog_Path" finner du alltid under HKEY_LOCAL_MACHINE – Software - Z Data - Converter.

"Prog_Path" til Z Data Converter blir aktivert under installasjon. Hvis ikke får du denne feilmelding ved utlegging av data fra Visma Business.

ZData.imp

Grunnen til at "Prog_Path" må finnes er at når vi legger ut data fra Visma så skal vi legge dette ut på et bestemt format som konverteren (Z Data) skal konvertere. Dette formatet er bestemt i filen "ZData.imp". Du må derfor aldri endre noe i denne filen. "ZData.imp" ligger under "Imp-katalogen" til Visma Business. Hvis filen "ZData.imp" ikke finnes, vil dere få samme feilmelding som vist over ved utlegging av data fra Visma.

Merk: Oppgradering av Z Data Converter og ZData.imp. For de som ikke oppgraderer konverteren, men kun Visma Business, se tabellen under for å benytte riktig ZData.imp:

Hvis det ligger feil ZData.imp inne, vil du få feilmeldingen "Feil i tegnseparert: Manglende/feil utfylt Transtype" når du prøver å legge ut data.

Setup.ini

Når Z Data Converter er installert og satt opp, vil du få en fil som heter "Setup.ini". Denne ligger på området hvor Z Data Converter er installert. I denne filen ligger alle stier og "settinger" som gjør at konverteringen til og fra fellesformatet går bra. Denne kommer vi tilbake til senere.

Installasjon på terminalserver

Under en installasjon av Z Data på en terminalserver, er det i hovedtrekk to ting du må ta hensyn til. Det er "Install/execute"-modus og "PayInit.exe".

Når du starter installasjonen, gjør du dette på terminalserver. Men sørg først for at du står i installeringsmodus før du starter installasjonen. Dette gjør du ved starte en "Dos"-kommandoboks hvor du skriver kommandoen ”Change user /Install” og trykk "Enter". Gjennomfør installasjonen av Z Data som beskrevet i installasjonsdokumentet.

Etter at installasjonen er ferdig, går du tilbake til vanlig ”brukermodus” på terminalserveren ved hjelp av kommandoen ”Change user /execute”. Denne kommandoen kjører du også fra en "Dos"-kommandoboks.

Når installasjonen av Z Data er ferdig, må du på lik linje med vanlige klient/server installasjoner, kjøre "PayInit.exe". Men til forskjell fra ”vanlige” installasjoner, der du må kjøre "PayInit.exe" på alle klienter, gjør du dette en gang på terminalserveren. Når du kjører "PayInit.exe" blir verdien av programstien skrevet til

Hkey_local_machine\software\Zdata\converter

i Registry på terminalserver. Når terminalklientene logger seg på, vil denne nøkkelen leses og gi informasjon om hvor alle filer skal ligge.

Rettigheter

Sørg for at alle brukere av Z Data har lese- og skriverettigheter til Z Data Convert katalog på server, samt lese- og skriverettigheter til

Hkey_local_machine\software\Zdata\converter

i Registry på terminalserver. For lite rettigheter gir feilmeldingen: ”Ukjent feil i convert.exe”.

Innstillinger i Visma Business

Opprett Z Data Converter i tabellen "Bankpartnere". Du må fylle inn feltene

  • Bankpartnernr (tast + for tildeling)
  • EBF System lik 99 Z Data Converter
  • Kundenr i banken

I utgangspunktet kan du remittere alle åpne leverandørposter som har ”Prioritet” ulik 8 eller 9. Posten kan være satt til unntas remittering ved velge verdi 9 i feltet ”Prioritet”. Hele leverandøren kan også unntas remittering ved å sette ”Remitteres ikke” i feltet ”Leverandør Preferanser” på leverandøren.

Remittering til utland

Remittering av utenlandske betalinger krever flere opplysninger enn innenlandske transaksjoner, f. eks valutakode og valutakurser. Du må derfor sette en hake for ”Utenlandsremittering” i feltet ”Leverandørpreferanser” på aktøren for å angi at dette er en utenlandsk aktør. Da blir automatisk riktige felter lagt ut. Du må selvsagt fylle inn riktige verdier i disse feltene selv. Valutakode og valutakurser hentes automatisk fra den åpne posten. Enkelte opplysninger er ikke alltid påkrevd, men blir registrert ved behov. Disse er nevnt under.

Om mottaker eller avsender skal betale omkostningene blir bestemt i feltene "Innl.omk" / "Utenl.omk" i tabellen "Betalingslinjer". Standard verdi som blir lagt ut fra Visma Business er BEN/OUR.

Omkostningene betales av leverandør = BEN.
Dersom vi skal betale = OUR.
Ønsker du å dele, kan du slette OUR i utenlandske omkostninger.

Deklarasjonskode og Deklarasjonstekst

Når beløpet er over en viss størrelse krever Norges Bank at det ligger med ”Betalingsartkode” (Deklarasjonskode) og en tekst som forklarer hva beløpet gjelder (Deklarasjonstekst). Dette skal du legge inn i feltene ”Dekl. kode” og ”Dekl. tekst” i tabellen ”Betalingslinjer”. Det betyr at du må lage et betalingsforslag først for så å redigere i tabellen ”Betalingslinjer” før du legger ut data.

”Dekl.kode” og ”Dekl.tekst” med gyldige koder som du kan hente frem under betalingslinjer oppretter du i tabellen "Tekster". "Dekl.kode" er teksttype 131. "Dekl.tekst" må du manuelt registrere på betalingslinjen, (evt. bruk utfyllingsregler med fast kode og tekst).

IBAN

(International Bank Accunt Number) er det nye formatet for bankkontonummer som blir brukt i EU. IBAN nummeret skal du legge i feltet ”Bankkontonummer” på leverandøren. Det forutsettes at det er krysset av for utenlandsremittering. IBAN vil ikke gjelde på betalinger som sendes innenlands.

Enkelte land trenger tilleggsopplysninger til IBAN. Det er en bankkode (Sort Code, BLZ, Branch Code, Clearing Code eller AT). De forskjellige land har forskjellig betegnelse på bankkoden. Det må du registrere i feltet bankforbindelser i Visma Business. Tyskland bruker BLZ, mens England bruker Clearing code.

BIC

Bank Identifier Code er en unik adresse i SWIFTadresseregisteret for en bank, også kalt SWIFTadresse. SWIFT-koder og adresser fyller du inn i feltene ”Swiftkode” og ”Swiftadresse 1” til ”Swiftadresse 4” på leverandøren.

Flere belastningskonto

Visma Business benytter belastningskonto fra tabellene "Bankpartnere", "Valuta" og "Bedrifts-opplysninger" i nevnte rekkefølge. Ønsker du å remitere fra flere bankkontoer oppretter du en ny linje i bankpartnertabellen med Z data Converter som ”EBF system”. Legg inn samme kundenummer i bank, men med annet bankkontonummer.

Du velger hvilke bankpartnernummer (belastningskonto) som skal benyttes i dialogen som fremkommer når du lager betalingsforlag.

Merk: Foreløpig er det kun ”Belastes bankkonto” du kan velge å ha flere av i tabellen "Bankpartnere". Feltene ”Hovedb. Bank” og ”Hovedb. Gebyr” er foreløpig ikke i bruk.

Dette forutsetter at ikke feltet "Bankkonto" er fylt ut i tabellen "Valuta".

Når bankkonto blir hentet fra tabellen "Bankpartnere" fylles ikke feltet ut på betalingslinjene før du har lagt ut filen. Når bankkonto blir hentet fra tabellene "Valuta" eller "Bedriftsopplysninger" fylles bankkonto inn på betalingslinjene.

Kontantrabatt

Registrere du et bilag med betalingsbetingelse som kvalifiserer for kontantrabatt, blir feltene ”Kontantforfallsdato” og ”Kontantforfallsbeløp” oppdatert. Remitteres denne posten før kontantforfallsdato blir kontantbeløpet automatisk brukt. Kontantrabatt og avmerking av reskontro skjer automatisk etter at du har mottatt retur på belastningen.

Utfordring med belastningsdato

Lager du betalingsforslag og sender dette til remittering før kontantforfallsdato, er det kontantforfallsbeløpet som blir benyttet. Bankene har forskjellig praksis på hvor ofte de henter remitteringsfiler. Hvis du fra Visma Business har sendt fil innenfor kontantforfallsdatoen, men banken henter filen dagen etter, blir belastningsdato utenfor kontantforfallsdato - altså den dagen banken henter din fil. Ved bokføring av bilaget blir ikke posten riktig avmerket. Dette kan vi ikke lage løsning for i Visma Business. Kundene må påse at de legger ut filen slik at den er hos banken før kontantforfallsdatoen.

MVA på kontantrabatt bokføres på feil dato

Eksempel: Posten blir belastet i bank 28.02.03, men du henter først returfilen fra banken 01.03.03. Reskontropostene får dato 28.02.03, mens automatposteringene (mva og kontantrabatt) får dato 01.03.03. Det medfører at MVA-reduksjon blir tatt i 2. termin, mens den i realiteten tilhører 1.termin på MVA-oppgaven. Dette har vi endret i versjon 4.50 slik at det er dato på bilagslinjen som initierer kontantrabatten som blir dato på de automatgenererte transene. Tidligere var det valuteringsdato på retur fra remittering som ble dato på automatpostene som blir generert ved oppdatering av bunt.

Remitteres leverandør

Feltet ligger på leverandøren og benyttes dersom betalingen skal skje til en annen enn leverandøren. For eksempel hvis det er en kjede hvor all betaling skjer til hovedkontoret. Da oppretter du hovedkontoret som leverandør og legger inn dette leverandørnummeret i feltet ”Remitteres leverandør” på de leverandørene hvor betaling skal skje til hovedkontoret.

Det er viktig å legge inn hovedkontorets bankkonto på leverandøren som er opprettet som ”hovedleverandør” ettersom bankkonto hentes fra remitteres leverandør og ikke hver enkelt leverandør. I versjon 4.0x er det en feil, der hentes bankkonto fra hver enkelt leverandør og ikke remitteres leverandør. Det er rettet til 4.10.

Betalingsbetingelsene hentes fra ”Remitteres leverandør”. Du kan krysse av for ”Ikke kopiert fra remitteres lev.” i leverandørpreferanser (fra versjon 4.50). Det medfører at betalingsbetingelser hentes fra opprinnelig leverandør og gjelder kun fra ordremodulen. Registrerer du inngående faktura i vanlig bilagsregistrering gjelder ikke dette valget.

Du trenger ikke å legge inn ”Remitteres leverandørnr” for factoring. Factoringselskapet er egentlig ikke vår leverandør. Her trenger du kun å legge inn factoringselskapets bankkontonr i feltet ”Bankkontonr” på opprinnelig leverandør.

Delbetaling

Ved å sette inn beløp i kolonnen ”Delbetaling” får du remittert deler av åpen post. Viktig at du setter negativt beløp her, ellers anser ikke systemet det som en betaling.

Da restbeløpet skal betales vises ikke posten i vinduet for Betalingsforslag. Dette på grunn av at posten har fått X i kolonnen Remittert, dermed er det lett å glemme denne posten ved neste remittering. Vi har ikke endret dette i skjermbildeoppsettet pr 4.40.3

Du må manuelt hente opp den åpne posten på leverandøren og sletter X i remittert. Vi har lagt inn ønske om at krysset remittert ikke skal settets før posten er helt betalt.

Ved innlesing av returdata blir delbetalingen matchet mot opprinnelig faktura og restbeløpet blir redusert. Du må være oppmerksom på at du må slette verdien i feltet ”Delbetalt” på den åpne posten før du skal lage betalingsforslag neste gang. Ellers blir kun det delbetalte beløpet foreslått remittert og ikke restbeløpet. Vi arbeider med en løsning for å få en annen behandling av dette.

Kreditnota

”Hovedregel” er at en bør forsøke å oppdatere reskontro løpende. Det vil si at du avmerker kreditnotaer mot fakturaer fortløpende ved registrering. Hvis du ikke ønsker å avmerke kreditnota mot faktura, men ønsker å sende postene over til remittering enkeltvis bør du endre ”Planlagt betalingsdato” og ”Forfallsdato” på kreditnotaer til samme forfall som fakturaen du sender over.

Er kreditnota høyere enn faktura (pr leverandør) blir i utgangspunktet posten ikke remittert. Du vil da få meldingen ”En eller flere leverandører har negative betalinger” ved utlegging av filen. Du kan hake av i feltet ”Tillat negative betalinger” i feltet ”Regnskapsbehandling” i Bedriftsopplysninger. Da er det ikke test/kontroll på om betalingen er positiv eller negativ. Det gjelder ikke Telepayformatet. Selv om du tillater negative betalinger fra Visma Business, godtar ikke Telepay negativ betaling pr leverandør pr dag pr valuta. Da vil få denne meldingen fra Z Data Converter.

Ingen debetsaldo ved remittering

Du må ikke forveksle dette med ”Tillat negative betalinger”. Dette er en kontroll du kan slå på for å ikke få produsert debetsaldo ved remittering.

Eksempel:
Du har faktura på kr 2000,-, og en kreditnota på kr 500,-. Hvis du velger kun å utbetale faktura står du igjen med en debetsaldo på kr 500,-. Har du haket av for ”Ingen debetsaldo ved remittering” vil det ikke bli laget noe betalingsforlag i dette tilfelle da det er en debetsaldo på leverandøren. Det sjekkes på hele reskontroen til leverandøren og finnes en debetsaldo innenfor forfall blir denne fanget opp. Dette blir gjort for å unngå å utbetale faktura hvis det ligger en kreditnota som ikke er matchet.

Omkostninger/Provisjon

Før versjon 4.40 tolket vi omkostninger/provisjon mottatt fra bank som norske kroner uansett om det var valuta eller ei. Det er endret slik at vi nå benytter valuta og valutakursene også på omkostninger/provisjon hvis banken har lagt ut omkostninger i valuta.

Melding til mottaker

Det finnes to typer meldinger til mottaker i Telepayformatet.

Den ene er mottakers referanse og den andre er varsling via telefaks/teleks.

I den tekniske beskrivelsen av Telepay-formatet står det at KID ikke kan brukes sammen med mottakers referanse.

Default blir KID nr sendt som melding til mottaker. Hvis KID nr ikke er utfylt kan du bruke feltet ”Fakturanummer” i tabellen "Betalingslinjer". Dette feltet er alfanummerisk, og dersom du fyller ut noe her, vil mottaker få beskjed. Du kan derfor ikke få sendt både KID og egen melding på samme transaksjon.

Hvordan legge ut poster til elektronisk remittering

1. Lag betalingsforslag

Det gjør du fra tabellen ”Åpne leverandørposter”. Marker de postene du vil remittere og gå på behandlingsmenyvalget ”Lag regnskapsbunt”. Når dette er gjort vil det bli dannet en linje som legger seg i tabellen ”Betalinger”. Postene legger seg i tabellen ”Betalingslinjer”. De får ”Betalingsstatus og ”Betalingslinjestatus” lik ”1. Forslag”. Lar du være å markere postene i tabellen ”Åpne leverandørposter”, og du har satt på at den skal ”Behandle alle radene” under ”Fil” / ”Utskriftsformat”, dannes det et betalingsforslag med transaksjoner som har ”Planlagt betalingsdato” som ligger innenfor det du valgte i ”À jour pr. dato”.

Kriteriet for at posten skal bli med i et betalingsforslag er at det finnes et bankkontonummer på aktøren og at det ikke er satt at posten ”Ikke skal remitteres” under prioritet. Ved å gjøre de nødvendige utvalgene og sorteringen i tabellen ”Betalingslinjer” kan du lage deg et utskriftsbilde over betalingsforslagene. Du kan redigere enkelte andre felt i tabellen ”Betalingslinjer” før utlegging av data. Det kan for eksempel være felter som ”Bankkonto”, ”KID-kode” eller ”Melding til mottaker”.

Er det poster som du ikke vil skal være med på denne betalingen er det bare å markere aktuell rad og slett denne. Krysset som ble satt i feltet ”Remittert” i tabellen ”Åpne leverandørposter” når du laget betalingsforslaget, blir opphevet etter lagring av den slettede raden.

2. Legg ut data

Når betalingsforslaget er godkjent og funnet i orden står du til tabellen ”Betalinger” og velger ”Legg ut data” fra behandlingsmenyvalget. Fil til remittering blir dannet og ”Betalingsstatus” og ”Betalingslinjestatus” blir endret til ”2. Overført”. Hvis det nå skulle være nødvendig å legge dette ut på nytt igjen kan du endre status tilbake til ”1. Forslag” å velge ”Legg ut data” på nytt igjen. Dette må ikke gjøres når ”bankfilen” fysisk er oversendt banken. Legg her merke til at kreditnotaer som er større en sum faktura pr leverandør ikke blir sendt hvis du ikke har krysset av for dette i ”Bedriftsopplysninger”.

3. Retur fra bank

Når ”bankfilen” fysisk er oversendt banken er det bare å vente på mottaksretur eller avregningsretur. Når dette har kommet fra banken må du stå i tabellen ”Betalinger” og velge ”Hent returdata” fra behandlingsmenyvalget. Avhengig av hva du henter vil nå ”Betalingslinjestatus” ha enten status ”3. Kvittert” eller ”5. Avregnet”. For de transaksjonene som eventuelt for status ”7. Avvist” må du slette disse linjene fra tabellen ”Betalingslinjer”, gjøre endringen, lage et nytt betalingsforslag og sende dette på nytt igjen.

4. Bokfør betalinger

De transaksjonene som har fått status ”5. Avregnet” er nå klar for bokføring. Tipset her er å lage et bokføringsbilde hvor du tar utgangspunkt i tabellen ”Betalingslinjer” og setter utvalg på ”Betalingslinjestatus”. Utvalget bør da være lik verdi ”5. Avregnet”. Det kan også være lurt å sortere på ”Betalingsnummer” og ”Linjenummer”. Dette fordi ved mottak av avregningsretur kan denne inneholde avregninger fra flere betalinger. Alle transaksjonene i et betalingsoppdrag bør heller ikke ha fått status ”5. Avregnet”. Dette fordi transaksjonen ikke har forfalt enda. Ved å lage et bokføringsbilde som nevnt sikrer en seg for å bokføre transaksjoner som ikke har annen status enn ”5. Avregnet”. Dette er mulig fordi utenlandske banker sender verken tilbake mottaksretur eller avregningsretur. Visma må derfor ha mulighet til å bokføre fra andre statuser. Når vi nevner utenlandske banker her mener vi ikke de utenlandske transaksjonene som du sender via en norsk bank. Det vi mener er de av dere som remitterer direkte mot en utenlandsk bank. Når du skal lag regnskapsbunt står du i tabellen ”Betalingslinjer” og velger ”Lag regnskapsbunt” fra behandlingsmenyen. Det som nå skjer er at det blir opprettet en bunt med tilhørende bilagslinjer som du manuelt må oppdatere.

Hvor legger filene seg ved utlegging

Feltet ”Fil til bank” i oppsett av Z Data Converter angir område hvor Visma Business legger ut sine remitteringsfiler. Filen er en tekstfil og blir lagt ut på format "FraXXXX.dat" fra Visma Business. (XXXX er klientnummer). Z Data Converter tar tak i denne filen og konverterer den til Telepayformat. Filnavnet etter konvertering blir det du angir i ”Fil til bank”. Samtidig blir "FraXXXX.dat" omdøpt til "FraXXXX.bck".

Kjører du remittering for flere klienter vil du få spørsmål under utlegging om du skal legge ut for flere klienter. Svarer du ”Ja” til dette blir "FraXXXX.dat" for klienten du nettopp la ut liggende på området. Legg så ut neste klient. Spørsmålet om du skal remitere for flere klienter kommer så opp igjen. Nå ligger det to "FraXXXX.dat" på området (en pr klient). Når du svarer ”Nei” til remittering av flere klienter starter Z Data Converter og konverterer og slår samme disse to fra-filene til en Telepay fil. Det er denne som blir sendt til banken.

Denne dialogen er endret fra versjon 5.6.04 av Z Data Converter. Hvis det ligger "FraXXXX.dat" fra flere klienter vil du nå få opp en dialog som viser en liste over klientene som har produsert "FraXXXX.dat"-filer som ikke er sendt til banken. Du må hake av for hvilke klienter du ønsker å slå sammen i denne forsendelsen.

Innlesing av returfiler

Ved innlesing av retur er det AH-koden i returfilen som bestemmer om det er en kvittering-, avvisning- eller avregningsretur.

Ved innlesing av kvitteringsretur endrer ”Betalingslinjestatus” til ”3. Kvittert”. Posten er da ikke behandlet i banken, men du har fått kvittering på at banken har mottatt den.

Ved innlesing av avvisningsretur får du oversikt over hva som er feil. Det avhenger av hvilke type feilkoder som ligger i returfilen. Den avviste posten får "Betalingslinjestatus 7 Avvist”. Du må korrigere og sende posten på nytt.

Innlesing av avregningsretur endrer ”Betalingslinjestatus til 5. Avregnet”. Denne skal du lage bokføringsbilag av for å få postert betalingen og avmerket reskontroen.

Splitting av klientfiler ved innlesing

Kjører du remittering fra flere klienter på samme installasjon kan du få retur fra disse samlet fra banken. Det er ”Belastet bankkontonummer” på returtransaksjonen som avgjør hvilken klient posten forsøkes leses inn til i Visma Business. Filen ”setup.ini” som ligger på område hvor Z Data Converter er installert holder styr på dette. Ved remittering av flere klienter har du krysset av for ”Aktiver klient” i oppsett av Z Data Converter. Det gjør at det dannes en seksjon i setup.ini som inneholder opplysninger om hvilken klient som har hvilken belastningskonto. Setup.ini nedenfor viser at klient 9998 har belastningskonto 11113344443 og klient 9999 har belastningskonto 11112233336.

[Setup Visma Klient]
Klient 1 KontoNr=11113344443
Klient 1 Avdeling=9998
Klient 2 KontoNr=11112233336
Klient 2 Avdeling=9999
Antall Klienter=2
Aktivert Klient=1

Setup.ini blir oppdatert med disse opplysningene når du legger ut data.

Feilsituasjoner

Heng ved Lag betalingsforslag

Sjekk hva som står i kjørenr under "Endre tellere" i BO. (behandlingsmenyvalget). Hvis det nummeret som står der allerede eksisterer i "Betalingsnr" i tabellen "Betalinger", får du heng. De må endre til et høyere nummer. Det vil si et nummer som ikke har vært i bruk.

Utlegging

"Error in ascii-file name or layout file. Ascii-file cannot be sent". Denne feilmeldingen kan tyde på flere ting. "Progpath" på Visma Business og "Programpath" på Registry til Z Data Converter kan være feil definert. Sjekk at filen "Zdata.imp" ligger under "Imp"-katalogen til Visma Business. Mulig belastningskonto mangler i valutatabellen/Bedriftsopplysninger. Det kan også være at brukeren ikke har skriverettigheter til område hvor setup.ini ligger. (På området hvor de midlertidige "FfraXXXX.dat"-filene ligger).

Innlesing

"Error in format for payment line, ref.nr. QXX" (XX består av referansenr oppbygd av betalingsnr og betalingslinjenr). Meldingen forteller at Visma Business ikke finner tilhørende betaling/betalingslinjer i Visma Business. Det skyldes som regel at de har endret/slettet i betalinger/betalingslinjer etter å ha sendt over filen til banken. Det ligger en referanse i Telepay-filen pr transaksjon (QXX) som henviser til tabellene ”Betalinger” og ”Betalingslinjenr” på hver transaksjon. Denne må være identisk i ”Betalinger”/”Betalingslinjer” som på returtransen. Vi anbefaler at du bokfører returtransen manuelt hvis det er feil med betalingslinjenummeret. Sett transaksjonen til avregnet manuelt. Hvis det er utenlandsremittering må du ta hensyn til valutakurs/agio manuelt.

Det kan være problematisk å henvise til UNC-path i ”Fil fra bank” i Z Data Converter. Får du feilmeldingen ”Finner ikke filen \\server\server1\” ved innlesing av returdata og filen fysisk finnes på dette området omgår du problemet ved å mappe opp og legge inn ”mappet” henvisning i ”Fil fra bank”.

Dersom statusen ikke endrer seg fra Overført til Kvittering/Avregning ved innlesing av retur, kan årsaken være at det ligger feil i setup.ini

[Setup Visma Klient]
Klient 1 KontoNr=1111.22.33336
Klient 1 Avdeling=20--------------------------------> slik, det er feil.

[Setup Visma Klient]
Klient 1 KontoNr=1111.22.33336
Klient 1 Avdeling=0020 ----------------------------> slik må det ligge.

Hvis firmanummeret er F0020.

Valuta

Telepayformatet opererer med 3 kursfelter:

  • Avtalt kurs
  • Reel kurs
  • Kurs mot NOK

Visma Business bruker disse i nevnte rekkefølge ved innlesing av avregning: Hvis det ligger noe i ”Avtalt kurs” benyttes denne, hvis ”Avtalt kurs” er blank benyttes ”Reel kurs”. Hvis ”Reel kurs” er blank benyttes ”Kurs mot NOK”. Vi har hatt en utfordring hvis belastningskont er en valutakonto og betalingens valuta er ulik bakkontoens valuta. Da ble ikke riktig kurs-felt benyttet og du fikk feil agio beregnet. Dette er rettet i 4.30.3. Hvis betalingen er i valutakontoens valuta blir det riktig.

Remittering av kunder

Mulighet for å betale kreditnotaer til kunder elektronisk kom til versjon 4.40. Det er samme funksjonalitet og fremgangsmåte som gjelder for leverandører. I feltet ”Kundepreferanser” angir du om det er utenlandsk kunde.


Installation of Z Data server or Citrix

Installation of Z Data Terminal server or Citrix

Z Data have to be installed on the server (host), default folder will be

.\Visma\Business\Convert.

Using the same setup.ini for all users

Then you have to initialize Z Data on the terminal server as one of the logged on users. Use the same path as Visma Business to find the PayInit.exe and double click on it.

Then you can start the converter form Visma Business, This will initialize the SETUP.INI file and you can now enter the different file paths and banks.

1. Upload data
2. Download data
3. Setup of Converter

If the Setup of Convert does not start you have to check the registry settings.

HKEY_LOCAL_MACHINE\Software\Z DATA AS\Convert
PROGRAMPATH "C:\Program Files\Visma\Business\Convert"

You now have to maintain settings inside the Converter regarding bank format and file paths.

Using a user specified Setup.ini deepening on User logon

To use this setting you need Visma Business version 4.01.2 and Z Data Converter version 5.4.1. or higher.

By default will all parameters that controls start of Z Data form Visma Business be located in registry entry HKEY_LOCAL_MACHINE/Software/Z DATA AS/Converter.

Visma Business will find Convert.exe by reading the string PROGRAMPATH By moving the key to HKEY_CURRENT_USER/Software/Z DATA AS/Converter you can have different Setup.ini and file path depending on the logged on NT-user.

As a option you can add a key FILEPATH Convert.exe will use the to find the SETUP.INI where the bank system and customer details are for each logon user. By default Z Data is using the start up directory to locate SETUP.INI.

In the File path folder you also have copy the Program file witch is the license file for Z Data. The PayInit.exe will not write this information, so that has to be don manually, and then to be sure you must delete the registry key Z DATA AS under

HKEY/LOCAL_MACHINE/Software

File paths

It is of importance that this files are placed on a folder were the Terminal user have access and they can not be placed on the local machine. (Terminal user). We recommend that you use the same folder for all the files that are produced.

FraNNNN.dat (Output file form Visma Business where NNNN is the firm no.)
Result.zdt Report file for the Converter of total transferred and a backup of Result.bck the previous file
Resultditails.zdt Report file for the Converter of each transaction transferred and
Resultditails.bck a backup of the previous file
feildetails.zdt Error log from the Converter
[ToBank.txt] The result file form Converter to bank. Filename from setup
[FromBank.txt] Return file from the bank to Converter.
TilNNNN.dat File from converter to Visma Business


Kan ikke sende ASCII fil

ASCII file can not be sent

Ved utlegging av data fra Visma Business, kan denne feilmeldingen forekomme:

“Ascii file can not be sent”

Grunnen til dette er som oftest fordi en transaksjon mangler bankkontonummer. Fra og med versjon 4.01 så må bankkontonummeret ligge i Aktørregistret. I tidligere versjoner ble bankkontonummer hentet fra tabellen Åpne poster.

Sjekk derfor dette:

• At bankkontonummer ligger via underliggende tabell Aktører – Levnr.
• At bankkontonummer ligger på Betalingslinjene
• At bedriftens bankkontonummer ligger i Valutatabellen

• At det ikke er krysset av i ”Remitteres ikke” i Lev.pref
• At debetbeløpet (evt. kreditnotaer) ikke overstiger kreditbeløpet

Er det noe av dette som mangler/må endres, så fyll det ut og foreta ny Utlegging av fil til bank.
Mulig du må fylle ut bankkontonummer på Betalingslinjene selv om du kjører versjon 4.01, fordi transene er fra tidligere versjoner.


Regular expressions og KID konvertering

Konvertering av KID

Konvertering av KID

KBA-01116

Formål

Denne artikkelen forklarer hvordan man går frem for å sette opp KID konvertering i ConvertX 1.9 og senere versjoner. I denne versjonen er vanlig form for KID konvertering fjernet til fordel for ConvertX sin interne "mapping"-rutine for å konvertere og evt. sette sammen data-felter. Denne er vesentlig kraftigere og mer fleksibel, om enn noe vanskeligere å sette opp da den benytter "regular expressions" for å beskrive når og hvordan KID skal gjenoppbygges. Her følger en kort introduksjon til hvordan et enkelt oppsett kan defineres.

Fremgangsmåte

  1. Åpne oppsettet til ConvertX.
  2. Velg importen som man ønsker KID konvertering på og velg 'Rediger import'.
  3. Velg "Legg til parameter'/'add parameter".
  4. Velg "Mapping".

Nå har man fire felter

  • Fields: Her skal man liste alle feltene man vil ha med i "mapping"-en, atskilt med semikolon.
  • Conditions: Her skal man liste alle krav som må være oppfylt for at "mapping"-en skal skje, kravene følger feltene man har definert i "Fields", altså må krav til felt 1 definert i "Fields" komme først i listen. Kravene skilles med semikolon.
  • Expression: Hvordan den resulterende "mapping"-en er bygget opp, altså et uttrykk som beskriver oppbyggingen av "mapping"-en. Alle deler i oppbyggingen adskilles med paranteser, altså er (<uttrykk>)(<uttrykk>)(<uttrykk>) 3 deler.
  • Template: Hvordan verdien skal bygges opp igjen, altså hvilke deler resultatet skal bestå av. ($1 = del 1, $2 = del 2 osv.). Dersom man ønsker "Modulus" riktig resultat kan man bruke funksjonene "MOD10" eller "MOD11" bak uttrykket.

Dette forklares best med et par eksempler

Eksempel 1: "KID"-konvertering dersom "SAccount1" er et spesielt kontonummer, f.eks. 12345678901. De to første sifrene i "KID"-en skal fjernes.

  • Fields: SAccount1;CID. "CID" skal konverteres dersom "SAccount1" har en verdi angitt i "Conditions".
  • Conditions: 12345678901. "CID" skal kun konverteres dersom "SAccount1" = 12345678901.
  • Expression: (12345678901)([ ]?)([0-9]{2})([0-9]*). Siden "mapping"-en inkluderer kontonummer og "KID" blir disse to feltene satt sammen for et samlet løsningssett. Men vi vil ikke ha kontonummer med i den nye "KID"-en derfor definerer vi kontonummeret som del 1, (12345678901), ([ ]?) blir del 2, og de 2 første sifrene i "KID"-en blir del 3, ([0-9]{2}), resten blir del 4, ([0-9]*).
  • Template: $4MOD10. Bestemmer hvilke deler vi vil ha med i den nye "KID"-en. I dette tilfellet skal det kun være del 4, uten kontonummer og minus de to første tegnene i den originale "KID"-en. "MOD10" indikerer at vi vil ha et resultat som er modulusriktig.

Eksempel 2: Kid konvertering dersom "KID" er en bestemt lengde. For eksempel for å fjerne foranstilt klientnummer fra enkelte "KID"-er.

  • Fields: CID;CID. "Mapping" fra/til "CID".
  • Conditions: [0-9]{16}. Skal kun skje dersom "CID" er 16 lang.
  • Expression: ([0-9]{4})([0-9]{12}). Deler "CID" i 2 biter, en på 4 (klientnummer) og en på 12 tegn ("KID").
  • Template: $2. Vi skal kun skrive del 2.

Ekstra kommentarer

Merk at alle felter i betalingsfilen i de fleste tilfeller kan benyttes som triggere og elementer i "KID"-konverteringen. Ta kontakt med Z Data AS om det er behov for spesielt tilpassede løsninger.


Overgang_Vbus510_og_EBF2200

Overgang Visma Business 5.10 og Visma Bank 2200

Generelt

Alle innstillinger som tidligere var i Oppsett ConvertX og BankX er nå flyttet over i Visma Business. Dette har åpnet for større fleksibilitet på bruk av både remittering ogt lesing av innbetaling. Nå kan behandlingsregler både på remittering og innbetalinger settes pr. konto, noe som tidligere ble satt pr. installasjon av ConvertX.

ConvertX er oversatt til Finsk.
Finnes nå på følgende språk: Norsk, Dansk, Svensk, Finsk og Engelsk.

Innbetalinger

  • Henter original faktura ved innsetting i bunt selv om betaling skjer av purringer generert fra dokumentkopier
  • Flere KID definisjoner på samme konto, innlesing av KID generert i eksternt system. Tidligere KID konverteringer gjøres nå direkte på KID definisjonen i factoringtabell
  • Nytt valg "Bruk motref. tabell på innbetalinger". Ved betaling av flere fakturaer oppdateres motref. tabellen. For betalinger via OCR (en referanse) settes motreferanse direkte på bilagslinjen som før
  • Henter kontonummer fra den åpne posten der hvor KID definisjon inneholder bare fakturanummer
  • Kontroller at konto finnes hvis KID definisjon kun inneholder kundenummer

Remittering

  • Nytt valg for brukeradgang via brukeradgangstabell. Bruk av dette løser problemet med tilgang til for mange firmaer fra remittering
  • Gebyrhåndtering har eget valg som settes slik banken bokfører gebyr (Inkl./Egen/Ingen, Gebyr i valuta)
  • Oppretting av betalingsbunt fra avregningsretur tar nå høyde for inntil 3 ulike valutaer. Fakturavaluta, Betalingsvaluta og Firmavaluta. OBS! Hvis firmavaluta <> NOK og belastningsvaluta vil kursen regnes om i forhold til kursene i valutakurstabellen. Hvis ikke kurs ifnnes på bankens avregningsdato vil nærmeste dato bli brukt. Hvis ikke dato finnes vil det gis melding. (ExternRef2 på bilagslinjen)

Avstemming

  • Oppsett av alle visninger (kolonner) lagres nå pr. bruker
  • Slått sammen menyvalg for Avstemming og Kontogrupper. (Nytt valg har beholdt navnet Avstemming)
  • Starte automatisk avstemming fra vinduet for manuell avstemming (CTRL+ALT+A)
  • I vinduet for manuell avstemming, kan du nå holde musepekeren over et felt for å se hele teksten dersom denne ikke får nok plass i feltet
  • Forhåndsvisning av importfil i notisblokk
  • Nye farger i programmet, mer i samsvar med "Nordic Cool"

Administrasjon - Systemopplysninger - EBF Oppl.

(Menyreferanser peker til nye skjermbilder som er laget for versjon 5.10)
OBS! Parametere med * (stjerne) som settes i system (vbsys), vil gjelde alle klienter tilhørende denne systemdatabasen. De andre parametrene er bare standardverdier som brukes ved opprettelse av nye klienter. Disse parametrene finnes enten per kontooppsett eller per bedrift.

Dokumentasjon innlesing av innbetalinger Visma Business versjon 5.10

Nyheter

1. Behandling av dokumentkopier på purringer

Oppsett: Kryss for Purringer, samt legg inn egen bilagsserie i purrebrevbilagsserie. (Husk å legge inn fra - til nummer).

Innlesing: Hvis oppgitt KID er innenfor purrebrevserien, hentes riktig fakturanummer (motref) fra den åpne posten ved innsetting på bilagslinjen.

2. Ulike KID definisjoner på en og samme konto

Hvis ulike KID definisjoner på en og samme konto, må bankkonto fylles ut i factoringtabellen.

Se under for utfylling.

Administrasjon - Bedriftsparametere - Reskontro - Import/Eksport - OCR/KID

** Utfylling av KID-kode behandling

Betalingsformidling
Administrasjon - Bedriftsparametere - Reskontro - Betalingsformidling


Remittere fra flere konti

Nå har du mulighet for å remittere fra flere konti i Visma Business (4.30).

For å få til dette må du opprette like mange Bankpartnere i Bankpartnertabellen som det du ønsker å ha som belastningskonti å remittere fra.

Eksempel:

Når du nå skal lage betalingsforslag, får du følgende valg under Bankpartner i dialogen ”Lag betalingsforslag”:

Du velger da den kontoen du vil dette betalingsforslaget skal belastes fra.

NB! Foreløpig er det kun ”Belastes bankkonto” du kan velge å ha flere av i Bankpartnertabellen. Feltene ”Hovedb. Bank” og ”Hovedb. Gebyr” er foreløpig ikke i bruk...

NB! Dette forutsetter at ikke Bankkonto er fylt ut i Valutatabellen.


Utenlands betalinger SISU

Utlandsbetalningar SISU

Vid utlandsbetalningar skall vissa uppgifter om varje betalningspost finnas i filen. Dessa uppgifter registrerades i fälten EBF 1-4 vid användandet av den gamla EBF:en. Nedan följer en beskrivning av dessa och förslag på lämpliga fält i ”Betalningsrader”. Jag har testat lite att registrera i EBF1-4 och värde i EBF 3 följer med till Dekl.kod och även vidare ut till SISU-filen så den är OK. Övriga EBF-fält följer inte med till någon kolumn i Betalningsrader. Jag har dessutom testat att lägga värden i lite olika fält i Betalningsrader, men de påverkar inte heller värdena i SISU-filen.

Det skulle vara intressant att se var i filen ”fra****.dat” som resp fält i betalningsrader läggs ut. Man skulle då enkelt kunna instruera för zdata-programmerarna vad som skall hämtas till resp fält i filen.

Kolumn i OpSupTr

Kolumn i BPmtLn

Max tkn i fil

Övriga kommentarer

EBF 1 - Valutakonto

Finns ej

(Hittar inget med lämplig benämning)

1

Vilket konto skall belastas för betalningen?

0 = SEK-konto..

1 = Valutakonto belastas. Registrera 1 i denna kolumn.

EBF 2 – Avgiftskod

Utl.omk

(AbCst)

1

Vem skall betala bankens remitteringsavgifter för uppdraget?

0 = Alla avgifter betalas av avsändaren. Sätts default.

1 = Expressavgifter betalas av mottagaren. Registrera 1 i denna kolumn.

2 = Alla avgifter betalas av mottagaren. Registrera 2 i denna kolumn.

EBF 3 – Riksbankskod

Dekl.kod

(DeclCd)

Kommer med från Öppen post redan idag.

3

Registrera riksbankskod för betalningen.

EBF 4 – Betalnings-metod

Finns ej

(Ev. bet.rad-behandling

(PmtLnPro) men det hänger ju ihop med andra fält)

1

Välj betalningsmetod.

0 = Normalbetalning.

1 = Expressutbetalning. Registrera värde 1 i denna kolumn.

2 = Koncerninbetalning. Registrera värde 2 i denna kolumn.

Filformatet som vi historiskt använder oss av är Bankgirots SISU-layout. Alla det stora affärsbankerna använder sig av detta format, men med lite små variationer i främst fälten för Avgiftskod (EBF 2) och Betalningsmetod (EBF 4). Nedanstående beskrivning gjorde för den gamla EBF:en

S-E-Banken

Beskrivningen ovan gäller S-E-Banken.

Test och godkännande av betalning till S-E-Banken är utförd 980205.

Föreningssparbanken

· Kolumnen EBF 2 – Avgiftskod använder sig Föreningssparbanken enbart av värdet 0 eller 2.

0 = Alla avgifter betalas av avsändaren.

2 = Mottagaren betalar avgiften.

· Kolumnen EBF 4 – Betalningsmetod har värdet 2 en annan innebörd än hos S-E-Banken.

0 = Normalbetalning. Säts default.

1 = Expressutbetalning.

2 = Betalning med check.

Test och godkännande av betalning till Föreningssparbanken är utförd 980217.

Nordbanken

· Kolumnen EBF 2 – Avgiftskod. Nordbanken ignorerar värde i denna kolumn. De behandlar alltid betalningen så att avsändaren står för svenska kostnader och mottageren för de utländska.

Test och godkännande av betalning till Nordbanken är utförd 980217.

Handelsbanken

· Kolumnen Bankkonto/giro. Handelsbanken önskar att man anger sortcode i detta fält. Syntaxen för sortcode hos Handelsbanken är; SCXXXXX, BLXXXXXX eller FWXXXXXX. (Fältet skall inte inledas med //.)

· Kolumnen Swiftadress 1. Handelsbanken vill i första hand ha swiftadress till banken eller klartext på bankkontorets namn och adress på maximalt 30 tecken.

· Kolumnen EBF 2 – Avgiftskod. Handelsbanken använder enbart kod 0 eller 2. Kod 1 används inte.

Test och godkännande av betalning till Handelsbanken är utförd 980302.


Altinn

Altinn generelt (kun for Norge)

Generelt

Altinn er en portal, et felles nettsted for innlevering av offentlige skjemaer på Internet. Altinn er et samarbeid mellom flere offentlige etater som innhenter data fra bedrifter og privatpersoner.
Grunntanken bak Altinn er at offentlige skjemaetater samarbeider om å lage en felles kanal for innrapportering til det offentlige i stedet for å lage hver sin løsning.
Altinn gjør det mulig å levere skjemaløsninger til brukerne med forhåndsutfylling av informasjon myndighetene allerede kjenner, for eksempel grunndata fra Enhetsregisteret i Brønnøysund og kontroll av data mot Det sentrale folkeregisteret.
Altinn muliggjør større grad av samordning og forenkling for brukerne, ved at myndighetene ikke spør brukerne om de samme opplysningene flere ganger.
Du kan lese mer om Altinn på internettsiden "www.altinn.no"

Altinn i Visma Business

I Visma Business kan du eksportere følgende skjema til Altinn:

  • Omsetningsoppgave (Momsrapport)
  • Du får kjørt ut momsrapport til Altinn ved å velge "Skriv ut" i Regnskap/Regnskapsrapporter/Omsetningsoppgave, eller velge "Skriv ut i tabellen Avgiftsterminer.

Forutsetninger

Formular

For å få skrevet ut riktige data til Altinn krever det at du velger riktig formular i utskriftsparametere. Formularet lager også en papirkopi av omsetningsoppgaven, som er underlaget til filen du sender til Altinn.
Formularet må inneholde XML tagger i Formularlinjene i kolonnen ”XML tag”.

NB! Formularelementer med XML tagger må ha følgende verdier i kolonnene
Desimal = 0, Desimaltype = 1 og Elelmentbehandling = 1.
Dersom du har formular for Omsetningsoppgave som ikke har ”XML tagger” må du importere nytt formular. Formularet er tilgjengelig for forhandlere på Forhandlerlounge :
Ordinær omsetningsoppgave m XML tagger
Før du importerer dette formularet må du slette formular med formulartype 2 og formularnummer 1 (Avgiftsoppgave / Omsetningsoppgave).

Organisasjonsnummer

For at du skal få kjørt rutinen Altinn må du ha registrert riktig organisasjonsnummer i tabellen Bedriftsopplysninger.

Bedriftsnavn

I tabellen Bedrifter må det ligge riktig firmanavn i henhold til navnet for org.nr. som er registrert i Brønnøysund.

Registrering av programfil

I mappen ..\Visma\Business ligger det en fil (VismaAIE.dll) som må registreres.
Dette gjør du enklest ved å trykke Start, Kjør og i feltet Åpne skrive inn: regasm.
I utforsker finner du filen ..\Visma\Business\VismaAIE.dll og drar denne ned til Åpne linjen i Kjør. (Eksempel: regasm "C:\Program Files\Visma\Business\VismaAIE.dll") Klikk OK.

Alternativt kan du lage en cmd fil, med innhold som vist under, som må kjøres fra programkatalog for Visma Business.

Filnavn: VismaAIE_RegAsm.cmd
Innhold:
%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe VismaAIE.dll /unregister
%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe VismaAIE.dll
Pause

Meldingsformatfiler

Fil for meldingsbeskrivelse finner du på Skattedirektoratets hjemmeside under http://w2.brreg.no/oppgaveregisteret/spesifikasjon_skjema.jsp?skjemanr=212
Der ligger spesifikasjonsfilen for omsetningsoppgave: Eks. ( ”melding-212-7266.xsd (05.12.2007).
NB! Bruk alltid ferskeste meldingsformatfil.
Denne skal lastes ned og legges i programmappen for Visma Business. Om du ikke får sendt melding kan dette skyldes at du ikke har riktig meldingsspesifikasjon..
NB! Kontroller spesielt at filen får .XSD som filendelse.

System-ID og skjema nr. (tabellen Altinn)

Du må legge inn System-Id og Passord i tabellen Altinn. I kolonnen System-ID må du registrere System-ID du får tildelt fra Altinn og i kolonnen Altinn skjema nr. kan du gjøre oppslag og velge 212 (RF-0002) eller 213 (RF-0004). Passord må du legge inn via Behandling og Endre passord. Se beskrivelse av tabellen Altinn.

Registrere datasystem i Altinn for innsending av Omsetningsoppgave

Hvis du skal sende inn omsetningsoppgave til Altinn må du registrere datasystem som skal sende inn til Altinn. I nedtrekksmenyen må du velge Visma Business slik at du får tildelt SystemID. SystemID blir da ulik på alle kunder hvor det er registrert bruk av Visma Business.
Merk! Noter System-ID og passord slik at du har dette når du skal legge inn verdiene i tabellen Altinn i Visma Business.

Passord for Altinn (tabellen Altinn)

Du må legge inn passord for Altinn slik at Visma Business kan legge ut riktig informasjon vedrørende innsendingen til Altinn. Passord legger du inn via menyen Behandling i tabellen Altinn.
For informasjon om passord kan du se Hjelp og ”Del 1 - Innlogging og rapportering” på Altinn - Hjelp.

For Regnskapskontor (Byrå)

Hvis regnskapskontoret er registrert som regnskapsfører for selskapet i Brønnøysund. Kan regnskapskontoret registrere bruk av Visma Business og få tildelt SystemID. Da vil denne SystemID være gyldig for alle kunder (Juridiske enheter i Brønnøysund) som regnskapskontoret er registrert regnskapsfører for.
Hvis du skal sende en omsetningsoppgave via Altinn for en bedrift du ikke er registrert som regnskapsfører for må du i Altinn registrere Visma Business som datainnsender og får ny SystemID hver gang.

Skrive ut Omsetningsoppgave til Altinn

Når du skal skrive ut momsrapporten må du gjøre følgende:

  • Stå i tabellen Avgiftsterminer eller i Omsetningsoppgave under Regnskapsrapporter
  • Velg riktig formular i feltet "Formularnr." under Fil / Utskriftsformat / Utskriftsparametere
  • Skriv rapporten til skriver ved å klikke på ikonet "Skriv ut". Hvis du skriver til fil, får du ikke en korrekt rapport til Altinn
  • Når du har valgt "Skriv ut" får du opp dialogen Avgiftsoppgjør, hvor du må krysse av i feltet "Lag Altinn data"

Feltet "Lag Altinn data" ikke tilgjengelig

Hvis feltet "Lag Altinn data" ikke er tilgjengelig i dialogen Avgiftsoppgjør, har du ikke opprettet en rad i tabellen Altinn. Da må du gjøre følgende:

  • Velg behandlingsmenyvalget "Testforbindelse" i tabellen Altinn
  • Registrer "System ID" og "Altinn skjema" i tabellen Altinn
  • Opprett passord med behandlingsmenyvalget "Endre passord" i tabellen Altinn

Her leser du mer om "Altinn"

Her leser du mer om "Tabellen Altinn"

Innsending av Omsetningsoppgave til Altinn

Dette gjør du fra tabellen Altinnlogg (Visma Business Utforsker, Tabeller, Regnskap, Altinn). Sjekk at ”Altinn skjema nr” (212 / 213) og ”Altinn skjema spek” (7266) er fylt ut. Dette skal normalt bli utfylt av Visma Business ved generering av rad fra Omsetningsoppgave.
Marker raden for oppgaven som skal sendes inn og velg Behandling og Send.
Du må deretter logge på Altinn for å godkjenne den innsendte oppgaven. Det er også mulig å slette innsendt oppgave.

Fil for omsetningsoppgave til Altinn

Altinndata legger seg i filen Altinnxxxx.xml (xxxx er et nummer), under mappen Program Files/Altinn. Altinndata er et internformat som du kan endre før du sender det til Altinn-portalen.

Feilmeldinger

Feilsøking

Hvis du ikke registrerer riktige verdier får du opp en feilmeldilng. Du kan få mer informasjon om feilen ved å slå på loggen for feilsøking.

  1. Gå inn i Regedit
  2. Velg HKEY_LOCAL_MACHINE\SOFTWARE\Visma\Altinn
  3. Sett DWORD til "Debug Level"
    • 0 - Ingen logg
    • 1 - Lav logg (noen interne feil blir logget)
    • 3 - Medium logg (DEBALL.LOG blir opprettet, input data og noen resultater blir logget)
    • 7 - Høyt nivå (tilbakemelding fra Activeforms webservice blir logget)
    • 15 - Full logg (de fleste intern kontroller blir logget)

  4. Loggfiler blir lagret på programkatalogen for Visma Business og får filnavn Altinn.log og debAl.log

Feilmeldinger med forklaring

Altinn returnerer i dette tilfelle at meldingsformatfil 3622 skal brukes. Når den ikke eksisterer i business-katalogen får du feilmeldingen over.

Altinn returnerer i dette tilfelle at meldingsformatfil 0 skal brukes. Feilmeldingen kom når Altinn var nede.

Feilmeldingen over skyldes at org.nr (participantID) i bedriftsopplysninger er lagt inn med tekst (NO MVA).

Etter for mange forsøk med feil passord får du meldingen over. Du må logge inn på altinn og låse opp igjen kontoen.

Når feil meldingsformatfil benyttes får man denne feilmeldingen i Altinn.

Feilmelding ved overføring til Altinn:

Årsaken er at det ikke er definert rett format i formularet for omsetningsoppgave vedrørende tusenskilletegn, desimalskilletegn og desimaler på linjer med XML tagger. Se Formular

Regedit parameter (kun nødvendig for test og i pilotperiode)

Altinn har en portal for test og en portal for drift. Du kan avgjøre hvilken portal du skal kjøre mot. Det gjør du i Regedit under HKEY_CURRENT_USER\Software\VISMA\VISMA BUSINESS\CurrentVersion\Miscellaneous. Her setter du ALTINN_TEST til 1, da kobler Visma Business opp mot test portalen. Dette gjøre du kun under feilsøking og i pilotperioder.
Dette fordrer at sertifikat blir godkjent i brannmur.
Dersom Altinn_test er satt til 1 så fungerer ikke Test fra Altinn logg tabellen.

Altinn (kun for Norge)

Tabellen inneholder informasjon for å få oversendt data til Altinn.

Behandlingsmenyvalgene i tabellen

Endre passord

Altinn krever et passord og det oppretter du ved å velge "Endre passord". Passordet kan inneholde 16 tegn i versjon 4.60 og 8 tegn i versjon 4.50. Her registrerer du passordet som er registrert i Altinn.

Testforbindelse

Behandlingsmenyvalget Testforbindelse kan du bruke for å sjekke at det er forbindelse til Altinn.
Behandlingsmenyvalget Testforbindelse må du også bruke for å opprette ny rad i tabellen Altinn.

Tabellen Altinn (kun for Norge)

Forklaring til feltene i tabellen Altinn.

Altinn skjema nr.

Feltet blir automatisk oppdatert med Altinn skjemanummer fra tabellen Altinn, når du skriver ut momsrapporten og har krysset av i feltet "Lag Altinn data".

Altinn skjema spek.

Feltet blir automatisk oppdatert når du skriver ut momsrapporten og har krysset av i feltet "Lag Altinn data".

Altinn status

Feltet blir automatisk oppdatert med aktuell status for rapporten hos Altinn, når du velger behandlingsmenyvalget Status.

Arbeidsflytreferanse

Feltet blir automatisk oppdatert med arbeidsflytreferanse fra Altinn, når du velger behandlingsmenyvalget Status.

Arkivreferanse

Feltet blir automatisk oppdatert med arkivreferanse fra Altinn, når du velger behandlingsmenyvalget Status.

Avsenders ref.

Feltet blir automatisk oppdatert med avsender sin referanse fra tabellen Altinn, når du skriver ut momsrapporten og har krysset av i feltet "Lag Altinn data".

Buntnr.

Feltet blir automatisk oppdatert med buntnummer, når du skriver ut momsrapporten og har krysset av i feltet.

Dato

Feltet blir automatisk utfylt med dagens dato når sender momsoppgaven til Altinn.

Filnavn

Feltet blir automatisk utfylt med filnavnet du skriver momsrapporten til. Feltet blir oppdatert når du skriver ut momsrapporten og har krysset av i feltet "Lag Altinn data".

Godkjenningsreferanse

Feltet blir automatisk oppdatert med godkjenningsreferanse fra Altinn, når du velger behandlingsmenyvalget Status.

Kid kode

Feltet er ikke i bruk.

Melding

Feltet blir automatisk oppdatert med en melding fra Altinn, når du velger behandlingsmenyvalget Status.

Meldingstype

Feltet blir automatisk oppdatert med en meldingstype fra Altinn, når du velger behandlingsmenyvalget Status.

Mottakers referanse

Feltet blir automatisk oppdatert med mottakers referanse fra Altinn, når du velger behandlingsmenyvalget Status.

Nr.

Feltet blir automatisk oppdatert med nummeret fra tabellen Altinn, når du skriver ut Momsrapporten og har krysset av i feltet "Lag Altinn data" i Utskriftsformat.

Periode

Feltet blir automatisk utfylt med periode, når du skriver ut Momsrapporten og har krysset av i feltet "Lag Altinn data" i Utskriftsformat.

Sendt tidspunkt

Feltet blir automatisk utfylt med tidspunktet du sender Momsoppgaven til Altinn.

År

Feltet blir automatisk utfylt med året du sender Momsoppgaven til Altinn

Returkoder

/* Retcodes */
#define ALTINN_RETCODE_ERR -1
#define ALTINN_RETCODE_OK 0

#define ALTINN_RETCODE_TRUST_FAILURE 2
#define ALTINN_RETCODE_CONNECTION_FAILURE 3
#define ALTINN_RETCODE_CONNECTION_CLOSED 4
#define ALTINN_RETCODE_PROTOCOL_ERROR 5
#define ALTINN_RETCODE_TIMEOUT 6
#define ALTINN_RETCODE_UNKNOWN_ERROR 7
#define ALTINN_RETCODE_NAME_RESOLUTION_FAILURE 8
#define ALTINN_RETCODE_CONNECTION_OK_BUT_INTERNAL_ERROR 10
#define ALTINN_RETCODE_ERROR_LOADING_INTERN_XML 20
#define ALTINN_RETCODE_SCHEMA_NOT_FOUND 30
#define ALTINN_RETCODE_NOT_VALID_SCHEMA 31
#define ALTINN_RETCODE_ERR_BUILDING_SCHEMA 32
#define ALTINN_RETCODE_NO_SCHEMA_RECEIPTS 33
#define ALTINN_RETCODE_ERR_CHECKING_SCHEMA_VERSION 34
#define ALTINN_RETCODE_ERR_BUILDING_SCHEMA_PATHAND_FILE 35
#define ALTINN_RETCODE_SCHEMAFILE_NOT_FOUND 36
#define ALTINN_RETCODE_NOTHING_TO_SEND 40

/* Retcodes for Batch status */
#define ALTINN_RETCODE_STAT_OK RETCODE_OK
#define ALTINN_RETCODE_STAT_ACCESS_DENIED 100
#define ALTINN_RETCODE_STAT_FORMAT_ERROR 101
#define ALTINN_RETCODE_STAT_VALIDATION_ERROR 102
#define ALTINN_RETCODE_STAT_ALLREADY_EXISTS 103
#define ALTINN_RETCODE_STAT_DOES_NOT_EXIST 104
#define ALTINN_RETCODE_STAT_GENERIC_ERROR 105
#define ALTINN_RETCODE_STAT_INTERNAL_ERROR 106
#define ALTINN_RETCODE_STAT_NOT_DEFINED 110
#define ALTINN_RETCODE_AUTHORIZATION_FAILED 120
#define ALTINN_RETCODE_UNKNOWN_SECURITY_TYPE 200
#define ALTINN_RETCODE_NO_STRUCT_REFERENCE 300
#define ALTINN_RETCODE_INVALID_STRUCT_SIZE 301
#define ALTINN_RETCODE_NO_BATCHID_SPECIFIED 1101


Avskrivning av driftsmidler

I versjon 4.50.4 er det gjort en endring i rutinen for avskrivning av driftsmidler. Hensikten med denne endringen er at tillegg/oppskrivninger som er ført på respektive driftsmidler blir bokført med en egen driftsmiddelbehandling ved avskrivning. Tillegg/oppskrivning vil da følge den levetid som er satt opp på driftsmidlet. Dersom et driftsmiddel er satt opp med 5 år og det gjenstår 2 år fra opprinnelig avskrivning når det blir ført et tillegg, så vil tillegget bli avskrevet over 5 år fra dato for anskaffelse av tillegget.

Tidligere har mange justert avskrivningssatsen på driftsmidlet for at driftsmidlet skal være i 0 når levetiden på opprinnelig anskaffelse er nådd. Dersom du skal få til dette i dag kan ikke driftsmidlet bli ført med driftsmiddelbehandling 2 eller 3, men med 1 (Anskaffelse). Dersom avskrivningssatsen justeres så vil det da fungere som tidligere.

For kunder som har benyttet denne måten må ”Driftsmiddeltransaksjonene” korrigeres ved oppgradering til versjon 4.50.4 eller høyere. Dette kan du gjøre ved hjelp av et SQL skript. Et eksempel på et slikt skript kan være:

update proptr
set Vogr1 = propprc

update proptr
set propprc = 1
where propprc = 2

update proptr
set propprc = 1
where propprc = 3

Dette skriptet setter Bilagsgruppe 1 = Opprinnelig Driftsmiddelbehandling. Dette fordi da kan de transaksjoner som opprinnelig var ført med driftsmiddelbehandling = 2 eller 3 spores tilbake. I tillegg settes Driftsmiddelbehandling = 1 på alle transaksjoner som har Behandling = 2 eller 3.

Merk: Etter skriptet er kjørt så må driftsmiddelsaldoene regenereres. Merk også at det ikke har vært skilt på avskrivninger tidligere slik at alle avskrivninger på driftsmiddelbehandling 7 blir satt til 9 Avskrivning på anskaffelse.

Script for korrigering av driftsmiddelbehandling med tanke på saldoliste.

update proptr
set Vogr1 = propprc

update proptr
set propprc = 9
where propprc = 7

Dette skriptet setter Bilagsgruppe 1 = Opprinnelig Driftsmiddelbehandling. Dette fordi da kan de transaksjoner som opprinnelig var ført med driftsmiddelbehandling = 7 spores tilbake. I tillegg settes Driftsmiddelbehandling = 9 på transaksjoner med driftsmiddelbehandling = 7 slik at saldoliste vil vise riktig avskrivning for kolonnen Avskrivning på anskaffelse.

Sum avskrivninger finner du i kolonnen Sum avskrivninger i saldotabellen.

Merk: Etter skriptet er kjørt så må driftsmiddelsaldoene regenereres. Merk også at det ikke har vært skilt på avskrivninger tidligere slik at alle avskrivninger på driftsmiddelbehandling 7 blir satt til 9 Avskrivning på anskaffelse.


Valutakurs justering

Valutakursjustering i Visma Business

I dette dokumentet vil vi gi en innføring i bruk av valutakursjustering vist med eksempler. Hensikten med valutakorreksjon er å justere valutaposter i henhold til aktuell kurs ved rapporteringstidspunkt for å få et så riktig regnskap som mulig.

Grunndata

I tabellen ”Valutakorreksjoner” angir du konteringsregler for kalkulerte kursdifferanser. Legg inn kontoer for gevinst / tap i balansen og resultatregnskapet. Du kan ha flere rader for samme kontotype med forskjellige kontointervall.

Tabellen ”Valutakurser” bør vedlikeholdes. Ved en kursregulering pr. en bestemt dato vil programmet velge valutakurs etter:

  1. Dagens kurs
  2. Seneste angitte kurs før reguleringsdato
  3. Kurs angitt i valuta tabellen

I ”Bedriftsopplysninger” er det to nye felt hvor du kan angi maksimalt akseptert kursdifferanse i % og beløp, samt for bilagsserie til bruk ved postering av kursdifferanser.

Nye felter og behandlingsmenyvalg i transaksjonstabellene

  • Hovedbokstransaksjoner
  • Kundetransaksjoner
  • Leverandørtransaksjoner

· ”Valutakorreksjonskurs” viser seneste korrigeringskurs. Feltet oppdateres allerede ved opprinnelig oppdatering av bilag og fylles da ut med opprinnelig valutakurs.

· ”Valutakorreksjonsbeløp” viser seneste ”Valutakorreksjonskurs” x ”Bokført beløp i valuta” i hovedbokstransaksjoner. På reskontrotransaksjoner viser feltet ”Seneste Valutakorreksjonskurs” x ”Restbeløp i valuta”.
NB! Ved kalkuleringen av feltet i hovedbokstransaksjoner tar programmet høyde for transaksjoner som påvirkes av mva-fratrekk hvor ”Bokført beløp” viser beløp eksklusiv mva. ”Beløp i valuta” viser beløp i valuta inklusive mva. Feltet oppdateres allerede ved opprinnelig oppdatering av bilag og fylls da ut med opprinnelig beløp.

· ”Valutakorreksjons dato” viser dato for seneste kursregulering.

· ”Valutakorreksjons kjøring” er ett unikt kjørenummer som gis for hver Valutakorreksjonsskjøring

· ”Siste Valutakorreksjons beløp” viser senest kalkulerte kursdifferanse.

Behandlingsmenyvalget ”Valutakorreksjon” overfører og rekalkulerer utvalgte eller markerte transaksjoner til den nye tabellen ”Valutakorreksjons data”. Her kan det være lurt å gjøre flere korreksjonsskjøringer etter utvalg, f. eks. pr. valuta, pr. kontogruppe eller lignende.

Ny tabell: ”Valutakorreksjonsdata”

er en ren kladdetabell som viser hvilket resultat en kursregulering vil gi.

Feltbeskrivelser:

· Bilagsjournalnr og rev nr: Utgjør tabellens primærnøkkel og kopieres direkte fra transaksjonstabellen.

· Kontonr, Valutanr, og Valutakurs kopieres direkte fra transaksjonstabellen.

· Beløp kopieres fra feltet ”Beløp i valuta” i hovedbokstransaksjonstabellen, eventuelt justert med mva.-beløp omregnet til valuta etter opprinnelig kurs.
For kunde- og leverandørtransaksjoner blir beløp kopiert fra ”Restbeløp i valuta”.

· Bokført beløp kopieres fra ”Bokført beløp” i tabellen hovedbokstransaksjoner og tilsvarende ”Restbeløp” i kunde- / leverandørtransaksjonstabellene.

· ”Korreksjonskurs” viser senest brukte reguleringskurs og kopieres fra transaksjonstabellen.

· ”Korreksjonsbeløp” kopieres fra transaksjonstabellen og viser seneste regulert beløp.

· ”Korreksjonsdato” viser dato for aktuell korreksjonskjøring.

· ”Ny korreksjonskurs” viser reguleringskurs for aktuellt reguleringsdato, hentet fra valutakurs- eller valutatabellen etter kriterier beskrevet ovenfor.

· ”Nytt korreksjonsbeløp” viser nytt beløp etter regulering.

· ”Siste korreksjonsbeløp” viser kalkulert kursdifferanse fra forrige regulering.

· ”Differanse %” viser %-differanse ved aktuell regulering.

· ”Beløpsdifferanse” viser beløpsdifferansen i standard valuta ved aktuell regulering.

· ”ABS Differanse %” viser %-differanse ved aktuell regulering med positivt fortegn.

· ” ABS Differanse beløp” viser beløpsdifferansen i standard valuta ved aktuell regulering med positivt fortegn.

· ”Akkseptert” viser et ”x” om ” ABS Differanse %” og ” ABS Differanse beløp”, ligger innenfor grensene for maksimal kursdifferanse angitt i ”Bedriftsopplysninger. Feltet kan redigeres manuelt og må være avhuket med et kryss for å kunne oppdatere transaksjonstabellene med nye korrigerte verdier og for å lage Korreksjonssbilag.

· ”Kontotype” viser kontotypen for konten som finns på linjen.

· ”Status” inneholder et bit-verdi som forteller om kontoen er en resultat- / eller balansekonto og om posten har ”x” i akseptert eller ikke.

Behandlingsmenyvalg: ”Oppdater valutakorreksjoner”

Returnerer nye verdier til transaksjonstabellenes felter ”Valutakorreksjonskurs”, ”Valutakorreksjonsbeløp” , ”Valutakorreksjonsdato”, ”Valutakorreksjonskjøring” og ”Siste valutakorreksjonbeløp”.

I tillegg blir det dannet en Bilagsbunt etter de regler som er satt opp i valutakorreksjonstabellen for oppdatering av valutagevinst eller valutatap.

Praktisk eksempel:

I dette eksempelet kan du oppdatere en leverandørfaktura bokført 01.01.2004 på 100 €, til kurs 8,34.

Start med å registrer valuta og valutakurser som vist under:

Registrer og oppdater leverandørtransaksjonen som vist under:

Velg behandlingsmenyvalget ”Valutakorreksjon” fra Leverandørtransaksjoner.

I dialogboksen under må du velge reguleringsdato, sett valuteringsdato til 31.01.2004

Ingen valutakurs er angitt i valutatabellen pr 31.01.2004, programmet kommer derfor til å velge nærmeste tidligere valutakurs fra 25.01.2004 som er 8,75

Behandlingsmenyvalget oppdaterer tabellen ”Valutakorreksjons data”. Feltbeskrivelse: se ovenfor

Du kan nå analysere resultatet av korreksjonen før du oppdaterer Valutakorreksjonen,

I tabellen Valuta korreksjonsdata kan du f. eks. via utvalg / sortering på kolonnene. ”Akseptert”, ”ABS Differanse beløp” eller ”ABS Differanse %” bestemme hvilke transaksjoner du vil oppdatere.

Dersom kjøringen genererer linjer uten ”x” i ”Akseptert” må du manuelt angi ”x” på disse postene for at de skal kunne behandles. Beløpsdifferansen viser 41,- i standard valuta. Dette skal tolkes som en anvisning om postering på resultatkonto, eller ”debet 41,-”, som betyr ”valutatap”.

I dette eksemplet velger du å oppdatere posten med behandlingmenyvalget ”Oppdater valutakorreksjoner”.

Behandlingsmenyvalget vil oppdatere Leverandørtransaksjonens felter:

”Valutakorreksjonskurs”, ”Valutakorreksjonsbeløp” , ”Valutakorreksjonsdato”, ”Valutakorreksjonskjøring” og ”Siste valutakorreksjonbeløp”

Det blir også opprettet en bunt med transaksjoner for valutatap som må oppdateres for å få et riktig resultet i regnskapet.

I dette tilfellet har vi gjort et kurstap på en leverandørfaktura og det lages derfor et bilag med posteringer utifra hva som er angitt i tabellen ”Valutakorreksjoner” for kontotype 2.

Kurstapet posteres i en bunt med opprinnelseskode ”Valutakorreksjon”. Bilaget lages pr. valuta og valutanummeret angis i feltet ”Ekstratekst” på bilagslinjen.

Vi utfører en ny korreksjon den 28.02.2004.

Den ”gamle” posten i ”Valutakorreksjonsdata” blir automatisk slettet når du gjør en ny korreksjon på samme post, ettersom den ”nye” Korreksjonsposten kommer til å ha samme primærnøkkel som den ”gamle” korreksjonsposten.

Kursen pr. den 29.02.2004 er 8,23 og du får derfor en kursgevinst på 11,- sammenlignet med opprinnelig kurs, eller en kursgevinst på 52,- sammenlignet med seneste korreksjon. Posten i korreksjonstabellen viser den nye differansen -11,00 (negativt fortegn) hvilket gir en anvisning om resultatkonteringen og skal tolkes som ”kredit 11,-”. Feltet ”Siste korreksjonsbeløp” viser forrige korreksjons anvisning om postering på resultatkonto og skal tolkes som ”tilbakefør kredit 41,-”.

Før du kjører behandlingsmenyvalget ”Oppdater valutakorreksjoner” må det settes et ”x” i feltet ”Akseptert”.

Behandlingsmenyvalget vil igjen oppdatere transaksjonstabellen:

....og lage to nye bilag, ett med tilbakeføring av tidligere postert differanse og ett med postering av ny differanse.

Etter oppdatering ser HB-transaksjoner på konto 81XX og 2990 slik ut:

Fra fakturaen som med opprinnelig verdi 834,- og regulert verdi 823,- finnes en kalkulert gevinst på 11,- på resultatkontoen og en reserve på 11,- pr 29.02.2004

Fakturaen betales den 15.03.2004, etter betalning ser leverandørtransaksjon ut slik:

Da det ikke lenger finnes noe restbeløp, så finnes det ikke noe ”valutakorreksjonsbeløp” på posten. Feltet ”siste valutakorreksjonsbeløp” beholder sin verdi, ettersom vi må ”valutakurskorrigere” posten en siste gang, for å kunne tilbakeføre den siste reguleringen på 11,-. Ved utvalg av reskontroposter som skal reguleres, bør du derfor alltid ta hensyn til poster med enten et restbeløp eller en verdi i ”Siste valutakorreksjonsbeløp”.

Korreksjon kjøres pr 31.03.2004 og nå kommer det ingen NY regulering, ettersom restbeløpet er 0,-

Etter kjøring av menyvalget ”Oppdater valutakorreksjoner” oppdateres leverandørtransaksjonen slik at ”sist valutakursbeløp” settes till 0,-

...og det lages en bilagslinje med tilbakeføring av den sist posterte kursdifferansen.

Etter oppdatering av bilaget viser samtlige kurskorreksjonskonti en balanse på 0,-.


Budsjettering

Budsjetteringsrutinen finner du under knappen ”Budsjett” på ”Flytskjema Regnskap”. I dette vinduet kan du registrere budsjetter på firmaet totalt og på ansvarsenheter.

Du kan legge inn et ubegrenset antall budsjetter og du kan budsjettere for mange år framover om det er ønskelig. Samme budsjett kan løpe over flere år. Du kan vedlikeholde budsjettene fortløpende etter hvert som forutsetningene endrer seg. Du kan budsjettere pr. periode pr. hovedbokskonto og / eller pr. ansvarsenhet. Ordremodulen benytter de samme tabellene for budsjettering av vareforbruk og omsetning. Da kan du også budsjettere i enheter i stedet for eller i tillegg til i beløp.

I resultat og balanserapportene kan du sammenligne med inntil to registrerte budsjetter (for eksempel mot et realistisk og et optimistisk budsjett). Dessuten kan du kombinere reelle tall for inneværende regnskapsår med budsjetterte tall for perioder du ikke har bokført bilag på ennå. Det er kun budsjetterte tall på hovedbokskontoer, eventuelt fordelt på ansvarsenheter, som blir akkumulert i resultat og balanserapportene.

Du kan også fordele budsjettet pr. kunde, leverandør og / eller ansatt. Disse budsjettallene får du foreløpig ingen direkte sammenligning med i noen rapporter, men du kan ta ut budsjettlister for en eller flere aktører eller aktørgrupper. Du kan også kopiere budsjettene ut til bruk i regneark eller andre eksterne verktøy.

Før du går i gang med budsjetteringen, bør du ha registrert de aktuelle regnskapsperiodene for året du skal budsjettere for og eventuelle fordelings- og periodiseringsnøkler. Dessuten bør du redigere kontoplanen slik at denne er tilpasset den bedriften du skal føre regnskap for. Vil du budsjettere på ansvarsenheter og / eller kunder, leverandører og ansatte, bør disse være registrert i ansvarsenhetstabellene og tabellen "Aktører" på forhånd. Du kan føye til nye kontoer, ansvarsenheter, kunder, leverandører og ansatte underveis, men arbeidet blir oppstykket om du ikke har registrert noe før du begynner å budsjettere.

Budsjetteringsrutinen består av to tabeller:

  • Budsjetter
  • Budsjettlinjer

Budsjetter

Hver rad i tabellen ”budsjetter” beskriver ett budsjett:

  • Budsjettnummer
  • Navn
  • År

Du kan legge inn et ubegrenset antall budsjetter – gjerne for flere regnskapsår (bare de er opprettet i tabellen ”regnskapsperioder”). Du kan f.eks. budsjettere for et prosjekt over flere år og få resultat- og balanserapporter med budsjett-tall for hele prosjektets levetid.

Budsjettlinjer

Hver rad i tabellen ”budsjettlinjer” beskriver en budsjettpost:

  • Linjenummer
  • år
  • periode
  • hovedbokskontonummer
  • debet og kredit beløp
  • henvisningsfelt til ansvarsenheter, ansatt-, kunde- og leverandørnummer.

Du kan fordele budsjettpostene på flere regnskapsperioder og/eller ansvarsenheter ved hjelp av menyvalget ”behandling/fordeling.

Registrere budsjett

Når du registrerer budsjett gir du det et budsjettnummer, navn og år.

Budsjettnr

Visma Business tildeler hvert budsjett et unikt nummer. Du kan bare registrere tall i feltet, og budsjettnummeret kan være på inntil 10 siffer. Taster du "+" i feltet foreslår Visma Business neste ledige budsjettnummer. Markøren vil flytte til neste felt automatisk, slik at du ikke behøver å taste "linjeskift". Visma Business foreslår ikke ledige hull i nummerserien etter budsjetter du eventuelt har slettet.

Budsjettnummer er primærnøkkel i tabellen, slik at du ikke kan ha to likelydende budsjettnummer. Prøver du å opprette et nytt budsjett med samme nummer som et eksisterende, får du feilmelding. Du får ikke endret budsjettnummer etter at det er registrert. Har du registrert feil eller vil endre budsjettnummer av andre grunner, må du markere og slette hele radene, før du kan registrere et nytt budsjett med ønsket primærnøkkel.

Navn

Du kan gi budsjettet et navn, som beskriver hva slags budsjett du har laget. Lager du mer enn ett budsjett, bør du legge inn en tekst slik at du enkelt kan skille budsjettene fra hverandre.
Du behøver ikke å fylle ut navnefeltet. Feltet kan være på maksimum 40 tegn. Både bokstaver og tall er tillatt

År

Her angir du hvilket år budsjettet skal gjelde for. Budsjettåret må falle innenfor en definert regnskapsperiode. Visma Business foreslår år ut i fra dagens dato.

Du behøver bare å taste de to siste sifrene i årstall. Taster du "+" eller "/" i feltet, foreslår Visma Business samme årstall som i raden over. Markøren vil flytte til neste felt automatisk, slik at du ikke behøver å taste "linjeskift".

Behandlingsmenyvalgene i tabellen ”Budsjettlinjer”

Fordeling

Når du står i vinduet "Budsjettlinjer" og har tastet inn en budsjettpost på en hovedbokskonto, kan du velge menyvalget "Behandling / Fordeling" for å angi på hvilke perioder og / eller ansvarsenheter du ønsker budsjettposten fordelt. Dette forutsetter at du på forhånd har definert de nødvendige periodiserings- og fordelingsnøklene. Da vil du få opp en dialogboks, der du kan velge i to nedtrekkslister mellom forhåndsdefinerte nøkler, som du ønsker å fordele budsjettposten etter.

Ved godkjenning av dialogen vil Visma Business ekspandere og erstatte den budsjettlinjen du står på, slik at budsjettposten blir splittet opp på det antall perioder og / eller ansvarsenheter de valgte periodiserings / fordelingsnøklene tilsier.

Når du kjører menyvalget Fordeling, får du melding hvis budsjettlinjen/-linjene har ugyldige kombinasjoner eller hvis du mangler verdier i feltene "Fordelingsnøkkel", og "Periodiseringsnøkkel".

Hvis du markerer flere budsjettlinjer og feltene "Periode", "Periodiseringsnøkkel" og "Fordelingsnøkkel" er blanke, behandler Visma Business kun en rad av gangen.

Merk: Angir du en ansvarsenhet direkte på budsjettlinjen, vil denne overstyre fordelinger til samme ansvarsenhetsklasse i fordelingsnøklene, mens budsjettlinjer ført direkte på en periode vil komme i tillegg til det som eventuelt er fordelt ved hjelp av periodiseringsnøklene.

Budsjettering på ansvarsenheter

Skal du rapportere på ansvarsenhetsnivå i regnskapet, kan det være greit også å legge inn budsjettet fordelt på ansvarsenheter. Da kan du sammenligne regnskapstallene i resultat og balanserapporten direkte opp mot budsjett. Alle budsjettlinjer som henviser til samme kontonummer (på forskjellige ansvarsenheter) vil bli samlet på hovedbokskontoen til én budsjettsum.

For å budsjettere på ansvarsenheter kan du enten velge "Behandling / Fordeling" på menylinjen, som bruker forhåndsdefinerte fordelingsnøkler, eller du kan hente fram kolonnen for den aktuelle ansvarsenhetsklasse i vinduet "Budsjettlinjer", for eksempel prosjekt eller avdeling. Du vil ha like mange henvisningsfelt til ansvarsenheter som ansvarsenhetsklasser som er opprettet i tabellen "Bedriftsopplysninger".

Du kan få opp et hjelpevindu med oversikt over registrerte ansvarsenheter, ved å dobbeltklikke eller taste "*" i aktuelt ansvarsenhetsfelt. Hjelpevinduet fungerer som et vanlig delvindu der ansvarsenhets-tabellen er åpnet. Finner du ikke den ansvarsenheten du ønsker, kan du endre eller opprette en ny ansvarsenhet, som i et hvilket som helst annet delvindu.

Merk: Angir du ansvarsenhet direkte på budsjettlinjen, vil denne overstyre eventuelle fordelinger på samme ansvarsenhetsklasse i fordelingsnøkler.

Du kan alternativt koble tabellen "Budsjettlinjer" til som et delvindu til ansvarsenhets-vinduet. Da kan du budsjettere for èn ansvarsenhet av gangen. Du vil slippe å gjenta ansvarsenhetsnummeret på budsjettlinjene, fordi disse alltid vil gjelde for den ansvarsenheten du står på i ansvarsenhetsvinduet. Budsjettnummeret må være opprettet fra før.

Budsjettering på aktører

Du har også mulighet for å splitte opp budsjettet på aktører, for eksempel selgerbudsjett, kundesalgsbudsjett, og innkjøpsbudsjett fordelt på leverandører. Hvis du vil ha budsjettbeløpene akkumulert opp på kontoer til bruk i resultat- og balanserapporten, må du angi hovedbokskonto på hver budsjettlinje. Alle budsjettlinjer som henviser til samme kontonummer (på forskjellige aktører) vil bli samlet på hovedbokskontoen til én budsjettsum.

For å budsjettere på kunder, leverandører eller ansatte må du hente fram kolonnen for kunde-, leverandør- eller ansattnummer i vinduet "Budsjettlinjer". Ved å dobbeltklikke eller taste "*" i en av disse kolonnene, får du opp tabellen "Aktører" i et hjelpevindu, der du kun ser aktører registrert med henholdsvis kunde-, leverandør- eller ansattnummer avhengig av hvilket henvisningsfelt du står i.

Hjelpevinduene fungerer som et vanlig delvindu der tabellen "Aktører" er åpnet, men du har bare tilgang til aktører som er definert med henholdsvis kunde-, leverandør- eller ansattnummer. Finner du ikke den kunden, leverandøren eller ansatte du ønsker, kan du endre eller opprette en ny aktør i hjelpevinduet. Har du imidlertid registrert en aktør uten ansatt-, kunde- eller leverandørnummer slik at den ikke kommer fram i hjelpevinduet, må du inkludere tabellen "Aktører" som et vanlig delvindu for å få angitt aktuelt nummer på aktøren.

Du kan alternativt koble tabellen "Budsjettlinjer" til som et delvindu til vinduet "Aktører". Du velger om du vil koble til budsjettlinjer for kunde, leverandør eller ansatt. Det er også praktisk å gjøre et utvalg i vinduet "Aktører", slik at du kun har den kategori aktører framme i vinduet som du vil budsjettere for. I et slikt vindu kan du budsjettere for èn kunde, leverandør eller ansatt av gangen. Du slipper å gjenta kunde-, leverandør- eller ansattnummer på budsjettlinjene fordi disse alltid vil gjelde for den aktøren du står på i vinduet "Aktører". Budsjettnummeret må være opprettet fra før.

Registrering av nytt budsjett

Når du skal registrere et nytt budsjett, tilføyer Visma Business dette på slutten av tabellen "Budsjetter". Har du avsluttet budsjetteringen midt i et budsjett, og vil fortsette der du sist slapp, stiller du markøren på aktuelt budsjettnummer. Da vil budsjettlinjene komme fram i vinduet "Budsjettlinjer", og du kan forsette registreringen.

Du kan lagre, endre og slette et helt budsjett eller en eller flere budsjettlinjer. Det er kun ved utskrift av resultat- og balanserapporter der du har valgt å sammenligne med budsjetterte tall, at budsjetteringstabellene blir brukt av Visma Business.

Tabellen "Budsjettlinjer" blir sortert i den rekkefølgen radene blir registrert i tabellen, fordi et fortløpende linjenummer er med som en del av primærnøkkelen. Du kan bruke menyvalget "Rediger / Innsett" eller det tilhørende ikonet, for å legge inn en ny rad der den naturlig hører hjemme. Den nye raden blir lagt inn på raden før den du står på.

Ønsker du å gjenta verdien fra samme felt i raden over, velger du "Rediger / Gjenta verdi" fra menylinjen eller taster "/" i feltet (ikke på redigeringslinjen, da vil Visma Business ta /-tegnet som en del av feltverdien). Velger du "Rediger / Foreslå verdi" fra menylinjen eller taster "+" i et felt (ikke på redigeringslinjen, da vil Visma Business ta +-tegnet som en del av feltverdien), vil Visma Business foreslå en verdi for utfylling av feltet, for eksempel neste nummer. Der Visma Business ikke har noen logisk verdi å foreslå, fungerer valget som kommandoen "Gjenta verdi".

Du kan også klippe og lime slik det er vanlig å gjøre i andre Windows-programmer. Du kan for eksempel kopiere et helt budsjett med alle budsjettlinjene til et nytt budsjettnummer, enten for å lage et mer optimistisk eller pessimistisk budsjett for samme år, eller for å ta utgangspunkt i årets budsjett for neste års budsjettering. Du kan også kopiere et helt budsjett ut, og lime det inn for eksempel i et regneark for å framstille det grafisk. På samme måte kan du utarbeide budsjettet i en annen (Windows-)applikasjon og klippe / lime den inn i budsjettvinduene. Vær nøye med kolonnenes bredde og rekkefølge, slik at du ikke får logiske feil i budsjettet.

Navigering i registrerte budsjetter

Når du har registrert ferdig en rad i vinduet "Budsjetter", vil markøren automatisk hoppe ned i vinduet "Budsjettlinjer". For å bevege deg mellom delvinduene, kan du enten bruke F6-tasten eller mus. I vinduet "Budsjettlinjer" får du bare opp budsjettposter som tilhører det budsjettnummeret du står på i vinduet "Budsjetter". Forflytter du deg til neste budsjett, vil utvalget av budsjettposter endre seg tilsvarende.

Du kan bla i tabellene med "PageUp" og "PageDown" for å få forrige og neste budsjett eller budsjettlinje, eller bruke rullefeltet til høyre i vinduene. Menyvalget "Vis / Gå til" inneholder forskjellige navigeringsmuligheter for å bevege markøren i vinduene.

Sortering og utvalg av budsjett og budsjettlinjer

Er du bare interessert i å se på noen av budsjettpostene du har registrert, kan du sette et utvalg på én eller flere kolonneverdier i vinduet "Budsjettlinjer". Dette gjør du med menyvalget "Vis / Utvalg". Ønsker du for eksempel bare å se på hva som er budsjettert på prosjekter, gjør du et utvalg på prosjekt forskjellig fra 0 i vinduet "Budsjettlinjer".

Du kan også velge hvordan du vil sortere budsjettpostene med menyvalget "Vis / Sortering". Visma Business skiller ikke på små og store bokstaver. Tall blir sortert foran bokstaver.

Utskrift av budsjett

Når du står i vinduet "Budsjetter" med vinduet "Budsjettlinjer" tilkoblet, kan du skrive ut et eller flere budsjetter. Du markerer det eller de budsjett(ene) du vil skrive ut, og velger menyvalget "Fil / Skriv ut" eller bruker det tilsvarende ikonet.

Sletting av budsjett og budsjettlinjer

Du kan slette et eller flere budsjetter eller budsjettlinjer, ved å markere den eller de raden(e) du ønsker å slette. Menyvalget "Rediger / Slett", Delete-tasten eller det tilsvarende ikonet, vil slette de markerte budsjettene / budsjettlinjene.

Merk: Hvis du sletter et budsjett, får du også slettet de tilhørende budsjettlinjene.

Utskrift av rapporter sammenlignet mot budsjett

  • Budsjett 1
    Du kan sammenligne tallene mot inntil to ulike budsjetter med angitt periodeintervall.
  • Budsjett 2
    Du kan sammenligne tallene mot inntil to ulike budsjetter med angitt periodeintervall.

Visma Business kan vise økning / budsjettavvik både i beløp og prosent. Ettersom du kan oppbevare regnskaps- og budsjettdata for flere år, kan du få ut rapporter for så langt bakover eller framover i tid som du har data for.

Merk: Du må hente fram tilsvarende felt i vinduet "Resultat/Balansekolonner" for å få vist de aktuelle tallene på rapporten.

Budsjetter

Her registrerer du hvilke budsjetter du vil sammenligne regnskapstallene med. Du kan om ønskelig utarbeide et normalt, et optimistisk og et pessimistisk budsjett. Du kan da kjøre ut en rapport der du benytter det normale budsjettet i tillegg til realisert, og sammenligner både med det optimistiske (som budsjett 1) og det pessimistiske budsjettet (som budsjett 2). De nedtrekkbare listene i kombo-boksene viser budsjettene i tabellen "Budsjetter".

Rapportdefinisjon

Her velger du hvilken av de forhåndsdefinerte rapportdefinisjonene du vil bruke på resultat- og balanserapporten. Den nedtrekkbare listen viser rapportdefinisjonene i tabellen "Resultat/Balansedefinisjoner".

Spesifiser kontoer

Du kan velge om du kun vil vise kontogruppene eller om du også vil ha spesifisert de enkelte kontoene som inngår i hver gruppe på egne linjer. Velger du å spesifisere kontoene, vil de bli sortert innenfor hver kontogruppe i den rekkefølgen de er sortert i vinduet "Hovedbokskontoer". Du kan skrive ut kontonummeret for eksempel helt til venstre i rapporten (foran tekstkolonnen) ved å hente fram feltet "Kontonr" i vinduet "Resultat/Balansekolonner".


Driftsmiddelhåndtering i Visma Business

1. Opprett driftsmiddelgruppen

Legg inn avskrivningssats, hvor ofte avskrivningen skal foretas pr år, hovedbokskonto for driftsmiddel (balansekonto) og kostnadskonto for avskrivning. Du kan også knytte driftsmidelklassen til en Saldogruppe. Saldogrupper bruker du for å gruppere driftsmiddelklassene. Du kan for eksempel bruke samme inndeling for saldogrupper som skatteloven.

2. Opprett deretter driftsmiddelet

Driftsmiddelnummer blir automatisk tildelt, men kan overstyres. Registrer Beskrivelse av driftsmiddelet og total levetid for driftsmiddelet. Systemet regner ut riktig avskrivningssats automatisk. Denne kan overstyres og settes blank. Da benyttes avskrivningssatsen på driftsmiddelklassen.

Merk: Ikke legg inn Anskaffelsesdato når du oppretter driftsmiddelet. Denne datoen blir oppdatert via oppdatering av bilag for anskaffelsen.

Nå er alt klart til å registrere anskaffelsen (inngående faktura) i bilagsregistrering.

3. Registrer anskaffelsen

Viktig at du benytter riktig driftsmiddelbehandling. Benyttes bilagsart for ”Anskaffelse av driftsmiddel”, blir også riktig Driftsmiddelbehandling utfylt. Ved registrering av anskaffelse skal ”Driftsmiddelbehandling 1” ”Anskaffelse” benyttes. I feltet Debet konto angir du driftsmiddelnummeret. (På samme måte som du fører reskontro). Den blir da oppdatert på balansekontoen som vi la inn på driftsmiddelklassen. Bokfør denne.

Standard bilagsarter for driftsmidler:

61 Anskaffelse driftsmiddel

62 Tillegg driftsmiddel

63 Oppskrivning driftsmiddel

64 Nedskrivning driftsmiddel

65 Salg driftsmiddel

66 Utrangert driftsmiddel

67 Avskrivning driftsmiddel

68 Tilbakeføring driftsmiddel

Driftsmiddelbehandling:

1. Anskaffelse

2 .Tillegg

3 .Oppskrivning

4. Nedskrivning

5. Salg

6. Utrangering

7. Avskrivning

8. Tilbakeføring

Går du inn på driftsmiddelet og kobler til transaksjoner ser du at anskaffelsen er bokført. (Det er på en måte som en reskontro hvor vi fører ”skyggeregnskap” på hvert driftsmiddel som oppbevarer enkelttransaksjoner og saldoer for senere avskrivning).

4.Neste steg er løpende avskrivninger

Visma Business lager avskrivningsforslag og bokfører dette automatisk hvis du ønsker. Avskrivning foretas fra tabellen Driftsmidler. I hjelpeteksten er en mer detaljert beskrivelse av avskrivning beskrevet under avsnittet ”Behandingsmenyvalgene i tabellen Driftsmidler”.

Marker driftsmiddelet og velg Behandling og Avskrivninger. Følgende dialog fremkommer:

Legg inn dato for hvor langt frem du vil avskrive. (Hvis du foretar avskrivning en gang pr. måned bør du kjøre denne rutinen hver måned og angi f.eks avskrivningsdato siste dag i måneden).

Det blir nå automatisk produsert avskrivningsbilag som legger seg i bunter og bilag. Du kan bokføre bilaget direkte ved å krysse av for Direkte oppdatering i dialogboksen. Hovedbokskonto for avskrivning hentes fra driftsmiddelklassen på driftsmiddelet. Eksempel på avskrivningsbunt ser du under:

Etter bokføring av bunten blir driftsmiddelsaldoen redusert med avskrivningen. Legg merke til at feltet ”Sist avskrevet” blir oppdatert med datoen du legger inn i dialogboksen for avskrivning. Ved neste avskrivning benyttes denne dato som ”fra dato” ved utregning av avskrivningstid. I bildet under ser du driftsmiddeltransaksjonene med anskaffelse og avskrivning.

Bilagsserier for avskrivning i bedriftsopplysninger må også fylles ut. Feltet heter ”Driftsm.avskr.serie”.

Hvordan registrere tilleggskjøp på driftsmidlet

Registrer den inngående faktura med Driftsmiddelbehandling ”2. Tillegg”. I feltet Debet konto angir du driftsmiddelnummeret.

Saldo på driftsmiddelet, avskrivningsgrunnlag og hovedbok for driftsmiddelet blir oppdatert. Feltet for Tillegg i Saldotabellen blir oppdatert.

Tillegget blir med i grunnlag for avskrivning. (Driftsmiddelbehandling 1 og 2)*20% delt på antall avskrivninger pr år. Her blir det (600000+20000)*20% delt på 12 avskringer pr.år. Det kan diskuteres om det er optimal, men det er slik løsningen er pr i dag. Dette er planlagt endret til 4.50.1.

Under ser du eksempel på avskrivningsbilag for en måned etter tilleggsføringen.

Hvordan foreta oppskrivning av driftsmidlet

Registrer bilag med Driftsmiddelbehandling ”3. Oppskrivning”. I feltet Debet konto angir du driftsmiddelnummeret og i feltet Kredit konto angir du resultatkonto for oppskrivning.

Saldo på driftsmiddelet, avskrivningsgrunnlaget og hovedbokskonto for driftsmiddelet blir oppdatert. Feltet for Oppskrivning i saldotabellen oppdateres.

Oppskrivningen blir med i grunnlag for avskrivninger på samme måte som forklart under Tillegg. Forskjellen er at saldotabellen oppdaterer feltet for Oppskrivning.

Under ser du eksempel på avskrivningsbilag på en måned etter oppskrivningen.

Hvordan foreta nedskrivning av driftsmidlet

Registrer bilag med Driftsmiddelbehandling ”4. Nedskrivning”. I feltet Kredit konto angir du driftsmiddelnummeret og i feltet Debet konto angir du kostnadskonto for nedskriving. Saldo på driftsmiddelet og avskrivningsgrunnlaget blir oppdatert. Oppdaterer eget felt for Nedskrivning i Saldotabellen.

Hvordan føre salg av driftsmidlet

Registrer bilag hvor du krediterer driftsmiddelet med anskaffelsesverdi og Driftsmiddelbehandling ”1. Anskaffelse”. Registerer ny linje hvor du debiterer driftsmiddelet med akkumulerte avskrivninger og Driftsmiddelbehandling ”7. Avskrivning”. Registrer ny linje med debet kundefordringer eller likviditetskonto. Oppstår det tap eller gevinst blir dette en restpost av de tre posteringene over og posteres til kredit gevinst eller debet ved tap. Saldo for driftsmiddelet og avskrivningsgrunnlaget blir nullstilt.

Hvordan føre utrangering av driftsmiddel

Utrangering virker i prinsippet på samme måte som salg, bortsett fra at det ikke blir noen postering for salgsinntekten. Driftsmiddelbehandling 6 er ikke 100% gjennomført. Den nullstiller f.eks. ikke akkumulerte avskrivninger.

På driftsmiddelet eller driftsmiddelklassen har du et felt som heter ”Utrangeringsverdi”. Feltet har ikke noe med utrangering å gjøre, og det er mulig vi endrer navn på feltet for å unngå feiltolkning av det. Verdien i feltet er ment brukt til å ”stoppe” avskrivninger uansett om driftsmiddelet skal utrangeres eller ikke. Det er ment brukt i land hvor det er lovbestemt at eiendommer ikke må oppføres med nullverdi i balansen.

Registrerer du en verdi i feltet fungerer det slik at hvis differansen mellom saldo på driftsmiddelet og utrangeringsverdi er lavere enn ”neste” avskrivning, vil det ikke bli dannet bunt for avskrivning. Feltet hjelper deg da til å stoppe avskrivning når du når denne summen.

Hvordan tilbakeføre driftsmiddel

Benyttes ved korreksjon av feilføringer. Registrer bilag med driftsmiddelbehandling 8, Kredit Driftsmiddelet og Debet opprinnelig konto på bilaget (f.eks leverandør). Tilbakeføring reduserer grunnlag for avskrivning og oppdaterer egne kolonner i tabellen driftsmiddelsaldoer.


Eksport av hovedbokssaldoer til årsavslutningsprogram

Mange ønsker å overføre hovedbokssaldoer fra økonomisystemet til et årsavsluttningsprogram for videre bearbeidelse. Visma Business kan overføre hovedbokssaldoer til følgende årsavslutningsprogram:

  • Akelius
  • Finale
  • Maestro
  • Total

Fremgangsmåte

  1. Velg Opsjoner, Systemadministrasjon og Eksporter... Marker Spesialformat og velg Hovedbokssaldoer.

  2. Ved å velge Eksport kommer du til utforsker. Her skriver du filnavnet på datafilen du skal generere og velger ønsket katalog. (Mulig filnavnet er ferdig definert i årsavslutningsprogrammet.) I vårt eksempel kaller vi filen ”hovedbokssaldo2003”og legger det på katalogen til Akelius.

  3. Ved lagring fremkommer neste dialog.
  4. Her angir du år og periode. Deretter skal du velge hvilke format du ønsker å legge ut hovedbokssaldoene på. Søk deg frem til katalogen hvor Imp-filene ligger. Default ligger de under Programfiler\Visma\Business\Imp

  5. Marker ønsket Imp-fil f.eks Akelius.imp og velg OK.

Filen blir nå generert og den kan leses inn i årsavslutningsprogrammet.

Eksporter Ansvarsenhet 1 saldo

Ved å hake av for Eksporter Ansvarsenhet 1 saldo, eksporteres saldotallene med ansvarsenhet 1. De Imp-filene som vi har tilpasset ligger ikke med avdeling. Ønskes dette må du legge inn en linje i impfilen med ansvarsenhet 1 f.eks slik:

a,1,;,1,,,,,,,,,,,,,,,,,,,,,,,,,,

b,Misc,1,,1,

c,AcNo,1,10,0,,,,,,,,,I,,

c,RespUnitNo,2,10,0,,,,,,,,,I,,

c,AcNm,3,60,0,,,,,,,,,S,a,

c,AcUB,4,20,0,,,,,,,,,S,,

På \Imp katalogen ligger det syv forskjellige formater

Akelius.imp | Hovedboksaldoer på valgt år
Akelius_m_fjoraar.imp | Hovedboksaldoer på valgt år samt fjoråret
Finale.imp | Hovedboksaldoer på valgt år
Finale_m_fjoraar.imp | Hovedboksaldoer på valgt år samt fjoråret
Maestro.imp | Hovedboksaldoer på valgt år
Maestro_m_fjoraar.imp | Hovedboksaldoer på valgt år samt fjoråret
Total.imp | Hovedboksaldoer på valgt år

Benytter kunden annet årsavslutningsprogram enn de vi har tilpasset kan du lage egen imp-fil tilpasset formatet dette programmet krever.


Endring av MVA-sats i Visma Business/micro80

Under Tabeller – Faste opplysninger ligger tabellen Merverdiavgift. Det er i denne tabellen du skal legge inn ny MVA-sats med opplysninger om hvilken dato den skal gjelde fra.

Hent frem feltene ”Ny sats” og ”Etter dato”. I ”Ny sats” legger du inn for eksempel 25 og i ”Etter dato” legger du inn datoen du vil 25% skal gjelde fra.

Ved overgang til en ny sats, kan du oppbevare begge satsene i tabellen, sammen med datoen for når den nye satsen trer i kraft. Programmet vil da velge riktig sats ved å sammenligne valuteringsdatoen for bilagene og fakturadatoen med denne datoen.

Når det ikke lengre er aktuelt å benytte den gamle satsen, kan du flytte den nye satsen over i det ordinære satsfeltet og ta bort datoen.

Det er viktig å få med seg at det er ordredatoen som gjelder. Det vil si at hvis du har registert ordre på dato med gammel sats, vil gammel sats også gjelde når disse blir fakturert. Det er fullt mulig å overstyre ordredatoen, slik at ny sats skal gjelde.


Fakturamottak

Fakturajournal fra Visma Avendo til Visma Business

Visma Avendo kan eksportere fakturajournaler i Visma Business format. Importen i Visma Business krever at noen riktige ”innstillinger” er satt, samt en forståelse for hvordan filen er bygget opp.

Mulige problemstillinger rundt import av Fakturajournal fra Visma Avendo til Visma Business

Det er stort sett tre problemstillinger som det er viktig å være klar over.

1. Omsetningsklasse mangler

Så lenge kontoplanen i Visma Business er satt opp med korrekte omsetningsklasser, så går innlesningen bra. Hvis noen konti ligger uten omsetningsklasse eller med feil omsetningsklasse, så blir ikke filen lest inn. Et eksempel her kan være konto 7790 - Øresavrunding som kan stå med f. eks Omsetningsklasse = Innkjøp. Da feiler innlesningen. Endres det til Omsetningsklasse = Salg, så går det greit.

Tips: I Visma Business finnes det en innstilling i Bedriftsopplysninger: ”Sjekk om omsetningsklasse finnes på bilag”. Denne bør være markert.

I neste versjon (høsten 2005) vil vi gjøre en liten endring slik at vi sender de unike verdiene for postene Omsetningsklasse. Innlesningen vil da fungere, selv om omsetningsklasse ikke er fylt ut i Visma Business.

2. Mva beregnes dobbelt

Alle poster fra Visma Avendo sendes som nettoposter. Dette er fordi Visma Avendo er bygget opp på en annen måte enn Visma Business.

Eksempel: En faktura for 124 kr kommer på tre linjer i filen, som følger:

Konto | Debet | Kredit
Kundenummer | 124 |
Salgskonto (3000) |  | 100
Utg. MVA konto |  | 24

Fakturajournalen er bygget opp slik at det likevel ikke vil bli beregnet dobbelt MVA. Følgende felt sørger for det:

TransSt = 1 som betyr overstyrt MVA beløp på alle salgslinjer med avgiftskode 3, 13,15
VatAm = 0 på de samme linjene, noe som betyr at det ikke skal beregnes MVA på linjen

Det betyr at selv om det ser ut som om MVA vil bli beregnet to ganger, så gjør det ikke det.

3. Kunder registreres som hovedbok

Dette var en feil i versjon 3.0, som nå er rettet i 3.01. Feilen var at feltet DbAcCI og CrAcCI ble fylt ut med verdien 3, som betyr hovedbok. Det betyr at også kundene ble registrert som hovedbok. Radene som inneholdt kundeopplysninger skulle vært fylt ut med verdien 1. Dette er som sagt rettet i versjon 3.01, som alle kunder nå skal ha installert. Pass på at kunden sitter med nyeste versjon.

Nedenfor finner du postbeskrivelsen for Visma Business formatet.

Postbeskrivelse Visma Business format

Under finner du en teknisk postbeskrivelse av formatet som eksporteres til Visma Business. Noen poster er merket med en kommentar som beskriver posten.

Filen inneholder data til tre tabeller @Actor, @WaBnD og @WaVo

Felt til @FIRM_BEGIN

Posisjon | Feltnavn | Beskrivelse | Kommentar
1 | Firm_Begin | Bestemmer hvilket firma i Visma Business dataene skal leses inn i. | Dette er det klientnummeret i Visma Business, som du oppgir i firmainnstillingene i Visma Avendo Fakturering.

Felt til @IMPORT_METHOD

Posisjon | Feltnavn | Beskrivelse | Kommentar
1 | IMPORT_METHOD | Verdien 1 betyr at feltene for den gjeldende kunden blir oppdatert. |

Felt til @Actor:

@Actor (=CustNo,Nm,Ad1,Ad2,PNo,PArea,Ctry,Phone,Fax,CpmtTrm,Cur,Inf)

Posisjon | Feltnavn | Beskrivelse | Kommentar:
1 | CustNo | Kundenummer |
2 | Nm | Navn |
3 | Ad1 | Adressefelt 1 |
4 | Ad2 | Adressefelt 2 |
5 | PNo | Postnummer |
6 | PArea | Poststed |
7 | Ctry | Landkode |
8 | Phone | Telefonnummer |
9 | Fax | Faksnummer |
10 | CpmtTrm | Betalingsbetingelser |
11 | Cur | Valutakode |
12 | Inf | Hovedkontaktperson | Deres Ref på kunde i Visma Avendo Fakturering

Felt til @WaBnD

@WaBnd(Descr,ValDt,SrcTp)

Posisjon | Feltnavn | Beskrivelse | Verdi
1 | Descr | Beskrivelse av hva bunten inneholder. | F.eks. "Importert fra Avendo" Dette blir satt automatisk av Visma Avendo Fakturering.
2 | ValDt | Dato som styrer regnskapsperioden |
3 | SrcTp | Opprinnelse | Skal ha fast verdi = 12

Felt til @WaVo

@WaVo(VoNo,Valdt,VoDt,Votp,Txt,DbAcNo,DbTxCd,DbAcCl,CrAcNo,CrTxCd,CrAcCl,Cur,CurAm,ExRt,Am,InvoNo,DueDt,AgRef,R3,R8)

Posisjon | Feltnavn | Beskrivelse | Verdi
1 | VoNo | Bilagsnummer | Fakturanummer i Visma Avendo Fakturering
2 | Valdt | Valuteringsdato | Fakturadato i Visma Avendo Fakturering
3 | VoDt | Bilagsdato | Fakturadato i Visma Avendo Fakturering
4 | VoTp | Bilagstype | 10012= Debetfaktura 10013= Kreditfaktura Disse numrene blir generert automatisk i Visma Avendo Fakturering.
5 | Txt | Bilagstekst |
6 | DbAcNo | Debet konto | Hovedbokskontonr. eller reskontronr.
7 | DbTxCd | Debet MVA-kode | Her settes MVA-kode i Visma Business. 3 = 24% utg MVA 13 = 12% utg MVA 15 = 6% utg MVA 9 = Salg utenfor avgiftsområdet
8 | DbAcCl | Debet k.type |
9 | CrAcNo | Kredit konto | Hovedbokskontonr. eller reskontronr.
10 | CrTxCd | Kredit MVA-kode | Her settes MVA-kode i Visma Business. 3 = 24% utg MVA 13 = 12% utg MVA 15 =6% utg MVA 9 =Salg utenfor avgiftsområdet
11 | CrAcC1 | Kredit k.type |
12 | TransSt | Trans.status .1 som betyr overstyrt MVA beløp på alle salgslinjer med avgiftskode 3, 13,15 | Betyr at MVA ikke regnes ut automatisk når posten kommer inn i Visma Business.
13 | VatAm | 0 på de samme linjene noe som vil bety at det ikke skal beregnes MVA på linjen | Betyr at MVA ikke regnes ut automatisk når posten kommer inn i Visma Business.
14 | Cur | Valuta | 47 for NOK
15 | CurAm | Valutabeløp |
16 | ExRt | Valutakurs |
17 | Am | Beløp |
18 | InvoNo | Fakturanummer |
19 | DueDt | Forfallsdato |
20 | AgRef | Motpostreferanse på kreditfaktura | Dette feltet fylles kun ut på kreditfakturaer der man har laget et motbilag mot et annet fakturanummer.
21 | Cid | KID-nr | Om man genererer KID-nr i Visma Avendo Fakturering så kommer KID-nr med i filen.
22 | R1 | Kostnadsbærer i Visma Business R1-R12. Avhengig av hvilke kostnadsbærere man har valgt i innstillingene. | Dette er avdeling i Visma Avendo Fakturering.
23 | R2 | Kostnadsbærer i Visma Business R1-R12. Avhengig av hvilke kostnadsbærere man har valgt i innstillingene. | Dette er medarbeider i Visma Avendo Fakturering.


Forhåndsregistrering og attestasjon

Dette er en rutine som er praktisk å bruke når inngående fakturaer skal attesteres / konteres av andre brukere enn den som registrerer fakturaen.

Bruker du forhåndsregistrering av inngående fakturaer, kan du registrere inngående fakturaer umiddelbart etter at du har mottatt dem fra leverandør, slik at du får håndtert MVA på riktig avgiftstermin samt får oversikt over fakturaer som er ute for attestering.

Forhåndsregistrering gir også oversikt over fakturaer som skal attesteres før de er klare for betaling. Det er ikke mulig å remittere fakturaene før de er attestert eller at prioritet for betaling er manuelt endret.

Vindu for forhåndsregistrering og attestering finner du under Regnskapsprosessen, Registrering, knapp for Forhåndsreg. / Att. eller i Utforsker, 3. Regnskap, 30. Registrering og 302. Forhåndsreg./Att.

Du registrerer inngående fakturaer som et vanlig bilag, bortsett fra at du fører mot en interimskonto eller en konto for ikke-attesterte varekjøp. ”Debet avg. kode" legges inn, ”bilagsart” er 26 – forhåndsregistrering, "prioritet” er 8 – til attestasjon. I tillegg legger du inn ”attestasjonsansvarlig”.

Når du så skal attestere eller godkjenne den inngående fakturaen velger du fanen ”attestasjon”. Du må krysse av i feltet "Attestasjon" i bunthodet (dette er forhåndsutfylt i standard vindu 302. Forhåndsreg./Att.). Når du kommer ned på bilagslinjene har du to muligheter til registrering.

  1. Taster du inn tidligere bilagsnummer først, vil "tidligere bilagsnummer" bli kopiert til feltet "Bilagsnr". Da vil du få samme bilagsnummer på attestasjonen som på forhåndsregistreringen.
  2. Det andre alternativet er å bytte om på rekkefølgen på kolonnene slik at Bilagsnr. er plassert før Tidligere bilagsnr. Taster du + i Bilagsnr. vil du få tildelt bilagsnummer fra bilagsserien på bunten. Tast deretter inn Tidligere bilagsnr. for å attestere / godkjenne bilaget.

Visma Business vil nå hente opp nettobeløpet, bilagsdato, fakturanummer og endre prioritet på reskontroposten, samt at interimskontoen blir hentet opp til kredit. Du må selv legge inn den eller de kontoer som du bruker for varekjøp.

Forhåndsregistrering

Forhåndsregistrering av bilag som skal attesteres og eventuelt konteres gjør du i eget vindu for forhåndsregistrering / attestasjon (Regnskapsprosessen, Registrering, knapp for Forhåndsreg. / Att. eller i Utforsker, 3. Regnskap, 30. Registrering og 302. Forhåndsreg./Att.).

Hensikten med dette er å sikre at MVA blir registrert på riktig termin, at poster som skal betales er godkjent samt at du får kontroll over bilag som er ute for attestasjon.

I vinduet som vist under vil du automatisk få foreslått bilagsserie og bilagsart for forhåndsregistrering. På bilagsart 26 kan du definere en fast konto som interimskonto i kolonnen Debet konto. Det er også satt utfyllingsregel for kolonnen Prioritet slik at denne får verdien 8. Til attestasjon.

I eksempelet under er det registrert en inngående faktura på kr.12.500,- som er MVA-pliktig (25 % MVA). Gjør du dette, får du et bilag med kr. 12.500,- til kredit på konto 2410 (som er standard konto for leverandørgjeld i Visma Business), kr. 10.000 til debet på interimskontoen og kr. 2.500,- til debet på konto 2710 (som er standard konto for inngående MVA i Visma Business). Det er også registrert hvem som skal attestere bilaget i kolonnen Att. ansv.

Attestering

Attestering og kontering gjør du i samme vindu som forhåndsregistrering, men på siden merket Attestasjon.

Bunter du oppretter for attestasjon får automatisk kryss i kolonnen Attestasjon. Dette gjør at du får mulighet for å henvise til tidligere bilagsnummer på bilagslinjene.

I eksempelet under vil ikke Bilagsserien som er registrert i bunten få noen effekt da kolonnen for Tidligere bilagsnr. ligger før kolonnen Bilagsnr. Når rekkefølgen er slik vil tidligere bilagsnummer bli kopiert til kolonnen Bilagsnr. og du får registrert nye transaksjoner på samme bilagsnummer.

Dersom du ønsker å bruke egen bilagsserie for attestasjon bør du flytte kolonnen Bilagsnr. før kolonnen Tidligere bilagsnr. Bilagsnummer blir tildelt på ordinær måte ved å taste + i Bilagsnr.

Når du skal attestere den inngående fakturaen må du registrere bilagsnummeret på det forhåndsregistrert bilaget i kolonnen Tidligere bilagsnr. Visma Business henter da opp interimskontoen til kredit og beløpet kr. 10.000,-. Samtidig blir Prioritet endret til 2. Betalingsprioritet 2 slik at posten vil komme med ved betaling.
Du må nå registrere kontoen for kostnaden og eventuelle ansvarsenheter (avdeling, prosjekt o.s.v.). Du kan selvfølgelig splitte kostnaden på flere konti eller ansvarsenheter ved å registrere flere bilagslinjer. Avgiftskode og Omsetningsklasse skal være blank da MVA er håndtert ved forhåndsregistreringen.
Leverandørtransaksjonen finner du igjen nederst i skjermbilde under ”aktuell post”.

Oppfølging av bilag til attestasjon / godkjenning

Vindu for oppfølging av bilag til attestasjon finner du under Regnskapsprosessen, Registrering, knapp for Attestasjonsoppfølging eller i Utforsker, 3. Regnskap, 30. Registrering og 305. Attestasjonsoppfølging.

På siden Uattesterte finner du bilag til attestasjon pr. ansatt.

Siden Alle uattesterte viser alle bilag som ikke er attester sortert pr. ansatt og pr. leverandør.


Generell momskompensasjon - håndtering i regnskapene

Oppsummering av løsning i regnskapssystem

Følgende typer konti er nødvendig for å dekke krav til håndtering i regnskap.

Poster til disse konti skal genereres via avgiftskode

Kortsiktig fordring staten | Konto 2.1310
Akkumulert grunnlag for refusjonskrav | Konto ikke oppgitt
Betalt mva Investeringsregnskap | Konto 0.222.429
Inntektsført refusjonskrav | Konto 1.222.729 NB! Føres i driftsregnskap
Betalt mva Driftsregnskap | Konto 1.222.429
Inntektsført refusjonskrav | Konto 1.222.728

Se eksempel for føringer under samt i vedlagt dokument fra Kommunal- og regionsdep.

Dette medfører at det er tre nye konti som må håndteres i tillegg til ordinær mva for hver mva kode. Forutsetter at konto for Betalt mva styres til konto for ”Inngående avgift”.

I tillegg må poster til Kto. 2.1310 Kortsiktig fordring staten, Kto. 1.222.728/1.222.729 Inntektsført refusjonskrav og Grunnlag for refusjonskrav (akkumulert) styres via avgiftskoden. Mao tre nye kontoangivelser knyttet til avgiftskode med tilhørende logikk.

Eksempel på postering:
Inngående faktura kr. 124,-

Kto 1.222.230 Kost |  | Kto. 1.222.429 Mva på kost | Leverandør
100,- |  | 24,- |  | 124,-
Kto. 1.222.728 Innt. Ført ref.krav |  | Kto. 2.1310 Korts. Fordr. stat | Akkumulert grunnlag
 | 24,- | 24,- |  | 100,-

Utover dette skal ”ikke kompensasjonsberettigede anskaffelser” registreres med mva kode med 0 sats.

Forslag til foreløpig løsning i Visma Business.

Funksjonalitet for automatisk føring av konti angitt i Merverdiavgiftstabellen, kolonnene Debet/kredit kildeskatt styrt av verdi i Beregn av brutto vil komme i versjon 4.31.1 og 4.40.4.

Frem til dette er implementert må postering av intektsføring av mva og fordring til staten i balansen føres manuelt f.eks ved månedsslutt. Tilsvarende konti angitt i kolonnen Debet/kredit kildeskatt.

Under følger forslag til avgiftskoder etc. NB! Disse kodene og mva nr vil bli brukt i kommende Kompensasjonsoppgave.

Avgiftskoder, nye

Avg. kode | Beskrivelse | Mva nr | Inv.avg.nr | Oms. klasse
20 | Mva komp 24% Drift | 20 | 20 | 4
21 | Mva komp 12% Drift | 21 | 20 | 4
22 | Mva komp 6% Drift | 22 | 20 | 4
23 | Mva komp 0% Drift | 23 |  | 4
25 | Mva komp 24% Invest. | 25 | 20 | 4
26 | Mva komp 12% Invest | 26 | 20 | 4
27 | Mva komp 6% Invest | 27 | 20 | 4
28 | Mva komp 0% Invest | 28 |  | 4

Tabellen Merverdiavgift

Mva nr | Sats | Inng. konto | Debet kildeskatt | Kredit kildeskatt | Beregn av brutto
20 | 24 | 1.222.429 | 2.1310 | 1.222.728 |
21 | 12 | 1.222.429 | 2.1310 | 1.222.728 |
22 | 6 | 1.222.429 | 2.1310 | 1.222.728 |
23 | 0 | 1.222.429 | 2.1310 | 1.222.728 |
25 | 24 | 0.222.429 | 2.1310 | 1.222.729 |
26 | 12 | 0.222.429 | 2.1310 | 1.222.729 |
27 | 6 | 0.222.429 | 2.1310 | 1.222.729 |
28 | 0 | 0.222.429 | 2.1310 | 1.222.729 |

Satt opp i henhold til dokumentasjon under. Ved bruk av annen kontoplan må konti settes opp i henhold til eksempler under.

Beregn av brutto er tatt med da implementeringen av ferdig løsning forutsetter at det settes en bit verdi som vil styre bruken av konti angitt i Debet/kredit kildeskatt.

Tabellen Investeringsavgift

Brukes kun for å ta vare på grunnlag på egen konto.

Inv.avg.nr | Sats | Inv. Avg. Konto | Grunnlagskonto
20 | 0 |  | Må bestemmes av kunde. NB! Konto skal ikke ha kontogruppe

Dersom ”firmaet” også skal levere ordinær mva oppgave må mva nr for kompensasjon ekskluderes fra formularet for mva oppgave.

Visma leverer nytt formular for avgiftsoppgave hvor det er tatt hensyn til mva nr for kompensasjon til versjon 4.31.1 og 4.40.4

Generell momskompensasjon - håndtering i regnskapene

Vi viser til brev av 8. oktober 2003.

Departementet vil i dette brevet gi informasjon om :

1. Håndtering av generell kompensasjonsordning i de kommunale regnskapene. Behandling av utgifter/inntekter og utbetalinger/innbetalinger.

2. Framstilling av merverdiavgift og kompensasjon for merverdiavgift ved rapportering av regnskapsopplysninger til sentrale myndigheter (KOSTRA)

3. Overgangsordning for krav om kompensasjon for anskaffelser i regnskapsårene 2002 og 2003.

Forslaget om innføring av en generell kompensasjonsordning ligger til behandling i Stortinget. I forhold til omtale av ordningen må det tas forbehold om stortingets tilslutning til regjeringens forslag i Ot.prp. nr. 1 (2003-2004) kapittel 20.

Håndtering av generell kompensasjonsordning, planlagt iverksatt 1. januar 2004, i de kommunale regnskapene.

Etter gjeldende regler er kommuner og fylkeskommuner mv. ikke pålagt å postere vederlaget og beregnet avgift for vederlaget hver for seg ved anskaffelser av merverdiavgiftspliktige varer og tjenester. For manges del posteres vederlaget og avgiften til staten samlet.

I forbindelse med innføring av ordning med generell kompensasjon for merverdiavgift, pålegges kommuner, fylkeskommuner og andre som har regnskapsplikt etter kommuneloven å postere vederlag uten avgift, avgift og kompensasjon for avgift separat. Departementet legger samtidig vekt på at merarbeid som følge av ovennevnte krav ikke skal bli betydelig.

Inngående faktura vil fra en avgiftspliktig leverandørs side være spesifisert med beløp for varen/tjenesten og avgiften. Dette er også tilfelle når fakturaen inneholder både avgiftspliktig og avgiftsfritt salg, eventuelt også salg med reduserte mva-satser. I drifts- og investeringsregnskapet skal anskaffelsen (varen/tjenesten) registreres med beløpet for anskaffelsen og beløpet for mva. Motposten til denne utgiftsføringen er balanseposten for leverandørgjeld/reskontro leverandører. I tillegg skal selve kompensasjonskravet registreres som en inntekt, men bare i driftsregnskapet ikke investeringsregnskapet. Motposten til denne inntektsføringen er en balansepost under fordringer – virksomhetens krav på staten. Det skal i tillegg opprettes en grunnlagskonto hvor alle kompensasjonsberettigede anskaffelser eks. mva skal registreres og akkumuleres gjennom året. De posteringer som er nevnt i dette avsnittet vil skje automatisk fra økonomisystemet. Departementet har orientert leverandører av økonomisystemer som bekrefter at de nevnte posteringer kan legges inn som automatiske gitt korrekt registrering av vederlaget eksklusive avgift.

En forutsetning for automatisk postering, jf. foregående avsnitt, er at kommunen ved registrering av faktura (bilag) fører på definerte koder for merverdiavgift på kompensasjonsberettigede anskaffelser. Det må i tillegg føres på kode for ikke kompensasjonsberettigede anskaffelser som det heller ikke foreligger rett til fradrag for etter merverdiavgiftsloven. Leverandører av økonomisystemer oppgir på forespørsel sifre på momskoder som kan nyttes av brukere av systemet. NARF har oppgitt at de tar sikte på å angi forslag til standardisering av momskoder som inkluderer inngående avgift, utgående avgift og momskompensasjon. Inntil slikt forslag foreligger må kommuner benytte de koder ( se ”a”- ”h” under) som tilbys av egen leverandør av økonomisystem.:

MVA-sats 24 pst. -> Kode ”a” Art 429 Driftsregnskap

MVA-sats 12 pst. -> Kode ”c” Art 429 Driftsregnskap

MVA-sats 6 pst. -> Kode ”e” Art 429 Driftsregnskap

MVA-sats ”0” pst. -> *) Kode ”g” Art 429 Driftsregnskap

MVA-sats 24 pst. -> Kode ”b” Art 429 Inv.regnskap

MVA-sats 12 pst. -> Kode ”d” Art 429 Inv.regnskap

MVA-sats 6 pst. -> Kode ”f” Art 429 Inv.regnskap

MVA-sats ”0” pst. -> *) Kode ”h” Art 429 Inv.regnskap

*) Ikke kompensasjonsberettigede anskaffelser uten rett til fradrag for inngående avgift. Bruk av ulike koder for å identifisere ulike MVA-satser for ikke-kompensasjonsberettigede anskaffelser må vurderes særskilt.

Mottatt faktura skal kodes med mva kode for refusjonskravet og for en virksomhet som benytter ”kostra-artene” (inklusive nye arter i 2004)i sitt interne regnskap vil registreringen se slik i driftsregnskapet:

Eksempel undervisningslokaler

Kto 1.222.230 kr 100,00 kjøp av tjeneste vedlikehold

Kto 1.222.429 kr 24,00 mva betalt

Kto 1.222.728 kr 24,00 mva refusjonskrav

I investeringsregnskapet vil det se slik ut:

Eksempel undervisningslokaler:

Kto 0.222.230 kr 100,00 kjøp av tjeneste vedlikehold

Kto 0.222.429 kr 24,00 mva betalt

NB Kto 1.222.729 kr 24,00 mva refusjonskrav

NB! refusjonen skal inntektsføres i driftsregnskapet kontoklasse 1.

Utgiften (vederlaget samt betalt mva) skal utgiftsføres i investeringsregnskapet, kontoklasse 0.

Inntektsføring av kompensert mva skal skje ved bruk av art 72x i driftsregnskapet

Det skal skilles mellom kompensert mva investering og drift:

Art 728 kompensert mva driftsregnskapet (ny art 2004)

Art 729 kompensert mva investeringsregnskapet (ny art 2004)

Posteringene i balansen vil se slik ut:

Balansen

– inntektsført beløp på kto 1.222.728 føres som kortsiktig fordring Stat

Debet Kto 2.1310 kr 24,00

– faktura beløp inkl. mva beløp føres som kortsiktig gjeld via leverandørreskontroen

Kredit Kto 2.3275 kr 124,00

Betalingene – kommunen betaler leverandøren

Kredit ”bank” kto 2.1020 kr.124,00

Debet Kortsiktig Gjeld (via leverandørreskontroen) kto 2.3275 kr 124,00

Betalingene – staten betaler kompensasjonen

Debet bank kto 2.1020 kr 24,00

Kredit kortsiktig fordring Stat kto 2.1310 kr 24,00

Etter departements oppfatning vil en med den nevnte løsning unngå merarbeid av betydning ved registrering. I tillegg kommer at en ved en generell ordning vil ha mindre behov for å gjøre vurderinger av om anskaffelsen er kompensasjonsberettiget og dermed at ordningen vil være enklere å praktisere i regnskapet enn dagens ordning.

Framstilling av merverdiavgift og kompensasjon for merverdiavgift ved rapportering av regnskapsopplysninger til sentrale myndigheter (KOSTRA)

Kompensasjon for merverdiavgift vil med den foreslåtte ordning bli en synlig inntekt for kommunesektoren som inngår i kommuneopplegget. Samlet årlig kompensasjon antas å ligge på ca. knapt 9 mrd. kroner for kommunal forvaltning første året. Årlig kompensasjonsbeløp vil kunne endres avhengig av hvordan kommuner og fylkeskommuner mv. tilpasser seg ordningen.

Kommuner, fylkeskommuner og andre som er pålagt rapporteringsplikt etter kommuneloven § 49 eller tilsvarende bestemmelse i lov om interkommunale selskaper (IKS) skal benytte følgende (nye fra 2004) arter ved regnskapsrapportering fra og med regnskaps- og rapporteringsåret 2004 :

Merverdiavgift på vederlag, merverdiavgiftspliktige anskaffelser : Art 429 (ny art 2004)

Komp. for merverdiavgift anskaffelser utgiftsført i driftsregnskap : Art 729 (ny art 2004)

Komp. for merverdiavgift anskaffelser utgiftsført i inv. regnskap : Art 728 (ny art 2004)

Artene 728 og 729 skal kun regnskapsføres og rapporteres i kontoklasse 1.

Overgangsordning for krav om kompensasjon for anskaffelser i regnskapsårene 2002 og 2003.

Selv om dagens begrensede ordning etter planen avvikles fra årsskiftet, og umiddelbart erstattes av den foreslåtte generelle ordning, vil en få en overgangsperiode fram til og med 2005 hvor både den begrensede og den generelle kompensasjonsordning gir økonomisk effekt for stat, kommuner, fylkeskommuner og andre kompensasjonsberettigede.

Både den begrensede kompensasjonsordning og den generelle kompensasjonsordning er i hovedsak finansiert gjennom trekk i rammetilskudd til kommuner og fylkeskommuner. Etter den begrensede ordning utbetales kompensasjonen to år i etterkant av anskaffelsen. Måten trekket for den begrensede ordning er gjennomført på, innebærer at også trekket skjer to år i etterkant. Den begrensede ordning ble innført 1. mai 1995. I 1997 ble kompensasjon for første gang bevilget på statsbudsjettet og utbetalt kommuner og fylkeskommuner. Samme år (1997) ble kommuner og fylkeskommuner for første gang trukket i rammetilskudd for ordningen. Dette etterslepet i bevilgning på statsbudsjettet, utbetaling til kommuner og fylkeskommuner og trekk i rammetilskudd gjelder fortsatt. Det innebærer at det på statsbudsjettet for 2004 over kapittel 1532 er bevilget over egen post kompensasjon som knytter seg til 2002. Tilsvarende må en på statsbudsjettet for 2005 bevilge midler på samme kapittel og post til kompensasjon som gjelder 2003.

Med den foreslåtte generelle ordning forlater en det to års etterslep i bevilgning, utbetaling og trekk i rammetilskudd en har hatt etter den begrensede ordning. Kommuner og fylkeskommuner mv. vil i 2004 sende inn kompensasjonskrav knyttet til anskaffelser i 2004. Det er derfor opprettet ny post på statsbudsjettet for 2004 på kapittel 1532 som gjelder utbetaling etter ny ordning. Som følge av at statsbudsjettet følger et kontantprinsipp gjelder bevilgningen 5 av 6 terminer for 2004 (snaut 7 ½ mrd kroner for kommuner og fylkeskommuner). For 2005 må det bevilges midler for å dekke siste termin 2004 og 5 av 6 terminer for 2005 (dvs. full årseffekt). På statsbudsjettet for 2005 må det i kompensasjon til kommuner og fylkeskommuner samlet bevilges 10,5-11 mrd kroner knyttet til begrenset og generell ordning. Dette er vesentlig mer enn trekket i rammetilskudd til kommuner og fylkeskommuner. Forskjellene skyldes i stor grad ulike regnskapsprinsipper i stat og kommunesektor.

Krav sendt i 2003 for anskaffelser i 2002 er i tråd med gjeldende regnskapsregler inntektsført i driftsregnskapet for 2003, slik at utbetaling av kompensasjon i 2004 kun får en likviditetseffekt. Det ligger ikke inne noe trekk i rammetilskudd knyttet til utbetaling av kompensasjon i 2004 for anskaffelser i 2002. Bortfallet av trekk for 2002 innebærer dermed kun en styrking av likviditeten for kommunesektoren, ikke styrking av sektorens driftsresultat.

Det er imidlertid ikke bortfallet (se forrige avsnitt) av 2004-trekk som forklarer at uttrekket er lavere enn anslått kompensasjon i 2004. Forklaringen er derimot knyttet til følgende forhold: Krav for 2004 for anskaffelser i 2004 skal en i tråd med gjeldende regnskapsregler inntektsføre i driftsregnskapet for 2004 (samtlige 6 terminer siden inntektsføring av krav følger regnskapsår for anskaffelsen). For kommuner og fylkeskommuner samlet er slik kompensasjon antatt å utgjøre knapt 9 mrd. kroner (tilsvarende anskaffelser i drifts- og investeringsregnskapet til en brutto verdi av noe over 40 mrd. kroner). Det er for slike anskaffelser/kompensasjon gjort et trekk i rammetilskudd til kommuner og fylkeskommuner for 2004 på knapt 7 mrd. kroner. Differansen skyldes at deler av kompensasjonen for 2004 (ca. 1,6 mrd kr) ville vært kompensert også etter den begrensede ordning (men i så fall i 2006 og med tilsvarende uttrekk i 2006). Uttrekket er derfor lavere enn forventede kompensasjonskrav for 2004.

Det knytter seg en særlig utfordring til kompensasjonskrav etter den begrensede ordning for 2003. Kompensasjonsberettigede vil i 2005 få utbetalt kompensasjon både etter den begrensede ordning (for 2003) og den generelle ordning (for 2005).

Samlet bevilgningsbehov over statsbudsjettet etter gjeldende og foreslått ny ordning antas å bli 10,5- 11 mrd. kr, dvs. betydelig over antatt årlig omfang som er lagt inn som grunnlag for uttrekk i rammetilskudd. Etter gjeldende regler (jf. forskrift om årsbudsjett og forskrift om årsregnskap og årsberetning) skal krav for 2003 føres opp som inntekt i driftsregnskapet for 2004, mens trekk i rammetilskudd ut fra gjeldende prinsipper skal foretas i 2005. Dette er et trekk som kommer i tillegg til de trekk som allerede er gjennomført eller varslet. Det er videre tale om et trekk som kun gjelder 2005 og som vil falle bort fra og med 2006. Dersom kompensasjon for 2003 etter den begrensede ordning inntektsføres i 2005 (i stedet for 2004) vil denne inntekten for kommunesektoren tilsvare det ytterligere trekk som må foretas i kommunesektorens inntekter for 2005 alene.

Departementet meddeler derfor at kompensasjonskrav for 2003 skal føres som inntekt i årsbudsjett og årsregnskap for 2005, dvs. legge til grunn at regnskapsføring av krav for 2003 isolert skal skje etter kontantprinsippet. Den særskilte økning av trekket i inntekter i 2005 alene, vil dermed balanseres mot utbetaling av kompensasjon også i 2005, for anskaffelser i 2003. Når denne praksis følges vil kommuner og fylkeskommuner unngå unødvendige og utilsiktede svingninger i inntektsnivå. Departementet vil med bistand fra fylkesmennene følge opp at krav som gjelder 2003 ikke føres opp i årsbudsjett og årsregnskap for 2004. Departementet viser også til pålagt regnskapsrevisjon av kommunale regnskaper.

Det foreslåtte opplegg vil medføre at kommunesektoren fortsatt vil ha et likviditetsmessig og resultatmessig overskudd knyttet til kompensasjonsordningen. Kommuner og fylkeskommuner som ønsker dette dokumentert, kan summere samlet trekk i rammetilskuddene for årene 1997-2004 (på grunnlag av beregningsteknisk dokumentasjon for 1997, 1998 og 2004) og sammenligne dette beløpet med summen av bevilgninger på statsbudsjettets kapittel 1532 for årene 1997-20041 .

Nærmere opplysninger om ordninger med momskompensasjon får en ved å henvende seg til stedlig fylkesskattekontor. Fylkesmannen i fylket kan i tillegg kontaktes om håndtering av ordningen i årsbudsjett og årsregnskap.

Med hilsen

Eivind Dale e.f. Trond Ø. Christensen

ekspedisjonssjef Underdirektør


Imort av bunt

Data kan importeres til programmet via menyvalget “Import” i Fil-menyen, eller ved kjøring av programmet i kommando/import-modus – se eget avsnitt.

Det er bare brukere som er definert som systemansvarlig som har anledning til å importere data. Eksempler på data som det kan være aktuelt å importere er: aktører, produkter, priser, ordrer, bunter, faste opplysninger, formularer og oppsett.

For å kunne importere til tabellene med ordrer, ordrelinjer og reservasjoner må man ha modulen for import av ordrer, og for å kunne importere til tabellene med bunter, bilag og motreferanser må du ha modulen for import av bunter.

Valg i import-dialogen

Menyvalget leder til følgende dialog:

Til database

Dataene er organisert i én database pr. bedrift, og en systemdatabase som er felles for alle bedriftene. Øverst i dialogen velger man hvilken bedrift man skal importere til, eller om man skal importere til systemdatabasen.

Systemdatabasen inneholder bl.a. oppsett og formularer, i tillegg til definisjon av brukere, bedrifter og adgangsrestriksjoner. Det kan ikke importeres til tabellen med aktive sesjoner eller mastertabellen [1] i systemdatabasen.

Tabeller eller spesialformat

I dialogen kan man velge mellom å importere data til tabeller angitt i importfilen, eller å importere data i spesielle formater, produsert av andre programmer.

Listboksen under radiobutton’ene skifter innhold avhengig av hvilken radiobutton som er valgt, og viser hhv. importmetoder og spesialformater.

Importmetode

Importmetoden bestemmer hvordan programmet skal behandle nye rader i forhold til eksisterende rader.

1. Ved importmetoden “Overskriv oppgitte felter” vil programmet for hver rad i filen forsøke å finne frem til en rad med samme primærnøkkel, og bytte ut verdien i de feltene som man har listet opp i filen. Hvis ikke raden finnes fra før, blir den lagt inn med de verdiene den har i filen. Denne metoden er velegnet når man skal oppdatere visse felter, og bevare verdien i de øvrige feltene.

2. Ved “Bytt ut hele rader” vil programmet lese inn alle radene, bytte ut gamle rader med samme primærnøkkel som noen av de nye radene, og beholde de øvrige radene.

3. Ved “Legg bare til nye rader” vil ikke programmet gjøre noe med rader som finnes fra før, men bare legge til nye rader. Dette er den minst farlige av alle importmetodene (og den enkleste å reversere) siden ingen data blir overskrevet.

4. Ved “Erstatt hele innholdet i tabellene” sletter programmet først det gamle innholdet i tabellene, og leser inn de nye radene. Denne metoden er den rette når man ikke er interessert i å ta vare på noe av det gamle innholdet i tabellene, og filen inneholder en komplett opplisting av alle radene som man ønsker at tabellene skal bestå av etter importen. Hvis det ikke er oppgitt noen rader for en tabell, blir virkningen ved denne importmetoden at tabellen tømmes.

Veiviser

Hvis det krysses av for ”Veiviser”, vil det komme opp en ”Wizard” for import av tekstfiler når man trykker ”OK”.

Syntakssjekk

Før selve importeringen starter og prosessmeteret kommer frem på statuslinjen, foretar programmet en syntakssjekk av filen og gir eventuelle feilmeldinger, med mindre man har fjernet avkrysningen for “Syntakssjekk”.

Dersom man er overbevist om at filen er syntaktisk korrekt, f.eks. fordi den har blitt produsert ved en forutgående eksport, kan man spare noe tid ved å hoppe over syntakssjekken. Programmet vil likevel stanse og gi feilmelding hvis noe er galt, men da kan innholdet i tabellene allerede være berørt.

Konverter fra OEM til ANSI

Ved importering kan programmet konvertere fra OEM til ANSI-tegnsettet. ANSI-tegnsettet brukes av Windows, OEM av DOS. Hvis man skal importere en fil som er produsert av et DOS-program, kan man dermed krysse av for konvertering fra OEM til ANSI for at bl.a. de norske bokstavene æ, ø og å skal bli riktig.

Importer

Når man trykker knappen ”Importer”, kommer det opp en dialog hvor man velger hvilken fil som skal importeres.

Nye versjoner av datamodellen

Programmet gir advarsel ved import dersom filen er eksportert med en tidligere versjon av datamodellen, med spørsmål om man likevel ønsker å importere filen.

Når databasene oppgraderes, kan også selve innholdet i tabellene bli endret i tillegg til definisjonen av tabellene, og slike datakonverteringer får man ikke med seg ved import. Importeringen er likevel et stykke på vei bakoverkompatibel ved at programmet hopper over kolonner som det vet er slettet, og kjenner igjen kolonner som har skiftet navn. Om det har blitt lagt til kolonner, trenger ikke det å ha noen betydning, med mindre logikken i programmet forutsetter at disse kolonnene har bestemte verdier.

Datavalidering

Etter at man har importert data, kan man få validert dem via menyvalget “Valider data” i Rediger-menyen, som kontrollerer at alle feltene har gyldige verdier i de radene som er markert. Hvis programmet avdekker en ugyldig verdi i et felt, flytter feltpekeren seg dit, og man får beskjed om hva som er galt. Etter at man har rettet feilen, kan man fortsette valideringen derfra og ut tabellen.

Hvis man importerer data til flere tabeller, kan det være at de har referanser til hverandre, i tillegg til at det kan være referanser mellom radene i enkelte tabeller. Ved at valideringen skjer etter at alle dataene er lest inn, spiller det ingen rolle hvilken rekkefølge de leses inn i, og man slipper gjentatte avbrudd og tidkrevende igangkjøringer under selve innlesningen.

Hvis man føler seg sikker på at dataene er korrekte, f.eks. fordi de har blitt validert i det systemet de ble registrert, hvilket utvilsomt er en fordel, kan man spare betydelig tid på unnlate å validere dataene på nytt. Programmet vil uansett kunne avdekke feil på et senere tidspunkt, f.eks. ved oppdatering av bilag.

a)

Eksempel på import av bunt

Figuren nedenfor illustrerer den bunten som blir produsert ved bokføring av ordren i eksemplet foran. La oss se hvordan en slik bunt kan importeres til VISMA Business.

Henter vi frem alle kolonnene og skriver bunten til fil, får vi følgende fil:

@WaBnd (BndNo, ValDt, SmDb, SmCr, 860, Att, R1, TxTrm, TxYr, CpBankCh, \

6823, Descr, SrNo, 6824, BankAcNo, BankIB, R6, 4585, CtrlSm, Keep, \

SrcJNo, SrcTp, AcPr, R2, Susp, BankOB, AcYr)

"1" "19991102" "71500" "71500" "0" "" "0" "0" "0" "0" "0" "" "0" "0" "0" \

"0" "0" "0" "0" "" "2" "9" "0" "0" "" "0" "0"

@WaVo (VoNo, VoDt, VoTp, Txt, DbAcNo, DbTxCd, CrAcNo, CrTxCd, Am, Emp, \

Att, R1, TxTrm, TxYr, BankG, CurAm, PmtTrm, VoGr1, VoGr2, BndNo, \

DbAutSt, DbAcCl, DbTrnCl, PropPrc, PropNo, EFT1, EFT2, EFT3, EFT4, \

Txt2, InvoNo, FixAm, FixCurAm, DstGr, DueDt, Exc, R6, CID, CshDueDt, \

CshAm, CshCurAm, CrAutSt, CrAcCl, CrTrnCl, Cust, Sup, LnNo, NoteNm, \

Qty, AgRef, VatAm, Task, AcPr, Pri, Act, R2, Ref, IntRt, Srt, PrevVoNo, \

TransSt, ExAut, ExRt, Cur, ValDt, AcYr)

"1000005" "19991102" "11" "Utgående faktura" "10240" "0" "0" "0" "61500" \

"0" "0" "0" "0" "0" "" "61500" "0" "0" "0" "1" "0" "1" "0" "0" "0" "0" \

"0" "0" "0" "" "1000005" "0" "0" "0" "19991102" "0" "0" "" "0" "0" "0" \

"0" "0" "0" "10240" "0" "1" "0" "0" "" "11500" "1" "0" "0" "" "0" "" "0" \

"1" "0" "0" "" "100" "47" "0" "0"

"120005" "19991102" "19" "Fakturert" "0" "0" "3010" "1" "61500" "0" "0" "0" \

"0" "0" "" "61500" "0" "0" "0" "1" "0" "0" "0" "0" "0" "0" "0" "0" "0" \

"" "" "0" "0" "0" "0" "0" "0" "" "0" "0" "0" "0" "3" "1" "0" "0" "2" "0" \

"0" "" "0" "0" "0" "0" "" "0" "" "0" "2" "0" "0" "" "100" "47" "0" "0"

"120005" "19991102" "19" "Fakturert" "4410" "0" "0" "0" "10000" "0" "0" "0" \

"0" "0" "" "10000" "0" "0" "0" "1" "0" "3" "0" "0" "0" "0" "0" "0" "0" \

"" "" "0" "0" "0" "0" "0" "0" "" "0" "0" "0" "0" "0" "0" "0" "0" "3" "0" \

"0" "" "0" "0" "0" "0" "" "0" "" "0" "3" "0" "0" "" "100" "47" "0" "0"

"120005" "19991102" "19" "Fakturert" "0" "0" "4990" "0" "10000" "0" "0" "0" \

"0" "0" "" "10000" "0" "0" "0" "1" "0" "0" "0" "0" "0" "0" "0" "0" "0" \

"" "" "0" "0" "0" "0" "0" "0" "" "0" "0" "0" "0" "3" "0" "0" "0" "4" "0" \

"0" "" "0" "0" "0" "0" "" "0" "" "0" "4" "0" "0" "" "100" "47" "0" "0"

I denne utskriften har vi først streket under alle tall- og tekstfelter som er forskjellig fra 0 eller blank, og deretter streket over de av feltene som programmet likevel kommer til å beregne på nytt ved import (sum debet og sum kredit), kolonner som bare ligger i hukommelsen (differanse og kontrolldifferanse, men som i dette eksemplet likevel er 0), eller som vil bli fylt ut hvis de ikke allerede er det (buntnr, linjenr og sorteringssekvensnr). I tillegg har vi streket over kolonner som ikke er nødvendig å ta med. De av feltene som er vist i kursiv skrift kan tas med i den utstrekning man har behov for dem; de andre feltene som ikke er understreket kan utelates, i likhet med dem som er overstreket.

Når vi utelater felter som er overstreket eller ikke understreket, og noen av feltene i kursiv, ender vi opp med følgende fil:

@WaBnd (ValDt)

“19991102”

@WaVo (VoNo, VoDt, VoTp, Txt, DbAcCl, DbAcNo, DbTxCd, CrAcCl, CrAcNo, \

CrTxCd, Cur, ExRt, CurAm, Am, InvoNo, DueDt)

"1000005" "19991102" "11" "Utgående faktura" "1" "10240" "0" "0" "0" "0" "47" \

"100" "61500" "61500" "1000005" "19991102"

"120005" "19991102" "19" "Fakturert" "0" "0" "0" "3" "3010" "1" "47" "100" \

"61500" "61500" "" "0"

"120005" "19991102" "19" "Fakturert" "3" "4410" "0" "0" "0" "0" "47" "100" \

"10000" "10000" "" "0"

"120005" "19991102" "19" "Fakturert" "0" "0" "0" "3" "4990" "0" "47" "100" \

"10000" "10000" "" "0"

I bunthodet har vi tatt med bare valuteringsdatoen, og på bilagslinjene bilagsnr, bilagsdato, bilagsart og -tekst, debet og kredit kontotype, kontonr og avgiftskode, valutanr, valutakurs, beløp i aktuell valuta og standard valuta, fakturanr og forfallsdato.

B.8 Kolonneoversikt

Nedenfor gjengis en oversikt over kolonnene i noen aktuelle tabeller. Første linje for hver tabell viser navnet på tabellen i databasen og på skjermen i henholdsvis 1. og 2. kolonne, og antall kolonner og bytes i 3. og 4. kolonne – både i databasen og totalt i hukommelsen, adskilt med /. De etterfølgende linjene viser kolonnene i tabellen; 1. kolonne viser navnet på kolonnene i databasen, eller “(MEMORY)” hvis en kolonne ikke ligger i databasen, 2. kolonne hvilke navn de har på skjermen (med originale tekster for det språket som benyttes), eller “(NO_READ)” hvis de ikke kan hentes frem på skjermen, 3. kolonne datatypen (heltall, flyttall eller tekst av en bestemt lengde), og 4. kolonne angir hvilke kolonner som er primærnøkkelkolonner (PRIMARY_KEY), og hvilke som er reservert for fremtidig bruk (FUTURE_EXT).

[1] Alle databasene inneholder en mastertabell, som bl.a. inneholder versjonsdatoen for datamodellen I bedriftsdatabasene inneholder den også parametre som kan settes via behandlingsmenyvalget for endring av tellere under bedriftsopplysninger. Modelldatoen i databasene blir sammenholdt med den i programmet for å avdekke om databasene trenger oppgradering når programmet startes.


InkassoNO

Eksport av filer til inkasso

I Visma Business finnes funksjonalitet for overføring av kundereskontro til inkasso. Både missligholdte poster og påfølgende endringer kan overføres via filer til inkassoselskapet.
Det forutsettes at kunden først purres det antall ganger som er oppgitt i ”Maks antall brev” for den enkelte kunde eller det antall purrebrev som finnes i tabellen Purrebrev. Ved godkjenning av siste purring vil kunden bli kredittsperret og være klar for overføring til inkassoselskap.

Filer som benyttes:

Eksport:

  • Inkassoliste (missligholdte poster, evnt. hele reskontro)
  • Endringsliste (betalinger, kreditnotaer)

Import:

  • Ingen

Parametersettinger:

MERK: Nødvendige parametere må settes FØR siste purring for at kunde og reskontroposter skal få ritktige statuser.

I Regnskapsbehandling i Bedriftsopplysninger finnes to parametre for inkasso:

  • Sett til inkasso etter siste purring
  • Overfør kun forfalte poster

Aktivering av inkassofunksjonaliteten gjøres ved å huke av ”Sett til inkasso etter siste purring”. I tillegg kan parameteret ”Overfør kun forfalte poster” benyttes hvis ikke hele reskontroen skal overføres i første overføringsfil.

To metoder:
Det finnes to metoder for bruk av inkassofunksjonaliteten i Visma Business.

  1. Overføre alle åpne poster på kunde i første Inkassoliste.
    (Bruk bare ”Sett til inkasso etter siste purring”)
  2. Overføre bare missligholdte poster i første inkassoliste, deretter nye forfalte (missligholdte) poster i ny inkassoliste.
    (Bruk både ”Sett til inkasso etter siste purring” og ”Overfør kun forfalte poster”)
  • ”Maks antall brev” på kunde. Når metode 2 benyttes må maks antall brev angis på aktøren for at eksporten skal kunne skille missligholdte og ikke-missligholdte poster. ”Antall purringer” på transaksjonen sammenlignes med ”Maks antall brev” på aktør.
  • Definere inkassoliste og endringsliste i tabellen ”Factoringselskap KID def.”

Tabellen benyttes til å angi hvilken imp-fil som skal benyttes som filter , og hvor eksportfilene skal ligge. Angi type i ”Fact. Behandling” (inkassoliste, endringsliste).

Rutinebeskrivelse

  1. Godkjenn siste purring
    Etter at siste purrebrev er godkjent settes statusen ”Til inkasso” på kunden (Kundepref). Samtidig settes kunden til ”Kredittsperret” (evnt. også ”Purrefritak” og ”Rentefritak” hvis dette er angitt i ”Etter siste purring” i Land-tabellen).
    Kunden er nå klar for utlegging av inkassoliste til fil, men normal praksis er å avvente noen dager for å gi kunden en sjanse til å betale siste purring. Tips – gjør utvalg på kunder med status ”Til inkasso” og ”Purret pr. dato” eldre enn f.eks. 14 dager.
  2. Kontroller inkassostatus
    Når tiden er inne for å legge ut inkassoliste, kjør først behandlingsmenyvalget ”Kontroller inkassostatus”. Med dette behandlingsmenyvalget kan du rydde i kundepreferanser i tabellen Aktører når inkassoposter er betalt før inkassolisten er sendt. Det vil si i løpet av perioden fra purringene er kjørt til inkassolisten blir sendt.
  3. Legg ut fil til inkasso
    Kjør behandlingsmenyvalget ”Overfør til inkasso” for å produsere inkassoliste. Samtidig settes statusen ”Overført til inkasso” på kunden og behandlede transer.
  4. Legg ut fil med endringer
    Endringer i reskontroen, dvs. betalinger og kreditnotaer, eksporteres til fil ved å kjøre behandlingsmenyvalget ”Legg ut endringsliste til inkasso”.
  5. Retur fra inkasso
    Når du får tilbakemelding fra inkassobyrået om at en kunde har gjort opp for seg, kan du markere kunden og benytte behandlingsmenyvalget Retur fra inkasso. Dette valget fjerner da følgende kryss i Kundepreferanser:
  • Purrefritak
  • Rentefritak
  • Til inkasso
  • Overført til inkasso

Behandlingsmenyvalget "Retur fra inkasso" fjerner også krysset i feltet Kredittsperre i tabellen Aktører.
Verdi i feltet Inkasso kjørenummer på transaksjonene blir ikke fjernet.

Forklaring til behandlingsmenyvalgene på kunde

For å utføre behandlingene må tabellene Aktører og Kundetransaksjoner kobles via fremmednøkkelen”Kundenr->Kundenr”. Følgende behandlingsmenyvalg som gjelder inkasso blir da tilgjengelig:

  • Kontroller inkassostatus
  • Overfør til inkasso
  • Legg ut endringsliste til inkasso
  • Retur fra inkasso

Se hjelpefilen for detaljert forklaring til behandlingsmenyvalgene.

Forklaring til statuser på kunde og transer

Kundepref. i tabellen Aktører har følgende statuser som gjelder inkasso:

  • Til inkasso (Siste purring er sendt. Kunden er klar for å sendes til inkasso)
  • Overført til inkasso (Inkassoliste er produsert)

Transstatus i tabellen Kundetransaksjoner har følgende statuser som gjelder inkasso.

  • Overført til inkasso (Transaksjonen er lagt ut på inkassoliste)
  • Tilbake fra inkasso (Behandlingsmenyvalget ”Retur fra inkasso” er kjørt)
  • Lagt til under inkasso (Nye poster som er bokført etter at kunden har fått status ”Til inkasso”. Benyttes av metode 1 ved utlegging til endringsliste.)

Merk! Metode 2 leser også transer uten statusen ”Lagt til under inkasso” for å kunne legge ut nye missligholdte poster på ny inkassoliste. Dvs. åpne poster som ikke var missligholdt ved utlegging av første inkassoliste.

Fritak fra inkasso

Kunder eller enkeltvise åpne poster som ikke skal til inkasso kan fritas fra dette. For kunden benyttes parameteret ”Inkassofritak” i Kundepref. For åpne poster benyttes ”2. Fritas for inkasso” i kolonnen Purrefritak.

Eksempel på bruk av ”Fritas fra inkasso” på åpen post:

Kunde har 2 åpne poster. Kun eldste er missligholdt og sendes til inkasso. På et senere tidspunkt mottar kunden en betaling på den nyeste fakturaen. Denne ønsker vi ikke å sende til inkassoselskapet via endringslisten og merker den derfor med ”Fritas fra inkasso”.


InkassoENG

Export of files to debt collection

Visma Business supports exporting of files to debt collection, and both overdue open entries and following payments and credit notes can be transferred to debt collectors.

Before sending the customer to debt collection all reminder letters must have been sent according to ”Max no. of reminders” on the associate, or the number of letters in table Reminders. After the last letter is sent, the flags for “Credit denied” and “To debt collection” are set and customer is ready to be transferred to debt collection.

File types in use:

Export:

  • Legal recovery list (overdue open entries / all entries)
  • Legal recovery list changes (payments, credit notes)

Import:

  • None

Parameter settings:

Note: Required parameters must be set before the last reminder letter in order to set correct statuses on the customer and transactions.

  • There is two parameters in ” Accounting processing ” regarding debt collection:
    • Set debt collection flag after last letter
    • Only transactions due for legal recovery

Activation of debt collection functionality is made by enabling the flag ” Set debt collection flag after last letter”. In addition the flag “Only transactions due for legal recovery” can be used if not the complete customer ledger shall be transferred in the first Legal recovery list.

Two methods:
There are two methods for the use of debt collection functionality in Visma Business.

  1. Transfer all open entries in the first file.
    (Set only ” Set debt collection flag after last letter”)
  2. Transfer only overdue open entries in the first file.
    (Set both ” Set debt collection flag after last letter” and ” Only transactions due for legal recovery”)
  • ” Max no. of reminders” in Associates table. When method 2 is used the ” Max no. of reminders” must be registered to distinguish overdue and not-overdue open entries. ”No. of reminders sent” of the transaction is compared with the ” Max no. of reminders” in Associates table.
  • Defining ”Legal recovery list” and ”Legal recovery list changes” in table ”Factoring firms and CID def.".
    The import file is the file that describes the format in which Visma Business is to save the data. The column “Factoring file” is used for defining the name of (and path to) the data file that is to be sent to the debt collection agency. Define type of file in column “Fact. Processing” (Legal recovery list, Legal recovery list changes).

Guidelines

  1. Print the last reminder letter
    After the last letter is printed the flag “To debt collection” is set in the associates table. Also the flag “Credit denied” is set (optionally also the flags for ”No reminder” and ”No interest” is set if “After last reminder” in Country table is used).
    The ”Legal recovery list” is now ready to be sent, but normal practice is to wait some days to give the customer a chance to pay last reminder. Tip - make selection for customers with the status "To debt collection" and "Last reminder date" earlier than, for example 14 days ago.
  2. Remove legal recovery status if settled
    When it’s time to send the Legal recovery list, run the process ”Remove legal recovery status if settled”. This process will clean up statuses in the Associates table if the open entries are paid already. That is, during the period from the last reminder letter is sent to the time that the file is to be sent.
  3. Transfer to debt colleciton
    Run the process ”Transfer to debt collection” in order to produse ”Legal recovery list”. At the same time, the status “Transferred to debt collection” is set for the customer and the transactions.
  4. List debt collection related transactions
    Changes in the ledger, i.e. payments and credit notes, are exported to file by running the process ”List debt collection related transactions” .
  5. Return from debt collection
    When the debt collection agency confirms that the customer has paid their open entries, run the process ”Return from debt collection”. This process removes the following flags in ”Customer options” :
  • No reminder
  • No interest
  • To debt collection
  • Transferred to debt collection

This process also removes ”Credit denied” in the associates table. “Debt collection run no.” on the transactions is not removed.

Explanation of the processes in Associates table

To be able to run the processes, the table Associates and Customer transactions must be joined by using foreign key ”Cust.no.->Cust.no.”. The following processes regarding debt collection will then be enabled:

  • Remove legal recovery status if settled
  • Transfer to debt colleciton
  • List debt collection related transactions
  • Return from debt collection

Refere to the help file for more regarding those processes.

Explanation of status on customer and transactions

“Customer options” in Associates table:

  • To debt collection (Last reminder letter is sent. Customer ready for transfer to debt collection)
  • Transferred to debt collection (Legal recovery list is sent)

”Trans.status” in Customer transactions table:

  • Transferred to debt collection (Transaction sent to debt collection)
  • Returned from debt collection (The process ” Return from debt collection” is executed)
  • Added during debt collection (New records that are updated after customer is flagged ”To debt collection”. This flag is used by method 1 when sending” Legal recovery list changes” .)

NOTE! Method 2 also read transaction without the flag ”Added during debt collection” in order to send new overdue open entries. This means open entries that was not overdue when the first file was sent.

Exempt from debt recovery

Customers or individual open entries that shall not be sent to debt collection can be exempted from this. To exempt the customer, the flag “Exempt from reminder letter” in “Customer options” must be used. To exempt an open entry, set “2. Exempt from debt recovery” in column “No reminders”.

Example where ”Exempt from debt recovery” is used:

Customer has two open entries. The oldest one is overdue and sent to debt collection. At a later stage the customer receives a payment on the newest open entry. This payment does he not want to send to the debt collection agency and it is therefore flagged “Exempt from debt recovery”.


Hensikten med dokumentet

I dette dokumentet vil vi gi en innføring i bruk av Avgrensninger og Kombinasjonsmatrise vist med eksempler.

Avgrensninger (Tabeller - Felles - Brukere)

Avgrensninger kan du bruke for å bestemme hvilke transaksjoner som skal være tilgjengelige for forskjellige brukere i tabellen vist i dialogen under.

Opprett avgrensningsgruppe med brukere som skal ha felles avgrensninger. Legg opp avgrensningene i tabellen Avgrensninger. Du må velge hvilken ansvarsenhet og intervall avgrensningen gjelder og i kolonnen Avgr.behandl. velge hvilke tabeller avgrensningen gjelder for. I dialogen kan du også bestemme om intervallet skal være tilgjengelig eller ikke og om transaksjoner uten ansvarsenhet skal være tilgjengelig.

Under kan du se eksempel på avgrensning:

Her er avgrensningsgruppe 1 Avdeling 200-201 i bruk på bruker standard og avgrensninger er satt opp med Ansvarsenhet 1 (Avdeling) og intervall 200 til 201. I dialogen for Avgrensningsbehandling er det satt at avgrensningen gjelder hovedbokstransaksjoner og at brukeren ikke skal se transaksjoner uten ansvarsenheter. I dette tilfelle vil brukeren kun få se hovedbokstransaksjoner med avdeling 200 til 201.

Her er avgrensningsgruppe 2 Avdeling 100 i bruk på bruker standard og avgrensninger er satt opp med Ansvarsenhet 1 (Avdeling) og intervall 100 til 100. I dialogen for Avgrensningsbehandling er det satt at avgrensningen gjelder alle transaksjonstabeller og at brukeren ikke skal se transaksjoner innenfor avgrensningen. I dette tilfelle vil brukeren få tilgang til alle transaksjoner unntatt de med Ansvarsenhet 1 (avdeling) lik 100.

Kombinasjonsmatrise (Tabeller - Felles - Brukere)

Kombinasjonsmatrisen kan du bruke for å bestemme hvilke ansvarsenheter, innenfor kontotype og kontointervall, en bruker skal få lov til å registrere bilag på.

Opprett kombinasjonsgruppe med brukere som skal ha felles kombinasjonsmatrise. Legg opp kombinasjonene i tabellen Kombinasjonsmatrise. Du må velge hvilken kontotype og intervall for ansvarsenhet(er) som skal være tilgjengelig i bilagsregistreringen for kombinasjonsgruppen. Det kan være flere linjer i kombinasjonsmatrisen for samme eller forskjellige kontotyper.

I eksempelet over er det for kombinasjonsgruppe 1 satt tilgang til hvilke avdelinger som skal være tilgjengelig på hovedbokskonto 3000 til 9999 i bilagsregistreringen. Ved registrering av bilag på hovedbokskonto innenfor angitt intervall med ansvarsenhet 1 som ikke er med i kombinasjonsmatrisen vil du få melding når du går til neste linje eller ved oppdatering av bunt (bunten vil ikke bli oppdatert).

Det blir kun testet på ansvarsenheter hvor det er angitt verdi i kolonnen for ansvarsenhet i kombinasjonsmatrisen.


Momsparameterar Sverige

Styrparametrar för moms (Sverige)

Huvudbokskonton

I tabellen huvudbokskonton finns ett antal paramtrar som man kan använda för att styra momsen med.

Fält

Beskrivning

Momskontroll

I detta fält kan du lägga in värden som kontrollerar vilken omsättningsklass som skall vara tillgänglig för kontot. Alternativen som finns är

1. Ingen moms

2. Bara försäljning

3. Bara inköp

Kontroll sker dels i denna tabell där fälten Omsättningsklass och Momskontroll måste stämma överens. På verifikationsraden sker kontroll när man fyller i Debet/kreditkonto och omsättningsklass. Även vid uppdatering sker kontroll och programmet sätter felstatus på transaktioner med omsättningsklasser som strider mot värdet i fältet Momskontroll.

Omsättningsklass

I detta fält kan man ange en omsättningsklass som skall föreslås som debet eller kredit omsättningsklass på verifikationsrader vid registrering av motsvarande huvudbokskonto. Omsättningsklassen styr vilka kontonsaldon som skall ackumuleras i summa momspliktig försäljning, Eu-inköp etc på momsrapporten.

OBS! Huvudbokskontots omsättningsklass används förutsatt att inte omsättningsklassen är angiven på aktuell verifikationstyp eller hämtats via kund eller leverantör som finns med på verifikationen.

Momskod

Här kan du registrera den momskod som du vanligtvis kommer att använda på huvudbokskontot. Denna momskod föreslås varje gång du registrerar en verifikation på aktuellt konto. Momskoden styr vilken typ av moms och vilken momssats som skall beräknas på verifikationen.

OBS! Har du kryssat i fältet "Ignorera momskod" på den aktuella verifikationstypen kommer inte programmet att föreslå momskod trots att det är angivet på kontot.

Ange momskod

Här kryssar man i om man vill att markören skall stanna i fältet för debet/kredit momskod vid verifikationsregistrering på kontot.

OBS! Har du kryssat i fältet "Ignorera momskod" på aktuell verifikationstyp kommer programmet att hoppa över fältet "Momskod" även om du har kryssat i detta fält

Verifikationstyp

I tabellen verifikationstyp finns ett antal fält som överstyr andra satta momsparametrar.

Fält | Beskrivning
Omsättningsklass | I detta fält registrerar du omsättningsklassen för verifikationstypen. Visma Business kommer då att föreslå denna istället för den som är registrerad på debet-/kredit kontot på verifikationsraden
Ignorera momskod | Om du kryssar i detta fält beräknar inte Visma Business moms på verifikationer med denna verifikationstyp

Aktörer

I aktörtabellen finns ett antal parametrar som man kan styra momsen med.

Fält

Beskrivning

Område

I detta fält definierar du om kunden/leverantören ligger inom eller utom EU. Fältet sätter sedan omsättningsklass på verifikation och kontrollerar att korrekt momskod anges på verifikationerna . Vid fakturering och inköp används område tillsammans med "Transaktionstyp" och "Tjänst" för att ta fram korrekt omsättningsklass.

Momskod

Ange den momskod som är vanligast förekommande för kunden/leverantören. Momskoden föreslås vid registrering av försäljnings- eller inköpsorder, eller vid verifikationsregistrering på kund/leverantör förutsatt att Kund/Levpreferenser är ikryssde för att föreslå momskod (se nedan).

OBS! Vid orderregisitrering överstyr denna momskod eventuell momskod i moms- och bokföringsupplysningar.

Kundpref./Lev.pref: Föreslå momskod

I fältet Kund- resp. levpreferenser finns en kryssruta som heter "Föreslå momskod" Vid registrering av verifikationer kommer systemet att föreslå kundens/leverantörens momskod.

Automatkonteringar

I tabellen där man registrerar in automatkonteringar kan man även styra momshanteringen för dessa automatkonteringar, om det är så att det skiljer sig från hur kontot normalt sett hanteras.

Fält

Beskrivning

Debet/Kredit momskod

Vill du ha en speciell momskod för den aktuella automatkonteringen, kan denna anges för varje enskilt debet/kreditkonto. Denna kod överstyr i så fall det som eventuellt är angivet på kontot i tabellen "Huvudbokskonton".

Momskodbehand-ling

I detta fält anger du hur momskoderna i ovan nämnda fält skall behandlas.

0 - Kopieras från konto

1- Överskrivet på aut.kont.rad - Fältet för debet/kredit momskod kopieras från automatkonteringsraden till de nya verifikationsraderna som läggs till automatiskt.

2- Kopieras från verifikationsrader - Systemet använder debet/kredit momskod från den verifikationsrad som automatkonteringarna expanderas utifrån.

3- Dra ifrån momsbelopp - Andelen på automatkonteringsraden beräknas utifrån beloppet på huvudverifikationsraden minus värdet i fältet för momsbelopp.

Inventarier

Även i inventarietabellen finns möjlighet att ange momskoder.

Fält

Beskrivning

Momskod

I detta fält registrerar du vilken momskod som skall gälla för inventariet. Visma Business föreslår denna momskod på verifikationsraden för inventariet.

OBS! Om du låter fältet vara tomt föreslår systemet istället momskoden på det huvudbokskonto som är kopplat till inventariet.

Pris- och rabattmatrisen

Fält

Beskrivning

Momskod

Om man vill att vissa kombinationer av kunder-produkter skall ha en speciell momskod kan man styra detta från pris- och rabattmatrisen. Man anger produktnr, kundnr och momskod på egna rader i matrisen. Vid orderregistrering på denna kund hämtas då den speciella momskoden till orderraden för denna produkt. Övriga orderrader med andra produkter får momskod enligt kund eller enligt moms- & bokföringsupplysningar.

OBS! Om man i Moms & Bokföringingsupplysningar kryssat i för "Överstyr momskod order" så gäller inte denna momskod, utan den som finns på Moms- & bokföringsgruppen. (se nedan)

Moms- och bokföringsupplysningar

Fält

Beskrivning

Momskod inköp/ momskod försäljning

Här kan man ange vilken momskod som skall gälla vid försäljning resp. inköp av produkterna inom varje grupp. Denna momskod hämtas fram till orderraderna om inte

a) momskoden hämtas från kunden/leverantören

b) momskoden är speciellt angiven för viss produkt i pris och rabattmatrisen.

OBS! Om område är angivet på kunden/leverantören som är fritt från moms, beräknas inte någon moms oavsett värde i momskod.

Överstyr momskod order

Om detta fält är ikryssat gäller vid orderregistrering den momskod som finns angiven på denna rad, oavsett om det finns momskod på produkten i pris- och rabattmatrisen eller på kunden/leverantören.

Land

Fält | Beskrivning
Momskod fakturaavgift | Här anger man den momskod man vill ha på eventuell debiterad fakturaavgift. Finns ingen momskod här beräknas inte moms på fakturaavgiften.

Vad överstyr vad

Vid manuell verifikationsregistrering/fakturaregistrering

Omsättningsklass

Omsättningsklass kan fyllas i på verifikationsraderna utifrån tre olika förutsättningar - från huvudbokskonto, från kund/leverantör eller från verifikationstyp. De tre olika sätten att hämta fram omsättningsklass är prioriterade enligt nedan:

  1. Verifikationstyp

  2. Kund/Leverantör

  3. Huvudbokskonto

D.v.s om omsättningsklass finns angivet på den aktuella verifikationstypen, så styr den över alla andra värden. Om så inte är fallet så styr den omsättningsklass som kommer från kunden/leverantörens område.

OBS! Var uppmärksam på att området på kunden/leverantören - i förlängningen omsättningsklassen - även styr över momskod som inte stämmer med omsättningsklassens förutsättningar. Vid momsfritt område beräknas således ingen moms trots att momskod finns angiven på kund/leverantör. Detta gäller oavsett om man angivit i preferenserna att momskod skall föreslås.

Momskod

Momskoden kan hämtas fram till debet/kredit kolumnerna på verifikationsraden från lite olika sätt. Den kan hämtas från huvudbokskontot, från kund/leverantör, från automatkonteringstabellen om det handlar om automatkontering och från inventarier.

Även här är det Verifikationstypen som styr först. Men i detta fall handlar det om att man kryssar i "Ignorera momskod" för att undvika att momskod anges på verifikationerna.

OBS! Tänk på att det endast är momskoden som ignoreras. Omsättningsklassen bokas ändå. Så om "Ignorera momskod" används bör man även se till att man satt övriga parametrar korrekt som gäller omsättningsklass.

Om man på kund eller leverantör har ikryssat i kund-/leverantörpreferenser att systemet skall föreslå momskod så gäller den momskod som finns på kunden/leverantören före eventuell momskod på huvudbokskonto som motkonteras.

OBS! Var uppmärksam på att område styr över momskoden på kunden/leverantören. Detta innebär att om angivet område är ett momsfritt område och t.ex. kunden har momskod 1, 2 eller 3 så sker ingen momsberäkning.

OBS! Om du manuellt registrerar verifikationer där kunden och huvudbokskontot inte registreras på samma verifikationsrad så används dock den momskod som ligger på huvubokskontot.

Sammanfattningsvis kan man alltså säga att momskod hämtas enligt följande prioritetsordning:

  1. Verifikationtyp med "Ignorera momskod" - ingen moms

  2. Kund/Leverantörspreferenser "Föreslå momskod" - kundens momskod förslås.

  3. Momskod från automatkonteringstabellen eller inventarier.

  4. Huvudbokskontots momskod.

Vid orderregistrering

Momskod

Vid orderregistrering finns andra parametrar som kan överstyra momskoder som finns på t.ex. kunden, vilket i och för sig kanske är det vanligaste. Listan nedan beskriver den prioritetsordning systemet har gällande vilken momskod som skall gälla.

  1. Moms- & bokföringsupplysningar med kryss för "Överstyr momskod order"

  2. Pris- & rabattmatris - vid angiven kombination av "Produkt", "Kund" och "Momskod".

  3. Aktörens momskod - "Momskod kund" / "Momskod lev" i aktörsregistret.

  4. Moms- & bokföringsupplysningar.

Omsättningsklass

Omsättningsklass på transaktioner som kommer från Ordersystemet sätts uteslutande utifrån aktörens område. Kombinationen av värden i fälten "Område", "Transaktionstyp" och "Tjänst" sätter korrekt omsättningklass.

Omsättningsklass går före Momskod

Genom hela systemet gäller att där hämtad/angiven omsättningklass inte matchar/stämmer med den angivna/hämtade momskoden så är det omsättningsklassen som styr. Har man en omsättningklass som innebär att det är momsfritt så bokas ingen moms trots att det finns momskod på transaktionen.


Omsetningsoppgavelogg

Fra versjon 4.60.3 kan du om ønskelig reversere omsetningsoppgave under omsetningsoppgavelogg. Denne finner du under Tabeller – Felles – Logger – Omsetningsoppgavelogg i Visma Utforsker (Ctrl+O)

For å finne riktig omsetningsoppgavenummer må dette hentes frem under regnskapsrapporter – MVA-rapport. Stå i avgiftsterminer og hent frem omsetningsoppgavenummer. (Ctrl+U)

Deretter kan du gå inn under omsetningsoppgavelogg, markere raden med riktig omsetningsoppgavenummer og velge Behandling – Trekk tilbake omsetningsoppgave.

Da får du følgende dialog:

Det er huket her ut i fra om bunten er oppdatert eller ligger i bilagsbehandling til oppdatering. Hakene kan overstyres om dette er ønskelig.


Rapportering av valutatransaksjoner

Bankene har fra 01.07.05 fått endret sitt krav vedrørende spesifikasjon av valutatransaksjoner. Grensen som tidligere var kr 25.000,- er nå fjernet, det vil si at alle transaksjoner må merkes med deklareringskode for at bankene skal akseptere disse.

Disse kan opprettes manuelt i Teksttabellen med teksttype lik 131 eller de kan importeres fra filen Deklareringskoder.txtil den enkelte firmabase.

Standard deklareringskode kan du fra versjon 4.50 legge inn i tabellen Bankpartner. Denne verdien blir kun benyttet dersom det ikke er angitt deklareringskode på transaksjonen under bilagsregistrering eller på betalingslinjen.

Deklareringstekst må angis på betalingslinjen. Her kan du legge tilleggsinformasjon om betalingen, men såvidt vi kjenner til er det ingen formkrav til dette. Foreslår at du sjekker dette med din bank.

Landkode for bank når betalingsmottakers bank og betalingsmottaker er i forskjellige land:

Dette blir håndtert via Swiftkode og IBAN kontonummer da disse inneholder nødvendig informasjon.

Du kan kopiere Deklarasjonstekst.txt her


SIE 4 Test - Sverige

SIE TEST har tagits fram för att på ett enkelt sätt kunna följa med i det förbättringsarbete som ständigt bedrivs med SIE 4. SIE TEST innehåller samma ”programkod” som filen ”sie.dll”, vilken medföljer varje version av Visma Business.

SIE TEST erbjuder möjligheten att ta tillvara de senaste förbättringarna i SIE 4, utan att behöva uppgradera till senaste version av Visma Business.

När filen TEST_SIE.exe startas, erhålls följande dialog:

Server = SQL-server namn som ska nyttjas

Database = Företagsdatabas som skall användas

SQL user = Användarnamn i SQL-server

SQL password = Password SQL-server

Business user = användarbnamn i Visma Business

Company name = används inte

SIE data path = Sökväg till mapp där SIE-filer förvaras


SIE - standard import eksport

SIE –standard import export

Bakgrund

SIE vilar på tre ben. "S" som står för Standardiserad, "I" för Import och "E" för Export. Standardiserad Import och Export helt enkelt.

Standard:

Bakom SIE står flertalet av landets affärssystem, revisions- och redovisningsbyråer. Och de har tänkt till. Gör man det och är man många som tillför sin expertis, delar på kostnaden och kommer på en bra lösning , så blir det lätt, smart, snabbt och billigt. Speciellt om man standardiserar lösningen och gör den tillgänglig för alla som vill.

Import:

För att det finns många försystem till ekonomisystemen som skapar bokföringsunderlag till dem. Försystem som faktureringssystem, lönesystem, hyressystem, bokslutssystem och så vidare. Men trots att dessa system är datoriserade så kan de sällan prata direkt med ekonomisystemet. Nej, du måste skriva ut ett bokföringsunderlag och sedan knappa in det för hand. Omständligt, långsamt och inte särskilt tillförlitligt.

Tills SIE kom.

Nu kan ett försystem generera en SIE fil. Den i sin tur importeras av ekonomisystemet och blir automatiskt en bokföringspost där. Med bara några musklick.

Export:

För att behovet av att deklarera, analysera, göra bokslut eller revision i olika eftersystem också är viktigt. Tidigare fick du skriva ut dina rapporter på papper från ekonomisystemet för att sedan manuellt knappa in dem i eftersystemen. Likaså det omständligt, långsamt och inte särskilt tillförlitligt.Det förändrades också i och med SIE. Exporterar du en fil så kan dessa system läsa in uppgifterna och automatiskt placera dem rätt. Trots det är din arbetsinsats även här, bara några musklick.

Fyra varianter av SIE:

SIE typ 1 - innehåller kontoplan, SRU-koder och årssaldon (för skatte- och analyssystem med flera)

SIE typ 2 - innehåller dessutom periodsaldon (för analyssystem med flera)

SIE typ 3 - innehåller dessutom objektsaldon (för analyssystem med flera)

SIE typ 4 - innehåller transaktionsinformationen (för försystem som vill skapa bokföringsordrar eller för att låta redovisningsbyråer göra bokslut, med flera) eller analyser på transaktionsnivå.

Exempel på användningsområden av SIE och de olika filtyperna.

SIE typ 1, 2 och 3 används bara för att exportera data från ekonomisystem för att sedan läsas in i andra eftersystem.

SIE typ 4 används dels för att exportera data från ekonomisystem till eftersystem, men kan också användas för att importera data från försystem. Vid import till ekonomisystem blir SIE typ 4 - filen en bokföringstransaktion i systemet.

I bilden ovan ser du exempel på olika användningsområden, som du förstår så används ordet import och export utifrån ekonomisystemets perspektiv

De olika typerna av SIE-filer

Allmänt om de olika filtyperna.

Exportbehoven från redovisningsprogram till eftersystem kan vara olika omfattande. Förekomsten av olika uppgifter i redovisningen kan också variera beroende på redovisningsprogrammets möjligheter.

Beroende på programvaruföretagens ambitionsnivå tillåts därför informationsmängden i en exporterad fil att variera.

Filtyperna 1, 2 och 3 är olika nivåer på exporten av saldon från redovisningsprogram. Typ 4 specificerar ett filformat för import och export av verifikationer.

Typ 1 - Export av bokslutssaldon<

Denna typ innefattar de posttyper som behövs för export av årssaldon till olika eftersystem. Årssaldon är ofta tillräckliga för program för deklaration eller årsredovisning. Filtyp 1 innehåller relativt lite information och tillåts främst av historiska skäl. Vi rekommenderar att alla nya implementationer av SIE-export omfattar mist typ 2.

Typ 2 - Export av periodsaldon

Typ 2 är en utökning av typ 1 och ska således innehålla alla poster som specificerats för typ 1. Dessutom ingår i filer av denna typ poster för periodvisa saldon samt periodvisa budgetsaldon. Innehållet i denna filtyp är avsedd att användas av olika typer av analysprogram.

Typ 3 - Export av objektsaldon

Denna typ av exportformatet innefattar export av saldon på objektnivå. Då program från olika tillverkare hanterar objekt på mycket varierande sätt har här gjorts ett försök att generalisera begreppen.

Typ 4 - Import/Export av transaktioner

Detta filformat är avsett för att importera och exportera transaktioner till/från redovisningsprogram. Exempel på importfiler är filer som genereras av försystem, t ex ett faktureringssystem. Genom att här använda SIE-formatet ges stora möjligheter att använda försystem från en programtillverkare samtidigt som man använder ett redovisningsprogram från annat håll. Detta är speciellt intressant då många försystem är skräddarsydda branschlösningar. Genom att försystemet stödjer SIE-formatet erhåller man större valfrihet vid val av redovisningsprogram.

Import av transaktioner används även då man utnyttjar speciella bokslutsprogram. De transaktioner som genereras av bokslutsprogrammet kan då enkelt återföras till redovisningsprogrammet.

Export av transaktioner är kanske inte lika vanligt. Dock finns ett stort behov av detta i samband med bl a datorstödd revision. Genom att exportera samtliga transaktioner ur redovisningsprogrammet kan ett revisionsprogram utföra olika automatiska kontroller.

Då det inte är önskvärt att ha olika filformat för import och export bygger dessa på samma filformatspecifikation. Dock förekommer vissa skillnader i vilka poster och fält som är obligatoriska.

Format i Visma Business

I Visma Business finns stöd för Export av SIE-1 och SIE-4 samt Import av SIE-4

SIE-Import i Visma Business

Import av SIE-filer finns tillgänglig under menyvalet Alternativ/ Systemadministration/ Importera. En dialog visas där man bl.a. väljer till vilken databas man vill göra importen.

Genom att markera alternativknappen ”Specialformat” visas så endast två alternativa importformat. Här skall du givetvis markera SIE.

Nu visas en ny dialog innehållande två ”flikar”. En för export av SIE och en för Import. Du klickar då på fliken för ”Import”.

Det första man skall göra nu är att leta upp den fil som skall läsas in, vilket man gör i dropplisten längst upp till vänster under ”Filer att läsa in”.

Förutsättningar

För att du skall hitta filen gäller några förutsättningar.

· För det första måste filen ha ändelsen .SI (det är SIE-standard för import)

· Filen skall vara placerad i en mapp som heter SIE och som i sin tur skall ligga i en mapp med företagsnumret vilken är placerad i Visma Business programkatalog. Exempel på struktur är: ...\Business\F0001\SIE\siefil.si

· Den fil som skall importeras får inte tidigare vara inläst. Efter inläsning flaggas filens första post med värdet 1 istället för 0 på icke inlästa filer.

Den här filen är inte tidigare inläst då #FLAGGA har värdet 0

Efter val av fil visas nu vissa egenskaper i filen:

I fältet ”Dimensioner från fil” visas nu vilka redovisningsdimensioner som är definierade i filen. Dessa skall nu matchas mot önskade ansvarsenheter i Visma Business. De ansvarsenheter som finns upplagda i Visma Business visas nu i fältet ”Redovisningsdimensioner”.

Du matchar dessa genom att först dubbelklicka på önskat värde i det vänstra fältet och därefter på önskad dimension i mittenrutan. För att ”koppla” dessa klickar du sedan på den lilla rutan med pilarna och då visas kopplingen i den högra rutan.

Detta innebär att alla transaktioner som i filen finns på Dimension 2 – K-ställe nu kommer att registreras på K-ställe i Visma Business.

Fortsätt så med övriga redovisningsdimensioner.

Till sist skall man ange vilken verifikationsserie man vill att importen skall gå in på. I dropplisten ”Serienr” visas alla serier som finns upplagda i Visma Business. Om import av SIE-fil sker löpande bör en speciell serie för ändamålet läggas upp, så att man enkelt kan härleda dessa transaktioner.

Så är alla inställningar i dialogen klara och man startar importen via knappen ”OK”.

Kontroller

Vid importtillfället sker ett antal kontroller mot värden i Visma Business samt även uppläggning av vissa värden.

· Kontroll att filen inte tidigare är inläst som beskrivet ovan

· Kontroll att organisationsnummer i filen överensstämmer med organisationsnummer i Visma Business.

· Kontroll att räkenskapsår i filen finns upplagt i Visma Business.

· Kontroll om Huvudbokskonto finns. Om kontot saknas läggs detta upp med nummer och namn.

· Kontroll om definierade Redovisningsdimensioner/Ansvarsenheter finns i Visma Business. Om värde saknas registreras detta i systemet med nummer och namn.

OBS! Du måste själv se till att övriga parametrar på konto resp. ansvarsenheter läggs upp manuellt. Exempel på sådana parametrar är ”Kontogrupp” på huvudbokskonto så att kontot kommer med i Resultat / Balansrapporter.

Loggning av ändringar

De ändringar som görs vid import av SIE loggas i en speciell fil som finns i en undermapp till SIE-mappen där du har din SIE-fil. Mappen heter system och där skapas en fil för kontoförändringar , ”Logg Konton.txt”, och en fil för ändringar av ansvarsenheter som heter ” Logg Objekt.txt”.

Bunt i Visma Business

När importen är färdig visas ett statusmeddelande längst ned i dialogen

En bunt med ursprung ”12 Import” skapas i Visma Business

OBS! Glöm inte att se över kontoplan och ansvarsenheter efter importen och komplettera med nödvändiga uppgifter.

Export SIE typ 4 i Visma Business

Export av SIE typ 4 startas på liknande sätt som importrutinen. Gå via menyvalet Alternativ / Systemadministration / Export. I dialogen väljs det företag man vill exportera från. Markera alternativknappen ”Specialformat”.

Markera SIE 4 och tryck på ”Exportera”.

>Nu visas samma dialog som vid Import SIE, men nu skall fliken för Export vara aktiv.

Börja med att ange ”Startperiod” och ”Slutperiod”. I dropplisterna visas de perioder som finns upplagda i Visma Business. Du kan välja en enskild period eller flera perioder.

Nu skall du markera vilka ansvarsenheter du vill ha med i exportfilen. Dialogen innehåller SIE-formatets standardbegrepp, vilka kan kännas främmande för en Visma Businessanvändare. Vi skall här förklara innebörden.

Förklaring dimensioner enligt SIE-formatet

Deklaration av dimensioner

För att det importerande programmet ska veta vad filens objektsaldon har för innebörd måste det först i filen ligga en beskrivning av dimensionerna. Varje dimension åsätts här ett dimensionsnummer. I deklarationen anges också dimensionernas samband, t ex om de är hierarkiska. Ett läsande program kan således använda dessa deklarationer för att avgöra hur objektsaldona ska utnyttjas samt vilka saldon som är av intresse.

En deklaration kan t ex se ut på följande vis:

#DIM 1 "Kostnadsställe"
#UNDERDIM 2 "Kostnadsbärare" 1
#DIM 6 "Projekt"

Deklarationen av dimensioner är i princip fri. Dock reserveras vissa dimensionsnummer för en del vanligt förekommande objekttyper.

Enkla dimensioner

I det enkla fallet har dimensionerna inget samband med varandra. I dessa fall deklareras dimensionerna på följande vis:

#DIM 7 "Anställningsnummer"

Export av objekten inom dimensionen sker därefter på följande vis:

#OBJEKT 7 "23" "Sven Svensson"

Export av saldon sker enligt följande:

#PSALDO 0 199301 5010 {7 "23"} 200.00

Hierarkiska dimensioner

Vissa objekt är en ren uppdelning av överliggande objekt. Koden för underliggande objekt saknar innebörd om inte överliggande objekt anges. Avdelning 01 kan t ex ha tre underavdelningar (01, 02 och 03) medan avdelning 02 har fyra underavdelningar (01, 02, 03 och 04). Att här ange endast koden för underavdelning (t ex 02) ger ej fullständig information om vilken avdelning som avses.

En underdimension deklareras på samma sätt som en vanlig dimension. Dock tillfogas information om vilken dimension som är överordnad. Exempel:

#DIM 20 "Avdelning"
#UNDERDIM 21 "Underavdelning" 20

Vid export av hierarkiska objekt exporteras saldon för de överliggande objekten för sig, och saldon för de underliggande för sig. Vid export av underobjekten konkateneras koderna för överliggande och underliggande objekt.

Exempel:

#DIM 20 "Avdelning"
#UNDERDIM 21 "Underavdelning" 20
#OBJEKT 20 "01" "Barnavd"
#OBJEKT 20 "02" "Ungdomsavd"

#OBJEKT 21 "0101" "Spädbarn"
#OBJEKT 21 "0102" "Barn 1-3 år"
#OBJEKT 21 "0103" "Barn 4-6 år"
#OBJEKT 21 "0201" "Högstadieungdom"
#OBJEKT 21 "0202" "Gymnasieungdom"

#PSALDO 0 199301 4010 {20 "01"} 49655.00
#PSALDO 0 199301 4010 {20 "02"} 200.00
#PSALDO 0 199301 4010 {21 "0101"} 13200.00
#PSALDO 0 199301 4010 {21 "0102"} 7800.00
#PSALDO 0 199301 4010 {21 "0103"} 28655.00
#PSALDO 0 199301 4010 {21 "0201"} 200.00

Exportdialogen i Visma Business

SIE-Dim:

Detta är de olika alternativa värden i SIE-filen man vill koppla en ansvarsenhet till. Nummerserien för dessa val är inte i sekvens vilket beror på att vissa värden är hårt knutna till t.ex. kundnummer eller leverantörnummer och vissa värden är till för framtida bruk. Dessa nummer kan man således inte koppla egna ansvarsenheter till och vi har då valt att inte visa dem i dialogen.

Här väljer du t.ex. värde 1

Redovisningsdimension:

I denna ruta visas de ansvarsenheter som finns upplagda i Visma Business och som du kan välja att koppla till markerat värde i SIE-Dim

I vårt exempel väljer vi att SIE-Dim ”1” skall kopplas till redovisningsdimension ”K-ställe (R1)”

Super-Dim:

Om man arbetar med hierarkiska redovisningsdimensioner liknande den som exemplifieras i beskrivningen ovan skall man här ange vilken övergripande dimension den markerade ansvarsenheten skall tillhöra. Detta fält kan uteslutas.

Koppl. Dimensionstabell för SIE:

Här visas den markerade kopplingen.

Om man ångrar den koppling man gjort och vill börja från början markerar man värdet i denna ruta och trycker på “Delete”-knappen. Följande dialog visas och man har möjlighet att ignorera åtgärden eller gå vidare och ta bort valet.

Om man tidigare exporterat en SIE-4 fil för det aktuella företaget sparas de angivna kopplingarna I en s.k. “ini-fil” och därmed föreslås samma värden i denna dialog nästa gång man startar rutinen för SIE-export.

Fritext:

I detta fält finns möjlighet att skriva en fritext som upplysning vilket sedan skrivs i det fält som heter Prosa i exportfilen

När du gjort alla kopplingar du önskar – man behöver inte ta med alla ansvarsenheter eller någon alls om man inte vill – trycker du på “OK” och exporten startas.

Filnamn och sökväg

Vid export skapas en fil som heter SIE.SE, vilket är definierat i programkoden och kan inte ändras. Denna fil sparas i en mapp som heter SIE vilket är en undermapp till en mapp med samma namn som företagsnumret, t.ex. F0001. Dessa återfinns i programkatalogen för Visma Business.

Notera att det inte finns någon registernyckel till denna sökväg.

Exempel på sökväg och filnamn:

…Business \ F0001\SIE\SIE.SE

Inte heller sökvägen kan ändras, utan är definierat i programkoden.

OBS! Det är viktigt att användaren som skall utföra exporten har rättigheter att skriva i den aktuella mappen. Finns sådana begränsningar kommer inte SIE-filen att kunna skapas i mappen.


Valuta 2

Formål

Kunne registrere 3 valutaer på alle transaksjonen relatert til standard valuta eller en forhåndsbestemt definert valuta eller en valuta som bestemmes på ordre/bilags-registrerings tidspunkt

Tabellen Bedriftsopplysninger

Definerer du hva som er Valutanr.” og ”Valutanr. 2”

”Valutanr.”

  • Valuta som du rapporterer til myndighetene
  • Denne valutaen vil også gjelde i enhver situasjon, hvis ikke annet er oppgitt på kunde/leverandør

”Valutanr.2”

  • Det som blir oppgitt her fylles som default under bilagsregistrering i feltet Valuta2

Under feltet ”Regnskapsbehandling” finner vi parametere for valuta 2 styringen.

  • Fast ”Valutanr.2”
  • Sperrer feltet for overstyring av Valutanr. 2

  • Fast ”Valutakurs2
    • Sperrer for overstyring av Valutakurs2
  • Beregn ”Beløp i valuta2” fra ”Beløp i valuta”
    • ”Beløp i valuta 2” blir beregnet fra feltet ”Beløp i valuta”

    Tabellen Valuta2 kurser

    • Regulerer forholdet mellom Valuta og Valuta2
    • Hvis parameteret Beregn ”Beløp i valuta2” fra ”Beløp i valuta” er slått på, må du registrere valutaforhold i ”Valuta2” tabellen.

    I feltet ”valutanr” på bankpartneren kan du angi hvilken valuta kontoen er i. Dvs si at dersom du har en konto i Euro og du betaler i Dollar så må agioen forholde seg til 3 valutaer NOK Euro og Dollar. Dette gjelder spesiellt innen shipping

    Med konto mener vi bankkonto i banken.

    Korreksjoner av valutatransaksjoner

    Endre historiske transer

    • Dette kan adgangsreguleres
    • Gir mulighet for å korrigere historiske transer
    • Få registrert Valuta2 beløp på den historiske transen
      • Oppdatere historiske transer med ”riktige” kurser
      • Vil korrigere ut fra hva som ligger i Valuta2 tabellen

      Tabellen Bilagsarter

      Eksempel saldoinnleggelse.

      I feltet ”Bilagsartbehandling” har vi blant annet følgende parameter:

      Kryss på de 2 øverste gir deg:

      • Mulighet for innleggelse av kun Valuta2 saldoer
      • Nyttig blant annet for valutajustering på bankkonto
      • Evt. rette opp valutafeil.


Visma Business MVA, endring 01.01.2005

Stortinget har vedtatt endringer i merverdiavgiftssatsene fra 1. januar 2005:

· Den ordinære satsen økes til 25 %.
· Satsen på næringsmidler reduseres til 11 %.
· Satsen for persontransport, fergetransport og kringkastingsavgiften økes til 7 %.
· Tjenester i form av rett til å overvære kinoforestilling er avgiftspliktig med en sats på 7 %.

Slik legger du inn de nye satsene i Visma Business

I standard oppsett. Åpne Administrasjon, Vedlikehold bedriftsdata, vinduet 9100. Bedriftsparametere og fanen Avgiftskoder. I tabellen Merverdiavgift må du hente frem kolonnene (Ctrl+u) Fom. dato og Ny sats.

Dersom du ikke har standard oppsett, kan du åpne tabellen Merverdiavgift via Visma Utforsker (Ctrl+o), Tabeller, Felles og Faste opplysninger. Legg inn de nye satsene som vist under.

Overgangsregler

Skattedirektoratet har fastsatt overgangsregler i en egen forskrift nr. 129 som i korthet går ut på:

· Ved levering av varer og tjenester etter 31. desember 2004 skal de nye satsene benyttes. Dette gjelder selv om avtale om levering er inngått i 2004.

· Løpende ytelser som er fakturert før 31. desember 2004, men som først leveres etter denne dato, skal også avgiftsberegnes med de nye satsene.

· Varer og tjenester som ble levert før 1. januar 2005 skal avgiftsberegnes med tidligere satser selv om faktura utstedes etter denne dato.

· Satsendringene medfører ikke at det blir laget nytt skjema for omsetningsoppgave. I den ordinære omsetningsoppgaven skal det derfor tas med omsetning både med 24, 12 og 6 % og omsetning med 25, 11 og 7 %. Omsetning som skal avgiftsberegnes med de satser som gjaldt før 1. januar 2005, men som ikke faktureres før i 2005, tas med på de samme poster i omsetningsoppgaven. Dette vil igjen innebære at beløpet for beregnet merverdiavgift ikke utgjør forventet prosent av beregningsgrunnlaget.

Hvordan håndtere dette i Visma Business

Det er kun punktene under, i Overgangsreglene, som kan være en utfordring i Visma Business.

Ved levering av varer og tjenester etter 31. desember 2004 skal de nye satsene benyttes. Dette gjelder selv om avtale om levering er inngått i 2004.

Løsning:

Du kan løse dette ved å endre sats for merverdiavgift, midlertidig, i tabellen Merverdiavgift til 25%, 11% eller 7% under fakturering av varer og tjenester som skal leveres i 2005, men som du fakturerer i 2004.

Varer og tjenester som ble levert før 1. januar 2005 skal avgiftsberegnes med tidligere satser selv om faktura utstedes etter denne dato.

Løsning:

Du kan løse dette ved å endre sats for merverdiavgift, midlertidig, i tabellen Merverdiavgift til 24%, 12% eller 6% under fakturering av varer og tjenester som leveres i 2004, men som du fakturerer i 2005.


Visma Business Dokumentsenter

Her kommer tips og gode råd om Visma Business Dokumentsenter


Indeksering Visma Business Dokumentsenter

Indeksering – Visma Business Dokumentsenter

Dersom hastighet er en utfordring i Visma Business dokumentsenter så kan det være hensiktsmessig å legge opp indekser på feltet ”Scandok.nr” i disse tabellene:

  • Åpne kundeposter
  • Kundetransaksjoner
  • Åpne lev.poster
  • Leverandørtransaksjoner
  • Hovedbokstransaksjoner
  • Driftsmiddeltranser
  • Dokumenter
  • Produkter
  • Vareparti
  • Ordrelinjer
  • Reservasjoner
  • Produkttransaksjoner
  • Ordredokumentlinjer
  • Bilag
  • Oppdaterte bilag

Det er kun nødvendig å indeksere i de tabeller som kunde benytter i sine skjermbilder eller opplever at hastigheten ikke er som ønsket.

Indekser legger du opp ved å velge Oppsjoner/Systemadministrasjon/Indekser


Innføring i Visma Business Time

Installasjon og feilsituasjoner

Installasjon av service (tjeneste)

Dette skal gjøres fra C:\ eller D:\ (selvfølgelig fra \DocCenter) ikke fra share (eks. v:\....\DocCenter).

Dersom det i ”Path to executable” ligger tilordnet diskbokstav (for eksempel er U:\...) må du avinstallere servicen først og deretter installere fra C:\. Både Avinstallasjon/Installasjon og Stopp/Start av service gjøres fra C:\Program Files\Visma\Business\DocCenter:

Brukeren som kjører servicen må ha skrive og leserettigheter til område. Det område som er angitt i tabellen Programmer i Visma Business. Program og Dataområde.

Loggon kontoen på servicen må også ha rettigheter til %Windir%\temp katalogen.
Oppsett av bruker som kjører servicen (PlServer.exe)

Merk: Local System Account har ikke nok rettigheter på andre disker enn C:\ disken.

For å sjekke rettighetene til brukeren som kjører servicen (PlServer.exe) kan du gjøre følgende:

  1. Rename PlServer.exe PlServer1.exe. Det betyr at vi ikke benytter servicen for å starte Visma Dokumentsenter. Hvis du nå klarer å starte Visma Dokumentsenter, betyr det at det er servicen som er problemet.
  2. Du kan også starte PlServer.exe manuelt og deretter starte PldService.exe. Dersom det går greit, er det servicen som er problemet.
  3. Grunnen til at vi har PlServer.exe er at du skal slippe å starte PlServer.exe manuelt, slik at du igjen kan starte PldSenter.exe.

PlSetup.exe

Ved problem med brukers_plsetup kan siste utgave hentes fra klient på: C:\Documents and Settings\”Bruker”\Local Settings\Temp\PaperLess\

PlSetup.ini

Det blir lagret en pr. bruker. Så fort en bruker gjør en endring i skjermbildet, vil denne endringen bli lagret i denne filen. Dersom filen slettes, opprettes en ny ved oppstart av Dokumentsenter.

PlSetup.ini blir overstyrt ved oppgradering.

Merk: Etter oppgradering til ny versjon, skal alltid PlServerSetup.exe startes!

Tiff filer

Tiff filer skal ha komprimering og oppløsning som vist under.

Dette kan du sjekke i Ms Office Document Imaging, View, Page properties.

Scanner software: ImageLib = skannet med Dokumentsenter.

Merk: Sort/hvit

Dokumenter som ikke er synlig i DocCenter.

Kan skyldes at bilag er lagt inn med Bilagsserie lik angitt i PreRegVs i PLServerSetup.

Fakturatolken virker ikke. Dialogen med progressindikator starter men avslutter uten tolking.

Det kan virke som om en sikkerhetsoppdatering (windows) gjør at bruker System (Local system account) på servicen ikke har rettighet til å kjøre exe filer via servicen. Dette resulterer i at tolkingen ikke blir kjørt på grunn av at plserver kjørt som service ikke får tilgang til filen PLOCR.exe. Dialogen for tolken er synlig noen sekunder men tolkingen blir ikke kjørt.

For å omgå dette problemet må du endre Log on konto på servicen til en konto som er med i administratorgruppen.

  1. Stopp servicen PLServer.
  2. Endre konto på servicen. I mitt tilfelle la jeg inn konto micro80\eddie med passord.
  3. Start servicen.

Merk: Husk å vedlikeholde passord på servicen når dere bytter passord på kontoen deres.

Feilsituasjoner

Feilmelding

Løsningsforslag:

Feil IP adresse eller Port (i PLServerSetup)

Meldingen kan også komme dersom PlServer ikke er startet.

Feilmelding

Løsningsforslag:

I versjon 3.x må det være lagt inn dataområde for PLDview i tabellen Programmer i Visma Business.

Merk: Ved oppgradering fra 2.8 kan det være at det er kjørt med blank i dataområde og vil da få feil med dette i versjon 3.

Husk også å benytte UNC adresse.

Meldingen kan også komme dersom dokumentteller er endret til høyere verdi hvor mappe ikke er opprettet.

Feilmelding:

Løsningsforslag:

Melding kommer dersom du ikke har rettigheter til dataområde i tabellen Programmer i Visma Business. Husk alltid å legge inn unc-path, ikke oppmappet bokstav.

Feilmelding:

”Error creating directory v:\Business\F0002\Docs\1

(3) The system cannot find the path specified”

Løsningsforslag:

Ikke tilgang til dataområde som er angitt i Visma Business, i tabellen Programmer.

Brukeren må ha tilgang til både Program og Dataområde. Skrive og lese rettigheter.

Feilmelding:

”Exception Edatabase Error in module PlCenter.exe

At 001EA64B (PAPERLESS SERVER ERROR)

Field ‘Sup’ not found”

Løsningsforslag:

Slett PlSetup.ini på den brukeren som ikke kommer inn i Dokumentsenter.

Feilmelding:

Løsningsforslag:

Krever ny Rtk.dll.

Dette gjelder eldre versjoner av Doksenter. Filen RTK.dll må tidsbeskyttes fordi den er lisensiert av en underleverandør.

Vi tidsbeskytter den slik at vi alltid kan sende den ut med Visma-cd-plater, nye versjoner, etc. Alternativet var at vi aldri kunne sende den ut, og måtte sende en og en fil ut til kunde som kjøper fakturatolk. Det ville ikke være noen god løsning og skape mye administrasjon. På denne måten kan vi også få til demolisenser slik vi gjør i dag.

Tidsbeskyttelsen for versjon før 3.0.3.5 gikk da ut 30.06.2006. Den RTK.dll dere har mottatt nå og som vil ligge i 3.0.3.6 går ut 30.06.2007.

Feilmelding:

Løsningsforslag:

Årsaken til meldingen ved flytting av side er at Log on konto på servicen PLServer ikke har nødvendige rettigheter for å flytte filen fra %windir%\temp til katalogen for tiff filene. Mest sannsynlig er servicen satt opp med Local system account og kontoen "system" har ikke nødvendige rettigheter. Sett opp servicen med konto administrator og sjekk om det funker.

Det som skjer ved flytting er at tiff filen flyttes fra tiff område til windir temp katalogen, der byttes det litt også flyttes den tilbake til tiff område.

Merk: Årsaken kan også være at filstien er for lang eller at det er tegn den ikke liker. Det blir forsøkt rettet til versjon 3.0.3.6. I mellomtiden må stien endres i feltet "Dataområde" i tabellen Programmer i Visma Business.

Feilmelding:

Løsningsforslag:

Vi får fremprovosert samme melding her dersom du gjør det i denne rekkefølgen:

  1. Kjører fakturatolk
  2. Rediger OCR-maske
  3. Velger Lagre uten å gjøre noen endringer, det betyr at ingen ocrres.txt blir opprettet
  4. Vis siste ocr resultatfil

Nå kommer meldingen.

Dersom det finnes en ocrres.txt vil ikke denne meldingen fremkommer.


Parameter for Doksenter

Ekstra sjekk i bedriftstabellen for Dokumentsenter 3.x

Fra versjon 5.20 av Visma Business, har bedriftstabellen fått et ekstra sjekkpunkt for å skille på om den valgte bedriften benytter seg av Dokumentsenter 3.x eller 5.x. Standard valg er 5.x og dersom du forsøker å starte Dokumentsenter 3.x med standard verdi, vil følgende statusmelding vises:

Sjekkpunktet finnes i kolonnen Bedriftsbehandling. Denne åpner følgende dialog:

Med "Benytt Dokumentsenter 3.x/4.x" valgt, vil versjon 3.x kunne startes uten feilmeldling på den valgte linja.


Visma Business Rapportsenter

Med Modulen Visma Business Rapportsenter kan du produsere alt fra enkle standardrapporter til de mest komplekse ad hoc-rapporter med nøkkeltallsberegninger og grafer.

Arbeid enkelt i Excel-miljø – dra og slipp, raskt og enkelt! Dette verktøyet omfatter også et budsjetteringsverktøy der budsjett-tallene føres direkte fra Excel-ark over til økonomisystemet hvor de oppdateres for løpende oppfølging.

Rapportene kan sendes med e-post rett fra systemet. Periodiske rapporter kan settes opp til automatisk utsendelse til ulike mottakere på fastlagte tidspunkter, f.eks. hver uke.

Her, i Kunnskapsbasen, finner du tips og gode råd om Visma Business Rapportsenter.


Excel Visma Business Rapportsenter

Excel - Visma Business Rapportsenter

Hvordan lager du grupper?

Grupper og disponer (group and outline) brukes for å identifisere og summere viktig informasjon i store excelark/excelbøker. Dataene blir brutt ned i hierarkier, og du ser bare de viktigste dataene først. Du kan ”drille deg ned” for mer detaljer om nødvendig.

Ved å bruke funksjonen Grupper og disponer både på rader og kolonner kan du presentere store omfattende rapporter på en oversiktlig måte. Ved å sette alle – til + i definisjonen vil du kun få presentert summeringene pr. gruppe med mulighet for å få presentert detaljene om du vil ve å trykke på +.

Benytt excel hjelpefil. Søk etter Outline (engelsk) disponer (norsk)

Hvordan lager man templates .xlt-filer?

En template (mal) bruker du dersom formatteringen til din rapport brukes mye om igjen. Har du definert noen templates kan du ved kjøring av rapporter benytte disse direkte fra Report Composer. Dette vil være virkningsfullt f.eks i en presentasjon, men først og fremst tidsbesparende for brukeren da formateringen av rapporten tross alt er det som nesten tar mest tid.

Kombinasjon tekst og formel i Excel: for eksempel Avdeling (tekst) + avd.navn

Du kan kombinere formel med tekst for å gjøre rapportene mer presentable. I eksempelet nedenfor ønsker vi at det skal stå Avdeling: foran alle avdelingsnavnene som hentes fra Visma Business. Avdelingsnavnet henter vi inn med formeldefinisjonsknappen fx
Ved å trykke F2 kan vi så redigere formelen i cellen. Vi går inn etter tegnet = og skriver ”<vår tekst>”&

Eksempel:
="Avdeling: "&ixDimGet("R1"; "Name")

Formatering av hvordan du vil presentere verdier

Dersom du ønsker en annen formatering av verdiene du får frem i den ferdige rapporten kan du under format cells - custom selv gjøre din definering.

Hvordan vil du presentere positive tall, negative tall, null-verdier og tekst.
Du vil kanskje presentere negative tall røde eller kanskje med (parantes) og kanskje presentere null-verdier som -. Valget er ditt.

I eksempelet under ønsker vi:
Positive tall med tusentallsseparator
Negative tall som røde og med tusentallsseparator
0 vises som –

For mer info les hjelpefilen i Excel:

Søk etter number format
- Finn 'create a custom number format'.

Formater en tekst til å gå over flere celler

Ønsker du at headingen skal gå over mange celler eller at kolonneoverskriften er så stor at du f.eks vil benytte 3 celler til dette ?

I eksempelet under viser vi deg hvordan du bruker 3 celler til kolonneoverskriften. I tillegg kan du definere at teksten skal midtstilles ved å velge center i menyen vertical: midt i bildet.

Du kan om skråstille teksten ved å endre gradene (degrees) i Orientation til høyre i bildet om det er ønskelig.


Rapportsenter - feilmelding ved oppstart pga .NET

Årsaken til denne feilmeldingen er at Rapportsenter 3.x ikke har støtte for .NET 2.0.

Versjon 4 av Report Center har støtte for dette.

Alternativ løsning for 3.x er å benytte vedlagte config-fil for å angi at RC skal benytte ver. 1.1. Framgangsmåte:

På klienter hvor .NET Framework 2.0 er installert, legg denne filen i client mappen til RC.

.NET 1.1 må være installert. Legg en kopi av filen iLytixApp.exe.config i katalogen hvor Excel.exe ligger.

Rename filen iLytixApp.exe.config til Excel.exe.config.


Visma Business Rapportsenter

Hvordan få med alle kombinasjoner posteringer med konto / avdeling / postert beløp hvor avdeling av og til kan være utelatt.

Ren utlistning av detaljer fra hovedbokstransaksjoner

p

Hvordan skille data fra ordre ifht produkttransaksjoner ?
Ved å benytte dimensjonen moduler kan man splitte opp dette.
Ved å velge modul = 6 får man bare antall fra restordre. Man benytter da feltene Restordreantall og Restordrebeløp.

p


Visma Business Outlook link

Visma Business Outlook

Visma Business Outlook gir bedrifter, som benytter Microsoft Outlook som standard kommunikasjonsapplikasjon, integrasjon mellom Microsoft Outlook og Visma Business. Mange firmaer benytter kundekartotek, kontakt –og avtaleregisteret, møteinnkallinger og ordinær korrespondanse i Microsoft Outlook.

Visma Business kommuniserer med Outlook for å unngå merarbeid i form av dobbeltregistrering. Det betyr felles avtalekalender og dokumenthistorikk per kunde eller kontakt.

På Visma Business Outlook CD-en finner du brukerdokumentasjon. Her, i Kunnskapsbasen, finner du tips og gode råd om Visma Business Outlook.


Hva logges hvor

Aktiviteter

Mail logging


Innføring i bruk og installasjon av Visma Business Outlook Lite

Innhold:

- installasjon

- server installsjon

- klient installsjon

- innstillinger i Ms Outlook

- logge e-post

- logge avtaler

- Generell informasjon

Installasjon

Installasjonen for Visma Business Outlook Lite er todelt akkurat som for en Visma Business installasjon. Først gjøres en server installasjon for å klargjøre Sql Server for bruk. Så gjøres det en klient installasjon for å klargjøre Outlook klientene.

Server installsjon

Når du setter inn cd platen starter installasjonen automatisk. Trykk ”Next” for å komme videre.

I denne dialogen velger du om du skal installere lite- eller fullversjonen av Visma Business Outlook. Velg ”Visma Business Outlook Lite” og trykk ”Next” for å komme videre.

InstallShield trenger connectionstring for å vite hvor den skal kjøre sine script. I denne dialogen må du trykke ”create SQL connection” for skape en slik connectionstring.

Her velger du navnet på serveren hvor Sql Serverer ligger, samt brukernavn/passord og hvilken database du vil kjøre Visma Business Outlook mot.

I denne dialogen velger du hvilken katalog du vil at programfilene skal ligge. Ønsker du å endre denne plasseringen, trykk ”Change”. Trykk ”Next” for å komme videre.

Her er InstallShield klar til å starte installasjonen av programmet. Trykk ”Install” for å starte installasjonen.

Vent mens installasjonsprosessen er i gang med kopiering av filer og registrering av komponenter

Installasjonen er ferdig, trykk ”Finish” for å avslutte.

Klientinstallasjon

Under serverinstallasjonen blir det dannet en klient-mappe under den katalogen hvor du valgte å plassere programfilene til Visma Business Outlook. I denne katalogen ligger det en fil som heter Setup.exe. Når du skal gjøre en klient-installasjon, må du kjøre denne filen fra alle de klientene som skal ha Visma Business Outlook installert.

InstallShield for klientinstallasjonen starter. Trykk ”Next” for å komme videre.

Velg om installasjonen skal gjelde bare for din Windowsbruker, eller for alle. Trykk ”Next” for å komme videre.

Når du tar i bruk Visma Business Outlook for første gang, har du muligheten til å synkronisere data som allerede er registrert i Ms Outlook over til Visma Business. I denne dialogen velger du fra hvilken dato denne synkroniseringen skal gjelde. Dagens dato blir valgt som default. Trykk ”Next” for å komme videre.

Her er InstallShield klar til å starte klient installasjonen.Trykk ”Install” for å starte installasjonen.

Vent mens installasjonsprosessen er i gang med kopiering av filer og registrering av komponenter.

Installasjonen er ferdig, trykk ”Finish” for å avslutte.

Innstillinger i Ms Outlook

Første gang du starter opp Outlook etter installasjonen, må du fortelle Visma Business Outlook hvem du er. Navn og e-post adresse til den som er konfiguret på den aktuelle Outlook klienten blir da forsøkt funnet i aktørtabellen i Visma Business. Navn og e-post adresse for aktuell Outlook klient må altså eksistere som en aktør med samsvarende e-post adresse i aktørtabellen.

Når du skal sette opp dine lokale innstillinger, trykker du på ”verktøy” knappen i Ms Outlook.

NB! Alle innstillinger som du setter i dialogene under, skrives til tabellen ”ekstern konfigurasjon” i Visma Business når du avslutter Ms Outlook. Du kan derfor i praksis sitte på server å gjøre all klientkonfigurasjon i denne tabellen.

Under mappen ”Oppsett” krysser du av om Visma Business Outlook skal logge e-post, logge avtaler, ta med vedlegg....etc.

Under mappen ”Preferanser” legger du inn riktig connectionstring mot Sql Server og hvilke mapper logget mail og vedlegg skal ligge.

Under mappen ”Annet” skriver du inn default avdelings nr., avdelingstabell og prosjekttabell.

Logge E-post

All logget e-post med vedlegg vil bli opprettet som enkeltstående filer på ett gitt område, med beskrivelse og koblinger mot aktører i tabellene ”dokumenter” og ”dokumentkoblinger”.

Når du skal logge din e-post, gjøres dette på to måter:

- Innkommende e-post som ligge i innboks.

- Utgående e-post som logges når du sender e-post.

Innkommende

Stå i din innboks i Ms Outlook og merk den e-posten som du ønsker å logge, trykk så på knappen ”logg e-post”.

I dialogen som følger skriver du inn eventuelt avdeling, prosjekt...etc., som du vil at e-posten skal knyttes mot. Trykk ”OK”.

Velg så hvilken aktør i Visma Business du vil knytte e-posten til, og trykk ”OK”.

Eventuelle vedlegg vil også bli overført til Visma Business, hvis du har dette valget med.

Utgående

Idet du sender en e-post vil denne dialogen dukke opp. Trykker du ”YES” vil e-posten bli logget.

I dialogen som følger skriver du inn eventuelt avdeling, prosjekt...etc., som du vil at e-posten skal knyttes mot. Trykk ”OK”

Velg så hvilken aktør i Visma Business du vil knytte e-posten til, og trykk ”OK”.

Eventuelle vedlegg vil også bli overført til Visma Business, hvis du har dette valget med.

Logge avtaler

Alle avtaler som logges, skrives til tabellen ”aktiviteter” i Visma Business, som igjen er knyttet opp mot en aktør i aktørtabellen.

Avtaler logges på to måter i Visma Business Outlook:

- Eksisterende avtaler som ennå ikke er logget.

- Ved opprettelse av en avtale.

Eksisterende avtaler

Merk den avtalen du ønsker å logge i din kalender i Ms Outlook, og trykk ”Logg avtale”.

Velg så hvilken aktør du ønsker avtalen skal knyttes til og trykk ”OK”.

Avtalen skrives så til aktiviteststabellen i Visma Business, og avtalen er logget.

Opprettelse av ny avtale:

Idet du oppretter en ny avtale i Ms Outlook, vil samme dialog som over dukke opp automatisk.

Velg så hvilken aktør du ønsker avtalen skal knyttes til og trykk ”OK”.

Avtalen skrives til aktiviteststabellen i Visma Business, og avtalen er logget.

Generell informasjon

Visma Business Outlook Lite er ett enkelt og stabilt verktøy, som krever lite ressurser.

Men i motsetning til fullversjonen, logges data kun den ene veien. Data replikeres altså fra

Ms Outlook til Visma Business, ikke fra Visma Business til Ms Outlook.

Du vil heller ikke kunne replikere dine aktører i Visma Business over som kontakter i

Ms Outlook, dette krever fullversjon av Visma Business Outlook.

Lite versjonen krever derimot ikke Ms Exchange Server, noe som kreves hvis du ønsker å benytte fullversjonen.

Visma Business Outlook Lite er uansett et fremragende verktøy hvis du ønsker å holde

”track” på dine mange e-poster og avtaler.


Skreddersydde skjermbilder Visma Business Outlook

”Skreddersydde” skjermbilder for Visma Business Outlook

Dagens skjermbilder i Visma Business er ikke optimal i forhold til bruken av Visma Business Outlook. Hva som vises er avhengig av hvordan aktøren er koblet til tabellene dokumenter og dokumentkoblinger. Vi har derfor laget ett sett med skjermbilder som er tilpasset nettopp denne bruken. Skjermbildene tar for seg kunder, leverandører, ansatte og kontaktpersoner, koblet mot logget e-post med eventuelle vedlegg og avtaler. Det kreves at du minimum benytter versjon 4.40.0 av Visma Business for å ta i bruk disse skjermbildene.

Skjermbildene kan lastes ned fra ”forhandlerlounge”, under produktet Visma Business og ”nedlastninger”. Webadressen er: http://forhandler.vismasoftware.no/


Installasjon av Visma Business Outlook

Regel nummer en hvis du får problemer med å få Visma Business Outlook til å fungere som den skal etter en installasjon: Sett på en logg.

Loggen gir en god indikasjon på hva programmet prøver å gjøre, og hva den feiler på.

Klient

Det blir generert en logg på klienten som heter "VbusOutl.log". Loggen blir lagret på den katalogen klientinstallasjonen er installert på.
Du setter på loggen på ved å merke av for ”Setter utvidet feil håndtering på” fra ”Verktøy-knappen” i Microsoft Outlook under mappen ”Oppsett”.

Server

Servicen genererer en logg som du kan benytte til feilsøking.

Dette gjør du ved å sette verdien "1" i "Registry"-nøkkelen under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Visma Sync Exchange\firms\FXXXX\ExtErrLog - hvis du benytter fullversjon av Visma Business Outlook.

Loggfilen som heter "VBUSSyncExchange.log" og denne finner du i katalogen hvor servicen er installert.

I tillegg genereres det en logg som heter "VbusOutlDba.log" og den genereres på server der servicen er installert og på klient der klientinstallasjonen er gjort.

Cdo.dll (Collaboration Data Objects):

"Cdo.dll" er en sentral komponent som Visma Business Outlook benytter til å kommunisere med Microsoft Outlook/Exchange Server. "Cdo.dll" er en komponent som er utviklet av Microsoft, og kommer i forskjellige versjoner og med forskjellige sikkerhetsnivåer. Microsofts applikasjoner har i flere år vært ett yndet mål for hackere, og de har løst dette ved å gjøre slike komponenter mer eller mindre ugjennomtrengelige for eksterne applikasjoner. Så hvis din Microsoft Exhange/Outlook installasjon benytter en ”sikker” versjon av "Cdo.dll" er det stor sannsynlighet for at Visma Business Outlook vil få problemer med å fungere som den skal.

Vi anbefaler derfor at du benytter den versjonen av "Cdo.dll", versjon 5.5.2653.12, som ligger på CD-en til Visma Business Outlook.

Får du feilmeldinger eller logg som sier noe om denne komponenten, bør du sjekke hvilken versjon du benytter og eventuelt erstatte den med den versjonen som ligger på CD-en.

Filen kan ligge på forskjellige plasser avhengig av hvilke applikasjoner som er på maskinen, men ved å søke i registry kan du finne ut hvilken fil som blir brukt.

Vær oppmerksom på at andre applikasjoner kan holde på denne filen, slik at du ikke får slettet eller erstattet den. Da må du avslutte alle applikasjoner som holder på denne filen.

Er ikke denne komponenten installert, må du installere den ved hjelp av ”Add or remove features” under ”Add or remove programs” i kontrollpanelet (Er en del av Microsoft Outlook).

Servicen (Visma Sync Exchange):

"Visma Sync Exchange" er en NT-service som flytter data fra Sql Server til Microsoft Exchange Server. Servicen installeres enten på Sql server eller Microsoft Exchange Server, og må startes manuelt etter installasjonen.

Servicen må kjøres på en bruker med alle rettigheter på Microsoft Exchange Server. Servicen skal blant annet ha rettigheter til å logge seg på og skrive til andre brukerkontoer.

Det er ikke gitt at en administratorbruker har slike rettigheter. Du må derfor eksplisitt gå inn på den brukeren som servicen skal kjøres på, og gi ham slike rettigheter til kontoene til de andre brukere. En administratorbruker har ofte ”Deny” på ”Send as” og ”Receive as”, og da vil ikke servicen klare å skrive til brukerens avtalebok i Microsoft Outlook. Du må da sørge og sette ”Allow” på ”Send as” og ”Receive as”.

Dette er en feil mange gjør. De forutsetter at servicen har nok rettigheter siden ”den kjøres jo på en domeneadministrator”.

Klienten:

Selve klientinstallsjonen er i praksis bare innkopiering og registrering av tre komponenter:

  • VbusOutlLog.dll
  • VbusOutlDba.dll
  • VbusSec2.dll

Her er "VbusOutlLog.dll" den mest sentrale filen, og fungerer som "Com-addin" på Microsoft Outlook klientene. Denne komponenten gjør "Queries" mot "Microsoft Sql Server" fra de forskjellige klientene. Sørg for at disse filene er registrert, og at "Connection string" er riktig mot " Microsoft Sql Server".

"Connection string" i Visma Business Outlook finner du som vist under:

Du finner også "Connection string" i "Registry" under: HKEY_CURRENT_USER\Software\VISMA\Visma Business Outlook\ConnectionDatabase.

Under “verktøy knappen” i Microsoft Outlook setter du også din lokale innstilling for hva du vil Visma Business Outlook skal gjøre og hvor filer etc. skal plasseres.

Tabellen Ekstern konfigurasjon(ExtConf):

I tidligere versjoner hadde vi en fil som ble kalt VbusOutlook.ini, hvor all klientkonfigurasjon ble gjort. Denne filen er nå fjernet, og all klientkonfigurasjon blir nå skrevet til tabellen ”Ekstern konfigurasjon” i Visma Business databasen. Dette er blitt gjort for å bedre stabiliteten på klientene. Her er en liten forklaring på de mest sentrale feltene i denne tabellen:

  • Objektnavn: Hva den aktuelle raden i ExtConf-tabellen er ment for.
  • Objekttekst: E-post adresse til person Outlook klienten er konfigurert for.
  • Kolonnenavn 2: Filtyper som godtas ved lagring av vedlegg.
  • Uttrykk 1: Default avdelingsnummer og avdelingstabell.
  • Uttrykk 2: Default prosjekttabell.
  • Tekst 1: Sti til filområde der e-post og vedlegg lagres.
  • Tekst 3: Sti for formularer på exchange server.
  • Tekst 4: Navn på person Outlook klienten er konfigurert for.

Registry

Her er noen sentrale plasseringer i "Registry":

"Connection string" for Visma BusinessOutlook klienten:
HKEY_CURRENT_USER\Software\VISMA\Visma Business Outlook\ConnectionDatabase

"Connection string" for servicen:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Visma Sync Exchange\Firms\FXXXX\Connection

Nøkkel for å sette logging på servicen av eller på:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Visma Sync Exchange\firms\FXXXX\ExtErrLog


Template

Bransjeløsninger

Visma Software har utarbeidet bransjetilpasset programvare for økonomistyring og salg- og markedsstøtte.Det kan du lese mer om på hjemmesiden til Visma Software ASA.

I dette dokumentet, Kunnskapsbasen, finner du tips og gode råd om bransjeløsninger i Visma Business.


Brukerhåndbok Visma Business Regnskapsbyrå

Visma Business Regnskapsbyrå

Brukerhåndbok finner du på CD-en til Visma Business Regnskapsbyrå.


Installasjon av NARF malene

NARF malene til Visma Byrå

Installasjon (felles for alle versjoner av Office)

Malene må kopieres inn fra CD’en Program files\Visma\Business\Templates\Bureau til tilsvarende katalog på pc’en. Ta også med filene xlodbc.xla, xlodbc32.dll og xlquery.xla.

Malene installeres i mal-mappen under Visma Business på vanlig måte, se eventuelt brukerdokumentasjon. Malene er satt opp med følgende forutsetninger:

Visma Business benytter registry-nøkkelen CurrentVersion
byråets egen klient er database F0001

Dersom Vbus.exe startes med /n og en registry-nøkkel, eller byråets egen klient ikke er F0001, må denne informasjonen legges inn i registry slik:

HKEY_CURRENT_USER

Software

VB and VBA Program Settings

Visma Regnskapsbyrå

Versjon

"VismaKey"="CurrentVersionServer"
"Klientdatabase"="F3001"

Sammen med malene er det en fil som heter Maler.reg. Tilpass denne filen og dobbelklikk på den for å importere den inn i registry.

Klargjøring av malene for Office 97 og 2000 ( XP er beskrevet i eget punkt)

For å kunne kjøre malene må disse klargjøres til den enkelte PC. Dette gjøres ved å finne de aktuelle malene ved hjelp av utforskeren.

Høyre klikk på malen og velg Åpne.

Velg deretter og aktivere makroene.

Velg Verktøy->Makro->Makroer.

Velg Rediger.

Velg Tools | References

Du vil få opp en dialogboks som vist nedenfor Den kan enten se slik ut:

XLODBC.XLA finnes i lista, men er ikke huket av. Det må du da gjøre, og deretter trykke OK

… det kan også hende at du vil få opp en melding som ser slik ut, der XLODBC.XLA er MISSING

Legg merke til at den da henviser til en mappe hvor denne fila ligger. Den kan ligge på litt forskjellige steder etter hvilken utgave av Windows du har, men det kan jo være greit å søke etter den, fordi den MÅ være tilstede for at malene skal fungere

Når du har funnet fram til mappen (etter et søk) går du inn i malen igjen som beskrevet ovenfor, velger igjen Tools | References og bruker knappen Browse for å finne den fram til filen, slik:

NB! Legg merke til at du må overstyre valget her for å finne fram til XLODBC.XLA !!

Velg XLODBC.XLA, trykk Open og dialogboksen vil nå se slik ut:

Trykk OK og deretter Fil-> Lagre og returnere til Excel. Lagre deretter malen og den vil nå være klar til bruk.

Ovennevnte øvelse må gjøres på samtlige maler.

Klargjøre Tools for å kjøre malen (gjelder XP)

Filen XLODBC.XLA følger ikke med Office XP. I malområdet ligger derfor disse filene:

Gå inn i malen som beskrevet ovenfor

Velg Tools | References | Browse

Finn fram til aktuell mappe hvor XLODBC.XLA ligger

Overstyr forslaget på filtype – slik:

Dobbeltklikk XLODBC.XLA
Denne filen vil nå være installert i Tools, og malen vil fungere
Ovennevnte øvelse må gjøres på samtlige maler


Kirkeløsningen

  • Skjermbilder fra 440 000 - 440 017
  • I "Vindustabellen" er"Tilgjengelig for" = 8 (Alle brukere / Bedriftsgruppe)
  • I Vindustabellen er"Bedriftsgruppe nr." = 99
    • Bokføre mva kompensasjon. BIG foretar hele beregningen. BIG tar med ansvarsenhet til grunnlagskonti for mva. Flagg for mva kompensasjon er ikke satt i Bedriftsopplysninger, BIG tar seg av dette.
    • Feltet"Avgiftsoppl." i tabellen Avgiftskoder trigger om BIG skal slå til.
    • BIG slår til ved oppdatering av Bunt.
    • Spesielle regnskapsrapporter - veldig spesifikke.

Importfilter

  • Datafiler fra andre systemer. Brukes ved gjentagende importer, f.eks. Fakturajournal.
  • Ved første gangs opprettelse av importfilter, blir stier satt i tabellen Navnerom.
  • Se egen dokumentasjon under mappen ”Importfilter”.

Feilmeldinger

Ulike feilmeldinger kan fremkomme, f.eks.:

"Start up Status: The Solution numbers collected by the Authorisation event is not
exactly identical with them the system key was generated from."

Kan være missmatch mellom BigComponents.xml og lisensen, f.eks:
- Autopay - må kjøres Setup
- Kirkeløsning - må legge inn informasjon i Xml filen manuelt (innholdet i filen BIGComponents-kirke.txt kopieres til BigComponents.xml)
- Innfordring - må kjøres Setup

Filen skal alltid hete BigComponents.xml.
En standard BigComponents.xml ser slik ut:

<?xml version="1.0" encoding="utf-8" ?>
- <Components>
- <Component>
<Uri>VCT.DiverseByra.dll</Uri>
<Namespace>VCT.DiverseByra</Namespace>
</Component>
</Components>

*** *** ***

"Trenger Big for å starte"

Kan være fordi parameteret "Trenger BIG for å starte" i tabellen Systemopplysninger er satt og kunden prøver å starte Vbus.exe.

*** *** ***

"VCT.DiverseByra.Events" class not found in the "VCT.DiverseByra.dll" assembly".

Sett .NET security settingene i henhold til skrivet på cd`n under Documents - Common - Skrivet heter "PrivilegesVismaBusinessEng". I tillegg må du sette opp Full trust på local intranett på .NET wizarden..

Mappen Globalassemblycache må kopieres inn på hver enkelt arbeidsstasjon. I tillegg må filen install.bat kjøres.

*** *** ***

Merk: Du kan ikke kjøre med en lisens som inneholder Visma Byrå og modulen Autogiro (som er laget og levert fra Visma).

Lisensen

Slik ser lisensen ut dersom det er Visma Byrå...

  • Professional eller Design
  • Det blir automatisk satt hake i Klientversjon
  • Det blir automatisk satt hake i Regnskapsbyrå
  • Crm, outlook
  • Import av ordre, Fakturering og Ordre/Time må ha samme antall

Dersom de har Logistikk, skal også "Innkjøp" ha likt antall.


AutoPay

AutoPay er en unik løsning for effektiv og sikker behandling av betalingsdata for deg som bruker, kombinert med en automatisert formidling av betalingsdata mellom den enkelte klient/bedrift i Visma Business og vedkommende bedrift sin bankforbindelse.

Filosofien bak AutoPay er å gjøre betalingsformidlingen så enkel, effektiv og sikker å bruke at du sparer tid og krefter som heller kan benyttes på andre og minst like viktige områder i regnskapsarbeidet. Løsningen skal også gjøre deg mer konkurransedyktig dersom du jobber i et regnskapsbyrå.


AutopayTips

Autopay

Generelt

AutoPay er Visma sin unike løsning for helautomatisk betalingsformidling. AutoPay leveres kun til Visma Business og Visma Business Regnskapsbyrå.
Konseptet AutoPay bygger på ideen om ”Den elektroniske motorvei” som vi har definert på følgende måte:

”Automatisk transport av betalingsdata begge veier mellom abonnenten (lisensinnehaver Visma Business) og datamottaker (for eksempel BBS) uten manuell inngripen fra noe hold.”

Spørsmål og svar:

1. Hvor får jeg tak i nye versjoner av Autopay?

Kan lastes ned på din server fra forhandlerlounge, produkt Visma Business, Autopay.
Filer med navn setup benyttes til første gangs installasjon, de andre for oppgradering.

Samtidig må du installere BIGWinservice som tilhører den versjonen av Autopay som skal installeres

2. Er det noe spesielt jeg må huske på når jeg skal oppgradere Autopay?

Det er viktig at det er sammenheng mellom aktuell versjon av Visma Business og den versjon av AutoPay som benyttes. Det betyr at man alltid må oppgradere AutoPay når man installerer ny hovedversjon av Visma Business.
AutoPay er delt i to deler, en Windowsservice (BigWinSercice) og en programfil (BigAutoPay). Ved oppgradering må alltid BigWinService stoppes, og ingen må være logget på Visma Business. BigWinService må oppgraderes mellom hver hovedversjon av Visma Business, altså mellom versjon 4.x og 5.x, men ikke mellom 5.10 og 5.20.

3. Dersom en klient har flere bankkonti som det skal remitteres fra via AutoPay, skal vi da legge opp flere bankpartnere og velge der hvilken vi skal remittere fra?

Nei kun èn bankpartner for Visma AutoPay, , men det må registreres èn avtale pr. bankkonto.

4. Vi har ikke motatt betalingsretur på mange dager

Veldig ofte skyldes dette at BIGwin service ikke er aktiv. Restart denne. Tjenesten må være oppe å gå for at Autopay skal fungere.

5. Vi ønker at pengene skal inn på mottakers konto i dag. Når må vi godkjenne betaling?

Dette avhenger av banksentral: Nordea: Cut off for avregning av innlandsbetaling samme dag er kl 12.00, og for utlandsbetalinger gjelder kl 14.00.
DnB: Innlandsbetalinger må godkjennes før innleveringsfristen (cut-off) kl 12.30 dersom de skal utføres i dag (bankdag).
Ordinære betalinger til utlandet må godkjennes før innleveringsfristen kl 14.00 dersom de skal utføres i dag (bankdag).
Ekspress betalinger til utlandet må godkjennes i henhold til cut-off for den enkelte valutasort dersom de skal utføres i dag (bankdag).
BBS: Betalingen må godkjennes før kl 10:00, avregning hos BBS skjer kl. 12.00, men BBS garanterer ikke at oppdrag avregnet kl. 12.00 er på konto samme dag..

Se for øvrig skjema ”Tidsfrister direkte remittering via BBS” som kan lastes ned fra forhandlerlounge.

6. Oppdraget er ikke utført pga. manglende dekning på konto. Hva gjør vi?

BBS kjører dekningskontroll kl.12.00 og kl.24.00. Et oppdrag blir forsøkt belastet to ganger, d.v.s. er det ikke dekning på første forsøk,tas oppdraget med på neste dekningskontroll.

Alt. 1: Dersom det blir satt inn penger på konto mellom første og andre dekningskontroll blir oppdraget belastet..Hvis ikke kan man sende en mail til: autorisering@bbs.no og be om reåpning av oppdraget. Man må da oppgi: kontonr., beløp og dato fila ble sendt til BBS.
Alt.2: Legge ut betalingen på nytt. Da må man annullere oppdraget i autopay ved å gå inn på oppsett Autopay fra bet.formidling, fane sende betaling, merke oppdraget, velge se/endre oppdrag, merke transer og velge avvist bank. De vil da legges tilbake til betalingsforslag og man kan lage nye forslag og legge de ut på nytt.

7. Avslutte en avtale

Dersom en kunde ønsker å slutte med autopay på en klient holder det å ta vekk kryss for aktiv på avtalen i Visma Business. Da stoppes faktureringen for den avtalen. Er det bare innbetaling, h.h.v. utbetaling de ikke vil fortsette med (bare en av avtalene, tar de bort kryss for inn-, h.h.v. utbetaling)

Dersom man har sendt bet.oppdrag til banksentral som man ikke har mottatt retur på, så må man vente med å ta vekk krysset til man er ajour med retur, evt. bokføre retur manuelt.


Avtale om betaler-tjenester og betalingsmottaker-tjenester i næringsforhold

Del E av kontoavtalen

Opplysninger om kontohaver

Opplysninger om banken

Organisasjonsnummer

Organisasjonsnummer

Bankregisternummer

Kundens navn

Bankens navn

Adresse

Adresse

Postnummer og sted

Postnummer og sted

Telefonnummer

Telefaksnummer

Telefonnummer

Telefaksnummer

Kryss av for de tjenester som ønskes

Betaler-tjenester

Direkte remittering (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Egiro utbetaling (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Betalingsmottaker-tjenester

Autogiro (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

AvtaleGiro (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

OCR giro (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Egiro innbetaling (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Egiro innbetaling pluss (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Giromail (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Girofax (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

eFaktura (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Tjenesten kan kun benyttes for konti angitt i registreringsskjema bankkunde.

Avtalevilkårene for tjenestene suppleres av tjenestespesifikk brukerdokumentasjon, som angitt i tjenesteavtalen, samt bankens Alminnelige vilkår for innskudd og betalingsoppdrag (Del C av kontoavtalen).

Ved motstrid mellom følgende dokumentasjoner gjelder følgende rangordning:

1. Registreringsskjema bankkunde, tjenestespesifikasjon og meldingshåndbøker

2. Avtalevilkår for tjenestene

3. Alminnelige vilkår for innskudd og betalingsoppdrag

4. Annen brukerdokumentasjon

Banken skal sende Registreringsskjema bankkunde (3 sider) til BBS. Avtalen (forsiden) beholdes av bank/kunde.

Så snart BBS har registrert avtalen, vil BBS varsle banken og kontohaver om dette, slik at de ønskede tjenester kan tas i bruk.

Kontohaver bekrefter å ha mottatt avtalevilkårene og godtar disse

Sted, dato

Kundens underskrift

Sted, dato

Bankens underskrift og stempel

Vi er registrert som kunde i BBS tidligere

Registreringsskjema bankkunde 1 av 3

1. Kunde (kontoeier)

4. Gjelder eFaktura

Organisasjonsnr.

Avtalenavn som presenteres for forbruker i nettbank:

Bransje

Navn

Navn/avdeling for kundehenvendelser:

Adresse 1 (v/person eller avdeling)

Telefon

e-post

Adresse 2 (gate-/postadresse)

Tilbyr dere AvtaleGiro: Ja Nei

Hvis ja, vil eFaktura bli tilbudt

I kombinasjon med AvtaleGiro: Ja Nei

Postnr. og sted

Land

Telefon

eFaktura referanse

Hva benyttes som eFaktura referanse: ………………………………..

(eks. kundenr.)

Antall siffer. Alt.1: Alt.2: Alt.3: -

Kun numerisk Ja Nei

Disse opplysningene benyttes til kontroll ved innmelding i nettbank.

Kontaktperson

e-post

Oppdragskonto

Faktureringskonto

Avtalen gjelder:

Avtale- ID i BBS

Avtalefangst i nettbank

Angi kontonummer for avtalefangst:

Direkte remittering

Egiro utbetaling

Konto:

Konto:

Konto:

Autogiro

Hvis flere enn 3 konti, bruk pkt 13, Merknader.

AvtaleGiro

KID Angi totalt antall siffer i KID inkl. kontrollsiffer :

Angi posisjon for eFakturareferansen i KID:
f.o.m. t.o.m. -

OCR giro

eFaktura oppdrag
Formater
Programpakker

Egiro innbetaling

Egiro innbetaling pluss

BBS

XML

Annet

Navn, versjon

Giromail

Avtaleoppdrag

Girofax

eFaktura

Faktura-/betalingskravs-oppdrag

Sikkerhet på egiro-tjenestene

Sikkerhetsprogrammet Toolkit kan bestilles hos BBS

Kvittering på oppdrag

Eksisterende fakturavolum til forbruker pr. år.

Antall:

Fakturahotell

Fylles ut hvis annet enn Bankenes Fakturahotell skal benyttes

Organisasjonsnummer:

Navn:

Kontaktperson:

Telefon:

e-post:

2. Fast tekst på kontoutskrift.

Eventuell integrasjonspartner

Kun aktuelt for brukere av Bankenes Fakturahotell som ikke bruker BBS-format og standard fakturamal.

Gjelder for direkte remittering, autogiro(maks 30 pos) og AvtaleGiro(maks 25 pos)

Navn:

3. Kontobytte (Gjelder ikke OCR giro)

Kontaktperson:

Gammel konto:

Avtale-ID:

Telefon:

e-post:

Ny konto:

Skal gjelde fra (dato):

Registreringsskjema bankkunde 2 av 3

5. Gjelder autogiro

9.1 Gjelder autogiro

Valgfritt ønske om repetering av transaksjoner avvist i betalers bank:

1 dag 2 dager 3 dager

BBS skal produsere betalingspåminnelse når trekk er avvist av betalers bank

Gjelder ikke engangsfullmakter

Elektronisk innsending av fullmakter

10. Mottaker av konteringsdata

Navn og adresse skal kun fylles ut hvis det avviker fra pkt. 1. Kunde

Kundeenhet-ID i BBS

00011542

Navn

Visma Solution AS, avd. Trondheim

(Om ytterligere opplysninger, spesifiser i pkt 13. Merknader)

Telefon

46400500

10.1 Gjelder autogiro

Elektronisk retur av fullmakter

Retur av godkjente transaksjoner

Retur av avviste transaksjoner

Gjelder ikke engangsfullmakter

10.2 Gjelder egiro utbetaling –

Konteringsdata i DEBMUL-melding

Alt.1: Betalingsoppdrag sendt BBS i PAYMUL- melding på sum nivå (B)

Alt.2: Betalingsoppdrag sendt BBS i PAYMUL- melding på sum og transaksjons nivå (B og C)

Alt.3: Alle betalingsoppdrag sendt BBS og bank(B og C)

6. Gjelder OCR giro, egiro innbetaling og egiro innbetaling pluss

Avvisning av betalinger med manglende eller ugyldig KID

Alle online-betalinger til vår OCR giro konto skal avvises dersom Kundeidentifikasjon mangler eller er ugyldig.

Alle elektroniske betalinger til vår OCR giro konto skal avvises dersom Kundeidentifikasjon mangler eller er ugyldig.

10.3 Gjelder direkte remittering

7. Gjelder egiro utbetaling

Retur av godkjente transaksjoner

Ønsker å kansellere betalingsoppdrag i egiro utbetaling ved bruk av FINCAN-melding

10.4 Periodisering av AvtaleGiro og OCR giro konteringsdata

8. Opplysninger om Programvareleverandør/ egenutviklet programvare

Daglig

Ukedag(er) (1-5) -

Dag(er) i mnd (1-31) -

Eventuelle forskjeller i periodisering pr tjeneste kan angis i pkt 13. Merknader

Navn Programvareleverandør/egenutviklet programvare

Visma Solutions AS, avd. Trondheim

KID for AvtaleGiro

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: -

Kundenummer: Posisjon

f.o.m. t.o.m. -

Betalingstype: Posisjon

f.o.m. t.o.m. -

10.5 Periodisering av egiro konteringsdata

Egiro utbetaling

Levering 1 gang pr dag

Egiro innbetaling

Daglig

Ukedag(er) (1-5) -

Dag(er) i mnd (1-31) -

Egiro innbetaling og egiro innbetaling pluss for betalingsoppdrag avregnet i BBS

Levering 1 gang pr dag

Levering 2 ganger pr dag

Konteringsdata for betalingsoppdrag avregnet i banken blir sendt bankkunde via BBS ihht gjeldende driftsmønster

For OCR giro og egiro kan det oppgis inntil 3 KID alternativ:

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: 14 -

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: -

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: -

9. Dataavsender

Navn og adresse skal kun fylles ut hvis det avviker fra pkt. 1. Kunde

Kundeenhet-ID i BBS

00011542

Navn

Visma Solution AS, avd. Trondheim

(Om ytterligere opplysninger, spesifiser i pkt 13. Merknader)

Telefon

46400500

11.1 Giromail

Registreringsskjema bankkunde 3 av 3

e-post adresse: (BRUK BLOKKBOKSTAVER)

12. Mottaker av kvitteringslister

Navn og adresse skal kun fylles ut hvis det avviker fra pkt. 1 Kunde

Kundeenhet-ID i BBS

11.2 Girofax

Telefaks alt. 1: -

Landkode Områdekode Lokalt telefaksnr.

Telefaks alt. 2: -

Landkode Områdekode Lokalt telefaksnr.

Dersom flere konti, skriv disse i pkt 13. Merknader.

Girofax maks. 50 sider pr forsendelse. Dersom det ønskes økt antall noteres dette i pkt. 13. Merknader.

Navn

Adresse 1 (v/person eller avdeling)

Adresse 2 (gate-/postadresse)

Postnr. og sted

Land

Telefon

Kontaktperson

13. Merknader

VIKTIG ! Referer alltid til hvilket felt merknaden gjelder.

Vi ber om at kundens godkjente avtale med avtaleID påført returneres til følgende adresse:

Bytt ut med firmanavn

Att:

Bytt ut med adresse, postnr.- og sted på denne linje

NB! Dersom dette er en remitteringsavtale skal punkt 10.3 og punkt 10.4 "Daglig" alltid være avkrysset.

Dersom dette kun er en OCR avtale, skal punkt 10.4 "Daglig" alltid være avkrysset. (Gjelder kundeenhet-ID 00011542)

14. kontaktpersoner

Hos kunden Telefon e-post adresse

Hos Programvareleverandør Telefon e-post adresse Programvare

Einar Fjørtoft 46400641 einar.fjortoft@visma.no Visma AutoPay

Hos banken Telefon e-post adresse Bankens reg. nr.

15. Underskrifter
Sted, dato | Sted, dato
Kundens underskrift | Bankens underskrift og stempel

16. Avtalen er registrert i BBS

Sted, dato

Underskrift


Brukerdokumentasjon AutoPay

Om denne brukerdokumentasjonen

Denne brukerdokumentasjonen omhandler kun de funksjoner i Visma Business som berører konseptet AutoPay. Det betyr at du må ha kjennskap til Visma Business for å kunne ha utbytte av å lese denne dokumentasjonen. I tillegg til AutoPay sine egne bilder viser vi her kun de bilder i Visma Business som er direkte berørt av AutoPay.

Vi vil i denne dokumentasjonen henvise til en del vinduer i standard Visma Business og Visma Business Regnskapsbyrå der dette er nødvendig.

Nødvendige forkunnskaper

Før du kan begynne å bruke denne oppslagsboka, er det en fordel om du har grunnleggende kunnskap om Visma Business.

Kurs i Visma Business Visma Business Regnskapsbyrå

Informasjon om våre kurstilbud finner du på www.vismasoftware.no, eller ved å kontakte Visma eAccount, som tilbyr standard kurs så vel som en bedriftstilpasset opplæring.

Din forhandler vil også kunne gi deg en god innføring i Visma Business Regnskapsbyrå.

Hvordan komme i gang med AutoPay?

For å kunne benytte AutoPay, må systemet først installeres på din server og gjøres tilgjengelig for deg gjennom Visma Business eller Visma Business Regnskapsbyrå.

Dersom du benytter Visma Business Regnskapsbyrå, så vil AutoPay ligge på CD-platen og kan lett installeres dersom du oppgraderer til anbefalt versjon av Visma Business.

Dersom du benytter standard Visma Business Design eller Professional og ønsker å ta i bruk AutoPay, så må du også oppgradere til anbefalt versjon samtidig som du også må oppgradere grensesnittet på skjermbilder og oppsett til versjon 4.40.4 eller høyere.

Du må da sørge for å få tilsendt en CD med installasjonsprogram for AutoPay eller laste dette ned via nettet. For de som benytter Visma Business Regnskapsbyrå vil AutoPay bli installert automatisk ved oppgradering fra og med versjon 4.40.4.

Hva er AutoPay?

Definisjon

AutoPay er en unik løsning for effektiv og sikker behandling av betalingsdata for deg som bruker, kombinert med en automatisert formidling av betalingsdata mellom den enkelte klient/bedrift i Visma Business og vedkommende bedrift sin bankforbindelse.

Filosofien bak AutoPay er å gjøre betalingsformidlingen så enkel, effektiv og sikker å bruke at du sparer tid og krefter som heller kan benyttes på andre og minst like viktige områder i regnskapsarbeidet. Løsningen skal også gjøre deg mer konkurransedyktig dersom du jobber i et regnskapsbyrå.

AutoPay er et konsept som det ikke finnes maken til i markedet, og en grunnleggende filosofi i løsningen er at automatiske prosesser skal ta hånd om og passe på alt som man i tradisjonelle løsninger er nødt til å passe på og utføre manuelt selv. Det vi ønsker å oppnå med dette, er å gjøre hverdagen enklere og bedre for den enkelte medarbeider og samtidig øke konkurransekraften for den virksomheten som benytter systemet.

Den Elektroniske Motorvei

For å få AutoPay til å virke i praksis, har vi vært nødt til å finne opp et helt nytt konsept for automatisert transport av all form for data som det er naturlig å transportere ut og inn av økonomisystemet og til og fra eksterne datamottakere. Dette konseptet har vi kalt ”Den elektroniske Motorvei” og er visualisert nedenfor.

Denne ”motorveien” er selve ”hjertet” i AutoPay, men er også designet for på sikt å kunne transportere all type data mellom Visma Business og en ekstern datamottaker/avsender.

I skrivende stund er det Visma Innfordring (purring/inkasso) og AutoPay som benytter seg at denne motorveien.

Det er altså ”Den Elektroniske Motorvei” som frakter betalingsinformasjonen frem og tilbake mellom banken på den ene siden og den enkelte bedrift i Visma Business på den andre siden.

For å effektivisere denne transporten og gjøre det mulig å unngå at hver enkelt medarbeider selv må sende og motta betalingsdata og oppdatere disse i økonomisystemet (slik det vanligvis skjer i dag), så har vi altså laget et felles ”Sinsenkryss” hvor alle betalingsdata for alle ”abonnenter” går gjennom. Dette ”veikrysset” overvåkes av Visma eAccount.

Oversikt Direkte Remittering

Nedenfor ser du en enkel skisse for hvordan AutoPay benytter ”Den Elektroniske Motorvei” i forbindelse med remittering. Bedriftens bankforbindelse er her representert ved BBS (Bankenes Betalingssentral).

Etter at du har akseptert betalingsforslaget fra Visma Business, overtar automatikken helt og sørger til og med for automatisk oppdatering av Visma Business etter hvert som betalingene utføres av BBS.

Oversikt OCR innbetalingsservice

Her ser du på samme måte hvordan datastrømmen går når det gjelder OCR innbetaling. Det finnes intet manuelt arbeid vedrørende bruk av OCR innbetalingsservise. Alle data kommer automatisk til deg via den ”Elektroniske Motorvei” og AutoPay sørger for automatisk bokføring og oppdatering av alle innbetalinger. Du trenger ikke en gang å være på jobb! Forutsetningen er selvsagt at det i forbindelse med faktureringen er generert bankgiro med KID-kode.

Hvilken infrastruktur kreves for å kjøre AutoPay?

Du kan benytte deg av AutoPay under en av følgende forutsetninger:

Du kjører Visma Business online via et såkalt ”datakraftverk”. I skrivende stund er det to store datakraftverk som er klargjort for AutoPay, og det er Doorway og Visma Provider.

Du kjører AutoPay på din egen server. Her er det kun en forutsetning, og det er at du har tilgang til Internett.

Du kjører Visma Business på en enkeltstående PC. Også her er det også kun en forutsetning som må være oppfylt, nemlig at du har tilgang til Internett.

Hvilke elementer består AutoPay av?

AutoPay er som nevnt ovenfor et meget avansert konsept for behandling av betalingsdata både til og fra økonomisystemet Visma Business.

Nedenfor lister vi opp de hovedfunksjoner som finnes i løsningen:

Vedlikehold avtaler

Registrering/vedlikehold av avtaler for den enkelte klient. En avtale kan inneholde både remittering og OCR innbetalingsservice, men de kan godt deles i to ulike avtaler dersom du har ulike konti for remittering og OCR, eller flere remitterings- og OCR innbetalingskonti.

2.62 Direkte remittering

Her har du følgende funksjoner tilgjengelig. Noe av dette bestemmes på avtalenivå, noe overordnet på installasjonen og noe er generell funksjonalitet som gjelder uansett:

· Valgfri anvisning/attestasjon før utbetaling kan skje. Dersom denne funksjonen velges, så kan ikke samme person både kjøre utbetalingsforslaget og deretter godkjenne forslaget for utbetaling. Godkjenning/anvisning bestemmes overordnet på hver enkelt installasjon, men kan fravikes på klientnivå under bestemte forutsetninger.

· Godkjenning/anvisning av utbetalinger kan også bestemmes på klientgruppenivå. Det betyr at en klient kan meldes inn i en klientgruppe (for eksempel et team i et regnskapsbyrå) og så må den/de ansvarlige for aktuell klientgruppe/team godkjenne/anvise utbetalingene. Klientgruppe er et eget begrep innenfor AutoPay og lever sitt eget liv uavhengig av tilsvarende grupperingsmuligheter i økonomisystemet.

· Logging av bankkontonummer. Dette er en innebygd funksjon i AutoPay som ikke kan overstyres, og som er bygget inn i systemet for å gi bedre sikkerhet i forbindelse med utbetalinger. Alle nye leverandører/kontonummer og alle eksisterende leverandører som det endres kontonummer på blir logget i forbindelse med godkjenning/anvisning av utbetalinger. Det samme gjelder ved utbetaling til faktoringselskap.

· Valgfri håndtering av belastningsdato i bank.

o        Hver faktura innenfor et oppdrag remitteres med individuell belastningsdato. Det vil si at belastningsdato settes lik forfallsdato på remitteringsoppdraget.

o        Samlet forfall.  Det betyr at du kan legge ut alle fakturaer innenfor et utbetalingsforslag med en felles belastingsdato (for eksempel lik dagens dato).  Mange ønsker å kunne benytte seg at denne funksjonaliteten for å ha bedre kontroll med likviditeten enn man har når det ligger faktura på forfall hos BBS.

· Valgfritt om du ønsker automatisk oppdatering av genererte bunter ved utbetaling, eller om du ønsker å gjøre dette manuelt selv (kjøre ”kaffekopp” i Visma Business). Vi anbefaler at du setter dette opp til å gå automatisk.

· "Fremmedremittering". Det vil si at AutoPay kan ta hånd om og behandle eksterne remitteringsfiler som er generert av andre datasystem enn Visma Business. Eksempel på dette kan være remitteringsfil fra et lønnssystem.

· Returmeldinger av ulike slag. Dette betyr at AutoPay vil sende ut viktige meldinger vedrørende det enkelte remitteringsoppdrag automatisk via e-post til den ansvarlige saksbehandler. Dette gjelder for eksempel følgende:

o        Feil ved remitteringsavtale eller bankkontonummer på oppdraget.

o        Oppdraget stoppet i dekningskontroll hos BBS – AutoPay vil da automatisk reversere hele oppdaget eller de enkeltposter som har blitt forkastet helt tilbake til Visma Business slik at disse postene i neste omgang igjen fremkommer på betalingsforslaget som nye poster.

o        Feil eller manglende KID.  AutoPay vil automatisk reversere utbetalingslinjen helt tilbake til Visma Business slik at de fremkommer på neste betalingsforslag som nye poster.

o        Feil ved dataforbindelsen mellom din server og AutoPay sentralt.

2.63 OCR innbetalingsservice

På samme måte som ved direkte remittering, er noe av funksjonaliteten i forbindelse med OCR bestemt overordnet, noe er generell funksjonalitet og noe bestemmes på avtalenivå.

I OCR innbetaling i AutoPay finner du bl.a. følgende funksjonalitet:

· OCR avtalene kan enten registreres på egne separate avtaler, eller på samme avtale som direkte remittering.

· Mulighet for flere OCR-avtaler pr bedrift/klient

· KID-konvertering. (NB!) Viktig og unik funksjonalitet som gjør at du kan benytte OCR innbetalingsservice også dersom bedriften/klienten fakturerer fra et annet faktureringssystem enn Visma Business med annen KID-kode oppbygging. AutoPay vil da automatisk oversette denne ”fremmede” KID-kode til Visma Business sitt format, slik at automatisk bokføring allikevel kan finnes sted!

· Automatisk bokføring av alle innbetalinger for alle bedrifter/klienter under ett uten manuell behandling.

· Valgfritt om du ønsker automatisk oppdatering av genererte bunter fra OCR innbetalingsrutinen, eller om du ønsker å gjøre dette manuelt selv (kjøre ”kaffekopp” i Visma Business). Vi anbefaler at du setter dette opp til å gå automatisk.

· Felles OCR innbetalingskonto for flere bedrifter/klienter. Dette er også en unik funksjonalitet i systemet. AutoPay sørger for bokføring mot riktig bedrift selv om flere ulike bedrifter/klienter benytter samme bankkonto! (Dette er særlig aktuelt i forbindelse med konsern hvor man ønsker en felles bankkonto, men har behov for å dele opp i flere underliggende bedrifter/klienter av praktiske årsaker.

2.7 Hvem kan benytte seg av AutoPay?

AutoPay er et konsept som er bygget rundt Visma Business. Forutsetningen for å kunne ta i bruk dette unike konseptet er følgende:

· Du benytter Visma Business versjon 4.40.4 eller høyere i en av følgende varianter:

o        Visma Business Regnskapsbyrå

o        Visma Business Advokat

o        Visma Business Lokal Forvaltning

o        Visma Business Design

o        Visma Business Professional

· At du tegner formidlingsavtale med Visma eAccount for AutoPay via ”Den Elektroniske Motorvei”. (Se pkt. 2.2 ovenfor)

3. Funksjonsbeskrivelse AutoPay

3.1 Innlegging av grunndata for AutoPay

Før du starter opp med AutoPay må det legges opp en del grunnleggende data både i Visma Business og i AutoPay. Nedenfor beskriver vi prosessen du må gå gjennom før du kan remittere eller motta OCR innbetalinger for første gang.

Normalt legges dette opp av en konsulent, slik at du slipper å forholde deg til dette selv.

3.1.1 Opplegg av grunndata i Visma Business

En del viktige opplysninger bør legges inn for aktuelt firma/klient i Visma Business før du starter opp.

Det første du gjør er å gå inn på ”Flyskjema administrasjon” og trykke på knappen "Bedriftsparametre". Du får da opp følgende bilde:

Under fanen Bedriftsopplysninger - Generelt

Legg inn følgende:

· Organisasjonsnummer

· Bedriftens bankkontonummer.

· Dersom du skal fakturere med KID-kode (hvilken du nå bør gjøre!), bør du også vurdere å tilpasse din KID-kode ved hjelp av feltene ”KID kunde/lev sifre”, ”KID ref.nr. sifre” og KID-kode behandling”. ·Dette for å optimalisere KID-koden slik at det blir minst mulig antall siffer for din kunde å behandle når han mottar din faktura.

3.1.2 Opplegg av grunndata i AutoPay

Generelt

For å komme inn i de ulike skjermbilder i AutoPay må du alltid gå via ordinær betalingsformidlings-meny i Visma Business. Gå derfor inn på flytskjema "Regnskapsprosessen" og trykk på knappen ”Betalingsformidling”.

Du kommer da inn i følgende vindu:

I det vinduet skal du oppholde deg under hele prosessen som har med AutoPay å gjøre.

Når du kommer inn i vinduet for betalingsformidling havner du i fanen "Betalingsforslag". Dette er i utgangspunktet et vindu som viser åpne poster for leverandører. Herfra får du ikke tak i menyvalget for AutoPay.

Velg derfor neste fane i dette vinduet som heter "Sende betaling". Klikk deretter på overskriften "Betalingslinjenummer" eller på en eksisterende betalingslinje i dette vinduet dersom det finnes.

Når du gjør det, så blir "Behandlingsmenyen" øverst til venstre i Visma Business tilgjengelig, og du skal nå klikke på den slik at rullegardinen fremkommer som vist i bildet nedenfor.

Klikk deretter på menyvalget "Oppsett av AuyoPay" (eventuelt ”Oppsett av Converter), og du får da opp det nedenfor viste vinduet.

Dette er hovedbildet i AutoPay som gir tilgang til både å legge inn/vedlikeholde systemopplysninger i AutoPay, samt oversikt over aktive eller avsluttede betalingsoppdrag på den bedriften/klienten du er logget inn på i Visma Business.

Også dette vinduet har en verktøylinje øverst til venstre.

Ved å trykke på knappen "Oppsett" kommer du inn i oppsettsmenyen av AutoPay.

Følgende valg finnes vedr. oppstart av AutoPay (se bildet ovenfor):

Dataavsender (Krever ekstra passord for å få tilgang)

Kilder (Krever ekstra passord for å få tilgang)

Grupper (Krever ekstra passord for å få tilgang)

KID-kovertering

Ekstra passord for tilgang til gitte systemopplysninger

Årsaken til at visse funksjoner i AutoPay er passordbeskyttet, et at ukyndig og ulovlig tilgang til gitte rutiner kan medføre at oppsettet og følgelig automatikken i systemet blir ødelagt, samt at utbetalinger til leverandører ikke blir anvist (godkjent) som forutsatt av autorisert personell.

MERK! Det er ikke tilrådelig at mer enn en person i organisasjonen har kjennskap til dette passordet. Dersom passordet skulle bli glemt, kan nytt midlertidig og meget tidsbegrenset passord fåes ved henvendelse til Visma eAccount. Dette passordet vil måtte endres umiddelbart for å komme videre. Du bør ikke be om nytt passord før du har behov for det, da det ikke vil være gyldig i mer enn noen få timer etter at det er generert.

Brukere på datakraftverk vil ikke ha tilgang til de passordbeskyttede rutinene, og skal ta kontakt med Visma eAccount for å få endret på de aktuelle systemopplysningene.

Vi anbefaler at passordet skiftes med jevne mellomrom. Dette er særlig viktig dersom anvisningsfunksjonen i AutoPay er i bruk.

Når du trykker på et menyvalg som er passordbelagt, må du oppgi riktig passord for å komme videre inn i den passordbeskyttede delen av systemet.

Passordet ved første gangs innlogging er alltid "AutoPay" med stor "A" og stor "P". Systemet krever deretter at du skifter passord umiddelbart for å komme videre.

Passordvinduet som dukker opp ser slik ut:

Trykk på knappen "Nytt Passord" dersom du skal endre det. Ved første gangs innlogging eller når du får oppgitt nytt passord fra Visma eAccount, så kommer du direkte inn i funksjonen "Nytt passord" som vist nedenfor.

Dataavsender

Velg "Dataavsender", og du får da opp spørsmål om passord som beskrevet ovenfor.

Legg inn riktig passord, og du kommer da inn i vedlikeholdsbildet for dataavsender.

Dataavsender er et svært viktig element i AutoPay. Før du registrerer inn data i dette vinduet, skal du ha inngått avtale med Visma eAccount og blitt registrert som "abonnent" i AutoPay.

Dersom du kjører AutoPay på et datakraftverk, skal du ikke legge inn data i dette bildet.

Dette er altså en engangsregistrering som gjøres dersom du kjører på egen server eller på egen selvstendig PC.

Følgende felt i skjermbildet skal fylles ut: (Husk at det er viktig at dette gjøres nøye!)

Organisasjonsnummer

Her legger du inn dataavsender sitt organisasjonsnummer. Husk at du kun skal legge inn de nummeriske verdiene i organisasjonsnummeret (dvs. ikke "NO" og/eller "MVA"). Dersom du for eksempel er et regnskapsbyrå som kjører på egen server for mange klienter, så er det regnskapsbyrået sitt organisasjonsnummer som skal legges inn her.

Dato opprettet

Denne fylles ut automatisk av systemet

Navn

Fyll ut dataavsender sitt firmanavn (for eksempel regnskapsbyråets navn)

Adresse

Legg inn dataavsenders adresse og poststed i samme felt.

E-postadresse systemansvarlig

Her fyller du inn e-post adressen til den personen hos dataavsender som er dataansvarlig i virksomheten. AutoPay vil i gitte situasjoner sende e-post til denne personen, og Visma eAccount vil også kunne ha behov for å ta kontakt med vedkommende dersom utforutsette situasjoner skulle oppstå. (For eksempel dersom dataforbindelsen faller ut)

Signatur

Dette er en kode som tildeles dataavsenderen av Visma eAccount og må registreres inn nøyaktig. AutoPay tester mot denne signaturen for å kontrollere at riktig avsender står bak de riktige dataene ved overføring til bankene (BBS).

Ønsker e-postmelding dersom data ikke er utvekslet med Visma en dag

Dersom du krysser av i dette feltet, vil AutoPay automatisk sende deg melding dersom systemet ser at det ikke er utvekslet data mellom din server og AutoPay en dag. Denne testen skjer hver natt, og vil altså fange opp mulige kommunikasjonsproblemer litt i etterkant. Vær oppmerksom på det.

Kilde/VBsys

Deretter velger du "Kilde" som vist nedenfor. Ved valg av "Kilde" får su samme spørsmål om passord som beskrevet under "Dataavsender" ovenfor. Det er selvsagt samme passord benyttes i alle rutiner som er passordbeskyttet.

Dersom du kjører på et datakraftverk vil "Kilde" blir opprettet for deg av dataleverandøren, mens du må opprette dette selv dersom du kjører på eget anlegg.

I Visma Business sammenheng vil "kilde" bety hvilken "VBsys" du kjører på, slik at AutoPay vet hvor dine data ligger når de automatiske prosessene kjøres.

Når du trykker på valget "Kilde", kommer du inn i vinduet nedenfor. Dette vinduet inneholder både et vindu for å legge inn "Kilde" og en del grunnleggende opplysninger rundt automatisk pålogging av systemet. I tillegg finnes det et vindu for opplegg av brukergrupper i forbindelse med godkjenning/anvisning av utbetalinger.

Registry nøkkel (kilde)

Denne foreslås normalt av systemet og skal ikke endres av bruker. På datakraftverk blir dette lagt opp av din dataleverandør.

Kildenavn

Fylles normalt ut av systemet, men dersom du har fordelt dine bedrifter/klienter på flere VBsys, så kan du bli nødt til å angi riktig VBsys (kildenavn) manuelt.

Brukernavn Visma Business

Her legger du inn det brukernavnet som AutoPay skal logge seg på med når de automatiske prosessene skal legge inn data i Visma Business etter hvert som det ankommer returdata fra BBS. Dersom du har ledige lisenser kan du godt benytte en spesielle bruker som ikke brukes av andre, men dersom du ikke har lisens for noen ubenyttede brukere, så kan du gjerne angi "System" som bruker her, eller en annen bruker som har systemrettigheter.

MERK! Husk at den brukeren som oppgis her skal være satt opp som systemansvarlig og ikke ha kryss i feltet "En om gangen" i brukertabellen i Visma Business.

Passord og bekreft passord

Her angir du passordet i Visma Business på den brukeren du har angitt ovenfor.

Autorisasjonsnummer

Dette nummeret får du oppgitt av Visma eAccount og vil være din kundereferanse.

Anvisnings-funksjonalitet Kilde/VBsys

Dersom du ønsker at utbetalingene for denne "kilden" (gruppe av bedrifter) skal godkjennes/anvises før det sendes til BBS for belastning, så krever det at en ekstra person i organisasjonen involveres i utbetalingsprosessen før automatikken i AutoPay kan overta..

Alle utbetalingsoppdrag som er underlagt godkjenning/anvisning må alltid godkjennes av en autorisert bruker før utbetalingen kan gå videre til BBS for belastning.

Anvisningsfunksjonen i AutoPay er meget enkel å utføre, og du bør derfor ha veldig gode grunner til for ikke å benytte deg av denne funksjonaliteten!

Hvordan den enkelte rent praktisk ønsker å ordne dette og hvilke grunnlagsmateriell som bør legges frem for den som skal godkjenne utbetalingene må bestemmes av den enkelte bedrift eller regnskapsbyrå.

For regnskapsbyråenes sin del, anbefaler vi at man følger de råd og retningslinjer som er satt opp av NARF i sakens anledning.

I dette bildet angir du på overordnet nivå om det skal være anvisningsplikt på den aktuelle "kilden". Når det er angitt overordnet at det skal være anvisning ved utbetaling, så kan dette overstyres på klient/bedriftsnivå, ved at du på avtalenivå kan sette inn "Nei" til anvisning.

Det er imidlertid kun den person som har passordrettighet til grunndataene som kan gjøre dette. Har du ikke valgt anvisning overordnet, så kan du allikevel sette det opp på en enkeltbedrift/klient. (For eksempel en onlinekunde for et regnskapsbyrå som du ønsket ekstra sikkerhet for)

MERK! Vi anbefaler at det settes på anvisning overordnet, slik at det aldri vil være mulig for en og samme person å gjennomføre en utbetaling fullt ut. Dette sikrer både deg, din bedrift og dine ansatte fra å komme ut for ubehagelige situasjoner og fristelser.

Anvisning

Her angir du om "kilden" skal underlegges anvisningskrav eller ikke. Vi anbefaler altså at du legger inn "Ja" i dette feltet.

Ny

Ved å klikke på menyen "Ny", så får du opp vinduet "Attestant" hvor du angir brukernavnet i NT til den eller de personene som skal kunne anvise utbetalinger.

MERK! De brukere som generer utbetalingsforslag, skal ikke legges opp som anvisere. Kun de personer som skal anvise et utbetalingsoppdrag skal legges inn her. AutoPay passer også på at en og samme person ikke både kan generere utbetalingsoppdrag og anvise det samme oppdraget for utbetaling selv om vedkommende i utgangspunktet har anledning til å gjøre begge deler.

Grupper

Ved å trykke på fanen "Gruppe", kommer du inn i det vinduet hvor du kan opprette anvisningsgrupper.

Attestasjonsgrupper vil si grupper av ansatte (NT-brukere) som du igjen kan knytte til opp mot den enkelte remitteringsavtale i AutoPay.

Dersom du skal opprette en ny attestasjonsgruppe, så klikker du først på fane "Ny" i vinduet "Gruppe" og oppretter en attestasjonsgruppe. Du bestemmer selv navnet.

Deretter knytter du den enkelte brukerne (NT-bruker navnene) på serveren som skal ha tilgang til å attestere utbetalinger til den aktuelle gruppe.

Bildet nedenfor viser dette.

KID-konvertering

KID-konvertering er en spesiell funksjon som finnes i AutoPay for å kunne takle fakturering med KID fra andre system enn Visma Business og hvor selve regnskap og reskontro ligger i Visma Business. Ved hjelp av funksjonen "KID-konvertering" vil AutoPay sørge for at den fremmede KID-koden blir leselig for Visma Business som om KID-koden var generert av Visma Business.

For at det skal være mulig, så må vi legge inn en egen beskrivelse av aktuell KID-kode fra det "fremmede systemet" og knytte denne definisjonen opp mot aktuell OCR-avtalen for bedriften/klienten.

Poenget med dette er altså at man slipper å be om endring av KID-kode i det fremmede systemet og dermed unngå dyr ekstraprogrammering for å kunne benytte OCR mot Visma Business.

(Dette er ofte både vanskelig å få til, da det er nesten ingen faktureringssystem som tilbyr en helt fleksibel KID-kode)

Normalt inneholder en KID-kode både kundenummer og fakturanummer, men AutoPay støtter også KID-koder som kun inneholder en av delene. Dette er beskrevet nøye nedenfor.

Klikk derfor på valget KID-konvertering som vist nedenfor.

Du kommer da inn i vinduet for definisjon av ulike fremmede KID-koder.

I dette vinduet vedlikeholder du definisjon av "fremmed" KID-kode. Disse definisjonene kan du i neste omgang velge ved opplegg av nye OCR-avtaler i AutoPay når "fremmed" KID er aktuelt.

KID-navn

Dersom du skal inn på en eksisterende KID-definisjon velger du den fra rullgardinen i dette feltet.

Skal du lage en ny KID-definisjon, trykk på knappen "Ny KID".

Navnet eller betegnelsen du her legger inn er helt valgfri, men det samme navnet må selvsagt ikke finnes fra før. Det er imidlertid fornuftig å relatere navnet til det systemet som genererer den "fremmede" KID-koden, slik at det er lett å kjenne den igjen.

Bare kundenummer

Ved å sette et kryss i dette feltet, så betyr det at den KID-kode som skal tolkes ikke inneholder fakturanummer.

Det betyr at du ikke kan få krysset innbetalingene direkte mot faktura i Visma Business. Alle innbetalingene vil da bli bokført som "åpne betalinger" og må krysses manuelt mot aktuelle faktura i etterkant.

Bare fakturanummer

Ved å sette et kryss i dette feltet, så betyr det at den KID-kode som skal tolkes ikke inneholder kundenummer.

I dette tilfellet vil du få krysset mot riktig faktura såfremt fakturanummeret er unikt. (Det må ikke finnes flere faktura med samme fakturanummer i kundereskontroen).

Kundenummer posisjon

Her angir du hvor i KID-koden kundenummeret starter. Husk at KID-koden på giroen maksimalt kan være på 25 posisjoner inklusiv kontrollsiffer.

KID-koden er alltid høyrejustert, og uansett hvor lang den er, så skal du oppfatte første siffer fra venstre som første posisjon ved angivelse fra fra-posisjon på kundenummeret i KID-koden.

Kundenummer lengde

Her angir du hvor mange siffer kundenummeret i KID-koden består av.

Fakturanummer posisjon

Her angir du hvor i KID-koden fakturanummeret starter. Tell fra venstre i KID-koden til du finner første posisjon i fakturanummeret og angi dette sifferet her.

Fakturanummer lengde

Her angir du hvor mange siffer fakturanummeret i KID-koden består av.

3.2 Oppretting av avtaler

3.2.1 Generelt

Før du kan registrere inn remitteringsavtalen eller OCR avtalen i AutoPay, må du på vegne av bedriften/klienten ha inngått tilsvarende avtale med BBS (Bankenes Betalingssentral). Gjennom opprettingen av denne avtalen får du tildelt en såkalt avtaleID, som du må angi ved opprettingen av avtalene i AutoPay.

For hver remitteringsavtale og/eller OCR-avtale du oppretter mot BBS, må du altså opprette den samme avtalen i AutoPay.

Så lenge du er registrert som abonnent i AutoPay skal du ikke gi beskjed til Visma eAccount om dette. De automatiske prosessene vil sørge for at avtalen kommer Visma eAccount i hende.

NB! Husk at du må ha valgt riktig bedrift/klient i Visma Business for å få opprettet remitteringsavtale på ønsker bedrift.

Velg "Oppsett av AutoPay" i behandlingsmenyen når du står i vinduet "Betalingsformidling" under fanen "Sende betaling" (se nedenfor).

Du får da opp oversiktsvinduet i AutoPay. Trykk på valget "Oppsett" øverst til venstre i bildet og velg "Opprett avtale" fra rullegardinen.

Dette vinduet er delt opp i fire ulike deler:

· Klientinformasjon

· Saksbehandler

· Avtale

· Anvisning

Nedenfor beskriver vi de ulike felt innenfor hver del.

3.2.2 Klient informasjon

Klientnr.

Dette er klient/bedriftsnummeret i Visma Business som automatisk hentes inn i avtalebildet.

Autorisasjonsnummer

Dette fylles ut automatisk av systemet og er det samme nummer som ble tildelt av Visma eAccount i forbindelse med opplegg av "Kilde/VBsys"

Dataavsender

Fylles ut automatisk av systemet.

Klientnavn, adresse og poststed

Fylles automatisk ut av systemet dersom de samme opplysninger er fylt ut i bedriftsopplysningene i Visma Business.

Klients e-postadresse

AutoPay vil i gitte situasjoner kunne sende e-postmelding til ansvarlig person hos bedriften/klienten. Feltet må ikke fylles ut.

3.2.3 Saksbehandler

Windowsbruker

Her forteller du hvem som er saksbehandler for klienten og hvilket brukernavn i Windows vedkommende har. (NB! Ikke brukernavn i Visma Business)

Det finnes ikke verifisering på riktig brukernavn, så dette må angis riktig uten hjelp fra systemet..

E-postadresse

Her legger du inn saksbehandler sin e-post adresse. Denne adressen vil bli benyttet av AutoPay til å sende automatiske meldinger til saksbehandler når dette er nødvendig. Eksempler på slike meldinger kan være feil ved avtale eller kontonummer, feil KID ved betaling eller manglende dekning på konto.

3.2.4 Avtaleopplysninger i AutoPay

Banksentral

Systemet fyller automatisk ut "BBS" i dette feltet. AutoPay kanaliserer alle betalinger via BBS, som igjen har forbindelse med alle banker i Norge. Dette effektiviserer betalingsformidlingen. Alle brukere av AutoPay må derfor fylle ut nye remitteringsavtaler med BBS mot sine respektive banker for å nyte godt av løsningen.

Dersom du har avtale direkte med BBS fra før, så er det ikke nødvendig å fylle ut nye avtaler. I slike tilfeller er det nok at autorisert personell hos kunden/klienten gir beskjed om endringen i avtalen direkte til BBS via e-post. Visma eAccount hjelper til med å gjøre dette på riktig måte.

Det får ingen konsekvenser for ditt forhold til banken at du kanaliserer all din betalingsformidling via BBS.

Avtaletype

Her er det pr dags dato kun ett valg, nemlig "BBS Dirrem og OCR"

Bankkontonummer

Her fyller du ut avtalens bankkontonummer enten det er en kun en remitteringsavtale, kun OCR-avtale eller begge deler.

MERK! Dersom du har avtale på flere bankkonti for remittering og/eller OCR, så skal du opprette flere avtaler i dette bildet på aktuell bedrift/klient. Det er ingen begrensning i antall avtaler pr bedrift/klient.

Beskrivelse

Frifelt til eventuell beskrivelse av angitt utbetalings- eller innbetalingskonto. Dette feltet kan være aktuelt å bruke dersom du har registrert avtale på mange konti og ønsker å skille dem ved hjelp av et navn eller en tekst.

Kilde (VBsys)

Fylles ut av systemet.

KID-konvertering

Når du krysser av i dette feltet må du angi hvilken KID-konvertering som skal benyttes. Definisjon av nye KID-konverteringsformat gjøres i den overordnede oppsettmenyen i AutoPay under valget "KID-konvertering"

Se beskrivelse av dette under "Kid-konvertering" under punkt "3.1.2 Opplegg av grunndata i AutoPay"

Testavtale

Ved å hake av i dette feltet, kan du opprette testavtaler som går gjennom systemet, men som i stedet for å bli sendt til BBS for belastning, så vil AutoPay sin sentrale database i stedet sende returdata på oppdraget som om det var betalt. Dette er gjort for at du kan teste ut systemet for du tar det i aktiv bruk, og bruke det til ”live” demonstrasjon overfor kunder og forbindelser.

Testoppdrag er alltid merket på en tydelig måte slik at det ikke er vanskelig å skille dem ut.

Slike testavtaler bør selvsagt kjøres fra en testklient/testbedrift i Visma Business, og ikke på virkelige data.

Aktiv

I dette feltet gjør du avtalen aktiv eller ikke aktiv. Det er ikke mulig å foreta noen ut- eller innbetalinger så lenge avtalen ikke er aktiv.

OCR innbetaling

Innbetaling

Ved å sette kryss i dette feltet, så angir du at det skal være OCR innbetalingsservice på denne avtalen.

AvtaleID

Dersom det er krysset av for OCR innbetaling i feltet ovenfor, så skal du angi OCR-avtalen sin avtaleID i dette feltet. Denne får du tildelt av BBS ved inngåelse av avtalen.

Oppdatere bilag

Du bestemmer selv om du ønsker automatisk oppdatering av genererte bunter fra OCR innbetalingsrutinen, eller om du ønsker å gjøre dette manuelt selv (kjøre ”kaffekopp” i Visma Business). Vi anbefaler at du setter dette opp til å gå automatisk.

Merk! Dersom ikke systemet klarer å bokføre alle innbetalingene riktig, vil ikke bunten bli oppdatert (”kaffekopp” er ikke kjørt). Saksbehandler får melding om dette fra AutoPay og må gå inn i bilagsregistreringen under fanen ”Automatgenererte bunter” påføre nødvendige verdier som måtte mangle. Eksempel på slike feil, er dersom kunden har påført feil KID på betalingen, slik at ikke fakturanummer eller kundenummer stemmer med tilsvarende data i Visma Business.

Splitting av innbetalinger

Dette er en funksjon som er beregnet på bedrifter som fakturerer i hvert sitt firma, men hvor innbetalingene skal gå til en felles bankkonto. I slike tilfelle kan du få AutoPay til å splitte innbetalingene, slik at de blir bokført i hvert sitt firma, selv om AutoPay mottar returdata samlet for elle sammen.

Forutsetningen for at dette skal være mulig, er at de avsettes egen nummerserie for kunder eller fakturanummer for hvert firma. Ut fra dette vil så AutoPay splitte betalingene og bokføre dem i riktig firma.

her kan du registrere inntil to forskjellige KID-format. Dette vil være aktuelt i en overgangsfase mellom to system, eller hvor man permanent fakturerer fra to forskjellige system.

KID-lengde

Her angir du den totale lengden på KID-koden inklusiv kontrollsiffer.

Direkte remittering

Utbetaling

Her krysser du av for om dette er en utbetalingsavtale eller ikke.

AvtaleID

Dersom du har krysset av for at dette er en utbetalingsavtale så må du også fylle inn avtaleID i dette feltet. Denne avtale ID-en får du fra BBS ved etablering av avtalen.

Oppdatere bilag

Du bestemmer selv om du ønsker automatisk oppdatering av genererte bunter fra OCR innbetalingsrutinen, eller om du ønsker å gjøre dette manuelt selv (kjøre ”kaffekopp” i Visma Business). Vi anbefaler at du setter dette opp til å gå automatisk.

Felles utbetalingsdato

Ved å krysse av i dette feltet, vil AutoPay lage en felles belastningsdato på alle betalinger som blir med på utbetalingsoppdraget. Det er mange som ønsker å kjøre utbetalinger flere ganger pr. uke og sette felles belastningsdato på alle utbetalingene innenfor et oppdrag, slik at de lettere har kontroll på hvor mye som belastes kontoen til enhver tid.

Det er dermed lettere å holde kontroll med likviditeten.

Dersom du ikke setter kryss i dette feltet, så vil hver faktura bli lagt ut på sin forfalldato som belastningsdato.

Fremmedremittering

Ved å sette et kryss i dette feltet, så angir du at du skal behandler såkalt "fremmedremittering" innenfor denne avtalen. Med fremmedremittering mener vi remitteringsoppdrag som er generert av andre system enn AutoPay. Dette kan for eksempel være utbetalinger som er generert av et eksternt lønnssystem eller annet økonomisystem.

AvtaleID

Dersom du har krysset av for fremmedremittering så må du også fylle inn avtaleID i dette feltet. Som regel skal fremmedremitteringen belastes samme konto som den remitterings som genereres via AutoPay, og da skal du i så fall angi den samme avtaleID her som du har gjort ovenfor under ordinære remittering.

Dersom dette er remittering til en helt annen konto, så må denne kontoens avtaleID angis her.

Anvisning av utbetalingsoppdrag

Anvisning

Her angir du om det skal være anvisning på aktuell remitteringsavtale eller ikke. Vanligvis lar du dette stå som angitt av systemet, altså "Som overordner (Ja) eller (Nei), men dersom du skal ha noe annet enn det som er bestemt overordnet, må du være autorisert til å endre dette via det passordet som dukker opp.

Merk! Avvik fra den overordnede anvisningsregel bør og skal være godkjent ansvarlig person i organisasjonen! Dette passordet skal kun være tilgengelig for kontoansvarlig i selskapet eller den vedkommende bemyndiger.

Gruppe

Dersom det skal være anvisning på denne avtalen, kan du her legge inn hvilken/hvilke anvisningsgruppe(r) som skal kunne anvise denne avtalen. En anvisningsgruppe er altså en gruppe ansatte som skal kunne godkjenne aktuell remitteringsavtale. En anvisningsgruppe kan bestå av en eller flere ansatte.

Et typisk eksempel på en slik anvisningsgruppe er et "Team" i regnskapsbyråsammenheng hvor for eksempel teamlederen skal være godkjenner av alle utbetalinger.

Merk! Det kan det være lurt å legge inn anvisningsgrupper i stedet for ansatte på den enkelte avtale. Ved skifte av ansatte eller når det blir endringer i ansvarsforholdene rundt anvisning, så kan denne endringen gjøres overordnet på en plass i bildet for vedlikehold av anvisningsgruppe i stedet for å måtte endre på hver enkelt avtale. Det betyr at anvisningsgruppe også bør benyttes når det kun er en person pr. anvisningsgruppe.

Vindowsbrukere

Dersom aktuell avtale skal anvises av en spesiell person og ikke via en anvisningsgruppe, så angir du vedkommende sitt NT-brukernavn her. Det er ikke lagt inn kontroll på riktig brukernavn i dette vinduet, så du må vite eksakt riktig brukernavn i Windows (NB! Ikke Visma Business) på den personen som skal anvise her.

Ny

For å legge inn ny anviser/godkjenner, så må du først trykke på Ny-knappen

Slett

For å slette en anviser/godkjenner, må du først merke aktuell anviser og deretter trykke på Slett-knappen.

3.2.5 Avtaleinngåelse med BBS (Bankens Betalingssentral)

Utfylling av avtaleskjema betalingsformidling

Dette skjemaet er laget i Word, og du finner mal på dette både på distribusjonen av Visma Business Regnskapsbyrå på CD under katalogen \Documents\Norwegian eller under www.vismasoftware.no

Ved å dobbelklikke i de sjekkbokser som skal krysses ut, settes det automatisk kryss i ønsket felt.

For kunne etablere en remitteringsavtale mot BBS, så må dette avtaleskjemaet alltid fylles ut og sendes BBS for registrering og godkjenning.

Før avtalen kan sendes til BBS (dette skal kontohavers bankforbindelse gjøre), skal den egenhendig underskrives både av kontohaver og av kontohavers bankforbindelse.

Det avtaleskjemaet som du skal bruke ved etablering av avtalen har vi kalt " Avtaleskjema BBS betalingsformidling AutoPay".

Skjemaet finner du på distribusjonen av Visma Business Regnskapsbyrå (på CD) under katalogen \Documents\Norwegian eller på Visma Software sin nettside under .

Når du kommer inn på denne siden, velg produkt "Visma Business Regnskapsbyrå" og last ned avtaleskjemaet fra vinduet "Nedlastninger"

Du finner også en ferdig utfylt mal på samme sted som også kan lastes ned. Denne malen heter

"Ferdig utfylt avtaleskjema BBS betalingsformidling AutoPay"

Word-dokument for utfylling av avtalen finner du også via denne lokale linken:

Avtaleskjema BBS betalingsformidling AutoPay

Tilsvarende avtale ferdig utfylt finner du på denne linken:

Ferdig utfylt avtaleskjema BBS betalingsformidling AutoPay

Forklaring på utfylling av avtaleskjema

Avtaleskjema om betaler-tjenester og betalingsmottaker-tjenester i næringsforhold

Del E av kontoavtaler. (forside):

Opplysninger om kontohaver.

Her skal organisasjonsnummer, kundens navn (kontohavers navn), adresse, poststed, telefonnummer og fax-nummer fylles ut.

Opplysninger om banken

Her skal minimum bankregisternummer og bankens navn være fylt ut.

Betalertjenester.

Her krysser du av for de tjenester du skal benytter deg av i AutoPay. De tjenester som i skrivende stund er tilgjengelig i AutoPay er:

· Direkte remittering

· OCR giro

· Giromail

Kontohaver bekrefter å ha mottatt avtalevilkårene og godtar disse

Her fyller du ut sted og dato, og den eller de som har fullmakt på kontoen skriver under for hånd. Sørg også for å få underskift fra din bankforbindelse

Registreringsskjema bankkunde 1 av 3:

Her er det kun pkt. 1 som skal fylles ut med mindre du skal bytte bankkontonummer. I det tilfelles skal pkt. 3 Kontobytte fylles ut. Dersom kontobytte registreres via avtaleskjemaet, vil dette skje elegant og smertefritt for deg som bankkunde. Fra det tidspunktet kontobytte skal gjelde fra, vil alle innbetalinger til gammel konto automatisk blir overført til ny konto uansett hvilken bank det gjelder, og alle OCR innbetalinger til gammel konto vil bli flyttet til den nye.

Ved bytte av bankkontonummer vil du beholde din gamle avtaleID, og følgelig ikke være nødt til å gjøre andre endringer i AutoPay avtalen enn å endre bankkontonummer.

1. Kunde (kontoeier)

Organisasjonsnummer, bransje, navn, adresse, postnr.- og sted, land, telefon, kontaktperson hos kontohaver, e-post adresse kontohaver, oppdragskonto, faktureringskonto skal fylles ut. I tillegg skal du krysse av for hva avtalen gjelder. AutoPay dekker i dag direkte remittering og OCR giro. Dersom du velger OCR giro bør du også krysse av for Giromail.

Faktureringskonto er det kontonummer som bankgebyrene skal belastes mot. Som regel er det samme nummer som oppdragskonto.

Registreringsskjema bankkunde 2 av 3:

8. Opplysninger om programvareleverandør/egenutviklet programvare

Forhåndsutfylt av Visma eAccount.

For OCR giro og e-Giro kan det oppgis inntil 3 KID alternativ:

Dersom det på side 1 og side 2, pkt 1. Kunde er merket av for OCR giro, så skal det her oppgis layout på den KID kode som benyttes. Vi anbefaler at du reduserer lengden på KID-koden så mye som mulig, ved å sørge for at riktig paremeter settes under bedriftsopplysningene i Visma Business.

Anbefalt KID lengde er 14 posisjoner inkl kontrollsiffer, og at kundenummer settes til 6 posisjoner og fakturanummer til 7. Modulus 10 benyttes til kontrollsiffer. Kryss derfor av på Mod 10 og Antall siffer inkl. kontrollsiffer = 14.

For å få dette til, så må følgende felt i Visma Business settes opp på følgende måte:

Bedriftsopplysninger - Generelt:

· KID kunde/lev. Sifre 6

· KID ref.nr.sifre 7

· KID-kode behandl. Ikke utfylt

Dersom du har faktura generert fra flere system med ulik KID-format, og disse skal inn i Visma Business, så kan du definere inntil 3 ulike KID format pr konto. For at dette i neste omgang skal kunne leses inn i økonomisystemet må du benytte deg av den unike funksjonaliteten "KID-konvertering" som finnes i AutoPay for å takle dette.

Se beskrivelse av dette under avsnitt 3.1.2 Kid-konvertering ovenfor.

*) e-Giro er ikke en del av AutoPay i første omgang.

9. Dataavsender

Forhåndutfylt av Visma eAccount

10. Mottaker av konteringsdata

Forhåndsutfylt av Visma eAccount

10.3 Gjelder direkte remittering

Skal alltid krysses av dersom du har krysset av for direkte remittering på avtalen ovenfor. AutoPay krever returdata på remittering.

10.4 Periodisering av konteringsdata

Forhåndsutfylt av Visma eAccount

11.1 Giromail (Gjelder OCR innbetaling)

Dersom du har krysset av for Giromail på side 1 og på side 2 pkt 1. Kunde, så skal du oppgi e-post adressen til den personen som skal mottatt elektronisk kvittering på manuelle innbetalinger (uten KID) i dette feltet.

Giromail erstatter de brevbaserte kvitteringene som er vanlig i dag, og bør derfor mottas av den som fører innbetalingene. Det er naturlig at det er konsulenten på regnskapskontoret som oppgis her dersom regnskapet er satt bort til et regnskapsbyrå.

12. Mottaker av kvitteringslister

For kunne motta kvitteringslister på vegne av andre juridiske enheter må du på forhånd være registrert hos BBS som "datamottaker" og ha fått din egen "Kundeenhets-ID" hos dem.

Dette gjelder i hovedsak regnskapsbyrå som remitterer og kjører OCR innbetaling på vegne av sine klienter.

Dersom det på denne avtalen skal være en annen mottaker av kvitteringslister enn kontoeier, så må følgende fylles ut:

Kundeenhets-ID i BBS skal alltid fylles ut med mindre du ennå ikke har mottatt denne ID fra BBS. I tillegg skal navn, adresse, postnr. og – navn, land, telefon og kontaktperson også fylles ut.

Merk! Dette punktet skal altså kun fylles ut dersom mottaker av kvitteringslister er en annen juridisk enhet enn kontoinnehaver (for eksempel et regnskapsbyrå på vegne av en klient). Se punktet "Utfylling av skjema for nye listemottakere" nedenfor.

13. Merknader

Dersom du ønsker at godkjent avtale med ny avtaleID skal sendes til andre enn kontohaver, så skriver du det i denne rubrikken på følgende måte:

Vi ber om at kundens godkjente avtale med avtaleID påført returneres til følgende adresse:

Regnskapsbyrået AS

Att: Berit Olsen

Martin Stokkens vei 299, 7027 Trondheim

Den teksten som står til slutt er en ekstra påminnelse til registervedlikehold hos BBS, i fall noen fyller ut avtalene feilaktig. Denne teksten må ikke slettes.

14. Kontaktpersoner

Kontaktperson hos kunden fylles ut. Dersom det er en ansatt i et regnskapsbyrå som skal være den daglige kontaktpersonen, så oppgis det her.

Kontaktperson hos programvareleverandøren er fylt ut på forhånd av Visma eAccount.

15. Underskrifter

Påfør dato og sted og sørg for egenhendig underskrift både fra kontohaver og bankforbindelse.

Utfylling av avtaleskjema for listemottakere

For kunne motta kvitteringslister på vegne av andre juridiske enheter må du på forhånd være registrert hos BBS som "datamottaker" og ha fått din egen "Kundeenhets-ID".

Dette gjelder i hovedsak regnskapsbyrå som remitterer og kjører OCR innbetaling på vegne av sine klienter og som har behov for å motta kvitteringslistene direkte fra BBS.

For å bli opprettet som listemottaker, må er eget skjema fylles ut i forbindelse med registrering av første remitteringsavtale på vegne av klienter.

Dette skjema som vi har kalt "Avtaleskjema BBS for egne listemottakere AutoPay".

Det finner du på distribusjonen av Visma Business Regnskapsbyrå (på CD) under katalogen \Documents\Norwegian eller på Visma Software sin nettside under .

Velg produkt "Visma Business Regnskapsbyrå" og last ned fra vinduet "Nedlastninger" både avtaleskjemaet og eventuelt også det ferdig utfylte eksempelet på hvordan denne avtalen skal fylles ut. Dette dokumentet heter "Ferdig utfylt avtaleskjema BBS for egne listemottakere AutoPay"

AVTALE EGEN/NY KUNDE (BBS ® 22318822 NG. 079)

Side 1 av 2

Her skal følgende fylles ut:

Listemottaker

Dette er forhåndsutfylt av Visma eAccount

Underskrifter

Pass på at sted, dato og egenhendig underskrift av listemottakers (regnskapsbyrået) leder og bankforbindelse må fylles ut.

Side 2 av 2. Her skal kun pkt. 1 "Kunde" fylles ut.

Følgende felt skal fylles ut:

Org.nr., navn, adresse, postnr. og –sted, land, bransje, kontaktperson og telefonnr.

Utfylling av avtaleskjema for overgang til Giromail

For kunne motta "melding om kreditering" via e-post i stedet for via brev i posten, så må et eget avtaleskjema for overgang til denne løsningen fylles ut både av kontoeier og dennes bank og sendes til BBS for registrering. De fleste banker kan også registrere inn dette selv uten å sende skjemaet videre til BBS.

Dette skjema som vi har kalt "Avtaleskjema BBS Girofax og Giromail AutoPay".

Det finner du på distribusjonen av Visma Business Regnskapsbyrå (på CD) under katalogen \Documents\Norwegian eller på Visma Software sin nettside under .

Velg produkt "Visma Business Regnskapsbyrå" og last ned fra vinduet "Nedlastninger" både avtaleskjemaet og eventuelt også det ferdig utfylte eksempelet på hvordan denne avtalen skal fylles ut. Dette dokumentet heter "Ferdig utfylt avtaleskjema BBS Girofax og Giromail AutoPay"

Utfyllingshjelp

· Valg av tjeneste.
Kryss av i toppen av avtaleskjemaet om du ønsker GiroFax eller Giromail på aktuell bankkonto. Vi anbefaler Giromail.

· Kundeopplysninger
Fyll ut opplysninger om kontoeier og kontaktperson hos kontoeier (bedrift/klient).

· Meldinger og girokopier til følgende konti ønskes tilsendt på telefaks
Giromail Denne teksten er misvisende på avtaleskjemaet. Selv om du velger Giromail, så skal kontonummeret oppgis her! Altså den kontoen du ønsker for.

· E-postadresse
Her oppgir du e-post adressen til den personen som skal motta Giromail. Dette bør da være den personen som fører innbetalingene for aktuell klient.

· Underskrifter
Pass på at dette avtaleskjema skrives under av både bedrift/klient dennes bank før det går videre til BBS. De fleste banker kan registrere dette inn på OCR-avtalen selv uten å sende det til BBS

Merk! Pass på at den oppgitte e-post boksen er tilgjengelig for andre personer ved for eksempel sykdom og ferie.

3.3 Direkte remittering

Direkte remittering via av AutoPay gir deg blant annet følgende fordeler:

· Forenkle arbeidet for deg som bruker

· Vesentlig effektivisering av utbetalingsprosessen

· Løpende oversikt over alle betalingsoppdrag og status på disse.

· Historisk oversikt over alle oppdrag som er sendt og oppgjort.

· Større sikkerhet

· Logg på endring av kontonummer det remitteres til.

· Anvisningsfunksjon

· Automatiske prosesser som oppdaterer alle bedrifter/klienter under ett uten manuell behandling.

· Automatisk e-post til saksbehandler eller systemansvarlig når avvikende situasjoner oppstår.

· Bedre og automatisk informasjon fra AutoPay via e-post.

AutoPay er avhengig av at du gjør det grunnleggende arbeidet ved remittering på vanlig måte i økonomisystemet. Når betalingsforslag er ferdig behandlet i økonomisystemet overtar AutoPay.

3.3.1 Klargjøring av utbetalingsforslag

Generelt

Betalingsforslag behandles på vanlig måte som beskrevet i standard brukermanual for Visma Business. Gå inn i "Regnskapsprosessen" og klikk på knappen "Betalingsformidling".

Behandling av kreditnota

Det er ikke mulig å remittere en kreditnota, og det er derfor viktig at eventuelle kreditnota som skal trekkes fra på en eller flere faktura først krysses mot disse fakturaene i Visma Business før remitteringsforslag genereres.

Dette gjør du ved å merke aktuelle poster som skal krysses mot hverandre (se i bildet nedenfor) og deretter trykke på behandlingsmenyen i Visma Business. Velg deretter "match post-mot-post" fra rullegardinen, og systemet vil da krysse aktuelle poster mot hverandre. Dersom en kreditnota ikke helt dekker opp en faktura, så vil aktuell faktura bli stående igjen med et restbeløp som deretter kan remitteres.

Utarbeidelse av betalingsforslag

Når du står i fanen "Betalingsforslag" kan du enten trykker på behandlingsmenyen og velger "Lag betalingsforslag" med en gang, eller merke av de spesifikke postene du ønsker å betale for deretter å trykke på valget "Lag betalingsforslag".

Du får da opp vinduet "Lag betalingsforslag" som vist nedenfor.

Feltbeskrivelse av vinduet "Lag betalingsforslag" ovenfor:

À jour pr. dato

Her angir du frem til hvilken forfallsdato du ønsker å ha med på forslaget. Det betyr at alle fakturaer med forfall mindre eller lik det du angir i dette feltet vil fremkomme på forslag til utbetaling.

Overføringsdato

Her foreslår Visma Business dagens dato, og du bør i hovedsak akseptere den.

Maks. beløp

Her kan du angi det maksimale beløp du ønsker å generere utbetalingsforlag for.

Dersom du oppgir et maksimumsbeløp (i standard valuta), vil Visma Business velge ut åpne poster så lenge summen av betalingene ikke overstiger dette beløpet. En eventuell sortering av leverandørpostene vil da være avgjørende for hvem som får betaling og ikke. Med andre ord, så velger Visma Business postene i den rekkefølge de vises på skjermen. Du kan selv påvirke rekkefølgen på postene ved å endre på standard utvalg og sortering via funksjonstastene <F7> og <F9>.

Betalingsnummer

Jobber du med et nytt betalingsforslag, velger du "Nytt betalingsforslag" fra nedtrekkslisten. Hvis du derimot skal legge til nye poster i et eksisterende betalingsforslag, velger du betalingnummeret til dette forslaget fra nedtrekkslisten. Det er kun betalingsnummer med status "1" som kommer opp i nedtrekkslisten.

Bankpartner

Her velger du "98 AutoPay".

3.3.2 Utlegg av remitteringsdata

Utlegg fra Visma Business

Når du har fått generert et betalingsforslag vil du finne det igjen under fanen "Sende betalinger". Her kan du ikke lenger endre noe på den enkelte betalingslinje, men du kan slette linjer som du allikevel ikke vil betale ved å merke den eller de linjer dette gjelder og trykke på <Delete> -tasten.

Husk å oppdatere med å trykke <Ctrl+S>.

De slettede betalingslinjene vil da flyttes tilbake til fanen "Betalingsforslag" og kunne remitteres på nytt med en gang eller eventuelt senere. Dersom det betalingsforslaget du har fått generert har så mange feil og mangler at du ønsker å starte på nytt, merker du av hele betalingsforslagsnummeret i det øverste vinduet i bildet og trykker på <Delete> -knappen. Da vil hele betalingsforslaget bli annullert og du kan starte på nytt i fanen "Betalingsforslag". Husk å lagre endringen med <Ctrl+S>.

Merk! Husk imidlertid at du må trykke på oppfrisk-knappen <Shift_F5> eller kun <F5> dersom du allerede står i fanen "Betalingsforslag" for at de slettede postene skal fremkomme i bildet på nytt.

Når betalingsforslaget er slik du ønsker det skal være, plasserer du feltpeker i feltet "Betalingsnummer" og velger "Legg ut data" fra Behandlingsmenyen.

Oppdraget overføres nå til AutoPay sin egen betalingsdatabase. Du vil automatisk få frem godkjenningsbildet i AutoPay som vist nedenfor.

Merk! Dersom du har registrert flere remitteringsavtaler på aktuell klient, så vil AutoPay spørre deg om hvilken avtale du skal benytte før du kommer inn i godkjenningsbildet i systemet.

Avhengig av om du har satt opp AutoPay med krav om anvising av utbetaling eller ikke, så blir rutinene noe forskjellig.

Dersom du ikke benytter anvisningsfunksjonen i AutoPay, så er det tillatt at en og samme person både registrerer bilag, legger opp nye betalingsmottakere (leverandører), generere utbetalingsoppdaget og godkjenner det for utbetaling.

Dersom det er satt opp krav om anvisning på hele kilden (se definisjon av "Kilde" under pkt. 3.12 ovenfor) eller på avtalen, så vil AutoPay passe på at en og samme person ikke får tilgang til både å utarbeide betalingsforslaget og å godkjenne det. En autorisert anviser må da godkjenne oppdraget før det går videre til BBS.

Dersom en som har rettigheter til å anvise utbetalinger utarbeider egne betalingsoppdrag, så medfører det at en annen person må godkjenne oppdraget for utbetaling.

Nedenfor forklarer vi prosessen slik den vil være uten at anvisning er i bruk, mens selve anvisningsfunksjonen, som bare er et lite mellomsteg i prosessen, er beskrevet for seg selv under pkt. 3.3.3.

Merk! Vi anbefaler alle å benytte anvisningsfunksjonen. Dette av sikkerhetsmessige årsaker.

Bekrefte utbetaling i AutoPay uten anvisning

I dette eksempelet er ikke anvisningsfunksjonen aktiv på aktuell avtale. Det betyr at den personen som har utarbeidet betalingsforslaget også kan godkjenne det for utbetaling ved å trykke på knappen "Godkjenn".

I utbetalingsvinduet bør du være oppmerksom på følgende:

Remitteringskonto, klient/bedriftsnavn

Dette hentes inn fra den på forhånd valgte remitteringsavtale på klienten. Husk at du kan ha flere remitteringsavtaler på en og samme bedrift/klient, og du bør da være særlig nøye med å sjekke at riktig konto er valgt før du aksepterer utbetalingen.

Status

Før utbetalingen er godkjent har dette feltet status "Opprettet". Øvrige statuser er følgende:

Opprettet - Status på oppdraget før godkjenning

Godkjent lokalt - Status på oppdraget etter godkjenning

Annullert - Status på oppdraget etter annullering i AutoPay, men før

- tilbakestilling er gjort i Visma Business (skjer automatisk)

Tilbakestilt - Annullert oppdrag er tilbakestilt i Visma Business.

Sendt til sentral - Oppdraget er ferdig og overført til Visma eAccount sentralt.

Delbehandlet - En eller flere poster på oppdraget er belastet bank.

Ferdig behandlet - Oppdraget er ferdig behandlet. Merk at dette ikke betyr at alle

poster betalt, men at det også kan finnes avviste poster i oppdraget.

Eksempler på dette kan være at enkeltposter er avvist på grunn av

manglende eller feil KID eller på grunn av stopp i

dekningskontrollen.

Datasentral

Her ser du hvilken datasentral oppdraget sendes til. I AutoPay er dette i første omgang kun BBS – Bankenes Betalingssentral.

Sum Beløp

Totalsum på oppdraget

Felles belastningsdato

Dersom du ikke har krysset av for "felles belastningsdato" på avtalen, vil dette feltet være blankt. Er feltet er blankt, så betyr det at alle fakturaer som er med på oppdraget blir lagt ut med den respektive faktura sin forfallsdato som belastningsdato.

Skulle du allikevel ønske å overstyre dette, slik at oppdraget i stedet skal legges ut med felles belastningsdato, så kan du krysse av i dette feltet nå. AutoPay vil da sjekke de poster som ligger i oppdraget, og dersom det finnes poster med lavere eller lik forfallsdato med dagens dato, så vil alle poster få belastningsdato lik dagens dato. Dersom det kun finnes poster med forfalls/belastningsdato fremover i tid, så vil AutoPay velge den laveste dato av de fremtidige datoene som felles belastningsdato.

Ved å ta bort merket for "Felles belastningsdato", så vil alle postene gjenvinne sine opprinnelige belastningsdatoer (forfallsdatoer). Dette gjelder uansett om det er krysset av for dette på remitteringsavtalen eller ikke.

Avtale

Ved å trykke på knappen "Avtale", kommer du rett inn i aktuell remitteringsavtale.

Utskrift

Ved å trykke på denne knappen vil du få ut en remitteringsjournal som du kan skrive ut og eventuelt sende til bedriften/klienten for godkjenning.

Nedenfor ser du bildet av hvordan journalen ser ut.

Logg

Dette er et viktig element i sikkerheten rundt AutoPay.

I delvinduet "Logg" vises alle nye leverandører som det gjøres utbetaling på i dette oppdraget, samt alle leverandører som er med på denne utbetalingen og som det er endret bankkontonummer på siden forrige gang det ble gjort til denne leverandøren. Det samme er tilfelle også ved remittering via faktoringselskap.

Ved å trykke på en av linjene i loggen, så vil alle poster i betalingsoppdraget som er relatert til denne leverandøren bli uthevet i spesifikasjonsvinduet av enkeltpostene.

Se pkt. 3.3.4 Logging av endrede bankkontonummer ved remittering i denne dokumentasjon.

Godkjenn

Dersom du utfører betaling for en bedrift hvor anvisningsfunksjonen i AutoPay ikke er i bruk, vil det nederst på skjermen stå følgende med uthevet skrift:

"Denne utbetalingen krever ikke anvisning og blir automatisk overført til bank."

Du kan da trykke på knappen "Godkjenn", og oppdraget vil automatisk bli overført til BBS.

AutoPay sender deg da tilbake til betalingsformidlingsvinduet i Visma Business med meldingen "Utbetalingen er overført til AutoPay"

3.3.3 Anvisning av utbetaling i AutoPay

Dersom det på den "kilden" (gruppe av bedrifter) du er medlem av, eller på den aktuelle remitteringsavtale som du i øyeblikket jobber med er bestemt at utbetalingene skal anvises/godkjennes av en annen person i AutoPay før sendes til BBS for belastning, så krever det en ekstra behandling før automatikken i AutoPay kan ta over.

Slike utbetalingsoppdrag må alltid anvises av autoriserte brukere før utbetalingen vil gå videre til BBS.

Hvordan den enkelte rent praktisk ordner dette og hvilke grunnlagsmateriell som skal legges frem for anviser må bestemmes av den enkelte bedrift eller regnskapsbyrå.

For regnskapsbyråenes sin del, anbefaler vi at man følger de råd og retningslinjer som er satt opp av NARF i sakens anledning.

Hva skjer forut for anvisningen av oppdraget?

Dersom du benytter deg av denne viktige tilleggssikkerheten som ligger i AutoPay, så vil behandlingen frem til oppdraget skal godkjennes være identisk med hvordan det er når anvisning ikke benyttes.

Eneste forskjell for den som utarbeider utbetalingsoppdraget et at knappen for "Godkjenning" nå bytter navn til "Til Godkjenning".

I tillegg står det nå nederst på skjermen følgende melding:

"Denne utbetaling krever anvisning og blir ikke overført til bank før anviser godkjenner den".

Det er derfor viktig at den person som skal anvise oppdragene gjør dette til rett tid. Hvis ikke, så vil betalingene ikke bli utført til rett tid.

Til Godkjenning

Når du trykker på denne knappen vil du, på samme måte som beskrevet overfor i forbindelse med godkjenning uten anvisning, automatisk gå tilbake til bildet for betalingsformidling i Visma Business med meldingen " Utbetalingen er overført til AutoPay", men denne gangen går det ikke oppdraget automatisk over til BBS før anvising er utført.

Anvisning av utbetalingsoppdrag.

For å kunne anvise et eller flere utbetalingsoppdrag får du som godkjenner av slike oppdrag tilgang til anvisningsbildet på tre forskjellige måter:

1 Når du logger deg på Visma Business fra skrivebordet, vil AutoPay sjekke om du er en gyldig "anviser" av utbetalingsoppdrag. Deretter sjekker om du har noen ikke anviste oppdrag liggende på venting. Dersom du har et eller flere slike oppdrag liggende på venting, får du opp dialogboksen som vist nedenfor:

Svarer du "Nei" her, kommer du rett inn i Visma Business på vanlig måte

Ved å svare "Ja" på spørsmålet i dialogboksen, kommer du rett inn i godkjenningsbildet i AutoPay som vist nedenfor.

Alle ikke godkjente utbetalingsoppdrag for alle klienter du er godkjenner for vil nå vises på skjermen, og du kan nå godkjenne dem etter tur.

I og med at du nå ikke er innlogget på en spesiell klient, har du kun tilgang til godkjenningsfunksjonen.

2 Når du har logget deg inn på Visma Business Regnskapsbyrå, kan du gå inn i godkjenningsfunksjonen for utbetalinger via knappen [image] i startvinduet for regnskapsbyrå.

Brukere av Visma Business Design kan selv designe inn denne knappen i sitt egen startvindu via en egen "GUID" dersom det er ønskelig. Se bilde av startvindu for Visma Business Regnskapsbyrå nedenfor.

3 Velg riktig klient/bedrift og gå inn i "Regnskapsprosessen" og trykk på knappen "Betalingsformidling".

Velg deretter fanen "Sende betaling" og klikk på en betalingslinje i øverste del av vinduet eller på teksten "betalingsnr." (Dersom det ikke finnes oppdragslinjer å peke på. i bildet)

Verktøylinjen "Behandling" blir nå aktiv, og du velger "Oppsett av AutoPay" som vist nedenfor.

Du kommer nå inn i oversiktsbildet for AutoPay som vist nedenfor.

Dette bildet er det samme som du kommer inn i dersom du velger å gå inn i anvisningsfunksjonen via pkt. 1 og 2 ovenfor. Ved å gå inn i godkjenningsbildet via en klient (som vist her), så vil du imidlertid oppnå den fordelen at du i tillegg har tilgang til bedriften/klientens avtaleopplysninger.

Når du komme inn i dette bildet vil du derfor i øverste del av vinduet, få frem aktive avtaler på den klienten du er inne på i Visma Business, samt aktive oppdrag (som ikke er ferdig betalt) for samme klient i nederste del av vinduet.

Anviser for:

Klare

For å få oversikt over de utbetalingsoppdrag som du skal anvise, så må du klikke på radioknappen "Klare" under overskriften "Anvisning for"

Du får da opp alle oppdrag på alle klienter som du er anviser for, og som du ennå ikke har godkjent for utbetaling.

Dobbel-klikk deretter på hvert enkelt oppdrag i tur og orden. Dette medfører at du kommer inn i spesifikasjonsbildet for det enkelte oppdrag som vist nedenfor.

Merk! Anvisning av utbetalinger er en viktig, men valgfri sikkerhetsfunksjon som sikrer både den enkelte bedrift som gjør utbetalingene selv, og de regnskapsbyrå som kjører utbetaling på vegne av klientene på en måte som ingen andre elektroniske betalingsløsninger på det åpne markedet kan oppvise maken til.

Det er viktig at anviserne lager seg gode rutiner for hvordan godkjenningen skal skje:

· Når skal utbetalingsoppdragene være klar for anvisning

· Når skal anviser godkjenne sine oppdrag

· Hvilke grunnlagsmateriell (bilag) skal eventuelt legges frem for godkjenner

· Hvem vikarierer for hvem som anviser.

· Alt dette er viktig for å sikre seg at alle utbetalinger kommer BBS i hende i riktig tid.

· Oppdrag som ikke er anvist, vil ikke bli overført til BBS, og vil følgelig heller ikke bli belastet konto.

Både vanlige utbetalinger gjennom Visma Business, utbetalinger via lønn og eventuelle andre remitteringsoppdrag generert av andre system skal alle gå gjennom anvisningsfunksjonen i AutoPay, og alt dette må godkjennes før utbetaling kan skje.

Merk! Særlig lønnsutbetalinger er kritiske å så henseende. Det er derfor av avgjørende betydning at anviser utfører anvisningsjobben løpende og til rett tid.

Godkjenn

Før du godkjenner utbetalingsoppdraget, står det nederst på skjermen:

"Utbetalingen mangler anvisning"

Etter at du har gjort nødvendige kontroller av utbetalingsoppdraget, trykker du på knappen "Godkjenn". Oppdraget vil da automatisk bli overført til BBS.

AutoPay sender deg tilbake til betalingsformidlingsvinduet i Visma Business med meldingen "Utbetalingen er overført til AutoPay"

Obs! Hva gjør du dersom godkjenn-knappen er ikke aktiv?

Dersom du får opp et utbetalingsoppdrag til godkjenning, og "Godkjenn-knappen" ikke er aktiv, er årsaken mest sannsynlig at det er feil på et bankkontonummer eller en KID-kode.

Sjekk derfor loggen (se pkt. 3.3.4 nedenfor). Denne loggen vises nederst på skjermen separat for hvert enkelt oppdrag.

Dersom det er noe feil ved oppdraget som gjør at godkjennings-knappen ikke virker, vil du finne svaret på dette her!

I slike tilfeller må hele oppdraget annulleres og feilen rettes i Visma Business. Dette medfører at Visma Business blir automatisk tilbakestilt, og du kan derfor umiddelbart generere et nytt utbetalingsoppdrag på vanlig måte.

3.3.4 Logging av nye/endrede bankkontonummer ved remittering

Generelt

Dette er et meget viktig element i sikkerheten rundt AutoPay.

I delvinduet "Logg" vises alle nye leverandører som det gjøres utbetaling til i dette oppdraget, samt alle leverandører som er med på denne utbetalingen og som det er endret bankkontonummer på siden forrige gang det ble gjort utbetaling til samme leverandør.

Det samme er tilfelle ved remittering via et faktoringselskap. Dersom du endrer betalingsmottaker på en leverandør som er med på dette utbetalingsoppdraget, eller endrer bankkontonummer på et faktoringselskap som er relatert til en leverandør som er med på dette oppdraget, så vil hendelsen bli logget i AutoPay og vist frem i logg-vinduet på det enkelte oppdrag.

Dette er en viktig kontroll for den som skal godkjenne oppdragene, for revisor og for ledelsen i selskapet for å unngå at det utbetales penger til feilaktige konti. På den måten vil AutoPay være med på å trygge bedriften økonomisk ved å eliminere feilutbetlinger enten de er gjort med overlegg eller ikke.

Det er så vidt vi vet intet annet utbetalingssystem på det åpne markedet som har en tilsvarende sikkerhet!

Ved å trykke på en av linjene i loggen, vil alle poster i betalingsoppdraget ovenfor som er relatert til denne leverandøren bli uthevet i spesifikasjonsvinduet ovenfor.

Merk! De første gangene du remitterer med AutoPay, vil systemet oppfatte alle leverandører som "nye". Loggen vil derfor være lang de første gangene, men den vil veldig fort normalisere seg når det er remittert til alle de viktigste leverandørene minst en gang.

Revisjon og sporbarhet

Alle utbetalingsoppdrag og all informasjon som ligger i dette vinduet på anvisningstidspunktet vil bli tatt vare på, og kan når som helst hentes frem i skjermbildet på nytt og skrives ut både av saksbehandler, godkjenner, ledelse og revisor. Dette gjelder også den meget viktige loggen på hvert enkelt utbetalingsoppdrag. Se nedenfor under pkt. 3.3.5.

3.3.5 Oppslag på ferdig behandlede utbetalingsoppdrag.

Spørring i AutoPay

Du kan i ettertid gjøre oppslag på alle utbetalingsoppdrag både de som er avsluttet og de som fremdeles er aktive. Dette bestemmer du ved å trykke på en av radioknappene i utbetalingsvinduet nedenfor.

Når du dobbelklikker på et oppdrag, får du frem spesifikasjonen som vist i bildet nedenfor:

Aktive

Dersom radioknappen aktiv er slått på, så får du frem kun ikke avsluttede oppdrag på aktuell klient. I utgangspunktet bør det ikke ligge oppdrag med status lavere enn "Sendt til sentral" i dette vinduet annet enn i perioden mellom klargjøring av betalingsoppdraget og anvisning av oppdraget.

Det betyr at du må umiddelbart ta tak i slike hendelser. Dersom årsaken til problemet er manglende godkjenning av oppdraget, så må du ta kontakt med riktig godkjenner. Er det andre årsaker til dette som du ikke selv kan løse, så må du ta kontakt med Visma eAccount.

Alle

Med radioknappen "Alle" aktiv, så får du listet opp alle oppdrag som finnes på aktuell klient, både de som er avsluttet og de som er under behandling.

Ved å dobbelklikke på et oppdrag (som vist ovenfor), kommer du inn i detaljbildet som viser alle poster som inngår i oppdraget på samme måte som da du skulle godkjenne det for utbetaling. Her vil du også se status på hver enkelt post. Det kan nemlig godt hende at de ulike postene har forskjellig status avhengig av forfall, avvisning eller lignende.

Logg

I delvinduet "Logg" ser du alle leverandørkontonummer som det ikke har vært remittert til tidligere, og samt alle leverandører som det er endret kontonummer på siden sist det er remittert til samme leverandør. Dette gjelder også remittering via factoring.

Se pkt. 3.3.4 Logging av endrede bankkontonummer ved remittering i denne dokumentasjon.

Spørring i Visma Business

I Visma Business vil du nå finne oppdraget under fanen "Hente returdata" med ulik status avhengig av hvor langt oppdaget har kommet i prosessen.

AutoPay vil passe på dette for deg og sørge for at du får oppdatert økonomisystemet straks noe har skjedd med oppdraget.

Merk! Du skal altså selv ikke foreta noen endringer i dette "hente returdata", med mindre dette gjøres etter avtale med Visma eAccount.

I eksempelet nedenfor ser du at alle linjene er merket som "Betalt", hvilket vil si at det også er generert regnskapsbunt på grunnlag av dette betalingsoppdraget.

Alle automatisk genererte bunter som kommer fra AutoPay blir lagt inn i Visma Business med opprinnelseskode = 7. (Direkte remittering)

Under knappen "Betalingsformidling" i "Regnskapsprosessen" finner du arkfanen "Konteringsjournal" Her vises kun de automatgenererte bilagsjournalene som kommer fra AutoPay. Disse er sortert på synkende dato slik at den siste (nyeste) bunten alltid kommer først.

Se bildet av dette skjermbildet nedenfor.

Utskrift av konteringsjournal

Ved å sette feltpeker på riktig bilagsjournalnummer i øverste del av vinduet ovenfor, kan du velge vanlig utskrift eller forhåndsvising. Du får da ut en journal slik den er vist nedenfor.

Du kan selvsagt også søke frem den samme journalen via oppdaterte bunter i bilagsregistreringen eller via knappen "Journaler" og gå inn på fanen "Oppdateringsjournal".

Det enkleste er imidlertid å benytte fanen "Konteringsjournal" som vist ovenfor.

3.4 OCR innbetaling

3.4.1 Generelt

OCR innbetaling er en funksjon som finnes i det fleste økonomisystem, men det finnes ingen andre

løsninger som til de grader er automatisert som den du finner i AutoPay

AutoPay OCR-innbetaling krever absolutt intet arbeid fra den enkelte medarbeideren sin etter at OCR-avtalen er registrert hos BBS og i AutoPay. Fra det tidspunktet overtar automatikken helt enten du har mange klienter på din server eller kun en.

Se den overordnede beskrivelsen av OCR innbetaling i AutoPay under pkt. 2.4 ovenfor.

3.4.2 Registrering av OCR-avtale

Registrering av OCR-avtale med BBS

Det første som må skje er at du fyller ut avtaleskjema for OCR innbetalingsservice fra BBS (dette gjør du vanligvis samtidig med at tilsvarende avtale for direkte remittering fylles ut).

Merk! Se forklaringen på utfylling av BBS sine avtaleskjema for OCR innbetaling, for "Listemottakere" og for Giromail under punktene 3.2.5, 3.2.6 og 3.2.7 i denne brukerbeskrivelse.

Registrering av OCR-avtale i AutoPay

Det er viktig at de riktige opplysningene for aktuell OCR-avtale registreres inn i avtalebildet for betalingsformidling i AutoPay.

Dersom du allerede har registrert inn en utbetalingsavtale på aktuell bedrift/klient, kan du registrere inn OCR-avtalen i samme avtale.

Flere konti med OCR-avtale på samme bedrift.

Noen bedrifter har flere ulike bankkonti som de har OCR-avtale på, og AutoPay takler dette ved at det kan opprettes flere OCR-avtaler i AutoPay på samme klient/bedrift.

Se registrering av avtaler under pkt. 3.2.4 Avtaleopplysninger i AutoPay – OCR innbetaling ovenfor.

Konsernbehandling av innbetalinger – En konto flere bedrifter/klienter

AutoPay er bygd for å kunne takle OCR innbetaling til flere bedrifter/klienter i Visma Business hvor pengene fysisk betales til en og samme bankkontonummer!

For at dette skal kunne la seg gjøre, må noen viktige forutsetninger være oppfylt:

· Alle bedriftene/klientene må fysisk være plassert hos en og samme datamottaker i AutoPay. (Det er intet krav om at de ligger på samme VBsys)

· AutoPay benytter KID-koden som grunnlag for å kunne skille betalingene på ulike bedrifter/klienter innenfor konsernet fra hverandre.

Det betyr følgende:

Det må reserveres egne kundenummerserier eller bilagsnummerserier for hver enkelt bedrift/klient som må unik for i forhold til de andre bedriftene i konsernet.

Dette betyr at alle bedrifter/klienter som benytter denne bankkontoen som innbetalingskonto ved fakturering, må registrere hver sin OCR-avtale i AutoPay med dette kontonummeret.

Her må det da legges inn kundeintervall eller fakturanummerintervall som aktuell bedrift/klient benytter.

Ut fra dette vil AutoPay splitte alle innbetalingene som i fysisk kommer inn på en og samme bankkonto til et ubegrenset antall andre klienter uten manuell oppfølging på noe punkt!

De betalinger som rettmessig tilhører konsern-bedriften vil selvsagt bli bokført dit dersom det legges inn tilsvarende informasjon kundeintervall eller fakturanummerintervall også på den OCR-avtalen.

I tillegg til dette krysses det av i avtalebildet om aktuell klient er /kontoeier eller ikke. Dette fordi alle innbetalinger via OCR som AutoPay ikke klarer å finne riktig klinet på, automatisk vil bli postert inn på kontoeier sin klient/bedrit.

Se for øvrig beskrivelsen av oppretting av nye avtaler under pkt. 3.2.4 ovenfor.

3.4.3 Hva skjer i økonomisystemet ved OCR innbetaling?

Generelt

For at OCR innbetaling skal kunne benyttes, så fordrer det selvsagt at fakturaene som produseres i økonomisystemet er skrivet ut med riktig KID-kode på bankgiroen. I tillegg må det være registrert en OCR-avtale hos BBS og i AutoPay som er i overenstemmelse med den KID-kode som genereres av fakturasystemet.

Merk! Fakturaene behøver imidlertid ikke å være generert av Visma Business. Hvilket som helst annet fakturasystem som kan generere OCR giro på fakturaene kan benyttes til dette formålet. KID-koden trenger heller ikke å være lik den som produseres i Visma Business. Dette konseptet kaller vi "KID-konvertering".

Se beskrivelse av følgende:

Pkt. 3.1.1 Anbefalt KID-oppsett

Pkt 3.1.2 Opplegg av grunndata i AutoPay - KID-konvertering.

Når OCR-avtalen er registrert og i orden, så overtar automatikken fullt og helt enten du har en eller mange OCR-avtaler, og helt uanhengig av antall innbetalinger pr avtale.

Det betyr følgende:

Alle OCR-innbetalinger blir automatisk overført til din server fra BBS minst en gang pr dag

Innbetalingene blir deretter sortert og postert inn i OCR automatbunter på hver enkel bedrift/klient.

Oppdatering av OCR-bunt blir automatisk utført dersom det er krysset av for dette på avtalen.

Med endre ord, ingen manuelle inngrep for at innbetalingene skal bli postert.

Merk! I tillegg er det viktig å være klar over at AutoPay sørger for nøyaktig riktig bokføring av innbetalte beløp i forhold til hvordan beløpene fremkommer på kontoutskriften fra bank. Dette letter selvsagt avstemmingsarbeidet for den enkelte bruker.

Avvikshåndtering ved bokføring av innbetalinger

Dersom det kommer innbetalinger via OCR som har KID, men hvor AutoPay ikke gjenfinner KID-referansen mot kunde og/eller faktura eller at beløpet ikke stemmer med restbeløp på fakturaen, så medfører dette følgende:

Dersom det ikke er krysset av for "Bare kundenummer" i bildet for KID-konvertering, og fakturanummer fra KID =0, legges kundetransaksjonen ut på bilagslinjen uten kontonummer og med følgende tekst i feltet "Ekstratekst": "Klarer ikke å tolke KID".

Dersom fakturanummer finnes, men beløp er større enn fakturanummer, så overstyrer AutoPay automatikken i Visma Business, slik at det faktisk innbetalte beløp blir bokført på kontoen. Det betyr at en overbetaling mot en gitt faktura vil medføre at overbetalingen vil bli stående igjen som rest på selve innbetalingsposten.

Dersom AutoPay finner et fakturanummer ut fra KID-koden og denne fakturaen tilhører en annen kunde enn det kundenummeret som er angitt på KID-koden, så setter AutoPay dette kundenummer til 0 og gir melding på Ekstratekst-feltet med følgende tekst" Kundenummer i Visma stemmer ikke med kundenummer på KID".

Dersom AutoPay via KID-tolking ikke finner noen faktura i åpen post som stemmer med fakturanummer på KID-kode, så posterer AutoPay transaksjonen mot det kundenummeret som ligger på KID-koden. Innbetalingen blir da postert som en "åpen innbetaling" uten motreferanse.

Dersom AutoPay på punktet ovenfor finner ut at det kundenummer som settes inn fra KID-koden ikke eksisterer i Visma Business, så settes kontonummeret til 0 og teksten "Kundenummer fra KID eksisterer ikke" settes i feltet "Ekstratekst".

Sannsynlig feil er da at kunden mangler i aktørtabellen.

Dersom en innbetalingsbunt inneholder transaksjoner som ikke kan behandles fullt ut, vil AutoPay la være å oppdatere bunten og sende melding til saksbehandler om at det ligger en ikke oppdatert OCR-bunt som må behandles manuelt.

Disse buntene finner du i bildet for "Bilagsregistrering" under fanen "Automatgenererte bilag" som vist nedenfor.

Oppslag på innbetalinger og OCR-informasjon i Visma Business

Når du står på en innbetalingslinje i Visma Business enten i oppdaterte eller ikke oppdaterte bilag, så kan du slå opp et egen vindu som gir deg ytterligere informasjon om innbetalingen. Dette gjør du ved å stå på ønsket transaksjonslinje og deretter trykke på knappen · og få frem spesifikasjonsvinduet som vist nedenfor.

Under knappen "Bilagsregistrering" – "Journaler" finner du fanen "OCR-innbetalinger. Her får du frem alle OCR-innbetalingsjournalene i synkende rekkefølge. Det betyr at du får opp de nyeste journalene først. Her kan du også hente frem ekstra betalingsinformasjon ved å stå på ønsker transaksjonslinje og trykke på knappen "OCR-info".

Utskrift av OCR innbetalingsjournal fra Visma Business

Ved å trykke på knappen "Forhåndsvising" i bildet ovenfor får du opp OCR innbetalingsjournalen som vist nedenfor. Fra dette vinduet kan du trykke på utskriftsknappen og få rapporten ut på skriver. Du kan selvsagt også trykke direkte utskriftsknappen i bildet ovenfor og få utskriften direkte ut på skriver.


Utfylt avtaleskjema

Avtale om betaler-tjenester og betalingsmottaker-tjenester i næringsforhold

Del E av kontoavtalen

Opplysninger om kontohaver

Opplysninger om banken

Organisasjonsnummer

999999999

Organisasjonsnummer

Bankregisternummer

6001

Kundens navn

Utbetaler & co AS

Bankens navn

Nordea

Adresse

Prinsensgt. 39

Adresse

Postnummer og sted

7401 Trondheim

Postnummer og sted

0

Telefonnummer

73568890

Telefaksnummer

73568891

Telefonnummer

0

Telefaksnummer

Kryss av for de tjenester som ønskes

Betaler-tjenester

Direkte remittering (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Egiro utbetaling (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Betalingsmottaker-tjenester

Autogiro (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

AvtaleGiro (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

OCR giro (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Egiro innbetaling (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Egiro innbetaling pluss (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Giromail (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Girofax (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

eFaktura (Se vedlagte Avtalevilkår og Registreringsskjema bankkunde)

Tjenesten kan kun benyttes for konti angitt i registreringsskjema bankkunde.

Avtalevilkårene for tjenestene suppleres av tjenestespesifikk brukerdokumentasjon, som angitt i tjenesteavtalen, samt bankens Alminnelige vilkår for innskudd og betalingsoppdrag (Del C av kontoavtalen).

Ved motstrid mellom følgende dokumentasjoner gjelder følgende rangordning:

1. Registreringsskjema bankkunde, tjenestespesifikasjon og meldingshåndbøker

2. Avtalevilkår for tjenestene

3. Alminnelige vilkår for innskudd og betalingsoppdrag

4. Annen brukerdokumentasjon

Banken skal sende Registreringsskjema bankkunde (3 sider) til BBS. Avtalen (forsiden) beholdes av bank/kunde.

Så snart BBS har registrert avtalen, vil BBS varsle banken og kontohaver om dette, slik at de ønskede tjenester kan tas i bruk.

Kontohaver bekrefter å ha mottatt avtalevilkårene og godtar disse

Sted, dato

Trondheim, 2. februar 2004

Kundens underskrift

Sted, dato

Trondheim, 5. februar 2004

Bankens underskrift og stempel

Vi er registrert som kunde i BBS tidligere

Registreringsskjema bankkunde 1 av 3

1. Kunde (kontoeier)

4. Gjelder eFaktura

Organisasjonsnr. 112233445

Avtalenavn som presenteres for forbruker i nettbank:

Bransje Dagligvare

Navn

Utbetaler & co AS

Navn/avdeling for kundehenvendelser:

Adresse 1 (v/person eller avdeling)

Telefon

e-post

Adresse 2 (gate-/postadresse)

Prinsensgt. 39

Tilbyr dere AvtaleGiro: Ja Nei

Hvis ja, vil eFaktura bli tilbudt

I kombinasjon med AvtaleGiro: Ja Nei

Postnr. og sted

7401 Trondheim

Land

Norge

Telefon

73568890

eFaktura referanse

Hva benyttes som eFaktura referanse: ………………………………..

(eks. kundenr.)

Antall siffer. Alt.1: Alt.2: Alt.3: -

Kun numerisk Ja Nei

Disse opplysningene benyttes til kontroll ved innmelding i nettbank.

Kontaktperson Peder Aas

e-post peder.aas@online.no

Oppdragskonto

99999999995

Faktureringskonto

99999999995

Avtalen gjelder:

Avtale- ID i BBS

Avtalefangst i nettbank

Angi kontonummer for avtalefangst:

Direkte remittering

Egiro utbetaling

Konto:

Konto:

Konto:

Autogiro

Hvis flere enn 3 konti, bruk pkt 13, Merknader.

AvtaleGiro

KID Angi totalt antall siffer i KID inkl. kontrollsiffer :

Angi posisjon for eFakturareferansen i KID:
f.o.m. t.o.m. -

OCR giro

eFaktura oppdrag
Formater
Programpakker

Egiro innbetaling

Egiro innbetaling pluss

BBS

XML

Annet

Navn, versjon

Giromail

Avtaleoppdrag

Girofax

eFaktura

Faktura-/betalingskravs-oppdrag

Sikkerhet på egiro-tjenestene

Sikkerhetsprogrammet Toolkit kan bestilles hos BBS

Kvittering på oppdrag

Eksisterende fakturavolum til forbruker pr. år.

Antall:

Fakturahotell

Fylles ut hvis annet enn Bankenes Fakturahotell skal benyttes

Organisasjonsnummer:

Navn:

Kontaktperson:

Telefon:

e-post:

2. Fast tekst på kontoutskrift.

Eventuell integrasjonspartner

Kun aktuelt for brukere av Bankenes Fakturahotell som ikke bruker BBS-format og standard fakturamal.

Gjelder for direkte remittering, autogiro(maks 30 pos) og AvtaleGiro(maks 25 pos)

Navn:

3. Kontobytte (Gjelder ikke OCR giro)

Kontaktperson:

Gammel konto:

Avtale-ID:

Telefon:

e-post:

Ny konto:

Skal gjelde fra (dato):

Registreringsskjema bankkunde 2 av 3

5. Gjelder autogiro

9.1 Gjelder autogiro

Valgfritt ønske om repetering av transaksjoner avvist i betalers bank:

1 dag 2 dager 3 dager

BBS skal produsere betalingspåminnelse når trekk er avvist av betalers bank

Gjelder ikke engangsfullmakter

Elektronisk innsending av fullmakter

10. Mottaker av konteringsdata

Navn og adresse skal kun fylles ut hvis det avviker fra pkt. 1. Kunde

Kundeenhet-ID i BBS

00011542

Navn

Visma Solution AS, avd. Trondheim

(Om ytterligere opplysninger, spesifiser i pkt 13. Merknader)

Telefon

46400500

10.1 Gjelder autogiro

Elektronisk retur av fullmakter

Retur av godkjente transaksjoner

Retur av avviste transaksjoner

Gjelder ikke engangsfullmakter

10.2 Gjelder egiro utbetaling –

Konteringsdata i DEBMUL-melding

Alt.1: Betalingsoppdrag sendt BBS i PAYMUL- melding på sum nivå (B)

Alt.2: Betalingsoppdrag sendt BBS i PAYMUL- melding på sum og transaksjons nivå (B og C)

Alt.3: Alle betalingsoppdrag sendt BBS og bank(B og C)

6. Gjelder OCR giro, egiro innbetaling og egiro innbetaling pluss

Avvisning av betalinger med manglende eller ugyldig KID

Alle online-betalinger til vår OCR giro konto skal avvises dersom Kundeidentifikasjon mangler eller er ugyldig.

Alle elektroniske betalinger til vår OCR giro konto skal avvises dersom Kundeidentifikasjon mangler eller er ugyldig.

10.3 Gjelder direkte remittering

7. Gjelder egiro utbetaling

Retur av godkjente transaksjoner

Ønsker å kansellere betalingsoppdrag i egiro utbetaling ved bruk av FINCAN-melding

10.4 Periodisering av AvtaleGiro og OCR giro konteringsdata

8. Opplysninger om Programvareleverandør/ egenutviklet programvare

Daglig

Ukedag(er) (1-5) -

Dag(er) i mnd (1-31) -

Eventuelle forskjeller i periodisering pr tjeneste kan angis i pkt 13. Merknader

Navn Programvareleverandør/egenutviklet programvare

Visma Solutions AS, avd. Trondheim

KID for AvtaleGiro

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: -

Kundenummer: Posisjon

f.o.m. t.o.m. -

Betalingstype: Posisjon

f.o.m. t.o.m. -

10.5 Periodisering av egiro konteringsdata

Egiro utbetaling

Levering 1 gang pr dag

Egiro innbetaling

Daglig

Ukedag(er) (1-5) -

Dag(er) i mnd (1-31) -

Egiro innbetaling og egiro innbetaling pluss for betalingsoppdrag avregnet i BBS

Levering 1 gang pr dag

Levering 2 ganger pr dag

Konteringsdata for betalingsoppdrag avregnet i banken blir sendt bankkunde via BBS ihht gjeldende driftsmønster

For OCR giro og egiro kan det oppgis inntil 3 KID alternativ:

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: 14 -

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: -

Mod 10 Mod 11 Antall siffer inkl.

kontrollsiffer: -

9. Dataavsender

Navn og adresse skal kun fylles ut hvis det avviker fra pkt. 1. Kunde

Kundeenhet-ID i BBS

00011542

Navn

Visma Solution AS, avd. Trondheim

(Om ytterligere opplysninger, spesifiser i pkt 13. Merknader)

Telefon

46400500

11.1 Giromail

Registreringsskjema bankkunde 3 av 3

e-post adresse: (BRUK BLOKKBOKSTAVER)

BERIT.OLSEN@REGNSKAPBYRAET.NO

12. Mottaker av kvitteringslister

Navn og adresse skal kun fylles ut hvis det avviker fra pkt. 1 Kunde

Kundeenhet-ID i BBS

0001177

11.2 Girofax

Telefaks alt. 1: -

Landkode Områdekode Lokalt telefaksnr.

Telefaks alt. 2: -

Landkode Områdekode Lokalt telefaksnr.

Dersom flere konti, skriv disse i pkt 13. Merknader.

Girofax maks. 50 sider pr forsendelse. Dersom det ønskes økt antall noteres dette i pkt. 13. Merknader.

Navn

Regnskapsbyrået AS

Adresse 1 (v/person eller avdeling)

Martin Stokkens vei 299

Adresse 2 (gate-/postadresse)

Postnr. og sted

7027 Trondheim

Land

Norge

Telefon

72560506

Kontaktperson

Berit Olsen

13. Merknader

VIKTIG ! Referer alltid til hvilket felt merknaden gjelder.

Vi ber om at kundens godkjente avtale med avtaleID påført returneres til følgende adresse:

Regnskapsbyrået AS

Att: Berit Olsen

Martin Stokkens vei 299, 7027 Trondheim

NB! Dersom dette er en remitteringsavtale skal punkt 10.3 og punkt 10.4 - "Daglig" alltid være avkrysset.

Dersom dette kun er en OCR avtale, skal punkt 10.4 - "Daglig" alltid være avkrysset. (Gjelder kundeenhet-ID 00011542)

14. kontaktpersoner

Hos kunden Telefon e-post adresse

Berit Olsen 73538891 berit.olsen@regnskapsbyraet.no

Hos Programvareleverandør Telefon e-post adresse Programvare

Einar Fjørtoft 46400641 einar.fjortoft@visma.no Visma AutoPay

Hos banken Telefon e-post adresse Bankens reg. nr.

15. Underskrifter
Sted, dato Trondheim, 2. februar 2004 | Sted, dato Trondheim, 5. februar 2004
Kundens underskrift | Bankens underskrift og stempel

16. Avtalen er registrert i BBS

Sted, dato

Underskrift


Komme i gang med AutoPay

”Komme i gang” med Visma AutoPay

Når du kommer i gang med AutoPay vil e-post være en viktig informasjonskanal mellom deg og de automatiske prosessene i systemet. Det er derfor viktig at du følger med i din egen postboks når det gjelder meldinger som kommer fra AutoPay.

For å få full oversikt over AutoPay bør du lese hele brukerdokumentasjonen. Denne ”Komme-i-gang-oversikten” er ment som en kort oppsummering over hva som må gjøres ved oppstart/bruk av AutoPay.

Oppstart av AutoPay (en gangs jobb pr installasjon)

Oppretting av formidlingsavtale med Visma eAccount for å starte opp med AutoPay
Dette gjør du ved å ta kontakt med Visma eAccount direkte og be om hjelp for å sette opp systemet og legge inn grunnleggende data som gjelder din installasjon. Legg ikke særlig vekt på å forstå hva som skjer her, da det kun er en engangsjobb som du siden ikke behøver å bry deg om. Kjører du på datakraftverk fra Visma eAccount, så slipper du helt å tenke på noe av dette!

Oppstart av OCR/remittering på nytt firma

  1. Etablering av remitteringsavtale og OCR-avtale hos BBS
    Det første du må sørge for, er å få etablert avtale med BBS på de remittering og/eller OCR oppdrag du har. Dette skjer ved at du fyller ut de skjema som er laget for dette formålet på riktig måte. Deretter må kontoeier og bankforbindelse skrive under avtalen og sende den til BBS for registrering.
    Se brukerdokumentasjonen for AutoPay pkt . 3.2.5 - Utfylling av avtaleskjema betalingsformidling.
  2. Evt. omregistrering av eksisterende avtale hos BBS
    Dersom du allerede har en remitteringsavtale hos BBS så holder det å omregistrere dataavsender på denne. Ta evt kontakt med Visma eAccount for informasjon/bistand
  3. Registrering av remitteringsavtale og OCR-avtale i AutoPay
    Når du har fått godkjent avtale i retur fra BBS, så må denne registreres i AutoPay. Dette skjer i følgende vindu (husk å stå på riktig klient/bedrift) i Visma Business: Regnskapsprosessen – Betalingsformidling – Sende betaling – Behandlingsmeny – velg "Oppsett av AutoPay".
    Se brukerdokumentasjonen for AutoPay pkt . 3.2 Oppretting av avtaler.

Bruk av AutoPay ”trinn-for-trinn”

  1. Lage betalingsforslag
    Dette gjør du i Visma Business. Se brukerdokumentasjonen for AutoPay pkt . 3.3.1
  2. Utlegg av remitteringsoppdrag og bekrefting av utbetaling
    Utlegg gjør du i Visma Business og bekrefting i AutoPay. Se brukerdokumentasjonen for AutoPay pkt . 3.3.2
  3. Anvisning av utbetalingsoppdrag
    Dette gjelder kun de som ønsker ekstra sikkerhet før utbetaling skjer ved at en annen enn den som har generert oppdraget må godkjenne det før det sendes til utbetaling. Se brukerdokumentasjonen for AutoPay pkt . 3.3.3
  4. Logging av endrede kontonummer
    Dette er en viktig sikkerhet som er innebygd i Visma AutoPay, og som alle bør bruke aktivt for å sørge for at betaling går til riktig mottaker. Se brukerdokumentasjonen for AutoPay pkt . 3.3.4
  5. Spørring på oppdrag i AutoPay og Visma Business.
    Du kan spørre på oppdrag både i Visma Business og i AutoPay lang tilbake i tid som du ønsker. Det er fornuftig å sette seg inn i dette etter hvert som man kommer i gang.Se brukerdokumentasjonen for AutoPay pkt . 3.3.5


Tidsfrister Direkte Remittering i AutoPay

Frist for lokal god kjenning i AutoPay | AutoPay sender oppdragene til BBS | Avregning hos BBS | Normalt på konto hos mottaker
10.00 | 10.45 | 12.00 (innleste og gyldige oppdrag) | I løpet av samme dag
13.00 | 13.50 | 24.00 (innleste og gyldige oppdrag) | Neste morgen
15.00 | 15.40 | 24.00 NB! Med forbehold! – se nedenfor | Neste morgen eller ettermiddag

Disse fristene gjelder alle typer remittering som godkjennes via AutoPay (fra Visma Business, lønnssystem eller annen ”fremmedremittering”)

Vedr. godkjenningsfrist kl. 15:00:

Bankenes Betalingssentral garanterer ikke at utbetalingsoppdrag som er dem i hende etter kl. 13:50 blir behandlet samme dag og kan følgelig heller ikke garantere at pengene på slike oppdrag er på konto neste morgen. BBS sier imidlertid at slike oppdrag ”mest sannsynlig” vil bli behandlet samme kveld med mindre det er en feil i oppdraget eller manglende dekning på konto.

Innleste og gyldige oppdrag som er dem i hende etter kl. 13:50 og som av en eller annen grunn ikke er blitt behandlet, vil i stedet bli behandlet påfølgende dag kl. 12:00 og være på konto i løpet av ettermiddagen. Vi fraråder derfor mot å ”gamble” med fristen kl. 15:00 på kritiske betalinger!

Vedr. remittering på fredager:

Siste avregning hos BBS er kl. 12:00 på fredager. Det betyr at oppdrag som er godkjent i AutoPay mellom kl. 10:00 og 13:00 på fredager ikke vil være på konto før mandag morgen. Oppdrag som må være på konto i løpet av fredag, må derfor senest være godkjent i AutoPay kl. 10:00. Vi anbefaler imidlertid å godkjenne slike betalinger innen kl. 13:00 dagen før for å være på den sikre siden.

”Hastebetalinger”

Dersom du har en betaling som må være på konto i løpet av inneværende dag, har du mulighet for å rekke det ved å godkjenne oppdraget i AutoPay innen kl. 10:00. Da blir oppdraget med på avregning hos BBS kl. 12:00 samme dag og på konto i løpet av ettermiddagen.

”Normalt på konto”

Tidspunkt for godskriving på konto kan avhenge av hvilken bankforbindelse mottakeren har.

27.6.2005 Einar Fjørtoft, produktansvarlig AutoPay


Visma Importfiler

Visma Importfilter

Om denne brukerdokumentasjonen

Denne brukerdokumentasjonen omhandler kun de funksjoner som finnes i tilleggsmodulen ”Visma Import-filter”. Videre behandling i Visma Business av importerte data er ikke omtalt i dette dokumentet. Det betyr at du må ha kjennskap til Visma Business for å kunne behandle disse dataene videre inn i Visma Business.

Hvordan komme i gang med Visma Import-filter?

All nødvendig programvare blir installert sammen med standard versjon av Visma Business Regnskapsbyrå. Dersom du ikke kjører denne versjonen av Visma Business, så må du få tilsendt ett distribusjonssett av programvaren for Visma Import-filter.

I Visma Business Regnskapsbyrå finnes det en egen knapp for å starte ”Import-filteret” fra oppstartsvinduet. I tillegg til programvaren må en egen lisensnøkkel fremskaffes. Denne kan du få ved å kontakte din forhandler.

Visma Import-filter ber deg sette inn denne lisensnøkkelen første gang programmet startes.

Dette er ett program som er beregnet på import inn til Visma Business av de aller fleste typer av fakturajournaler og andre typer transaksjoner og aktører som blir levert fra andre systemer. Programmet vil kunne huske oppsettet/definisjonen for de forskjellige import-filene, slik at det er enkelt og lettvint å importere samme type filer på nytt.

I utgangspunktet er det 2 måter man benytter programmet på:

  1. Du skal importere enn fil på ett oppsett som allerede er definert
  2. Du skal importere en fil som ikke er definert

Importere ett definert oppsett

  1. Velg korrekt oppsett. (Første oppsett blir foreslått).
    Merk at merking i ”kun klient” / ”overordnet” / ”Alle” styrer hvilken type oppsett som skal kunne velges i oppsett-feltet.
  2. Sjekk at filen i feltet ”Fil fra system” er korrekt i forhold til den filen som skal importeres.
  3. Trykk på knappen ”Start Import”.

Importere en fil som ikke er definert

Det første du må gjøre er å definere for programmet hvordan filen som skal importeres ser ut.

  1. Velg ”Nytt Oppsett” i oppsett-feltet.
  2. Let frem filen du skal importere ved å trykke knappen med 3 prikker rett bak feltet ”Fil fra system”.
  3. Velg korrekt filinndeling inne i rammen for ”Opprinnelig datatype”.
    (Fast feltbredde / Skilletegn – Tabulator, semikolon …)
  4. (Trykk knappen ”Vis fil” dersom du ikke ser filinnholdet nå)
  5. Definer filformatet ved å velge korrekte verdier i feltene:
    - Tekstkvalifikator (Benyttes dersom tekst er omgitt av eksempelvis tegnet ”)
    - Tusenskilletegn
    - Antall desimaler (Flytende bør kunne velges dersom filen inneholder
    desimalskilletegn)
    - Desimalskilletegn
    - Datoformat
    - Startlinje (Er normalt 1 dersom her ikke er noen overskrift)
    - Filopprinnelse (Er normalt ”Windows (ANSI)”)
  6. Velg hvilket filnavn som den filtrerte filen skal legges på i feltet ”Fil til Visma”
  7. Dersom filen er av ”fast bredde”-format, så må du nå manuelt sette inn feltskillestreker i aktuelle posisjoner ved å klikke med musen på aktuelle posisjoner i filinnholdet som vises nederst i programmet.

Du er nå klar til å definere hvilke felter som skal importeres.

  1. Velg korrekt Visma-tabell i feltet ”Importer til tabell”. (For eksempel ”Bilag”).
  2. Trekk deretter kolonneoverskrifter fra listeboksen nedenfor over til korrekt kolonne i den viste filen. (pek, trykk ned venstre museknapp, dra bort til korrekt kolonne, slipp museknappen). Overskriften skal nå legge seg over riktig kolonne.
    (Høyreklikk i kolonnen for å se hele overskriftsnavnet).
  3. Fortsett med dette til alle nødvendige overskrifter er definerte
  4. Du kan trekke feltet ”-” (minus) over en kolonneoverskrift dersom du ønsker å viske den bort.
  5. Trykk knappen ”Lagre oppsett” når du er ferdig
    MERK AT OPPSETTET ALLTID MÅ LAGRES FØR ENDRINGER BLIR GYLDIGE ! (Det er kun det som er lagret som blir benyttet når knappen ”Start IMPORT” trykkes …)
    (Lagre normalt på klientnivå. Det er kun dersom du ønsker å ta vare på oppsettet som en mal for andre klienter at det er aktuelt å lagre dette overordnet).
  6. Trykk knappen ”Start IMPORT” for å importere.

Generelt

Dersom ikke felter for avgiftskoder er fylt ut (eller at de ikke har noen verdi), så vil programmet hente disse verdiene fra Visma Business sin kontoplan. (I tillegg til verdier for kontoklasse og omsetningsklasse).

Dersom filen inneholder kun en konto-kolonne og en beløps-kolonne så føres positive beløp til DEBET og negative beløp til KREDIT.

Ansvarsenheter settes inn med det navn de har fått i Visma Business. (Mao. Så må de være satt opp og definert i Visma Business før man starter import via Import-filter programmet).

Dersom ikke bilagsart er angitt i filen, benyttes den som er angitt for definisjonen. (Dersom kun ”Bilagsart H.bok” er utfylt, så benyttes denne på alle typer transaksjoner).

Overskriften ”Bilagsnr=Fakturanr” betyr at fakturanummer settes lik bilagsnummeret for alle reskontroposter.

Avanserte muligheter

Noen ganger kommer du borti filer som ikke helt rett frem lar seg importere så enkelt som beskrevet ovenfor. Dette kan skyldes mange ting, men vi vil tro at det meste vil kunne løses ved hjelp av mulighetene vi skisserer nedenfor.

A. Filen inneholder både reskontro-opplysninger og transaksjoner på samme linjer
Dette løses ved å lage 2 definisjoner/oppsett. Lag først ett som importerer reskontroopplysningene, og deretter ett som tar for seg transaksjonsopplysningene. Deretter henviser du til det første oppsettet i feltet ”Importer først”. (Her kan man i teorien ha en lang rekke med henvisninger – filen man viser til peker på en annen ”Importer først” osv.).

Programmet vil utføre alle ”Importer først” henvisningene før det starter på det valgte oppsettet.

B. Momskodene stemmer ikke
Her kan man hake av i boksen ”MVA konv.”, og deretter trykke knappen ”Konv.Tabell”.

Man får da opp ett vindu hvor man for hver avgiftskode i filen kan definere en annen avgiftskode som skal settes inn i import-filen.

(Trykk ”SØK” for at programmet skal hente alle avgiftskoder fra filen).
(Fra versjon 2 av programmet kan for så vidt regler benyttes også for MVA-konvertering. Merk her at regler oversettes med en gang inn i det viste filinnholdet, mens MVA-konverteringen først utføres etter at kanppen ”Start IMPORT” er trykket).

C. Filen er ukonsekvent, sær , vanskelig å definere
En del filer vil ikke kunne la seg importere uten videre. (Mammut, Vega m.fl.). Dette kan skyldes at for eksempel kontonummeret befinner seg flere steder i filen, eller at noen av verdiene ikke passer med verdiene som benyttes i Visma Business.

For å takle slike filer har vi innført mulighetene for å definere regler.
Med regler kan man tilpasse og justere filen som skal importeres til å bli akkurat slik vi vil ha den.

Reglene har 2 hovedfunksjoner:

  1. Gjøre ett utvalg på hvilke linjer som skal importeres

    A. Hopp over linjer
    B. Behandle kun linjer
  2. Endre verdier i filen før import

    C. Sett inn verdi

Reglene kan nå benyttes til å flytte kontonummer inn i samme kolonne, til å variere bilagsart i forhold til ordinær faktura eller kreditnota, til å konvertere kontonummer for å nevne noen eksempler. Her er det i utgangspunktet kun fantasien som setter begrensninger på hva dette kan benyttes til. Som eksempel følger her noen regler satt opp for import MAMMUT-filen vist tidligere:

Det finnes noen spesial-verdier som kan settes inn i ”Verdi”-feltene:

<Teller=100> En teller startes, med startverdi lik 100

<Teller=Teller> Teller settes lik forrige linjes teller

I eksemplet over starter vi en bilagsnummer teller på 1000, øker den for hvert reskontronummer vi finner – samt beholder samme verdi som forrige gang når vi finner linjer som har hovedbokskontoer. (Bilagsnummer start blir ikke oppdatert, slik at her må man evt. justere reglene mellom hver kjøring).

Merk også at man må være bevisste på valget ”numerisk”. Numerisk betyr at sammenligningen foregår som tall. Dersom dette ikke er avmerket foregår sammenligningen som bokstaver, noe som blant annet betyr at verdien ”10001” er mindre enn ”9999” fordi første sifferet ”1” er mindre enn ”9”.

Verdier som endres farves blått i filvisningen, mens linjer som blir utelatt farves rødt. (Forutsetter at regelvisning i farver er valgt i oppsetts-menyen).

Oppsett

Første gang programmet startes vil du få opp ett vindu hvor du blir bedt om å sette inn en lisensnøkkel. Lisensnøkkelen kan inneholde en begrensning på antall klienter du kan kjøre import for.

Auto-Vis fil | Filinnholdet vises frem automatisk. Dette er standard. (Jobber du med store filer kan det være ønskelig å slå av denne. Du må da trykke knappen ”Vis fil” hver gang du ønsker å oppdatere filinnholdet).
Vindu alltid topp | Vil du være sikker på at du alltid får opp importvinduet foran Visma Business, så kan dette valget hakes av. Vi anbefaler imidlertid at dette ikke er avmerket, da man slipper at vinduet blir i ”veien” for andre programmer og vinduer.
Regelvisning i farver | Normalt er dette valgt. Dette betyr at endrede verdier på grunn av regler blir farvet blått, og at linjer som ikke vil bli behandlet pga. regler vil bli farvet røde. (Merk at dette IKKE gjelder for MVA-konvertering, da denne konverteringen først foregår etter at knappen ”start IMPORT” er trykket).
Importer til Visma | Her kan du merke av for at du ønsker at programmet skal importere den ferdige import-filen rett inn i Visma Business. Merk at dette skjer ved at Vbus.exe kalles opp med diverse parametre. (Passordet kan lagres kryptert i dette programmet. Det vil da foreslås neste gang under forutsetning av at samme bruker starter import-programmet).
Sett filområde | Her bestemmer du hvilket standard filområde som skal benyttes. (Dvs. hvor oppsett/definisjonsfilene skal ligge). Vi anbefaler at importfiler legges på kataloger under dette området igjen.
Ny lisensnøkkel | Dette valget gir deg muligheter for å sette inn lisensnøkkel på nytt.


ConvertX Sverige

Elektronisk betalningsförmedling - ConvertX

Installation

Convert X är modulen för betalningsförmedling i Visma Business. Modulen läser information från ett flertal olika tabeller för att sedan skapa betalningsfiler som sedan kan skickas till BankGirot, PlusGirot och Sparbanken.

OBS: Notera att version 4.50 eller senare krävs för att kunna köra Convert X.

Installation på server

För att kunna installera ConvertX på servern krävs att .NET är installerat. Detta pga att applikationen Convert X är skriven i .NET.

Ni kan endast installera ConvertX underförutsättning att Ni loggar in i Visma med en ODBC källa som använder SQL Server verifiering och inte Windows NT verifiering.

Detta gäller endast vid installation.

XB_01

Installation av Convert X

Börja med att installera ConvertX med hjälp av installationsfilen.

XB_02

Om du redan har installerat ConvertX, frågar programmet om det är ok att avinstallera först, innan det återinstalleras. Vi rekommenderar att du avinstallerar din tidigare version av ConvertX, innan du uppgraderar till en senare version.

Välj var du vill installera programmet. Notera att denna "sökväg" bör vara i UNC-format om du önskar att använda den i en inställning för Client-Server. Exempelvis "\\db1\Business\". Notera också att ConvertX katalogen läggs till automatiskt som en underkatalog till den sökväg som har angivits.

Installationsprogrammet installerar ConvertX med tillhörande "registry settings". "Registry settings" lagras i en egen fil " ConvertX.reg" och kan användas för att sätta upp klienter/företag. Installationen resulterar i att tre genvägar skapas för att a) installera klientmaskiner, b) skapa registerfilen på nytt, c) konvertera information från en gammal version av Convert 5.5 till ConvertX.

ClientSetup

XB_03

Körs från kommandolinjen som: ClientSetup.exe.

Används för att installera ConvertX på en klientmaskin. Efter färdig installation på servern körs detta program på klienten. Då uppdateras klientens register med de rätta inställningarna. Det är viktigt att ConvertX installeras med en sökväg som är tillgänglig för alla klienter (helst UNC-sökväg). Detta för att denna sökväg används av klienten när programmet startas. Observera att detta inte är nödvändigt om man bara installerar programmet på en "stand alone" maskin (d.v.s. server och klient på samma maskin).

Convert "Old" Setup

XB_04

Körs från kommandolinjen som: ClientSetup.exe/ConvertSetup.

Används för att konvertera en setup.ini fil från det gamla systemet till nya ConvertX.

Konverteringsprogrammet vill så länge som möjligt ta vara på sökvägar, parameterinställningar o.s.v. ConvertOldSetup skriver över de existerande inställningarna. Därför rekommenderar vi att köra rätt installation, innan man börjar sätta upp ConvertX. Man bör se över de inställningarna som är konverterade innan man börjar använda ConvertX.

ServerInit

XB_05

Körs från kommandolinjen som: ClientSetup.exe/ServerInit

Används för att skapa ConvertX.reg dvs registerfilen skapas på nytt. Bör köras från den maskin som har de rätta registerinställningarna. Vanligtvis är programmet installerat på servern. Genom att göra redigeringar i denna fil, kan ClientSetup-en köras på nytt och skriva över existerande inställningar.

Parametrar för ClientSetup programmet
ServerInit | Startar programmet i "ServerInit mode" (se ovan).
ConvertSetup | Startar konvertering av setup.ini från Convert 5.5.
Override | Används om ClientSetup ska scriptas, skriver alltid över de existerande inställningarna. Till exempel: ClientSetup.exe /ServerInit /Override /Silent skriver över existerande registerfil.
Silent | Används om ClientSetup-en ska "scriptas". ClientSetup-en visar då inga dialoger under installationen, utan lägger in ett antal fördefinierade värden under Setup-en.
ASP | Används om ClientSetup ska "scriptas" på en ASP-lösning.


@Txt (Lang, TxtTp, TxtNo, Txt)

"47" "131" "14" "Kjøp/salg av varer"
"47" "131" "26" "Leie"
"47" "131" "29" "Annet kjøp/salg av tjenester"
"47" "131" "31" "Renter"
"47" "131" "35" "Utbytte"
"47" "131" "38" "Annen kapitalavkastning"
"47" "131" "41" "Kjøp/salg av fast eiendom og aktiverte rettigheter i utlandet"
"47" "131" "43" "Direkteinvestering i aksjer mm."
"47" "131" "45" "Direkteinvestering i annen kapital"
"47" "131" "51" "Porteføljeinvestering i aksjer og verdipapirfondsandeler"
"47" "131" "52" "Porteføljeinvestering i obligasjoner og sertifikater"
"47" "131" "53" "Porteføljeinvestering i derivater"
"47" "131" "71" "Livsforsikring/pensjon"
"47" "131" "79" "Andre finansinvesteringer"
"47" "131" "81" "Lønn"
"47" "131" "82" "Arv, gave med mere"


Mal

Tekst


Betalingsformidling via ConvertX

Visma Business - Betalingsformidling via ConvertX

Betalingsidentifikasjon/melding til mottaker

Registrering uten KID

  • Feltet ”Ekstratekst” kommer ikke med som melding til mottaker
  • Feltet ”Referanse” kommer ikke med som melding til mottaker
  • Feltet ”Fakturanr” kommer med over som melding til mottaker

Registrering med KID:

  • Kun KID blir sendt som betalingsidentifikasjon.
  • Feltet ”Fakturanr.” kommer ikke med over som melding til mottaker.

Tabellen Bankpartner (Tabeller – Regnskap – Betalingsformidling)

Opprett en bankpartner per belastningskonto/valutakonto. For å slippe å lage et betalingsforslag pr. valuta kan du angi Bankpartnernr. på leverandøren. Når du da lager betalingsforslag setter du hake i parameteret ”Benytt bankpartner fra leverandør (kunde)”. Husk å sette opp ”Bruk database forbindelse for ZData” i feltet ”EBF behandling” for at ConvertX skal benyttes.

Tabellen Bedriftsopplysninger (Tabeller – Felles – Faste opplysninger)

Feltet ”Regnskapsbehandling”

Forklaring på disse parameterene i feltet ”Regnskapsbehandling” i tabellen Bedriftsopplysninger:

”Tillat negative betalinger” = Medfører at det kan remitteres poster som totalt gir negativ betaling. Eksempel: Kreditnota som overstiger faktura. Dette er aktuelt i de tilfeller hvor banken overvåker og motregner kreditnota.

”Ingen debetsaldo ved remittering” = Hvis du krysser av i dette feltet sjekker Visma Business at utbetaling ikke gir debetsaldo på en leverandør. Programmet godtar ikke overføring av transaksjoner til betalingsforslag som medfører at saldoen på leverandøren gir debetsaldo. Det blir gjort kontroll mot betalingslinjer med status 1, 2, 3, 5 og utgående balanse på leverandøren. Betalingstransaksjoner som enda ikke er bokført blir også behandlet. Dette blir kontrollert mot saldo på leverandøren i tabellen Leverandørsaldoer.

”Anvend betalingsbetingelser på kreditnotaer” = Forfallsdato og planlagt betalingsdato blir satt på kreditnota.

”Ikke planlagt betalingsdato på kreditnotaer” = Planlagt betalingsdato blir ikke satt på kreditnota. Ved remittering vil da bilagsdato bli brukt.

Merk: Parametrene ”Anvend betalingsbetingelser på kreditnotaer” og ”Ikke planlagt betalingsdato på kreditnotaer” er gjensidig utelukkende slik at du bare kan velge en av disse.

Bet. frie dager

Her kan du sette hake ved de dagene som er betalingsfrie. Nederst i dialogen kan du bestemme om planlagt betalingsdato skal flyttes til en tidligere dato.

Valg i denne dialogen vil kun bli tatt hensyn til når du bruker en bilagsart hvor det i Bilagsartbehandling er satt hake i Flytt planlagt betalingsdato til arb.dag ved registrering av faktura.

Konto for provisjon / bankgebyr

Hovedbokskonto for provisjon/bankgebyr må du registrere i tabellen Bankpartner (Hovedb. k. gebyr) eller Valuta (Remit. geb. konto). Dersom konto ikke er angitt, som beskrevet, ved generering av bilag for betaling med provisjon / gebyr vil dette havne på feilkonto (9999).

Kreditnota og remittering

  • Kreditnotaen kan aldri være større enn betalingen ved remittering.
  • Kreditnotaen og betalingen kan aldri være lik ved remittering.
  • Begge disse forekomstene vil bli avvist av Z-Data.

Dersom du skal remittere en kreditnota, må kreditnotaen være mindre enn betalingen og feltet ”Planlagt bet. Dato” må være likt på betalingen og kreditotaen.

Du trenger ikke sette opp noe i verken Bankpartnertabellen eller Bedriftsopplysninger for å få til dette.

DK - Melding til Mottaker (kort og lang Advi)

I Bankpartnertabellen og feltet ”EBF behandling” har vi parameteret ”Kort melding til mottaker”. Oppdater til siste versjon av ConvertX (1.4.0.9) fra vår ZData sin hjemmeside.

Det er her gjort noen små endringer i formatene Unitel og DanskeBank.

Generelt gjelder følgende:
Meddelelsestype skal være Langadvis (dette er også default på formatet - kort advis brukes til blant annet lønn og pensjoner).

Dersom du oppretter samletranser skal du benytte tekstkode 100 i felt 51 og i felt 53 legges avsenders navn. De enkelte fakturanr. vil da komme i felt 23-26 og eventuelt felt 54-90. Dette har vi fått oppgitt av banken.

Felt 51 = Tekstkode (3 langt) settes slik:

1) Meddelelsestype = Straks advis medfører at felt 51 = tomt

2) Meddelelse = Lang advis medfører:

Dersom samletx og feltet Varslingskode (NtfCd) er ulik tomt eller 0 medfører at felt 51 = Varslingskode

Dersom samletx og feltet Varslingskode (NtfCd) er tomt eller 0 medfører at felt 51 = 100 = Fritekst (settes altså av ConvertX som default)

Dersom ikke samletx og feltet Varslingskode (NtfCd) er ulik tomt eller 0 medfører at felt 51 = Varslingskode

Dersom ikke samletx og feltet Varslingskode (NtfCd) er tomt eller 0 medfører at felt 51 = 160 = Faktura (settes altså av ConvertX som default)

Felt 53 = Kort fri advis (20 langt) settes slik:

1) Meddelelsestype = Starks advis eller Kort meddelelse medfører at felt 53 = tomt

2) Meddelelsestype = Lang advis medfører:

  • Dersom feltet Varslingskode = 100 eller ConvertX har satt felt 51 til 100 (alternativ b for felt 51) og feltet Varslingstekst (NtfTxt) ikke er tom, medfører at felt 53 = Varslingstekst
  • Dersom feltet Varslingskode = 100 eller ConvertX har satt felt 51 til 100 (alternativ b for felt 51) og feltet Varslingstekst (NtfTxt) er tom, medfører at felt 53 = Bedriftsnavn
  • Dersom feltet Varslingskode = 160 eller ConvertX har satt felt 51 til 160 (alternativ d for felt 51) og feltet Varslingstekst (NtfTxt) ikke er tom, medfører at felt 53 = Varslingstekst
  • Dersom feltet Varslingskode = 160 eller ConvertX har satt felt 51 til 160 (alternativ d for felt 51) og feltet Varslingstekst (NtfTxt) er tom, medfører at felt 53 = Fakturanr (InvoNo)

Ellers settes felt 53 = tomt.

Felt 23-26 = Meddelelse line 1 til 4 (4 x 35 langt) settes slik:

Dersom meddelelsestype = lang advis eller straks advis, fylles feltene med innholdet fra feltet Tekstlinje (TxtLn) og dersom dette feltet ikke allerede inneholder fakturanr (InvoNo) legges også dette til.

Ellers settes feltene tomme.

Felt 54-90 = Lang advis tekst, meddelelseslinje 5 til 41 (37 x 35 langt) settes slik:

Dersom meddelelsestype = lang advis eller straks advis og feltet Tekstlinje (TxtLn) +/- et eventuelt fakturanr (InvoNo) er lengre enn felt 23-26, legges resten av meldingen her

Ellers settes feltene tomme.

Alt her i henhold til tilbakemeldinger fra Nordea.

DK Samletranser for danske formater

Dersom parameteren ”Samletranser” skal benyttes på danske formater...

... forutsetter det at krysset for ”Samletransaksjoner” i feltet ”EBF behandling” i Bankpartnertabellen er utfylt:

DK Egenreference

Innstilling for danske formater for hva som skal være tekst på avsenders kontoutdrag. Denne innstilling finner du under parametre for formatet som er valgt på ”Fil til bank”.

Samling av betalingstransaksjoner (ved kreditnota)

Telepay 2.0 tillater remittering av kreditnotaer etter spesielle vilkår. Felles er at telepay ikke tillater kreditnotaer i bunter der summen er 0 eller negativ. Telepay bunter sammen såkalte strukturerte og ustrukturerte transaksjoner på betalingsdato;

ustrukturerte transaksjoner er transaksjoner som ikke har KID eller fakturanummer. Dvs. transaksjoner som skrives med melding. (NB! enkelte funksjoner i Visma Business har den effekten at transaksjoner behandles som med melding, selv om den har oppgitt KID og/eller fakturanummer).

strukturerte transaksjoner er transaksjoner som har enten KID eller fakturanummer oppgitt.

Ustrukturerte transaksjoner på samme dato til samme mottaker vil havne i en felles bunt, og alle strukturerte transaksjoner på samme dato og til samme mottaker vil havne i en felles bunt. Det vil si at det buntes strukturerte og ustrukturerte transaksjoner hver for seg. Husk at buntene MÅ ha positiv sum, derfor må en kreditnota alltid kunne buntes sammen med en eller flere betalinger som gjør at totalsummen blir positiv (det holder ikke at den blir 0).

ConvertX vil prøve å flytte betalinger på dato for å, om mulig, lage bunter som er positive (dersom ConvertX flytter en transaksjon på dato vil du man få melding om dette). Om ConvertX ikke klarer å lage en positiv bunt vil alle transaksjoner til mottakeren avvises.

Husk altså at ustrukturerte transaksjoner buntes for seg og strukturerte transaksjoner buntes for seg. For å gjøre en transaksjon/kreditnota strukturert, kan du sette på KID eller fakturanummer, den vil så kunne buntes sammen med betalinger med KID (anbefalt). Alternativt kan man sende alt ustrukturert ved å slette KID på betalinger og kreditnota.

Merk! I ZData er fortegnsstillingen snudd, slik at når det er snakk om positiv bunt vil det si at leverandøren har penger tilgode.

Betalingsmottaker avvises dersom:

1. Det er feil på en kreditnota til mottakeren.

2. Det er negativ sum til mottakeren. Du vil få følgende feilmelding:
"Sum oppdrag er negativ (Ustrukturert)", eller "Sum oppdrag er negativ (Strukturert)" i feltet betalingsreturkode.

Denne informasjonen finner du her:

http://www.zdata.no/ConvertXVB_Help/Norwegian/Visma_ConvertX_brukerveiledning/TelePay_2_0.htm

Avtalegiro

Ved bruk av avtalegiro og remittering samtidig via ConvertX må det opprettes egen bankprofil (bank) for avtalegiro i ”Oppsett av Converter”. Årsaken til at det må være en egen bankprofil for avtalegiro er at avtalegiro transer blir tatt med i fil for remittering også hvis samme bankprofil blir brukt. Ved eksport av avtalegiro er det viktig at konto blir koblet til rett bankprofil.

Import av avtaler kan fortsatt ligge på samme bankprofil som remittering.

Eksempel

Telepay 2.01

Bankene har innført en ny versjon av sitt betalingsformat (Telepay 2) og dette har følgende praktiske konsekvenser for deg som bruker:

Innlandsremittering

Nå kan du sende både betalinger med KID og kreditnotaer til samme leverandør uten først å slette KID på fakturaen for å få trukket fra kreditnotaen. Informasjon som blir registrert på betalingslinjene i feltet KID-kode (SQL navn CID) og Fakturanummer (SQL navn InvoiceNo) blir nå sendt i samme overføring til leverandøren. Se Telepay 2.0 informasjonen for ytterligere informasjon.

Utlandsremittering

Bruk av ny EBF krever vedlikehold grunndata leverandører.

Tidligere har SwiftAdresse1 vært brukt til å legge inn bankens SortingCode/FW-code. Denne verdien skal nå legges i et eget felt som heter Bankfilial (SQL feltnavn Branch). (Hvis ikke dette feltet finnes hentes det frem). SwiftAdresse1 skal inneholde Bankens navn.

Viktige felter å fylle ut på leverandøren:

Felt i Visma | Felt i Banken
Bankfilial | SortingCode/Fedwire
SwiftCode | SwiftCode
SwiftAdresse1 | Bankens navn
SwiftAdresse2, 3, 4 | Bankens adresse(r)

Kontroll av betalingsdata utland

Banken har også endret kravet til hvordan utlandsbetalinger må utfylles. Betalinger som ikke oppfyller kravet vil enten bli avvist eller bli behandlet manuelt av banken, noe som de fleste banker tar seg godt betalt for. Ny versjon av EBF utfører test mot de fleste krav banker har før betalingene blir sendt til banken. Test som gjennomføres på utlandsbetalinger er følgende:

Betalinger som blir markert som Feil, og må rettes før de kan sendes.

Feilmelding | Felter i Visma (SQL navn i parantes)
Ikke utfylt valutakode | Fakturavalutakode = ISO kode (ISO) fra Betalingslinjer eller Belastes valutanr (PmtCur) fra Betalingslinjer
Leverandørens Navn, adresse eller landkode er ikke utfylt. | Navn (Nm) på leverandør fra Aktører, Adresselinje1 (Ad1) på leverandør fra Aktører, Landnr (Ctry) på leverandør fra Aktører.
Feil utfylt IBAN nummer (leverandørens bankkonto). | Bankkontor (BGiro) på leverandør fra Aktør.
SwiftCode og SwiftAdresser er blank | Swiftkode (SwftCd) på leverandør fra Aktør, Swiftadresse1 (SwftAd1) på leverandør fra Aktør, Swiftadresse2 (SwftAd2) på leverandør fra Aktør, Swiftadresse3 (SwftAd3) på leverandør fra Aktør og Swiftadresse4 (SwftAd4) på leverandør fra Aktør.

Betalinger blir markert som Advarsel, og bør rettes før de kan sendes.

Advarsel | Felter i Visma (SQL navn i parantes)
Feil eller ikke oppgitt SwiftCode. | Swiftkode (SwftCd) på leverandør fra Aktør.
Ikke utfylt bankartkode. | Dekl.kode fra Betalingslinjer (DeclCD)
Ikke utfylt meldingsfelt til Norges Bank. InfoBank | Deklarasjonstekst fra Betalingslinjer (DeclTxt).

Denne informasjonen finner du her:

http://www.zdata.no/ConvertXVB_Help/Norwegian/Visma_ConvertX_brukerveiledning/Changes_from_Convert_5_5.htm

Remittering til Plusgiro (Postgiro)

Dersom du ønsker å remittere til Plusgiro (ofte svenske kunder), må du huske på å sette hake i parameteret ”Bruk postgirokonto ved remittering – sv” i feltet ”Lev.pref.”:

Feltet blir brukt i svensk remittering av ZData ConvertX. Plusgiro (Postgiro) blir også brukt på andre formater, derfor må du ikke krysse av i dette feltet hvis du remitterer til andre bankformater enn de svenske.

Dersom du har både Bankgironr. og Plusgironr. (postgironr.) liggende på aktøren, benyttes Bankkontonr. dersom det ikke er hake i dette parameteret.

Merk! Ved betalingsformat Bankgiro der leverandøren har samme Bankgironr. som Plusgironr., tolker ConvertX det som et Plusgironr. selv om det er valgt betalingsformat Bankgiro. Du får da ikke sendt filen som bankgirobetaling.

Dette er løst i ConvertX versjon 1.4.0.8:

For Plusgirot gjelder nå følgende:

Ved remittering til leverandør som ikke har Plusgirotkonto, men en 10-siffret personkonto i Nordea skal dette kontonummer plasseres i feltet Postgiro på leverandøren i Visma Business.

Dette fordi girering til plusgirotkonto og kontoinnsetting til 10-siffret personkonto i Nordea behandles likt.

Utbetalingsanvisning

Dersom leverandøren hverken har Plusgironr. eller Bankgironr. liggende på seg i Aktørtabellen, så vil den få tilsendt en utbetalingsanvisning fra banken dersom du har tatt vekk krysset for ”Remit.hvis gironr.” i tabellen Bedriftsopplysninger:

Betalingen kommer med i Betalingsforslag på vanlig måte, og filen til banken ser ca. slik ut:

Remittering i Valuta

Bilag for betaling i valuta

Ved remittering av faktura i valuta, vil alltid bilag for betalingen bli ført med samme valutakurs som på fakturaen. Dette for at reskontropostene (faktura og betaling) skal gå i null både for beløp i valuta og i egen valuta. Verdien på fakturaen blir målt mot belastet beløp på betalingslinjen og differransen vil utgjøre kursdifferransen (agio/disagio). Provisjon blir ført på konto for bankgebyr, angitt på bankpartner eller valuta, og lagt til belastet beløp slik at dette samlet blir ført ut av konto for bank.

Dekl.kode og Dekl. Tekst

ConvertX, versjon 1.4.0.5 eller nyere.

Versjon 4.60.2 av Visma Business.

I Teksttabellen må du legge inn de ulike Deklareringskodene (Dekl.kode). Disse skal registreres på Teksttype lik 131.

Standard Dekl.koder er:

Deretter legger du inn ønsket ”Dekl.kode” på Leverandøren:

Dekl. koden som du legger på Leverandøren vil da bli hentet i Bilagsregistreringen og til Bilagslinjene ved registrering.

Bunten oppdateres.

Åpne poster vil nå se slik ut:

Du lager betalingsforslag på samme måte som tidligere...

Dersom det er Deklarasjonskode på betalingslinjen blir det sjekket om det er registrert Deklarasjonstekst på betalingslinjen. Dersom det er registrert Deklarasjonstekst på betalingslinjen blir denne brukt. Ellers blir Deklarasjonsteksten hentet fra Teksttabellen i henhold til Deklarasjonskode ved eksport av betalinger.

Når du deretter legger ut data, kan du åpne filen som skal sendes til banken å se at "Dekl.kode" ligger der med korrekt Deklarasjonstekst, hentet fra betalingslinjen eller teksttabellen.

Eksempel på fil til banken:

OCR retur
Det er nå mulig å importere både OCR retur og avregning av betalinger i samme fil via ConvertX, siden begge blir lest via formatet ”AutoDetect”.

Dialog for betalingsforslag

Dersom det kun er registrert en bankpartner i tabellen bankpartnere vil denne bli foreslått i feltet Bankpartner.

Er det registrert flere bankpartnere vil det ikke bli foreslått bankpartner i dialogen. Du må velge hvilken bankpartner som skal bli brukt.

Alternativt kan du registrere bankpartner på leverandør (aktør) og i dialogen sette hake på ”Benytt bankpartner fra leverandør (kunde)”. Det vil da bli generert betalinger i henhold til bankpartnere registrert på leverandører som er utvalgt ved generering av betalingsforslag.

Hvis du samtidig velger bankpartner i dialogen kan du også sette hake i ”Produser betalinger kun for valgt bankpartner”.

Overvåking av kreditnotaer

For å stille inn hvor mange dager banken skal overvåke en kreditnota før de sender den tilbake settes opp i Visma Business. ( I tidligere versjoner satt man dette i Converteren).

Dette hentes ikke lenger fra ConvertX, men i fra Visma Business:

Det kan settes på 2 måter:

  • Fra feltet Kreditnota forfallsdager (CNtDy) på Betalingslinjene
  • Fra feltet Std. kreditnota forfallsdager (CNtDy) på Bankpartner

Trusted Connection

ConvertX kan kjøre med Trusted Connection og SQL Autentisering.

Dersom Trusted Connection skal benyttes, fjerner du ”Login” og ”Passord” i oppsettet i ConvertX, men har hake i ”Overstyr innstillinger fra Visma Business” og angir riktig ”Server”.

(Oppsett – Oppsett og fane Database)

Dersom SQL Autentisering skal benyttes, setter du også hake i ”Overstyr innstillinger fra Visma Business” og angir riktig ”Server”. I tillegg må du legge inn ”Login” = sa og ”Passord” = passordet på sa brukeren

Dersom du ønsker å benytte en annen bruker enn sa, angir du denne brukeren under ”Login” og tilhørende Passord.


CREATE TRIGGER [aktivitet] ON [dbo].[Agr]
FOR INSERT, UPDATE
AS
Update agr
set agr.ordno = R7.Inf8 from agr, r7
where R7.RNo = Agr.R7

update agr
set agr.Prodno = R3.gr12 from agr, r3
where R3.RNo = Agr.R3

update agr
set agr.agrproc = prod.agrproc from agr, prod
where Prod.Prodno = Agr.prodno

CREATE TRIGGER [overf] ON [dbo].[OrdLn]
FOR INSERT, UPDATE
AS
Update ordln
set ordln.TrfOrdno = R7.Inf8 from ordln, r7
where R7.RNo = ordln.R7


Visma Business eInvoice

To use the Visma Business eInvoice you have to set a few parameters, use a special form and a window to write from.

Settings in Visma Business

The table ’E-Document info’ is found under Tables \ Order/logistic \ Base data.

Settings:

Message type => 1 (Invoice)

From Serv prov ID => a unique ID of the sender in the segment <SenderInfo>

To Serv prov ID => a unique ID of the sender in the segment <ReceiverInfo>

Write to file => the location of the file

Read from file => the location of the imp file to use

Run Status => 1= Normal production, 0=Test only

Segments

There are three different types of segments in the production of the Visma Business e-invoice.

  1. eInvoiceEnvelope and eInvoice are two segments written by the system. The choice of field can’t be changed. You will find a description of these fields in “Specification of the Visma Business eInvoice XML format.doc”.
  2. The tags in the Invoice segment (the actual invoice) connected to the order head are defined in the form and ‘imp’-file. You will find a description of these fields in “XMLformat - Business implementation.doc”.
  3. The tags in the Invoice segment (the actual invoice) connected to the order lines are defined in the ‘imp’-file through the External ID of the field. You will find a description of these fields in “XMLformat - Business implementation.doc”.

‘Imp’-file

The Visma Business eInvoice uses the normal ‘imp’-file format in Visma Business, except for the creation of ‘tags’.

The order head tags are created in the Form elements. There are two new fields – XML level and XML tag. Only XML tag is in use in 4.40.1 version.

The XML tag connect the ‘imp’-file to the Text/parameter in Visma Business. This is where you choose which field to connect to.

The Visma Business XML tag is the first parameter in the ‘imp’-file. Check the invoice number marked above and bold below –

a,1,;,1,,,,,,,,,,,

b,OrderHead,1,,1,,,,,,,,,,

c,RecType,1,1,0,,,,,,,,,S,

c,OrderType,2,3,,,OrderType,,,,,,,S,

c,InvoiceNumber,3,20,,,InvoiceNumber,,,,,,,S,

The sixth parameter is the name of the tag in the final eInvoice XML file.

These parameters can be different.

c,Supplier,54,20,,,,,,,,,,X,

c,SupplierName,55,40,,,Name,,,,,,,S,

c,SupplierAddress1,56,40,,,Address1,,,,,,,S,

c,SupplierAddress2,57,40,,,Address2,,,,,,,S,

c,SupplierAddress3,58,40,,,Address3,,,,,,,S,

c,SupplierPostCode,59,10,,,PostCode,,,,,,,S,

The example above is taken from the Supplier segment. There is a difference between the Visma Business XML tag – SupplierName - and the final XML tag – Name. The reason is that the final XML tag – Name – will appear five times in the XML file. Visma Business has to see a difference between these tags when creating the file and connecting the Visma Business XML tag to the correct Text/parameter in the form. In these cases, where the final XML tag will appear more then once, the Visma Business XML tag will be named as Segment + final XML tag.

The order lines are produced in a different way. They are not registered in the form. They have to be presented in the view from where you start the printing job.

In the ‘imp’-file they are defined by the External number of the field.

c,RecType,1,1,1,0,,,,,,,,S,

c,XML_NoOfOrderLines,2,20,,,OrderLineCount,,,,,,,S,

c,OrderLine,3,20,,,,,,,,,,X,

c,2952,4,32,,,OrderNumber,,,,,,,I,

c,3028,5,32,,,OrderLineNumber,,,,,,,I,

c,2953,6,32,,,OriginalLineNumber,,,,,,,I,

New ‘imp’-file macro

There are some fields that has to be calculated on the order line. They are the new XML macros.

Ordelines -

XML_NoOfOrderLines => Total number of order lines (see example above)

XML_AmountPrUnit => Discount amount per unit

XML_Amount => Discount amount

XML_Percentage => Discount percantage

XML_VATPercent => VAT percantage

XML_VATBasisAmount => VAT basis amount

Segment start and stop

The start and stop of the segment is defined in the ‘imp’-file.

Start => c,Supplier,54,20,,,,,,,,,,X,

Stop => c,/Supplier,67,20,,,,,,,,,,X,

The start line is the name of the segment, and the stop line is a ‘/’ followed by the name. The field type has to be a ‘X’.

Segment VAT

The segment VAT in the order head is a special case. In the form you will find VAT represented 3 times. This is once for every VAT code in Visma Business. It will also have three entries in the ‘imp’-file. If the customer has more than three VAT codes he will have to add them to the form and the ‘imp’-file.

eInvoice Print job

To start an eInvoice print job you will have to have a view where all the order line fields in the ‘imp’-file has to be represented.

Choose your eInvoice form.

In the Order document dialog you have to choose ‘EDocument’.


Visma Business kunnskapsbase

Velkommen til Visma Business Kunnskapsbase

Oppdatert 02. september 2009!

http://visma.no
Copyright © Visma Software ASA